Bienvenido a Digi3D y DigiNG versión 2003.85.0000

Información General

Bienvenido a Digi3D y DigiNG

Digi21 ofrece actualmente diferentes módulos de software y hardware para responder a las necesidades de la restitución fotogramétrica digital. Entre estas aplicaciones se encuentra la Estación Fotogramétrica Digital Digi3D y el sistema de diseño e información cartográfico DigiNG.

La ayuda de Digi3D contiene los siguientes apartados:

  • Instalación del hardware: aquí aprenderás a instalar todo el hardware perteneciente a la estación fotogrametrica digital.
  • Instalación de Digi3D: aquí se explica toda la instalación del software de Digi3D.
  • Comenzando con Digi3D: aquí, además de las explicaciones teóricas hay a una serie de videos explicativos con los que podrás aprender los conceptos básicos para preparar tu equipo y trabajar con Digi3D y DigiNG.
  • Comenzando con DigiNG: en este apartado de la ayuda aprenderás a restituir y editar con DigiNG.
  • Referencia: este apartado de la ayuda está dividido en varias secciones y explica al completo todos los aspectos de Digi3D y DigiNG. Desde explicaciónes detalladas de los menús, Configuraciones, Órdenes existentes hasta formatos de archivo.
  • Programacion: en este tema de la ayuda se explican aspectos relacionados con la programación con DigiNGScript, VisualC++ y Visual Basic.

© 2003 equipo de Digi21.net Todos los derechos reservados.

Fecha de última modificación: 25 de Mayo de 2004


Instalación del Hardware

El Hardware del restituidor digital Digi3D se compone de:

  • 2 Monitores: uno que contiene a la ventana principal de Digi3D, y otro para la visualización estereoscópica (recomendados de 17'' y de 21'' respectivamente).
  • Dispositivos de entrada: puedes tener varios tipos de configuración:
    • Manivelas y pedales.
    • Ratón 3D con varios botones programables.
    • JoyStick de fuerza.
    • JoyPad.
  • Dispositivo de visualización estereoscópica: puede ser estereóscopo, gafas pasivas (ZScreenTM), o gafas activas (CristalEyes o Eye3D).
  • Ordenador: se recomienda una configuración similar a la siguiente:

      Ordenador INTEL PENTIUM IV 1,5 Ghz (socket 478)
      HD 40Gb IDE UDMA 100 7200 rpm
      1GB de memoria RIMM (4x256) PIV
      Tarjeta de video AGPx4 Matrox G450 32MB
      Tarjeta de video PCI GeForce2 MX 32MB
      CD_ROM 52x Teclado , Ratón, Tarjeta de red 3Com 10/100

Hay varias posibles configuraciones del restituidor digital Digi3D, en función del dispositivo de entrada y del dispositivo de visualización estereoscópica seleccionado. Luego puedes tener cualquiera de las siguientes configuraciones:

Dispositivo de Entrada | Dispositivo de visualización estereoscópica
Manivelas y pedales | Estereóscopo
Manivelas y pedales | Gafas pasivas (ZScreenTM)
Manivelas y pedales | Gafas activas (CristalEyes o Eye3D)
Ratón 3D | Estereóscopo
Ratón 3D | Gafas pasivas (ZScreenTM)
Ratón 3D | Gafas activas (CristalEyes o Eye3D)

También es posible la configuración como dispositivo de entrada de un JoyStick de fuerza o un JoyPad.

En los siguientes temas de la ayuda se explica cómo instalar cada componente del restituidor digital Digi3D:

  • Instalación de manivelas y pedales.
  • Instalación del Estereóscopo.
  • Instalación de los monitores.
  • Instalación del Ratón 3D.
  • Instalación de gafas pasivas (ZScreenTM).
  • Instalación de gafas activas (Cristal Eyes).
  • Instalación de gafas activas (Eye3D).
  • Instalación de JoyStick.
  • Instalación de JoyPad.

Fecha de última modificación: lunes, 26 de Agosto de 2002


Instalación de manivelas y pedales

La instalación de estos dispositivos de entrada se explica en los siguientes temas de la ayuda:

  • Instalación de las manivelas.
  • Instalación del pedal de Z.
  • Instalación de los pedales de control.
  • Instalación de la tarjeta de codificadores.

Todos estos dispositivos de entrada se conectan a este cable:

donde los conectores a X, Y, Z están marcados y por lo tanto se pueden identificar. Los conectores a X e Y, corresponden a las manivelas X e Y. El conector a Z corresponde a la rueda de Z.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Instalación de las manivelas

Antes de comenzar con la instalación hay que asegurarse de disponer de todos los elementos necesarios:

  • 2 manivelas.
  • Tornillos para la fijación de las manivelas a las placas, y para la fijación de las placas metálicas a la mesa de trabajo.
  • Abrazaderas para el cableado.
  • Cable de conexión de las manivelas a la tarjeta de codificadores.
  • Juego de llaves.
  • Destornillador.

En primer lugar hemos de ver dónde vamos a situar cada una de las dos manivelas. Lo normal es colocarlas enfrente del monitor de visualización estereoscópico y con una distancia entre ellas de 70 cm. aproximadamente. Y todo ello en una disposición centrada en la mesa de trabajo.

Para colocar la primera manivela hemos de fijar la placa metálica a la mesa por la parte inferior de la misma y en la posición que hayamos dispuesto. Se atornilla dicha placa a la mesa:

y luego fijamos la manivela a la placa metálica como se puede ver en la siguiente imagen, de tal forma que la parte del cableado quede por debajo de la mesa y la parte con el disco en la parte delantera de la mesa.

Posteriormente enroscamos el asa en la parte frontal de la manivela, primero por la parte delantera de forma manual, y después se fija por la parte trasera del disco con la llave correspondiente.

El aspecto que presenta ahora la manivela ahora el siguiente:

El cable que une la tarjeta de codificadores con los dispositivos de entrada se ramifica en un extremo en otros 4 cables, 3 que parecen iguales y un cuarto que se utiliza para los pedales de control. Los 3 que parecen iguales están marcados para saber cuál es el correspondiente a la manivela X, cuál a la manivela Y, y cuál a la rueda de Z.

Normalmente la manivela que se sitúa a la izquierda del operador corresponde a la X, y la manivela que se sitúa a la derecha corresponde a la Y. Lo que debemos hacer es conectar el cable de la tarjeta de codificadores (el que esté marcado con la manivela que estemos colocando) con el cable que sale de la parte posterior de la manivela.

Repetimos el proceso de instalación para la otra manivela. El aspecto una vez colocadas las dos manivelas es el siguiente:

Después colocaremos los cables bien con las abrazaderas, o si nuestra mesa de trabajo posee un estante inferior (como en la imagen) se pueden colocar sobre él los cables de las manivelas.

En el siguiente tema de la ayuda se explica cómo instalar la rueda de Z.

Fecha de última modificación: viernes, 17 de Mayo de 2002


Instalación del pedal de Z

Antes de efectuar la instalación del pedal de las Z debes asegurarte de disponer de:

  • Pedal de Z.
  • Plataforma metálica.

La instalación de la rueda de Z es muy sencilla. Simplemente debes colocar la plataforma en el suelo y debajo de la mesa de trabajo, normalmente en la parte derecha (para poder accionar el pedal con el pie derecho), y colocar después el pedal de Z encima de dicha plataforma. Coloca la rueda de tal forma que el cable que sale de ella quede por la parte posterior, y no moleste al manejar el pedal.

Después conecta el cable que sale de la rueda de las Z con el cable correspondiente de los 4 que salen del cable de la tarjeta de codificadores.

Por último, ayúdate de las abrazaderas para colocar el cable de forma conveniente. Finalmente, el pedal tendrá un aspecto similar al de la siguiente imagen:

En el siguiente tema de la ayuda se explica la instalación de los pedales de control.

Fecha de última modificación: viernes, 19 de Abril de 2002


Instalación de los pedales de control

Antes de iniciar la instalación de los pedales de control asegúrate de disponer:

  • Los 3 pedales, cada uno con un cable. Los tres cables se unen en un mismo conector.
  • Plataforma metálica.

Lo normal es colocar la plataforma en suelo, debajo de la mesa de trabajo y en la parte izquierda para accionar los pedales con el pie izquierdo. Coloca encima de dicha plataforma los pedales, de tal forma que los cables queden por la parte posterior, y así no molestarán cuando se trabaje. Luego une el conector que está al otro extremo con el correspondiente conector que sale del cable de unión a la tarjeta de codificadores.

Una vez conectados los pedales deben tener un aspecto similar al de la siguiente imagen:

En el siguiente tema de la ayuda se explica cómo instalar la tarjeta de codificadores.

Fecha de última modificación: lunes, 20 de Mayo de 2002


Instalación de la tarjeta de codificadores

La tarjeta de codificadores es externa por lo que su instalación es sencilla y no precisa del desmontaje del ordenador. Esta tarjeta es la siguiente:

Esta tarjeta presenta un cable en un extremo y un conector en el otro. En este conector hemos de engancharlo con conector del cable donde están conectados los pedales, las manivelas y la rueda de Z.

El cable que sale de la tarjeta de codificadores se conecta a un puerto serie del ordenador.

Y también se conecta al puerto USB:

Así ya estaría instalada la tarjeta de codificadores.

Fecha de última modificación: viernes, 19 de Abril de 2002


Instalación del Estereóscopo

Antes de comenzar con el montaje del Estereóscopo hay que asegurarse de que disponemos de todos los elementos:

  • Soporte.
  • Brazo.
  • Cuerpo de lentes.
  • Juego de llaves.

En primer lugar se monta el brazo en el soporte. Se trata de introducir el brazo por el hueco que se encuentra en la parte izquierda, al lado del tornillo de presión. Para que quede perfectamente horizontal tumbamos el brazo y el soporte sobre el suelo como se puede ver en la imagen:

y en este postura se aprietan los dos tornillos que sujetarán el brazo al soporte:

Y ya sólo queda introducir el cuerpo de lentes en el brazo por la parte superior, situándolo aproximadamente en el centro de la barra horizontal del brazo, y se aprieta el tornillo de presión del cuerpo de lentes.

Una vez montado el estereóscopo, presenta el siguiente aspecto:

Como ya hemos visto, el estereóscopo consta de varias partes:

  • Brazo: une el soporte con el cuerpo de las lentes. En la parte inferior posee un tornillo de presión para liberar o fijar el brazo. Si el brazo está liberado, se puede girar el brazo para colocarlo a la altura de los ojos o por encima del monitor.
  • Soporte: ofrece estabilidad al estereóscopo. Sobre su parte horizontal se coloca el monitor destinado a la visualización estereoscópica.
  • Cuerpo de las lentes: se puede mover de forma horizontal a lo largo del brazo, y girar alrededor del mismo para colocarlo en la posición adecuada. Posee un tornillo de presión en la parte superior que permite su fijación al soporte. Las lentes son desplazables para ajustarse a la distancia interpupilar del operador. También posee en la parte frontal un elemento de goma que permite apoyar en él la frente de forma cómoda. Dicho elemento se puede colocar en la posición adecuada para cada usuario aflojando los tornillos (2 bolas negras) situados en la parte superior.

Fecha de última modificación: martes, 21 de Mayo de 2002


Instalación de los monitores

Si dispones de estereóscopo, el monitor de visualización estereoscópica se coloca encima de la plataforma del estereóscopo:

Si dispones de gafas pasivas (ZScreen), o de gafas activas (CristalEyes, Eye3D) puedes colocar el monitor donde creas conveniente, aunque generalmente se suele situar en el centro de la mesa de trabajo. Después podemos conectar el monitor a la tarjeta gráfica correspondiente.

Si la tarjeta gráfica dispone de dos entradas, debes conectar el monitor en la número 1.

El otro monitor, en el que se manejará la ventana principal del restituidor digital Digi3D, se puede colocar al lado derecho de la pantalla de visualización estereoscópica.

Y conectamos también este monitor a su tarjeta gráfica.

También conectaremos (en el caso de que no estén ya conectados) el teclado y el ratón, con lo que la parte posterior del ordenador presentará un aspecto parecido al siguiente:

Fecha de última modificación: viernes, 19 de Abril de 2002


Instalación del ratón 3D

Fecha de última modificación: viernes, 19 de Abril de 2002


Instalación de gafas pasivas (ZScreen)

Digi3D

Instalación de gafas pasivas (ZScreenTM)

Fecha de última modificación: viernes, 17 de Mayo de 2002


Instalación de gafas activas (CristalEyes)

Fecha de última modificación: viernes, 17 de Mayo de 2002


Instalación de gafas activas (Eye3D)

Antes de comenzar con la instalación de la gafas activas Eye3D, tenemos que comprobar que disponemos de todos los elementos necesarios:

  • Cable en T.
  • Caja entrelazadora.
  • Juego de gafas con cable.
  • Juego de gafas inalámbrico y pilas.

Podemos comenzar por conectar el juego de gafas con cable a la caja entrelazadora. Para ello se conecta el cable que sale de las gafas en una de las clavijas que están situadas en la parte derecha de la caja entrelazadora, como podemos observar en la siguiente imagen:

A continuación conectamos el cable en T a la caja entrelazadora por la parte posterior de ésta:

Luego conectamos el cable en T a la tarjeta gráfica que corresponde al monitor de visualización estereoscópica. En el caso de que tu tarjeta gráfica disponga de dos entradas, debes conectarla en la número 1.

Después conectamos el cable en T al puerto USB:

Conectamos el cable del monitor de visualización estereoscópica al cable en T:

Con lo que el aspecto de la parte posterior de la CPU será similar al siguiente:

Ahora podemos colocar la caja entralazadora encima del monitor de visualización estereoscópica para que funcione de forma correcta la emisión/recepción de infrarrojos:

Es recomendable situar la caja entrelazadora en la parte izquierda del monitor de visualización estereoscópica, para que al girar la cabeza y mirar al monitor de la derecha, se pierda la emisión recepción de infrarrojos y sea más cómodo el trabajo con el monitor donde no se entrelazan las imágenes.

Ahora ya tenemos visión estereoscópica con el juego de gafas con cable. Ya sólo nos queda instalar el juego de gafas inalámbricas. Comenzamos por la colocación de las pilas en la caja:

Conectamos el cable a la caja mediante los dos conectores:

Luego conectamos el cable a las gafas por la parte izquierda de éstas:

Y ya estaría instalado el juego de gafas inalámbrico. La caja de este juego de gafas inalámbrico tiene un botón de color gris en un lateral. Si se mantiene pulsado se encenderá la caja, lo que se manifiesta por el encendido rojo del piloto de la caja. Si lo volvemos a mantener pulsado se apagará la caja. Para obtener la visión estereoscópica debe de estar la caja encendida.

Con la caja encendida, si pulsamos el botón gris situado en el lateral de forma rápida, invertimos el orden con el que vemos las imágenes, es decir, veremos con el ojo izquierdo la imagen derecha, y viceversa. Con esto se consigue la visión pseudoscópica, y con ella el terreno que en visión estereoscópica lo observamos elevado, lo veremos ahora hundido. Si volvemos a pulsar el botón gris de forma rápida volveremos a tener visión estereoscópica.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Instalación de JoyStick

Fecha de última modificación: viernes, 21 de Junio de 2002


Instalación de JoyPad

Fecha de última modificación: viernes, 21 de Junio de 2002


Instalación de Digi3D

En este tema de la ayuda se explica la instalación, actualización, y desinstalación de Digi3D:

  • Primera instalación de Digi3D.
  • Actualización de Digi3D.
  • Desinstalación de Digi3D para actualizaciones.
  • Desinstalación completa de Digi3D.

Fecha de última modificación: miércoles, 10 de abril 2002


Primera instalación de Digi3D

Los pasos generales para la instalación de Digi3D son:

  1. Instalación de Archivos Comunes.
  2. Instalación del driver de la llave de protección.
  3. Solucionar problemas de GenPORT. Si tu tarjeta de codificadores es externa, no hagas este paso e instala Digi3D como se explica en el siguiente punto.
  4. Instalación de Digi3D.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: miércoles, 10 de abril 2002


Instalación de Archivos Comunes

Dentro de la carpeta Archivos Comunes que cuelga del directorio instalacion se encuentra el archivo de instalación ArchivosComunes.msi. Se ejecuta haciendo doble click sobre dicho archivo. Aparece la siguiente ventana donde no tenemos que hacer nada:

No hay que hacer más operaciones para la correcta instalación de Archivos Comunes.

El siguiente paso de la instalación de Digi3D corresponde al driver de la llave de protección.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: martes, 9 de Abril de 2002


Instalación del driver de la llave de protección

Se ejecuta el programa hldrv32.exe que se encuentra dentro de la carpeta Llave que cuelga del directorio instalacion. Aparece entonces la siguiente ventana:

donde se selecciona U.S. English y se pulsa OK. En la siguiente ventana:

se pulsa sobre Next, y se ejecuta la instalación del driver de la llave de protección. En la siguiente ventana no hay que hacer nada:

Una vez instalado aparece esta ventana:

en la que se pulsa sobre Finish, y ya está instalado el driver de la llave de protección.

El siguiente paso de la instalación dependerá del tipo de usuario que seas:

  • Si tienes tarjeta de codificadores interna debes instalar el driver de GenPort y después instalar el propio programa Digi3D.
  • Si tienes tarjeta de codificadores externa el último paso en la primera instalación de Digi3Dse trata de la instalación del propio programa Digi3D.

Se recomienda efectuar los pasos en el orden en que se explican.

Siguiente

Fecha de última modificación: miércoles, 17 de Abril de 2002


Solucionar problemas de GenPORT

Esta parte de la instalación solamente corresponde hacerla a los usuarios con tarjetas de codificadores internas.

¿Qué es GenPORT?.

GenPORT es un driver (un programa con privilegios especiales) que permite a Digi3D comunicarse con la tarjeta de codificadores.

Este driver es necesario únicamente cuando los codificadores se conectan a una tarjeta que se ha conectado dentro del ordenador. Es el caso de las tarjetas Rest2, Rest3, Altek y SecPC.

Al intentar ejecutar Digi3D aparecen dos ventanas con la siguiente información:

Este error se produce bien porque el driver GenPORT no está instalado, o bien porque no está bien instalado o está instalado varias veces.

Para solucionar el problema realice las dos siguientes tareas (reiniciando el ordenador cuando la ayuda le indique que tiene que reiniciar):

  • Desinstale el driver GenPORT de su ordenador.
  • Instale nuevamente el driver GenPORT en su ordenador.

Fecha de última modificación: 2 de febrero de 2001


Desinstalar el driver GenPORT

¿Por qué desinstalar el driver GenPORT?.

Puede que necesitemos desinstalar el driver GenPORT por cualquiera de los siguientes casos:

  • Porque esté mal instalado.
  • Porque tengamos instalado más de un driver de GenPORT. Esto es una causa de que Digi3D no se comunique con los codificadores.
  • Porque queramos desinstalarlo porque queremos eliminar la aplicación Digi3D del ordenador.

En el caso de que queramos desinstalar el driver de GenPORT por que tenemos más de uno instalado, es muy importante desinstalar todos los drivers de GenPORT y luego volver a instalar un único driver GenPORT como se describe en Solucionar problemas de GenPORT.

Para eliminar el driver de GenPORT del ordenador seguimos los siguientes pasos:

Atención, es muy importante que usted tenga derechos administrativos para poder desinstalar el driver GenPORT. Sólo un administrador o un usuario con derechos de instalación de hardware puede desinstalar el driver de GenPORT.

  • Pulsamos con el botón derecho del ratón sobre el icono Mi PC y pulsamos la opción Administrar:

  • Aparece un programa llamado Administrador de equipos:

  • Pulsamos sobre la opción Administrador de dispositivos:

  • Comprobamos que en la rama del arbol denominada Sample drivers aparece una o varias veces la opción Sample PortIO Driver. Seleccionamos una de las opciones Sample PortIO Driver y pulsamos sobre el botón marcado con un ordenador y con una cruz roja sobre dicho ordenador (el icono que aparece más arriba/derecha):

  • Aparece una ventana de confirmación titulada Confirmar la eliminación del dispositivo. Pulsamos sobre el botón Aceptar para que Windows elimine el driver:

  • Comprobamos que se ha eliminado el driver:

  • En el caso de que tengamos más drivers tendremos que desinstalarlos hasta que ya no queden drivers llamados Sample PortIO Driver:

  • Cuando ya no quedan más drivers GenPORT, Reiniciamos el ordenador.

Fecha de última modificación: 2 de febrero de 2001


Instalar el driver GenPORT

¿Por qué instalar el driver GenPORT?.

El driver GenPORT es necesario para que Digi3D trabaje con los codificadores conectados a una tarjeta de tipo Rest2, Rest3, Altek ó SecPC.

Si queremos instalar el driver GenPORT porque este no funciona, tenemos que asegurarnos de que no está instalado ya. En este caso seguimos los pasos del asistente para Solucionar problemas de GenPORT.

Para instalar el driver de GenPORT en el ordenador seguimos los siguientes pasos:

Atención, es muy importante que usted tenga derechos administrativos para poder desinstalar el driver GenPORT. Sólo un administrador o un usuario con derechos de instalación de hardware puede desinstalar el driver de GenPORT.

  • Pulsamos sobre el botón Inicio luego sobre Configuración y luego sobre Panel de control:

  • Hacemos doble click sobre el icono titulado Agregar o quitar hardware:

  • Aparece un programa titulado Asistente para agregar o quitar hardware. Pulsamos sobre el botón Siguiente:

  • Aparece una página titulada El asistente localiza automáticamente nuevo hardware Plug and Play. Esperamos un momento a que Windows 2000 localize dispositivos Plug and Play. En el caso de que Windows localice algún dispositivo Plug and Play nos mostrará una lista con los dispositivos Plug and Play que ha localizado y nos preguntará si el dispositivo que queremos instalar está en la lista. Respondemos que no:

  • Aparece una página titulada ¿Qué dispositivo de hardware desea reparar?. Seleccionamos la opción titulada Agregar un dispositivo nuevo y pulsamos sobre el botón Siguiente:

  • Aparece una página titulada Windows puede detectar también hardware que no es compatible con Plug and Play. Seleccionamos la opción titulada No, deseo seleccionar el hardware de una lista y pulsamos sobre el botón Siguiente:

  • Aparece una página titulada ¿Qué tipo de hardware desea instalar?. Seleccionamos la opción titulada Mostrar todos los dispositivos y pulsamos sobre Siguiente:

  • Aparece una página titulada ¿Qué controlador desea instalar para este dispositivo?. Pulsamos sobre el botón titulado Utilizar disco...

  • Aparece un cuadro de diálogo llamado Instalar desde disco. Pulsamos sobre el botón Examinar y buscamos el driver. (El driver lo tenemos que haber bajado de Internet http://www.digi21.net/downloads). Buscamos dónde se ha almacenado el driver con el botón Examinar.

  • Aparece un cuadro con el título Sample PortIO Driver. Pulsamos el botón Siguiente:

  • Aparece un cuadro de diálogo en el que Windows nos informa de que como el dispositivo no es Plug and Play no puede detectar la configuración. Pulsamos sobre el botón Aceptar.

  • Aparece un cuadro de diálogo titulado Propiedades de Asistente para agregar nuevo hardware. Pulsamos sobre el botón Aceptar.

  • Aparece un cuadro de diálogo titulado Creando una configuración forzada. Pulsamos sobre el botón Si.

  • Aparece una página titulada Windows está listo para instalar los controladores para su nuevo hardware. Pulsamos sobre el botón Siguiente:

  • Aparece una página titulada Finalización del Asistente para agregar o quitar hardware. Pulsamos sobre el botón Finalizar.

  • Aparece un cuadro de diálogo titulado Cambio de la configuración del sistema. Pulsamos sobre el botón Sí:

  • El ordenador se reinicia y ya tenemos instalado el driver correctamente.

Fecha de última modificación: 2 de febrero de 2001


Instalación de Digi3D

Se ejecuta Digi3D2002.msi que se encuentra en la carpeta Digi3D. Aparece la siguiente ventana:

donde se pulsa Siguiente, y se muestra el archivo Léame con avisos importantes acerca de la nueva versión de Digi3D:

Una vez leído, se pulsa Siguiente y en la siguiente ventana se rellena según corresponda:

y se pulsa de nuevo Siguiente. En la siguiente ventana se debe seleccionar la instalación Completa dado que se trata de la primera instalación.

Se pulsa Siguiente en esta ventana y aparece otra:

en la que también se pulsa Siguiente. A continuación se efectúa la instalación, y se muestra esta ventana para informar del estado de la instalación:

donde no hay que hacer nada. Y aparece una última ventana donde se informa de que Digi3D se ha instalado satisfactoriamente:

Se pulsa Finalizar y ya está completa la instalación de Digi3D.

El programa se instala en la carpeta Digi3D que cuelga de Archivos de programa. Ahora ya puedes comenzar a utilizar Digi3D.

Siguiente

Fecha de última modificación: jueves, 11 de Abril de 2002


Actualización de Digi3D

Si tiene instalada una versión anterior de Digi3D es obligatorio desinstalarla antes de comenzar con la instalación.

Se ejecuta Digi3D2002.msi que se encuentra en la carpeta Digi3D. Aparece la siguiente ventana:

donde se pulsa Siguiente, y se muestra el archivo Léame con avisos importantes acerca de la nueva versión de Digi3D:

Una vez leído, se pulsa Siguiente y en la siguiente ventana se rellena según corresponda:

y se pulsa de nuevo Siguiente. En la siguiente ventana se debe seleccionar la instalación Típica dado que se trata de una actualización.

Se pulsa Siguiente en esta ventana y aparece otra:

en la que también se pulsa Siguiente. A continuación se efectúa la instalación, y se muestra esta ventana para informar del estado de la instalación:

donde no hay que hacer nada. Y aparece una última ventana donde se informa de que Digi3D se ha instalado satisfactoriamente:

Se pulsa Finalizar y ya está completa la actualización de Digi3D.

El programa se instala en la carpeta Digi3D que cuelga de Archivos de programa.

Si quiere saber cómo ejecutar Digi3D lea el tema de la ayuda Ejecutar Digi3D.

Fecha de última modificación: jueves, 11 de Abril de 2002


Desinstalación de Digi3D para actualizaciones

Para la actualización sólo es necesario desinstalar Digi3D, salvo que en la página web se indique expresamente que haya que desinstalar también Archivos Comunes.

Digi3D se desinstala mediante Agregar o quitar programas del Panel de Control de Windows. Una vez desinstalado se puede proceder a la actualización.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: viernes, 28 de Junio de 2002


Desinstalación mediante el Panel de Control

Para desinstalar Digi3D desde Agregar o quitar programas del Panel de Control de Windows, se selecciona Digi3D y Eliminar.

Aparece la siguiente ventana donde pregunta si estamos seguros de eliminar Digi3D:

a lo que se responde afirmativamente y se desinstala el programa.

Ahora ya puedes actualizar Digi3D.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: jueves, 18 de Abril de 2002


Desinstalación Completa de Digi3D

Esta desinstalación completa sólo debe realizarse en el caso de por algún motivo Digi3D no funcione bien. Los pasos generales para la desinstalación completa de Digi3D son:

  1. Desinstalar Digi3D.
  2. Borrar desde el registro de Windows las referencias a Digi3D.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: viernes, 28 de Junio de 2002


Desinstalación mediante el Panel de Control

Para desinstalar Digi3D desde Agregar o quitar programas del Panel de Control de Windows se selecciona Digi3D y Eliminar.

Aparece la siguiente ventana donde pregunta si estamos seguros de eliminar Digi3D:

a lo que se responde afirmativamente y se desinstala el programa.

El siguiente paso para la desinstalación completa de Digi3D consiste en borrar desde el registro de Windows las referencias a Digi3D.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: jueves, 18 de Abril de 2002


Borrar las referencias en el Registro de Windows

Se trata de borrar desde el registro de Windows las referencias a Digi3D. Para ello se arranca Regedit desde Ejecutar del menú Inicio:

Se busca en HKEY_CURRENT_USER la carpeta correspondiente a Digi3D, se selecciona y se elimina. También se debe eliminar la carpeta Digi3D correspondiente a HKEY_LOCAL_MACHINE. Hay que tener especial cuidado en esta operación para borrar solamente estas carpetas.

Ahora ya está completamente desinstalado el programa.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: martes, 9 de Abril de 2002


Primeros pasos con Digi3D y DigiNG

Digi3D

Comenzando con Digi3D

En este capítulo se proporciona un tutorial que te guiará en la realización de tareas sencillas utilizando algunas de las funciones de restitución y edición de Digi3D y DigiNG.

En este tutorial también encontarás una serie de videos explicativos que te mostrarán el funcionamiento del interfaz para ayudarte a familiarizarte con él.

El tutorial contiene los siguientes apartados:

  • Ejecutar Digi3D
  • Ventana principal de Digi3D
  • Cuadro de díalogo Nuevo Proyecto
  • Movimiento de imágenes
  • Cómo crear un fichero de cámara
  • Orientaciones con Digi3D
  • Medidia de la Aerotriangulación
  • Modelo Digital del Terreno por correlación

 © 2003 equipo de Digi21.net Todos los derechos reservados.

Fecha de última modificación: 22 de Marzo de 2004


Ejecutar Digi3D

Una vez instalado Digi3D, hay 3 formas de ejecutarlo:

  1. Desde el menú Inicio:

  2. Haciendo doble click sobre el acceso directo en el Escritorio de Windows:

  3. Haciendo un único click sobre el icono en la Barra de Windows:

La primera vez que se ejecuta la aplicación aparece la siguiente ventana:

de Sugerencias del día. En esta ventana tenemos las siguientes opciones:

  • Activar/desactivar Mostrar sugerencias al empezar. Lo podemos dejar activo para leer las sugerencias al iniciar el programa, o lo podemos desactivar para que no nos aparezca al iniciar Digi3D.
  • Pulsar el botón Siguiente Sugerencia para seguir informándonos sobre Digi3D.
  • Cerrar la ventana y empezar a utilizar Digi3D. Para ello pulsamos bien sobre el botón Cerrar, o bien sobre la cruz en forma de aspa que se encuentra en la esquina superior derecha de la ventana.

Una vez que hayamos cerrado esta ventana, pasaremos a la ventana principal de Digi3D.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Ventana principal de Digi3D

El restituidor digital Digi3D tiene dos monitores: uno para la visualización estereoscópica y otro para controlar el propio programa. En éste es donde se visualiza la ventana principal de Digi3D, que tiene el siguiente aspecto:

Esta ventana tiene varias partes, que de arriba a abajo son:

  • Barra de títulos: en ella aparece el nombre de la aplicación. Si además está abierto algún fichero bin con DigiNG, aparece al lado de Digi3D y entre corchetes el nombre del archivo bin:

  • Menú principal de Digi3D: donde se pueden elegir las acciones a realizar.

  • Barras de Herramientas: donde están las herramientas más comunes. Las puedes mover y colocar como te resulte más conveniente. Incluso tienes la posibilidad de crearlas o modificarlas mediante el manejador de barras de herramientas.

    • Si quieres saber algo más lee el tema de la ayuda Barras de Herramientas.

  • Espacio de trabajo: es el espacio entre las barras de herramientas y la barra de estado. Cuando abras DigiNG, es donde se encontrará el espacio de dibujo.
  • Barra de Estado de la ventana principal de Digi3D: en ella se informa del estado de la aplicación.

Si quieres empezar a trabajar con Digi3D debes crear o abrir un Proyecto.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Cuadro de diálogo Nuevo Proyecto

Este cuadro de diálogo es el cuadro de diálogo principal del restituidor digital Digi3D. En él indicamos al restituidor digital todos los datos necesarios para visualizar y trabajar con un par estereoscópico o con una imagen.

Este cuadro aparece cada vez que se ejecuta el restituidor digital (siempre y cuando no se haya activado el cuadro de chequeo con el título "No mostrar este cuadro de diálogo en el futuro") y cuando pulsamos sobre el menú Archivo/Nuevo o bien la combinación de teclas Ctrl + N.

El cuadro de diálogo se divide en cuatro partes principales:

  • Estereoscópico: donde podemos rellenar la información necesaria para crear un nuevo par estereoscópico.
  • Monoscópico: donde podemos rellenar la información necesaria para trabajar con una foto.
  • Digi: donde podemos abrir DigiNG.
  • Recientes: donde podemos recuperar con un simple click de ratón un modelo creado con anterioridad.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Página Estereoscópico

Digi3D

Cuadro de diálogo Nuevo Proyecto (Página Estereoscópico)

Esta página se utiliza para informar al restituidor digital Digi3D de todos los datos que éste necesita para generar un par estereoscópico:

Los datos que necesita el digital para crear un nuevo par estereoscópico son los siguientes:

  • Imagen izquierda: es la imagen que se verá con el ojo izquierdo independientemente del sistema de visualización estereoscópica utilizado. Esta imagen puede ser de cualquiera de los tipos de imágenes soportados.
  • Imagen derecha: es la imagen que se verá con el ojo derecho independientemente del sistema de visualización estereoscópica utilizado. Esta imagen puede ser de cualquiera de los tipos de imágenes soportados.
  • Directorio de trabajo: ubicación de los archivos utilizados por Digi3D: de orientaciones, de dibujo, etc..., exceptuando los archivos de imagen, de cámara y de puntos. La casilla Bloquear sirve para fijar este directorio y no se modifique cuando se cambie de modelo estereoscópico.
  • Pasada: en este campo se puede introducir el número de la pasada a la que pertenece el par estereoscópico con el que se va a trabajar. Este número de pasada se puede incluir en la reseñas generadas por Digi3D. Si quieres profundizar en el tema lee el tema de la ayuda Plantillas para el Generador de Reseñas.
  • Posición de los paneles en el modelo: es la posición en la que vemos los relojes en las imágenes, cuando éstas están formando modelo estereoscópico. Necesariamente tienen que estar los relojes en la misma posición en las dos imágenes. Los relojes pueden estar a la izquierda, arriba, derecha o abajo.
  • Archivo de puntos: se trata de archivo con las Coordenadas Terreno de los puntos de apoyo. Para conocer el formato de dicho archivo lee el tema de la ayuda Formato del archivo de puntos.
  • Archivo de cámara: es un archivo ASCII con información acerca de la focal de la cámara, las coordenadas de sus marcas fiduciales... Para conocer el formato de dicho archivo lee el tema de la ayuda Formato del archivo de cámara.
  • Cargar sólo la zona de recubrimiento: si se activa esta opción, sólo se carga en memoria una parte de la imagen (y sólo se visualiza), en función del Recubrimiento y del fotograma del que se trate. Por ejemplo, si se define un recubrimiento del 60%, sólo se carga el 60% correspondiente al lado derecha para la imagen izquierda. Y sólo se carga el 60% correspondiente al lado izquierdo de la imagen derecha. Esta opción permite cargar imágenes que ocupan mucho espacio en memoria, pues se reduce la carga en memoria de las mismas, al mismo tiempo que permite la visión estereoscópica del modelo, y por lo tanto, la restitución fotogramétrica.
  • Recortar verticalmente: si se activa esta opción sólo se carga en memoria una parte de la imagen. La cantidad que se introduzca, se divide entre dos, y corresponde con el tanto por ciento que se recorta de la parte superior y de la parte inferior de la imagen. Por ejemplo, si se establece a 20, se recortan las imágenes un 10% de su parte superior, y un 10% de la parte inferior.
  • Recortar por Arriba, Recortar por Abajo: estas dos casillas permiten definir el recorte vertical de tres formas distintas: sólo por la parte superior, sólo por la inferior, o ambos recortes conjuntamente.

Para que el restituidor digital Digi3D nos permita entrar en modo gráfico, se deben rellenar todos los datos del cuadro de diálogo Nuevo proyecto (página Estereoscópico). Si no se rellenan correctamente todos los datos, el programa marca de color gris el botón Abrir y no permite continuar.

La comprobación que hace el programa para permitir o no continuar y entrar en modo gráfico es la siguiente:

  1. Comprueba que el archivo con la imagen izquierda existe.
  2. Comprueba que el archivo con la imagen derecha existe.
  3. Comprueba que el archivo de puntos existe.
  4. Comprueba que el archivo de cámara existe, y además lo analiza comprobando que todos sus datos son correctos.

Una vez que se han rellenado correctamente todos los datos del cuadro de diálogo Nuevo proyecto (página estereoscópico) se puede pulsar sobre el botón Abrir y el programa entrará en modo gráfico.

Cuando se pulsa sobre el botón Abrir, el programa almacena en el registro del sistema para el usuario actual todos los parámetros, de modo que cuando se vuelva a ejecutar el programa aparezcan como datos por defecto en todos los controles del cuadro de diálogo.
Si se pulsa sobre el botón Cancelar no se almacenará en el registro esta información.

El cuadro de diálogo Nuevo Proyecto (página Estereoscópico) dispone de dos botones especiales: y [image].

Estos botones permiten copiar el nombre del archivo de imagen izquierda en la ventana de la imagen derecha o copiar el nombre de la imagen derecha en la ventana de la imagen izquierda respectivamente. De este modo se agiliza el proceso de cambiar de un modelo al siguiente dentro de la misma pasada, ya que sólo tendremos que buscar una de las imágenes en vez de las dos.

Todos los datos necesarios se almacenan en un archivo de proyecto cuyo nombre corresponderá con el del modelo estereoscópico abierto (imagen izquierda-imagen derecha), y con extensión .prjd3d. Este archivo de proyecto se almacena en el directorio de trabajo, con el icono de Digi3D, como se puede ver en la siguiente imagen un ejemplo con el archivo 107-108.prjd3d:

Si se hace doble click sobre este archivo, se abrirá automáticamente el restituidor digital Digi3D, con el par estereoscópico cargado y con los parámetros definidos en el cuadro de dialogo Nuevo proyecto. Si además, se hubiera abierto un fichero de dibujo conjuntamente con el par estereoscópico, también se abriría enotonces este fichero de dibujo.

Si quieres ver un todas las órdenes de Digi3D lee el tema de la ayuda Listado de órdenes de Digi3D.

Fecha de última modificación: martes, 29 de Octubre de 2002


Página Monoscópico

Digi3D

Cuadro de diálogo Nuevo Proyecto (Página Monoscópico)

Esta página se utiliza para informar al restituidor digital Digi3D sobre todos los datos que éste necesita para trabajar con una foto (se pueden hacer la Orientación Interna y Externa de la imagen).

Los datos que necesita el restituidor digital para trabajar con una foto son los siguientes:

  • Imagen: es la imagen escaneada de la foto. Esta imagen puede ser de cualquiera de los tipos de imágenes soportados.
  • Posición de los paneles en la imagen: es la posición en la que vemos los relojes en la imagen. Los relojes pueden estar a la izquierda, arriba, derecha o abajo.
  • Archivo de puntos: se trata de un archivo con las coordenadas de los puntos de apoyo. Para conocer el formato de dicho archivo lee el tema de la ayuda Formato del archivo de puntos.
  • Archivo de cámara: es un archivo ASCII con información acerca de la focal de la cámara, las coordenadas de sus marcas fiduciales... Para conocer el formato de dicho archivo lee el tema de la ayuda Formato del archivo de cámara.

Para que el restituidor digital Digi3D nos permita entrar en modo gráfico, se deben rellenar todos los datos del cuadro de diálogo Nuevo proyecto (página Monoscópico). Si no se rellenan correctamente todos los datos, el programa marca de color gris el botón Abrir y no permite continuar.

La comprobación que hace el programa para permitir o no continuar y entrar en modo gráfico es la siguiente:

  1. Comprueba que el archivo con la imagen existe.
  2. Comprueba que el archivo de puntos existe.
  3. Comprueba que el archivo de cámara existe, y además lo analiza comprobando que todos sus datos son correctos.

Una vez que se han rellenado correctamente todos los datos del cuadro de diálogo Nuevo proyecto (página Monoscópico) se puede pulsar sobre el botón Abrir y el programa entrará en modo gráfico.

Cuando se pulsa sobre el botón Abrir, el programa almacena en el registro del sistema para el usuario actual todos los parámetros, de modo que cuando se vuelva a ejecutar el programa aparezcan como datos por defecto en todos los controles del cuadro de diálogo.
Si se pulsa sobre el botón Cancelar no se almacenará en el registro esta información.

Si quieres ver todas las órdenes de Digi3D lee el tema de la ayuda Listado de órdenes de Digi3D.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Página Digi

Digi3D

Cuadro de diálogo Nuevo Proyecto (Página Digi)

Esta página se utiliza para informar al restituidor digital Digi3D de todos los datos que éste necesita para trabajar con DigiNG. El aspecto del cuadro de diálogo Nuevo Proyecto de DigiNG es el siguiente:

Los datos que necesita el restituidor digital para comenzar a utilizar DigiNG son los siguientes:

  • Nombre de archivo de trabajo: se escribe directamente el nombre del archivo (no es necesario teclear la extensión, ya que el programa asigna automáticamente la extensión BIN). Todos los dibujos realizados con el programa DigiNG se almacenan en archivos con extensión BIN. Si se pulsa sobre el triángulo situado en la parte derecha se despliega una lista con los 10 últimos archivos abiertos con DigiNG. Si el nombre de fichero tecleado no existe en el directorio actual de trabajo, se creará un archivo de dibujo nuevo. El resto de los datos que aparecen en este cuadro de diálogo son parámetros que controlan la forma de trabajar del programa. Pueden establecerse desde el principio de la sesión de trabajo o pueden ser inicializados con valores por defecto y posteriormente modificados, mediante órdenes específicas desde el entorno de dibujo.

  • Escala de dibujo: se asumirá por defecto 1:1000. Es importante poner bien este valor para una perfecta visualización de los patrones de línea. Es posible almacenar los valores correspondientes a Incremento de registro, Altura de textos, Equidistancia, Tolerancia a generalizar para cada escala pulsando sobre el botón Guardar. De esta forma, el usuario puede recuperar esta información para cada escala seleccionando ésta en la lista desplegable, y pulsando el botón Cargar para establecer los valores de dichos parámetros. Por defecto, existen unos valores para cada escala, que son los más extendidos, pero el usuario puede establecer los que considere oportuno y guardarlos.

  • Incremento de registro: establece la densidad o el número de puntos que se van a registrar cuando se dibujen entidades en modo continuo. Este valor se puede modificar durante la sesión de trabajo usando la orden INC.

  • Altura de textos: hace referencia a la altura, expresada en metros, con la que se van a rotular los textos en el dibujo. Este campo también es opcional, y su valor puede modificarse durante la sesión trabajo con la orden AT.

  • Corrección de Z entre operadores: representa el valor de la ecuación personal del operador de restitución al posarse sobre el modelo y se le sumará con su signo a la coordenada Z.

  • Equidistancia entre curvas de nivel: representa el valor de la equidistancia de curvas de nivel, que utilizarán las órdenes INTER (interpolación de curvas), FIJAZ (para fijar la cota a un múltiplo de este valor), BAJA_Z, .... También se puede emplear para moverse a intervalos fijos en XY con la orden FIJAXY.

  • Tolerancia a generalizar: representa el valor del factor de generalización lineal. Este dato puede introducirse posteriormente durante la sesión de trabajo con la orden TOL. Si no se especifica ningún dato, el programa asigna por defecto a este campo el valor 0.

  • Modo de búsqueda: el usuario ha de especificar cuál de las distintas posibilidades de enganche quiere establecer inicialmente en la sesión de trabajo. Los valores de respuesta posibles son: 0, 1, 2, 3, 4, 5, 6, ... (para más información, consultar CAMB_MODOB). Si no se especifica ningún valor de entrada, el usuario puede hacerlo posteriormente con la orden MODOB.

  • Archivo de puntos: el usuario ha de escribir el nombre del archivo que contiene las coordenadas de los puntos de apoyo.

  • Archivo de órdenes de inicio: es el nombre de un archivo de macroinstrucciones (un arroba), por ejemplo @inicio, en el que ponemos una serie de órdenes que queremos que se ejecuten cada vez que iniciemos DigiNG.

  • Directorio de tablas: sirve para especificar el directorio donde DigiNG buscará inicialmente cualquier tabla o archivo de configuración. Si no encuentra el archivo en este directorio, el programa buscará en el directorio de trabajo y por último en el directorio C:\Digi.

  • Precisión y Origen global: nos indica la precisión con la que se van a registrar los elementos dentro de DigiNG. Debido a que internamente DigiNG, al igual que MicroStation, almacena números enteros, no es posible trabajar con precisión de milímetro y almacenar valores de coordenadas superiores a 2147483 metros. Si quieres saber algo más lee el tema de la ayuda Precisión en DigiNG.

Una vez finalizada la entrada de datos, el usuario debe pulsar sobre el botón Aceptar para empezar a trabajar y acceder al archivo de dibujo.

Si quieres ver un todas las órdenes de DigiNG lee el tema de la ayuda Listado de órdenes de DigiNG.

Fecha de última modificación: martes, 27 de Agosto de 2002


Página Recientes

Digi3D

Cuadro de diálogo Nuevo Proyecto (Página Recientes)

Esta página se utiliza para rellenar de forma automática y con un simple click de ratón todos los datos que necesita el restituidor digital Digi3D para poder entrar en modo gráfico.

Cada vez que un usuario rellena el cuadro de diálogo Nuevo proyecto (página Nuevo), se almacenan en el registro del sistema todos los datos de cada modelo nuevo. Si en el cuadro de diálogo Nuevo proyecto nos vamos a la página Nuevo aparecerá una lista con todos los modelos que se han cargado en el restituidor en los últimos tres meses.

Si alguno de los datos de un determinado modelo no existe o es incorrecto, dicho modelo no aparecerá en la lista (Ej: si se ha borrado una imagen de un determinado modelo) pero no se borrará del registro del sistema hasta que hayan pasado tres meses. Si se vuelven a almacenar en su ubicación original todos los archivos de un modelo y no han transcurrido más de tres meses, dicho modelo aparecerá en la lista.

Para cargar un modelo anterior tenemos dos opciones: bien hacer doble click sobre el modelo que nos interese o bien seleccionarlo haciendo click sobre él y pulsando sobre el botón Abrir.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Control del restituidor

El restituidor digital Digi3D es controlado por medio de órdenes, que son introducidas en el restituidor de dos formas diferentes:

  • Introduciendo manualmente el nombre de la orden y sus parámetros. Para ello pulsamos Enter y el restituidor nos muestra un diálogo titulado Orden, como se puede ver en la siguiente imagen:

    • donde introducimos el nombre de la orden que queremos ejecutar y pulsamos nuevamente Enter. El campo de texto funciona de dos formas distintas, según esté o no activada la casilla Usar texto predictivo:

    • Si está marcada: se autocompletan los nombres de las órdenes. Si se pulsa sobre el triángulo situado en la parte derecha se despliegan en una lista todos las órdenes instaladas en DigiNG.
    • Si no está marcada: el campo de texto se comporta como una pila de órdenes. Pulsando la teclas de cursor se verán las órdenes anteriormente ejecutadas.

  • Pulsando una tecla a la que previamente se le ha asignado una determinada orden: ejecutamos la orden Tecla y seguimos sus instrucciones. Si quieres saber algo más lee el tema de la ayuda Orden TECLA.

Al instalar el módulo TeclasMnu de Digi3D, se instalan una serie de asignaciones de órdenes al teclado de Digi3D.

La asignación de teclas por defecto es la siguiente:

    Tecla | Orden | Descripción
Ctrl+Fin | SALIR_DIGI3D | Sale del modo gráfico y muestra la carátula principal del restituidor.
AvPág | REST_ZOOMIN | Zoom de acercar.
RePág | REST_ZOOMOUT | Zoom de alejar.
F3 | REST_ZOOME | Zoom extensión.
F4 | REST_ZOOM1X1 | Zoom a escala 1:1.
+ (del teclado numérico) | VELOCIDAD_MAS_XY | Aumenta la velocidad de las manivelas en XY.
- (del teclado numérico) | VELOCIDAD_MENOS_XY | Disminuye la velocidad de las manivelas en XY.
* (del teclado numérico) | VELOCIDAD_MAS_Z | Aumenta la velocidad de las manivelas en Z.
/ (del teclado numérico) | VELOCIDAD_MENOS_Z | Disminuye la velocidad de las manivelas en Z.
F2 | TIPO_INDICE | Cambia el tipo de índice.
B | CORRELAR | Posa en Z fijando la imagen izquierda
Tab | CAMBIA_TECLAS_MNU | Cambia la asignación de teclas actual
Control+P | IR_A_PUNTO_APOYO | Mueve el restituidor a un punto de apoyo del archivo de puntos.
R | RATON_DIGI3D | Activa/Desactiva el movimiento del restituidor con un ratón.

El archivo de teclas que se instala por defecto recibe el nombre de TDigital.mnu.

Si quieres ver todas las órdenes del restituidor Digi3D lee el tema de la ayuda Listado de Órdenes de Digi3D.

Fecha de última modificación: lunes, 11 de Noviembre de 2002


Programar los botones del ratón

En el caso de que tengamos como dispositivo de entrada el ratón 3D:

podemos programar los botones del ratón para que al pulsarlos se ejecuten órdenes. Para ello en primer lugar debemos conocer el número de botón que queremos programar. Mediante la orden VER_COORDENADAS, si le pasamos como parámetro 1, 2, 3 o 4, podemos ver en la pantalla de visualización estereoscópica el valor del botón del ratón que pulsemos.

Cada botón del ratón tiene un número asignado, y a los botonees correspondientes con 1, 2, y 4 corresponden con DATO, TENTATIVO, y FIN_ENTIDAD. Por lo tanto, a estos botones no admiten órdenes. A los restantes botones del ratón si les podemos asignar órdenes.

Conocidos los números asociados a los botones del ratón, para asignar órdenes a los botones debemos crear un archivo de texto, que tenga por nombre pedales.mnu, y que se almacene dentro de la carpeta C:\Archivos de programa\Digi3D. Cada fila de este archivo relaciona un botón (número) del ratón con una orden, y debe tener los siguientes campos:

  • Número: asociado a la pulsación de un botón del ratón.
  • Orden: orden que se asigna a la pulsación del botón asociado al número indicado en el primer campo.

De esta manera podremos asignar las funciones de DATO (1), TENTATIVO (2) y FIN (4) a cualquier botón.

Por ejemplo:

 32 1 (asigna la función de Dato al boton 32)
 64 4 (asigna la función Fin Entidad al botón 64)

Estos campos pueden estar separados por un espacio, tabulación, coma y comillas. Otro ejemplo de este archivo puede ser

3 EMBRAGUE
7 RATON_DIGI3D

La orden EMBRAGUE se utiliza para mover el ratón sin desplazar las imágenes. Para ello se debe mantener pulsado el botón asociado a esta orden.

La orden RATON_DIGI3D se utiliza para alternar el movimiento del ratón asociado a las imágenes y al puntero del ratón de Windows.

Fecha de última modificación: miércoles, 30 de Octubre de 2002


Monitores empleados en Digi3D

Los monitores que se utilizan en Digi3D son los dos que se pueden ver en la imagen:

  • El que está situado a la derecha se utiliza para manejar la ventana principal del restituidor digital Digi3D.
  • El que está situado a la izquierda se utiliza para obtener la visión estereoscópica.
    •

Fecha de última modificación: viernes, 19 de Abril de 2002


Pantalla de visualización estereoscópica

El restituidor Digi3D tiene dos monitores: uno para la visualización estereoscópica y otro para controlar el propio programa. En el primero es donde se efectúa la visión tridimensional de los modelos.

Para aprender a manejar esta pantalla y también a manejar las imágenes lo mejor es mediante un ejemplo. Para seguir el ejemplo se debe crear un directorio de trabajo, y en él se deben copiar los siguientes archivos de la carpeta Bronchales que cuelga del directorio c:\instalación:

  • 107.tif: fotograma izquierdo del par.
  • 108.tif: fotograma derecho del par.
  • BRONCHALES.xyz: archivo de puntos, y en él se encuentran los puntos de apoyo.
  • RMK15.cam: archivo de cámara.

Iniciamos un Nuevo Proyecto Estereoscópico:

En dicho cuadro de diálogo rellenamos los siguientes campos (todos los archivos de ejemplo están incluidos en la carpeta Bronchales que cuelga del directorio c:\instalacion):

  • Imagen izquierda: en nuestro ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: en nuestro ejemplo se trata de la imagen 108.tif.
  • Posición de los paneles en este modelo: izquierda.
  • Recubrimiento: se trata del recubrimiento longitudinal, que en este caso se trata de 60, esto es, 60%.
  • Archivo de puntos: archivo donde se encuentran los puntos de apoyo, que en nuestro ejemplo es BRONCHALES.xyz.
  • Archivo de cámara: el archivo es RMK15.cam.

Pulsamos en Abrir y aparecen en el monitor de visualización estereoscópica las imágenes. El aspecto de esta pantalla dependerá del tipo de visualización estereoscópica del que se disponga y de la configuración que hayamos dispuesto. En este ejemplo utilizaremos estereóscopo, por lo que tendremos un aspecto parecido al siguiente:

donde se puede ver en la parte superior las dos imágenes, y en la parte inferior información en forma de barra de estado. El aspecto de esta pantalla se puede modificar, como se explica en el tema de la ayuda Configuración de la visualización.

La barra de estado muestra la siguiente información de izquierda a derecha:

  • 107-108: son las imágenes cargadas, siendo en este caso 107 la imagen izquierda, y 108 la imagen derecha.
  • i d r a: informa del estado de las orientaciones. Se corresponden de la siguiente forma: i es la Orientación Interna del fotograma izquierdo, d es la Orientación Interna derecha, r es la Orientación Relativa, y por último, a es la Orientación Absoluta. Si se presenta en minúsculas, el programa está informando que la Orientación correspondiente no está hecha. Si se presenta en mayúsculas, quiere decir que la Orientación correspondiente si está realizada. Por ejemplo, la letra i indica que la Orientación Interna del fotograma izquierdo no está hecha, y la letra I indica que sí está hecha dicha Orientación.
  • 1:1: indica el zoom con el que se muestran las imágenes. Si el número de la izquierda es superior a 1, indica que se están mostrando las imágenes más pequeñas de lo que realmente son, esto es, se trata de un alejamiento de zoom. Si el número de la derecha es mayor de 1, indica que el zoom es de acercamiento.
  • (1600x1200): se trata de la resolución de la pantalla de visualización estereoscópica.
  • Escala: 1.0: informa de la escala de la visualización estereoscópica una vez hecha la Orientación Absoluta.
  • 1.00: indica la velocidad de las manivelas X e Y.
  • 1.00: indica la velocidad de la rueda de las Z.
  • AMS: muestra el nombre del equipo donde se encuentra la llave de protección del programa.

Si quieres aprender a manejar las imágenes lee el tema de la ayuda Movimiento de las imágenes.

Fecha de última modificación: jueves, 18 de Abril de 2002


Movimiento de las imágenes

Para manejar las imágenes que vemos en el monitor de visualización estereoscópica tenemos las siguientes opciones:

  • Mover las imágenes: dependerá del equipo que tengas en el restituidor digital Digi3D. Si tienes manivelas, moverás las imágenes con ellas, y si quieres también puedes hacerlo con el ratón de tu ordenador. Si tu equipo está formado por un ratón, moverás las fotografías con él.
  • Zoom: puedes navegar de forma rápida por las imágenes mediante las órdenes de Zoom de Digi3D.

Fecha de última modificación: jueves, 18 de Abril de 2002


Movimiento de las imágenes con las manivelas

Tienes dos manivelas: la que está situada a tu izquierda mueve las imágenes a lo largo del eje X, y la que está situada a tu derecha mueve las imágenes a lo largo del eje Y. El movimiento es suave, pero si giras las manivelas un poco más rápido verás como se "acelera" el movimiento de las imágenes. Este cambio de velocidad se puede configurar en Aceleración de las manivelas dentro de la Configuración de Digi3D.

Puedes cambiar la velocidad del movimiento de las imágenes de varias maneras:

  • Mediante las órdenes VELOCIDAD_MAS_XY y VELOCIDAD_MENOS_XY se aumenta y se disminuye, respectivamente, la velocidad de las manivelas X e Y. Además, con la orden VELOCIDAD puedes especificar la velocidad de las manivelas.
  • En el teclado por defecto (TDigital.mnu) están asignadas por defecto:

Tecla | Orden | Descripción
+ (del teclado numérico) | VELOCIDAD_MAS_XY | Aumenta la velocidad de las manivelas en XY.
- (del teclado numérico) | VELOCIDAD_MENOS_XY | Disminuye la velocidad de las manivelas en XY.

También puedes utilizar el ratón de tu ordenador para mover las imágenes. El movimiento de las imágenes se efectúa de igual forma que los restituidores digitales que tienen ratón especial.

Si además en tu ratón posees una rueda en la parte superior del ratón, la podrás utilizar como si fuera el pedal de Z.

Si tienes algún problema con las manivelas consulta el tema de la ayuda Configuración del Dispositivo de Entrada.

Fecha de última modificación: jueves, 18 de Abril de 2002


Movimiento de las imágenes con el ratón

Para mover las imágenes con cualquier ratón, tanto si trata del dispositivo especial del restituidor digital como si se trata del ratón sencillo de tu ordenador, debes ejecutar la orden RATON_DIGI3D (si quieres recordar como se ejecuta una orden lee el tema de la ayuda Control del Restituidor). Entonces los movimientos de las imágenes estarán asociados a los del ratón. Con este sistema no se puede modificar la aceleración de los movimientos.

Como el ratón mueve las imágenes, no dispones de ratón para manejar la ventana principal de Digi3D. Si quieres volver a tener disponible el ratón para utilizar la ventana principal de Digi3D debes volver a ejecutar la orden RATON_DIGI3D. Luego el modo de operar es ejecutar este orden alternativamente para manejar una u otra ventana.

En el caso del que dispongas del ratón especial:

puedes programar los botones como quieras, y además puedes asignar la orden RATON_DIGI3D a un botón.

Fecha de última modificación: viernes, 19 de Abril de 2002


Movimiento de las imágenes mediante Zoom

Una forma muy cómoda de navegar por las imágenes es alternar el Zoom extendido y el Zoom 1x1, mediante las órdenes REST_ZOOME y REST_ZOOM1X1, respectivamente. Si estás en un Zoom muy cercano a la imagen, los movimientos, por muy rápidos que éstos sean, no te permitirán desplazarte mucho por la imagen. Por ello, una buena técnica es hacer Zoom extendido, donde un pequeño desplazamiento te permitirá desplazarte rápidamente por las imágenes, y luego realizar un Zoom 1x1, con el que te acercarás a las fotografías.

En el teclado por defecto (TDigital.mnu) están asignadas por defecto:

Tecla | Orden | Descripción
AvPág | REST_ZOOMIN | Zoom de acercar.
RePág | REST_ZOOMOUT | Zoom de alejar.
F3 | REST_ZOOME | Zoom extensión.
F4 | REST_ZOOM1X1 | Zoom a escala 1:1.

donde también están configuradas las órdenes REST_ZOOMIN y REST_ZOOMOUT, para acercarse y alejarse respectivamente. Estas órdenes (o sus teclas), también pueden utilizarse para navegar por las fotografías.

Si quieres saber como asignar órdenes a las teclas lee el tema de la ayuda Control del Restituidor.

Fecha de última modificación: jueves, 18 de Abril de 2002


Salir del modo gráfico

Cuando estamos viendo imágenes en el monitor de visualización estereoscópica, estamos en el llamado modo gráfico. Por varios motivos, se debe salir de este modo con el restituidor digital Digi3D:

  • Cuando vayamos a cambiar de aplicación
  • Cuando vayamos a ejecutar alguna herramienta (del menú de herramientas de Digi3D) que cargue en memoria archivos raster (como por ejemplo la herramienta de Orientaciones Internas Automáticas u Orientaciones Relativas Automáticas).

La orden para salir del modo gráfico es SALIR_DIGI3D, que en el teclado por defecto (TDigital.mnu) está asignada a las teclas Ctrl+Fin:

    Tecla | Orden | Descripción
Ctrl+Fin | SALIR_DIGI3D | Sale del modo gráfico y muestra la carátula principal del restituidor.

A través del cuadro de diálogo Nuevo Proyecto se entra en el modo gráfico, es decir, visualizando las imágenes otra vez. Cada entrada/salida del modo gráfico no significa carga/descarga en de las imágenes, lo que implicaría esperar a que se carguen las imágenes en memoria en cada entrada al modo gráfico. Solamente se cargan en memoria las imágenes la primera vez que se entre en el modo gráfico, y ya no se descargan hasta que se salga de Digi3D.

Fecha de última modificación: martes, 15 de Octubre de 2002


Cómo crear un fichero de cámara

El archivo de cámara tiene una gran importancia dentro de Digi3D, pues en él se definen, además de datos relativos a la Orientación Interna, elementos correspondientes a otros importantes pasos fotogramétricos dentro de Digi3D. Tenemos entonces tres grupos de información dentro de este archivo:

  • Datos del certificado de calibración de la cámara.
  • Coordenadas para Orientación Relativa.
  • Coordenadas para Aerotriangulación.

El archivo de cámara es un archivo de texto que puedes crearlo o modificarlo con un editor de textos. Si prefieres puedes crearlo o modificarlo mediante Digi3D.

Si quieres conocer el formato del archivo de cámara pulsa aquí.

Si quieres pasar al tema de la ayuda Orientaciones en Digi3D pulsa aquí.

Fecha de última modificación: lunes, 22 de Abril de 2002


Cómo crear un fichero de cámara mediante un editor de textos

Para crear (o modificar) un archivo de cámara abrimos, por ejemplo, el bloc de notas. En él empezamos a escribir el fichero de cámara comenzando por la siguiente línea (si quieres conocer el formato del archivo de cámara lee el tema de la ayuda Formato del archivo de cámara):

    [Camara]

Con esta línea Digi3D entenderá que el archivo es de cámara. Lo siguiente que tenemos que escribir es la posición del panel. Supongamos que el panel (los relojes), está situado a la izquierda. Por lo tanto corresponde escribir 0 (cero).

    PosicionPanel=0

A continuación hay que escribir la distancia focal calibrada, que la obtenemos del certificado de calibración de la cámara. Se escribe de la siguiente forma:

    Focal=305.363

Es muy importante escribir todos los datos dentro del fichero de cámara en las mismas unidades. Después se introduce las Fotocoordenadas del Punto de mejor simetría, que también obtenemos del certificado de calibración de la cámara. Se separan las Fotocoordenadas X e Y mediante un espacio, coma o comillas simples:

    PuntoPrincipal= 0.000 0.011

Luego se introducen las Fotocoordenadas de las marcas fiduciales, con el sufijo Fiducial. Se separan las Fotocoordenadas X e Y mediante un espacio, una coma, tabulador o comillas:

    Fiducial1=113.012 0.019
Fiducial2=-112.997 0.020
Fiducial3=0.001 0.002
Fiducial4=0.002 -112.988
Fiducial5=112.999 113.014
Fiducial6=-112.994 -112.981
Fiducial7=-113.000 113.017
Fiducial8=113.000 -112.987

A continuación escribimos los puntos donde queremos que nos lleve Digi3D cuando hagamos la Orientación Relativa. Llevan el sufijo PRel:

    PRel1=0 0
PRel2=90 0
PRel3=90 90
PRel4=0 90
PRel5=0 -90
PRel6=90 -90
PRel7=45 0
PRel8=45 50
PRel9=45 -50

Después tecleamos los puntos donde queremos que nos lleve Digi3D cuando hagamos la Aerotriangulación. Llevan el sufijo PAero:

    PAero1=1 0.0 0.0
PAero2=2 0.0 90.0
PAero3=3 0.0 -90.0

Y por último, escribimos los valores de distorsión de la cámara, en la forma Radio Distorsión. Hay que tener especial cuidado con las unidades:

    Distorsion1=0  0.000
Distorsion2=10 0.001
Distorsion3=20 0.000
Distorsion4=30 0.000
Distorsion5=40 0.001
Distorsion6=50 0.002
Distorsion7=60 0.003
Distorsion8=70 0.003
Distorsion9=80 0.003
Distorsion10=90 0.002
Distorsion11=100 0.001
Distorsion12=110 -0.001
Distorsion13=120 -0.002
Distorsion14=130 -0.003
Distorsion15=140 -0.003
Distorsion16=150 0.001

Con lo que ya tendríamos escrito el archivo. Debemos guardarlo con extensión CAM. El archivo de cámara que hemos creado es el siguiente:

    [Camara]
PosicionPanel=0
Focal=305.363
PuntoPrincipal= 0.000 0.011
Fiducial1=113.012 0.019
Fiducial2=-112.997 0.020
Fiducial3=0.001 0.002
Fiducial4=0.002 -112.988
Fiducial5=112.999 113.014
Fiducial6=-112.994 -112.981
Fiducial7=-113.000 113.017
Fiducial8=113.000 -112.987
PRel1=0 0
PRel2=90 0
PRel3=90 90
PRel4=0 90
PRel5=0 -90
PRel6=90 -90
PRel7=45 0
PRel8=45 50
PRel9=45 -50
PAero1=1 0.0 0.0
PAero2=2 0.0 90.0
PAero3=3 0.0 -90.0
Distorsion1=0  0.000
Distorsion2=10 0.001
Distorsion3=20 0.000
Distorsion4=30 0.000
Distorsion5=40 0.001
Distorsion6=50 0.002
Distorsion7=60 0.003
Distorsion8=70 0.003
Distorsion9=80 0.003
Distorsion10=90 0.002
Distorsion11=100 0.001
Distorsion12=110 -0.001
Distorsion13=120 -0.002
Distorsion14=130 -0.003
Distorsion15=140 -0.003
Distorsion16=150 0.001

Fecha de última modificación: lunes, 22 de Abril de 2002


Cómo crear un fichero de cámara mediante Digi3D

En el menú principal de Digi3D seleccionamos Crear/Modificar Cámaras dentro de Herramientas:

y aparece la siguiente ventana:

donde podemos crear o modificar un archivo de cámara.

Si quieres conocer el formato del archivo de cámara lee el tema de la ayuda Formato del archivo de cámara.

Fecha de última modificación: lunes, 22 de Abril de 2002


Datos del certificado de calibración de la cámara

Para ver cómo obtener los datos nos apoyaremos en ejemplo de certificado de calibración, de una cámara con la se hayan hecho las fotografías. En dicho certificado tenemos que buscar los siguientes datos:

  • Distancia focal calibrada: en la página 2 del ejemplo de certificado de calibración:

    donde vemos que la distancia focal calibrada es 305.363 milímetros (MM). Es muy importante introducir en el fichero de cámara todos los datos en las mismas unidades.

  • Parámetros de distorsión de la cámara: en la página 2 del ejemplo de certificado de calibración:

    donde corresponde tomar los valores de la media AV (Average). Hay que tener especial cuidado en las unidades, porque en este caso la distorsión la están proporcionando en micras, y en el fichero de cámara para Digi3D necesitamos homogeneidad en las unidades. Por lo tanto, si los restantes elementos se introducen en milímetros, los parámetros de distorsión de la cámara debemos introducirlos también en milímetros.

  • Coordenadas del Punto de mejor simetría: en la página 2 del ejemplo de certificado de calibración:

    Hay que tomar las coordenadas de PPA.

  • Fotocoordenadas de las marcas fiduciales: en la página 2 del ejemplo de certificado de calibración:

    donde vemos que hay 8 marcas fiduciales, y que además las fotocoordenadas de éstas están en milímetros (MM).

No nos hacen falta más datos del certificado de calibración de la cámara para el fichero de cámara.

Si quieres conocer el formato del archivo de cámara lee el tema de la ayuda Formato del archivo de cámara.

Fecha de última modificación: jueves, 25 de Abril de 2002


Coordenadas para Orientación Relativa

En el fichero de cámara se introducen unas coordenadas para indicarle a Digi3D hacia que zonas debe dirigirse cuando vayamos a realizar la Orientación Relativa. Deben ser Fotocoordenadas (referidas a la imagen izquierda del modelo que se pretende formar) y deben estar en las mismas unidades que el resto de elementos del fichero de cámara.

Se escriben en el fichero de cámara precedidos del sufijo PRel. El siguiente listado de Fotocoordenadas:

    PRel1=0 0
PRel2=90 0
PRel3=90 90
PRel4=0 90
PRel5=0 -90
PRel6=90 -90
PRel7=45 0
PRel8=45 50
PRel9=45 -50

se corresponde con la numeración de este esquema:

Si vas a realizar la Orientación Relativa de varios modelos de forma automática, debes indicar solamente 6 puntos (en la distribución de la figura del 1 al 6). Además debes introducir una coordenada Y que no sea muy grande, con el fin de que no esté cerca del borde del fotograma, pues puede darse el caso de que no encuentre puntos homólogos en la imagen derecha.

Si quieres conocer el formato del archivo de cámara lee el tema de la ayuda Formato del archivo de cámara.

Fecha de última modificación: lunes, 22 de Abril de 2002


Coordenadas para Aerotriangulación

Estas coordenadas se utilizan para que el restituidor digital Digi3D nos ayude a realizar las medidas de Aerotriangulación. Han de llevar el sufijo PAero, deben estar en el sistema de Fotocoordenadas, y en las mismas unidades que en el resto de coordenadas definidas en el fichero de cámara.

Las siguientes coordenadas:

    PAero1=1 0 0
PAero2=2 0 -85
PAero3=3 0 85

corresponden con la siguiente distribución:

Si tenemos 2 pasadas, con tres fotogramas cada una, como es el caso de la siguiente figura:

vemos como la primera pasada está formada por las imágenes 1001, 1002, y 1003, mientras que la segunda pasada la forman los fotogramas 1004, 1005, y 1006. En todos los fotogramas se han marcado (con un punto de color negro) los puntos donde nos llevará el restituidor digital Digi3D cuando realicemos las medidas de Aerotriangulación, en el caso de que el fichero de cámara escribamos las coordenadas con el sufijo PAero como en ejemplo anterior.

Cuando realicemos las medidas de Aerotriangulación, Digi3D aplica una estrategia que nos ayuda a realizar las punterías, incluso entre pasadas contiguas. Si quieres conocer esta estrategia lee el tema de la ayuda Búsqueda de puntos en la medida de Aerotriangulación.

Si quieres conocer el formato del archivo de cámara lee el tema de la ayuda Formato del archivo de cámara.

Fecha de última modificación: viernes, 24 de Abril de 2002


Certificado de calibración de una cámara

Este certificado de calibración se expone aquí a modo de ejemplo para seguir la explicación sobre la creación un archivo de cámara. Este archivo en concreto se compone de varias páginas:

  • Página 1.
  • Página 2.
  • Página 3.
  • Página 4.

Si quieres conocer el formato del archivo de cámara lee el tema de la ayuda Formato del archivo de cámara.

Fecha de última modificación: jueves, 25 de Abril de 2002


Página 1 del Certificado de calibración

  • Página 2.
  • Página 3.
  • Página 4.
  • Seguir la explicación.

Fecha de última modificación: jueves, 25 de Abril de 2002


Página 2 del Certificado de calibración

  • Página 1.
  • Página 3.
  • Página 4.
  • Seguir la explicación.

Fecha de última modificación: jueves, 25 de Abril de 2002


Página 3 del Certificado de calibración

  • Página 1.
  • Página 2.
  • Página 4.
  • Seguir la explicación.

Fecha de última modificación: jueves, 25 de Abril de 2002


Página 4 del Certificado de calibración

  • Página 1.
  • Página 2.
  • Página 3.
  • Seguir la explicación.

Fecha de última modificación: jueves, 25 de Abril de 2002


Orientaciones con Digi3D

En este tema de la ayuda se explica cómo llevar a cabo las orientaciones con Digi3D mediante un ejemplo. Para seguir el ejemplo se debe crear un directorio de trabajo, y en él se deben copiar los siguientes archivos de la carpeta Bronchales:

  • 107.tif: fotograma izquierdo del par.
  • 108.tif: fotograma derecho del par.
  • BRONCHALES.xyz: archivo de puntos, y en él se encuentran los puntos de apoyo.
  • RMK15.cam: archivo de cámara.

Para comenzar con el ejemplo ejecutamos el programa Digi3D, con lo que aparece el cuadro de diálogo Nuevo Proyecto. En él hay dos opciones principales en cuanto a las Orientaciones:

  • Estereoscópico: consiste en trabajar con un par fotogramétrico, por lo que las orientaciones a realizar son: Interna, Relativa y Absoluta. Si quieres ver un ejemplo de cómo hacer las orientaciones de esta forma lee el tema de la ayuda Orientaciones en forma estereoscópica.
  • Monoscópico: consiste en trabajar con un solo fotograma, por lo que las orientaciones a realizar son: Interna y Externa. Si quieres ver un ejemplo de cómo hacer las orientaciones de esta forma lee el tema de la ayuda Orientaciones en forma monoscópica.

Realizadas las orientaciones, el programa está preparado para restituir con DigiNG.

Fecha de última modificación: lunes, 15 de Abril de 2002


Orientaciones en forma estereoscópica

En este tema de la ayuda se explica cómo llevar a cabo las orientaciones si en el cuadro de diálogo Nuevo Proyecto hemos seleccionado la opción Estereoscópico.

En este cuadro de diálogo rellenamos los siguientes campos (todos los archivos de ejemplo están incluidos en el directorio Bronchales):

  • Imagen izquierda: en nuestro ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: en nuestro ejemplo se trata de la imagen 108.tif.
  • Posición de los paneles en este modelo: izquierda en este caso.
  • Recubrimiento: se trata del recubrimiento longitudinal, que en este caso se trata de 60, esto es, 60%.
  • Archivo de puntos: archivo donde se encuentran los puntos de apoyo, que en nuestro ejemplo es BRONCHALES.xyz.
  • Archivo de cámara: el archivo es RMK15.cam.

Si quieres saber algo más acerca de los campos que componen este cuadro de diálogo lee el tema de la ayuda Cuadro de diálogo Nuevo Proyecto.

Pulsamos Abrir en dicho cuadro de diálogo y aparecen las imágenes en la pantalla de visualización estereoscópica. El aspecto de esta pantalla dependerá del tipo de visualización estereoscópica del que se disponga y de la configuración definida. En este ejemplo utilizaremos estereóscopo, por lo que la pantalla de visualización estereoscópica tendrá aspecto similar al siguiente:

Ahora ya estamos en disposición de empezar a realizar las orientaciones, que se deben efectuar en el siguiente orden:

  • Orientación Interna, tanto del fotograma izquierdo como del derecho.
  • Orientación Relativa.
  • Orientación Absoluta.

Realizadas las orientaciones, el programa está preparado para restituir con DigiNG.

Fecha de última modificación: lunes, 15 de Abril de 2002


Orientación Interna

Se puede realizar de dos formas: manual y automática, aunque la Orientación Interna de los fotogramas correspondientes a una pasada siempre debe hacerse de forma manual.

  • Orientación Interna Manual.
  • Orientación Interna Automática.

Una vez hecha la Orientación Interna, tanto del fotograma izquierdo como del derecho, se puede proceder a realizar la Orientación Relativa.

Fecha de última modificación: jueves, 11 de Abril de 2002


Orientación Interna Manual

Cargadas las imágenes, el monitor de visualización estereoscópica presenta el siguiente aspecto:

donde podemos ver en la parte superior las dos imágenes, y en la parte inferior la barra de estado. Como podemos observar no está hecha ninguna orientación, pues están todos los indicadores en minúsculas (i d r a). En este ejemplo comenzamos por la imagen izquierda, para ello tenemos tres opciones:

  • Teclear la orden ORI_INTERNA_I.
  • Pulsar la tecla que tenga configurada la orden ORI_INTERNA_I. Si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor.
  • Seleccionar Orientación Interna Izquierda dentro del menú Herramientas, en la ventana principal de Digi3D.

Ejecutada la orden de Orientación Interna, aparece la siguiente información en la pantalla de visualización estereoscópica:

e idéntica información en la ventana Salida dentro de la ventana principal del restituidor:

Hacemos la puntería a la primera marca fiducial. Se efectúa la puntería bien pulsando cualquier pedal, en el caso de que tu restituidor esté instalado con pedales, o bien con cualquier botón del ratón, en el caso de que tu restituidor esté configurado con un ratón. Hacemos Zoom (mediante las órdenes REST_ZOOMIN y REST_ZOOMOUT), y nos movemos según nos interese para poner el índice en el centro de la marca fiducial.

El programa nos lleva a la zona de la imagen donde están las marcas fiduciales. Esta posición aproximada se define en el fichero de cámara, archivo que en nuestro ejemplo es RMK15.cam.

En este caso tenemos ocho marcas fiduciales, el programa nos irá llevando a la posición aproximada de las mismas, e iremos haciendo las punterías.

En todo momento podemos dejar de hacer la Orientación Interna pulsando las teclas Ctrl + Supr. Sin embargo, al cancelar no se guardarán las punterías efectuadas.

En la versión de Digi3D 2004, mientras que efectuamos las punterías, los resultados del cálculo apareceran simultaneamente en un cuadro de dialogo de la pantalla principal.

Podremos apreciar justo debajo de la tabla de valores, en el lado izquierdo, la media de los resultados.

En la parte inferior del cuadro también se ofrecerán las siguientes opciones:

  • Omitir: pulsando la tecla O podremos omitir alguna de las punterías efectudas.
  • Remedir todos: pulsando la tecla T tendremos la oportunidad de volver a remedir todas las marcas fiduciales.
  • Remedir: pulsando la tecla R. Podremos seleccionar individualmente una puntería que queramos corregir.
  • Borrar: pulsando la tecla B. Podremos borrar alguna de las mediciones.
  • ¿Peor?: pulsando la tecla P, el programa será capaz de decirnos cúal de las 8 punterías ofrece la peor precisión.

Si aceptamos la Orientación Interna la letra i pasa a mayúsculas, I, porque estamos haciendo la Orientación Interna de la imagen izquierda. Si se tratase de la imagen derecha se mostraría una D en lugar de una d.

Los datos de la Orientación Interna quedan salvados en un fichero de extensión INN, y que tiene el mismo nombre que el de la imagen correspondiente. En este ejemplo, la imagen izquierda es 107.tif, y el archivo de Orientación Interna que se guarda 107.inn.

Una vez realizada la Orientación Interna del fotograma izquierdo, podemos repetir este proceso de forma manual para la imagen derecha (con la orden ORI_INTERNA_D), o podemos hacer la Orientación Interna del fotograma derecho de forma automática.

Realizada la Orientación Interna del par de fotogramas, se puede realizar la Orientación Relativa.

-Digi3D Versión 2004-

Fecha de última modificación: 9 de Diciembre de 2003


Orientación Interna Automática

Para poder realizar la Orientación Interna Automática (de una o varias fotografías) debemos haber realizado la Orientación Interna de un fotograma. Es necesario salir del modo gráfico para que estén disponibles las opciones del Menú Herramientas (con la orden SALIR_DIGI3D).

En el menú principal de Digi3D, elegimos Herramientas y después Correlar Internas:

entonces aparece la siguiente ventana:

donde:

  • Imagen de referencia: se trata de la imagen para la que se ha efectuado la Orientación Interna, por lo tanto debe existir el archivo de extensión inn. En este ejemplo se trata de la imagen 107.tif, y su correspondiente archivo de Orientación Interna 107.inn.
  • Archivo de cámara: se debe indicar el archivo de cámara. Si quieres ver una descripción de este tipo de archivo lee el tema de la ayuda Formato del archivo de cámara.
  • Imágenes objetivo: se trata de las imágenes para las que se desea que el programa calcule la Orientación Interna de forma automática. Se pueden incluir varias imágenes a la vez. En este caso es una sola imagen, 108.tif. Hay que tener en cuenta que las imágenes objetivo deben pertenecer, no ya al mismo vuelo y a la misma cámara, sino también a la misma pasada que la imagen de referencia. Esto es debido a que dentro de un mismo vuelo, pueden existir pasadas en un sentido (por ejemplo Este-Oeste), y pasadas en otro sentido (Oeste-Este). Si quieres hacer la Orientación Interna de forma automática de otra pasada en otro sentido distinto, debes hacer primero la Orientación Interna de un fotograma correspondiente a esa pasada, y utilizar dicha Orientación Interna para realizar la Orientación Interna de forma automática del resto de fotogramas de la pasada.
  • Tamaño en píxeles de la marca de referencia: en este caso son aproximadamente 100 píxeles.

En el caso de que se seleccione un archivo de imagen de referencia que no tenga asociado un archivo de interna, Digi3D no carga la imagen y muestra el siguiente mensaje en pantalla:

Una vez seleccionadas la imagen de referencia y la imagen objetivo, pulsamos sobre el botón Calcular. El programa calcula la Orientación Interna de las imágenes objetivo, y muestra el contenido del correspondiente archivo INN, para que el usuario observe los resultados.

Hay que tener en cuenta que el error medio que se obtiene la Orientación Interna de las imágenes objetivo es del mismo orden que el correspondiente a la Orientación Interna de la imagen de referencia.

Realizados todos los cálculos, cerramos la ventana Correlador de orientaciones internas pulsando sobre Cancelar.

El siguiente paso en la realización de Orientaciones en Digi3D corresponde a la Orientación Relativa.

Fecha de última modificación: miércoles, 23 de Octubre de 2002


Orientación Relativa

Realizada la Orientación Interna de un par de fotogramas, pasamos a realizar la Orientación Relativa del par. Hay varias maneras de realizar la Orientación Relativa mediante Digi3D:

  • Con correlación: el programa se encarga de buscar los puntos homólogos. Si quieres seguir el ejemplo con la Orientación Relativa de esta forma lee el siguiente tema de la ayuda. También podemos hacer la Orientación Relativa sin correlación, y entonces se identifican manualmente los puntos homólogos en ambas imágenes.
  • Utilizando estimadores robustos: podemos elegir si aplicar o no estimadores robustos en el cálculo de la Orientación Relativa. Para poder aplicar en el cálculo de la Orientación Relativa tenemos que realizar un gran número de observaciones, para así tener bastantes redundancias en el sistema.
  • Orientación Relativa Automática: el restituidor digital se encarga de hacer la Orientación Relativa. Si quieres seguir el ejemplo con la Orientación Relativa de esta forma lee el tema de la ayuda Orientación Relativa Automática. Puedes hacer también la Orientación Relativa automática de varios modelos a la vez.

Por defecto Digi3D tiene activada la Orientación Relativa mediante correlación y utilizando estimadores robustos en el cálculo. Para elegir la forma de realizar la Orientación Relativa debemos cambiar la Configuración de Digi3D.

La Orientación Relativa Automática es totalmente configurable, en cuanto a número de puntos a medir, valor mínimo de correlación, ... Si quieres saber algo más consulta el tema de la ayuda Cambio de la configuración de la Orientación Relativa Automática.

Una vez hayamos hecho la Orientación Relativa, podemos pasar a efectuar la Orientación Absoluta.

Fecha de última modificación: viernes, 10 de Mayo de 2002


Orientación Relativa con Correlacion

Para ejecutar la orden para realizar Orientación Relativa tenemos tres opciones:

  • Teclear la orden ORI_RELATIVA.
  • Pulsar la tecla que tenga configurada la orden ORI_RELATIVA. Si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor.
  • Seleccionar Orientación Relativa dentro del menú Herramientas, en la ventana principal de Digi3D.

Ejecutada la orden de Orientación Relativa, aparece la siguiente información en la pantalla de visualización estereoscópica:

e idéntica información en la ventana Salida dentro de la ventana principal del restituidor:

El programa nos lleva a una zona de la imagen. Esta posición aproximada se define en el fichero de cámara, archivo que en nuestro ejemplo es RMK15.cam. Por la zona a la que nos lleva el programa buscamos un punto en la imagen izquierda, y aceptamos la puntería. Se acepta la puntería bien pulsando cualquier pedal, en el caso de que tu restituidor esté instalado con pedales, o bien con cualquier botón del ratón, en el caso de que tu restituidor esté configurado con un ratón. En la siguiente imagen vemos la puntería en la imagen izquierda:

y aceptamos la puntería. Ahora el programa automáticamente busca el punto homólogo en la imagen derecha, y nos informa de la correlación obtenida:

Vemos que la correlación es 0.83 (r=0.83). También tenemos las siguientes opciones:

  • Aceptar la puntería: con lo que pasamos a la puntería del segundo punto.
  • Anular este punto (pulsando la tecla Esc): con lo que volvemos a buscar un punto en la imagen izquierda.
  • Cancelar la Orientación Relativa (pulsando Ctrl + Supr): dejamos de hacer la Orientación Relativa.
  • Busca (pulsando la tecla B): nos busca el punto homólogo mediante correlación.

Aceptamos la puntería pulsando cualquier pedal o botón del ratón si está bien posado. En el de caso de que no lo veamos posado tenemos dos posibilidades:

  • Posarnos manualmente en ese punto.
  • Dar a la tecla Esc e intentar corregir el paralaje en un punto cercano a éste, ya que en este punto el correlador no ha sido capaz de posarse correctamente. Esta opción es la más recomendable.

De una u otra forma nos posamos y aceptamos la puntería. Seguimos haciendo punterías a más puntos de igual forma, hasta que se alcance el número de puntos mínimo para iniciar el cálculo de la Orientación Relativa, que se define en la Configuración de la Orientacion Relativa . En este ejemplo es 5 (que también es el número de puntos mínimo para poder realizar el cálculo de la Orientación Relativa), al realizar la puntería al quinto punto podemos observar lo siguiente, tanto en la pantalla de visualización estereoscópica como en la ventana Salida:

donde empezamos a ver las paralajes calculadas. En este momento son "cero" debido a que el programa puede calcular la Orientación Relativa con 5 puntos, sin embargo no puede calcular las paralajes. De hecho, si realizamos la medición correspondiente al punto 6, vemos como empiezan a mostrarse las paralajes calculadas en cada punto:

Hacemos la medición al punto 6 de una forma más rápida porque el programa ya ha calculado unos parámetros de Orientación Relativa. El fichero de cámara correspondiente a nuestro ejemplo tiene configurados 9 puntos para la Orientación Relativa, por lo que seguimos haciendo punterías hasta el último punto, el número 9.

Cuando nos hayamos posado en todos los puntos definidos en el archivo de cámara, tendremos las siguientes opciones:

  • Aceptar (pulsando la tecla Enter): aceptamos la Orientación Relativa sin medir más puntos.
  • Remedir todos (pulsando la tecla R): volvemos a medir todos los puntos.
  • Remedir un punto (pulsando la tecla P): solamente se vuelve a medir un punto. También es posible remedir un punto haciendo doble click con el ratón sobre el punto en la ventana Salida.
  • Añadir un punto (pulsando la tecla A): medimos un punto que no esté definido en el fichero de cámara. Es útil en aquellos casos en los que necesitemos mejorar el modelo estereoscópico en alguna zona.
  • Cancelar relativa (pulsando las teclas Ctrl + Supr): dejamos de calcular la Orientación Relativa.

Cuando medimos el punto 9, que es el último punto que está definido en el fichero de cámara, el programa ya no nos pide que hagamos más punterías, y podemos elegir cualquiera de las opciones anteriores.

Cuando estemos conformes con la Orientación Relativa, pulsamos Enter. Ahora la letra r de la barra de estado pasa de minúsculas a mayúsculas, R, y tenemos un nuevo fichero en el directorio de trabajo que se llama 107-108.rel.

El siguiente paso dentro de las Orientaciones en forma estereoscópica es efectuar la Orientación Absoluta.

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orientación Relativa Automática

Para realizar la Orientación Relativa de forma automática, elegimos Orientación Relativa Automática por Correlación en Digital dentro del menú principal de Digi3D. Para poder hacerlo debemos tener las imágenes cargadas y con la Orientación Interna de cada una realizada, pues de otra forma esta orden estará desactivada (en color gris) y no podremos seleccionarla:

También podemos ejecutar la orden RELATIVA_AUTOMATICA. De cualquiera de las dos formas aparece la siguiente barra de estado:

donde debemos pulsar sobre el botón Comenzar. Entonces empieza a buscar y medir puntos homólogos en las imágenes, y la barra de progreso de esta ventana irá avanzando. En primer lugar aparecerá el mensaje Midiendo puntos por correlación. Cuando termina de buscar y medir, efectúa el cálculo de la Orientación Relativa, con lo que aparece el mensaje Calculando en la ventana de Orientación Relativa por Correlación. Cuando termina de calcular nos muestra una ventana donde podemos ver los resultados del cálculo:

Ya sólo nos queda cerrar esta ventana pulsando la cruz en forma de aspa que está situada en la esquina superior derecha.

Una vez que el restituidor digital Digi3D ha terminado el cálculo, ya está hecha la Orientación Relativa. Ahora la letra r de la barra de estado pasa de minúsculas a mayúsculas, R, y tenemos un nuevo fichero en el directorio de trabajo que se llama 107-108.rel.

La Orientación Relativa Automática es totalmente configurable, en cuanto a número de puntos a medir, valor mínimo de correlación, ... También puedes optar por realizar las Orientaciones Relativas de varios modelos a la vez de forma automática.

El siguiente paso dentro de las Orientaciones en forma estereoscópica es efectuar la Orientación Absoluta.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Orientación Relativa Automática de varios modelos

Con Digi3D podemos realizar las Orientaciones Relativas de varios modelos a la vez de forma automática. Para ello, debemos seleccionar Orientación de relativas dentro de Herramientas en el menú principal de Digi3D:

Entonces aparece esta ventana:

donde los datos son:

  • Cámara: se trata del archivo de cámara, donde deben estar definidos como PRel sólo 6 puntos (recomendamos en la distribución clásica). Puedes recordar la definición de los puntos PRel en el tema de la ayuda Coordenadas para Orientación Relativa. Si pulsas sobre el botón Buscar, se abre un cuadro de diálogo para que elijas el fichero de cámara.
  • Directorio con las fotos: donde se encuentren las imágenes para las que deseamos realizar la Orientación Relativa de forma automática. Si pulsas sobre el botón Buscar se abre un cuadro de diálogo para que selecciones el directorio donde tengas las fotografías. En este directorio es donde se guardarán los archivos resultado del cálculo de la Orientación Relativa.
  • Fotos localizadas: si ya has seleccionado el Directorio con las fotos, en este cuadro aparecen las imágenes existentes en dicho directorio.
  • Modelos formados: si pulsas sobre el botón > verás que pasan las fotos del cuadro Fotos localizadas al cuadro Modelos formados. Debes pasar las imágenes de forma consecutiva en el orden en que formen modelo. En el siguiente ejemplo:

los modelos son 9607-9608 y 9608-9609.Si además tienes varias pasadas, debes separarlas pulsando sobre el botón Pasada. Entonces se escribe un asterisco en Modelos formados, y así indicamos a Digi3D que las fotografías que se indican a continuación pertenecen a otra pasada:

Si te confundes, pulsas sobre el botón Borrar, y vuelves a comenzar. Cuando tengamos todos los modelos formados se pulsa sobre el botón Comenzar. Entonces el programa carga las imágenes del primer modelo (en el ejemplo 9607-9608) y calcula su Orientación Relativa:

presentando al terminar el archivo rel donde se almacenan los resultados (9607-9608.rel en el caso del primer modelo de este ejemplo):

Digi3D sigue calculando y mostrando los resultados hasta que termina de calcular todos los modelos.

Fecha de última modificación: viernes, 10 de Mayo de 2002


Repetir un punto en la Orientación Relativa

Cuando estamos dentro del menú de Orientación Relativa, y queremos repetir un punto, pulsamos la tecla P, y el programa pregunta el número de punto queremos volver a medir:

y Digi3D nos lleva al punto donde hicimos la anterior puntería para que la repitamos.

Fecha de última modificación: lunes, 15 de Abril de 2002


Añadir un punto en la Orientación Relativa

Si queremos añadir un punto, pulsamos la tecla A cuando estemos en el menú de Orientación Relativa, y directamente el programa nos pide que hagamos la puntería. Supongamos que el fichero de cámara del ejemplo tenemos 9 puntos para la Orientación Relativa (con el sufijo PRel), el programa autonumera al añadir un punto, por lo que el siguiente punto es el número 10:

Fecha de última modificación: viernes, 19 de Abril de 2002


Orientación Absoluta

Realizada la Orientación Relativa de un par de fotogramas, pasamos a realizar la Orientación Absoluta del par. Digi3D ayuda al usuario a realizar la Orientación Absoluta de varias formas:

  • Correlación en la Orientación Absoluta: para activar/desactivar la correlación en la Orientación Absoluta debemos cambiar la Configuración de Digi3D.
  • Búsqueda de los puntos de apoyo.

Si quieres seguir el ejemplo haciendo la Orientación Absoluta lee el siguiente tema de la ayuda.

Puedes aprender a generar reseñas mediante Digi3D leyendo el tema de la ayuda Generador de reseñas.

Realizadas las orientaciones, el programa está preparado para restituir con DigiNG.

Fecha de última modificación: viernes, 19 de Abril de 2002


Orientación Absoluta del primer par

Para realizar la Orientación Absoluta es necesario tener un archivo que contenga los puntos de apoyo. En este ejemplo ya lo hemos incluido en el cuadro de diálogo de Nuevo Proyecto, y se trata del archivo BRONCHALES.xyz.

Con las imágenes cargadas, podemos comenzar a realizar la Orientación Absoluta de tres formas distintas:

  • Teclear la orden ORI_ABSOLUTA.
  • Pulsar la tecla que tenga configurada la orden ORI_ABSOLUTA. Si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor.
  • Seleccionar Orientación Absoluta dentro del menú Herramientas, en la ventana principal de Digi3D.

Ejecutada la orden de Orientación Absoluta, aparece la siguiente información tanto en la pantalla de visualización estereoscópica:

como en la ventana Salida en la pantalla del menú principal:

donde podemos introducir el número que identifica al punto de apoyo. Tenemos opción a anular la orden introduciendo como número de punto 0, y también tenemos opción a cancelar la Orientación Absoluta pulsando las teclas Ctrl + Supr.

Si quieres ver donde están los puntos de apoyo acude al tema de la ayuda Apoyo para la Orientación Absoluta.

Introducimos 5 como número de punto. El programa coge las Coordenadas Terreno del fichero de puntos, y espera a que efectuemos el posado:

Ahora buscamos el punto 5 en la imagen, y luego nos posamos sobre él. Los movimientos en Z para efectuar el posado se pueden realizar:

  • Utilizando el pedal de Z, en el caso de que tu restituidor esté instalado con pedales y manivelas.
  • Con la rueda superior del ratón, si es que éste la tiene y además has utilizado la orden RATON_DIGI3D para asociar los movimientos del ratón a los de las imágenes.

Una vez posados en el punto 5, lo aceptamos. El programa nos pide ahora el siguiente punto de apoyo, que en nuestro ejemplo se trata del punto de apoyo que se identifica con el número 7. Hacemos lo mismo que con el punto 5: lo buscamos, nos posamos y luego lo aceptamos.

Digi3D determina ahora cuál es el siguiente punto de apoyo de los que se encuentran en el fichero de puntos, y nos lleva a él pues ya ha conseguido calcular una Orientación Absoluta aproximada. En este ejemplo es el punto 3. Nos podemos posar en él o no, pues si ahora pulsamos la tecla Esc, el programa lee el siguiente punto que encuentra en el archivo de puntos, determina por coordenadas si está en ambos fotogramas, y si así es, nos lleva a él. En caso de que el punto no esté en los fotogramas, pasa a leer el siguiente punto dentro del archivo de puntos.

Una vez hecho el posado en el tercer punto, Digi3D nos muestra los errores que se tienen hasta ahora el cálculo de la Orientación Absoluta:

Cuando estemos posados en el tercer punto, aceptamos el posado. Haremos el posado en los puntos de apoyo que consideremos. En este ejemplo nos posamos en los siguientes puntos (y además por este orden): 5, 7, 3, 4, y 6. Una vez que hayamos hecho el posado, aparece lo siguiente:

donde tenemos las siguientes opciones en el menú de Orientación Absoluta:

  • Aceptar la Orientación Absoluta (pulsando la tecla Enter).
  • Cancelar (pulsando la teclas Ctrl + Supr): para dejar de hacer la Orientación Absoluta y no guardar nada.
  • Remedir/Añadir (pulsando la tecla R). También es posible remedir un punto haciendo doble click con el ratón sobre el punto en la ventana Salida.
  • Sólo XY (pulsando la tecla X).
  • Sólo Z (pulsando la tecla Z).
  • Quitar (pulsando la tecla Q).
  • Recalcular Todos (pulsando la tecla C): el programa vuelve a efectuar el cálculo considerando todas las coordenadas de los puntos.

Cuando estemos de acuerdo con la Orientación Absoluta, aceptamos ésta pulsando la tecla Enter. Si hacemos ahora un zoom para ver las imágenes completas, mediante la orden Rest_ZoomE:

Entonces vemos varios cambios:

  • En la barra de estado cambia la letra a minúscula por la letra A mayúscula, que nos informará en adelante de que tenemos la Orientación Absoluta ya realizada.
  • Vemos los círculos que nos señalan donde están los puntos de apoyo medidos, y también vemos la numeración de dichos puntos. Si quieres saber cómo modificar la configuración de estos círculos lee el tema de la ayuda Configuración de la Aerotriangulación.
  • En la barra de estado la Escala indica 1:1201, que es la escala con la que se ve el modelo estereoscópico.

Se graban varios archivos al aceptar la Orientación Absoluta:

  • 107-108.abs: en este fichero se guardan los parámetros de la Orientación Absoluta. Se guarda en el directorio de trabajo.
  • 107.ori: en este fichero se almacenan los datos de las Orientaciones Interna y Externa de la imagen 107. Se guarda en el directorio de trabajo.
  • 108.ori: en este fichero se almacenan los datos de las Orientaciones Interna y Externa de la imagen 108. Se guarda en el directorio de trabajo.
  • 107.f: en este fichero se guardan las Fotocoordenadas de los puntos de apoyo medidos. Las Fotocoordenadas son las correspondientes a esta imagen. Se guarda en el directorio de Aerotriangulación.
  • 108.f: en este fichero se guardan las Fotocoordenadas de los puntos de apoyo medidos. Las Fotocoordenadas son las correspondientes a esta imagen. Se guarda en el directorio de Aerotriangulación.
  • Instantáneas: se guardan en archivos de imagen en formato BMP. Se almacenan dos copias de cada instantánea: una en el directorio de Instantáneas, con una cruz en el punto de apoyo, pues están pensadas para generar las reseñas; y la otra en el directorio de Aerotriangulación para realizar las búsquedas.

Los archivos con extensión ORI se graban por defecto. Se utilizan para visualizar las imágenes con DigiNG.

Ahora el programa está preparado para restituir con DigiNG.

Puedes seguir el ejemplo realizando tú mismo las Orientaciones correspondientes al par fotogramétrico 108-109. Así puedes ver la rapidez con la que se orienta con Digi3D, pues se obtiene rendimiento de las Orientaciones de los modelos anteriores.

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Remedir/Añadir un punto en la Orientación Absoluta

Para Remedir/Añadir un punto, en el menú de Orientación Absoluta pulsamos la tecla R. Entonces aparece lo siguiente:

donde tenemos tres alternativas:

  • Introducir el número de punto a remedir, si ya hemos hecho un posado sobre él. También puede ser el número de un punto a añadir, en el caso de que aún no nos hayamos posado en él o en el caso de que lo hayamos quitado del cálculo.
  • Salir al menú de Orientación Absoluta, esto es, volver al menú anterior. Se hace introduciendo como número de punto el 0, o bien pulsando la tecla Esc.
  • Cancelar la Orientación Absoluta pulsando las teclas Ctrl + Supr.

Si por ejemplo, queremos remedir el punto 6, al introducir el número de punto el programa nos lleva al punto 6. El punto aparece rodeado por un círculo, y con la numeración sobreimpresa en el fotograma:

La configuración del círculo y de la numeración se puede modificar en la Configuración de Areotriangulación. Nos posaremos de nuevo sobre este punto y aceptaremos. Entonces volvemos al menú de Orientación Absoluta.

Puede haber algún caso en que no podamos posarnos en Z en el punto, por ejemplo si el punto de apoyo está definido en planta en la esquina de una casa, y en cota en el terreno. Cuando vayamos a posarnos en este punto de apoyo (en el ejemplo el número 25) para realizar la Orientación Absoluta, puede darse el caso de que no podamos posarnos en la esquina de la casa a ras de suelo, porque el tejado de la propia casa nos lo impide. Para ello se introduce el número de punto con un signo menos delante, esto es, -25. Entonces nos pide que nos posemos solamente en X e Y, lo que en el ejemplo de la casa correspondería a la esquina de la casa pero en el tejado:

Aceptamos este posado, y luego nos pide que nos posemos sólo en Z:

que en el ejemplo de la casa correspondería a posarse en el terreno, al lado de la esquina.

Fecha de última modificación: jueves, 18 de Abril de 2002


Quitar un punto en la Orientación Absoluta

Para quitar un punto, en el menú de Orientación Absoluta pulsamos la tecla Q. Entonces el programa nos pide el número de punto que queremos quitar:

Introducimos, por ejemplo, el número 6, y se desactiva este punto del cálculo:

Para volver a incluir el punto 6 en el cálculo debemos añadir el punto en el menú de Orientación Absoluta.

Fecha de última modificación: martes, 16 de Abril de 2002


Remedir sólo en X e Y un punto en la Orientación Absoluta

Para Remedir sólo en X e Y un punto, en el menú de Orientación Absoluta pulsamos la tecla X. Nos pide el número de punto, por ejemplo el número 5. Entonces aparece lo siguiente:

Con esto conseguimos que para el punto 5 se considere para el cálculo solamente las Coordenadas Terreno X y la Y. Si queremos que vuelva a entrar en el cálculo, lo que tenemos que hacer es recalcular todos (pulsando la letra C).

Fecha de última modificación: miércoles, 17 de Abril de 2002


Remedir sólo en Z un punto en la Orientación Absoluta

Para remedir un punto sólo en Z, en el menú de Orientación Absoluta pulsamos la tecla Z. Nos pide el número de punto, por ejemplo el número 5. Entonces aparece lo siguiente:

Con esto conseguimos que para el punto 5 se considere para el cálculo solamente la Coordenada Terreno Z. Si queremos que vuelva a entrar en el cálculo, lo que tenemos que hacer es Recalcular todos (pulsando la letra C).

Fecha de última modificación: miércoles, 17 de Abril de 2002


Orientaciones del segundo par

Ya hemos orientado el par fotogramétrico correspondiente a las imágenes 107 y 108. Ahora puedes realizar las orientaciones correspondientes al siguiente par del vuelo. Para ello, puedes seguir el siguiente esquema que te ayudará a sacar máximo partido de Digi3D:

  • En primer lugar, define un nuevo modelo estereoscópico.
  • Luego puedes hacer la Orientación Interna de forma automática, aprovechando que ya la has hecho para las otras dos imágenes. Si no te acuerdas de cómo hacer la Orientación Interna de forma automática lee el tema de la ayuda Orientación Interna Automática.
  • Haz la Orientación Relativa con ayuda de la correlación. Recuerda que puedes añadir más puntos si quieres mejorar la formación del modelo estereoscópico. Si no te acuerdas de cómo hacer la Orientación Relativa con correlación lee el tema de la ayuda Orientación Relativa con Correlación.
  • Por último, realiza la Orientación Absoluta del par 108-109 aprovechando la búsqueda de puntos de apoyo que te ofrece Digi3D.

Cuando hayas orientado el par 108-109, el programa está preparado para restituirlo con DigiNG.

Fecha de última modificación: martes, 16 de Abril de 2002


Definición del nuevo modelo estereoscópico

Desde Digi3D abrimos el cuadro de diálogo de Nuevo proyecto, bien desde el menú principal de Digi3D o con la combinación de teclas Ctrl+N:

que como vemos contiene los datos del modelo anterior, pues la imagen izquierda es la 107, y la imagen derecha es la 108. Los datos del modelo siguiente, que corresponde a las imágenes 108 y 109, son los mismos a excepción de las propias imágenes. En el modelo 108-109 la imagen izquierda es la 108, que en el modelo anterior era la derecha. Para establecer la imagen 108 como imagen izquierda solamente tenemos que pulsar sobre el botón:

y tendremos como imagen izquierda la 108:

Sólo queda incluir como imagen derecha la 109:

Ya tenemos el nuevo modelo configurado, pulsamos sobre el botón Abrir y podemos empezar a realizar las Orientaciones. Ahora vemos en la pantalla de visualización estereoscópica que la Orientación Interna del fotograma izquierdo (108) está hecha:

pues en la barra de estado se puede ver que la letra que nos informa del estado de dicha Orientación está realizada. Lo normal ahora es salir del modo gráfico, con la orden SALIR_DIGI3D o pulsando la tecla donde hayamos configurado esta orden, y realizar la Orientación Interna del fotograma derecho de forma automática.

Fecha de última modificación: martes, 16 de Abril de 2002


Orientación Absoluta del par 108-109

Hechas las Orientaciones anteriores, si tecleamos la orden REST_ZOOME, tendremos un visión completa de las dos imágenes en el monitor estereoscópico:

donde podemos ver en la imagen de la izquierda (108) los círculos que identifican a los puntos de apoyo, además con la numeración correspondiente. Vemos como los puntos de apoyo 3 y 4 no entran en el modelo estereoscópico formado por las imágenes 108 y 109. Si queremos ver las imágenes con un zoom de 1x1, tecleamos la orden Rest_Zoom1x1.

Para hacer la Orientación Absoluta disponemos de tres posibilidades:

  • Teclear la orden ORI_ABSOLUTA.
  • Pulsar la tecla que tenga configurada la orden ORI_ABSOLUTA. Si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor.
  • Seleccionar Orientación Absoluta dentro del menú Herramientas, en la ventana principal de Digi3D.

Ejecutada la orden, el programa nos pide el número de punto de apoyo donde nos vayamos a posar, por ejemplo, el número 5. El programa nos lleva al punto 5 de la siguiente forma:

donde observamos novedades con respecto a la primera Orientación Absoluta:

  • En la imagen izquierda, además del círculo y la numeración del punto de apoyo, vemos como la marca flotante está en el punto de apoyo.
  • En la imagen derecha también está sobre el punto de apoyo.
  • Aparece una imagen más pequeña en la parte inferior derecha de la pantalla, y es la instantánea que se tomó al efectuar el posado estereoscópico sobre el punto 5 en el modelo 107-108. Con esta instantánea sabemos donde posamos el punto en el modelo anterior.
  • En la barra de esta (la última línea), podemos leer: pY=0.003 r=0.70, que se corresponden respectivamente con la paralaje y la correlación para ese punto.

Las posibilidades para realizar la Orientación Absoluta se amplían:

  • Podemos digitalizar el punto si vemos que ya está posado estereoscópicamente.
  • Podemos movernos sólo en Z. Se queda fija la marca flotante en la imagen izquierda, y se mueve en Z la marca flotante correspondiente al fotograma derecho. Así nos aseguramos de que ese punto ha sido medido en las mismas Fotocoordenadas (correspondientes a la imagen 108) en los dos modelos.
  • Podemos desbloquear el punto si queremos pulsando la tecla Esc. Entonces la forma de efectuar el posado estereoscópico es igual que en la primera Orientación Absoluta, es decir, mediante los movimientos en X, Y, Z. Si no desbloqueamos el punto, el único movimiento que podemos efectuar es el correspondiente al pedal Z.
  • Se puede buscar por correlación en la imagen izquierda pulsando la tecla B. Si está activada la correlación para la Orientación Absoluta, ya estará hecha esta búsqueda.
  • Podemos cancelar la Orientación Absoluta pulsando las teclas Ctrl+Supr.
  • Tenemos la posibilidad de sobreescribir la instantánea que se nos muestra en la parte inferior derecha.

Nos posamos sobre el punto 5 en la forma que mejor nos convenga, y aceptamos el posado. Nos pide el siguiente punto de apoyo, y escribimos el punto 6. Hacemos el posado de forma rápida, pues nos lleva a él y nos vuelve a ofrecer todas las opciones anteriores para que efectuemos el posado en el punto de la forma que nos resulte más cómoda y eficiente. El siguiente punto ya no nos lo pide, sino que nos lleva directamente al punto 7, y nos pide que hagamos el posado. En caso de que no queramos hacer el posado en el punto 7, pulsamos la tecla Esc, y el programa nos lleva al siguiente punto de apoyo que entre en el modelo. En este ejemplo corresponde con el punto número 8.

El programa lee el archivo de puntos (donde están las Coordenadas Terreno de los puntos de apoyo) y sabe qué puntos entran en el modelo, por lo que no nos llevará a los puntos 3 y 4, ni tampoco a los restantes puntos de apoyo que se encuentren en el archivo de puntos.

Si seguimos haciendo la Orientación Absoluta, haremos el posado en el punto de apoyo número 7. El siguiente punto que Digi3D encuentra en el archivo de puntos y que además calcula que entra en el modelo 108-109, es el punto 8, y nos lleva a él. En este punto ya no tenemos tantas opciones para posarnos como en los puntos anteriores. Esto es debido a que en el anterior modelo no nos posamos en este punto, dado que no entraba en él. Aún así el programa nos lleva al punto 8 gracias a que ya ha calculado la Orientación Absoluta de forma aproximada. Después haremos (o no) el posado en los restantes puntos de apoyo que entran en este modelo, que son los puntos 9 y 10.

Ahora ya tenemos el modelo 108-109 preparado para restituirlo con DigiNG.

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Generador de Reseñas

En el menú principal de Digi3D seleccionamos Generador de reseñas en el apartado Herramientas:

Entonces aparece la siguiente ventana:

donde podemos generar las reseñas. Para ello debemos tener:

  • Archivo de puntos con las Coordenadas Terreno. Si quieres ver la descripción de este tipo de archivos lee el tema de la ayuda Formato del archivo de puntos.
  • Archivo de descripciones de los puntos. Debe tener el mismo nombre que el fichero de puntos, y extensión des. Si quieres conocer el formato de este tipo de archivos lee el tema de la ayuda Formato del archivo de descripciones.
  • Instantáneas de los puntos, con las características definidas en la Configuración de instantáneas.

Los campos de la ventana se rellenan de la siguiente manera:

  • Archivo de puntos: se trata del archivo donde se encuentran las Coordenadas Terreno de los puntos.
  • Puntos: En el rectángulo blanco de la izquierda aparecen los puntos de los que tengamos instantánea y que además estén en el archivo de puntos. La forma de incluirlos en la reseña es señalándolos con el puntero de ratón, y pasándolos al rectángulo blanco de la derecha. Se puede pasar todos a la vez si queremos.
  • Archivo de plantilla: se trata de un archivo, con extensión PR (Plantilla de Reseña), que tiene el formato de las reseñas a generar. Se incluye un archivo de estas características, Tablas azules.pr, en la carpeta Plantillas. Está escrito en HTML, luego es fácil de personalizar. Si quieres conocer más sobre este tema lee el siguiente tema de la ayuda.
  • Título: es el título del archivo HTML que se genera.
  • Nombre del archivo a generar: escribimos el nombre de archivo HTML que queramos, por ejemplo Apoyo.

Luego la ventana de Generador de reseñas queda de la siguiente forma:

Pulsamos sobre el botón Generar. Entonces se crea un archivo en formato HTML en el directorio correspondiente a las instantáneas con las reseñas. Para cerrar esta ventana podemos pulsar sobre el botón Cancelar, o bien podemos pulsar sobre la cruz en forma de aspa que se encuentra en la esquina superior derecha de la ventana.

En el caso de que se traten de puntos de Aerotriangulación, y se hayan escrito las descripciones de dichos puntos, se tomarán estas descripciones para incluirlas en la reseña generada.

Si quieres ver el archivo Apoyo.html lee el tema de la ayuda Apoyo.

Fecha de última modificación: viernes, 18 de Octubre de 2002


Apoyo para la Orientación Absoluta

Esta es la imagen 108, donde puedes ver los puntos de apoyo de los modelos 107-108 y 108-109.

Puedes ver las reseñas creadas por el Generador de Reseñas de Digi3D en el tema de la ayuda Apoyo.

Fecha de última modificación: viernes, 19 de Abril de 2002


Apoyo

Digi3D

Apoyo.html

Nº de punto | 3
Fotograma |
Descripción |
X | Y | Z
619215.468 | 4485537.355 | 1573.802

Nº de punto | 4
Fotograma |
Descripción |
X | Y | Z
619173.900 | 4485177.298 | 1577.095

Nº de punto | 5
Fotograma |
Descripción |
X | Y | Z
619683.262 | 4485643.336 | 1593.088

Nº de punto | 6
Fotograma |
Descripción |
X | Y | Z
619505.093 | 4485329.173 | 1582.302

Nº de punto | 7
Fotograma |
Descripción |
X | Y | Z
619567.940 | 4485076.883 | 1609.768

Nº de punto | 8
Fotograma |
Descripción |
X | Y | Z
620097.282 | 4485672.614 | 1554.958

Nº de punto | 9
Fotograma |
Descripción |
X | Y | Z
620144.153 | 4485309.845 | 1550.214

Nº de punto | 10
Fotograma |
Descripción |
X | Y | Z
620085.090 | 4484804.750 | 1570.968

Fecha de última modificación: viernes, 19 de Abril de 2002


Búsqueda de puntos de apoyo en la Orientación Absoluta

Cuando el programa efectúa la Orientación Absoluta, en primer lugar nos pide el número que identifica al punto de apoyo en el fichero de puntos. Lee en dicho archivo las Coordenadas Terreno del punto de apoyo. Después, Digi3D busca el punto de apoyo siguiendo varias alternativas:

  1. Si ya se ha hecho el posado en 2 o más puntos, el programa calcula una Orientación Absoluta aproximada y sitúa la marca flotante sobre el punto.
  2. Si no se ha hecho ningún posado, o sólo se ha hecho en 1 punto, el programa no puede calcular la Orientación Absoluta. Sin embargo, busca el fichero de Fotocoordenadas (con extensión f), en el directorio donde se almacenan las instantáneas o en el directorio de Aerotriangulación. Si lo encuentra, carga las Fotocoordenadas y nos lleva al punto en el fotograma. Además, si tenemos activada la correlación en la Configuración de Digi3D, el programa busca el punto de apoyo por correlación en el otro fotograma del modelo.
  3. Si no tiene el fichero de Fotocoordenadas, busca el archivo con la instantánea del punto de apoyo en el directorio de Aerotriangulación. Este archivo de instantánea contiene una imagen, y lo que hace el programa es buscar por correlación esta instantánea en el fotograma.
  4. Si el programa no puede realizar ninguna de las alternativas anteriores, corresponde al usuario buscar el punto de apoyo en los fotogramas.

Fecha de última modificación: martes, 16 de Abril de 2002


Correlación en la Orientación Absoluta

Digi3D ayuda a realizar la Orientación Absoluta utilizando correlación. Cuando el programa busca un punto de apoyo, lo busca en un fotograma. Si queremos que además nos busque dicho punto de apoyo en el otro fotograma del par, debemos tener activada la correlación para la Orientación Absoluta en la Configuración de Digi3D. Esto no significa que la Orientación Absoluta sea automática, pues debemos realizar el posado estereoscópicamente. Sin embargo, implica un gran ahorro de tiempo cuando realicemos la Orientación Absoluta.

Fecha de última modificación: martes, 16 de Abril de 2002


Orientaciones en forma monoscópica

En este tema de la ayuda se explica cómo llevar a cabo las Orientaciones si en el cuadro de diálogo Nuevo Proyecto hemos seleccionado Monoscópico. En dicho cuadro de diálogo:

rellenamos los siguientes campos (todos los archivos de ejemplo están incluidos en la carpeta Bronchales):

  • Imagen: en nuestro ejemplo se trata de la imagen 107.tif.
  • Posición de los paneles en este modelo: izquierda.
  • Archivo de puntos: archivo donde se encuentran los puntos de apoyo, que en nuestro ejemplo es BRONCHALES.xyz.
  • Archivo de cámara: el archivo es RMK15.cam.

Si quieres saber algo más acerca de los campos que componen este cuadro de diálogo lee el tema de la ayuda Cuadro de diálogo Nuevo Proyecto. Pulsamos en Abrir y aparece en la pantalla de visualización estereoscópica la imagen 107.tif.

Ahora ya estamos en disposición de empezar a realizar las orientaciones, que se deben efectuar en el siguiente orden:

  • Orientación Interna.
  • Orientación Externa.

Fecha de última modificación: viernes, 19 de Abril de 2002


Orientación Interna

Se puede realizar de dos formas: manual y automática. Para hacer la Orientación Interna de un fotograma debes haber hecho antes una Orientación Interna de forma manual a otro fotograma del mismo vuelo y de la misma pasada.

  • Orientación Interna Manual.
  • Orientación Interna Automática.

Una vez hecha la Orientación Interna se puede proceder a realizar la Orientación Externa.

Fecha de última modificación: viernes, 19 de Abril de 2002


Orientación Interna Manual

Cargada la imagen, el monitor de visualización estereoscópica presenta el siguiente aspecto:

donde podemos ver en la parte superior la imagen, y en la parte inferior la barra de estado. Como podemos observar no está hecha ninguna orientación, pues están todos los indicadores en minúsculas (i e). Debemos comenzar por la Orientación Interna, para ello tenemos tres opciones:

  • Teclear la orden ORI_INTERNA_I.
  • Pulsar la tecla que tenga configurada la orden ORI_INTERNA_I. Si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor.
  • Seleccionar Orientación Interna Izquierda dentro del menú Herramientas, en la ventana principal de Digi3D.

Ejecutada la orden de Orientación Interna, aparece la siguiente información en la pantalla de visualización estereoscópica:

y en la ventana Salida dentro de la ventana principal del restituidor:

Hacemos la puntería a la primera marca fiducial. Se efectúa la puntería bien pulsando cualquier pedal, en el caso de que tu restituidor esté instalado con pedales, o bien con cualquier botón del ratón, en el caso de que tu restituidor esté configurado con un ratón. Hacemos Zoom (mediante las órdenes REST_ZOOMIN y REST_ZOOMOUT), y nos movemos según nos interese para poner el índice en el centro de la marca fiducial.

El programa nos lleva a la zona de la imagen donde están las marcas fiduciales. Esta posición aproximada se define en el fichero de cámara, archivo que en nuestro ejemplo es RMK15.cam.

En este caso tenemos ocho marcas fiduciales, el programa nos irá llevando a la posición aproximada de las mismas, e iremos haciendo las punterías.

En todo momento podemos dejar de hacer la Orientación Interna pulsando las teclas Ctrl + Supr, pero no se guardarán las punterías efectuadas.

Realizadas las punterías a todas las marcas fiduciales que están incluidas en el fichero de cámara, el programa presenta los resultados del cálculo:

tanto en la pantalla de visualización estereoscópica como en la ventana Salida dentro de la ventana principal del restituidor. Además, da opción a:

  • Aceptar la Orientación Interna: pulsando la tecla Enter.
  • Repetir todas las punterías: pulsando la tecla R.
  • Cancelar la Orientación Interna: pulsando las teclas Ctrl + Supr. El programa no guarda ninguna puntería y sale de la Orientación Interna.

Si aceptamos la Orientación Interna la letra i pasa a mayúsculas, I porque estamos haciendo la Orientación Interna de la imagen izquierda. Si se tratase de la imagen derecha se mostraría una D en lugar de una d.

Los datos de la Orientación Interna quedan salvados en un fichero de extensión INN, y que tiene el mismo nombre que el de la imagen correspondiente. En este ejemplo, la imagen izquierda es 107.tif, y el archivo de Orientación Interna que se guarda 107.inn.

Una vez realizada la Orientación Interna del fotograma, podemos hacer la Orientación Interna de otros fotogramas de forma automática. Para ello estos fotogramas deben pertenecer al mismo vuelo y a la misma pasada que el fotograma 107. Es el caso de la imagen 108.tif.

Realizada la Orientación Interna del par de fotogramas, se puede realizar la Orientación Externa.

Fecha de última modificación: lunes, 11 de noviembre de 2002


Orientación Interna Automática

Para poder realizar la Orientación Interna Automática (de una o varias fotografías) debemos haber realizado previamente la Orientación Interna Manual de un fotograma del mismo vuelo y de la misma pasada. Es necesario salir del modo gráfico (con la orden SALIR_DIGI3D), para que estén disponibles las opciones del menú Herramientas .

En el menú principal de Digi3D, elegimos Herramientas y después Correlar Internas:

Entonces aparece la siguiente ventana:

donde:

  • Imagen de referencia: se trata de la imagen para la que se ha efectuado la Orientación Interna, por lo tanto debe existir el archivo de extensión inn. En este ejemplo se trata de la imagen 107.tif y su correspondiente archivo de Orientación Interna 107.inn.
  • Archivo de cámara: se debe indicar el archivo de cámara. Si quieres ver una descripción de este tipo de archivo lee el tema de la ayuda Formato del archivo de cámara.
  • Imágenes objetivo: se trata de las imágenes para las que se desea que el programa calcule la Orientación Interna de forma automática. Se pueden incluir varias imágenes a la vez. En este caso es una sola imagen, 108.tif. Hay que tener en cuenta que las imágenes objetivo deben pertenecer, no ya al mismo vuelo y a la misma cámara, sino también a la misma pasada que la imagen de referencia. Esto es debido a que dentro de un mismo vuelo, pueden existir pasadas en un sentido (por ejemplo Este-Oeste), y pasadas en otro sentido (Oeste-Este). Si quieres hacer la Orientación Interna de forma automática de otra pasada en otro sentido distinto, debes hacer primero la Orientación Interna de un fotograma correspondiente a esa pasada, y utilizar dicha Orientación Interna para realizar la Orientación Interna de forma automática del resto de fotogramas de la pasada.
  • Tamaño en píxeles de la marca de referencia: en este caso son aproximadamente 100 píxeles.

Una vez seleccionadas la imagen de referencia y la imagen objetivo, pulsamos sobre el botón Calcular. El programa calcula la Orientación Interna de las imágenes objetivo, y muestra el contenido del correspondiente archivo INN, para que el usuario observe los resultados.

Hay que tener en cuenta que el error medio que se obtiene la Orientación Interna de las imágenes objetivo es del mismo orden que el correspondiente a la Orientación Interna de la imagen de referencia.

Realizados todos los cálculos, cerramos la ventana Correlador de orientaciones internas pulsando sobre Cancelar.

El siguiente paso en la realización de Orientaciones en forma monoscópica en Digi3D corresponde a la Orientación Externa.

Fecha de última modificación: miércoles, 23 de Octubre de 2002


Orientación Externa

Con la imagen cargada, tecleamos la orden ORI_EXTERNA, o bien la tecla que tenga configurada esta orden (si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor). Ejecutada la orden de Orientación Externa, aparece la siguiente información en la pantalla de visualización estereoscópica:

donde podemos introducir el número que identifica al punto de apoyo. Tenemos opción a anular la orden introduciendo como número de punto 0, y también tenemos opción a cancelar la Orientación Externa pulsando las teclas Ctrl + Supr.

Si quieres ver donde están los puntos de apoyo lee el tema de la ayuda Apoyo para la Orientación Absoluta.

Introducimos 5 como número de punto. El programa toma las coordenadas del fichero de puntos, y espera a que efectuemos el posado:

Ahora buscamos el punto 5 en la imagen, y luego nos posamos sobre él.

Una vez posados en el punto 5, lo aceptamos. El programa nos pide ahora el siguiente punto de apoyo, que en nuestro ejemplo se trata del punto de apoyo que se identifica con el número 7. Hacemos lo mismo que con el punto 5: lo buscamos, nos posamos y luego lo aceptamos.

Digi3D determina ahora cuál es el siguiente punto de apoyo de los que se encuentran en el fichero de puntos, y nos lleva a él pues ya ha conseguido calcular una Orientación Externa aproximada. En este ejemplo es el punto 3. Nos podemos posar en él o no, pues si ahora pulsamos la tecla Esc, el programa lee el siguiente punto que encuentra en el archivo de puntos, determina por coordenadas si está en el fotograma, y si así es, nos lleva a él. En caso de que el punto no esté en el fotograma, pasa a leer el siguiente punto dentro del archivo de puntos.

Mientras estamos haciendo el posado en el tercer punto, Digi3D nos muestra los resultados en tiempo real (en el caso de que tengamos así configurada la Orientación Externa):

Cuando estemos posados en el tercer punto, aceptamos el posado. Haremos el posado en los puntos de apoyo que consideremos. En este ejemplo nos posamos en los siguientes puntos (y además por este orden): 5, 7, 3, 4, y 6. Una vez que hayamos hecho el posado, aparece lo siguiente:

donde tenemos las siguientes opciones en el menú de Orientación Externa:

  • Aceptar la Orientación Externa (pulsando la tecla Enter).
  • Cancelar (pulsando la teclas Ctrl + Supr): para dejar de hacer la Orientación Externa y no guardar nada.
  • Remedir/Añadir (pulsando la tecla R): para volver a medir un punto o para añadir otro (siempre que esté en el fichero de puntos).
  • Quitar (pulsando la tecla Q): quitar un punto del cálculo de la Orientación Externa.
  • Activar Todos (pulsando la tecla C): el programa vuelve a efectuar el cálculo considerando las coordenadas de todos los puntos.

Cuando estemos de acuerdo con los resultados Orientación Externa, aceptamos ésta pulsando la tecla Enter. Entonces vemos varios cambios en la barra de estado:

  • Cambia la letra e minúscula por la letra E mayúscula, que nos informará en adelante de que tenemos la Orientación Externa ya realizada.
  • Vemos los círculos que nos señalan donde están los puntos de apoyo medidos, y también vemos la numeración de dichos puntos. Si quieres saber cómo modificar la configuración de estos círculos lee el tema de la ayuda Configuración de la Aerotriangulación.
  • Vemos como la Escala indica 1:1201, que es la escala con la que se ve el modelo estereoscópico.

Ahora el programa está preparado para restituir con DigiNG.

Se graban varios archivos al aceptar la Orientación Externa:

  • 107.ori: en este fichero se almacenan los datos de las Orientaciones Interna y Externa de la imagen 107. Se guarda en el directorio de trabajo.
  • 107.f: en este fichero se guardan las fotocoordenadas de los puntos de apoyo medidos. Las fotocoordenadas son las correspondientes a esta imagen. Se guarda en el directorio de Aerotriangulación.
  • Instantáneas: se guardan en archivos de imagen en formato BMP. Se almacenan dos copias de cada instantánea: una en el directorio de Instantáneas, con una cruz en el punto de apoyo, pues están pensadas para generar las reseñas; y la otra en el directorio de Aerotriangulación para realizar las búsquedas.

Los archivos con extensión ORI se graban por defecto. Se utilizan con el programa Digi21 para calcular las Ortofotografías.

Fecha de última modificación: viernes, 19 de Abril de 2002


Medida de Aerotriangulación

Realizadas las Orientaciones Relativas de los modelos estereoscópicos, podemos realizar Medidas de Aerotriangulación para luego calcular con otro programa como por ejemplo el programa AeroTri los parámetros para el ajuste de un bloque de modelos.

Al hacer las Medidas de Aerotriangulación no debe estar cargada ninguna orientación absoluta.

El restituidor digital Digi3D ayuda al operador a realizar las medidas, de manera semejante a como lo hace en la Orientación Absoluta. Por lo tanto, la estrategia que Digi3D sigue para ayudar a hacer la medida de Aerotriangulación es:

  • Correlación en la Medida de Aerotriangulación. Para activar/desactivar la correlación en la Medida de Aerotriangulación debemos cambiar la Configuración de Digi3D.
  • Búsqueda de puntos en la medida de Aerotriangulación.

Con las medidas realizadas por el restituidor digital Digi3D se generan varios archivos, de los cuales cabe destacar los siguientes por su importancia para el cálculo de la Aerotriangulación.:

  • Un archivo con extensión .mod con las Coordenadas Modelo, y con el formato adecuado para poder calcular la Aerotriangulación con PatM por el método de los Modelos Independientes. Este archivo .mod corresponderá a un solo modelo, por lo que se deberán unir en un solo archivo todos lo archivos .mod que nos interesen. Si quieres ver una descripción de este tipo de archivos lee el tema de la ayuda Archivo de Coordenadas Modelo para Aerotriangulación.
  • Dos archivos con extensión .f con las Fotocoordenadas, y con el formato adecuado para poder calcular la Aerotriangulación con PatB por el método de Ajuste de Haces. Este archivo .f corresponderá a un solo fotograma, por lo que se deberán unir en un solo archivo todos lo archivos .f que nos interesen. Si quieres ver una descripción de este tipo de archivos lee el tema de la ayuda Archivo de Fotocoordenadas para Aerotriangulación.

Existen más posibilidades para obtener los datos en otros formatos, como se explica en el tema de la ayuda Importar/Exportar.

Si quieres hacer un ejemplo de medida de Aerotriangulación lee el tema de la ayuda Ejemplo de medida de Aerotriangulación.

Fecha de última modificación: lunes, 7 de Octubre de 2002


Ejemplo de medida de Aerotriangulación

Con las imágenes cargadas, tecleamos la orden AEROTRI, o bien la tecla que tenga configurada esta orden (si quieres saber cómo se asigna una orden a una tecla lee el tema de la ayuda Control del restituidor). También se puede ejecutar en la ventana principal de Digi3D:

Ejecutada la orden de medida de Aerotriangulación, aparece la siguiente información tanto en la pantalla de visualización estereoscópica:

como en la ventana Salida dentro de la ventana principal del restituidor digital:

donde se nos indica que podemos digitalizar el punto 1070. Por defecto toma el número de la imagen, en este caso 107, y le asigna un 0 a la izquierda al final, 1070. Y este primer punto que nos lleva corresponde al primer punto que hayamos definido en el fichero de cámara con el sufijo PAero.

Una vez situados en la zona correspondiente a las coordenadas de los puntos PAero, deberemos buscar un detalle que esté bien definido en ambas imágenes. A continuación ejecutaremos la orden CORRELAR que está asignada por defecto a la tecla B. Esta orden buscará por correlación en la imagen derecha el punto homólogo del punto marcado en la imagen izquierda, con lo cual no habría necesidad de posarnos moviendo la rueda de Z.

También podemos pulsar la tecla Esc en el caso de que queramos buscar otro punto en la imagen izquierda.

Como en el caso de las Orientaciones, podemos dejar de realizar medidas de Aerotriangulación pulsando la combinación de teclas Ctrl + Supr. Y por último, nos permite sobreescribir la instantánea que tengamos almacenada para este punto.

En el caso de que hayamos marcado en la ventana de configuración de la Aerotriangulación la casilla Pedir reseñas, Digi3D pedirá ahora la descripción literal para la reseña:

Esta descripcion aparecerá en la proxima medida de Aerotriangulación que se realice con este punto, de forma previa al posado en el punto. De esta forma, la descripcion sirve de ayuda, junto a la instantánea que se mostrará en la parte inferior derecha de la pantalla de visualización estereoscópica, para identificar el punto en siguientes medidas de Aerotriangulación.

Una vez que nos hayamos posado en el punto (y en su caso, tecleado la descripción literal para la reseña) vemos que nos pide que digitalicemos el punto 1071:

que es el 2º punto que hayamos definido en el fichero de cámara. Así digitalizamos los puntos 1071 y 1072. Como sólo tenemos definidos en el fichero de cámara 3 puntos con el sufijo PAero, después de estos tres puntos (1070, 1071, y 1072), el restituidor digital Digi3D pasa a la otra imagen del modelo para tomar puntos de Aerotriangulación, de forma análoga a como hemos digitalizado los puntos correspondientes a la primera imagen. Así realizamos los posados en los puntos 1080, 1081, y 1082. Al finalizar estos 3 puntos, y como no tiene más puntos definidos en el fichero de cámara, el programa nos pide otro número de punto, si es que deseamos efectuar más medidas de Aerotriangulación.

donde podemos posarnos en más puntos o salir al menú de Aerotriangulación, que presenta el siguiente aspecto:

En este menú tenemos las siguientes opciones:

  • Aceptar (pulsando la tecla Enter): si aceptamos las medidas de Aerotriangulación, se sale de este meñú y se devuelve el control al restituidor.
  • Cancelar (pulsando las teclas Ctrl + Supr): no se guardarán las medidas realizadas, y se devuelve el control al restituidor.
  • Remedir/Añadir (pulsando la tecla R): si se pulsa esta opción se puede volver a medir .
  • Sólo XY (pulsando la tecla X): permite visualizar un punto considerándolo sólo en XY. Esta opción (y la siguiente), ayudan a encontrar un posible punto erróneo de forma visual, pero no se cambiarán las coordenadas asociadas a un punto. Para quitar este punto del cálculo se debe seleccionar la opción Quitar.
  • Sólo Z (pulsando la tecla Z): funciona de manera análoga a la opción anterior.
  • Quitar (pulsando la tecla Q): con esta opción no se guardan las coordenadas de este punto, pero sí se guardan las instantáneas. Al quitar un punto, aparece al lado (desactivado). Para volver a considerar este punto se debe elegir la opción Recalcular todos.
  • Eliminar (pulsando la tecla E): se borran las coordenadas de este punto, permaneciendo la instantánea.
  • Recalcular Todos (pulsando la tecla C): sirve para volver a considerar un punto desactivado mediante la opción Quitar.

Cuando terminemos de realizar las medidas de Aerotriangulación que creamos pertinentes, aceptamos las medidas pulsando la tecla Enter. Si hacemos ahora un zoom para ver las imágenes completas, mediante la orden REST_ZOOME:

donde podemos ver en color amarillo (o en el color que tengamos definido en Configuración de la Aerotriangulación) los puntos donde hemos realizado las medidas de Aerotriangulación.

Se graban varios archivos al efectuar las medidas de Aerotriangulación (al Aceptar dentro del menú):

  • *.bmp.f: en estos ficheros se guardan Coordenadas de los puntos medidos. Las Fotocoordenadas son las correspondientes a la imagen con la que se inicia el número de punto, por ejemplo, el archivo 1070.bmp.f almacena las Coordenadas Píxel o Instrumentales del punto 1070 en el sistema de Coordenadas Píxel de la imagen 107. Se guarda en el directorio de Aerotriangulación.
  • 107-108.mod: este fichero de texto guarda los datos necesarios para el posterior cálculo con el programa PatM por el método de los modelos independientes. El contenido del archivo 107-108.mod es el siguiente:
    •              010708
                107            0.0            0.0            0.0          0
                108        68000.0        -3390.0          184.0          0
               1070         1762.1        -2106.8      -120409.2          0
               1071         3053.1        69147.0      -119429.2          0
               1072        14043.0       -65799.0      -122323.2          0
               1080        81990.3         4181.5      -120325.2          0
               1081        70676.3        65664.6      -120303.2          0
               1082        78833.2       -73087.2      -121502.2          0
                -99
  • 107.f y 108.f: en estos dos archivos de texto se almacenan las Fotocoordenadas en el formato adecuado para su posterior utilización en el programa PatB, empleado para el cálculo de la Aerotriangulación por el método del Ajuste de Haces. El archivo 107.f presenta el siguiente contenido:
    •             107        154052.0
              5        107807.8         64601.5    0 0
              7         82222.3        -46031.8    0 0
              3         15235.5         47060.5    0 0
              4          4124.4        -21344.4    0 0
              6         69368.6          4837.5    0 0
           1070          1932.0        -12632.3    0 1
           1071             0.0         85603.2    0 1
           1072             0.0        -85000.0    0 1
           1080         85368.7         -2383.7    0 1
           1081         86689.8         80963.7    0 1
           1082         80336.9        -88589.8    0 1
            -99
  • Instantáneas: se guardan en archivos de imagen en formato BMP. Se almacenan dos copias de cada instantánea: una en el directorio de Instantáneas, con una cruz en el punto medido, pues están pensadas para generar las reseñas; y la otra en el directorio de Aerotriangulación para realizar las búsquedas.
  • BRONCHALES.des: en este archivo se almacenan las descripciones para los puntos de Aerotriangulación. Este archivo tiene el mismo nombre que el archivo de puntos de apoyo (en este ejemplo es BRONCHALES.txt), y con extensión des.

    • Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Correlación en la medida de Aerotriangulación

Digi3D nos ayuda a realizar las medidas de Aerotriangulación utilizando correlación. El programa efectúa una búsqueda de puntos en la medida de Aerotriangulación, y si encuentra un punto que ya haya sido medido en un fotograma, y queremos que además nos busque dicho punto en el otro fotograma del par, debemos tener activada la correlación para la medida de Aerotriangulación en la Configuración de Digi3D.

El restituidor digital Digi3D también efectúa la búsqueda entre fotogramas que pertenezcan a pasadas contiguas, y esta búsqueda se hará mediante correlación si ésta está activada en la configuración de Digi3D entre pasadas al Aerotriangular. La correlación se emplea en este caso tomando como imagen de referencia una instantánea en concreto, tal y como se explica en la búsqueda de puntos en la medida de Aerotriangulación.

La estrategia aplicada no conlleva que las medidas de Aerotriangulación sean automáticas, pues debemos realizar el posado estereoscópicamente en los puntos que el programa encuentre. Sin embargo, implica un gran ahorro de tiempo cuando realicemos las medidas de Aerotriangulación.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Búsqueda de puntos en la medida de Aerotriangulación

Cuando vamos a efectuar medidas de puntos para Aerotriangulación, Digi3D busca posibles puntos siguiendo la siguiente estrategia:

  1. Si se trata del segundo modelo en el que realizamos medidas de Aerotriangulación, busca por Fotocoordenadas el punto en la imagen. Las medidas efectuadas para Aerotriangulación en el primer modelo se almacenan en los dos archivos de Fotocoordenadas correspondientes a las dos imágenes, y gracias a las coordenadas almacenadas en estos ficheros, nos lleva a un punto en una imagen y podemos realizar el posado en la otra.
  2. Si no tiene el fichero de Fotocoordenadas, busca en el directorio de Aerotriangulación archivos de instantáneas. Este tipo de archivos contienen una imagen, y lo que hace el programa es buscar por correlación esta imagen en el fotograma. Esta alternativa se emplea para buscar puntos entre pasadas contiguas.
  3. Si el programa no puede realizar ninguna de las alternativas anteriores, corresponde al usuario buscar puntos en los fotogramas.

Fecha de última modificación: martes, 15 de Octubre de 2002


Modelo Digital del Terreno por Correlación

En este tema de la ayuda se explica paso a paso la creación de una nube de puntos (posados en Z y cada cierta distancia) automáticamente mediante el módulo de Correlación de Digi3D.

Para ello debemos haber realizado las Orientaciones Internas, Relativa y Absoluta de un par estereoscópico. Los pasos generales para crear el Modelo Digital del Terreno por Correlación con Digi3D son:

  1. Registro de las líneas de ruptura.
  2. Delimitación de la zona a correlar.
  3. Ejecución de la orden MDTPC.
  4. Selección de la línea límite.
  5. Relleno de los campos del cuadro de diálogo de la orden MDTPC.
  6. Comprobación del resultado.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Paso 1: Registro de las líneas de ruptura

El módulo de Correlación de Modelos Digitales del Terreno (denominado MDTPC a partir de ahora) requiere que registremos ciertas líneas estereoscópicamente para apoyarse en éstas y ayudarse de la información que éstas aportan para "saber dónde posarse".

Nuestro primer paso será pues registrar algunas líneas (un camino, una carretera, una senda) estereoscópicamente. No tenemos por que registrar todo el modelo, con unas cuantas líneas (5 ó 6) ya es suficiente. En el caso de que el correlador se equivoque, al ser el proceso de MDTPC un proceso interactivo, siempre podemos deshacer lo último que hemos hecho, pintar alguna línea de ruptura más y luego volver a realizar el proceso de MDTPC.

Siguiente

Fecha de última modificación: jueves, 23 de Mayo de 2002


Paso 2: Delimitación de la zona a correlar

Registramos un contorno cerrado (para cerrar una línea usamos la orden CIERRA_ENT). Este contorno delimitará la zona sobre la cual vamos a generar la nube de puntos.

El contorno lo podemos registrar de tres formas diferentes:

  • Mediante ratón directamente en la pantalla de DigiNG y sin posarnos en Z.
  • Estereoscópicamente punto a punto posando en Z únicamente los vértices del polígono cerrado.
  • Estereoscópicamente en modo continuo posando en Z toda la geometría del polígono cerrado.

Anterior | Siguiente

Fecha de última modificación: jueves, 23 de Mayo de 2002


Paso 3: Ejecución de la orden MDTPC

Para ejecutar la orden MDTPC tenemos dos opciones:

a) Ejecutarla mediante el menú

b) Ejecutarla escribiendo el nombre de la orden

Anterior | Siguiente

Fecha de última modificación: jueves, 23 de Mayo de 2002


Paso 4: Selección de la línea límite

Lo primero que nos pide la orden MDTPC cuando comienza a ejecutarse es que seleccionemos la línea que hace de límite de correlación y que hemos generado en un paso anterior.

Seleccionamos la línea con los pedales o con el ratón.

Anterior | Siguiente

Fecha de última modificación: jueves, 23 de Mayo de 2002


Paso 5: Relleno de los campos del cuadro de diálogo de la orden MDTPC

Una vez seleccionada la línea límite, nos aparece el cuadro de diálogo de la orden MDTPC:

  • En el campo titulado Geometría de la línea de límite se puede seleccionar el tipo de límite, dependiendo de si ningún vértice está posado en Z o sólo los vértices están posados en Z.
  • En los campos min y max se especifica el rango de Z dentro del cual se encuentran las líneas de ruptura. Todas las líneas que se encuentren dentro de la línea de límite pero que no se encuentren dentro de este rango de coordenadas mínimas y máximas no se tendrán en cuenta como líneas de ruptura.
  • En el campo Distancia entre puntos (en unidades terreno) se puede especificar cada cuántos metros se desea que el programa registre una cota. El programa registrará cotas separadas entre sí por esta distancia aproximadamente y nunca registrará una cota si en su posición se encuentra con algún segmento de alguna línea de ruptura.
  • Permitir que la Z se desplaze xxxxxx veces la distancia entre puntos. Cambiando este parámetro se puede indicar al programa, por ejemplo, que el terreno tiene mucho desnivel y que se puede dar el caso de que si se incrementa 10 metros en XY, la Z puede verse incrementada en 30 metros si se establece este campo a 3. Se puede establecer Semiancho de la imagen de referencia expresado en píxeles o en tanto por ciento con respecto al ancho de la imagen original, permite indicar el ancho en píxeles que tendrá el rectángulo que se correla con un factor piramidal 1:1. Aumentando este parámetro se consigue que el correlador tarde más en realizar su trabajo pero aumentamos la probabilidad de éxito de éste.
  • Tamaño del pixel en micras. Aquí se introduciría el tamaño del pixel del escaneo.
  • Anchos en píxeles de las imágenes de referencia para los diferentes niveles piramidales. Como valores por defecto aparecerán para el nivel piramidal 8, 4 y 1, los valores 16, 16 y 20 respectivamente. Estos valores se podrán variar en caso de que la imagen presente mucha resolución o que el terreno fotografiado presente mucha uniformidad, por ejemplo parcelas con cultivos iguales. Siendo ese el caso, se podría aumentar al valor de 20 a 21 píxeles.
  • Buscar puntos con factor de correlación >=. En este campo se define el factor de correlación mínimo con el que se desea que se efectúen las mediciones. En el siguiente campo se define el número de veces que se desea que se intente la medición de un punto. En el siguiente campo se define el número de píxeles con el se incremente la espiral (en la que se realiza la búsqueda) para cada nuevo intento. Si está marcada la casilla Borrar los puntos que no cumplan esta condición no se almacenarán los puntos que tengan factor de correlación menor del indicado y hayan superado el número de intentos. Si dicha casilla no está marcada, dichos puntos sí se almacenarán.
  • No correlar sobre las muestras de entrenamiento: si se marca esta casilla y se define una categoría (ver orden ENTRENAMIENTO), en el proceso de medición de puntos se tendrá en cuenta dicha muestra. Si el programa detecta que un punto correlado es una muestra, repite la medición según una espiral hasta que considere que el punto no está sobre la muestra. Esta espiral queda definida por el número de veces que se intentará posar en un punto, y por el número de píxeles en los que incrementa la espiral en cada intento. Estos parámetros se definen en esta misma ventana, en el apartado Buscar puntos con correlación. La muestra queda definida por el entrenamiento previo y el tamaño de la muestra que se define en esta ventana.
  • Generar un archivo log sirve para generar un archivo .html que luego se puede visualizar con un navegador web, y que muestra un resumen de la correlación. El nombre de este archivo será el nombre del archivo .BIN sobre el cual se va a generar el MDTPC, añadiéndole al final "_log.html".
  • Visualizar el proceso de correlación. Esta opción sirve para poder ver en tiempo real el proceso de correlación de las imágenes en la pantalla estereoscópica.
    •  Si quieres ver un ejemplo de este tipo archivo pulsa aquí.

Una vez rellenados todos los campos pulsamos sobre el botón Calcular y el programa se pone a calcular.

Anterior | Siguiente

Fecha de última modificación: 10 de Agosto, 2004


Paso 6: Comprobación del resultado

Si habíamos seleccionado la casilla generar un archivo log en el paso 5, el programa nos genera un archivo html en el mismo directorio que el archivo .bin.
Pulsa aquí para ver un ejemplo de archivo .log

Una vez finalizado el proceso de cálculo, desaparece el cuadro de diálogo de la orden MDTPC y haciendo un zoom extendido (con la orden ZOOME) vemos el resultado:

Si hacemos un zoom extendido en la pantalla estereoscópica vemos los puntos estereoscópicamente

¿Con qué códigos se han generado las cotas?

Dependiendo del factor de correlación de cada una de las cotas, el programa les ha asignado un código que podemos ver en la siguiente tabla:
    Fact. de correlación | Código asignado a la cota
[0.6-1.0] | 6
[0.4-0.6) | 4
[0.25-0.4) | 2
[0.0-0.4) | 0

¿Por qué no veo los puntos correlados?

Posíblemente por que no tengas creados estos códigos en tu tabla Digi.tab. Ejecuta la orden digi.tab dentro de DigiNG y crea estos códigos, puntuales y con diferentes colores (recomendamos rojo para el código 0, azul para el código 2, verde para el código 4 y amarillo para el código 6, así, los colores oscuros sabrás que están peor correlados que los colores claros).

Si prefieres editar manualmente tu archivo digi.tab, añade estas entradas:

    0 1 12 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.0-0.25)"
2 1 09 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.25-0.4)"
4 1 10 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.4-0.6)"
6 1 14 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.6-1.0]"

También es posible que no los veas por el grosor del punto. Puedes ejecutar la orden grosor y asignarle a esta propiedad otro valor, por ejemplo, 2:

    grosor=2

¿cómo puedo mover un punto mal posado?

Ejecutando la orden MOVER_Z que además de mover un punto en Z, le cambia el código por el que tengas como código activo.
Por lo tanto tienes que poner como código activo un código que visualmente (por su color) sepas que está posado correctamente y luego desactivar el flag de digi verifica (para que cuando la orden nos pida que seleccionemos una entidad a mover en Z, no nos pida luego que la confirmemos por segunda vez), luego localizaremos el punto mal correlado, nos posaremos en XYZ correctamente y pulsaremos el botón o pedal de data. La orden con esa única pulsación moverá el punto a su Z buena y además nos cambiará el código de éste por el que tenemos activo.

Ejemplo:

    cod=6
ver=0
mover_z

¿cómo puedo mover en Z de una vez una masa de puntos todos ellos elevados o hundidos la misma distancia?

Si la orden MDTPC tiene que correlar sobre una masa de árboles, éste pondrá las cotas sobre las copas de éstos. Tendremos que bajar todas estas cotas una determinada distancia.
Para ello seguimos los siguientes pasos:
  • Registramos una línea cerrada rodeando todas las cotas que queremos bajar (o subir) en Z.
  • Ejecutamos la orden de DigiNG MOVER_Z_V (de mover Z con ventana).
  • Seleccionamos la línea de límite.
  • El programa nos pide que registremos un punto. Nos posaremos en la copa de un arbol y pulsaremos el botón/pedal de data.
  • El programa nos pide que registremos un segundo punto. Nos posaremos en el terreno y pulsaremos el botón/pedal de data.

El programa bajará/subirá automáticamente todos los puntos que se encuentren dentro de la línea de límite calculando la distancia restando la Z del primer punto con respecto a la Z del segundo punto.

¿Existen más órdenes que me puedan ser útiles?

  • Si quieres borrar tódas las cotas con un determinado código pero que estén dentro de una línea de límite ejecuta la orden BORRA_COD_V
  • Si la última vez que ejecutaste la orden MDTPC éste se equivocó mucho, puedes ejecutar la orden undo para deshacer los últimos cambios, y registrar más líneas de ruptura dentro de ese límite para luego volver a ejecutar la orden mdtpc.

Anterior

Fecha de última modificación: jueves, 23 de Mayo de 2002


Resumen de la correlación generada por el Módulo de Modelo Digital del Terreno de Digi3D

Usuario: Administrador
Fecha: 29/4/2002 17:39
Geometría de la línea de límite: Ningun vértice está posado en Z
Se tomaron puntos de ruptura los que entraban en el siguiente rango de Zs: [0.000000-10000.000000]
Equidistancia entre puntos correlados: 10.000000
Se descartaron los puntos que formaban una pendiente inferior a: 0.000000 y superior a: 9999.000000

Estadisticas:
  |
p |
u |
n |
t |
o |
s |
  |
c |
o |
r |
r |
e |                                         *
l |                                         *
a |                                         *
d |     *                                   *
o |     *           *           *           *
s |     *           *           *           *
  |     *           *           *           *
--+---------------------------------------------
      [0.0-0.25) [0.25-0.4) [0.4-0.6)   [0.6-1.0]    factor de correlación

Número de puntos correlados: 2029
en el rango [0.00 - 0.25): 466
en el rango [0.25 - 0.40): 321
en el rango [0.40 - 0.60): 424
en el rango [0.60 - 1.00): 818

Puntos descartados por el filtro de pendientes: 0

Tiempo total del proceso de correlación: 12 segundos
Número de puntos correlados por segundo: 169.083333

Fecha de última modificación: jueves, 23 de Mayo de 2002


Ejecución de la orden MDTPC con parámetos

Digi3D

Ejecución de la orden MDTPC con parámetros

La orden MDTPC también se puede ejecutar desde la línea de órdenes desde MS-DOS. De esta forma se pueden ejecutar desde un archivo .bat varias llamadas a la orden. La orden tiene la siguiente sintaxis:

MDTPC=[codigo] [geometria] [rangoMin] [rangoMax] [distancia] [desplazamientoZ] [tipoSemiancho] [semiancho] [factorMinCorrelacion] [oportunidades] [incrementoEspiral] [borrarPuntos]
      [utilizarEntrenamiento]
           [archivoDeMemoria*] [categoría*] [tamañoMuestraX*] [tamañoMuestraY*]
      [filtrarPorPendientes]
           [pendienteMinima*] [pendienteMaxima*]
      [comoAlmacenarResultados]
           [distanciaDEM*]

donde los parámetros con el caracter * son opcionales. Los posibles valores para los parámetros son:

  • codigo: el código de la única entidad que tiene que existir con ese código.
  • Geometría: se puede seleccionar el tipo de límite:
    • 0: ningún vértice está posado en Z.
    • 1: sólo los vértices están posados en Z.
    • 2: toda la geometría del límite está posada en Z.
  • rangoMin,rangoMax: donde se especifica el rango de Z dentro del cual se encuentran las líneas de ruptura. Todas las líneas que se encuentren dentro de la línea de límite pero que no se encuentren dentro de este rango de coordenadas mínimas y máximas no se tendrán en cuenta como líneas de ruptura.
  • distancia: distancia entre puntos (en unidades terreno), que especifica cada cuántos metros se desea que el programa registre una cota. El programa registrará cotas separadas entre sí por esta distancia aproximadamente y nunca registrará una cota si en su posición se encuentra con algún segmento de alguna línea de ruptura.
  • desplazamiento: sirve para permitir que la Z se desplaze xxxxxx veces la distancia entre puntos. Cambiando este parámetro se puede indicar al programa, por ejemplo, que el terreno tiene mucho desnivel y que se puede dar el caso de que si se incrementa 10 metros en XY, la Z puede verse incrementada en 30 metros si se establece este campo a 3.
  • tipoSemiancho: establece el tipo de semiancho a emplear en las búsquedas:
    • 0: en % del ancho de la imagen.
    • 1: en píxeles.
  • semiancho: especifica el valor del semiancho.
  • factorMinCorrelacion: en este campo se define el factor de correlación mínimo con el que se desea que se efectúen las mediciones.
  • oportunidades: número de veces que se desea que se intente la medición de un punto.
  • incrementoEspiral: campo se define el número de píxeles con el se incremente la espiral (en la que se realiza la búsqueda) para cada nuevo intento.
  • borrarPuntos: sirve para indicar si se borran o no los puntos que tengan factor de correlación menor del indicado y hayan superado el número de intentospuede tomar los siguientes valores:
    • 0: no se borrarán los puntos.
    • 1: se borrarán los puntos.
  • utilizarEntrenamiento: este campo sirve para especificar si se desea correlar encima de las muestras de entrenamiento:
    • 0: no se desea correlar encima de las muestra de entrenamiento. En este caso los siguientes 4 campos se deben omitir.
    • 1: se desea correlar encima de las muestra de entrenamiento. En este caso los siguientes 4 campos se deben especificar:
      • archivoDeMemoria: archivo donde se encuentran las muestras de entrenamiento.
      • categoría: nombre de la muestra.
      • tamañoMuestraX, tamañoMuestraY: ancho y alto que se considerarán de la muestra.
  • filtrarPorPendientes: Filtro de puntos permite indicarle al programa que se desea eliminar los puntos cuya pendiente con todos los puntos de alrededor sea inferior a pendiente mínima ó superior a pendiente máxima. Puede tomar los siguientes valores:
    • 0: no se desea filtrar por pendientes. En este caso se deben omitir los 2 siguientes campos.
    • 1: se desea filtrar por pendientes. En este caso se deben especificar los dos siguientes campos, que son pendienteMinima y pendienteMaxima.
  • comoAlmacenarResultados: este campo permite definir cómo se desean almacenar los puntos obtenidos. Puede tomar los siguientes valores:
    • 0: si se marca esta opción el MDT obtenido será directamente la nube de puntos obtenida por correlación. En este caso el siguiente campo se debe omitir.
    • 1: genera una malla regular a partir de la nube de puntos correlados. Se debe especificar la distancia entre puntos en el siguiente campo, distanciaDEM
    • 2: se realiza un malla regular mediante un suavizado de la nube de puntos correlados. Dicho suavizado se efectúa mediante VirtuaLand, por lo que se requiere tener la licencia de este programa. debe especificar la distancia entre puntos en el siguiente campo, distanciaDEM.

    Fecha de última modificación: viernes, 3 de Enero de 2003


Comenzando con DigiNG

Con este tema de la ayuda aprenderás a manejar DigiNG:

  • Identificación de pedales o de botones del ratón: sólo debes realizarla la primera vez que ejecutes DigiNG.
  • Dibujar con DigiNG: donde aprenderás a restituir con DigiNG.
  • Precisión de DigiNG: aquí explicamos este importante concepto dentro de DigiNG.

Fecha de última modificación: miércoles, 24 de Abril de 2002


Identificación de pedales

Cuando realizamos las Orientaciones utilizamos los pedales indistintamente, sin tener en cuenta con qué pedal hacíamos cada acción. Sin embargo, para restituir con DigiNG es necesario identificarlos, porque cada pedal tiene un significado diferente. Los pedales se conocen con el nombre:

  • Dato: sirve para aceptar,
  • Fin entidad: sirve para terminar de dibujar una línea,
  • Tentativo: sirve para "cazar" un punto significativo.

Esta identificación de pedales sólo es necesario hacerla la primera vez que utilice DigiNG. Luego se rotulan para no tener que identificarlos más veces.

Podemos identificar los pedales de dos formas:

  • Mediante la ventana de configuración de Digi3D.
  • Mediante la orden Ver_Coordenadas.

Una vez identificados y marcados los pedales, podemos empezar con DigiNG.

Fecha de última modificación: miércoles, 24 de Abril de 2002


Identificación de pedales mediante la ventana de configuración de Digi3D

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Dispositivos de entrada en la lista de la izquierda. Pulsamos sobre el botón Comprobar y cambia el contenido de la ventana:

Si pulsamos sobre cada uno de los pedales veremos como cambia el contenido del cuadro Pedal. Podemos ver los tres siguientes valores:

  • 1: este pedal es el llamado Dato.
  • 4: este pedal es el denominado Fin entidad.
  • 2: este pedal es el Tentativo.

Si quieres saber algo más acerca de la configuración del Dispositivo de entrada pulsa aquí.

Una vez identificados y marcados los pedales, podemos empezar con DigiNG.

Fecha de última modificación: miércoles, 24 de Abril de 2002


Identificación de pedales mediante la orden VER_COORDENADAS

Si estamos visualizando las imágenes en el monitor de visión estereoscópica y pulsamos la tecla Enter, en la pantalla donde está la ventana principal de Digi3D aparece:

donde podemos escribir la orden de Digi3D que consideremos. En este caso nos interesa teclear la orden Ver_Coordenadas, y pulsamos la tecla Enter. Esta orden nos muestra al lado de las coordenadas un número que identifica qué pedal se está pulsando. En la siguiente imagen:

podemos ver que estamos pulsando el pedal que se identifica con el número 4. La correspondencia de estos números con los pedales es la siguiente:

  • 1: este pedal es el llamado Dato.
  • 4: este pedal es el denominado Fin entidad.
  • 2: este pedal es el Tentativo.

Una vez identificados los pedales, lo mejor es marcarlos para no tener que hacer esta operación más veces. Ahora ya podemos empezar con DigiNG.

Fecha de última modificación: miércoles, 24 de Abril de 2002


Iniciando DigiNG

Ya conocemos cuáles son los pedales o botones que se identifican con Dato, Fin entidad, y Tentativo. Para comenzar con DigiNG cargamos las imágenes, y después volvemos a sacar el cuadro de diálogo Nuevo Proyecto (pulsando Ctrl+N para no tener que salir del modo gráfico). Vemos que directamente nos aparece la opción de DigiNG:

Si quieres recordar la descripción de este cuadro de diálogo pulsa aquí. Tecleamos un nombre de archivo de trabajo, por ejemplo, Demo. Como sólo vamos a ver cómo funciona DigiNG, dejamos el resto como está y pulsamos sobre el botón Abrir. Entonces se abre DigiNG en la ventana principal de Digi3D, y en la ventana de visualización estereoscópica seguimos viendo las imágenes. Como observamos:

cambia la ventana principal de la aplicación en los siguientes aspectos:

  • Barra de títulos: vemos como aparece el nombre del archivo en formato BIN que antes tecleamos, Demo:

  • Menú principal: podemos observar cambios en las opciones que se nos ofrecen:

  • Barra de Herramientas: de momento no cambia ninguna, pero cuando empecemos a dibujar con DigiNG veremos cómo se pueden utilizar:

  • Espacio de dibujo: observamos que se presenta en color negro. Este es el espacio donde se mostrará los elementos dibujados.

Lo más lógico ahora sería comenzar a restituir. Sin embargo, es conveniente primero familiarizarse con DigiNG, con su forma de dibujar, los elementos que podemos dibujar, los códigos, etc...

Fecha de última modificación: martes, 30 de Abril de 2002


Empezando a dibujar con DigiNG mediante órdenes

En este tema de la ayuda veremos qué elementos se pueden dibujar en DigiNG y cómo dibujarlos.

En DigiNG existen 3 tipos de elementos de dibujo:

  • Puntuales.
  • Lineales.
  • De Texto.

que están asociados a un código, y a una definición completa dentro del archivo DIGI.TAB, como ya explicaremos más adelante. Para dibujar un punto, una línea, o para escribir un texto, existen las órdenes Punto, Linea, y Texto, respectivamente:

  • Cómo ejecutar la orden Punto.
  • Cómo ejecutar la orden Linea.
  • Cómo ejecutar la orden Texto.

Fecha de última modificación: martes, 30 de Abril de 2002


Dibujar un punto con DigiNG

Para dibujar un punto en primer lugar hay que seleccionar un código que esté definido como puntual. Podemos buscar un código, con la barra de herramientas Digi1:

o con la orden bc (Buscar Código):

El código Centroide de parcela nos puede servir. Lo seleccionamos pulsando sobre él en la lista desplegable.

Para ejecutar una orden, se pulsa la tecla Enter y aparece la ventana donde se introduce el nombre de la orden:

En esta ventana escribimos punto, y pulsamos Enter de nuevo. Vemos que al ejecutar esta orden, aparece en la barra Órdenes la palabra punto, que nos informa de que estamos ejecutando dicha orden:

Ya estamos en disposición de poder poner un punto. Nos movemos en la pantalla de visualización estereoscópica, buscamos una parcela, nos posamos en el centro de la misma. Pulsamos sobre Dato para poner un punto sobre el centro de la parcela. Entonces vemos el punto que hemos dibujado en el espacio de dibujo, y que en la barra Órdenes ya no aparece ninguna orden:

Además vemos el punto sobre las dos imágenes en la pantalla de visualización estereoscópica. La marca flotante se ve en color rojo, y el punto en color verde:

Si queremos poner otro punto, ejecutamos otra vez la orden punto. Si pulsamos Enter para que aparezca la ventana donde se introducen las órdenes, vemos como aparece la última orden que hemos ejecutado, que en este caso es punto:

y para ejecutarla se pulsa sobre la tecla Enter. Entonces, para volver a ejecutar la última orden basta con pulsar dos veces seguidas la tecla Enter.

Si quieres aprender a dibujar una línea pulsa aquí.

Fecha de última modificación: martes, 30 de Abril de 2002


Dibujar una línea con DigiNG

Para dibujar una línea, en primer lugar hay que seleccionar un código, por ejemplo en la barra de herramientas Digi1, que esté definido como lineal:

o bien buscar un código mediante la orden bc:

El código Límite de parcela nos puede servir. Lo seleccionamos pulsando sobre él en la lista desplegable.

Para ejecutar una orden, se pulsa la tecla Enter y aparece la ventana donde se introduce el nombre de la orden:

En esta ventana escribimos linea, y pulsamos Enter de nuevo. Vemos que al ejecutar esta orden, aparece en la barra Órdenes la palabra linea, que nos informa de que estamos ejecutando dicha orden:

Ya estamos en disposición de poder poner una línea. Vamos a dibujar el límite de la parcela de la que hemos puesto el centroide, nos movemos, y nos posamos sobre un punto del límite. Pulsamos sobre Dato, vemos el primer vértice la línea y si nos movemos la línea ya está enganchada a ese primer punto.

Para poner otro punto de la línea, nos posamos sobre él y pulsamos Dato. Y así podemos poner punto a punto el límite de la parcela, como una línea poligonal quebrada. También se puede dibujar el límite de la parcela de forma continua si mantenemos pulsado Dato y a la vez nos movemos sobre el límite:

Se registran los puntos de la la línea continua cada un cierto intervalo, que se define en el cuadro de diálogo de Nuevo Proyecto DigiNG, y también se puede definir mediante la orden INC. También podemos borrar los últimos puntos de línea mediante la orden U.

Cuando hayamos terminado de pintar el límite, para cerrar la parcela se puede ejecutar la orden cierra_ent. Entonces se une el último punto del límite de la parcela con el primero:

y finaliza la orden línea como podemos ver en la barra Órdenes:

En el caso de que no queramos cerrar el polígono, sino simplemente dejar de dibujar el límite, pulsamos sobre Fin entidad. Muchos usuarios no utilizan el pedal o el botón del ratón que corresponde a Fin entidad. Está muy extendida la programación de la orden Fin_Ent en la tecla de la barra espaciadora, porque de esta forma resulta muy cómodo finalizar la entidad mientras se restituye. También es muy generalizada la programación de la orden cierra_ent en la tecla c, porque así cerramos un polígono con sólo pulsar dicha tecla.

Si quieres aprender a escribir texto con DigiNG lee el siguiente tema de la ayuda.

Fecha de última modificación: martes, 30 de Abril de 2002


Escribir texto con DigiNG

Para escribir texto en primer lugar debemos seleccionar un código lineal. Si ejecutamos la orden bc, y tecleamos texto, aparecen los códigos que en su descripción literal tienen la palabra texto:

y seleccionamos, por ejemplo, texto de paraje. Si ejecutamos la orden Texto, nos aparece la siguiente ventana:

donde escribimos el texto que deseemos, y luego pulsamos sobre el botón Aceptar. Entonces aparece el texto que hemos escrito al lado de la cruz en el espacio de dibujo:

y al lado de las marcas flotantes en la pantalla de visualización estereoscópica:

Lo ponemos con Dato donde nos interese, y nos vuelve a pedir un texto. Como no queremos escribir más, pulsamos sobre el botón Cancelar o la tecla Esc. Vemos en el espacio de dibujo lo que hemos escrito:

e

y también en el monitor de visualización estereoscópica:

Ya hemos visto cómo poner un punto, dibujar una línea, y escribir un texto mediante órdenes. En el siguiente tema de la ayuda se explica cómo hacer esto mismo pero sin necesidad de ejecutar órdenes, esto es, de una manera directa.

Fecha de última modificación: martes, 30 de Abril de 2002


Restituir con DigiNG

Ahora si movemos el ratón vemos que donde se mueve es en la ventana principal de DigiNG, tanto si tenemos el equipo con pedales y manivelas, como si lo tenemos con el ratón especial:

  • Comenzar a restituir es inmediato en el caso de que tengamos pedales y manivelas.
  • En el caso del ratón especial (o de que queramos restituir con el ratón sencillo de tu ordenador), pulsamos Enter para que el programa nos pide la orden que queremos ejecutar. Tecleamos Raton_Digi3D, y ya podemos empezar a restituir. Dicha orden corresponde a Digi3D, y hay dos ordenes equivalentes a esta en DigiNG: Raton y Digi3D. La orden Raton nos permiten pasar de utilizar el ratón con DigiNG a utilizarlo en la pantalla de visualización estereoscópica. La orden Digi3D nos permite pasar de utilizar el ratón en la pantalla de visualización estereoscópica a utilizarlo en el espacio de dibujo de DigiNG. Sin embargo, la forma más sencilla es ejecutar la orden Raton_Digi3D alternativamente para pasar de una a otra forma de utilizar el ratón.

Pulsamos el pedal/botón correspondiente a Dato. En el monitor de visualización estereoscópica vemos como asociado al movimiento de las manivelas/ratón estamos dibujando una recta, y no movemos las imágenes. Podemos dibujar varios tramos rectos:

o podemos dibujar en forma continua si dejamos pulsado Dato:

Si nos fijamos en la barra correspondiente a Coordenadas, vemos que se visualizan las coordenadas donde estamos dibujando la línea, y además en el cuadro de la izquierda aparece una R. Esta letra nos indica que se están registrando los puntos en el archivo de puntos que le hayamos definido en el cuadro de diálogo de Nuevo Proyecto DigiNG. Cuando queramos dejar de dibujar pulsamos Fin entidad. En DigiNG existe una orden llamada FIn_Ent, que tiene la misma finalidad que pulsar sobre el pedal o botón del ratón correspondiente a Fin entidad. Entre los usuarios de este restituidor digital está muy generalizado la programación de la orden Fin_Ent en la tecla de la barra espaciadora, porque de esta forma resulta muy cómodo mientras se restituye:

Observamos que:

  • Volvemos a manejar las imágenes.
  • En la pantalla de visión estereoscópica vemos lo que hemos dibujado.
  • En la pantalla donde está el espacio de dibujo de DigiNG no vemos lo que hemos dibujado. Esto es debido a que estamos dibujando en otras coordenadas de las que actualmente estamos visualizando. Para ver lo que hemos dibujado, pulsamos Enter, aparece la ventana para escribir las órdenes, en la que tecleamos la orden Zoome. Pulsamos Enter para aceptar esta orden, y vemos en el espacio de dibujo lo que acabamos de dibujar:

Como vemos, restituir es inmediato con Digi3D y DigiNG. También podemos dibujar directamente sobre DigiNG, para ello:

  • Si tu restituidor digital está formado por manivelas y pedales, debes hacer click con el ratón sobre el espacio de dibujo en la pantalla donde está la ventana principal de Digi. Dibujaremos (en DigiNG) entonces con el ratón del ordenador en lugar de con las manivelas y los pedales.
  • Si tu restituidor digital está formado por un ratón especial (o si quieres con el ratón que tengas), debes ejecutar la orden Digi3D.

El puntero del ratón cambia a una cruz. El ratón del ordenador suele estar configurado de la siguiente forma:

  • Dato: en el botón izquierdo.
  • Fin entidad: en el botón derecho.
  • Tentativo: en el botón central. Si tu ratón dispone de una rueda superior central, puedes pulsarla como un botón (no girarla) y se identifica con Tentativo.

Trazamos unas líneas con el ratón sobre el espacio de dibujo de DigiNG. Si ahora queremos volver a restituir:

  • Si tu restituidor digital está formado por manivelas y pedales, no debes hacer nada, simplemente utilizar las manivelas y los pedales para restituir. Si movemos las manivelas ahora, vemos que no se desplaza la cruz en el monitor de visualización estereoscópica. Para que se mueva pulsamos cualquier pedal.
  • Si tu restituidor digital está formado por un ratón especial (o si quieres con el ratón que tengas), debes ejecutar la orden Raton_Digi3D, para pasar el control del ratón a la pantalla de visualización estereoscópica.

Antes de continuar con la explicación de DigiNG es conveniente que te familiarices con la forma de restituir, y con la forma de entrar y salir con el ratón en el espacio de dibujo.

Fecha de última modificación: jueves, 25 de Abril de 2002


Referencia

En este tema de la ayuda se encuentra la documentación sobre Digi3D versión 2003 y sobre DigiNG:

  • Referencia de Digi3D.
  • Referencia de DigiNG.

Fecha de última modificación: martes, 30 de Abril de 2002


Referencia de Digi3D

En este tema de la ayuda se encuentra la documentación sobre Digi3D versión 2003:

  • Menú principal de Digi3D.
  • Línea de comandos.
  • Sistemas de visualización estereoscópica.
  • Tipos de imágenes soportados.
  • Configuración de Digi3D.
  • Listado de órdenes de Digi3D.
  • Formatos de archivo utilizados en Digi3D.
  • Estimadores Robustos.
  • Importar/Exportar.

Fecha de última modificación: martes, 14 de Mayo de 2002


Menú principal de Digi3D

Vemos que tenemos las siguientes opciones dentro de Digi3D:

  • Archivo.
  • Edición.
  • Ver.
  • Insertar.
  • Dibujo.
  • Digital.
  • Base de Datos.
  • Herramientas.
  • Ventana.
  • Ayuda.

Las opciones que están en este menú y sus correspondientes submenús también es posible ejecutarlas mediante órdenes, para que el usuario las ejecute como le resulte más cómodo, esto es, bien interactivamente con el ratón, bien ejecutando las órdenes, o bien asociando las órdenes a macroinstrucciones (arrobas).

Fecha de última modificación: viernes, 7 de Noviembre de 2003


Menú principal de Digi3D. Archivo

Tenemos las siguientes opciones dentro de Archivo:

  • Nuevo ...

  • Importar y Exportar ...

  • Salir: termina la ejecución de Digi3D.

Fecha de última modificación: viernes, 7 de Noviembre de 2003


Menú principal de Digi3D. Edición

Tenemos las siguientes opciones dentro de Edición:

Todas estas opciones se pueden seleccionar de este menú cuando tengamos abierto un archivo .bin. En este caso, se podrán ejecutar seleccionándolas del menú o bien introduciendo las ordenes correspondientes en la barra de órdenes.

El nombre exacto de dichas órdenes se puede encontrar en Órdenes de DigiNG.

Fecha de última modificación: viernes, 7 de Noviembre de 2003


Menú principal de Digi3D. Ver

Tenemos las siguientes opciones dentro de Ver:

En este menú podremos seleccionar cualquiera de las distintas opciones de Zoom y gestionar la visualización de códigos, de errores y del cursor.

Fecha de última modificación: martes, 11 de Noviembre de 2003


Menú principal de Digi3D. Insertar

Tenemos las siguientes opciones dentro de Insertar:

  • Desde un archivo...
  • Bloque.
  • Bloque rotando.
  • Bloque con ángulo activo.
  • Insertar foto
  • Insertar un nuevo objeto.

Fecha de última modificación: viernes, 7 de Noviembre de 2003


Menú principal de Digi3D. Dibujo

Tenemos las siguientes opciones dentro de Dibujo:

Todas estas opciones se pueden seleccionar de este menú cuando tengamos abierto un archivo .bin. En este caso, se podrán ejecutar seleccionándolas del menú o bien introduciendo las ordenes correspondientes en la barra de órdenes.

El nombre exacto de dichas órdenes se puede encontrar en Órdenes de DigiNG.

Fecha de última modificación: viernes, 7 de Noviembre de 2003


Menú principal de Digi3D. Digital

Tenemos las siguientes opciones dentro de Digital:

  • Orientación Interna izquierda.
  • Orientación Interna derecha.
  • Orientación Relativa.
  • Orientación Absoluta.
  • Medida de Aerotriangulación.
  • Orientación Relativa Automática por Correlación.
  • Ir a punto de apoyo.
  • Ver.
  • Brillo/Contraste.
  • Velocidades.
  • Índices.
  • Teclado.
  • Zoom de acercar.
  • Zoom de alejar.
  • Zoom extendido.
  • Zoom 1x1.
  • Salir de modo gráfico.

Hay opciones que pueden verse en gris, pues sólo estarán activas si Digi3D está en modo gráfico, esto es, con las imágenes cargadas en el monitor de visualización estereoscópica.

En el caso de las Orientaciones, se verá una marca a la izquierda que nos indica cuáles están hechas. En la imagen superior vemos que están todas las Orientaciones realizadas.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Menú Digital. Ver

Tenemos las siguientes opciones dentro de Ver:

Todas estas opciones se pueden seleccionar de este menú cuando tengamos abierto un archivo .bin. En este caso, se podrán ejecutar seleccionándolas del menú o bien introduciendo las ordenes correspondientes en la barra de órdenes.

El nombre exacto de dichas órdenes se puede encontrar en Órdenes de DigiNG.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Menú Digital. Brillo/Contraste

Tenemos las siguientes opciones dentro de Brillo/Contraste:

  • Positivo/Negativo: con esta opción podemos alternar entre el positivo y el negativo de las imágenes. También lo podemos hacer con la orden POSITIVO_NEGATIVO.

  • Izquierda y derecha: podemos hacer una serie de acciones a las dos imágenes, que son las que se pueden ver en la imagen:

    Estas acciones también se pueden ejecutar mediante las órdenes CAMBIO_BRILLO y CAMBIA_CONSTRASTE.

  • Izquierda: permite aclarar y oscurecer la imagen izquierda. También es posible hacerlo mediante la orden CAMBIO_BRILLO.

  • Derecha: permite aclarar y oscurecer la imagen derecha. También es posible hacerlo mediante la orden CAMBIO_BRILLO.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Menú Digital. Velocidades

Tenemos las siguientes opciones dentro de Velocidades:

Esta opción permite cambiar la velocidad de los movimientos asociados, por una parte a la X e Y, y por otra parte a la Z. En ambas opciones nos salen las dos siguientes:

También se pueden ejecutar mediante las órdenes VELOCIDAD_MAS_XY, VELOCIDAD_MENOS_XY, VELOCIDAD_MAS_Z, VELOCIDAD_MENOS_Z.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Menú Digital. Índices

Tenemos las siguientes opciones dentro de Índices:

que se corresponden con los distintos tipos de índices disponibles en el restituidor digital Digi3D. También es posible cambiar de índice mediante la orden TIPO_INDICE.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Menú Digital. Teclado

Tenemos las siguientes opciones dentro de Teclado:

  • Cambiar de teclado: con esta opción cambiamos del teclado actual a otro que tengamos definido en Configuración de tablas. También podemos hacerlo ejecutando la orden CAMBIA_TECLAS_MNU.
  • Programador de teclas: sirve para asignar órdenes a teclas. Si quieres aprender a hacerlo pulsa aquí. También puedes ejecutar la orden TECLA.

Fecha de última modificación: jueves, 23 de Mayo de 2002


Menú principal de Digi3D. Base de Datos

Tenemos las siguientes opciones dentro de Base de Datos:

Todas estas opciones se pueden seleccionar de este menú cuando tengamos abierto un archivo .bin. En este caso, se podrán ejecutar seleccionándolas de dicho menú o bien introduciendo las ordenes correspondientes en la barra de órdenes.

El nombre exacto de dichas órdenes se puede encontrar en Órdenes de DigiNG.

Fecha de última modificación: viernes, 7 de Noviembre de 2003


Menú principal de Digi3D. Herramientas

Tenemos las siguientes opciones dentro de Herramientas:

  • Correlar internas ...
  • Orientación de relativas.
  • Modelo Digital del Terreno.
  • Generador de reseñas.
  • Configuración.
  • Barras de Herramientas.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Menú principal de Digi3D. Ventana

Tenemos las siguientes opciones dentro de Ventana:

Permite crear una o varias ventanas con diferentes vistas que se mostrarán en el espacio de dibujo de DigiNG. Para ejecutar esta orden hace falta ir al menú principal de DigiNG/ Ventana/ Nueva Ventana.

Una vez pulsada esta opción, se crea automaticamente la nueva vista que aparecerá en un principio como maximizada. Para poder ver las ventanas actuales del proyecto tendremos que dar al boton de restaurar situado en la esquina superior derecha de la ventana principal.

Las ventanas creadas se pueden disponer en el espacio de dibujo de varias formas diferentes, las podemos colocar manualmente en la posición que deseemos o bien organizarlas según una cascada:

o bien como un mosaico, cubriendo todo el espacio de dibujo:

Todo esto se consigue con las opciones mostradas en el menú desplegable. Las diferentes ventanas pueden mostrar diferentes partes del dibujo todas ellas con el cursor en movimiento sincronizado y con la posibilidad de ejecutar diferentes Zooms en las diferentes vistas.

Órdenes relacionadas: GUARDA_DISPOSICION, CARGA_DISPOSICION.

Fecha de última modificación: viernes, 10 de Octubre de 2003


Menú principal de Digi3D. Ayuda

Tenemos las siguientes opciones dentro de Ayuda:

  • Ayuda de Digi3D: si pulsamos con ratón aparece en pantalla la ayuda de Digi3D:

  • Sugerencia del día: aparece la siguiente ventana:

  • Acerca de ...: emerge el Acerca de ... de Digi3D:

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Línea de comandos

Se pueden realizar procesos desde la línea de comandos (como norma general, hay que especificar las extensiones de todos los archivos).

Importación de Relativas
C:\> Digi3D -i1 [imagen izquierda] [imagen derecha] [cámara] [archivo .xyxy]

Ejemplo:

C:\>Digi3D -i1 c:\trabajo\1834.tif c:\trabajo\1835.tif  c:\trabajo\rc10.cam  c:\trabajo\1834-1835.xyxy
Importación de Abolutas
C:\> Digi3D -i2 [imagen izquierda] [imagen derecha] [cámara] [archivo .xyzxyz]

Ejemplo:

C:\>Digi3D -i2 c:\trabajo\1834.tif c:\trabajo\1835.tif  c:\trabajo\rc10.cam  c:\trabajo\1834-1835.xyzxyz
Importación de relativa y absoluta en un paso
C:\> Digi3D -i3 [imagen izquierda] [imagen derecha] [cámara] [archivo .xyxyXYZ]

Ejemplo:

C:\>Digi3D -i3 c:\trabajo\1834.tif c:\trabajo\1835.tif  c:\trabajo\rc10.cam  c:\trabajo\1834-1835.xyxyXYZ
Importación de internas de Digi
C:\> Digi3D -i4 [imagen] [cámara] [archivo .ori]

Ejemplo:

C:\>Digi3D -i4 c:\trabajo\1834.tif c:\trabajo\rc10.cam c:\trabajo\1834.ori
Importación de externas
C:\> Digi3D -i5 [imagen izquierda] [imagen derecha] [cámara] [archivo .ext]

Ejemplo:

C:\>Digi3D -i5 c:\trabajo\1834.tif c:\trabajo\1835.tif  c:\trabajo\rc10.cam  c:\trabajo\1834-1835.ext
Modelo Digital del Terreno por Correlación
C:\> Digi3D -mdtpc [archivo mdtpc]

Ejemplo:

C:\>Digi3D -imdtpc c:\trabajo\prueba.mdtpc
Exportación a formato JPEG
C:\> Digi3D -Ajpeg [Archivo tif, bmp ó jpeg] [archivo jpeg ] [calidad*]

Ejemplo:

C:\>Digi3D -Ajpeg c:\trabajo\prueba.tif c:\trabajo\prueba.jpg 50

*Calidad por defecto es 75

Giro de una imagen
C:\> Digi3D -girar [Archivo tif, bmp] [archivo a generar ] [grados centesimales]

Ejemplo:

C:\>Digi3D -girar c:\trabajo\prueba.tif c:\trabajo\pruebaGirado.tif 200

Orientación Relativa Automática
C:\> Digi3D -relativa [archivo relativa automática]

Ejemplo:

C:\>Digi3D -relativa c:\trabajo\relativa.txt
Ejecución de DigiNG
C:\> Digi3D -diging [archivo bin con extensión] [orden]

donde Orden es un parámetro opcional y puede ser una macroinstruccion.

Ejemplo:

C:\>Digi3D -diging c:\bronchales.bin zoome
Creación de archivos de proyecto
C:\> creaprj [archivo salida] [foto izquierda] [foto derecha] [archivo de cámara] [archivo de puntos] [archivo bin con extensión]

donde archivo salida debe tener la extensión .prjd3d

Ejemplo:

C:\creaprj  107-108.prjd3d 107.tif 108.tif rmk15.cam bronchales.xyz t.bin

Fecha de última actualización: viernes, 3 de Enero de 2003


Sistemas de visualización estereoscópica

Un sistema de visualización estereoscópica es un hardware añadido que nos permite obtener una visión tridimensional del terreno mostrado en la pantalla del ordenador.

Existen multitud de sistemas de visualización estereoscópica, muchos de los cuales son completamente incompatibles con un restituidor digital como son los casos de realidad virtual.

Los sistemas que más precisión tienen y que más se ajustan con el concepto de un restituidor digital son los siguientes:

Sistema | Resolución de la imagen | Sistema operativo | Precio | Uso fotogramétrico | Cansancio visual | Valoración por los operadores de restitución | Webs con información adicional
Estereóscopo | Completa | Win 2000, Win NT, Win 95/98/ME | Medio | Vuelos altos y bajos | Nulo | Muy buena |
Gafas pasivas (ZScreen™) | Completa en horizontal, la mitad en vertical.* | Win 2000, Win NT, Win 95/98/ME | Caro | Vuelos altos | Nulo/Bajo | Muy buena | www.stereographics.com
Gafas Activas (CristalEyes) | Completa en horizontal, la mitad en vertical.* | Win 2000, Win NT, Win 95/98/ME | Bajo | Vuelos altos | Medio | Regular | www.stereographics.com
* Con esta resolución si tenemos una imagen escaneada a 20 micras, realmente la visualizamos como si se hubiera escaneado a 20 micras en horizontal y 40 micras en vertical.

Fecha de última modificación: 14 de septiembre de 2000


Tipos de imágenes soportados

El restituidor Digital soporta los siguientes tipos de archivos:

  • Archivos BMP en paleta de color y en True Color.
  • Archivos TIFF en modo normal y con tiles en paleta de color, tono de gris y true color.
  • Archivos JPEG en modo normal y con tiles en paleta de color, tono de gris y true color.

Fecha de última modificación: 11 de enero de 2002


Cambio de la configuración de Digi3D

Puedes cambiar la configuración del restituidor digital Digi3D para adaptar la aplicación a tus necesidades.

  • Configuración de Tablas
  • Configuración de la visualización
  • Configuración del dispositivo de entrada
  • Configuración de Tensores
  • Configuración de la comunicación exterior
  • Configuración de la aceleración de las manivelas
  • Configuración de la correlación
  • Configuración de la Orientación Absoluta
  • Configuración de la Orientación Relativa
  • Configuración de la Aerotriangulación
  • Configuración de las Instantáneas

Fecha de última modificación: lunes, 22 de Abril de 2002


Configuración de Tablas

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Tablas en la lista de la izquierda. Esta ventana lo que nos permite es configurar las tablas (archivos de configuración de Digi3D) utilizadas por el programa. Tenemos varias opciones de configuración:

  • Archivos de asignación de teclas: por defecto tendremos el archivo de teclas TDigital.mnu, que tiene unas órdenes asignadas a unas teclas. Si queremos podemos añadir nuestro archivo de teclas pulsando en el botón Añadir. En ese caso tendremos dos teclados configurados, e incluso podemos tener más si lo deseamos. Si queremos quitar algún teclado tendremos que seleccionarlo en la lista y luego pulsar sobre Quitar. Por defecto, el primer archivo de la lista es el que estará activo al abrir un proyecto, en caso de que queramos cambiar el orden de los archivos introducidos podemos usar los botónes con las flechas que se encuentran al lado derecho. Si cuando estemos operando con Digi3D queremos cambiar de teclado, tecleamos la orden cambia_teclas_mnu, e irá pasando de un teclado al siguiente. En la ventana principal de Digi3D existe una barra de herramientas denominada Teclados donde podemos ver qué teclado tenemos activo en cada momento:

    • En este caso nos informa de que el teclado activo es TDigital.mnu.

  • Archivos de tablas de códigos: podemos tener varios archivos DIGI.TAB, por ejemplo, y aquí se define en qué directorio están. Cuando estemos trabajando en DigiNG se puede cambiar interactivamente este archivo en la barra de herramientas Códigos. Si quieres conocer el formato del archivo DIGI.TAB lee el tema de la ayuda Formato del archivo DIGI.TAB.

  • Podemos configurar sonidos para las acciones: Dato, Fin de orden, y Error. Por defecto utilizaremos el altavoz interno del ordenador. También tenemos la posibilidad de emplear la tarjeta de sonido, e indicarle al programa los archivos de sonido que queremos que suenen en cada una de estas acciones.

Fecha de última modificación: viernes, 4 de Octubre de 2002


Configuración de la Visualización

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Visualización en la lista de la izquierda. Entonces en la parte derecha de la ventana se nos muestra las diversas configuraciones de visualización de las que disponemos. En esta ventana se configura el monitor de visualización estereoscópica en función del dispositivo de visión que tengamos:

  • Estereóscopo: podemos elegir la posición de las imágenes en la pantalla de visualización estereoscópica.
  • Monitor ZScreen o gafas activas a pantalla completa en modo entrelazado.

Tenemos más alternativas para modificar la visualización:

  • Configuración avanzada de la visualización: resolución de los monitores, profundidad de color de las imágenes, etc...
  • Configuración de la apariencia de la visualización: tamaño de las imágenes en pantalla, colores de las marcas flotantes, etc...

Fecha de última modificación: lunes, 10 de Marzo de 2003


Configuración Avanzada de la Visualización

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Avanzada dentro de Visualización en la lista de la izquierda. En la parte derecha de la ventana tenemos diversas opciones:

  • Pantalla: En la lista desplegable podemos seleccionar uno de los dos monitores que tenemos en el restituidor digital Digi3D. Con un monitor así seleccionado podemos modificar su resolución, y lo podemos utilizar para la visión estereoscópica si activamos la casilla correspondiente.
  • Resolución para escala de grises y Resolución para color : Aquí se pueden diferenciar las resoluciones de entrada para imágenes en color y para imágenes en blanco y negro.
  • Resolución gráfica intermedia: es una resolución especial que consiste en cambiar la resolución del monitor por una inferior a la normal, que nos permite hacer un zoom por hardware. Tiene la ventaja de que nos permite mostrar un zoom intermedio entre el 1x1 y el 1x2, pero tiene el inconveniente de que el monitor tarda dos segundos en cambiar de resolución, por lo tanto no resulta eficiente y no se suele activar esta opción.
  • Transformar las imágenes de color verdadero a escala de grises: esta casilla se activa para permitir un movimiento más suave y continuo de las imágenes en el monitor de visualización estereoscópica. Entonces las imágenes de color se visualizarán en escala de grises.
  • Profundidad de color en Color Verdadero: podemos seleccionar la profundidad de color en función de la tarjeta gráfica que tengamos. Existen tarjetas gráficas que sólo permiten trabajar con 32 bits, y no con 24 bits, por lo que tendremos que seleccionar la profundidad de color que nos permita la tarjeta gráfica que tengamos. Si tenemos opción a varias profundidades de color, la que mejor resulta con Digi3D es la de 24 bits.

Para conocer las profundidades de color que disponemos, pulsamos con el botón derecho del ratón sobre el escritorio de Windows, con lo que emerge la siguiente ventana:

donde seleccionamos Propiedades, apareciendo la ventana Propiedades de Pantalla:

En esta ventana elegimos la pestaña superior de Configuración. Seleccionamos el monitor que utilizamos para visualización estereoscópica, en este caso el número 1, y pulsamos sobre la lista desplegable Colores:

Como podemos observar no disponemos de la profundidad de color de 24 bits. Luego nos corresponde seleccionar una profundidad de color de 32 bits en la configuración avanzada de la visualización.

Fecha de última modificación: lunes, 22 de Abril de 2002


Configuración de la Apariencia de la Visualización

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Apariencia dentro de Visualización en la lista de la izquierda. En la parte derecha de la ventana observamos los cambios que podemos efectuar en la apariencia de la visualización:

  • Tanto por ciento que ocupa una imagen en horizontal: corresponde al tanto por ciento que ocupará una imagen en horizontal (de las dos imágenes que se visualizan si trabajamos en modo estereoscópico) en la pantalla de visualización estereoscópica. Con estereóscopo se recomienda un 50%. En los otros dos modos de visualización estereoscópica se recomienda 100% (gafas activas y ZScreen).
  • Tanto por ciento que ocupa una imagen en vertical: corresponde al tanto por ciento que ocupará una imagen en vertical (de las dos imágenes que se visualizan si trabajamos en modo estereoscópico) en la pantalla de visualización estereoscópica. Con estereóscopo se recomienda un 70%. En los otros dos modos de visualización estereoscópica se recomienda 100% (gafas activas y ZScreen).
  • Corrección de astigmatismo horizontal: desplazamiento en X de la marca flotante para efectuar dicha corrección.
  • Corrección de astigmatismo vertical: desplazamiento en Y de la marca flotante para efectuar dicha corrección
  • Color del índice: podemos modificar el color de la marca flotante. Si pulsamos sobre el cuadrado de color nos aparecerá una ventana donde podemos seleccionar otro color, e incluso podemos crear un color que se ajuste mejor a nuestras necesidades.
  • Brillo del índice Izq: se trata del brillo con el que queremos visualizar la marca flotante izquierda.
  • Brillo del índice Der: se trata del brillo con el que queremos visualizar la marca flotante derecha.
  • Color del fondo: aquí podemos elegir el color de fondo de la pantalla de visualización estereoscópica.
  • Paleta de colores: si estamos visualizando las imágenes en escala de gris, el monitor de visualización estereoscópica sólo trabaja con 256 posibles valores. Por ello, cuando estamos restituyendo y queremos ver la minuta sobreimpresionada con las imágenes, lo que hace Digi3D es tomar el color más parecido de los que existan en esta paleta de colores para efectuar esta sobreimpresión. Por lo tanto, esta paleta de colores debemos adecuarla a nuestras necesidades. Los colores 0 y 31 no se pueden modificar. Si ya tenemos una paleta de colores de otro trabajo la podemos Importar. En el caso de que la queramos guardar para futuros trabajos pulsaremos sobre el botón Exportar.
  • Fuente: se trata del tipo de letra con la que aparecerá el texto en el monitor de visualización estereoscópica.
  • Tamaño: se trata del tamaño de la letra con la que aparecerá el texto en el monitor de visualización estereoscópica.

Fecha de última modificación: viernes, 5 de Julio de 2002


Configuración del Dispositivo de Entrada

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Dispositivos de entrada en la lista de la izquierda. En la parte de la derecha podemos ver las opciones:

  • Codificadores: aquí seleccionamos la tarjeta de codificadores que tengamos instalada.
  • Puerto serie: seleccionamos el puerto serie donde hemos conectado la tarjeta de codificadores.
  • Acceder la tarjeta de codificadores cada: tiempo de acceso a la tarjeta de codificadores en millisegundos. Si es 0, indica que es perrmanente el acceso a la tarjeta de codificadores.
  • Al pulsar un pedal, dormir durante: tiempo de espera (en milisegundos) después de haber pulsado un pedal.
  • Esperar xxx milisegundos antes de dibujar vectores sobre las imágenes estéreo.

Si pulsamos sobre el botón Comprobar, se modifica el contenido de la ventana:

donde podemos comprobar el funcionamiento de las manivelas y de los pedales. Debemos comprobar, por ejemplo, que la manivela de la X sea efectivamente la correspondiente a la X, y también que el sentido del movimiento sea el deseado. Si queremos realizar alguna modificación, hemos de pasar a la configuración de los tensores.

Se incluye un cuarto eje, W, que se utiliza con el JoyPAD. Para configurar éste debemos seleccionar JoyStick en la lista desplegable Codificadores.

Fecha de última modificación: lunes, 10 de Marzo de 2002


Configuración de Tensores

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Tensores dentro de Dispositivo de entrada en la lista de la izquierda. Vemos que aparece un tensor en la parte derecha de la ventana. Por defecto estará configurado dicho tensor tal y como se muestra en la imagen. Sin embargo, podemos realizar modificaciones sobre este tensor. Por ejemplo:

  • Podemos cambiar la manivela X por la Y, para ello se deja el tensor de la siguiente de la siguiente forma:

  • Podemos cambiar el sentido de los ejes, por ejemplo, el sentido del eje Y:

Se incluye un cuarto eje, W, que se utiliza con el JoyPAD.

Fecha de última modificación: viernes, 28 de Junio de 2002


Configuración de la Comunicación Exterior

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Comunicación exterior en la lista de la izquierda. En la parte derecha de la ventana observamos que está desactivada por defecto la opción Enviar coordenadas a un programa de CAD externo. Si activamos esta opción, vemos como se activa el resto de elementos de la ventana:

donde podemos modificar los siguientes elementos:

  • Tipo de Comunicación: podemos elegir entre: Enviar en formato Digi3D por el Com2, UDP/IP en modo Digi21, y Emular restituidores analíticos Anagraph por el Com2.

  • Dirección: si en Tipo de Comunicación hemos seleccionado UDP/IP en modo Digi21, podemos indicar la dirección IP, y el puerto en el campo siguiente

  • Puerto: es un valor entre 1 y 65535, y corresponde con el puerto de la dirección IP que determinemos.

Fecha de última modificación: lunes, 22 de Abril de 2002


Configuración de la Aceleración de manivelas

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Aceleración de manivelas en la lista de la izquierda. En el movimiento de las imágenes disponemos de dos velocidades: normal y rápida. En esta ventana lo que se hace es configurar tanto la velocidad rápida en función de la velocidad normal, como la forma de alcanzar la velocidad rápida. Los movimientos de las manivelas son controlados por pulsos, tomando éstos como unidad de distancia. En la parte derecha de la ventana disponemos de las siguientes opciones:

  • Tiempo de muestreo para aceleración: este tiempo se relaciona con el número de impulsos en el tiempo de aceleración. Si en el intervalo de tiempo que se indique, se supera dicho número de pulsos, se pasa de velocidad normal a rápida.
  • Número de impulsos en el tiempo de aceleración: se trata del número de pulsos a superar en el intervalo de tiempo (indicado en el cuadro anterior), para que la velocidad de las manivelas pase de normal a rápida.
  • Factor de multiplicación de la velocidad: se trata del factor que relaciona la velocidad normal con la velocidad rápida. Por ejemplo, si es 5, la velocidad rápida será 5 veces mayor que la velocidad normal.
  • Tiempo de parada para recuperar la velocidad original: en el caso de tengamos velocidad rápida, se trata del intervalo de tiempo (en milisegundos) que tiene que transcurrir una vez paradas las manivelas para volver a tener la velocidad normal.

Fecha de última modificación: lunes, 22 de Abril de 2002


Configuración de la Correlación

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Correlación en la lista de la izquierda. Podemos activar/desactivar la correlación en:

  • Orientación Relativa.
  • Orientación Absoluta.
  • En medida de triangulación: si está activada nos ayudará a buscar los puntos homólogos al realizar medidas de Aerotriangulación.
  • Entre pasadas al aerotriangular.

Si está activada la casilla de la izquierda, el programa correlará al efectuar la acción que se encuentre a la derecha de la casilla activa.

El valor mínimo de correlación es el valor mínimo aceptable en la búsqueda automática de puntos homólogos. La correlación estará comprendida entre 0 y 1, siendo 1 la correlación máxima. Si el valor mínimo de correlación es 0.50, cuando el programa efectúe una búsqueda automática y el valor máximo de correlación es menor de 0.50, el ordenador pitará para avisarnos de que la correlación está por debajo del mínimo que le hemos definido. Esto no quiere decir que el punto no sea el buscado, sino que simplemente la correlación está por debajo del valor mínimo aceptable que le hemos definido.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Configuración de la Orientación Absoluta

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde se puede modificar la configuración de Digi3D. Si quieres saber más acerca de esta ventana pulsa aquí.

En lo que corresponde a la Orientación Absoluta se pueden realizar dos cambios en la configuración:

  • Indicar si queremos que el programa correle o no en la Orientación Absoluta.
  • Indicar si queremos otros cambios en la configuración de la Orientación Absoluta.

Fecha de última modificación: lunes, 15 de Abril de 2002


Cambio de la Correlación en la Orientación Absoluta

En la ventana de Configuración de Digi3D, en la parte izquierda pulsamos sobre Correlación:

En la parte derecha podemos ver la Configuración de los parámetros de correlación. La segunda casilla corresponde con la correlación en la Orientación Absoluta. Si está activada, el programa correla al efectuar dicha orientación.

El valor mínimo de correlación es el valor mínimo aceptable en la búsqueda automática de puntos homólogos. La correlación estará comprendida entre 0 y 1, siendo 1 la correlación máxima. Si el valor mínimo de correlación es 0.50, cuando el programa efectúe una búsqueda automática y el valor máximo de correlación es menor de 0.50, el ordenador pitará para avisarnos de que la correlación está por debajo del mínimo que le hemos definido. Esto no quiere decir que el punto no sea el buscado, sino que simplemente la correlación está por debajo del valor mínimo aceptable que le hemos definido.

Fecha de última modificación: lunes, 15 de Abril de 2002


Cambios en la configuración de la Orientación Absoluta

En la ventana de Configuración de Digi3D, en la parte izquierda pulsamos sobre Absoluta:

donde vemos que tenemos dos casillas para activar/desactivar las siguientes opciones:

  • Almacenar una instantánea de los puntos de apoyo medidos.
  • Mostrar los resultados de la Orientación Absoluta en tiempo real al desplazarse.

Fecha de última modificación: lunes, 15 de Abril de 2002


Almacenar instantáneas de los puntos de apoyo medidos

Si activamos esta opción se grabarán en un directorio determinado los siguientes archivos:

  • Un archivo con extensión BMP: se trata de un archivo de imagen donde se almacena una instantánea del punto de apoyo medido. Si quieres saber más acerca de las instantáneas pulsa aquí.
  • Un archivo con extensión f: se trata de un archivo de texto donde se guardan las Fotocoordenadas de los puntos de apoyo medidos en un fotograma.

El directorio donde se guardan estos archivos se puede definir en Configuración de Digi3D. Si quieres saber más acerca de la configuración de las instantáneas pulsa aquí.

Fecha de última modificación: martes, 16 de Abril de 2002


Mostrar los resultados de la Orientación Absoluta en tiempo real al desplazarse

Si está activada esta opción, cuando remidamos un punto en el cálculo de la Orientación Absoluta, nos muestra los residuos del cálculo en tiempo real en la pantalla de visualización estereoscópica:

Fecha de última modificación: martes, 16 de Abril de 2002


Configuración de la Orientación Relativa

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde se puede modificar la configuración de Digi3D. Si quieres saber más acerca de esta ventana pulsa aquí.

En lo que corresponde a la Orientación Relativa se pueden realizar varios cambios en la configuración:

  • Indicar si queremos que el programa correle o no en la búsqueda de puntos homólogos.
  • Indicar el número de puntos a partir de los que queremos que se calcule la Orientación Relativa y si queremos efectuar el cálculo de la Orientación Relativa mediante estimadores robustos.
  • Se puede configurar la Orientación Relativa Automática.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Cambio de la Correlación en la Orientación Relativa

En la ventana de Configuración de Digi3D, en la parte izquierda pulsamos sobre Correlación:

En la parte derecha podemos ver la Configuración de los parámetros de correlación. La primera casilla corresponde con la correlación en la Orientación Relativa. Si está activada, el programa correla al buscar los puntos homólogos. Si no está activada, al hacer la Orientación Relativa deberemos buscar manualmente los puntos homólogos.

El valor mínimo de correlación es el valor mínimo aceptable en la búsqueda automática de puntos homólogos. La correlación estará comprendida entre 0 y 1, siendo 1 la correlación máxima. Si el valor mínimo de correlación es 0.50, cuando el programa efectúe una búsqueda automática y el valor máximo de correlación sea menor de 0.50, el ordenador pitará para avisarnos de que la correlación está por debajo del mínimo que le hemos definido. Esto no quiere decir que el punto no sea el buscado, sino que simplemente la correlación está por debajo del mínimo que le hemos definido.

Fecha de última modificación: lunes, 15 de Abril de 2002


Cambio del número de puntos del cálculo de la Orientación Relativa y Estimadores Robustos

Si en la ventana Configuración de Digi3D, en la izquierda pulsamos sobre Relativa, vemos que la parte derecha de la ventana cambia:

Aquí podemos:

  • Cambiar el número de puntos medidos a partir de los cuales el programa calcula la Orientación Relativa. El número mínimo de puntos medidos necesario es 5. Si queremos trabajar con fotografías aéreas es el número correcto. Si se trata de un trabajo de Fotogrametría Terrestre es necesario un número de puntos superior para formar el modelo de forma correcta.
  • Utilizar estimadores robustos: por defecto se utilizarán en el cálculo de la Orientación Relativa. Si no deseamos utilizarlos en el cálculo, tendremos que desactivar esta opción. Si quieres saber algo más sobre esto lea el tema de la ayuda Estimadores Robustos.
  • Configuración de la Orientación Relativa Automática.

Fecha de última modificación: lunes, 6 de Mayo de 2002


Cambio de la configuración de la Orientación Relativa Automática

Si en la ventana Configuración de Digi3D, en la izquierda pulsamos sobre Relativa, vemos en la parte derecha de la ventana un recuadro con el título Relativa automática:

En el fichero de cámara definimos los puntos (o zonas) para la Orientación Relativa. Sólo debe haber 6 puntos, y además hay que no se deben poner los puntos en Y muy cercanos al borde la imagen, porque puede resultar que en uno de los fotogramas no se encuentre.

Podemos configurar los siguientes parámetros:

    Número de puntos por zona | Número de puntos de los que se tomarán medidas de forma automática en cada zona de las indicadas en el archivo de cámara. Si tenemos 6 zonas marcadas en dicho archivo, y en este campo indicamos 9 puntos, se tomarán medidas de 54 puntos para realizar el cálculo de la Orientación Relativa.
Tamaño de la zona de referencia | Indica el tamaño (en píxeles) de la zona donde se buscarán puntos homólogos. Estas zonas son las definidas en el archivo de cámara. El tamaño debe ser significativo con respecto al tamaño de la foto, para que funcione adecuadamente la estrategia piramidal. Por lo tanto dependerá de la resolución de la imagen.
Mínimo valor de correlación aceptable | Indica el valor mínimo de correlación aceptable para incluir un punto en el cálculo. Si en un punto se obtiene un valor de correlación menor, no se considera este punto y se busca otro.
Rechazar puntos ... | En el cálculo de la Orientación Relativa Automática se emplean los estimadores robustos, y en este cálculo se detectan errores groseros en las observaciones. Si el residuo correspondiente a un punto (una observación) es mayor a lo especificado en este parámetro, se considera que la observación es errónea y se excluye del cálculo. Esta forma de cálculo es importante debido a que un factor de correlación alto en la búsqueda automática de puntos homólogos no implica necesariamente que se trate de puntos homólogos, y es por ello que en el cálculo de la Orientación Relativa de forma automática se busquen las observaciones incorrectas mediante el método de los estimadores robustos. El valor recomendado para este parámetro es 2.5.

Fecha de última modificación: jueves, 9 de Mayo de 2002


Configuración de la Aerotriangulación

En el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Triangulación en la lista de la izquierda. En la parte derecha de la ventana tenemos las siguientes opciones:

  • Almacenar una instantánea de los puntos de apoyo: se almacenará una instantánea de cada punto la primera vez que se mide el punto. Si se mide el punto más veces (en el mismo o en otro modelo), éste no se volverá a almacenar. De este modo se consigue no arrastrar errores en la medida.
  • Nombre del subdirectorio en el cual almacenar los datos: donde se guardarán los archivos generados para el programa PatM. El subdirectorio donde se almacenan los datos es un subdirectorio hijo del directorio donde está ubicada la imagen izquierda.
  • Color en el que aparecen los puntos de apoyo: si pulsamos con el puntero del ratón sobre el cuadrado podemos cambiar el color.
  • Color en el que aparecen los puntos medidos y que no son de control: se trata de los denominados puntos de paso. Si pulsamos con el puntero del ratón sobre el cuadrado podemos cambiar el color.
  • Color en el que aparecen los puntos medidos y que no son de control y pertenecen al esquema de Areotriangulación: si pulsamos con el puntero del ratón sobre el cuadrado podemos cambiar el color.
  • Puntos medidos marcados en la foto: podemos definir el tamaño del círculo y del texto con el que se marcan en pantalla los puntos. El tamaño es constante, es decir, siempre lo vemos con el mismo tamaño independientemente del Zoom con el que estemos visualizando las imágenes.
  • Nivel piramidal inicial: se trata del nivel piramidal inicial desde el que se empieza la búsqueda de puntos homólogos. El nivel piramidal inicial está muy relacionado con el tamaño de las instantáneas y la resolución de las imágenes.
  • Pedir reseñas: si se activa esta casilla de verificación, cuando se realicen las medidas de Aerotriangulación, se puede escribir la descripción literal de las reseñas. Esta descripción se almacena en un archivo con extensión des para poder utilizarla con el generador de reseñas.

Fecha de última modificación: lunes, 29 de Julio de 2002


Configuración de las Instantáneas

n el menú principal del programa Digi3D seleccionamos Configuración en el apartado Herramientas:

y aparece la siguiente ventana:

donde pulsamos sobre Triangulación en la lista de la izquierda.

En esta ventana se configuran las instantáneas que deseamos almacenar, tanto para generar reseñas como para utilizar en la búsqueda de puntos homólogos. En la parte derecha de la ventana tenemos las siguientes opciones:

  • Tipo de marca a insertar: podemos elegir entre insertar una cruz o no insertar ninguna marca.
  • Tamaño de la marca: en píxeles.
  • Tamaño de la instantánea: ancho y alto de la instantánea en píxeles. Está muy relacionado con el tamaño de las instantáneas y la resolución de las imágenes.
  • Nombre del subdirectorio en el cual almacenar los datos: se trata de un subdirectorio del directorio donde esté ubicada la imagen izquierda.

Fecha de última modificación: lunes, 22 de Abril de 2002


Instantáneas

El restituidor digital Digi3D almacena en Instantáneas trozos de imagen que contienen puntos de apoyo o de paso, y luego utiliza estas instantáneas para realizar la búsqueda de puntos homólogos. Dicha búsqueda en Digi3D está basada en una estrategia piramidal, y es por ello por lo que es importante introducir de forma correcta:

  • Nivel piramidal inicial: se define en Configuración de la Aerotriangulación.
  • Tamaño de la instantánea: se define en Configuración de las Instantáneas.

La relación entre ambos parámetros viene marcada por la resolución con la que se hayan escaneado las imágenes. Por ejemplo, si tenemos un tamaño de píxel de 20 micras, debemos tener 16 como nivel piramidal inicial, y un tamaño de instantánea de 500x500 píxeles.

En el caso de que tengamos un tamaño de píxel de 10 micras, y definamos 16 como nivel piramidal inicial, y un tamaño de instantánea de 500x500 píxeles, se puede dar el caso de que la búsqueda no se realiza de forma adecuada. En este caso hay que definir o bien un nivel piramidal inicial de 32, o bien un tamaño de instantánea de 1000x1000 píxeles.

Fecha de última modificación: lunes, 22 de Abril de 2002


Órdenes de Digi3D

    Orden | Descripción
AEROTRI | Ejecuta un cálculo de aerotriangulación.
BOTON | Asigna dinámicamente órdenes a diferentes botones del ratón.
CALCULA_GIRO | Proporciona la convergencia entre las imágenes.
CAMBIA_BRILLO | Cambia el brillo de las imágenes.
CAMBIA_BRILLO_INDICE | Cambia el brillo de los índices.
CAMBIA_CONTRASTE | Cambia el contraste de las dos imágenes.
CAMBIA_TECLAS_MNU | Cambia la asignación de teclas actual
COLOR_INDICE | Cambia el color del índice.
CORRELAR | Posa en Z fijando la imagen izquierda.
CORRIGE_KAPA | Corrige el giro Kapa girando la imagen derecha.
EMBRAGUE | Permite desplazar el ratón 3D sin mover las imágenes.
IR_A_PUNTO_APOYO | Mueve el restituidor a un punto de apoyo del archivo de puntos.
MOSTRAR_ESTEREO | Permite activar/desactivar la superimposición en la imagen raster.
ORI_ABSOLUTA | Ejecuta una orientación absoluta.
ORI_EXTERNA | Ejecuta una orientación externa.
ORI_INTERNA_D | Ejecuta una orientación interna para la imagen derecha.
ORI_INTERNA_I | Ejecuta una orientación interna para la imagen izquierda.
ORI_RELATIVA | Ejecuta una orientación relativa.
POSITIVO_NEGATIVO | Cambia las imágenes de positivo a negativo.
RATON_DIGI3D | Activa/Desactiva el movimiento del restituidor con un ratón.
RELATIVA_AUTOMATICA | Realiza la Orientación Relativa de forma automática
REST_ZOOM1X1 | Zoom a escala 1:1.
REST_ZOOME | Zoom extensión.
REST_ZOOMIN | Zoom de acercar.
REST_ZOOMOUT | Zoom de alejar.
SALIR_DIGI3D | Sale del modo gráfico y muestra la carátula principal del restituidor.
TECLA | Asigna órdenes a teclas
TIPO_INDICE | Cambia el tipo de índice.
VELOCIDAD | Establece una velocidad para las manivelas.
VELOCIDAD_MAS_XY | Aumenta la velocidad de las manivelas en XY.
VELOCIDAD_MAS_Z | Aumenta la velocidad de las manivelas en Z.
VELOCIDAD_MENOS_XY | Disminuye la velocidad de las manivelas en XY.
VELOCIDAD_MENOS_Z | Disminuye la velocidad de las manivelas en Z.
VER_COORDENADAS | Muestra las coordenadas en la barra de mensajes.
VER_PUNTOS | Activa/Desactiva la visualización de los puntos medidos en cada foto.

Fecha de última modificación: 20 de Abril de 2004


Orden AEROTRI

Esta orden se utilia para realizar medidas de Aerotriangulación. El resultado de estas medidas de Aerotriangulación será un archivo con formato PatM y otro con formato PatB.

El programa proporciona una serie de ayudas para la medida de Aerotriangulaciones, como son:

  • La generación de una instantánea al registrar un punto. Dicha instantánea aparecerá tanto en la esquina inferior derecha de la pantalla de visualización estereoscópica al medir ese punto en otro modelo, como en la reseñas que se pueden crear mediante el Generador de Reseñas.
  • El almacenamiento de la descripción del posado en un punto, a modo de reseña literal, que facilita tanto la generación de reseñas, como el posado en dicho punto en otro modelo estereoscópico.

Para aprender cómo configurar los parámetros de la orden AEROTRI lea el tema de la ayuda Configuración de la Aerotriangulación.

Para activar la generación de instantáneas, seleccionamos Almacenar una instantánea de los puntos de apoyo medidos en la página Aerotriangulación del cuadro de diálogo Configuración de Digi3D:

Si desea aprender algo más sobre Aerotriangulación, ver un ejemplo de medida, y saber cómo es la estrategia de búsqueda en este tipo de medidas, lea el tema de la ayuda Medida de Aerotriangulación.

Fecha de última modificación: lunes, 28 de Octubre de 2002


Orden BOTON

Con ésta orden podemos asignar dinámicamente órdenes a diferentes botones de los ratones o dispositivos especiales que tengan muchos botones.

Un ejemplo de llamada a esta orden sería: BOTON = 128 rest_zoome

El número correspondiente a cada botón se puede averiguar en el archivo pedales.mnu

Fecha de última modificación: jueves, 25 de Septiembre de 2003


Orden CALCULA_GIRO

Esta orden sirve para calcular el giro entre la imagen izquierda y la imagen derecha del par estereoscópico. El ángulo proporcionado, en graduación centesimal, permite girar una de la imágenes para contrarrestar este giro. Sólo se puede calcular si está realizada la Orientación Relativa.

Se puede ejecutar la orden de dos formas:

  • Teclear CALCULA_GIRO en la ventana de órdenes, y pulsar la tecla Enter.
  • En el menú de la ventana principal de la aplicación seleccionar Digital ->Ver->Calcular el giro entre las dos imágenes, como se puede ver en la siguiente imagen:

Ejecutada la orden, Digi3D calcula el giro y lo muestra en la pantalla de visualización estereoscópica:

Y el programa espera que el usuario pulse una tecla para volver a la ejecución de Digi3D.

Posteriormente se puede girar una imagen dicho ángulo con el archivo ejecutable Girar.bat, que se instala por defecto en directorio de instalación. Este archivo llama a la orden Girar que se ejecuta desde la línea de comandos. La ejecución de Girar.bat se efectúa desde MS-DOS y tiene la siguiente sintaxis:

Girar <Archivo imagen> <grados>

Este ejecutable en primer lugar guarda la imagen original pero cambiándole el nombre al ponerle un carácter de subrayado delante. Y después efectúa el giro a la imagen, con lo que la imagen girada tendrá el mismo nombre que la original.

Si se gira una de las imágenes, se debería volver a realizar la Orientación Interna de la misma, dado que al efectuar el giro cambian las Coordenadas Píxel referidas a dicha imagen. Sin embargo, no es necesario que el usuario vuelva a realizar la Orientación Interna, porque el programa la recalcula de forma automática.

Fecha de última modificación: lunes, 1 de Julio de 2002


Orden CAMBIA_BRILLO

Digi3D

Orden: CAMBIA_BRILLO

Esta orden cambia el brillo de la imágenes.

Admite los siguientes parámetros:
Parámetro | Descripción
-3 | Oscurece la imágen derecha*.
-2 | Oscurece la imágen izquierda*.
-1 | Oscurece la dos imágenes.
0 | Reestablece el brillo de las dos imágenes.
1 | Aclara la dos imágenes.
2 | Aclara la imágen izquierda*.
3 | Aclara la imágen derecha*.

* Estas opciones no son compatibles con la opción 0 (que reestablede el brillo de las dos imágenes).

Órdenes relacionadas: POSITIVO_NEGATIVO


Orden CAMBIA_BRILLO_INDICE

Digi3D

Orden: CAMBIA_BRILLO_INDICE

Esta orden permite cambiar la intensidad de los índices conjunta o independientemente.
La intensidad de los índices es un valor que puede variar entre 0 y 255 y esta orden realiza incrementos/decrementos de 5 en 5 unidades.

La orden admite los siguientes parámetros:

Parámetro | Descripción
-4 | Pone la intensidad del índice izquierdo con su brillo original.
-3 | Disminuye el brillo de los dos índices a la vez.
-2 | Disminuye el brillo del índice izquierdo.
-1 | Aumenta el brillo del índice izquierdo.
0 | Pone la intensidad de los dos índices con su brillo original.
1 | Aumenta el brillo del índice derecho.
2 | Disminuye el brillo del índice derecho.
3 | Aumenta el brillo de los dos índices.
4 | Pone la intensidad del índice derecho con su brillo original.

Ejemplo:

CAMBIA_BRILLO_INDICE=0


Orden CAMBIA_CONTRASTE

Esta orden permite cambiar rápidamente el contraste de las dos imágenes a la vez, permitiendo acentuar la diferencia entre las zonas claras y oscuras de la imagen.

Admite los siguientes parámetros:

Parámetro | Descripción
-2 | Disminuye el contraste de las imágenes, modificando para ello directamente los píxeles.
-1 | Disminuye el contraste de las imágenes, modificando la paleta.
0 | Reestablece el contraste de las imágenes.
1 | Aumenta el contraste de las imágenes, modificando la paleta.
2 | Aumenta el contraste de las imágenes, modificando para ello directamente los píxeles.

Fecha de última modificación: jueves, 5 de Septiembre de 2002


Orden CAMBIA_TECLAS_MNU

Esta orden permite cambiar entre los distintos archivos de configuración de teclas asignados a Digi3D.

Ejemplo:
Si tenemos dos archivos de configuración de teclas A.teclas y B.teclas y en A.teclas tenemos asignada a la tecla W la orden REST_ZOOME y en B.teclas tenemos asignada la orden REST_ZOOM1x1 y el teclado actual es el A.teclas, si pulsamos la tecla W se ejecutará la orden REST_ZOOME.

Pero si ejecutamos la orden CAMBIA_TECLAS_MNU, el teclado actual pasará a ser B.teclas, por lo que al pulsar la tecla W se ejecutará la orden REST_ZOOM1x1.

Órdenes relacionadas: TECLA


Orden COLOR_INDICE

Digi3D

Orden: COLOR_INDICE

Esta orden permite cambiar el color de los índices en la pantalla estereoscópica. Sólo tiene un parámetro, Color, que se corresponde con el color de la paleta que aparece en la página Apariencia del cuadro de diálogo de Configuración.

Si no se especifica ningún parámetro, el programa itera por todos los colores de la paleta.

Ejemplo:

COLOR_INDICE=7


Orden CORRELAR

Esta orden hace que el restituidor se pose en Z buscando un punto homólogo al centro de la imágen que le indiquemos por el parámetro. Hace falta que estén realizadas las orientaciones para poder hacer uso de esta orden.

La orden admite los siguientes parámetros:
Parámetro | Descripción
0 (o sin parámetro) | Se posa en Z fijando la imagen izquierda.
1 | Se posa en Z fijando la imagen derecha.


Orden CORRIGE_KAPA

Gira la imagen derecha para corregir la diferencia de giro Kappa entre las imágenes que forman el modelo estereoscópico cargado. Esta orden sólo funciona cuando esté hecha la Orientación Relativa.

Fecha de última modificación: lunes, 21 de Octubre de 2002


Orden EMBRAGUE

Digi3D

EMBRAGUE

Esta orden permite mover el ratón 3D sin mover las imágenes de la pantalla de visualización estereoscópica. Se asigna esta orden a un botón del ratón 3D, si desea aprender a hacerlo lea el tema de la ayuda Programar los botones del ratón.

La manera de utilizar esta orden es la siguiente:

  1. Se pulsa el botón del ratón 3D asociado a esta orden.
  2. Con el botón pulsado, se mueve el ratón. Se puede observar que las imágenes no se desplazan al mover el ratón.
  3. Cuando el ratón esté en la posición deseada, se suelta el botón del ratón, y vuelve a estar asociado el movimiento del ratón con el de las imágenes.

Esta orden se suele utilizar cuando al digitalizar una entidad continua, se acaba el espacio físico sobre la mesa y con ello se limita el movimiento del ratón. Entonces se pulsa el botón asociado a la orden EMBRAGUE, y manteniéndolo pulsado se coloca el ratón en una posición mejor de la mesa. Entonces se suelta el botón y se puede seguir digitalizando.

Fecha de última modificación: miércoles, 30 de Octubre de 2002


Orden IR_A_PUNTO_APOYO

Esta orden mueve el restituidor a un punto de apoyo cuyas coordenadas deben aparecer en el archivo de puntos que se especificó en la carátula de entrada Monoscópico.

La orden al cargar comprueba que hemos entrado en formato estereoscópico y que la relativa y la absoluta están realizadas.
Después solicita un punto* y busca dicho punto en el archivo de puntos. Si lo encuentra desplaza el restituidor a dicho punto. *El punto se puede entrar de dos formas:

  • Introduciendo un número de punto (el programa buscará por la primera columna del archivo de puntos).
  • Introduciendo *[nemotécnico] Ej: *PK12 (el programa buscará por el nemotécnico del archivo de puntos).

Elementos relacionados: Formato de los archivos de puntos.


Orden MOSTRAR_ESTEREO

Digi3D

Orden: MOSTRAR_ESTEREO

Esta orden permite activar/desactivar tanto la imágen raster cómo la superimposición.

Puede tener los siguientes valores:
Parámetro | Descripción
Sin parámetro | Alterna la visualización entre: Mostrar sólo raster/Mostrar sólo superimposición/Mostrar todo.
0 | Muestra sólo la superimposición.
1 | Muestra sólo la imágen raster.
2 | Muestra todo.


Orden ORI_ABSOLUTA

Esta orden sirve para realizar la Orientación Absoluta de un par estereoscópico con Digi3D. Si desea aprender a efectuar lea el tema de la ayuda Orientación Absoluta.

Fecha de última modificación: martes, 30 de julio de 2002


Orden ORI_EXTERNA

Esta orden sirve para realizar la Orientación Externa de una imagen con Digi3D. Si desea aprender a efectuarla lea el tema de la ayuda Orientación Externa.

Fecha de última modificación: martes, 30 de julio de 2002


Orden ORI_INTERNA_D

Esta orden sirve para realizar la Orientación Interna de la imagen derecha de un par estereoscópico con Digi3D. Si desea aprender a efectuarla lea el tema de la ayuda Orientación Interna.

Fecha de última modificación: martes, 30 de julio de 2002


Orden ORI_INTERNA_I

Esta orden sirve para realizar la Orientación Interna de la imagen derecha de un par estereoscópico con Digi3D. Si desea aprender a efectuarla lea el tema de la ayuda Orientación Interna.

Fecha de última modificación: martes, 30 de julio de 2002


Orden ORI_RELATIVA

Esta orden sirve para realizar la Orientación Relativa de un par estereoscópico con Digi3D. Si desea aprender a efectuar lea el tema de la ayuda Orientación Relativa.

Fecha de última modificación: martes, 30 de julio de 2002


Orden POSITIVO_NEGATIVO

Digi3D

POSITIVO_NEGATIVO

Modifica la visualización de las imágenes para alternar entre visualizarlas en positivo y en negativo.

Órdenes relacionadas: CAMBIA_BRILLO


Orden RATON_DIGI3D

Digi3D

RATON_DIGI3D

Esta orden permite mover la pantalla estereoscópica con el ratón. Si el ratón tiene rueda al mover ésta moveremos el restituidor en Z.

Esta orden no admite parámetros. Si el ratón no está moviendo el restituidor y la ejecutamos, pasa a moverlo y si lo está moviendo y la ejecutamos deja de moverlo.

Fecha de última modificación: martes, 15 de Octubre de 2002


Orden RELATIVA_AUTOMATICA

Esta orden sirve para la Orientación Relativa de forma automática. Para ejecutarla se deben tener las imágenes cargadas y la Orientación Interna de cada una realizada. Se puede ejecutar la orden bien tecleando RELATIVA_AUTOMATICA (y pulsando después la tecla Enter) en la ventana de órdenes, o bien seleccionando Orientación Relativa Automática por Correlación en Digital dentro del menú principal de Digi3D:

De cualquiera de las dos formas aparece la siguiente barra de estado:

donde se pulsa sobre el botón Comenzar. Entonces empieza a buscar y medir puntos homólogos en las imágenes, y la barra de progreso de esta ventana irá avanzando. En primer lugar aparecerá el mensaje Midiendo puntos por correlación. Cuando termina de buscar y medir, efectúa el cálculo de la Orientación Relativa, con lo que aparece el mensaje Calculando en la ventana de Orientación Relativa por Correlación. Cuando termina de calcular muestra una ventana donde se pueden observar los resultados del cálculo:

Para terminar la ejecución de la orden se cierra esta ventana pulsando la cruz en forma de aspa que está situada en la esquina superior derecha.

Una vez que el restituidor digital Digi3D ha terminado el cálculo, ya está hecha la Orientación Relativa. Ahora la letra r de la barra de estado pasa de minúsculas a mayúsculas, R, y tenemos un nuevo fichero en el directorio de trabajo que se llama 107-108.rel.

La Orientación Relativa Automática es totalmente configurable, en cuanto a número de puntos a medir, valor mínimo de correlación, ... También se puede optar por realizar las Orientaciones Relativas de varios modelos a la vez de forma automática.

Fecha de última modificación: miércoles, 26 de Junio de 2002


Orden REST_ZOOM1X1

Muestra las imágenes que se visualizan en la pantalla estereoscópica con un factor de 1x.

Órdenes relacionadas:

REST_ZOOMIN | REST_ZOOMOUT | REST_ZOOME

Fecha de última modificación: martes, 30 de julio de 2002


Orden REST_ZOOME

Hace un Zoom extendido de las imágenes que se visualizan en la pantalla estereoscópica.

Si ejecutamos la orden una vez, calcula el zoom extendido para centrar el índice en la foto izquierda, y si ejecutamos la misma orden una segunda vez calcula el zoom extendido para centrar el íondice en la foto derecha.

Órdenes relacionadas:

REST_ZOOMIN | REST_ZOOMOUT | REST_ZOOM1X1

Fecha de última modificación: martes, 30 de julio de 2002


Orden REST_ZOOMIN

Aumenta el factor de Zoom de las imágenes que se visualizan en la pantalla estereoscópica.

Por motivos de redondeo, no se permiten todos los factores de zoom, por los que los factores de zoom cuando estamos aumentando la imágen se limitan a: 2x, 4x, 5x, 10x, 20x.

Órdenes relacionadas:

REST_ZOOMOUT | REST_ZOOME | REST_ZOOM1X1

Fecha de última modificación: martes, 30 de julio de 2002


Orden REST_ZOOMOUT

Disminuye el factor de Zoom de las imágenes que se visualizan en la pantalla estereoscópica.

Órdenes relacionadas:

REST_ZOOMIN | REST_ZOOME | REST_ZOOM1X1 |

Fecha de última modificación: nartes, 30 de julio de 2002


Orden SALIR_DIGI3D

Finaliza una sesión de Digi3D dejando el monitor estereoscópico en modo normal y desconectándose de cualquier dispositivo de entrada.

Al ejecutar esta orden, el restituidor sale de modo gráfico sin descargar de memoria las fotos que se estuvieran viendo estereoscópicamente. Si volvemos a modo gráfico mediante el cuadro de diálogo de nuevo proyecto, las fotos no se vuelven a cargar ya que permanecen en memoria.

Fecha de última modificación: martes, 30 de julio de 2002


Orden TECLA

Permite asignar órdenes a teclas (en el teclado activo).

Al ejecutar la orden aparece una ventana que nos dice que pulsemos una tecla. Al pulsar una tecla, aparece una segunda ventana con la orden asignada a la tecla pulsada. En dicha ventana tecleamos la orden que queremos que se ejecute al pulsar dicha tecla.

Para salir de esta orden pulsamos la tecla Esc.

Órdenes relacionadas: CAMBIA_TECLAS_MNU

Fecha de última modificación: martes, 30 de julio de 2002


Orden TIPO_INDICE

Cambia el tipo de índice que se muestra en las imágenes de la pantalla estereoscópica.

Esta orden acepta parámetros:

Parámetro | Comportamiento de la orden
ninguno | alterna el tipo de índice entre los siguientes: aspa, cruz, índice grande, índice mediano, índice pequeño.
0 | Muestra el índice en forma de cruz.
1 | Muestra el índice en forma de punto grande.
2 | Muestra el índice en forma de punto mediano.
3 | Muestra el índice en forma de punto pequeño.
4 | Muestra el índice en forma de aspa.

Fecha de última modificación: martes, 30 de julio de 2002


Orden VELOCIDAD

Modifica la velocidad del restituidor.

Se puede establecer una velocidad para XY y otra diferente para Z

El formato de la orden es el siguiente:

VELOCIDAD=[xy] [z]

Si no se especifica una velocidad para Z, se establece la misma velocidad que para XY.

Ejemplos:

VELOCIDAD=5.75 (establece la velocidad de XY y Z a 5.75) VELOCIDAD=5.75 4.22 (establece la velocidad de XY a 5.75 y la de Z a 4.22)

Órdenes relacionadas:

VELOCIDAD_MAS_XY | VELOCIDAD_MENOS_XY | VELOCIDAD_MAS_Z | VELOCIDAD_MENOS_Z

Fecha de última modificación: martes, 30 de julio de 2002


Orden VELOCIDAD_MAS_XY

Aumenta la velocidad de las manivelas en XY.

Órdenes relacionadas:

VELOCIDAD_MENOS_XY | VELOCIDAD_MAS_Z | VELOCIDAD_MENOS_Z | VELOCIDAD

Fecha de última modificación: martes, 30 de julio de 2002


Orden VELOCIDAD_MAS_Z

Aumenta la velocidad de las manivelas en Z.

Órdenes relacionadas:

VELOCIDAD_MAS_XY | VELOCIDAD_MENOS_XY | VELOCIDAD_MENOS_Z | VELOCIDAD

Fecha de última modificación: martes, 30 de julio de 2002


Orden VELOCIDAD_MENOS_XY

Disminuye la velocidad de las manivelas en XY.

Órdenes relacionadas:

VELOCIDAD_MAS_XY | VELOCIDAD_MAS_Z | VELOCIDAD_MENOS_Z | VELOCIDAD

Fecha de última modificación: martes, 30 de julio de 2002


Orden VELOCIDAD_MENOS_Z

Disminuye la velocidad de las manivelas en Z.

Órdenes relacionadas:

VELOCIDAD_MAS_XY | VELOCIDAD_MENOS_XY | VELOCIDAD_MAS_Z | VELOCIDAD

Fecha de última modificación: martes, 30 de julio de 2002


Orden VER_COORDENADAS

Muestra coordenadas en la barra de mensajes de la pantalla estereoscópica.

Esta orden acepta los siguientes parámetros:

Parámetro | Comportamiento de la orden
ninguno | Alterna la visualización de coordenadas entre las siguientes opciones:no mostrar, mostrar coordenadas pixel, mostrar coordenadas foto, mostrar coordenadas modelo, mostrar coordenadas terreno.
0 | No muestra ninguna coordenada.
1 | Muestra coordenadas pixel.
2 | Muestra coordenadas foto.
3 | Muestra coordenadas modelo.
4 | Muestra coordenadas terreno.

Fecha de última modificación: martes, 30 de julio de 2002


Orden Ver_puntos

Digi3D

VER_PUNTOS

Activa o desactiva la visualización de los puntos medidos en cada foto.

Si no ponemos ningún parámetro, la orden alterna entra activada/desactivada.

Ejemplo:

ver_puntos=1


Formatos de archivo utilizados en Digi3D

En este tema de la ayuda se encuentra la documentación sobre los distintos formatos de archivos que se emplean en Digi3D:

  • Formato del archivo de MDTPC.
  • Formato del archivo de importación de orientaciones.
  • Formato del archivo de importación en un paso.
  • Formato del archivo de importación de absoluta.
  • Formato del archivo de puntos.
  • Formato del archivo de cámara.
  • Formato del archivo de importación de relativa.
  • Formato del archivo de Orientación Interna.
  • Formato del archivo de Orientación Relativa.
  • Formato del archivo de Orientación Absoluta.
  • Formato del archivo de Orientación Externa.

Fecha de última modificación: lunes, 20 de Mayo de 2002


Formato del archivo de MDTPC

Digi3D

Formato del archivo de Modelo Digital del Terreno Por Correlación

Un archivo de definición de cámara es un archivo ASCII con extensión .MDTPC y con el siguiente formato (Por cada proceso que queramos ejecutar definimos una sección con el formato):

[ProcesoX]
donde X es el número de proceso.

Dentro de la sección de proceso se definen los siguientes campos:
ImagenIzquierda | Ruta completa de la imagen izquierda (con extensión) | Obligatorio
ImagenDerechaFocal | Ruta completa de la imagen izquierda (con extensión) | Obligatorio
ArchivoEntrada | Ruta completa (con extensión) de un archivo Digi con el límite de correlación y con líneas o puntos de ruptura. | Obligatorio
ArchivoSalida | Ruta completa (con extensión) de un archivo Digi donde se almacenarán los resultados. Este archivo puede coincidir con el archivo Digi de entrada. | Obligatorio
CodigoLimite | Código Digi con el que se definió el límite de correlación. Con este código debe de existir una línea cerrada dentro del archivo Digi de entrada. | Obligatorio
GeometriaLinaLimite Número que indica la geometría del límite.
Puede tener los siguientes valores:
Valor | Significado
0 | Ningun vértice está posado en Z
1 | Sólo los vértices están posados en Z
2 | Toda la línea está posada en Z
 Obligatorio
ZMin | Z mínima por encima de la cual se tomarán puntos de las líneas de ruptura. | Obligatorio
ZMax | Z máxima por debajo de la cual se tomarán puntos de las líneas de ruptura. | Obligatorio
DistanciaPuntos | Distancia en XY entre los puntos correlados. | Obligatorio
DesplazamientoZMaximo | Valor que multiplicado por la variable DistanciaPuntos indica la distancia máxima que permitimos se nos desplaze la Z de un punto correlado a otro. | Opcional. Por defecto vale 2.0
SemianchoEnPixeles | Indica el semiancho en píxeles del rectángulo de corelación de la imagen de referencia en el factor piramidal 1. | Opcional
PendienteMinima | Valor que indica la pendiente mínima en % que se permite en el MDT resultante. | Opcional. Valor por defecto: 0
PendienteMaxima | Valor que indica la pendiente máxima en % que se permite en el MDT resultante. | Opcional. Valor por defecto: 9999
GenerarArchivoLog Valor que indica si queremos que se nos genere un archivo .log por cada archivo de salida.
Puede tener dos valores:
Valor | Significado
0 | No generar archivo .log
1 | Generar archivo .log
 Opcional. Por defecto vale 1

Un ejemplo de archivo de Modelo Digital Del Terreno por Correlación:
Nombre: prueba.mdtpc

[Proceso1]
ImagenIzquierda=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\1834.TIF
ImagenDerecha=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\1835.TIF
ArchivoEntrada=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\limiteCorrelacion.bin
ArchivoSalida=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\10metros.bin
CodigoLimite=1
GeometriaLinaLimite=1
ZMin=0
ZMax=9999
DistanciaPuntos=10
DesplazamientoZMaximo=2
PendienteMinima=0
PendienteMaxima=30
GenerarArchivoLog=1

[Proceso2]
ImagenIzquierda=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\1834.TIF
ImagenDerecha=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\1835.TIF
ArchivoEntrada=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\limiteCorrelacion.bin
ArchivoSalida=C:\Documents and Settings\Administrador\Mis documentos\Trabajo\Superimposición\20metros.bin
CodigoLimite=1
GeometriaLinaLimite=1
ZMin=0
ZMax=9999
DistanciaPuntos=20
DesplazamientoZMaximo=2
SemianchoEnPixeles=0
Semiancho=0.001
PendienteMinima=0
PendienteMaxima=30
GenerarArchivoLog=1

Fecha de última modificación: jueves, 31 de mayo de 2001


Formato del archivo de importación de orientaciones externas

Digi3D

Formato del archivo de importación de orientaciones externas.

Este método de importación permite crear una orientación de relativa y de absoluta a partir de las orientaciones externas de dos imágenes.

El archivo de importación de orientaciones externas es un archivo ASCII con extensión .ext.

El formato del archivo es el siguiente:

Z media del terreno
Línea en blanco
X del centro de proyección izquierdo | Y del centro de proyección izquierdo | Z del centro de proyección izquierdo
m[0][0] | m[0][1] | m[0][2]
m[1][0] | m[1][1] | m[1][2]
m[2][0] | m[2][1] | m[2][2]
Línea en blanco
X del centro de proyección derecho | Y del centro de proyección derecho | Z del centro de proyección derecho
m[0][0] | m[0][1] | m[0][2]
m[1][0] | m[1][1] | m[1][2]
m[2][0] | m[2][1] | m[2][2]

Para poder importar con este método, deben existir los ficheros de orientación interna de las dos fotos.

Ejemplo de un archivo de importación de externas:

1500

 619147.278 4485284.058    2379.772
   0.998918545482773    0.046494213491351    0.000166139706411
  -0.046494499237927    0.998909461837703    0.004260116398083
   0.000032112236590   -0.004263233858414    0.999990911861639

 619605.583 4485282.565    2381.200
   0.998954112658913    0.045566328140500    0.003793486738503
  -0.045595656067190    0.998927611262379    0.008041368381045
  -0.003423003015699   -0.008205924532275    0.999960472145237

Fecha de última modificación: 10 de octubre de 2000


Formato del archivo de importación de Orientaciones Externas con centros de proyeccion y giros

Digi3D

Formato del archivo de importación de Orientaciones Externas con centros de proyección y giros

Este método de importación permite crear las Orientaciones Relativa y Absoluta a partir de las Orientaciones Externas de las imágenes.

El archivo de importación de Orientaciones Externas con centros de proyección y giros es un archivo ASCII con extensión .EO.

En este tipo de archivos cada línea corresponde con la Orientación Externa de una imagen, y debe contener los siguientes campos:

Número fotograma | Nombre o Número de imagen
X | Coordenada Terreno X del centro de proyección.
Y | Coordenada Terreno Y del centro de proyección.
Z | Coordenada Terreno Z del centro de proyección.
Omega | Giro Omega del fotograma.
Fi | Giro Fi del fotograma.
Kappa | Giro Kappa del fotograma.

Los giros pueden estar expresados en diferentes unidades: sexagesimales (con fracción decimal de grado), centesimales, y radianes. El tipo de unidades se especifica en el importador.

Si desea ver un ejemplo de archivo de importación de Orientaciones Externas con centros de proyección y giros lea el siguiente tema de la ayuda.

Fecha de última modificación: miércoles, 23 de octubre de 2002


Ejemplo de archivos de importación de Orientaciones Externas con centros de proyeccion y giros

Digi3D

Ejemplo de archivo de importación de Orientaciones Externas con centros de proyección y giros

    107    619148.44630   4485283.40650      2380.31970  0.294773570878  0.082736022455  2.659147728045
    108    619607.63810   4485283.12660      2380.93760  0.443475904859 -0.076555280102  2.628497726498
    109    620067.60540   4485281.08770      2379.83100 -0.102214882909 -0.047187554564  2.677791219669

Fecha de última modificación: miércoles, 23 de octubre de 2002


Formato del archivo de importación de relativa y absoluta en un paso

El archivo de importación en un paso es un archivo ASCII con extensión .XYZxyxy.

El formato del archivo es el siguiente:
Número de punto X terreno Y terreno Z terreno x foto izquierda y foto izquierda x foto derecha y foto derecha

Para poder importar con este método, deben existir los ficheros de Orientación Interna de las dos fotos.

Ejemplo de un archivo de importación de relativa y absoluta en un paso:

 1    619145.587 4485235.863 1570.562       -0.778      -9.813       -88.496      -6.134
 2    619622.554 4485312.546 1585.774       92.335       0.577         2.944       4.439
 2    619622.554 4485312.546 1585.774       92.335       0.577         2.944       4.439
 3    619699.089 4485909.921 1532.877      105.161     108.012        21.398     111.088
 4    619222.715 4485838.743 1557.910       18.846     102.121       -67.118     105.472
 5    619237.525 4484876.591 1657.491       15.173     -88.564       -83.344     -84.513
 6    619644.824 4484797.280 1660.227      101.895    -110.108         3.070    -105.840
 7    619403.250 4485279.006 1594.907       50.095      -3.992       -40.273      -0.105
 8    619372.450 4485584.037 1552.176       44.340      53.057       -41.232      56.560
 9    619499.734 4485141.135 1614.580       69.567     -32.723       -23.202     -28.702

Fecha de última modificación: 10 de octubre de 2000


Formato del archivo de importación de absoluta

El archivo de importación de Orientación Absoluta es un archivo ASCII con extensión .xyzxyz.

El formato del archivo es el siguiente:
Todas las líneas con el mismo significado
Número de punto X Terreno Y Terreno Z Terreno X modelo Y modelo Z modelo

Ejemplo de un archivo de importación de absoluta:

  1004 633340.41 4474372.32 1159.23   81.471   83.559 -145.290
  1002 633586.40 4474988.31 1173.16   -4.249   13.569 -143.930
  1005 632940.66 4475126.08 1118.54   79.141  -58.841 -153.450
  1001 633605.71 4474645.67 1154.27   20.585   65.007 -146.514
  1003 633168.97 4475294.67 1169.05   32.143  -65.152 -145.236

Fecha de última modificación: 2 de octubre de 2000


Formato del archivo de puntos

Un archivo de puntos para el restituidor digital tiene un formato muy sencillo:

Es un archivo ASCII con varias líneas cada una de las cuales indica el número de punto y las Coordenadas Terreno de éste. Se puede añadir un comentario detrás de la Coordenada Z.

Se admiten como separadores de campo el espacio, tabulador, comillas y coma.

El identificador de un punto tiene que ser numérico.

Ejemplos válidos de puntos en un archivo de puntos:

1255 432257.32 4655200.46  127.66
1255 432257.32 4655200.46  127.66    "Arqueta, cota suelo"
1255,432257.32,4655200.46 "127.66"  Arqueta, cota suelo

Fecha de última modificación: 14 de septiembre de 2000


Formato del archivo de descripciones

Es un archivo ASCII con varias líneas, cada una de las cuales indica la información relativa a un punto. Cada fila de este archivo tiene los siguientes campos:

Número de punto | Identificador de punto.
Descripción | Información escrita por el usuario al realizar la medida de Aerotriangulación, en el caso de que estuviera activa la casilla Pedir Reseñas en la Configuración de la Aerotriangulación. Corresponde con la variable ___DESCRIPCION___ utilizada en la Plantilla para el Generador de Reseñas.
Pasada | Número de pasada indicada en el Cuadro de diálogo Nuevo Proyecto (Página Estereoscópico). Se corresponde con la variable ___PASADA___ utilizada en la Plantilla para el Generador de Reseñas.
Fotograma | Nombre de la imagen izquierda del modelo estereoscópico con el que se haya hecho la medida para Aerotriangulación. Se corresponde con la variable ___FOTOGRAMA___ utilizada en la Plantilla para el Generador de Reseñas.

Se admiten como separadores de campo el espacio, tabulador, comillas y coma.

Fecha de última modificación: viernes, 18 de Octubre de 2002


Formato del archivo de cámara

Un archivo de definición de cámara es un archivo ASCII con extensión .CAM y con el siguiente formato:

Se define dentro del archivo una sección Cámara.

Dentro de la sección cámara se definen los siguientes campos:
PosicionPanel Un valor numérico que indica la posición del panel. Puede tener los siguientes valores:
Valor | Significado
0 | Izquierda
1 | Arriba
2 | Derecha
3 | Abajo
Focal | Valor de la focal de la lente.
PuntoPrincipal | Coordenadas del punto de mejor simetría.
Fiducial x Coordenadas de las diferentes marcas fiduciales de la cámara Puede haber cualquier número de marcas fiduciales. El valor x puede ir desde 1 hasta n y no se puede saltar ningun valor.

Cuando el programa analiza el archivo de cámara comienza a buscar la fiducial Fiducial1 y después la fiducial Fiducial2 y así sucesivamente hasta que no encuentra una fiducial x. Si por ejemplo tenemos una fiducial 1,2,3 y 5, el programa sólo cargará las fiduciales 1, 2 y 3 ya que al ir a leer las coordenadas de la fiducial 4 y al no encontrar ninguna línea que la defina determinará que se han acabado las coordenadas de marcas fiduciales y no leerá la fiducial Fiducial5.

PRel x Coordenadas de los distintos puntos de relativa. A estas coordenadas nos llevará el programa cuando realicemos una orientación de relativa. Una vez estemos haciendo la orientación de relativa podremos añadir interactivamente nuevos puntos de relativa.

Si vas a realizar la Orientación Relativa de varios modelos de forma automática, debes indicar solamente 6 puntos. Además debes introducir una coordenada Y que no sea muy grande, con el fin de que no esté cerca del borde del fotograma, pues puede darse el caso de que no encuentre puntos homólogos en la imagen derecha .

PAero x | Sufijo de numeración de punto y coordenadas X,Y del esquema de puntos de Aerotriangulación.
Distorsion x Especifica las distorsiones radiales de la cámara.
Tiene dos parámetros:
Radio | Especifica el radio de la medida de distorsión.
Distorsión | Especifica el valor de distorsión para el radio especificado.

Los valores de las distorsiones/radios de distorsión se introducirán en las mismas unidades que el resto de parámetros en el archivo de cámara. Nótese que en la mayoría de los certificados de calibración de cámaras, los radios se dan en milímetros y los valores de distorsión en micras. Debiéndose poner aquí todos en las mismas unidades (normalmente en milímetros).

Un ejemplo de archivo de definición de cámara es el siguiente:
Nombre: rc10.cam

[Camara]
PosicionPanel=0
Focal=154.052
PuntoPrincipal=0.015 -0.004
Fiducial1=113.009 -0.004
Fiducial2=-112.987 -0.004
Fiducial3=0.015 113.002
Fiducial4=0.015 -113.016
Fiducial5=113.005 112.994
Fiducial6=-112.991 -113.015
Fiducial7=-112.989 112.991
Fiducial8=113.016 -113.013
PRel1=0 0
PRel2=90 0
PRel3=90 90
PRel4=0 90
PRel5=0 -90
PRel6=90 -90
PRel7=45 0
PRel8=45 50
PRel9=45 -50
PAero1=1 0.0   0.0
PAero2=2 0.0  90.0
PAero3=3 0.0 -90.0
Distorsion1=0 0.000
Distorsion2=10 0.000
Distorsion3=20 0.000
Distorsion4=30 -0.001
Distorsion5=40 -0.001
Distorsion6=50 0.000
Distorsion7=60 0.001
Distorsion8=70 0.002
Distorsion9=80 0.001
Distorsion10=90 -0.001
Distorsion11=100 0.000
Distorsion12=110 -0.001
Distorsion13=120 -0.002
Distorsion14=130 -0.001
Distorsion15=140 0.000
Distorsion16=150 0.001

Fecha de última modificación: jueves, 9 de Mayo de 2002


Formato del archivo de importación de Relativa

El archivo de importación de Orientación Relativa es un archivo ASCII con extensión .xyxy.

El formato del archivo es el siguiente:
Cabecera
Número de puntos | Focal | Base |
Resto de líneas
X* izquierda | Y* izquierda | X* derecha | Y* derecha
* Estas medidas son fotocoordenadas, los campos se delimitan por espacios/comas/comillas.

Ejemplo de un archivo de importación de relativa:

8 152.410  102.000
    0.079   -97.222    -94.976  -102.758
   -3.891    -0.451    -97.474    -4.282
    7.812   106.378    -91.562    99.246
   44.997    54.680    -54.666    50.170
   99.584    93.075      1.091    87.246
   98.517     0.299     -1.200    -2.702
   95.781   -99.125     -0.403  -103.962
   46.853   -49.851    -49.392   -53.547

Fecha de última modificación: 2 de octubre de 2000


Archivo de Orientación Interna

Una vez realizada la Orientación Interna, se guardan los datos correspondientes a la misma en un archivo de texto, con extensión INN y con el mismo nombre que la imagen. Si la imagen es 107.tif, el archivo de Orientación Interna será 107.inn. Dicho archivo contiene los siguientes datos:

    Cadena de texto | Esta cadena en este tipo de archivos siempre es RESULTADOS DE LA ORIENTACIÓN INTERNA.
    Parámetros En la Orientación Interna se aplica una Transformación Afín. En este archivo se escriben dos juegos de parámetros, correspondientes a:
    Paso de Fotocoordenadas a Coordenadas Píxel.
    Paso de Coordenadas Píxel a Fotocoordenadas.
    Datos cámara | Esta fila contiene las coordenadas del Punto Principal y la distancia focal de la cámara.
    Posición Panel | Posición de los relojes en la imagen, tal y como está definido en el archivo de cámara.
    Datos

    Son los datos con los que se ha calculado la Transformación Afín. Están en los siguientes campos:
    Fiducial | Número de marca fiducial
Coordenadas Fiducial | Fotocoordenadas, X e Y, de las marcas fiduciales. Son las especificadas en el archivo de cámara.
Coordenadas Medidas | Coordenadas Píxel de las punterías efectuadas a las marcas fiduciales.
Ex, Ey | Error en X, Y, respectivamente, de la Orientación Interna. Se expresan en las mismas unidades que las Fotocoordenadas.
    Nombre de la fotografía | Especifica el nombre del archivo de Orientación Interna, y en qué directorio se almacena.
    Fecha | Escribe la fecha y la hora de creación del archivo de Orientación Interna.

Si quieres ver un ejemplo de este tipo de archivo pulsa aquí.

Fecha de última modificación: lunes, 1 de Julio de 2002


Ejemplo de archivo de Orientación Interna

       RESULTADOS DE LA ORIENTACIÓN INTERNA
   0.000209904769502   -0.000001946808953    -116.315
  -0.000001953515495   -0.000209897937278     117.725

  4763.653966347548700  -44.183017283407715  559283.620
 -44.335222895246169 -4763.809024327200900  555661.142

   0.015000000000000   -0.004000000000000  154.051999999999990

  0

  Fiducial -Coordenadas Fiducial-         -Coordenadas Medidas-            -Ex-       -Ey-
      1     113.009      -0.004            1097620      550696         -0.000       0.005
      2    -112.987      -0.004              21053      560681          0.000      -0.002
      3       0.015     113.002             554363       17367         -0.000       0.005
      4       0.015    -113.016             564348     1094038         -0.000      -0.002
      5     113.005     112.994            1092608       12334          0.000      -0.007
      6    -112.991    -113.015              26027     1099053         -0.000       0.000
      7    -112.989     112.991              16051       22403          0.000      -0.000
      8     113.016    -113.013            1102646     1089023          0.000       0.000

  EM.= 0.003
  Nombre de la fotografía: C:\instalacion\BRONCHALES\107.inn
  Fecha: 1/7/2002 10:07

Fecha de última modificación: lunes, 1 de Julio de 2002


Archivo de Orientación Relativa

Una vez realizada la Orientación Relativa, se guardan los datos correspondientes a la misma en un archivo de texto, con extensión REL y con los nombres de las imágenes del modelo formado. Si las imágenes son 107.tif y 108.tif, el archivo de Orientación Relativa será 107-108.rel.

El archivo de Orientación Relativa contiene los siguientes datos:

    Cadena de texto | Esta cadena en este tipo de archivos siempre es RESULTADOS DE ORIENTACIÓN RELATIVA.
    Focal | Distancia focal de la cámara, especificada en el archivo de cámara.
    Coordenadas Punto Principal | Fotocoordenadas del Punto Principal, especificadas en el archivo de cámara.
    Parámetros de la imagen izquierda Se escriben los siguientes parámetros:
    bxi, byi, bzi | Base del fotograma izquierdo. Las unidades son las mismas de las Coordenadas Modelo.
Matriz de rotación | matriz de rotación de la imagen izquierda
    Parámetros de la imagen derecha Se escriben los siguientes parámetros:
    bxd, byd, bzd | Base del fotograma derecho. Las unidades son las mismas de las Coordenadas Modelo.
Matriz de rotación | matriz de rotación de la imagen derecha
    Coordenadas Modelo punto inicial | En esta línea se escriben las Coordenadas Modelo del punto que se visualizará al entrar en Digi3D. Por defecto se trata del primer punto al que se haya hecho puntería.
    Datos

    Son los datos con los que se ha calculado la Orientación Relativa. Están en los siguientes campos:
    N | Número de punto medido.
xFizq, yFizq | Fotocoordenadas X e Y, correspondientes a la imagen izquierda, de los puntos medidos.
xFder, yFder | Fotocoordenadas X e Y, correspondientes a la imagen derecha, de los puntos medidos.
xMod, yMod, zMod | Coordenadas Modelo X, Y, Z de los puntos medidos.
    Residuos

    Son los datos con los que se ha calculado la Orientación Relativa. Están en los siguientes campos:
    N | Número de punto medido.
vXizq, vYizq | Residuos en X e Y, correspondientes a la imagen izquierda, de los puntos medidos.
vXder, vYder | Residuos en X e Y, correspondientes a la imagen derecha, de los puntos medidos.
py(micras) | Paralaje en los puntos medidos.
    Puntos medidos | Es el número de puntos medidos antes de iniciar el cálculo. Por lo tanto son 6*Número de puntos por zona indicados en la configuración de la Orientación Relativa Automática.
    Puntos rechazados | Es el número de puntos medidos que son rechazados durante el cálculo de la Orientación Relativa de forma automática. Para excluirlos del cálculo se utilizan estimadores robustos.
    Número de iteraciones | Número de iteraciones realizadas en el cálculo de la Orientación Relativa.
    Giro de la cámara izquierda | Giros Omega, Phi y Kappa correspondientes a la imagen izquierda.
    Giro de la cámara derecha | Giros Omega, Phi y Kappa correspondientes a la imagen derecha.
    Nombre del modelo | Especifica el nombre del modelo.
    Fecha | Escribe la fecha y la hora de creación del archivo de Orientación Relativa.

Si quieres ver un ejemplo de este tipo de archivo pulsa aquí.

Fecha de última modificación: viernes, 10 de Mayo de 2002


Ejemplo de archivo de Orientación Relativa

      RESULTADOS DE LA ORIENTACIÓN RELATIVA
    154.052
      0.015      -0.004
      0.000       0.000       0.000

   1.000000000000000    0.000000000000000    0.000000000000000
   0.000000000000000    1.000000000000000    0.000000000000000
   0.000000000000000    0.000000000000000    1.000000000000000

     87.465      -4.359       0.239
   0.999995763173224   -0.000934864922658    0.002756748660664
   0.000924482514998    0.999992484833877    0.003765050842542
  -0.002760247757204   -0.003762486324739    0.999989112305216

      3.990      -7.139    -154.803
  N       -xFizq-     -yFizq-       -xFder-     -yFder-        -xMod-      -yMod-      -zMod-
 1         3.971      -7.102       -83.495      -3.426         3.990      -7.139    -154.803
 2        69.689       1.197       -19.370       5.010        68.754       1.181    -151.986
 3        91.067      89.704         3.857      93.084        91.890      90.516    -155.445
 4         3.893      88.452       -84.489      91.972         3.867      87.850    -153.001
 5        15.771     -87.797       -82.542     -83.727        14.101     -78.504    -137.746
 6        90.387     -90.634        -6.928     -86.434        81.530     -81.755    -138.958
 7        45.219      -0.924       -43.849       2.843        44.600      -0.911    -151.946
 8        42.199      49.959       -43.370      53.468        43.330      51.295    -158.181
 9        50.904     -46.226       -42.428     -42.211        47.906     -43.499    -144.977

  N       -vXizq-     -vVizq-       -vXder-     -vYder--    -py- (micras)
 1           0.1         1.8          -0.1        -1.8          -0.0
 2          -0.0        -0.1           0.0         0.1           0.0
 3          -0.0        -0.5           0.0         0.5           0.0
 4          -0.1        -1.5           0.1         1.5           0.0
 5           0.0         0.1          -0.0        -0.1          -0.0
 6           0.1         1.4          -0.1        -1.4          -0.0
 7           0.0         0.0          -0.0       -28.6          -0.0
 8           0.1         2.9          -0.1        -2.9          -0.0
 9          -0.2        -4.0           0.2         4.0           0.0

  Número de iteraciones: 11

  Giros de la cámara izquierda:
  Omega:    0.0000 gon  Phi:    0.0000 gon Kappa:    0.0000 gon

  Giros de la cámara derecha:
  Omega:    0.2395 gon Phi:   -0.1757 gon Kappa:   -0.0589 gon

  Nombre del modelo: 107-108

  Fecha: 3/5/2002 12:16

Fecha de última modificación: viernes, 3 de Mayo de 2002


Archivo de Orientación Absoluta

Una vez realizada la Orientación Absoluta, se guardan los datos correspondientes a la misma en un archivo de texto, con extensión ABS y con los nombres de las imágenes que forman el modelo separados por un guión. Si el modelo está formado por las imágenes 107.tif y 108.tif, el archivo de Orientación Absoltuta será 107-108.abs. Dicho archivo contiene los siguientes datos:

    Cadena de texto | Esta cadena en este tipo de archivos siempre es RESULTADOS DE ORIENTACIÓN ABSOLUTA.
    Parámetros de Orientación Absoluta En la Orientación Absoluta se aplica. En este archivo se escriben los siguientes parámetros:
    Coordenadas Terreno X, Y, Z. del punto de vista de la imagen izquierda.
    Matriz de rotación
    Giros Omega, Phi y Kappa.
    Cadena de texto | La cadena es RESULTADOS DE ORIENTACIÓN EXTERNA.
    Cadena de texto | La cadena es IMAGEN IZQUIERDA.
    Parámetros de Orientación Externa de la imagen izquierda

            Se escriben los siguientes parámetros:
    Coordenadas Terreno X, Y, Z. del punto de vista de la imagen izquierda.
    Matriz de rotación de la imagen izquierda.
    Giros Omega, Fi y Kappa.

    Cadena de texto | La cadena es IMAGEN DERECHA.
    Parámetros de Orientación Externa de la imagen derecha

            Se escriben los siguientes parámetros:
    Coordenadas Terreno X, Y, Z. del punto de vista de la imagen derecha.
    Matriz de rotación de la imagen derecha.
    Giros Omega, Fi y Kappa.

    Datos

    Son los datos con los que se ha calculado la Orientación Absoluta. Están en los siguientes campos:
    Punto | Número de punto de apoyo
Coordenadas Puntos de Apoyo | Coordenadas Terreno, X, Y, Z, de los puntos de apoyo. Las coordenadas son las especificadas en el archivo de puntos.
Coordenadas Medidas | Coordenadas Modelo, x, y, z de los posados efectuadas a los puntos de apoyo.
Ex, Ey, Ez | Error en X, Y, Z, respectivamente, de la Orientación Absoluta. Se expresa en las mismas unidades que las Coordenadas Terreno.
    EM | Error medio cuadrático del cálculo de la Orientación Absoluta.
    Nombre del modelo | Especifica el nombre del archivo de Orientación Absoluta, y en qué directorio se almacena.
    Fecha | Escribe la fecha y la hora de creación del archivo de Orientación Absoluta.

Si quieres ver un ejemplo de este tipo de archivo pulsa aquí.

Fecha de última modificación: viernes, 3 de Mayo de 2002


Ejemplo de archivo de Orientación Absoluta

     RESULTADOS DE LA ORIENTACIÓN ABSOLUTA
 619147.932 4485284.258    2380.267
  5.219492894148830
   0.998918838409510   -0.046482709913381    0.000715506606037  Omega:   -0.2515
   0.046485167407721    0.998911281545414   -0.003921837882383    Phi:   -0.0339
  -0.000532429968177    0.003950858186264    0.999992053587388  Kappa:   -2.9604

  RESULTADOS DE LA ORIENTACIÓN EXTERNA

  IMAGEN IZQUIERDA
 619147.932 4485284.258    2380.267
   0.998918838409510    0.046485167407721   -0.000532429968177  Omega:    0.2497
  -0.046482709913381    0.998911281545414    0.003950858186264    Phi:    0.0456
   0.000715506606037   -0.003921837882383    0.999992053587388  Kappa:    2.9602

  IMAGEN DERECHA
 619606.668 4485282.698    2381.332
   0.998962197776433    0.045467096906253    0.002696388806817  Omega:    0.4970
  -0.045486637663324    0.998935328336329    0.007692567560678    Phi:   -0.1492
  -0.002343759323321   -0.007807233857613    0.999966776393959  Kappa:    2.8968

  PUNTO   -XT-       -YT-     -ZT-     -xi-     -yi-     -zi-    -Ex-   -Ey-   -Ez-
     7 619567.94 4485076.88 1609.77   78.635  -44.043 -147.398 -0.118  0.160 -0.036
     6 619505.09 4485329.17 1582.30   68.859    4.799 -152.888 -0.124  0.057  0.119
     3 619215.47 4485537.36 1573.80   15.283   47.278 -154.695 -0.099 -0.276  0.025
     4 619173.90 4485177.30 1577.10    4.096  -21.306 -153.783  0.017 -0.016 -0.059
     5 619683.26 4485643.34 1593.09  105.668   63.346 -151.001  0.325  0.075 -0.050

  EM.= 0.187

  Nombre del modelo: C:\instalacion\BRONCHALES\107-108.abs

  Fecha: 26/4/2002 19:13

Fecha de última modificación: viernes, 3 de Mayo de 2002


Archivo de Orientación Externa

Una vez realizada la Orientación Externa de una imagen, se guardan los datos correspondientes a la misma en un archivo de texto, con extensión ORI y con el mismo nombre que la imagen. Si la imagen es 107.tif, el archivo de Orientación Externa será 107.ori. Al realizar la Orientación Absoluta de un par estereoscópico se crean dos archivos ORI, uno para cada imagen del par.

El archivo de Orientación Externa contiene los siguientes datos:

    Cadena de texto | Esta cadena en este tipo de archivos siempre es [Orientacion]
    Cadena de texto | Esta cadena es Modo=Externa.
    Cadena de texto | Esta cadena es [Interna]
    Parámetros de Orientación Interna Se escriben los siguiente parámetros:

    m0, m1 | Parámetros matemáticos de la Transformación Afín relativos a los factores de escala y al giro. Esta Transformación Afín es la correspondiente al paso de Fotocoordenadas a Coordenadas Píxel.
desp | Parámetros matemáticos de la Transformación Afín relativos a las traslaciones. Esta Transformación Afín es la correspondiente al paso de Fotocoordenadas a Coordenadas Píxel.
Focal | Distancia focal de la cámara, especificada en el archivo de cámara.
Puntoprincipal | Fotocoordenadas del Punto Principal, especificadas en el archivo de cámara.
    Cadena de texto | Esta cadena es [Externa]
    Parámetros de Orientación Externa Se escriben los siguiente parámetros:

    m0, m1, m2 | Matriz de rotación de la imagen.
CentroProyección | Coordenadas Terreno del Centro de Proyección (o Punto de Vista), de la cámara.
ZMedia | Cota media del terreno. Este dato se introduce porque los archivos ORI se utilizan para calcular Ortofotografías con Digi21.

Si quieres ver un ejemplo de este tipo de archivo pulsa aquí.

Fecha de última modificación: viernes, 3 de Mayo de 2002


Ejemplo de archivo de Orientación Externa

      [Orientacion]
  Modo=Externa

  [Interna]
  m0=47.6377287184 -0.4465960389
  m1=-0.4453196552 -47.6333620454
  Desp= 5592.7184  5556.4272
  Focal=  154.0520
  PuntoPrincipal=    0.0150    -0.0040

  [Externa]
  m0= 0.9989188384  0.0464851674 -0.0005324300
  m1=-0.0464827099  0.9989112815  0.0039508582
  m2= 0.0007155066 -0.0039218379  0.9999920536
  CentroProyeccion=  619147.9323  4485284.2580     2380.2673
  ZMedia=    1609.7680

Fecha de última modificación: viernes, 3 de Mayo de 2002


Plantillas para el Generador de Reseñas

El Generador de Reseñas utiliza una plantilla, que le sirve como modelo para crear la reseña de cada punto. Este modelo se define con un archivo en formato HTML y con extensión .pr, y en él se definen tanto la forma como el contenido de las reseñas.

La información que se puede introducir en las reseñas se define mediante las siguientes variables:

___NUMERO_DE_PUNTO___ | Número de punto reseñado. Se define en el Generador de Reseñas.
___X___ | Coordenada Terreno X del punto reseñado. El Generador de Reseñas la toma del archivo de puntos.
___Y___ | Coordenada Terreno Y del punto reseñado. El Generador de Reseñas la toma del archivo de puntos.
___Z___ | Coordenada Terreno Z del punto reseñado. El Generador de Reseñas la toma del archivo de puntos.
___FOTOGRAMA___ | Número de fotograma reseñado. Se toma del archivo de descripciones.
___PASADA___ | Número de pasada. Se define en el Cuadro de diálogo Nuevo Proyecto (Página Estereoscópico), y queda almacenado en el archivo de descripciones.
___DESCRIPCION___ | Se introducirá la informacion del punto que se encuentre en el archivo de descripciones.
___NOMBRE_FOTO___ | Con esta variable indicamos donde queremos que el programa introduzca la imagen. Debe estar dentro de una etiqueta de tipo imagen, por ejemplo <img src="___NOMBRE_FOTO___">. La imagen que se introduce corresponde a la instantánea almacenada directorio de Instantáneas, con las características definidas en la Configuración de Instantáneas.

Si quieres ver un ejemplo de Plantilla de Reseñas lee el siguiente tema de la ayuda.

Fecha de última modificación: viernes, 18 de Octubre de 2002


Ejemplo de Plantilla para el Generador de Reseñas

<P><TABLE border=0>
  <TR>
    <TD bgcolor=#ddddff><B><FONT face=Verdana size=2>Nº de punto</FONT></B></TD>
    <TD bgcolor=#ddddff colspan=2><FONT face=Verdana size=2>___NUMERO_PUNTO___</FONT></TD>
  </TR>
  <TR>
    <TD bgcolor=#ddddff><B><FONT face=Verdana size=2>Pasada</FONT></B></TD>
    <TD bgcolor=#ddddff colspan=2><FONT face=Verdana size=2>___PASADA___</FONT></TD>
  </TR>
  <TR>
    <TD bgcolor=#ddddff><B><FONT face=Verdana size=2>Fotograma</FONT></B></TD>
    <TD bgcolor=#ddddff colspan=2><FONT face=Verdana size=2>___FOTOGRAMA___</FONT></TD>
  </TR>
  <TR>
    <TD bgcolor=#ddddff><B><FONT face=Verdana size=2>Descripción</FONT></B></TD>
    <TD bgcolor=#ddddff colspan=2><FONT face=Verdana size=2>___DESCRIPCION___</FONT></TD>
  </TR>
  <TR>
    <TD bgcolor=#ddddff align=center><B><FONT face=Verdana size=2>X</FONT></B></TD>
    <TD bgcolor=#ddddff align=center><B><FONT face=Verdana size=2>Y</FONT></B></TD>
    <TD bgcolor=#ddddff align=center><B><FONT face=Verdana size=2>Z</FONT></B></TD>
  </TR>
  <TR>
    <TD bgcolor=#ddddff><FONT face=Verdana size=2>___X___</FONT></TD>
    <TD bgcolor=#ddddff><FONT face=Verdana size=2>___Y___</FONT></TD>
    <TD bgcolor=#ddddff><FONT face=Verdana size=2>___Z___</FONT></TD>
  </TR>
  <TR>
    <TD bgcolor=#ddddff colspan=3 align=center>
    <IMG border=1 src="___NOMBRE_FOTO___">
    </TD>
  </TR>
  </TABLE>

Este modelo se repite para cada punto. Si deseas ver un ejemplo de archivo HMTL así generado lee el tema de la ayuda Apoyo.hmtl.

Fecha de última modificación: viernes, 18 de Octubre de 2002


Archivo Coordenadas Modelo para Aerotriangulación

Archivo de Fotocoordenadas para Aerotriangulación

Una vez realizada la Aerotriangulación, se guardan los datos correspondientes a la misma en dos archivos de texto, con extensión .f y con el mismo nombre que las fotografías que componen el modelo. Si el modelo está formado por las imágenes 107 y 108, los archivos de Fotocoordenadas de Aerotriangulación se llamarán 107.f y 108.f. Dicho archivo contiene los siguientes datos:

    Primera línea | Cadena de números que identifica la imagen y a continuación el valor de la focal multiplado por 1000.
    Segunda línea y siguientes Contienen las fotocoordenadas de los puntos medidos para Aerotriangulación. Esta línea está formada por los siguientes campos:
    Número | Número del primer punto medido
X | Fotocoordenada X del primer punto medido
Y | Fotocoordenada Y del primer punto medido
0 | Valor 0, que queda como parámetro fijo.
0, 1 ó 2 | El último campo nos da el tipo de punto de Aerotriangulación. Será un 0 en caso de ser Punto de Apoyo, un 1 en caso de ser Punto de Paso o un 2 en caso de ser un punto del esquema de Aerotriangulación.
    Última línea | Debe ser siempre -99.

    Si quieres ver un ejemplo de este tipo de archivo lee el siguiente tema de la ayuda.

    Fecha de última modificación: lunes, 7 de Octubre de 2002


Estimadores Robustos

En Digi3D, los estimadores robustos se aplican en el cálculo de la Orientación Relativa. El cálculo de ésta normalmente se efectúa por Mínimos Cuadrados, método aplicado cuando se tiene un número superior observaciones que de incógnitas, esto es, cuando tenemos redundancias en el sistema de observación. Con el método de Mínimos Cuadrados se obtienen buenos resultados si las observaciones del cálculo se distribuyen en torno a la curva de distribución Normal de Gauss.

Sin embargo, en el caso de que tengamos errores groseros o equivocaciones en las observaciones, los resultados obtenidos mediante los Mínimos Cuadrados se ven afectados por dichos errores groseros, y no hay forma de saber cuál o cuáles de las observaciones son equivocaciones. Debido a esto, se aplican los estimadores robustos, que permiten detectar los errores groseros en las observaciones. Una vez detectada la observación incorrecta se puede bien eliminar del cálculo o bien reobservar.

La aplicación de los estimadores robustos en el cálculo se realiza mediante la introducción de una función de pesos en el método de los Mínimos Cuadrados. Los pesos que se asignan son:

  • Pequeños: en el caso de que se detecte que la observación es errónea, para que la ecuación correspondiente a esta observación pese poco en el sistema.
  • La unidad (1): en el caso de que no se trate de una observación grosera.

El estimador robusto aplicado en el cálculo de la Orientación Relativa es el denominado método Danés modificado, el cual emplea la siguiente función de pesos:

donde Sigma es la desviación típica calculada, y v es el residuo de la observación que se está evaluando.

Fecha de última modificación: viernes, 3 de Mayo de 2002


Importar/Exportar

En Digi3D existe la posibilidad de realizar importaciones y exportaciones de varios tipos de archivo. Si se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se puede seleccionar la importación o exportación a realizar:

  • Exportar archivos .job y .mod para Kork.
  • Exportar datos de aerotriangulación para AeroSys.
  • Exportar orientaciones a formato PatB y a formato de centro de proyección y giros.
  • Exportar orientaciones para Albany.
  • Generar un archivo .bin con el gráfico de modelos.
  • Importar absolutas de PatM y .MOD.
  • Importar absolutas desde un archivo.
  • Importar archivos .SUP de LH Systems (centros de proyección y giros).
  • Importar de PatB fotocoordenadas y coordenadas terreno.
  • Importar de PatB orientaciones.
  • Importar de PatB orientaciones (en grupo).
  • Importar internas de Digi21.
  • Importar orientaciones de Albany.
  • Importar orientaciones de DIAP.
  • Importar orientaciones de DIAP con centros de proyección y giros.
  • Importar orientaciones externas.
  • Importar orientaciones externas con centros de proyección y giros.
  • Importar orientaciones externas con centros de proyección y giros en grupo.
  • Importar orientaciones externas de SD2000.
  • Importar relativa y absoluta desde un archivo en un solo paso con fotocoordenadas.
  • Importar relativas desde un archivo.
  • Preparar datos para PatB y PatM.
  • Sacar instantáneas de fotos a partir de sus archivos de fotocoordenadas de aerotriangulación.

El procedimiento para efectuar una de las importaciones/exportaciones es seleccionar la opción correspondiente y pulsar sobre el botón Ejecutar, situado en la parte inferior derecha de la ventana. En caso de que no se desee realizar ninguna opción, se cierra la ventana bien pulsando sobre el botón Salir, situado en la parte inferior derecha de la misma, o bien pulsando sobre la cruz en forma de aspa que se encuentra en la esquina superior derecha de la ventana.

La lista de importaciones/exportaciones aparece ordenada alfabéticamente. Además aparece seleccionada la última importación/exportación ejecutada, por lo que si se desea volver a ejecutar la misma, nada más hay que pulsar sobre el botón Ejecutar, o bien directamente pulsar la tecla Enter.

Fecha de última modificación: miércoles, 23 de Octubre de 2002


Exportar archivos .job y .mod para Kork

Para exportar archivos en los formatos JOB y MOD para Kork, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar archivos .job y .mod para Kork, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Archivo de absoluta: se selecciona el archivo con extensión .ABS que contiene los datos de la Orientación Absoluta efectuada en Digi3D.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede observarse en el tema de la ayuda Formato del archivo de cámara.
  • Nombre del modelo: se trata del nombre que se quiera asignar al modelo.
  • Nombre del archivo .job a generar: aquí se escribe el nombre del archivo a crear. Si se pulsa sobre su correspondiente botón Examinar, aparece la siguiente ventana:

    se puede observar como en la lista desplegable correspondiente a Tipo por defecto aparece Archivos de definición de trabajo de Kork (*.job).

Seleccionados los elementos deseados en la ventana Exportar archivos .job y .mod para Kork, se pulsa sobre el botón Exportar situado en la parte inferior de dicha ventana.

Si quiere ver un ejemplo de exportación de archivos .job y .mod lea el siguiente tema de la ayuda.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Ejemplo de exportación de archivos .job y .mod para Kork

Digi3D

Ejemplo de exportación a archivos .job y .mod para Kork

Para exportar a archivos .job y .mod para Kork se necesita tener hecha la Orientación Absoluta de un modelo estereoscópico. Además necesitamos el archivo de cámara.

Para exportar archivos en los formatos JOB y MOD para Kork, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Exportar archivos .job y .mod para Kork, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de absoluta: en este ejemplo se trata del archivo 107-108.abs,
  • Archivo de cámara: en este ejemplo se trata del archivo RMK15.cam.
  • Nombre del modelo: se trata del nombre que queremos asignar al modelo, por ejemplo 107-108.
  • Nombre del archivo .job a generar: escribimos, por ejemplo, Proyecto.job. También se generará el archivo Proyecto.mod

Seleccionados los elementos deseados en la ventana Exportar archivos .job y .mod para Kork, pulsamos sobre el botón Exportar situado en la parte inferior de dicha ventana.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Exportar datos de Aerotriangulación para AeroSys

Para exportar datos de Aerotriangulación para AeroSys, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar datos de aerotriangulación para AeroSys, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Título del proyecto: se trata del título que le desee asignar al proyecto.
  • Archivo a generar: aquí se escribe el nombre del archivo a crear. Si pulsamos sobre su correspondiente botón Examinar, aparece la siguiente ventana:

    se puede observar como en la lista desplegable correspondiente a Tipo por defecto aparece Archivos de proyecto de AeroSys.

  • Archivo de puntos: se trata del archivo donde están las coordenadas de los puntos de apoyo. Si quiere saber cómo es el formato de este tipo de archivos lea el tema de la ayuda Formato del archivo de puntos.
  • Candidatos: en esta lista aparecen los fotogramas que son candidatos a entrar en la exportación a AeroSys.
  • Incluir: en este cuadro aparecen los fotogramas seleccionados que se incluyen en la exportación a AeroSys.

Seleccionados los elementos deseados en la ventana Exportar datos de orientación para AeroSys, se pulsa sobre el botón Exportar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo exportación de datos de Aerotriangulación a AeroSys lea el siguiente tema de la ayuda.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Ejemplo de exportación de datos de Aerotriangulación para AeroSys

Para exportar datos de Aerotriangulación para AeroSys, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Exportar datos de aerotriangulación para AeroSys, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de cámara: es un archivo ASCII cuya descripción puede observarse en el tema de la ayuda Formato del archivo de cámara. En este ejemplo se trata del archivo RMK15.cam.
  • Título del proyecto: se trata del título que le queremos asignar al proyecto, en este caso se pone como título Proyecto.
  • Archivo a generar: aquí escribimos el nombre del archivo a crear. En este caso Proyecto.
  • Archivo de puntos: se trata del archivo donde están las coordenadas de los puntos de apoyo. En este ejemplo se trata del archivo BRONCHALES.XYZ.
  • Candidatos: en esta lista aparecen los fotogramas que son candidatos a entrar en la exportación a AeroSys. Aparecen los imágenes 107 y 108.
  • Incluir: en este cuadro aparecen los fotogramas seleccionados que se incluyen en la exportación a AeroSys. En este caso se trata de 107 y 108.

Seleccionados los elementos deseados en la ventana Exportar datos de orientación para AeroSys, se pulsa sobre el botón Exportar situado en la parte inferior de dicha ventana.

El restituidor digital Digi3D genera dos archivos: Proyecto.cal y Proyecto.ctl. El contenido del fichero Proyecyo.cal es el siguiente:

    CAM
RMK15
8 154.052 0.015 -0.004  0.00000E+0000  0.00000E+0000  0.00000E+0000  0.00000E+0000   0  0  0
1 113.009 -0.004 0.001 0.001
2 -112.987 -0.004 0.001 0.001
3 0.015 113.002 0.001 0.001
4 0.015 -113.016 0.001 0.001
5 113.005 112.994 0.001 0.001
6 -112.991 -113.015 0.001 0.001
7 -112.989 112.991 0.001 0.001
8 113.016 -113.013 0.001 0.001

y a continuación se expone el contenido del archivo Proyecto.ctl:

    CTL
Archivo CTL generado automáticamente por Digi3D
1 618919.208 4485805.702 1558.194 0.05 0.05
2 618883.344 4484881.606 1598.679 0.05 0.05
3 619215.468 4485537.355 1573.802 0.05 0.05
4 619173.900 4485177.298 1577.095 0.05 0.05
5 619683.262 4485643.336 1593.088 0.05 0.05
6 619505.093 4485329.173 1582.302 0.05 0.05
7 619567.940 4485076.883 1609.768 0.05 0.05
8 620097.282 4485672.614 1554.958 0.05 0.05
9 620144.153 4485309.845 1550.214 0.05 0.05
-99

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Exportar Orientaciones a formato PatB y a formato de centro de proyección y giros

Para exportar Orientaciones a formato PatB y a formato de centro de proyección y giros, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar orientaciones a formato PatB y a formato de centro de proyección y giros, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Directorio con los archivos .ABS: ubicación de los archivos ABS. Si se pulsa sobre Examinar aparece la siguiente ventana donde se selecciona dicho directorio:

  • Archivo a exportar: se trata del archivo con los datos a exportar y es un archivo ASCII. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    • donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos se puede ver Archivos de orientación, con lo que se asignará una extensión por defecto al archivo a crear.

  • Grados: se trata de la unidad con la que se escribirán los giros. Podemos elegir entre radianes, sexagesimales y centesimales:

Seleccionados todos los archivos en la ventana Exportar a PatB con centros de proyección y giros, pulsamos sobre el botón Exportar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo de exportación de Orientaciones a formato PatB y a formato centros de proyección y giros lea el siguiente tema de la ayuda.

Fecha de última modificación: martes, 15 de Octubre de 2002


Ejemplo de exportación de Orientaciones a formato PatB y a formato de centro de proyección y giros

Para poder realizar esta exportación es necesario tener en un mismo directorio los archivos .abs generados al realizar la Orientación Absoluta.

Para exportar Orientaciones a formato PatB (.or) y a formato de centro de proyección y giros (.eo), se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar orientaciones a formato PatB y a formato de centro de proyección y giros, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Directorio con los archivos .ABS: ubicación de los archivos abs. En este ejemplo se trata del directorio C:\BRONCHALES, en el que están los archivos 107-108.abs, y 108-109.abs.
  • Archivo a exportar: se trata del archivo con los datos a exportar y es un archivo ASCII, por ejemplo ExpPatB.or (por defecto con la extensión .OR). Hay que resaltar que se generarán dos archivos, uno con el formato correspondiente a PatB (ExpPatB.or), y otro con el correspondiente a centro de proyección y giros (ExpPatB.eo).
  • Grados: se trata de la unidad con la que se escribirán los giros, por ejemplo sexagesimales.

Seleccionados todos los archivos en la ventana Exportar a PatB con centros de proyección y giros, se pulsa sobre el botón Exportar situado en la parte inferior de dicha ventana. Realizada la exportación se generan los archivos ExpPatB.or y ExpPatB.eo en el directorio donde están los archivos .ABS. El archivo ExpPatB.or tiene el siguiente contenido:

        107      0.00000000    619148.44630   4485283.40650      2380.31970
 -0.998922166800  0.046394175300  0.001444015500 -0.046401030800 -0.998909643600
 -0.005144741300  0.001203754900 -0.005206199900  0.999985723100
              108      0.00000000    619607.63810   4485283.12660      2380.93760
 -0.998946991900  0.045859808700 -0.001336141300 -0.045848145000 -0.998918434900
 -0.007740030500 -0.001689652500 -0.007670620600  0.999969152900
              109      0.00000000    620067.60540   4485281.08770      2379.83100
 -0.998907720400  0.046719245300 -0.000823578100 -0.046720654400 -0.998906400900
  0.001783984700 -0.000739331000  0.001820514200  0.999998069600

y el archivo ExpPatB.eo el siguiente:

        107    619148.44630   4485283.40650      2380.31970  0.294773570878  0.082736022455  2.659147728045
    108    619607.63810   4485283.12660      2380.93760  0.443475904859 -0.076555280102  2.628497726498
    109    620067.60540   4485281.08770      2379.83100 -0.102214882909 -0.047187554564  2.677791219669

Fecha de última modificación: martes, 15 de Octubre de 2002


Exportar orientaciones para Albany

Para exportar las orientaciones realizadas en Digi3D para Albany mediante un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar orientaciones para Albany y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Directorio con los archivos .ORI: ubicación de los archivos de orientación generados por Digi3D al finalizar la Orientación Absoluta o la Externa. Si desea conocer el formato de los archivos .ORI lea el tema de la ayuda Formato de archivo de Orientación Externa.
  • Archivo a generar: nombre y ubicación del archivo donde se exportan las orientaciones. Por defecto se le asigna la extensión OPM.
  • Pasada: se trata del número de pasada.

Seleccionados todos los archivos en la ventana Exportar datos para Albany, se pulsa sobre el botón Exportar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo de este tipo de exportación lea el siguiente tema de la ayuda.

Fecha de última modificación: viernes, 13 de Septiembre de 2002


Ejemplo de exportación de orientaciones para Albany

Para exportar las orientaciones realizadas en Digi3D a Albany mediante un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar orientaciones para Albany y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Directorio con los archivos .ORI: en este caso se encuentran en la carpeta C:\BRONCHALESs.
  • Archivo a generar: el archivo donde se exportan las orientaciones es 107-108.opm.
  • Pasada: en este caso se trata de la pasada número 1.

Seleccionados todos los archivos en la ventana Exportar datos para Albany, se pulsa sobre el botón Exportar situado en la parte inferior de dicha ventana. El archivo generado presenta el siguiente contenido:

1  107  1 619148.673000 4485284.696200 2380.126500 154.052000
1  107  1 0.225028116191233 0.097231745945445 -197.025566310471390
1  108  1 619606.937100 4485282.713200 2381.434300 154.052000
1  108  1 0.496010451627751 -0.131521632331406 2.890895502655118
1  0  1 0.000000 0.000000 0.000000 0.000000
1  0  1 0.000000000000000 0.000000000000000 0.000000000000000
1  0  1 0.000000 0.000000 0.000000 0.000000
1  0  1 0.000000000000000 0.000000000000000 0.000000000000000
1  0  1 0.000000 0.000000 0.000000 0.000000
1  0  1 0.000000000000000 0.000000000000000 0.000000000000000
1  0  1 0.000000 0.000000 0.000000 0.000000
1  0  1 0.000000000000000 0.000000000000000 0.000000000000000
1  0  1 0.000000 0.000000 0.000000 0.000000
1  0  1 0.000000000000000 0.000000000000000 0.000000000000000
1  0  1 0.000000 0.000000 0.000000 0.000000
1  0  1 0.000000000000000 0.000000000000000 0.000000000000000

Fecha de última modificación: viernes, 13 de Septiembre de 2002


Generar un archivo .BIN con el gráfico de modelos

Para importar un archivo .BIN con el gráfico de modelos, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar absolutas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Directorio con los archivos .ORI: se trata de la ubicación del directorio donde están los archivos .ORI correspondientes a los modelos para los que se va crear el gráfico en un archivo .BIN. Si pulsamos sobre su correspondiente botón Examinar, aparece la siguiente ventana donde seleccionamos el directorio:

  • Archivo .BIN a generar: se trata del archivo en el que se dibujará el gráfico de modelos. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde vemos en la lista desplegable Tipo que por defecto aparece Archivos DIGI, y se guardará con extensión .BIN.

Seleccionados todos los archivos en la ventana Generar un gráfico de las fotos de un trabajo, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de generación de un archivo .BIN con el gráfico de modelos pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Ejemplo de generación de un archivo .BIN con el gráfico de modelos

Si queremos generar un grafico con los modelos formados en Digi3D debemos haber realizado todas las Orientaciones fotogramétricas, estos es, las Orientaciones Interna, Relativa y Absoluta (o bien por el camino Orientación Interna y Externa). En el directorio de trabajo se habrán generado los correspondientes archivos .ORI.

Para importar un archivo .BIN con el gráfico de modelos, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar absolutas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Directorio con los archivos .ORI: en este ejemplo se trata del directorio C:\Instalacion\BRONCHALES. Los archivos ORI que se encuentran dentro de dicho directorio son: 107.ori, 108.ori, y 109.ori.
  • Archivo .BIN a generar: se trata del archivo en el que se dibujará el gráfico de modelos. En este caso se trata de grafico.bin.

Seleccionados todos los archivos en la ventana Generar un gráfico de las fotos de un trabajo, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

De esta forma en el archivo grafico.bin tenemos un grafico con los modelos.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Importar Orientaciones Absolutas de PatM y .MOD

Para importar Orientaciones Absolutas de PatM y de archivos .MOD, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar absolutas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo de puntos: se trata de un archivo de puntos generado por PatM.

Seleccionados todos los archivos en la ventana Importar absolutas de PatM y .mod, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de este tipo de importación pulsa aquí.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Ejemplo de importación de Orientaciones Absolutas de PatM y .MOD

Para importar Orientaciones Absolutas de PatM y de archivos .MOD, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar absolutas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí. En este caso se trata del archivo RMK15.cam.
  • Archivo de puntos: se trata de un archivo de puntos generado por PatM. En este caso se trata del archivo Proyecto.ctl.

Seleccionados todos los archivos en la ventana Importar absolutas de PatM y .mod, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Importar Orientación Absoluta desde un archivo

Para importar una Orientación Absoluta desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar absolutas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Absoluta a importar. Es un archivo ASCII con extensión XYZXYZ cuya descripción puede aprenderse pulsando aquí. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos ASCII (N Xt Yt Zt Xm Ym Zm)(*.XYZXYZ), que nos ayuda a identificar el formato del archivo de importación de Orientación Absoluta.

Seleccionados todos los archivos en la ventana Importar Absoluta, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo importación de Orientación Absoluta pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Ejemplo de importación de Orientación Absoluta desde un archivo

Para importar la Orientación Absoluta es necesario tener un archivo con los datos en el formato adecuado. Digi3D no importa los parámetros de la Orientación Absoluta directamente, sino las coordenadas que le son necesarias, y con ellas calcula la Orientación Absoluta. En este caso concreto los datos necesarios son las Coordenadas Terreno y las Coordenadas Modelo de los puntos de apoyo. Para que se calcule de forma correcta la Orientación Relativa correspondiente a las Coordenadas Modelo debe ser la misma, y por ello lo normal es importar primero la Orientación Relativa, y después los datos de la Orientación Absoluta.

En este ejemplo, supongamos que tenemos el modelo 107-108, formado por las imágenes 107.tif y 108.tif. Además, supongamos que ya hemos realizado (o importado) las Orientaciones Internas de ambas fotografías, con lo que tendremos los archivos 107.inn y 108.inn en el directorio de trabajo, y que también hemos efectuado (o importado) la Orientación Relativa para este modelo, por lo que tendremos también el archivo 107-108.rel en el directorio de trabajo. Para completar las Orientaciones falta la Absoluta, y tenemos las Coordenadas Terreno de los puntos de apoyo, y también las Coordenadas Modelo de dichos puntos. Estas Coordenadas Modelo han sido obtenidas con la misma Orientación Relativa que tenemos en el archivo 107-108.rel.

Necesitamos crear un archivo en formato de importación de la Orientación Absoluta, que simplemente se trata de un archivo ASCII de texto, en el que cada fila es un punto de apoyo con las Coordenadas Terreno y las Coordenadas Modelo. En nuestro ejemplo es el siguiente archivo:

    7 619567.94 4485076.88 1609.77   78.635  -44.043 -147.398
6 619505.09 4485329.17 1582.30   68.859    4.799 -152.888
3 619215.47 4485537.36 1573.80   15.283   47.278 -154.695
4 619173.90 4485177.30 1577.10    4.096  -21.306 -153.783
5 619683.26 4485643.34 1593.09  105.668   63.346 -151.001

donde se puede ver que son 5 puntos de apoyo (son necesarios un mínimo de 3 puntos de apoyo para poder efectuar el cálculo de la Orientación Absoluta). Este archivo tiene por nombre 107-108.xyzxyz.

Para importar los datos para calcular la Orientación Absoluta el archivo 107-108.xyzxyz, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar absolutas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: en nuestro ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: en nuestro ejemplo se trata de la imagen 108.tif.
  • Archivo de cámara: en nuestro ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Absoluta a importar, que en nuestro ejemplo es 107-108.xyzxyz.

Seleccionados todos los archivos en la ventana Importar Absoluta, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana. Una vez importado, Digi3D calcula la Orientación Absoluta y almacena los resultados en el archivo 107-108.abs:

    RESULTADOS DE LA ORIENTACIÓN ABSOLUTA
 619147.931 4485284.263    2380.271
5.219511402629197
   0.998918959856032   -0.046480098520562    0.000715598814251  Omega:   -0.2512
   0.046482553873740    0.998911421766970   -0.003917096994773    Phi:   -0.0339
  -0.000532752774727    0.003946125316109    0.999992072103310  Kappa:   -2.9602
    RESULTADOS DE LA ORIENTACIÓN EXTERNA
    IMAGEN IZQUIERDA
 619147.931 4485284.263    2380.271
   0.998918959856032    0.046482553873740   -0.000532752774727  Omega:    0.2494
  -0.046480098520562    0.998911421766970    0.003946125316109    Phi:    0.0456
   0.000715598814251   -0.003917096994773    0.999992072103310  Kappa:    2.9601
    IMAGEN DERECHA
 619605.020 4485282.752    2381.186
   0.998960152949217    0.045537711234265    0.002220287193761  Omega:    0.4968
  -0.045553571836695    0.998932139020661    0.007710624133305    Phi:   -0.1188
  -0.001866792060485   -0.007803748275719    0.999967807781956  Kappa:    2.9010
    PUNTO   -XT-       -YT-     -ZT-     -xi-     -yi-     -zi-    -Ex-   -Ey-   -Ez-
     7 619567.94 4485076.88 1609.77   78.635  -44.043 -147.398 -0.118  0.158 -0.036
     6 619505.09 4485329.17 1582.30   68.859    4.799 -152.888 -0.127  0.053  0.116
     3 619215.47 4485537.36 1573.80   15.283   47.278 -154.695 -0.097 -0.273  0.023
     4 619173.90 4485177.30 1577.10    4.096  -21.306 -153.783  0.019 -0.015 -0.055
     5 619683.26 4485643.34 1593.09  105.668   63.346 -151.001  0.322  0.077 -0.047
    EM.= 0.185
    Nombre del modelo: C:\instalacion\BRONCHALES\107-108.abs
Fecha: 14/5/2002 10:24

Digi3D además genera los archivos 107.ori y 108.ori, con los datos de las Orientaciones Interna y Externa, que se pueden utilizar para generar Ortofotografías digitales con la aplicación Digi21. Si quieres saber algo más acerca de los archivos ORI pulsa aquí.

De esta forma se importa la Orientación Absoluta desde un archivo. Si quieres ver la descripción del archivo de Orientación Absoluta pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Importar archivos .SUP de LH Systems con centros de proyección y giros

Para importar Orientaciones de DIAP con centros de proyección y giros desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar archivos .SUP (con centros de proyección y giros) y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara.
  • Z media del terreno: se trata de la cota media del terreno.
  • Girar 200 grados el giro de Kappa.

Los archivos SUP deben estar en el directorio donde se encuentren las imágenes, y con su mismo nombre. En caso contrario, el sistema no puede realizar la importación y muestra el siguiente mensaje:

Seleccionados todos los archivos en la ventana Importar archivos .SUP (con centros de proyección y giros), se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo de este tipo de importación lea el siguiente tema de la ayuda.

Fecha de última modificación: miércoles, 11 de Septiembre de 2002


Ejemplo de importación de archivos .SUP de LH Systems con centros de proyección y giros

Para importar archivos .SUP de LH Systems con centros de proyección y giros desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar archivos .SUP (con centros de proyección y giros) y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Imagen izquierda: en este caso 06816.tif.
  • Imagen derecha: en el ejemplo 06817.tif.
  • Archivo de cámara: en el ejemplo se trata del archivo rc-10.cam.
  • Z media del terreno: se trata de la cota media del terreno.
  • Girar 200 grados el giro de Kappa: en este caso no es necesario.

Los archivos SUP deben estar en el directorio donde se encuentren las imágenes, y con su mismo nombre. En caso de que los arhivos .SUP no estén almacenados en dicho directorio se visualiza el siguiente mensaje:

Por lo tanto, en el directorio C:\Correo se encuentran los archivos 06816.SUP y 06817.SUP. Un ejemplo de este tipo de archivo se muestra a continuación:

    support_file d
IMAGE_ID "98_3_347"
IMAGE_FILE_NAME 1 "O:\orthoadjust\block7\roll3\98_3_347.tif"
LINES   18624
SAMPLES 18624
IMAGE_FILE_NAME 2 "O:\orthoadjust\block7\roll3\98_3_347.tif_2"
LINES   9312
SAMPLES 9312
IMAGE_FILE_NAME 4 "O:\orthoadjust\block7\roll3\98_3_347.tif_4"
LINES   4656
SAMPLES 4656
IMAGE_FILE_NAME 8 "O:\orthoadjust\block7\roll3\98_3_347.tif_8"
LINES   2328
SAMPLES 2328
IMAGE_FILE_NAME 16 "O:\orthoadjust\block7\roll3\98_3_347.tif_16"
LINES   1164
SAMPLES 1164
IMAGE_FILE_NAME 32 "O:\orthoadjust\block7\roll3\98_3_347.tif_32"
LINES   582
SAMPLES 582
IMAGE_FILE_NAME 64 "O:\orthoadjust\block7\roll3\98_3_347.tif_64"
LINES   290
SAMPLES 290
IMAGE_FILE_NAME 128 "O:\orthoadjust\block7\roll3\98_3_347.tif_128"
LINES   144
SAMPLES 144
IMAGE_FILE_NAME 256 "O:\orthoadjust\block7\roll3\98_3_347.tif_256"
LINES   72
SAMPLES 72
IMAGE_FILE_NAME 512 "O:\orthoadjust\block7\roll3\98_3_347.tif_512"
LINES   36
SAMPLES 36
IMAGE_FILE_NAME 1024 "O:\orthoadjust\block7\roll3\98_3_347.tif_1024"
LINES   18
SAMPLES 18
RECTIFICATION_TERMS
    0.00000000000000e+000 0.00000000000000e+000 1.00000000000000e+000
    0.00000000000000e+000 1.00000000000000e+000 0.00000000000000e+000
GRND_BIAS 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
BIAS 0.000000 GAIN 1.000000
GROUND_ZERO 5.99582574770852e+005 6.04996693532010e+005 1.19745694153358e+002
LOAD_PT 5.99582574770852e+005 6.04996693532010e+005 1.19745694153358e+002
COORD_SYSTEM 3
UNITS 1
USE_FAST_MATH 0
MAX_AND_MIN_ELEVATION 0.0  1000.0
IMAGE_MOTION 0
INITIALIZED 2
STATUS 2
PHOTO_DATE ""
QUALITY 53
SENSOR_TYPE CLOSE_RANGE
FOCAL -1.52760600000000e+002
IOCOEF_LINE -2.49460258483887e+001 -7.91354551911354e-002 7.99801254272461e+001 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
IOCOEF_SAMPLE -2.47324047088623e+001 -7.99873275756836e+001 -8.19081217050552e-002 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
OPK_LSR 1.67754512928033e-003 -1.38165307139239e-003 -3.12792893779644e+000
LSR_CAMERA 6.04996693532010e+005 5.99582574770852e+005 6.50625555208618e+003
LENSCO 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
XPOFF 2.00000000000000e-003
YPOFF 8.00000000000000e-003
USE_LENS_DISTORTION 0
A1 -7.05153000000000e-011
A2 -6.22748000000000e-014
A3 0.00000000000000e+000
B1 0.00000000000000e+000
B2 0.00000000000000e+000
C1 0.00000000000000e+000
C2 0.00000000000000e+000
C3 0.00000000000000e+000
D1 0.00000000000000e+000
D2 0.00000000000000e+000
D3 0.00000000000000e+000
D4 0.00000000000000e+000
D5 0.00000000000000e+000
D6 0.00000000000000e+000
D7 0.00000000000000e+000
D8 0.00000000000000e+000
D9 0.00000000000000e+000
D10 0.00000000000000e+000
R_ZERO 0.00000000000000e+000
ROTATION_SYSTEM 0
USR_TO_LSR
    1.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
    0.00000000000000e+000 1.00000000000000e+000 0.00000000000000e+000
    0.00000000000000e+000 0.00000000000000e+000 1.00000000000000e+000
X0Y0Z0_USR 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
X0Y0Z0_GEO 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
AZIMUTH_LSR 0.00000000000000e+000
LOCAL_ORIGIN       0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000
BASIS              1.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 1.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 0.00000000000000e+000 1.00000000000000e+000
ORIGIN_OFFSET      0.00000000000000e+000 0.00000000000000e+000

Seleccionados todos los archivos en la ventana Importar archivos .SUP (con centros de proyección y giros), se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana. Así ya estarían importados los archivos .SUP.

Fecha de última modificación: miércoles, 11 de Septiembre de 2002


Importar de PatB Fotocoordenadas y Coordenadas Terreno

Para importar Fotocoordenadas y Coordenadas Terreno de PatB, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar de PatB fotocoordenadas y coordenadas terreno y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo de fotocoordenadas ajustadas: se trata del archivo donde están las Fotocoordenadas ajustadas en PatB.
  • Archivo de coordenadas terreno ajustadas: se trata del archivo donde están las Coordenadas Terreno ajustadas en PatB.

Seleccionados todos los archivos en la ventana Importar de PatB fotocoordenadas y coordenadas terreno, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de importación de PatB de Fotocoordenadas y Coordenadas Terreno pulsa aquí.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Ejemplo de importación de PatB Fotocoordenadas y Coordenadas Terreno

Para importar Fotocoordenadas y Coordenadas Terreno de PatB, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar de PatB fotocoordenadas y coordenadas terreno y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo. En este caso se trata de la imagen 108.tif.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. En este ejemplo se trata de la imagen 109.tif.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí. En este caso es RMK15.cam.
  • Archivo de fotocoordenadas ajustadas: se trata del archivo donde están las Fotocoordenadas ajustadas en PatB. En este caso se trata del archivo P1.cor.
  • Archivo de coordenadas terreno ajustadas: se trata del archivo donde están las Coordenadas Terreno ajustadas en PatB. En este caso se trata del archivo P1.adj.

Seleccionados todos los archivos en la ventana Importar de PatB fotocoordenadas y coordenadas terreno, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: martes, 14 de Mayo de 2002


Importar Orientaciones de PatB

Para importar Orientaciones de PatB desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar de PatB orientaciones, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema Formato del archivo de cámara.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones a importar. Es un archivo ASCII con extensión ORI. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos de orientación de PatB (*.ori), que nos ayuda a identificar el archivo.

  • Z media del terreno: se trata de la cota media del terreno.
  • Girar Kappa 180º: si se marca esta casilla se gira el modelo 180º en Kappa.

Seleccionados todos los archivos en la ventana Importar orientaciones de PatB, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de importación de Orientaciones de PatB lee el siguiente tema de la ayuda.

Fecha de última modificación: jueves, 12 de Septiembre de 2002


Ejemplo de importación de Orientaciones de PatB

Para importar Orientaciones de PatB desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar de PatB orientaciones, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo. En este ejemplo se trata de C:\BRONCHALES\108.tif
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. En este ejemplo se trata de C:\BRONCHALES\109.tif
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara. En este ejemplo es RMK15.cam
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones a importar. En este caso se trata del archivo Bronchales.ori, cuyo contenido es el siguiente:
                    107      0.00000000    619148.44630   4485283.40650      2380.31970
 -0.998922166800  0.046394175300  0.001444015500 -0.046401030800 -0.998909643600
 -0.005144741300  0.001203754900 -0.005206199900  0.999985723100
              108      0.00000000    619607.63810   4485283.12660      2380.93760
 -0.998946991900  0.045859808700 -0.001336141300 -0.045848145000 -0.998918434900
 -0.007740030500 -0.001689652500 -0.007670620600  0.999969152900
              109      0.00000000    620067.60540   4485281.08770      2379.83100
 -0.998907720400  0.046719245300 -0.000823578100 -0.046720654400 -0.998906400900
  0.001783984700 -0.000739331000  0.001820514200  0.999998069600
  • Z media del terreno: en este ejemplo la cota media del terreno es 1500 metros.
  • Girar Kappa 180º: en este caso no es necesario girar.

Seleccionados todos los archivos en la ventana Importar orientaciones de PatB, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana, y ya están importadas las orientaciones de PatB.

Fecha de última modificación: jueves, 12 de Septiembre de 2002


Importar Orientaciones en grupo de PatB

Para importar Orientaciones en grupo de PatB, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar de PatB orientaciones (en grupo), y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Primera imagen: nombre y ubicación del archivo de imagen que contiene al primer fotograma.
  • última imagen: nombre y ubicación del archivo de imagen que contiene al último fotograma. Los archivos de imágenes son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Incremento: se trata del incremento entre los archivos de imagen, desde la primera imagen hasta la última. Por ejemplo, si se tiene como primera imagen la número 107, y como última la número 109, y se define como incremento 1, las imágenes que se consideran son: 107, 108, y 109.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones a importar. Es un archivo ASCII con extensión ORI. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos de orientación de PatB (*.ori), que ayuda a identificar el archivo.

  • Z media del terreno: escribimos la cota media del terreno.

  • Girar Kappa 200º: si se activa esta casilla se gira Kappa 200º.

Seleccionados todos los archivos en la ventana Importar orientaciones de PatB en grupo, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo de este tipo de importación lea el siguiente tema de la ayuda.

Fecha de última modificación: jueves, 26 de Septiembre de 2002


Ejemplo de importación de Orientaciones en grupo de PatB

Para importar Orientaciones en grupo de PatB, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar de PatB orientaciones (en grupo), y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Primera imagen: nombre y ubicación del archivo de imagen que contiene al primer fotograma. En este ejemplo se trata de la imagen 107.tif.
  • Última imagen: nombre y ubicación del archivo de imagen que contiene al último fotograma. En este ejemplo se trata del fotograma 109.tif.
  • Incremento: se trata del incremento entre los archivos de imagen, desde la primera imagen hasta la última. En este ejemplo, como tenemos como primera imagen la número 107, y como última la número 109, y definimos como incremento 1, las imágenes que se consideran son: 107, 108, y 109.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara. En este caso se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones a importar. En este caso se Bloque.ori.
  • Z media del terreno: escribimos la cota media del terreno, que en este ejemplo es 1500.
  • Girar Kapa 180º: en este caso no se gira.

Seleccionados todos los archivos en la ventana Importar orientaciones de PatB en grupo, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: jueves, 26 de Septiembre de 2002


Importar Orientaciones Internas de Digi21

Para importar Orientaciones Internas realizadas con el programa Digi21, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar internas de Digi21 , y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen: nombre y ubicación del archivo de imagen que contiene al fotograma del que queremos importar la Orientación Interna.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Interna a importar. Es un archivo ASCII con extensión ORI. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos ORI de Digi21, que nos ayuda a identificar el archivo.

Seleccionados todos los archivos en la ventana Importar internas de Digi21, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de importación de Orientaciones Internas de Digi21 pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Ejemplo de importación de Orientaciones Internas de Digi21

La aplicación Digi21 permite realizar las Orientaciones Interna y Externa de una imagen, y una vez efectuadas éstas, se crea un archivo con el mismo nombre que la imagen y con la extensión .ORI. En este ejemplo suponemos que hemos realizado dichas Orientaciones para la imagen 107.tif, para la que Digi21 ha generado el archivo 107.ori,

    [Orientacion]
Modo=Externa
    [Interna]
m0=47.6377287184 -0.4465960389
m1=-0.4453196552 -47.6333620454
Desp= 5592.7184  5556.4272
Focal=  154.0520
PuntoPrincipal=    0.0150    -0.0040
    [Externa]
m0= 0.9989221668  0.0464010308 -0.0012037549
m1=-0.0463941753  0.9989096436  0.0052061999
m2= 0.0014440155 -0.0051447413  0.9999857231
CentroProyeccion=  619148.4463  4485283.4065     2380.3197
ZMedia=    1570.5620

que contiene los datos de las Orientaciones Interna y Externa.

El restituidor digital Digi3D permite importar las Orientaciones Internas realizadas en Digi21 mediante la lectura de los archivos .ORI. Para importar Orientaciones Internas realizadas con el programa Digi21, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar internas de Digi21 , y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen: en este ejemplo se trata de la imagen 107.tif.
  • Archivo de cámara: en este ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Interna a importar. En este ejemplo se trata del archivo 107.ori.

Seleccionados todos los archivos en la ventana Importar internas de Digi21, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Realizada la importación, se crea en el directorio donde se encuentra la imagen el archivo 107.inn,

    RESULTADOS DE LA ORIENTACIÓN INTERNA
   0.000209899252153   -0.000001967952094    -116.297
  -0.000001962327633   -0.000209918494158     117.737
    4763.772871839999400  -44.659603890000000  559271.840
 -44.531965520000000 -4763.336204539999900  555642.720
    Orientación importada de un archivo
    Nombre de la fotografía: C:\instalacion\BRONCHALES\107.inn
Fecha: 16/5/2002 17:54

Este archivo contiene los datos de la Orientación Interna. Si quieres saber cómo es el formato de este tipo de archivos pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Importar Orientaciones de Albany

Para importar las orientaciones de Albany a Digi3D mediante un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones de Albany y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara.
  • Archivo a importar: se trata del archivo de Albany del que se realiza la importación de orientaciones.
  • Z media del terreno: se trata de la cota media del terreno.
  • Girar 200 grados el giro de Kappa.

Seleccionados todos los archivos en la ventana Importar orientaciones de Albany, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo de este tipo de importación lea el siguiente tema de la ayuda.

Fecha de última modificación: lunes, 16 de Septiembre de 2002


Ejemplo de importación de orientaciones de Albany

Para importar las orientaciones de Albany a Digi3D mediante un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones de Albany y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Imagen izquierda: en este ejemplo se trata de C:\BRONCHALES\107.tif.
  • Imagen derecha: en este ejemplo se trata de C:\BRONCHALES\108.tif.
  • Archivo de cámara: es RMK15.cam.
  • Archivo a importar: en este caso 107-108.opm.
  • Z media del terreno: en esta zona son 1500 metros.
  • Girar 200 grados el giro de Kappa.

Seleccionados todos los archivos en la ventana Importar orientaciones de Albany, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: lunes, 16 de Septiembre de 2002


Importar Orientaciones de DIAP

Para importar Orientaciones de DIAP desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar orientaciones de DIAP y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones de Diap a importar. Es un archivo ASCII con extensión mod. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos de orientaciones de Diap (*.mod) que nos ayuda a identificar el archivo.

Seleccionados todos los archivos en la ventana Importar orientaciones de Diap, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de este tipo de importación pulsa aquí.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Ejemplo de importación de Orientaciones de DIAP

Para importar Orientaciones de DIAP desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar orientaciones de DIAP y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo. En este ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. En este caso se trata del fotograma 108.tif.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí. En este ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones de Diap a importar. En este caso se trata del archivo Proyecto.mod.

Seleccionados todos los archivos en la ventana Importar orientaciones de Diap, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Importar Orientaciones de DIAP con centros de proyección y giros

Para importar Orientaciones de DIAP con centros de proyección y giros desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar orientaciones de DIAP (con centros de proyección y giros) y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones de Diap a importar. Es un archivo ASCII con extensión mod. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos de orientaciones de Diap (*.mod) que nos ayuda a identificar el archivo.

  • Z media del terreno: se trata de la cota media del terreno.

Seleccionados todos los archivos en la ventana Importar orientaciones de Diap (con centros de proyección y giros), pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de este tipo de importación pulsa aquí.

Fecha de última modificación: lunes, 26 de Agosto de 2002


Ejemplo de importación de Orientaciones de DIAP con centros de proyección y giros

Para importar Orientaciones de DIAP con centros de proyección y giros desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar orientaciones de DIAP (con centros de proyección y giros) y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo. En este ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. En este caso se trata del fotograma 108.tif.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí. En este ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones de Diap a importar. En este caso se trata del archivo Proyecto.mod.
  • Z Media del terreno: se trata de la cota media del terreno, en este caso 1500 metros.

Seleccionados todos los archivos en la ventana Importar orientaciones de Diap (centros de proyección y giros), pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: lunes, 26 de Agosto de 2002


Importar Orientaciones Externas

Para importar una Orientación Externa desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar orientaciones externas, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Externa a importar. Es un archivo ASCII con extensión EXT (si quieres aprender cómo es su formato pulsa aquí). Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos de externas *.ext, que nos ayuda a identificar el archivo.

Seleccionados todos los archivos en la ventana Importar orientaciones externas, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo importación de Orientaciones Externas pulsa aquí.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Ejemplo de importación de Orientaciones Externas

Para realizar la importación de Orientación Externa debemos haber realizado previamente las Orientaciones Internas de los fotogramas. Además, el archivo con las Orientaciones Externas debe estar en un determinado formato.

Para importar una Orientación Externa desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar orientaciones externas, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo. En este ejemplo es C:\instalacion\BRONCHALES\108.tif.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. En este ejemplo es C:\instalacion\BRONCHALES\109.tif.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí. En este ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Externa a importar. Es un archivo ASCII con extensión EXT. En este ejemplo se trata del archivo Bronchales.ext, y tiene el siguiente contenido:

      1500

      619147.278 4485284.058 2379.772

      0.998918545482773 0.046494213491351 0.000166139706411

      -0.046494499237927 0.998909461837703 0.004260116398083

      0.000032112236590 -0.004263233858414 0.999990911861639

      619605.583 4485282.565 2381.200

      0.998954112658913 0.045566328140500 0.003793486738503

      -0.045595656067190 0.998927611262379 0.008041368381045

      -0.003423003015699 -0.008205924532275 0.999960472145237

Seleccionados todos los archivos en la ventana Importar orientaciones externas, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Importar Orientaciones Externas con centros de proyección y giros

Para importar una Orientación Externa con centros de proyección y giros desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones externas con centros de proyección y giros, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Externa a importar. Es un archivo ASCII con extensión .eo. Si se pulsa sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos se puede observar Archivos de orientación externa *.eo, que ayuda a identificar el archivo. Si quiere conocer este tipo de archivos lea el tema de la ayuda Formato del archivo de importación de Orientaciones Externas con centros de proyección y giros.

  • Z media del terreno: se trata de la cota media del terreno.
  • Unidades: son las correspondientes a los giros. Si se pulsa sobre la lista desplegable,

    • se puede elegir entre Sexagesimal (fracción decimal de grado), Centesimal, y Radianes, que lógicamente son las unidades de los giros.

  • Girar 200 grados el giro de Kappa: si se marca esta casilla se efectúa dicho giro.

Seleccionados todos los archivos en la ventana Importar externas con centros de proyección y giros, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quiere ver un ejemplo de cómo exportar Orientaciones Externas con centros de proyección y giros lea el siguiente tema de la ayuda.

Fecha de última modificación: martes, 22 de Octubre de 2002


Ejemplo de importación de Orientaciones Externas con centros de proyección y giros

Previamente a la importación de Orientación Externa con centros de proyección y giros se deben haber realizado las Orientaciones Internas de las imágenes.

Para importar una Orientación Externa con centros de proyección y giros desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones externas con centros de proyección y giros, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo, en este caso C:\instalación\bronchales\107.tif
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho, en este caso C:\instalación\bronchales\108.tif
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara. En este ejemplo es C:\instalación\bronchales\RMK15.cam
  • Archivo a importar: se trata del archivo con los datos de la Orientación Externa con centros de proyección y giros a importar. En este ejemplo se trata del archivo Bronchales.eo, y tiene el siguiente contenido:
        107    619148.44630   4485283.40650      2380.31970  0.294773570878  0.082736022455  2.659147728045
    108    619607.63810   4485283.12660      2380.93760  0.443475904859 -0.076555280102  2.628497726498
    109    620067.60540   4485281.08770      2379.83100 -0.102214882909 -0.047187554564  2.677791219669

    Si quiere conocer este tipo de archivos lea el tema de la ayuda Formato del archivo de importación de Orientaciones Externas con centros de proyeccion y giros.

  • Z media del terreno: se trata de la cota media del terreno, en este ejemplo 1500.
  • Unidades: son las correspondientes a los giros. Si se pulsa sobre la lista desplegable,

    • se puede elegir entre Sexagesimal (fracción decimal de grado), Centesimal, y Radianes, que lógicamente son las unidades de los giros.

  • Girar 200 grados el giro de Kappa: en este caso no es necesario efectuar ese giro, por lo que no se marca.

Seleccionados todos los archivos en la ventana Importar externas con centros de proyección y giros, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: martes, 22 de Octubre de 2002


Importar Orientaciones Externas con centros de proyección y giros en grupo

Para importar varias Orientaciones Externas con centros de proyección y giros desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones externas con centros de proyección y giros en grupo, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Primera imagen: nombre y ubicación del archivo de imagen que contiene al primer fotograma.
  • Última imagen: nombre y ubicación del archivo de imagen que contiene al último fotograma. Los archivos de imágenes pueden ser de cualquiera de los tipos de imágenes soportados.
  • Incremento: se trata del incremento entre imágenes consecutivas para las que se desea importar las Orientaciones Externas con centros de proyección y giros.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de Cámara.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones Externas a importar. Es un archivo ASCII con extensión EO. Si se pulsa sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos se puede observar Archivos de orientación externa *.eo, que ayuda a identificar el archivo. Si quiere conocer este tipo de archivos lea el tema de la ayuda Formato del archivo de importación de Orientaciones Externas con centros de proyección y giros.

  • Z media del terreno: se trata de la cota media del terreno.
  • Unidades: son las correspondientes a los giros. Si se pulsa sobre la lista desplegable,

    • se puede elegir entre Sexagesimal (fracción decimal de grado), Centesimal, y Radianes, que lógicamente son las unidades de los giros.

  • Girar 200 grados el giro de Kappa: si se marca esta casilla se efectúa dicho giro.

Seleccionados todos los archivos en la ventana Importar externas con centros de proyección y giros en grupo, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quiere ver un ejemplo de cómo exportar Orientaciones Externas con centros de proyección y giros en grupo lea el siguiente tema de la ayuda.

Fecha de última modificación: miércoles, 23 de Octubre de 2002


Ejemplo de importación de Orientaciones Externas con centros de proyección y giros en grupo

Previamente a la importación de Orientaciones Externas con centros de proyección y giros en grupo se deben haber realizado las Orientaciones Internas de las imágenes.

Para importar varias Orientaciones Externas con centros de proyección y giros en grupo desde un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones externas con centros de proyección y giros en grupo, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Primera imagen: nombre y ubicación del archivo de imagen que contiene al primer fotograma, en este caso C:\instalación\bronchales\107.tif
  • Última imagen: nombre y ubicación del archivo de imagen que contiene al último fotograma, en este caso C:\instalación\bronchales\109.tif
  • Incremento: en este caso el incremento entre imágenes consecutivas es 1, porque las imágenes para las que se quiere importar las Orientaciones Externas con centros de proyección y giros son 107, 108 y 109.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara. En este ejemplo es C:\instalación\bronchales\RMK15.cam
  • Archivo a importar: se trata del archivo con los datos de la Orientación Externa con centros de proyección y giros a importar. En este ejemplo se trata del archivo Bronchales.eo, y tiene el siguiente contenido:
        107    619148.44630   4485283.40650      2380.31970  0.294773570878  0.082736022455  2.659147728045
    108    619607.63810   4485283.12660      2380.93760  0.443475904859 -0.076555280102  2.628497726498
    109    620067.60540   4485281.08770      2379.83100 -0.102214882909 -0.047187554564  2.677791219669

    Si quiere conocer este tipo de archivos lea el tema de la ayuda Formato del archivo de importación de Orientaciones Externas con centros de proyeccion y giros.

  • Z media del terreno: se trata de la cota media del terreno, en este ejemplo 1500.
  • Unidades: son las correspondientes a los giros. Si se pulsa sobre la lista desplegable,

    • se puede elegir entre Sexagesimal (fracción decimal de grado), Centesimal, y Radianes, que lógicamente son las unidades de los giros.

  • Girar 200 grados el giro de Kappa: en este caso no es necesario efectuar ese giro, por lo que no se marca.

Seleccionados todos los archivos en la ventana Importar externas con centros de proyección y giros en grupo, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: miércoles, 23 de Octubre de 2002


Importar Orientaciones Externas de SD2000

Para importar las Orientaciones Externas de SD2000 a Digi3D mediante un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones externas de SD2000 y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse leyendo el tema de la ayuda Formato del archivo de cámara.
  • Archivo a importar: se trata del archivo de SD2000 del que se realiza la importación de orientaciones externas.
  • Z media del terreno: se trata de la cota media del terreno.

Seleccionados todos los archivos en la ventana Importar orientaciones externas de SD2000, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana. Como resultado de esta importación se crean 4 archivos:

  • Archivo de Orientación Relativa: se le asigna como nombre las dos imágenes separadas por un guión, y como extensión rel. Si quiere ver una descripción de este tipo de archivos lea el tema de la ayuda Formato del archivo de Orientación Relativa.
  • Archivo de Orientación Absoluta: se le asigna como nombre las dos imágenes separadas por un guión, y como extensión abs. Si quiere ver una descripción de este tipo de archivos lea el tema de la ayuda Formato del archivo de Orientación Absoluta.
  • Archivos de Orientación Externa: se crean dos archivos, correspondientes a cada una de las imágenes, y se les asigna como extensión ori. Si quiere ver una descripción de este tipo de archivos lea el tema de la ayuda Formato del archivo de Orientación Externa.

Si desea ver un ejemplo de este tipo de importación lea el siguiente tema de la ayuda.

Fecha de última modificación: lunes, 14 de Octubre de 2002


Importar Orientaciones Relativa y Absoluta desde un archivo en un solo paso con Fotocoordenadas

Para importar las Orientaciones Relativa y Absoluta desde un archivo en un solo paso con Fotocoordenadas, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar relativa y absoluta desde un archivo en un solo paso con fotocoordenadas, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de las Orientaciones a importar. Es un archivo ASCII con extensión XYZxyxy cuya descripción puede aprenderse pulsando aquí. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos ASCII (Xt Yt Zt Xi Yi Xd Yd)(*.XYZxyxy), que nos ayuda a identificar el formato del archivo de importación de Orientación Relativa y Absoluta en un solo paso.

Seleccionados todos los archivos en la ventana Importar relativa y absoluta en un solo paso, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de importación de las Orientaciones Relativa y Absoluta en solo paso con Fotocoordenadas pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Ejemplo de importación de las Orientaciones Relativa y Absoluta desde un archivo en un solo paso con Fotocoordenadas

Para importar las Orientaciones Relativa y Absoluta es necesario tener un archivo con los datos en el formato adecuado. Digi3D no importa los parámetros directamente, sino los datos que le son necesarios, y con ellos calcula las Orientaciones Relativa y Absoluta. En este caso concreto los datos necesarios son Fotocoordenadas y Coordenadas Terreno de puntos.

En este ejemplo, supongamos que queremos formar y apoyar el modelo 107-108, formado por las imágenes 107.tif y 108.tif. Además, supongamos que ya hemos realizado (o importado) las Orientaciones Internas de ambas fotografías, con lo que tendremos los archivos 107.inn y 108.inn en el directorio de trabajo. Tenemos también Fotocoordenadas y Coordenadas Terreno de los puntos.

Necesitamos crear un archivo en formato de importación de las Orientaciones Relativa y Absoluta en un solo paso , que simplemente se trata de un archivo ASCII de texto, en el que cada fila es un punto con sus correspondientes Coordenadas Terreno (X, Y, Z) y Fotocoordenadas (x, y, en cada imagen). En nuestro ejemplo es el siguiente archivo:

     1    619145.587 4485235.863 1570.562       -0.778      -9.813       -88.496      -6.134
 2    619622.554 4485312.546 1585.774       92.335       0.577         2.944       4.439
 2    619622.554 4485312.546 1585.774       92.335       0.577         2.944       4.439
 3    619699.089 4485909.921 1532.877      105.161     108.012        21.398     111.088
 4    619222.715 4485838.743 1557.910       18.846     102.121       -67.118     105.472
 5    619237.525 4484876.591 1657.491       15.173     -88.564       -83.344     -84.513
 6    619644.824 4484797.280 1660.227      101.895    -110.108         3.070    -105.840
 7    619403.250 4485279.006 1594.907       50.095      -3.992       -40.273      -0.105
 8    619372.450 4485584.037 1552.176       44.340      53.057       -41.232      56.560
 9    619499.734 4485141.135 1614.580       69.567     -32.723       -23.202     -28.702

donde se puede ver que son 9 puntos (son necesarios un mínimo de 5 puntos homólogos para poder efectuar el cálculo de la Orientación Relativa y de 3 para la Orientación Absoluta). Este archivo tiene por nombre 107-108.XYZxyxy.

Para efectuar esta importación de datos desde el archivo 107-108.XYZxyxy, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar relativa y absoluta desde un archivo en un solo paso con fotocoordenadas, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: en nuestro ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: en nuestro ejemplo se trata de la imagen 108.tif.
  • Archivo de cámara: en nuestro ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de la Orientaciones Relativa y Absoluta a importar, que en nuestro ejemplo es 107-108.XYZxyxy.

Seleccionados todos los archivos en la ventana Importar Relativa, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana. Una vez importado, Digi3D calcula la Orientación Relativa y almacena los resultados en el archivo 107-108.rel:

    RESULTADOS DE LA ORIENTACIÓN RELATIVA
    154.052
      0.015      -0.004

          0.000       0.000       0.000
   1.000000000000000    0.000000000000000    0.000000000000000
   0.000000000000000    1.000000000000000    0.000000000000000
   0.000000000000000    0.000000000000000    1.000000000000000
         87.718      -4.388       0.241
   0.999993716987054   -0.001091754118972    0.003372544938136
   0.001079077963294    0.999992355853306    0.003758167865317
  -0.003376622153154   -0.003754505013777    0.999987250976199
         -0.783      -9.878    -155.042
    N       -xFizq-     -yFizq-       -xFder-     -yFder-        -xMod-      -yMod-      -zMod-
 1        -0.778      -9.813       -88.496      -6.134        -0.783      -9.878    -155.042
 2        92.335       0.577         2.944       4.439        91.148       0.570    -152.072
 3        92.335       0.577         2.944       4.439        91.148       0.570    -152.072
 4       105.161     108.012        21.398     111.088       111.112     114.125    -162.770
 5        18.846     102.121       -67.118     105.472        19.334     104.766    -158.038
 6        15.173     -88.564       -83.344     -84.513        13.593     -79.343    -138.013
 7       101.895    -110.108         3.070    -105.840        90.814     -98.134    -137.298
 8        50.095      -3.992       -40.273      -0.105        48.892      -3.889    -150.351
 9        44.340      53.057       -41.232      56.560        45.719      54.700    -158.845
10        69.567     -32.723       -23.202     -28.702        66.121     -31.104    -146.421

    N       -vXizq-     -vVizq-       -vXder-     -vYder--    -py- (micras)
 1         0.1         1.5          -0.1        -1.5      -0.0
 2        -0.0        -0.5           0.0         0.5       0.0
 3        -0.0        -0.5           0.0         0.5       0.0
 4        -0.0        -0.3           0.0         0.3       0.0
 5        -0.1        -2.6           0.1         2.6       0.0
 6        -0.0        -0.4           0.0         0.4       0.0
 7         0.0         0.5          -0.0        -0.5      -0.0
 8        -0.3        -6.9           0.3         6.9       0.0
 9         0.4         7.3          -0.4        -7.3      -0.0
10         0.1         2.1          -0.1        -2.1      -0.0
    Puntos medidos: 10
Puntos rechazados: 0
Desviación típica: 37.0 micras
Número de iteraciones: 4
    Giros de la cámara izquierda:
Omega:    0.0000 gon  Phi:    0.0000 gon Kappa:    0.0000 gon
    Giros de la cámara derecha:
Omega:    0.2390 gon Phi:   -0.2150 gon Kappa:   -0.0687 gon
    Nombre del modelo: 107-108
Fecha: 16/5/2002 16:31

Si quieres ver la descripción del archivo de Orientación Relativa pulsa aquí. Después calcula la Orientación Absoluta y guarda los resultados en el archivo 107-108.abs:

    RESULTADOS DE LA ORIENTACIÓN ABSOLUTA
 619148.446 4485283.406    2380.320
5.221202823598688
   0.998922166795246   -0.046394175329017    0.001444015453935  Omega:   -0.3314
   0.046401030798382    0.998909643550353   -0.005144741291234    Phi:   -0.0766
  -0.001203754932883    0.005206199923792    0.999985723126293  Kappa:   -2.9550
    RESULTADOS DE LA ORIENTACIÓN EXTERNA
    IMAGEN IZQUIERDA
 619148.446 4485283.406    2380.320
   0.998922166795246    0.046401030798382   -0.001203754932883  Omega:    0.3275
  -0.046394175329017    0.998909643550353    0.005206199923792    Phi:    0.0919
   0.001444015453935   -0.005144741291234    0.999985723126293  Kappa:    2.9546
    IMAGEN DERECHA
 619607.011 4485281.766    2380.908
   0.998971411593361    0.045292824671077    0.002163065528851  Omega:    0.5763
  -0.045310478935425    0.998932743266917    0.008962975391844    Phi:   -0.1117
  -0.001754798509647   -0.009051765714348    0.999957492206365  Kappa:    2.8855
    PUNTO   -XT-       -YT-     -ZT-     -xi-     -yi-     -zi-    -Ex-   -Ey-   -Ez-
     1 619145.59 4485235.86 1570.56   -0.783   -9.878 -155.042  0.001 -0.002 -0.002
     2 619622.55 4485312.55 1585.77   91.148    0.570 -152.072  0.001 -0.001  0.000
     2 619622.55 4485312.55 1585.77   91.148    0.570 -152.072  0.001 -0.001  0.000
     3 619699.09 4485909.92 1532.88  111.112  114.125 -162.770  0.001  0.004 -0.004
     4 619222.71 4485838.74 1557.91   19.334  104.766 -158.038  0.001 -0.000 -0.000
     5 619237.53 4484876.59 1657.49   13.593  -79.343 -138.013  0.003 -0.002 -0.002
     6 619644.82 4484797.28 1660.23   90.814  -98.134 -137.298 -0.004  0.003 -0.001
     7 619403.25 4485279.01 1594.91   48.892   -3.889 -150.351 -0.003  0.001  0.000
     8 619372.45 4485584.04 1552.18   45.719   54.700 -158.845  0.000 -0.001  0.004
     9 619499.73 4485141.13 1614.58   66.121  -31.104 -146.421 -0.001 -0.000  0.004
    EM.= 0.002
    Nombre del modelo: C:\instalacion\BRONCHALES\107-108.abs
Fecha: 16/5/2002 16:31

Si quieres ver la descripción del archivo de Orientación Absoluta pulsa aquí. Digi3D además genera los archivos 107.ori y 108.ori, con los datos de las Orientaciones Interna y Externa, que se pueden utilizar para generar Ortofotografías digitales con la aplicación Digi21. Si quieres saber algo más acerca de los archivos ORI pulsa aquí.

Seleccionados todos los archivos en la ventana Importar relativa y absoluta en un solo paso, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Fecha de última modificación: martes, 14 de Mayo de 2002


Importar Orientación Relativa desde un archivo

Para importar una Orientación Relativa desde un archivo, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar relativas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: nombre y ubicación del archivo de imagen que contiene al fotograma izquierdo.
  • Imagen derecha: nombre y ubicación del archivo de imagen que contiene al fotograma derecho. Los archivos de las imágenes izquierda y derecha son los archivos de las fotos y pueden ser de cualquiera de los tipos de imágenes soportados.
  • Archivo de cámara: es un archivo ASCII cuya descripción puede aprenderse pulsando aquí.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Relativa a importar. Es un archivo ASCII con extensión XYXY cuya descripción puede aprenderse pulsando aquí. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

    donde se puede seleccionar el archivo a importar. Por defecto en Tipo de archivos podemos ver Archivos ASCII (n Xi Yi Xd Yd)(*.xyxy), que nos ayuda a identificar el formato del archivo de importación de Orientación Relativa.

Seleccionados todos los archivos en la ventana Importar Relativa, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de importación de Orientación Relativa pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Ejemplo de importación de Orientación Relativa desde un archivo

Para importar la Orientación Relativa es necesario tener un archivo con los datos en el formato adecuado. Digi3D no importa los parámetros directamente, sino los datos que le son necesarios, y con ellos calcula la Orientación Relativa. En este caso concreto los datos necesarios son las Fotocoordenadas de puntos homólogos en las imágenes que van a formar el modelo estereoscópico, la distancia focal de la cámara y la base.

En este ejemplo, supongamos que queremos formar el modelo 107-108, formado por las imágenes 107.tif y 108.tif. Además, supongamos que ya hemos realizado (o importado) las Orientaciones Internas de ambas fotografías, con lo que tendremos los archivos 107.inn y 108.inn en el directorio de trabajo. Tenemos también las Fotocoordenadas de varios puntos homólogos.

Necesitamos crear un archivo en formato de importación de la Orientación Relativa, que simplemente se trata de un archivo ASCII de texto, en el que cada fila es un punto con sus correspondientes Fotocoordenadas (x, y, en cada imagen). En nuestro ejemplo es el siguiente archivo:

       8	154.052    68
  3.942      -7.076       -83.524      -3.403
 69.700       1.206       -19.356       5.016
 91.035      89.735         3.790      93.111
  3.905      88.437       -84.487      91.958
 15.490     -87.653       -82.828     -83.600
 90.314     -90.593        -7.023     -86.397
 42.640      -1.616       -46.303       2.167
 40.571     -49.040       -52.446     -45.083

donde se puede ver que son 8 puntos homólogos (son necesarios un mínimo de 5 puntos homólogos para poder efectuar el cálculo de la Orientación Relativa). Este archivo tiene por nombre 107-108.xyxy.

Para importar los datos para calcular la Orientación Relativa desde el archivo 107-108.xyxy, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Importar relativas desde un archivo, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Imagen izquierda: en nuestro ejemplo se trata de la imagen 107.tif.
  • Imagen derecha: en nuestro ejemplo se trata de la imagen 108.tif.
  • Archivo de cámara: en nuestro ejemplo se trata del archivo RMK15.cam.
  • Archivo a importar: se trata del archivo con los datos de la Orientación Relativa a importar, que en nuestro ejemplo es 107-108.xyxy.

Seleccionados todos los archivos en la ventana Importar Relativa, pulsamos sobre el botón Importar situado en la parte inferior de dicha ventana. Una vez importado, Digi3D calcula la Orientación Relativa y almacena los resultados en el archivo 107-108.rel:

    RESULTADOS DE LA ORIENTACIÓN RELATIVA
    154.052
      0.015      -0.004
          0.000       0.000       0.000
   1.000000000000000    0.000000000000000    0.000000000000000
   0.000000000000000    1.000000000000000    0.000000000000000
   0.000000000000000    0.000000000000000    1.000000000000000
         68.000      -3.390       0.184
   0.999995155095086   -0.000964027931349    0.002959803456871
   0.000952798889858    0.999992352952193    0.003792915951125
  -0.002963437300031   -0.003790077477360    0.999988426609071
          3.081      -5.531    -120.409
    N       -xFizq-     -yFizq-       -xFder-     -yFder-        -xMod-      -yMod-      -zMod-
 1         3.942      -7.076       -83.524      -3.403         3.081      -5.531    -120.409
 2        69.700       1.206       -19.356       5.016        53.483       0.926    -118.208
 3        91.035      89.735         3.790      93.111        71.414      70.394    -120.849
 4         3.905      88.437       -84.487      91.958         3.016      68.313    -118.997
 5        15.490     -87.653       -82.828     -83.600        10.772     -60.955    -107.131
 6        90.314     -90.593        -7.023     -86.397        63.340     -63.535    -108.041
 7        42.640      -1.616       -46.303       2.167        32.756      -1.241    -118.344
 8        40.571     -49.040       -52.446     -45.083        29.800     -36.022    -113.154

    N       -vXizq-     -vVizq-       -vXder-     -vYder--    -py- (micras)
 1        -0.0        -0.1           0.0         0.1       0.0
 2        -0.0        -0.7           0.0         0.7       0.0
 3         0.0         0.2          -0.0        -0.2      -0.0
 4        -0.0        -0.0           0.0         0.0       0.0
 5        -0.0        -0.5           0.0         0.5       0.0
 6        -0.0        -0.1           0.0         0.1       0.0
 7        -0.0        -0.1           0.0         0.1       0.0
 8         0.1         1.3          -0.1        -1.3      -0.0
    Puntos medidos: 8
Puntos rechazados: 0
Desviación típica: 20.9 micras
Número de iteraciones: 4
    Giros de la cámara izquierda:
Omega:    0.0000 gon  Phi:    0.0000 gon Kappa:    0.0000 gon
    Giros de la cámara derecha:
Omega:    0.2413 gon Phi:   -0.1887 gon Kappa:   -0.0607 gon
    Nombre del modelo: 107-108
Fecha: 16/5/2002 16:14

De esta forma se importa la Orientación Relativa desde un archivo. Si quieres ver la descripción del archivo de Orientación Relativa pulsa aquí.

Fecha de última modificación: jueves, 16 de Mayo de 2002


Preparar datos para PatB y PatM

Para preparar datos para PatB y PatM, elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Preparar datos para PatB y PatM, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de puntos de entrada: seleccionamos el archivo donde tenemos los puntos.
  • Archivo de puntos de salida: es el archivo ASCII con los puntos en el formato correspondiente a PatB y a PatM.
  • Formato de datos para el bloque de XY: aquí podemos especificar el formato para los datos XY en formato printf() de stdio.h del lenguaje de programación "C".
  • Formato de datos para el bloque de Z: al igual que en el campo anterior, aquí especificamos el formato para los datos Z en formato printf() de stdio.h del lenguaje de programación "C".

Seleccionados los elementos deseados en la ventana Exportar fichero de puntos de entrada, pulsamos sobre el botón Exportar situado en la parte inferior de dicha ventana.

Si quieres ver un ejemplo de preparación de datos para PatB y PatM pulsa aquí.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Ejemplo de preparación de datos para PatB y PatM

Para exportar al formato de PatB y PatM necesitamos el archivo de puntos en el formato de Digi3D.

Elegimos Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde seleccionamos Preparar datos para PatB y PatM, y pulsamos sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana introducimos los siguientes datos:

  • Archivo de puntos de entrada: en este ejemplo se trata del archivo Bronchales.xyz, que tiene el siguiente contenido:

      1 618919.208 4485805.702 1558.194
      2 618883.344 4484881.606 1598.679
      3 619215.468 4485537.355 1573.802
      4 619173.900 4485177.298 1577.095
      5 619683.262 4485643.336 1593.088
      6 619505.093 4485329.173 1582.302
      7 619567.940 4485076.883 1609.768
      8 620097.282 4485672.614 1554.958
      9 620144.153 4485309.845 1550.214

  • Archivo de puntos de salida: por ejemplo, el archivo Bronchales.ctl. Es el archivo donde se guardan los puntos en el formato requerido por PatM y PatB.

Seleccionados los elementos deseados en la ventana Exportar fichero de puntos a formato PatM y PatB, pulsamos sobre el botón Exportar situado en la parte inferior de dicha ventana.

El contenido del archivo exportado es el siguiente:

      0
      1 618919.21 4485805.70 1558.19 1
      2 618883.34 4484881.61 1598.68 1
      3 619215.47 4485537.36 1573.80 1
      4 619173.90 4485177.30 1577.10 1
      5 619683.26 4485643.34 1593.09 1
      6 619505.09 4485329.17 1582.30 1
      7 619567.94 4485076.88 1609.77 1
      8 620097.28 4485672.61 1554.96 1
      9 620144.15 4485309.84 1550.21 1
      -99
      0
      1 618919.21 4485805.70 1558.19 1
      2 618883.34 4484881.61 1598.68 1
      3 619215.47 4485537.36 1573.80 1
      4 619173.90 4485177.30 1577.10 1
      5 619683.26 4485643.34 1593.09 1
      6 619505.09 4485329.17 1582.30 1
      7 619567.94 4485076.88 1609.77 1
      8 620097.28 4485672.61 1554.96 1
      9 620144.15 4485309.84 1550.21 1
      -99

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Exportar Instantáneas de fotos a partir de sus archivos de fotocoordenadas de Aerotriangulación

Digi3D

Exportar Instantáneas de fotos a partir de sus archivos de fotocoordenadas de Aerotriangualción

Este exportador sirve para sacar instantáneas en color de modelos que se han aerotriangulado en escala de grises. Para exportar estas instantáneas, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Exportar instantáneas de fotos a partir de sus archivos de fotocoordenadas de aerotriangulación, y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se introducen los siguientes datos:

  • Directorio con las orientaciones internas: ubicación en la que se encuentran los archivos INN. Si se pulsa sobre Examinar aparece la siguiente ventana donde se selecciona dicho directorio:

  • Directorio con los archivos de fotocoordenadas: se trata del archivo con las fotocoordenadas de los puntos aerotriangulados. Si pulsamos sobre su botón Examinar, aparece el siguiente cuadro de diálogo:

Seleccionados todos los archivos en la ventana Exportar instantáneas de fotos a partir de los archivos de fotocoordenadas de aerotriangulación, pulsamos sobre el botón Comenzar situado en la parte inferior de dicha ventana.

Si desea ver un ejemplo de exportación de Orientaciones a formato PatB y a formato centros de proyección y giros lea el siguiente tema de la ayuda.

Fecha de última modificación: 20 de Septiembre de 2004


Referencia de DigiNG

En este tema de la ayuda se encuentra la documentación sobre DigiNG:

  • Menú principal de DigiNG.
  • Precisión en DigiNG.
  • Bases de Datos en DigiNG.
  • Mosaicos en DigiNG.
  • Modos de Búsqueda del Tentativo.
  • Simbología en DigiNG.
  • Barras de Herramientas.
  • Importación de Orientaciones.
  • Listado de órdenes de DigiNG.
  • Formatos de archivo utilizados por DigiNG.

Fecha de última modificación: martes, 29 de Octubre de 2002


Menú principal de DigiNG

Vemos que tenemos las siguientes opciones dentro de DigiNG:

Fecha de última modificación: miércoles, 24 de Abril de 2002


Precisión en DigiNG

La precisión en DigiNG está directamente relacionada con el espacio que se utiliza dentro del formato de archivo bin para almacenar un punto. Un punto dentro de un archivo bin se almacena mediante 12 bytes, y en estos 12 bytes se almacenan las coordenadas X, Y, Z, utilizando para cada una de ellas 4 bytes. Entonces cada coordenada se almacena como un número entero de 4 bytes, es decir, puede tomar 2^32 = 4294967296 valores, que estarán comprendidos entre -2147483648 y +2147483647 (aproximadamente entre -2000 millones y +2000 millones de unidades).

Luego hay que tener en cuenta tanto el intervalo máximo de unidades como la precisión (unidad) con la que queremos almacenar las coordenadas en el archivo con formato bin. Las unidades se definen en el cuadro de diálogo Proyecto Nuevo de DigiNG. Si queremos trabajar en centímetros, sólo podremos almacenar coordenadas (cualquiera de las 3) que estén comprendidas entre -2000 millones y +2000 millones de centímetros, esto es, entre -20 millones y +20 millones de metros.

Por lo tanto, no es posible trabajar con precisión de milímetro y almacenar valores fuera del intervalo -2000 millones y +2000 millones de milímetros, es decir, no es posible trabajar con coordenadas que estén fuera del intervalo -2 millones y +2 millones de metros.

Entonces, precisión implica un límite máximo en las coordenadas. Este aspecto es trivial, por ejemplo, en España donde la cartografía oficial debe estar en proyección UTM. En esta proyección los valores de la coordenada X no darán problemas dado que estarán en torno a los cientos de miles de metros. Sin embargo, los valores de la coordenada Y sí pueden dar problemas puesto que pueden superar los 4 millones de metros. Por ello, si definimos en DigiNG una precisión de milímetro, no podremos almacenar coordenadas superiores a 2 millones de metros.

Fecha de última modificación: miércoles, 24 de Abril de 2002


Bases de Datos en DigiNG

Una entidad de dibujo puede tener asociados una serie de atributos alfanuméricos con información relacionada con la entidad. Por ejemplo, una línea que representa el límite de una parcela puede tener asociado un número de parcela y/o otros datos relacionados con la misma, como el nombre del propietario, su utilización, etc ...

Para que exista este realción entre datos geográficos y datos alfanuméricos se tienen que asociar las entidades del archivo con una base de datos, que será donde se almacenen los atributos de las entidades. En DigiNG se puede trabajar con dos tipos de base de datos

  • Interna.
  • Externa de tipo Access.

En DigiNG se dispone de varias órdenes para trabajar con Bases de Datos:

  • Enlazar con base de datos con la orden BASE_DATOS se define la base de datos con la que se desea trabajar. La orden que efectúa la acción contraria es DEJAR_BASE_DATOS
  • Establecer atributos: mediante las órdenes ALTA y ALTA_DUP se rellenan los campos de las tablas con atributos, para luego asignar los atributos a las entidades. También es posible copiar los atributos de entidades mediante la orden CLONAR_ATRIBUTOS.
  • Asignación de atributos a entidades: se puede hacer digitalizándolas después de establecer los atributos con la orden ALTA. También es posible la asignación de atributos a portátil mediante la orden PONER_ATR.

Todas las órdenes disponibles para trabajar con bases de datos se listan a continuación:

ALTA
 ALTA_DUP
 BASE_DATOS
 CLONAR_ATRIBUTOS
 DEJAR_BASE_DATOS
 PONER_ATR
 QUITAR_ATRIBUTOS

Mediante el programa de instalación del programa se almacena una base de datos, ejemplo.mdb, en el directorio C:\Archivos de programa\Digi3D\Tablas, y que está en el formato adecuado para trabajar con DigiNG.

También existe la posibilidad de trabajar con las Bases de Datos mediante DigiNGScript, accediendo a todas las funcionalidades que ofrece ADO.

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Base de Datos Interna

La Base de Datos Interna de DigiNG se denomina DBDIGI. La información de los atributos se almacena en el propio fichero de dibujo, junto con las coordenadas y el resto de la información del fichero.

Cada registro está formado por dos campos:

  • Número de entidad: debe ser entero y pertenecer al intervalo (0, 4294967296).
  • Código: puede tener un máximo de 6 caracteres alfanuméricos.

Para utilizar esta Base de Datos Interna se debe ejecutar la orden ALTA, y seleccionar Tabla Interna de Digi. Luego se rellenan los campos atributos para uno o varios registros, y se aceptan estos registros. Al digitalizar ahora una entidad se almacenarán los atributos con la entidad en el fichero de dibujo.

Fecha de última modificación: martes, 29 de Octubre de 2002


Bases de Datos Externas

Para utilizar Bases de Datos Externas en DigiNG, éstas deben cumplir las siguientes requisitos:

  • Ser de tipo Access (.mdb).
  • Contener una tabla denominada CATDBS, a modo de catálogo de tablas. Esta tabla debe contener dos campos:
    • De tipo numérico: este campo puede tener cualquier nombre.
    • De tipo texto: este campo también puede tener cualquier nombre, y debe contener los nombres de las tablas.
  • Además, el primer registro de la tabla CATDBS debe tener en el campo numérico como 1, y en el campo de texto DBDIGI.
  • Las restantes tablas deben tener obligatoriamente un campo autonuméríco, cuyo nombre se deja a elección del usuario. Este campo servirá de enlace con las entidades de dibujo. Los demás campos servirán para almacenar los atributos de las entidades.

Cuando se instala Digi3D, se guarda en la carpeta C:\Archivos de programa\Digi3D\Tablas el archivo ejemplo.mdb. Es una base de datos en formato Access con las características adecuadas para utilizarla en DigiNG.

Fecha de última modificación: martes, 29 de Octubre de 2002


Mosaicos en DigiNG

En DigiNG se dispone de varias herramientas para realizar un mosaico de ortofotografías:

  • Carga de las imágenes con la orden CARGA_RASTER. Para descargarlas se utiliza la orden DEJAR_RASTER.
  • Cambio del brillo y del contraste: bien de una imagen en concreto o de una zona con partes de varias imágenes. Se dispone de las órdenes CAMBIA_BRILLO_CONTRASTE y CAMBIA_BRILLO_CONTRASTE_V.
  • Cambio del equilibrio de color mediante las órdenes EQUILIBRIO_COLOR y EQUILIBRIO_COLOR_V.
  • Color transparente: el color blanco del borde de las Ortofotografías se comporta como si fuera transparente, con lo que no se ocultan partes de imagen al solaparse unas imágenes con otras.
  • Prioridad de imágenes: se determina qué imágenes se visualizan por encima de otras utilizando la orden TRAER_AL_FRENTE.
  • Degradado: se puede aplicar definiendo la dirección e intensidad del mismo. La orden es DEGRADADO.
  • Alternar la visualización del positivo y del negativo de las imágenes, a través de la orden POSITIVO_NEGATIVO_RASTER.
  • Translación de las Ortos con la orden TRASLADA_RASTER.
  • Mezcla de píxeles comunes de varias ortofotografías mediante la orden MEZCLAR.
  • Definición del color: se dispone de una serie de órdenes con las que se puede:
    • cambiar un color por otro (CAMBIA_COLOR y CAMBIA_COLOR_V).
    • definir un color (COLOR_PIXEL) para luego pintar con él (PINTA_PIXEL), o copiar el color de un píxel determinado (CUENTAGOTAS).
    • copiar una zona de la imagen (TAMPÓN y TAMPÓN_T).
    • rellenar una zona con color determinado (RELLENA_COLOR).
    • conocer el histograma de una zona concreta (HISTOGRAMA).
  • Definir el límite del mosaico y guardarlo en un único fichero de imagen, mediante la orden CORTAR_RASTER.

Todas las órdenes disponibles para realizar mosaicos se listan a continuación:

CAMBIA_BRILLO_CONTRASTE
 CAMBIA_BRILLO_CONTRASTE_V
 CAMBIA_COLOR
 CAMBIA_COLOR_V
 CARGA_RASTER
CARGA_RASTERS_POR_VENTANA
COLOR_PIXEL
 CORTAR_RASTER
 CUENTAGOTAS
 DEGRADADO
 DEJAR_RASTER
 EQUILIBRIO_COLOR
 EQUILIBRIO_COLOR_V
 HISTOGRAMA
 MEZCLAR
 PINTA_PIXEL
 POSITIVO_NEGATIVO_RASTER
 RELLENA_COLOR
 TAMPÓN
 TAMPÓN_T
 TRAER_AL_FRENTE
 TRASLADA_RASTER

Fecha de última modificación: miércoles, 23 de Abril de 2003


Modos de búsqueda

Sirve para establecer el modo de búsqueda o enganche gráfico a elementos del dibujo. El ámbito de búsqueda de una entidad está determinado por el tamaño del cursor y el factor de zoom de pantalla.

Las modalidades de enganche son las siguientes:

  • 0. Vértice o proyección en XY: la función trata de encontrar los vértices de la entidad, si no encuentra ninguno en su ámbito de búsqueda, calcula la proyección del punto (correspondiente a la posición del cursor) sobre el segmento de la entidad que se encuentre en este ámbito. El enganche se realiza en coordenadas X, Y sobre la proyección calculada. El elemento que se engancha toma estas coordenadas planimétricas pero mantiene su cota.

  • 1. Proyección en XY: la función ignora los vértices de la entidad, y sólo calcula las proyecciones sobre sus segmentos componentes. Se toma como punto proyectado, aquel que se encuentre dentro del ámbito de búsqueda. El enganche se realiza en coordenadas X, Y sobre este punto (igual en que el caso anterior).

  • 2. Vértices extremos de la entidad en XYZ: la función sólo considera los vértices primero y último de las entidades. Por tanto, el enganche se realizará únicamente con uno de los extremos de la entidad, y en coordenadas X, Y, Z.

  • 3. Vértice o proyección en XYZ: igual que el modo 0 pero se engancha también en Z.

  • 4. Vértice en XYZ: se busca el vértice de la entidad más próximo y se engancha con él en X, Y, Z.

  • 5. Proyección en XYZ: igual que el modo 1 pero se engancha en X, Y, Z.

  • 6. Vértices extremos si coincide la Z: se engancha en X, Y, Z al vértice extremo más próximo de una entidad siempre y cuando la Z actual sea igual a la del vértice. Esto es útil para restitución ya que obliga a que se tenga la misma Z al engancharse a una curva de nivel ya existente. De esta forma, nos obligará a llevar activo el interruptor Z_fija al querernos enganchar, o nos permitirá descubrir si la curva existente fue hecha con el interrruptor Z_fija activo. En los aparatos analíticos cuando fijamos una Z con Z_fija el sistema nos buscará, dentro del ámbito de búsqueda del cursor, la curva de nivel que tenga esa Z, y engancharemos en uno de los extremos de esa curva.

  • 7. Dos puntos: 1º XY, 2º Z: cuando se selecciona un modo de búsqueda 7, se toman las coordenadas X,Y del último punto registrado, como coordenadas planimétricas para el siguiente punto de datos. La coordenada Z será el valor de Z cuando se de el punto. No hay que indicar ninguna entidad. Suele utilizarse para realizar volúmenes.

  • 8. XYZ en el punto medio del segmento: se engancha en X, Y, Z en el punto medio del segmento donde se halla seleccionado con el cursor.

  • 9. Vértice en XY: igual que el modo 2 pero tomando sólo las coordenadas X, Y del vértice más próximo. El valor de Z se toma del valor de la Z actual.

  • 10. Vértices extremos de la entidad en XY: igual que el modo 2 pero tomando sólo las coordenadas X, Y del vértice más próximo. El valor de Z se toma del valor de la Z actual.

  • 11. Intersección: la función busca el punto intersección de dos entidades.

Fecha de última modificación: miércoles, 22 de Mayo de 2002


Simbología en DigiNG

La simbología en DigiNG está gestionada por 3 archivos:

  • DIGI.TAB: donde se definen los códigos
  • DIGI.PAL: donde se definen los colores de visualización en pantalla.
  • TEXT.TXT: en él se definen los símbolos y los caracteres. Hay que transformarlo al archivo binario TEXT.FNT mediante el programa COMTEXT, para que DigiNG lo utilice.

Este tema de la ayuda a su vez contiene a los siguientes:

  • El archivo DIGI.TAB.
  • El Editor de Códigos.
  • Como crear simbolos para DigiNG.

Fecha de última modificación: lunes, 29 de Abril de 2002


DIGI.TAB

En DigiNG se define la simbología mediante una ventana, llamada Editor de Códigos. Además se guarda la simbología en un archivo de texto, llamado DIGI.TAB. En otras versiones de Digi se gestionaba la simbología editando el archivo DIGI.TAB. En DigiNG podemos:

  • Crear/modificar códigos mediante el Editor de Códigos.
  • Elegir interactivamente el código en la barra de herramientas correspondiente a Digi1.

Si lo prefieres puedes editar el archivo DIGI.TAB y modificarlo manualmente. Para ello te será muy útil leer el tema de la ayuda Formato del archivo DIGI.TAB.

Fecha de última modificación: lunes, 29 de Abril de 2002


Editor de códigos

Esta ventana se visualiza ejecutando la orden DIGI.TAB dentro de DigiNG:

En esta ventana aparece la simbología definida en el archivo DIGI.TAB. La ventana se compone de varios elementos:

  • Lista de códigos: se muestran los códigos existentes en el archivo DIGI.TAB:

    • La primera columna de este cuadro muestra una casilla para activar y desactivar la visualización de los códigos en pantalla. Los códigos serán visibles si está marcada la casilla. Podemos seleccionar interactivamente el código que queramos. El código seleccionado podemos modificarlo como queramos, mediante el resto de elementos de esta ventana. Si hemos modificado un código y no lo queremos guardar en el archivo DIGI.TAB, pulsamos sobre el botón Cancelar en la ventana.

  • Paleta de colores: podemos seleccionar el color que nos interese. Hay que tener en cuenta que se modificará el archivo DIGI.TAB cuando pulsemos sobre el botón Aceptar de la ventana Editor de Código.

    • Los tres campos indican los valores de las componentes Rojo, Verde y Azul en el color seleccionado. Se puede cambiar un color pulsando sobre el botón Cambiar, con lo que emerge la ventana clásica de Windows para la definición de color. Si cambiamos aquí la configuración de colores, estaremos modificando el contenido del archivo DIGI.PAL que se esté empleando.

  • Código: es un campo alfanumérico que contiene el código de dibujo. El código es una cadena de caracteres que puede tener un máximo de 6 caracteres.
  • Tipo: es un campo numérico que hace referencia al tipo de entidad que se puede dibujar con el código anterior. Admite hasta 256 valores y que corresponden con:
    • 0: entidad puntual. El programa termina de forma automática la entidad cada vez que se da un punto. Todas las entidades que se registren con este código, sólo tendrán un punto. Con este tipo de entidades no se puede registrar en modo arrastre.
    • 1: entidad lineal. Las entidades se pueden registrar en modo punto a punto o de arrastre. El programa une mediante segmentos los puntos registrados. El usuario ha de indicar el final de entidad con la orden FIN_ENT, para dibujar un nuevo elemento. Si se registra un sólo punto y da por finalizada la entidad, el programa no registra dicha entidad.
    • Número negativo: entidad lineal. En caso de que dicha entidad sea cerrada, la entidad se visualizará y se imprimirá rellena con el color correspondiente al número que se indique en el digi.tab. La asociación entre un número de color y un determinado color RGB se realiza en el archivo DIGI.PAL. En el caso de que existan varias entidades cerradas y rellenas unas dentro de otras, la visualización y la impresión de los rellenos se realiza en el orden en que han sido registradas las entidades. Si la entidad no es cerrada no se rellenará.

    Si pulsamos sobre la lista desplegable que aparece al lado de Tipo podemos elegir entre:

  • Pluma: indica el número de la pluma que se va a emplear en el dibujo de la entidad. Si el número es negativo, no se dibuja (códigos virtuales), pero si la entidad lleva relleno si se rellenará.
  • Grosor: es un campo numérico usado para especificar el grueso de línea asociado a cada código. Se utiliza tanto para archivos de ploteo en lenguaje BGL como HPGL, y permite generar diferentes grosores de línea utilizando una misma pluma. Esto se consigue mediante el trazado de varias líneas paralelas. El grosor también se muestra por pantalla.
    Otra forma de obtener varios grosores es la que se basa en el uso de varias plumas diferentes. Es decir, cada grosor va asociado a una pluma específica del carrusel. Este forma es más efectiva para obtener grosores que la anterior.

  • Símbolo: Indica el número de símbolo que se va a utilizar a lo largo de una línea, o sobre una entidad puntual. Ejemplos: superposición del símbolo "aspa" sobre una línea para definir la entidad "alambrada", superposición del símbolo fuente en un punto, etc...
    El número utilizado se corresponde con el del código asignado al símbolo en el archivo TEXT.TXT (campo 1 del primer registro asociado a cada uno de los símbolos).
    En el caso de líneas sin patrón, este campo toma el valor "0".

    • Si pulsamos sobre la lista desplegable podemos elegir entre varios símbolos definidos en el archivo TEXT.TXT.

  • Distancia: distancia de la posición del símbolo (sólo en el caso lineal). Indica el incremento en distancia utilizado para espaciar los símbolos sobre la línea. Se ha de tener en cuenta que el primer símbolo se coloca con respecto al origen de la línea a una distancia igual a la mitad del incremento especificado.
    En la visualización en pantalla la distancia depende de la escala de dibujo, y en la representación obtenida con el plotter de la escala fijada en el programa PLT. El valor se da en décimas de mm. y es el que se obtendrá a la escala resultante de ploteo.
  • SimbX: indica el tamaño, expresado en décimas de milímetro, con el que ha de dibujarse el símbolo en el sentido del eje X (tamaño sobre papel).

    • Para definir un símbolo se utiliza un cuadrado de 100 x 100 cm, donde las coordenadas de las esquinas inferior izquierda y superior derecha son: (-50, -50) y (50, 50) respectivamente. El símbolo creado dentro de este espacio, ha de ser escalado de forma que en el dibujo tenga el tamaño especificado en este campo. El programa calculará un factor de escala en X, en función de este valor y de la escala de ploteo.

  • SimbY: indica el tamaño, expresado en décimas de milímetro, con el que ha de dibujarse el símbolo en el sentido del eje Y. En este caso, el programa calcula el factor de escala en Y que debe aplicarse al símbolo, en función de la escala de ploteo.

    Si se trata de un texto en este código, los campos 9 y 10 indican la relación ancho/alto, es decir, los tamaños en X e Y que tomará la letra dentro del font seleccionado. Si se dejan a cero los campos 9 y 10, la relación será 1:1.

  • Fuente: si elegimos la opción Text.fnt tendremos la posibilidad de escoger una fuente que previamente hayamos definido en el archivo TEXT.TXT, :

    • Si queremos una fuente True Type podemos elegirla de la lista desplegable:

  • Definición de los intervalos de trazado: los cuadros de texto, indican la longitud de tramo con la pluma levantada y longitud de trazo dibujado, alternativamente.

  • Descripción del código: se trata de una descripción literal que nos puede servir para identificar un código. Por ejemplo "LIMITE PROVINCIAL".
  • Color de fondo para este archivo de códigos: lista desplegable donde se define el color de fondo de la visualización del fichero de dibujo.
  • Color para los elementos desconocidos: cuando DigiNG no encuentra el archivo DIGI.TAB (porque éste no existe o no está ni en el directorio de Tablas, ni en el directorio de trabajo, ni en C:\Digi), nos presenta los elementos que componen el dibujo con el color que seleccionemos en esta lista desplegable.

En el siguiente tema de la ayuda aprenderás a crear tu propia simbología para DigiNG.

Fecha de última modificación: viernes, 17 de Octubre de 2003


Cómo crear simbología en DigiNG

Puedes crear tú mismo los códigos para utilizarlos en DigiNG. Para ello dispones de dos posibilidades:

  • Mediante la ventana del editor de códigos.
  • Mediante el archivo DIGI.TAB.

Fecha de última modificación: lunes, 29 de Abril de 2002


Cómo crear simbología en DigiNG mediante el Editor de códigos

Si en la ventana del Editor de Códigos pulsamos sobre el botón Nuevo:

Vemos como se nos crea un nuevo código. Ahora sencillamente le indicamos los distintos valores que queremos para el código. Por ejemplo, vamos a crear un símbolo lineal para representar alambradas, y queremos que tenga las siguientes características:

  • Línea base: una línea continua.
  • Símbolo: una cruz en forma de aspa de 5 mm de ancho y 5 mm de alto, tomando estas medidas como queremos que quede la línea una vez ploteada.
  • Repetición del símbolo cada 1.5 cm.

Entonces definimos los cuadros de la ventana Editor de Códigos así:

  • Código: 252525
  • Tipo: Lineal.
  • Pluma: 0
  • Grosor: 1
  • Símbolo: 21 (cruz en forma de aspa).
  • Distancia: hay que especificarla en décimas de mm. y a la escala de ploteo, si queremos que estén separadas las cruces 1.5 cm., tendremos que poner 150.
  • SimbX: si queremos que las cruces tengan ancho de 5 mm, pondremos 50.
  • SimbY: si queremos que las cruces tengan alto de 5 mm, pondremos 50.
  • Fuente: lo dejamos como está.
  • Intervalos de trazado: los dejamos todos a cero, porque queremos que la línea sea continua.
  • Descripción del código: Símbolo lineal de alambrada.

Para que se guarde el símbolo (código) creado hay que pulsar sobre el botón Aceptar. Si lo prefieres puedes aprender a crear los códigos abriendo el archivo DIGI.TAB con un editor de textos.

También puedes diseñar los símbolos, si quieres aprender cómo se diseñan pulsa aquí.

Fecha de última modificación: lunes, 29 de Abril de 2002


Cómo crear simbología en DigiNG mediante el archivo DIGI.TAB

También es posible crear simbología abriendo el archivo DIGI.TAB con un editor de textos, por ejemplo, con el Bloc de Notas de Windows. Lo abrimos, y sabemos que cada código ocupa un línea dentro de este archivo. Por ejemplo, vamos a crear un símbolo lineal para representar alambradas, y queremos que tenga las siguientes características:

  • Línea base: una línea continua.
  • Símbolo: una cruz en forma de aspa de 5 mm de ancho y 5 mm de alto, tomando estas medidas como queremos que quede la línea una vez ploteada.
  • Repetición del símbolo cada 1.5 cm.

Entonces escribimos una línea (o registro) dentro del archivo DIGI.TAB con los siguientes campos, separando éstos por comas, comillas o espacios en blanco:

  • Campo 1: Código, por ejemplo 252525.
  • Campo 2: Tipo de símbolo, como queremos que sea lineal, ponemos un 1.
  • Campo 3: Color, es un número entre 0 y 255 que identifica el color con el que se visualizará en pantalla, y que se corresponde con la paleta de colores definida en DIGI.PAL. Ponemos, por ejemplo, el color 5.
  • Campo 4: Pluma, 0
  • Campo 5 : Grosor, 1
  • Campo 6: Fuente, como no queremos ninguna, tecleamos 0 (cero).
  • Campo 7: Símbolo, el número 21 (cruz en forma de aspa). El número de símbolo depende del archivo TEXT.FNT (o TEXT.TXT) donde tengamos definidos los símbolos.
  • Campo 8: Distancia, hay que especificarla en décimas de mm. y a la escala de ploteo. Si queremos que estén separadas las cruces 1.5 cm., tendremos que poner 150.
  • Campo 9; SimbX, si queremos que las cruces tengan ancho de 5 mm, pondremos 50.
  • Campo 10: SimbY, si queremos que las cruces tengan alto de 5 mm, pondremos 50.
  • Campo 11: Fuente, como no queremos escribir ninguna ponemos un 0 (cero).
  • Campo 12 : aquí corresponde poner los intervalos de trazado de la línea, y los dejamos todos a cero, porque queremos que la línea sea continua.
  • Último campo: es una descripción literal del código, "Símbolo lineal de alambrada".

Luego la línea que hemos escrito en el archivo DIGI.TAB es la siguiente:

    252525 1 5 0 1 0 21 150 50 50 0 "Símbolo lineal de alambrada"

Escribiendo esta línea ya hemos creado el código para DigiNG. Si ahora entramos en DigiNG con este archivo DIGI.TAB almacenado en el directorio de tablas, podremos ver el resultado:

Si quieres aprender a crear símbolos pulsa aquí.

Fecha de última modificación: lunes, 29 de Abril de 2002


Barras de Herramientas

Por defecto aparecen las siguientes barras de herramientas:

  • Barra de Herramientas Códigos.
  • Barra de Herramientas Teclados.
  • Barra de Herramientas Coordenadas.
  • Barra de Herramientas Flags.
  • Barra de Herramientas Ordenes.
  • Barra de Herramientas Tentativo.
  • Barra de Herramientas Archivos.
  • Barra de Herramientas MDT.
  • Barra de Herramientas de Base de Datos.
  • Barra de Herramientas Dibuja.

Existen dos ventanas acoplables:

  • Salida: donde se muestran distintos tipos de listados y resultados, en función de la orden que se esté ejecutando.
  • Ayuda Dinámica: donde se muestra la ayuda de la orden que se esté ejecutando.

También es posible la creación y/o modificación de una barra de herramientas mediante el manejador de barras de herramientas.

La forma de activar la visualización de las barras de herramientas es pulsando con el botón derecho del ratón en la zona superior de la ventana principal de DigiNG, debajo del menú principal. Entonces emerge la siguiente ventana:

donde se activa o desactiva la visualización tanto de las barras de herramientas como de la ventana Salida y de la barra de estado (Status Bar).

Fecha de última modificación: viernes, 10 de Octubre de 2003


Barra de Herramientas Códigos

Tiene el siguiente aspecto:

Se utiliza en DigiNG, y contiene dos listas desplegables. La que está situada a la izquierda sirve para seleccionar un archivo de códigos, y la que está a la derecha sirve para seleccionar el código de forma interactiva.

Los archivos de códigos se establecen en la configuración de DigiNG, en el apartado de Tablas. Si quiere conocer como se configura lea el tema de la ayuda Configuración de Tablas.

Los códigos se definen en archivos de configuración con extensión TAB. Si quiere conocer el formato de este tipo de archivos lee el tema de la ayuda Formato del archivo DIGI.TAB.

Cuando se cambie de archivo de configuración de códigos, posteriormente se debe ejecutar la orden REGENERA.

También se puede pulsar sobre el icono situado en la parte derecha (prismáticos), que ejecuta la orden BC (Buscar Código).

Fecha de última modificación: viernes, 4 de Octubre de 2002


Barra de Herramientas Dibuja

Tiene el siguiente aspecto:

donde se puede ver que consta de seis iconos:

  • El primer icono que representa un lápiz, corresponde a la orden DIBUJAR

  • El segundo icono que representa una lupa y una flecha, corresponde a la orden ZOOM2P

  • El tercer icono que representa una lupa y un símbolo menos, corresponde a la orden ZOOM-

  • El cuarto icono que representa una lupa y un símbolo más, corresponde a la orden ZOOM+

  • El quinto icono que representa una lupa y una ventana, corresponde a la orden ZOOMV

  • El siguiente icono, corresponde a la orden ZOOME

  • El último icono, corresponde a la orden REGENERA

Fecha de última modificación: martes, 9 de Diciembre de 2003


Barra de Herramientas Teclados

Tiene el siguiente aspecto:

En esta barra de herramientas aparece el nombre del archivo donde tengamos configurado el teclado. Es posible tener varios teclados configurados, y hay dos maneras de efectuar el cambio de un teclado a otro:

  • Con el ratón, desplegando la lista en la misma barra.
  • Mediante la orden CAMBIA_TECLAS_MNU.

Esta barra resulta muy útil porque indica cuál es el teclado activo en cada momento.

Fecha de última modificación: martes, 27 de Agosto de 2002


Barra de Herramientas Coordenadas

Tiene el siguiente aspecto:

donde se puede ver que consta de dos cuadros:

  • En el cuadro de la derecha se visualizará una R cuando se esté dibujando una línea o un punto, que indica que se están registrando las coordenadas en el archivo de puntos que previamente se haya definido en el cuadro de diálogo Nuevo Proyecto DigiNG.

  • En el cuadro de la derecha se visualizarán las coordenadas donde esté el cursor en cada momento. Se visualizarán en metros con la precisión definida en el cuadro de diálogo Nuevo Proyecto DigiNG.

Fecha de última modificación: miércoles, 24 de Abril de 2002


Barra de Herramientas Flags

Tiene el siguiente aspecto:

En esta barra de herramientas puede aparecer la siguiente información:

  • Rep->: sirve para activar o desactivar la modalidad de repetición. Si se encuentra activa, al llamar a una orden ésta se ejecutará en modo recursivo, es decir, se repetirá hasta que se salga de ella con la orden ESCAPE, o pulsando la tecla Esc. Para activar este Flag se debe ejecutar la orden REPITE.
  • A: variable que se utiliza para activar o desactivar el autozoom. Cuando está activado, la pantalla va siguiendo al cursor en sus desplazamientos por el dibujo (autozoom), excepto cuando se registra en modo continuo. En este caso, la pantalla no se desplaza hasta que se suelta el botón de registro, centrándose en la posición que tenga el cursor en ese momento. Para activar/desactivar el autozoom se utiliza la orden AUTO.
  • V: si está activada al efectuar un enganche a una entidad con el botón de tentativo, ésta se presenta en pantalla con el color asignado con la orden COLOR_TENTATIVO, y el usuario puede verificar si la captura se realiza o no con dicha entidad. En caso afirmativo, puede aceptar la operación pulsando la tecla + o el botón del cursor correspondiente. Se activa/desactiva mediante la orden VER.
  • G: si está activada, al terminar una entidad sus puntos son generalizados antes de grabarse en el fichero. Se activa/desactiva mediante la orden G.
  • B: si está activa, indica que se visualizan en pantalla las entidades borradas. Se activa/desactiva mediante la orden BORRADOS.
  • C: si está activa, al finalizar las entidades lineales, éstas se cierran automáticamente, uniéndose el último punto con el primero. Se activa/desactiva con la orden C.
  • (n): indica el número de puntos máximo por entidad lineal. Se establece con la orden MAXPUNTOS.
  • Z_f: si está activado, la coordenada Z queda bloqueada, de forma que no puede ser modificada la cota al accionar el pedal del restituidor. Se activa/desactiva con las órdenes FIJAZ y Z.
  • <-: si está activado, al finalizar una entidad, lleva a Digi3D a la posición de la primera entidad. Se activa/desactiva con la orden IR_PRINCIPIO.
  • ->: si está activado, al pulsar sobre Tentativo lleva a Digi3D a la posición donde se haga tentativo. Se activa/desactiva con la orden IR_TENTATIVO.
  • Ort: si está activado, al dibujar un nuevo segmento, se fuerza a que sea perpendicular al anterior. Se activa/desactiva con la orden ORTO.
  • Ort_aa: si está activado, al dibujar un nuevo segmento, se fuerza a que sea perpendicular al ángulo activo. Se activa/desactiva con la orden ORTO_AA.
  • AR: si está activado, la superimposición vectorial del dibujo sobre Digi3D se regenera automáticamente. Se activa/desactiva mediante la orden AUTOREGENERAR.
  • S: si está activado, al terminar una entidad ésta es suavizada antes de almacenarse en el fichero de dibujo. Se activa/desactiva mediante la orden S.
  • tc: si está activado, corta las entidades al hacer tentativo en ellas. Se activa/desactiva con la orden TENTATIVO_CORTA.
  • tYf: si está activado, finaliza automáticamente el registro de un elemento lineal cuando se acepta un tentativo sobre otra entidad. Se activa/desactiva con la orden TENTATIVO_FIN.
  • Tt: si está activado, permite hacer tentativo en los textos. Se activa/desactiva mediante la orden TENTATIVO_TEXTOS.
  • //: si está activado, al terminar una entidad lineal, realiza una paralela de ésta. Se activa/desactiva ejecutando la orden P.
  • MDTz: si está activado, el valor de la Z se actualiza según los MDT cargados. Se activa/desactiva según la orden MDT_MUEVE_Z.
  • <n>:si está activado, muestra el número de atributos pendientes de asignar a entidades. Se activa mediante la orden ALTA, y se desactiva al asignar dichos atributos pendientes, bien digitalizando una entidad o bien seleccionando entidades mediante la orden PONER_ATR.
  • arMDT: si está activado, se autoregenera el primer archivo MDT cargado si hemos hecho algún cambio. Se activa/desactiva según la orden AUTORECALCULAR_MDT.

Fecha de última modificación: viernes, 25 de Octubre de 2002


Barra de Herramientas Ordenes

Tiene el siguiente aspecto:

Cuando se está trabajando con DigiNG informa de la orden activa en cada momento.

Fecha de última modificación: martes, 23 de Abril de 2002


Barra de Herramientas Tentativo

Tiene el siguiente aspecto:

Esta barra de herramientas está dividida en las tres partes, que de izquierda a derecha son:

  • Color: muestra el color de la entidad seleccionada mediante un tentativo.
  • Coordenadas: muestra las coordenadas donde se ha seleccionado una determinada entidad mediante un tentativo.
  • Modos de búsqueda: en esta lista desplegable se puede elegir el modo de búsqueda en el tentativo.

Fecha de última modificación: viernes, 3 de Mayo de 2002


Barra de Herramientas Archivos

Tiene el siguiente aspecto:

Esta barra de herramientas tiene varias funciones que de izquierda a derecha son:

  • Lista desplegable que establece el fichero de dibujo actual, entre los distintos archivos de referencia cargados (Orden CAMBIA_FICHEROS).
  • Permite cargar ficheros de referencia (Orden CARGA_F).
  • Descarga ficheros de referencia (Orden DEJAR).
  • Establece tiempo entre copias de seguridad (Orden SALVAR).
  • Guarda el archivo actual, eliminando del archivo las entidades con marca de Borrado (Orden COMPRIMIR).
  • Muestra en la ventana acoplable Salida información de los archivos actualmente cargados (Orden BININFO).

Fecha de última modificación: lunes, 30 de Septiembre de 2002


Barra de Herramientas MDT

Tiene el siguiente aspecto:

Esta barra de herramientas tiene dos funciones que de izquierda a derecha son:

  • Triangula a partir de un MDT o de un fichero BIN (Orden TRIANGULAR).
  • Realiza curvado a partir de un MDT (Orden CURVAR).

Fecha de última modificación: martes, 1 de Octubre de 2002


Ventana Salida

Se trata de una ventana acoplable donde se muestran distintos tipos de listados y resultados, en función de la orden que se esté ejecutando. Por ejemplo, si se ejecuta la orden LISTA, y como corresponde a dicha orden, se selecciona una entidad, en la ventana Salida se visualiza la información referente a la entidad seleccionada.

Para mostrar la ventana Salida se pulsa sobre la zona de la barra de herramientas con el botón derecho del ratón, emergiendo entonces la siguiente ventana:

donde se pueden seleccionar las barras de herramientas que se deseen visualizar. Si se marca la opción Salida, se visualiza en la parte inferior de la ventana principal de DigiNG la ventana Salida:

Esta ventana tiene dos páginas, como se puede observar en su parte inferior, Digi3D y DigiNG. Si se pulsa sobre una de ellas se muestra la página correspondiente. En el caso de que la información mostrada así lo requiera, se activan las barras desplazamiento horizontal y/o vertical, para poder visualizar todo su contenido. Se puede modificar el tamaño de la ventana, para adecuarla a las preferencias del usuario, como cualquier otra ventana de tipo Windows.

Asimismo, es posible mover la ventana y acoplarla en el lugar que el usuario prefiera. Para ello, se debe coger la ventana por la parte izquierda de la misma y arrastrar la ventana con el ratón, manteniendo para ello el botón izquierdo del ratón pulsado.

La ventana Salida se puede cerrar bien pulsando sobre la cruz en forma de aspa situada en la esquina superior izquierda, o bien pulsando sobre la zona de la barra de herramientas con el botón derecho del ratón, y desactivando la visualización en la ventana emergente.

Fecha de última modificación: martes, 3 de Septiembre de 2002


Ventana Ayuda Dinámica

La ventana acoplable de Ayuda Dinámica muestra la ayuda relacionada con la orden que se esté ejecutando, sin necesidad de ejecutar la orden AYUDA. La ayuda, es decir, el archivo Digi3D.chm, debe estar en el directorio C:\Archivos de programa\Digi3D\Ayuda. Si se ha realizado la instalación con la instalación propia de la ayuda, la ayuda debe funcionar correctamente.

Nada más iniciar el programa, se muestra la ventana de la Ayuda Dinámica:

En el caso de que no esté instalada la ayuda, en esta ventana se encuentra un enlace que descarga y ejecuta directamente la instalación de la ayuda:

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Manejador de la Barra de Herramientas

Si se selecciona Barra de Herramientas dentro de Herramientas en el menú principal de DigiNG:

aparece la siguiente ventana:

desde la que se pueden crear, modificar, ... barras de herramientas. Para crear una nueva barra de herramientas se pulsa sobre el botón Nueva, y aparece la siguiente ventana:

donde:

  • Título de la barra: en este campo se escribe el título general de la barra.
  • Mover arriba: cuando hay varios botones dentro de la barra, se puede variar la posición de éstos dentro de la barra de herramientas.
  • Mover abajo: ídem.
  • Nuevo: sirve para crear un nuevo botón. Si se pulsa sobre él aparece la ventana Datos de botón de barra de herramientas.
  • Editar: sirve para editar el contenido de un botón. Si se pulsa sobre él aparece la ventana Datos de botón de barra de herramientas.
  • Eliminar: se utiliza para quitar un botón de la barra de herramientas.

Si se pulsa sobre el botón Nuevo o sobre el botón Editar aparece la siguiente ventana:

en la que se define el botón a crear o a modificar:

  • Título del botón: título del botón (en la figura ZoomE).
  • Imagen asociada al botón: imagen que aparece sobre el botón. Debe estar en formato BMP, con un tamaño de 16x16 píxeles, y con una profundidad de color de 16 colores (en el ejemplo de la figura es la imagen Icono.bmp, que simplemente se trata un imagen en color amarillo).
  • Orden a ejecutar cuando se pulse el botón: se trata de la orden que se ejecutará cuando se pulse el botón (en el ejemplo de la figura la orden ZoomE).

Una vez definido, se pulsa sobre el botón Aceptar, y entonces se retorna a la ventana anterior:

donde se puede observar que aparece el botón creado (en el ejemplo de la figura ZoomE). Si se pulsa en esta ventana sobre el botón Aceptar se vuelve a la primera ventana:

donde se pulsa también sobre el botón Aceptar, y se vuelve al restituidor digital Digi3D:

donde se observa la nueva barra en la parte derecha de la ventana de trabajo. Esta ventana se puede mover, editar, ... Si se pulsa sobre el botón de la barra de herramientas (en el ejemplo de la figura en color amarillo) se ejecuta la orden asignada al botón (en este caso ZoomE).

Fecha de última modificación: viernes, 24 de Mayo de 2002


Listado de órdenes de DigiNG

Digi3D

Órdenes de DigiNG

    Orden |  | Descripción
AA | * | Establece un ángulo activo.
ACOPLAR | * | Establece un ángulo activo.
ACUERDO |  | Dibuja un arco entre segmentos.
AFIN_RASTER |  | Carga imágenes sin orientación asociada.
AGREGA |  | Añade un punto al archivo de puntos.
ALINEAR |  | Alinea puntos.
ALTA |  | Añade un registro a la base de datos.
ALTA_DUP |  | Activa añadir registro sobre copia del último registro.
ARCO |  | Dibuja un arco a partir de 3 puntos.
AREA |  | Calcula el área de una entidad cerrada.
ASIGNAR_GUID |  | Asigna un GUID (un número único) a cada entidad de un archivo Digi.
AT | * | Establece la altura de textos.
ANULA_ORDENES |  | Aborta la ejecución de una orden.
AUTO | * | Activa o desactiva el autozoom.
AUTONUM | * | Establece el factor de autonumeración.
AUTORECALCULAR_MDT |  | Activa/desactiva la función que autoregenera el primer archivo MDT cargado si se hace algún cambio.
AUTOREGENERAR | * | Actualiza la superimposición vectorial.
AYUDA |  | Muestra la ayuda de la orden que se esté ejecutando.
BAJA_Z |  | Baja la coordenada Z el valor de la equidistancia.
BAK |  | Realiza una copia de seguridad del archivo actual.
BASE_DATOS |  | Establece conexión con base de datos externa.
BC |  | Busca un código dentro de DIGI.TAB.
BININFO |  | Informa de las entidades que contiene un fichero de dibujo.
BINTOP | * | Informa de las topologías que contiene un fichero de dibujo.
BINTRAM | * | Genera archivo de errores y corrige topologías..
BLOQUE |  | Guarda entidades para insertar como bloque.
BLOQUE_2P |  | Guarda entidades para insertar como bloque rotado.
BORRA_ATR |  | Borra atributos de una entidad.
BORRA_BARRA_SALIDA |  | Borra el contenido de la barra de salida.
BORRA_COD | * | Borra entidades con el código dado.
BORRA_COD_V |  | Borra entidades con el código dado según una ventana.
BORRA_E |  | Borra la entidad que se seleccione.
BORRA_LIN1 |  | Borra las líneas de longitud menor de la indicada.
BORRA_ULTIMO |  | Borra la última entidad registrada en el fichero.
BORRA_V | * | Borra entidades según ventana.
BORRA_VERTICE | * | Borra vértices de entidades lineales.
BORRADOS |  | Activa o desactiva la visualización de entidades borradas.
BORRAR_GUID |  | Borra el GUID asignado a una entidad.
BUSCAR |  | Establece un criterio de búsqueda de entidades.
BUSCAR+ |  | Salta a la siguiente entidad localizada con el criterio establecido con la orden BUSCAR.
BUSCAR- |  | Retrocede a la entidad anterior, localizada con el criterio establecido con la orden BUSCAR.
C |  | Activa o desactiva el cierre automático de entidades.
CAL_ORTO | * | Calcula Ortofotografías Digitales.
CAMB_AT |  | Modifica la altura de los textos que se seleccionen.
CAMB_COD |  | Cambia el código a una entidad que se seleccione.
CAMB_JT |  | Modifica la justificación de textos.
CAMB_MAXPUNTOS |  | Cambia el número máximo de puntos a una entidad lineal.
CAMB_MODOB |  | Modifica el modo de búsqueda o de enganche.
CAMB_SEN |  | Cambia el sentido de una entidad.
CAMB_SEN_BAJA |  | Cambia el sentido de registro de los puntos de una entidad.
CAMB_SEN_SUBE |  | Cambia el sentido de registro de una entidad.
CAMB_TEXTO | * | Cambia un texto por otro.
CAMB_Z |  | Cambia la cota de una entidad.
CAMBIA_BRILLO_CONTRASTE |  | Cambia el brillo y el contraste de las imágenes cargadas en DigiNG.
CAMBIA_BRILLO_CONTRASTE_V |  | Cambia el brillo y el contraste de zonas de las imágenes cargadas en DigiNG.
CAMBIA_COLOR |  | Cambia un determinado color por otro en las imágenes raster.
CAMBIA_COLOR_V |  | Cambia un determinado color por otro en las imágenes raster según una ventana.
CAMBIA_DIGI_TAB |  | Cambia el archivo de definición de códigos.
CAMBIA_FICHEROS |  | Cambia fichero activo por uno de referencia.
CAMBIA_TECLAS_MNU |  | Cambia el fichero de teclas.
CARGA_DISPOSICION | * | Carga la disposicion de vistas y ventanas creada con anterioridad.
CARGA_DLL | * | Carga librerías DLL con funciones programadas en C.
CARGA_F |  | Visualiza fichero de referencia.
CARGA_MDT |  | Carga un Modelo Digital del Terreno.
CARGA_P | * | Carga fichero de puntos.
CARGA_PUNTOS_MEDIDOS |  |
CARGA_RASTER |  | Carga una imagen raster.
CARGA_TOP | * | Carga un archivo de topología.
CEBRA |  | Dibuja pasos de cebra.
CEBRA_4P |  | Dibuja pasos de cebra digitalizando 4 puntos.
CIERRA |  | Cierra una entidad existente.
CIERRA_ENT |  | Cierra la entidad que se está dibujando.
CIRCR |  | Dibuja una circunferencia mediante el centro y radio.
CIR2P |  | Dibuja una circunferencia mediante el centro y un punto.
CIR3P |  | Dibuja una circunferencia mediante tres puntos.
CLONAR |  | Activa el código y atributos de la entidad que se seleccione.
CLONAR_ATRIBUTOS |  | Copia en memoria los atributos de una entidad.
COD | * | Establece el código activo.
COD_COTAS | * | Activa el código de las cotas.
COD_CURVAS | * | Define el código de las curvas de nivel.
COLOR_FONDO | * | Establece el color del fondo.
COLOR_PIXEL |  | Establece el color de píxel.
COLOR_TENTATIVO | * | Especifica el color de las entidades seleccionadas.
COMPRIMIR |  | Elimina entidades con marca de borrado.
COPIA2P |  | Copia, gira y escala una entidad.
COPIAR |  | Copia una entidad.
CORTA_2P |  | Corta una entidad por dos puntos de la misma.
CORTAR_E |  | Corta una entidad en dos entidades.
CORTAR_F |  | Genera un fichero con entidades definidas dentro de otra.
CORTAR_RASTER |  | Corta imágenes cargadas y genera una imagen a partir de ellas.
COTA |  | Registra puntos de cota.
CREAR_DIGI_TAB |  | Crea un DIGI.TAB con todos los códigos del dibujo aúnque sean desconocidos.
CRUCE |  | Dibuja un cruce en intersecciones de entidades.
CUADROS |  | Construye matrices de rectángulos.
CUADROS_4P |  | Construye matrices de polígonos de cuatro lados.
CUENTAGOTAS |  | Selecciona un color de píxel de una imagen cargada.
CURSOR | * | Establece tamaño y forma del cursor.
CURVAR |  | Realiza el curvado de una triangulación.
DA | * | Establece los valores de las dos distancias activas.
DIGI3D |  | Asocia el cursor los movimientos de Digi3D
DEGRADADO |  | Aplica una función de degradado a las imágenes cargadas en DigiNG.
DEJAR | * | Descarga ficheros de referencia.
DEJAR_BASE_DATOS |  | Descarga Base de Datos.
DEJAR_MDT |  | Descarga el Modelo Digital del Terreno.
DEJAR_RASTER |  | Descarga imágenes raster.
DEJAR_TOP |  | Descarga archivos de topología.
DEM |  | Genera malla regular a partir de triangulación.
DESCARGA_DLL | * | Sirve para descargar librerías DLL previamente cargadas con la orden CARGA_DLL.
DIBUJAR | * | Activa o desactiva la opción de digitalizar o no sobre la ventana de DigiNG.
DIGI.TAB |  | Permite ver la definición de los códigos.
DISPOSITIVO_ENTRADA |  | Establece restituidor QASCO como dispositivo de entrada.
DLL | * | Sirve para ejecutar funciones de una librería DLL cargada con La orden CARGA_DLL.
DUP |  | Generado el duplicado de una entidad.
EDITAR |  | Modifica posición XY de vértices de entidad.
EDITAR_ATR |  | Permite editar mediante texto los atributos de una entidad así como borrarlos.
EDITAR_FOTO |  | Modifica una imagen raster existente.
EDITAR_TEXTO |  | Modifica un texto existente.
EDITAR_XYZ |  | Modifica posición XYZ de vértices de entidad.
EDITAR_Z |  | Modifica Z de coordenadas de entidad.
EQUIDISTANCIA | * | Establece la equidistancia de las curvas de nivel.
EQUILIBRIO_COLOR |  | Cambia el color de las imágenes cargadas en DigiNG.
EQUILIBRIO_COLOR__V |  | Cambia el color de zonas de las imágenes cargadas en DigiNG.
ENTRENAMIENTO |  | Guarda muestras de imagen.
ENVIA_DATOS_DRIVER |  | Envía datos a los drivers programados.
ERR | * | Visualiza un error dado.
ERR- |  | Visualiza error anterior.
ERR+ |  | Visualiza error siguiente.
ERROR |  | Visualiza el error en la barra de salida.
ERROR+ |  | Visualiza el siguiente error en la barra de salida.
ERROR- |  | Visualiza el anterior error en la barra de salida.
ESC_ACT | * | Establece factor de escala para inserciones de bloques.
ESCALA |  | Informa de la escala de visualización del fichero de dibujo.
ESCALERA |  | Construye escalera.
ESCALERA_DA |  | Construye escalera especificando el ancho de los peldaños.
ESCAPE |  | Finaliza una orden.
EXPLOTAR_PUNTOS |  | Convierte símbolos puntuales en segmentos lineales independientes.
EXPLOTAR_SIMBOLOGIA |  | Convierte líneas con patrón en segmentos lineales independientes.
EXPLOTAR_TEXTOS |  | Convierte textos en segmentos lineales independientes.
EXPORTAR |  | Exporta fichero actual a formato ASCII.
EXT |  | Prolonga entidad hasta intersección con otra.
EXT_M |  | Prolonga varias entidades hasta intersección con otra.
EXT_P |  | Prolonga e inserta punto en intersección.
EXT2X |  | Prolonga dos entidades hasta intersección.
EXTRAER_GEOREFERENCIACIóN |  | Crea diferentes archivos de georreferenciación de una imagen.
EXTRAER_GUID |  | Copia al portapapeles de Windows el Guid asignado a una entidad.
FICHERO_DIBUJO |  | Cambia fichero de dibujo actual.
FICHERO_P | * | Establece fichero de puntos.
FIJAXY | * | Activa o desactiva el forzado de coordenadas XY.
FIJAZ | * | Activa o desactiva el forzado de coordenada Z.
FIN |  | Finaliza sesión de dibujo sobre fichero actual.
FIN_ENT |  | Finaliza dibujado de entidad.
G | * | Activa o desactiva la función de generalización.
GEN | * | Elimina puntos de una entidad.
GIRAR | * | Visualiza fichero con ángulo de giro.
GROSOR | * | Asigna grosor de visualización para entidades en la pantalla ortogonal.
GROSORS | * | Asigna grosor de visualización para entidades en la pantalla estereoscópica.
GUARDA_DISPOSICION | * | Guarda la disposición actual de vistas y ventanas.
HISTOGRAMA |  | Muestra el histograma de la imagen.
HORIZON | * | Convierte entidades lineales en señalización horizontal.
IMPORTAR |  | Importa archivos DGN, DXF, ArcView, Kork.
IMPRIMIR |  | Imprime fichero de dibujo actual.
IMPRIMIR_V |  | Imprime según una ventana a modo de límite.
INC | * | Establece incremento de registro.
INS | * | Inserta bloque en fichero de dibujo.
INS_AA | * | Inserta bloque rotado según ángulo activo.
INS_FOTO | * | Inserta una imagen raster en el archivo de dibujo.
INS_OLE |  | Inserta un objeto OLE dentro de un archivo Digi.
INSERTA_VERTICE |  | Inserta un vértice nuevo en una entidad lineal.
INSR | * | Inserta bloque según ángulo indicado.
INTER | * | Interpola curvas de nivel.
INTER_EJE |  | Interpola entidad entre otras dos.
IR_A |  | Lleva el índice del restituidor Digi3D a la posición del cursor de DigiNG.
IR_PRINCIPIO | * | Activa o desactiva ir al primer punto de entidad al finalizar ésta.
IR_TENTATIVO | * | Activa o desactiva llevar índice del restituidor Digi3D a punto tentativo.
JT | * | Establece la justificación del texto.
JSCRIPT | * | Ejecuta programas de jscript.
JSCRIPT_ENCRIPTADO | * | Ejecuta programas de jscript encriptado.
JUNTAR |  | Traslada puntos de entorno a un mismo punto.
LANZA_ARROBA |  | Ejecuta macroinstrucciones (arrobas).
LIMITE_0 |  | Desactiva límites de zona de trabajo.
LIMITE_1 |  | Establece límites de zona de trabajo.
LINEA |  | Dibuja una entidad lineal.
LISTA |  | Presenta información sobre entidades de dibujo.
LISTA_ATR |  | Presenta información sobre los atributos de las entidades seleccionadas.
MARCAR_ATR |  | Genera un archivo de errors con referencias a entidades con atributos duplicados.
MAXPUNTOS | * | Establece número máximo de puntos de una entidad.
MDT |  | Determina una rejilla por la que se moverá el restituidor para registrar puntos.
MDTPC |  | Genera Modelos Digitales del Terreno por Correlación.
MDT_MUEVE_Z |  | Activa o desactiva la visualiación del MDT cargado.
MENU |  | Muestra el menú de pantalla.
MEZCLAR |  | Mezcla píxeles comunes de varias ortofotografías.
MIDE |  | Calcula distancia y acimut entre puntos.
MOD |  | Modifica el trazado geométrico de una entidad.
MOD_Z |  | Modifica el trazado geométrico de una entidad sólo en planimetría.
MODIFICA_VERTICE |  | Modifica planimetría del vértice.
MODOB | * | Activa una modalidad de búsqueda o enganche.
MOVER |  | Cambia la posición planimétrica de una entidad.
MOVER_Z |  | Cambia la cota a entidades.
MOVER_Z_V |  | Cambia la cota a entidades según un contorno.
MULTIARCO |  | Digitaliza arcos consecutivos.
N |  | Activa como dispositivo de entrada un archivo ASCII.
NDEC | * | Fija el número de decimales de texto numérico.
NUEVA_VENTANA |  | Crea una nueva vista del dibujo actual.
NUEVO_PROYECTO |  | Abre otro fichero de dibujo, sin cerrar el actualmente abierto.
OFF | * | Desactiva visualización de entidades según código en fichero de dibujo.
OFFD | * | Desactiva la visualización de entidades según código en fichero de dibujo y en pantalla de visualización estereoscópica.
OFFS | * | Desactiva visualización de entidades según código en pantalla de visualización estereoscópica.
OFF_GUID |  | Desactiva visualización de entidades que tengan asignado un GUID.
ON | * | Activa visualización de entidades según código en fichero de dibujo.
OND | * | Activa visualización de entidades según código en fichero de dibujo y en pantalla de visualización estereoscópica.
ONS | * | Activa visualización de entidades según código en pantalla de visualización estereoscópica.
ON_GUID |  | Activa visualización de entidades que tengan asignado un GUID.
ORDENA_POR_CODIGO |  | Ordena las entidades en el fichero según código.
ORDENA_POR_CODIGO_N |  | Ordena las entidades en el fichero según código numérico.
ORIGEN_GLOBAL | * | Establece el origen de coordenadas.
ORTO | * | Activa o desactiva el trazado perpendicular.
ORTO_AA | * | Activa o desactiva el trazado perpendicular con ángulo activo.
OSCURECER_ARCHIVOS_REFERENCIA | * | Oscurece la visualización de los archivos de referencia.
P | * | Activa o desactiva la generación automática de paralelas de entidades lineales.
PARALELA | * | Dibuja paralelas de entidades existentes.
PARAMETROS_IMPORTACION | * | Especifica los parámetros al importador/exportador correspomdiente.
PATRON | * | Activa o desactiva la visualización de los patrones de línea en el fichero de dibujo.
PATRONS | * | Activa o desactiva la visualización de los patrones de línea en la pantalla de visualización estereoscópica.
PERP |  | Traza perpendicular a una entidad.
PERP_A |  | Traza perpendiculares a un entidad
PINTA_PIXEL |  | Pinta píxeles con color definido o seleccionado.
PITA | * | Activa o desactiva los aviso acústicos.
PIXEL | * | Informa del tamaño, en unidades terreno, que le corresponde a un píxel de la imagen raster.
PONE_ALTURA |  | Coloca un texto con el valor de la coordenada Z actual.
PONE_DISTANCIA |  | Coloca un texto con el valor de la distancia entre dos puntos.
PONER_ATR |  | Asigna a una entidad los atributos en memoria .
PONER_ATR_R |  | Asigna atributos por recinto calculando topologías en tiempo real.
PONER_XY |  | Sirve para colocar dos textos con las coordenadas X e Y del punto o puntos seleccionados por el usuario.
POSITIVO_NEGATIVO_RASTER |  | Alterna visualización del positivo y del negativo de la imagen cargada.
PRECISION | * | Establece la precisión de las coordenadas.
PROG | * | Ejecuta otros programas desde DigiNG.
PROYECTA_ENTRE_CURVAS |  | Proyecta en Z puntos contenidos entre dos entidades lineales.
PUNTEAR |  | Rellena entidades cerradas con una trama de puntos.
PUNTO |  | Dibuja un punto con el código actual.
QUITAR_ATRIBUTOS |  | Borra los atributos en memoria.
RANGO_Z | * | Visualiza entidades dentro de un rango de cotas.
RATON |  | Establece el ratón como entrada de datos en DigiNG.
RATON_DIGI3D |  | Establece el ratón como dispositivo de entrada para Digi3D.
RAYAR |  | Establece un rayado interior para entidades cerradas.
RECUPERA |  | Recupera entidad con marca de borrado.
RECUPERA_COD | * | Recupera entidad con marca de borrado según código y tipo de entidad.
REGENERA |  | Actualiza visualización del dibujo.
RELLENA_COLOR |  | Rellena con un color una zona definida en una imagen raster.
RELLENAR |  | Activa o desactiva rellenado de entidades lineales cerradas.
RENOMCOD | * | Cambia código a varias entidades.
REPITE | * | Activa o desactiva la repetición de órdenes.
RESTAURAR_FICHERO |  | Mezcla dos ficheros comprobando los GUIDS de las entidades nuevas y borradas.
RETRIANGULA |  | Retriangula el primer archivo MDT cargado con los cambios ejecutados desde la última vez que se retrianguló o generó.
ROTULA_CURVAS |  | Rotula una o varias curvas a la vez con su correspondiente cota.
ROTULA_T |  | Rotula puntos con la descripción literal del código correspondiente.
ROTULA_Z |  | Rotula puntos con su cota correspondiente.
R_TEXTO |  | Gira un texto existente en el archivo de dibujo actual.
S | * | Activa o desactiva la función de suavizado de entidades.
SACA_P | * | Extrae puntos al lado de textos a una distancia activa.
SALIR |  | Termina sesión de trabajo volviendo al sistema operativo.
SALVAR | * | Establece tiempo entre copias de seguridad.
SELECCIONA_ULTIMO |  | Selecciona el último elemento digitalizado para terminar de ejecutar otra orden.
SELECCIONA_VENTANA | * | Permite seleccionar varios elementos por ventana al ejecutar las órdenes CAMB_COD o MOVER.
SIMB | * | Rellena el interior de una entidad cerrada usando una trama de símbolos.
SOLAPE | * | Establece el % de solape para órdenes de zoom.
SUAVIZA |  | Suaviza una entidad existente.
SUAVIZAR_MDT | * | Suaviza el MDT usando como parámetros las pendientes mínima y máxima.
SUBE_Z |  | Sube la coordenada Z el valor de la equidistancia.
TAMPóN |  | Clona píxeles de imágenes raster cargadas.
TAMPóN_T |  | Clona píxeles con transparencia de imágenes raster cargadas.
TECLA |  | Permite asignar órdenes a teclas.
TENTATIVO_CORTA | * | Activa o desactiva cortar entidad al hacer tentativo.
TENTATIVO_FIN | * | Activa o desactiva fin de entidad al hacer tentativo.
TENTATIVO_INSERTA |  | Inserción de un punto en las entidades lineales sobre las que se hace tentativo al registrar líneas.
TENTATIVO_TEXTOS | * | Activa o desactiva hacer tentativo a textos.
TEXTO | * | Escribe un texto en el fichero de dibujo.
TEXTO_R | * | Escribe un texto rotado en el fichero de dibujo.
TIEMPO_ESPERA | * | Permite especificar el tiempo de autorregistro de puntos al usar la orden MDT.
TOL | * | Establece el factor de tolerancia en el proceso de generalización.
TOL_ANG | * | Establece tolerancia angular en el proceso de generalización.
TRAER_AL_FRENTE |  | Visualiza una imagen sobre las demás.
TRAMAR | * | Establece un tramado para el interior de entidades cerradas.
TRANSFORMA_RASTER |  | Permite girar una imagen raster para su correcto ploteo.
TRASLADA_RASTER |  | Permite mover una imagen raster en el fichero de dibujo.
TRIANGULAR |  | Calcula la triangulación del Modelo Digital del Terreno cargado.
TRIM |  | Borra entidad desde el punto de intersección con otra.
U |  | Borra el último punto de la entidad que se está registrando.
UM |  | Borra los últimos puntos de la entidad que se esté registrando.
UNDO |  | Deshace las últimas acciones realizadas con el programa.
UNIR | * | Une dos entidades en una sola.
VBSCRIPT | * | Ejecuta programas de vbscript.
VBSCRIPT_ENCRIPTADO | * | Ejecuta programas de vbscript encriptado.
VER | * | Activa o desactiva la función de verificación.
VER_ATRIBUTOS |  | Muestra los atributos asociados a una linea.
VER_MDT | * | Activa o desactiva la visualización de la triangulación del MDT.
VER_TOPOLOGIAS | * | Activa o desactiva la visualización de las topologías del MDT.
XY |  | Sirve para introducir coordenadas de un punto.
Z | * | Asigna un valor a la coordenada Z.
ZOOMA |  | Centra visualización entorno al cursor.
ZOOMDER |  | Visualización en dirección derecha según solape.
ZOOME |  | Visualización de todo el dibujo en la pantalla.
ZOOME_R |  | Visualización de un recinto en la pantalla .
ZOOMIN |  | Aproximación visual centrada en el cursor.
ZOOMINF |  | Visualización en dirección inferior según solape.
ZOOMIZQ |  | Visualización en dirección izquierda según solape.
ZOOMOUT |  | Alejamiento visual centrado en el cursor.
ZOOMSUP |  | Visualización en dirección superior según solape.
ZOOMV |  | Visualización en pantalla de la zona indicada.
ZOOM+ |  | Acercamiento visual del dibujo.
ZOOM- |  | Alejamiento visual del dibujo.
ZOOM2P |  | Desplazamiento con el ratón en la pantalla de DigiNG.
1TEXTO |  | Inserta u único texto.
2P |  | Dibuja un cuadrado a partir de dos puntos.
2P_AA |  | Dibuja un rectángulo a partir de dos puntos teniendo en cuenta el ángulo activo.
3P |  | Dibuja un rectángulo a partir de 3 puntos.

    * Admite parámetros en la llamada a la orden.

Fecha de última modificación: 18 de Agosto 2003


Órdenes de DigiNG. A

    AA
    ACOPLAR
    ACUERDO
    AFIN_RASTER
    AGREGA ALINEAR
    ALTA
    ALTA_DUP

    ANULA_ORDENES
    ARCO
    AREA
    ASIGNAR_GUID
    AT
    AUTO
    AUTO_RATON
    AUTONUM
    AUTORECALCULAR_MDT
    AUTOREGENERAR
    AYUDA

Fecha de última modificación: miercoles, 10 de septiembre de 2003


Orden AA

Sirve para establecer el valor del ángulo activo. Este valor ha de introducirse en grados sexagesimales, y se puede indicar numéricamente o bien de forma gráfica dando dos puntos en pantalla con el cursor.

El origen de los ángulos coincide con el eje positivo de la coordenada X, y el avance en el sentido contrario a las agujas del reloj. El valor por defecto es 0 grados.

El ángulo activo se utiliza en la colocación de textos, líneas y en la inserción de bloques. La llamada a la orden admite tres posibilidades:

  • Escribir AA en la ventana de órdenes y pulsar Enter. Como se puede leer en la ventana que emerge:

    el sistema pide bien que se introduzca un valor para el ángulo activo, o bien que se pulsa sobre el botón Medir. En caso de que se introduzca un valor para el ángulo se debe pulsar sobre el botón Aceptar. En el caso de que se pulse sobre el botón Medir, se introduce el ángulo activo mediante dos puntos, en el orden que muestra la figura de arriba. Se digitaliza el primer punto, y al mover el ratón podemos ver en la parte inferior izquierda de la pantalla el ángulo que se registrará como activo para cada posición del segundo punto. Una vez digitalizado el segundo punto, ya está establecido el valor del ángulo activo.

  • Escribir AA=<valor> en la ventana de órdenes y pulsar Enter. El sistema tomará valor como el ángulo activo. Por ejemplo, así se introduce un ángulo activo de 45 grados sexagesimales:
    • AA=45

  • Escribir AA=? en la ventana de órdenes y pulsar Enter.

    • AA=?

    El programa muestra el valor actual del ángulo activo en la parte inferior derecha de la pantalla mediante un globo:

Órdenes relacionadas: INS_AA, ORTO_AA, TEXTO.

Fecha de última modificación: martes, 9 de Julio de 2002


Orden ACOPLAR

Con esta orden se genera un archivo raster idéntico al/los cargado/os mediante la orden CARGA_RASTER, pero con los vectores insertados en el propio raster. Esta opción nos será de gran utilidad a la hora de de querer plotear ortos por ejemplo, ya que el archivo generado se podrá plotear en un plotter que no disponga de ripper.

La orden ACOPLAR sólo se podrá ejecutar si se ha cargado previamente un archivo raster georrefrenciado, como por ejemplo una orto ó bien georreferenciando la imagén mediante la orden AFIN_RASTER. A continuación y con los vectores superpuestos podremos ejecutar la orden ACOPLAR.

Una vez ejecutada la orden se creará automáticamente un archivo raster con el siguiente nombre: [archivo raster cargado](número) acoplado.extensión. Por ejemplo, si el archivo raster cargado mediante la orden CARGA_RASTER fuera el Orto.tif, el archivo generado con la orden ACOPLAR se llamaría "Orto (0) acoplado.tif". Si dicho archivo ya existiese se generaría el archivo "Orto (1) acoplado.tif".

La orden ACOPLAR admite diferentes tipos de archivos raster cargados, pero hay que tener en cuenta que si el archivo cargado tiene una extensión diferente a .tif, .tiff ó .bmp el archivo se generará siempre con extensión .tif.

Órdenes relacionadas: CARGA_RASTER, AFIN_RASTER.

Fecha de última modificación: 4 de Mayo de 2004


Orden ACUERDO

Dibuja un acuerdo circular entre dos segmentos de una entidad con un vértice común, especificando un radio. Por lo tanto es necesario para el cálculo y dibujo del acuerdo tanto determinar el vértice de intersección de forma gráfica como introducir el valor del radio deseado (numérica o gráficamente).

El resultado de la orden es la sustitución del vértice por un arco del radio especificado y tangente a las dos rectas.

Una vez introducida la orden el programa nos pide que seleccionemos la línea (quebrada), y se debe hacer lo más próximo posible al vértice que se quiere sustituir por el acuerdo, para que DigiNG identifique el vértice deseado entre los que puedan existir en la línea quebrada:

Seleccionada la línea cerca del vértice deseado, aparece la siguiente ventana:

donde se puede introducir el valor del radio de dos formas:

  • Tecleando el valor del radio y pulsando sobre el botón Aceptar.
  • Determinar el valor del radio de forma interactiva mediante dos puntos en pantalla, bien pulsando previamente el botón Medir, o bien digitalizando los dos puntos directamente.

Si no se ejecuta la orden y aparece un mensaje de error puede ser debido a que el radio introducido es mayor que el radio máximo permitido por la entidad en la que se quiere dibujar un acuerdo.

Fecha de última modificación: jueves, 30 de Mayo de 2002


Orden AFIN_RASTER

Esta orden sirve para cargar imágenes sin orientación asociada. Se calcula automáticamente una orientación AFIN ajustando la imágen al rango de coordenadas máximas y mínimas en la pantalla en el momento de la carga de la imágen.

Para ejecutar ésta orden hace falta que previamente se carge la imagen raster con la orden CARGA_RASTER. En caso de llamar a la orden sin tener cargada la imagen, el programa nos avisará mediante el mensaje:

Después de llamar la orden AFIN_RASTER, se mostrará la siguiente ventana:

y el mensaje:

en la parte inferior de la pantalla. El programa requerirá una serie de puntos terreno y después los correspondientes puntos imagen. Una vez digitalizado el primer punto, el programa pedirá digitalizar otro para determinar las traslaciones en X y en Y, Xi e Yi. El programa necesitará al menos tres puntos para calcular la transformación, una vez introducidos, podremos aceptar o continuar introduciendo más puntos.

Nota: Una vez que se haya georreferenciado una imagen con la orden AFIN_RASTER no se podrá cortar dicho raster con la orden CORTAR_RASTER.

Órdenes relacionadas: CARGA_RASTER, CORTAR_RASTER, N, XY.

Fecha de última modificación: 28 de Junio 2004


Orden AGREGA

Sirve para añadir las coordenadas de un punto al fichero de puntos que se haya definido en la pantalla de inicio de DigiNG, o que se haya determinado con FICHERO_P.

Al ejecutar la orden aparece la siguiente ventana:

en la que el programa pide al usuario que teclee un número, que ha de ser entero. Si está activada la función AUTONUM el programa presenta el número de punto automáticamente. También se puede introducir un texto con información referente a ese punto, información que se almacenará junto con sus coordenadas. Si la casilla situada está activada, se escribirá como texto de información el código y la descripción del elemento "enganchado" junto a las coordenadas en el fichero de puntos. Para agregar un punto es necesario pulsar el botón Aceptar.

Finalmente se deben indicar numérica (con la orden XY) o gráficamente las coordenadas del punto. En este último caso, se puede dar el punto con el pulsador de dato o engancharse en una entidad dibujada con el pulsador de tentativo y aceptar la selección.

El número del punto, las coordenadas (X Y Z) y el texto de información se añadirán al fichero de puntos. Si se ha realizado un tentativo sobre una entidad al indicar el punto, el código de la entidad se guarda también en el fichero, después de las coordenadas y antes del texto explicativo.

La orden se ejecuta en modo de repetición (independientemente de que el conmutador REPITE esté activo o no), de forma que para salir de ella el usuario ha de pulsar la tecla Esc.

Órdenes relacionadas: AUTONUM, FICHERO_P, XY

Fecha de última modificación: jueves, 30 de Mayo de 2002


Orden ALTA

Sirve para dar de alta (añadir) uno o varios registros en la base de datos. Estos datos se asignarán posteriormente a una o varias entidades del dibujo. La base de datos puede ser la interna de DigiNG o bien una externa en formato Access (.mdb).

En el caso de que se trate de la base de datos interna los registros que se van a dar de alta tendrán dos campos: nº entidad y código. El número de entidad debe ser entero y pertenecer al intervalo (0, 4294967296), y el código puede tener un máximo de seis caracteres alfanuméricos. Este tipo de alta no se almacenará en una tabla externa, sino en el propio fichero de dibujo, junto con las coordenadas y el resto de la información del fichero.

Por el contrario, si se quiere utilizar una base de datos externa para almacenar los atributos de las entidades, debe haberse establecido previamente el nombre de dicha base de datos con la orden BASE_DATOS.

Al ejecutar la orden ALTA, el programa presenta la siguiente ventana:

donde:

  • Tabla: en esta lista desplegable se muestran las tablas activas. Por defecto se muestra la tabla interna de DigiNG, y en el caso de haber cargado una base de datos con la orden BASE_DATOS, se mostrarán en esta lista las tablas disponibles.
  • Campos de tabla: se mostrarán los campos definidos en la tabla seleccionada en la lista.
  • Nuevo: se genera un nuevo registro de la tabla actual, y aumenta incrementalmente el número de registro.
  • Borrar: borra el registro actual, disminuyendo el número de registros.
  • Aceptar: sale de esta ventana, y se muestra en la Barra de Herramientas Flags el número de registros pendiente.
  • Cancelar: sale de esta ventana, cancelándose esta orden.

Después de dar un alta, tanto en el caso de tabla interna como externa, aparece en la Barra de Herramientas Flags de la pantalla un '<1>', lo cual indica que hay un registro con datos que no está asociado a ningún elemento del dibujo. Si se dibuja una entidad en este momento o se ejecuta la orden PONER_ATR, se asignarán los datos del registro pendiente a la entidad. Después de esta asignación de atributos, se descargan los datos de la tabla y desaparecerá el indicador de registros pendientes de la Barra de Herramientas Flags.

Con la orden ALTA el programa presenta una plantilla vacía del registro para ser rellenado. Se puede activar la orden de alta duplicada (ALTA_DUP) para que al ejecutar la orden ALTA aparezca una copia del último registro, y poder utilizarlo como modelo, modificando alguno de los campos.

Órdenes relacionadas: ALTA_DUP, BASE_DATOS, BORRA_ATR, CLONAR_ATRIBUTOS, PONER_ATR, QUITAR_ATRIBUTOS.

Fecha de última modificación: viernes, 25 de Octubre de 2002


Orden ALTA_DUP

Con la orden ALTA el programa presenta una plantilla vacía con todos los campos definidos en la tabla activa, para que éstos sean rellenados. Se puede utilizar la orden de alta duplicada (ALTA_DUP) para que se active una ayuda en la edición de registros. Esta ayuda consiste en que al ejecutar la orden ALTA_DUP nos presentará una copia del último registro ya lleno en lugar de una plantilla vacía. De este modo podemos utilizar la copia como modelo y, en muchos casos, modificando sólo alguno de los campos quedan completados todos los datos.

Esta opción existe en el caso de utilizar bases de datos externas.

Órdenes relacionadas: ALTA, BASE_DATOS, BORRA_ATR, CLONAR_ATRIBUTOS, PONER_ATR, QUITAR_ATRIBUTOS.

Fecha de última modificación: viernes, 25 de Octubre de 2002


Orden ALINEAR

Esta orden se utiliza para mover puntos a una alineación dada. Se definirá la alineación indicando dos puntos, como se puede ver en el gráfico animado:

Todas las entidades que estén activas (ON), y que la distancia en proyección de alguno de sus puntos al segmento definido por los dos puntos anteriores, sea menor que la primera distancia activa, se modificará, de tal forma que esos puntos se proyecten sobre la alineación definida.

Ejecutada la orden el programa solicita el primer punto de la alineación,

y una vez digitalizado el primero, pide el segundo punto:

Entonces el programa alinea los puntos de las entidades activas cuya distancia en proyección sea menor que la distancia activa. Esta orden se repetirá si está activo el conmutador REPITE.

Órdenes relacionadas: DA.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden ANULA_ORDENES

Esta orden sirve para dejar de ejecutar una orden. Si por ejemplo se está dibujando una línea con la orden LINEA, y ejecutamos la orden ANULA_ORDENES, se deja de ejecutar la orden LINEA y se anula también la entidad que se estuviera dibujando mediante la orden LINEA.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden ARCO

Dibuja un arco en el espacio a partir de tres puntos definidos por el usuario. Estos pueden indicarse de forma gráfica con el cursor, o bien introduciendo sus coordenadas por teclado con la orden XY.

En primer lugar pide que se digitalice el primer punto, como se puede observar en la parte inferior izquierda de la pantalla:

Luego solicita el punto central del arco:

y finalmente el último punto:

Antes de digitalizar el último punto, vemos de forma interactiva el arco.

Si la orden se ejecuta mientras se esta dibujando una entidad, sólo hay que especificar los puntos segundo y tercero, ya que el primero se corresponde con el último registrado en la entidad.

Órdenes relacionadas: MULTIARCO, XY.

Fecha de última modificación: martes, 12 de Noviembre de 2002


Orden AREA

Calcula la superficie de entidades gráficas cerradas, y sitúa en la pantalla un texto con este valor, en la posición indicada por el usuario. Si devuelve un valor positivo indica que los elementos de la entidad cerrada han sido creados en el sentido de las agujas del reloj. Si devuelve un valor negativo indica que los elementos de la entidad cerrada han sido creados en el sentido contrario al del avance de las agujas del reloj.

El programa pedirá en primer lugar, un sufijo para colocar detrás del texto de superficie,

Este sufijo es opcional, y por defecto aparece la cadena Area. El usuario puede introducir el texto que desee y luego pulsar el botón Aceptar. Si se pulsa sobre el botón Cancelar, se detiene la ejecución de la orden AREA.

A continuación el usuario ha de seleccionar el elemento cuya superficie se desea conocer,

y después ha de indicar la posición donde desea colocar el texto:

Los parámetros relativos al código, altura, inclinación y orientación del texto, se corresponden con los que se encuentren activos en el momento de llamar a la orden. El número de decimales será fijado con la orden NDEC .

Esta orden se autorrepite, independientemente de si el conmutador REPITE está activo, y ya no pide el sufijo, sino que directamente pide la siguiente entidad a rotular su área. Continúa pidiendo entidades hasta que se pulse la tecla Esc.

Órdenes relacionadas: AA, AT, IT, NDEC.

Fecha de última modificación: lunes, 3 de Junio de 2002


Orden ASIGNAR_GUID

Sirve para asignar un GUID (un número único) las entidades de un archivo Digi. De este modo la entidad se puede identificar unívocamente incluso cuando se traspasa a otro fichero a través de la orden EXPORTAR.

Cuando ejecutemos la orden el programa pedirá seleccionar la entidad a la cual deseamos asignar un GUID.

En caso de que la entidad ya tenga assignado un GUID, el programa nos informa con el mensaje:

Órdenes relacionadas: ON_GUID, OFF_GUID, BORRAR_GUID, EXTRAER_GUID, RESTAURAR_FICHERO.

Última modificación: 29 de Julio de 2003


Orden AT

Sirve para establecer la altura de los textos en el dibujo. Este valor ha de introducirse en metros y fracción decimal de metro. También se puede indicar dando dos puntos en el dibujo.

La llamada a la orden admite tres posibilidades:

  1. Escribir AT y pulsar Enter. Entonces aparece la siguiente ventana, en la que el sistema pedirá que se introduzca un valor para la altura de textos. Esta altura se puede introducir por medio del teclado indicando su valor en metros y luego pulsando sobre el botón Aceptar.

    2. Y también se puede introducir de forma gráfica mediante dos puntos, bien pulsando sobre el botón Medir o directamente digitalizando el primer punto. Digitalizado un primer punto se muestra en la parte inferior izquierda de la ventana de la aplicación la distancia de forma interactiva:

    Y se digitaliza el segundo punto para determinar la altura de texto.

  2. Escribir AT=<valor> y pulsar Enter. El sistema tomará valor como la altura de textos actual.
    AT=1.5

  3. Escribir AT=? y pulsar Enter. El programa muestra el valor actual de la altura de textos mediante un globo en la parte inferior derecha de la ventana:
    4. AT=?

Órdenes relacionadas: CAMB_AT, TEXTO.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden AUTO

Variable que se utiliza para activar o desactivar el autozoom. Esta orden se mantiene únicamente para el caso de que el dispositivo de entrada, sea Digi3D con manivelas. Cuando está activada esta variable, la pantalla va siguiendo al cursor en sus desplazamientos por el dibujo (autozoom), excepto cuando se registra en modo continuo. En este caso, la pantalla no se desplaza hasta que se suelta el botón de registro, centrándose en la posición que tenga el cursor en ese momento.

Si el autozoom está activo, en la barra de herramientas Flags aparecerá la letra A.

El cambio de un estado a otro se produce cada vez que se llama a esta orden. También se puede introducir el valor de AUTO en la ventana de órdenes:

AUTO=1 | Activa el auto.
AUTO=0 | Desactiva el auto.
AUTO | Cambia el estado del conmutador.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden AUTO_RATON

Variable que se utiliza para activar o desactivar el autozoom. Sólo funciona en caso de que el dispositivo de entrada sea el ratón y se esté trabajando en la ventana ortogonal. Cuando está activada la variable AUTO_RATON, la pantalla va siguiendo al cursor en sus desplazamientos por el dibujo (autozoom), excepto cuando se registra en modo continuo. En este caso, la pantalla no se desplaza hasta que se suelta el botón de registro, centrándose en la posición que tenga el cursor en ese momento.

El cambio de un estado a otro se produce cada vez que se llama a esta orden. También se puede introducir el valor de AUTO_RATON en la ventana de órdenes:

AUTO=1 | Activa el auto.
AUTO=0 | Desactiva el auto.
AUTO | Cambia el estado del conmutador.

Fecha de última modificación: viernes, 15 de Enero de 2004


Orden AUTONUM

Se utiliza para establecer como factor de autonumeración el valor que le indiquemos en la llamada a la orden. Al poner textos numéricos, los valores se irán incrementando automáticamente con el factor de autonumeración.

Al ejecutar la orden aparece el siguiente cuadro de diálogo:

donde se puede introducir el nuevo valor de autonumeración, es decir, el incremento con el que se autonumeran los puntos en funciones como AGREGA, etc...

También es posible introducir el factor de autonumeración de forma directa con la siguiente sintaxis:

autonum=<factor de autonumeración>

Por ejemplo, ejecutando la siguiente línea:

  autonum=1

se establece como factor de autonumeración 1.

Esta orden suele utilizarse en:

  • Rotulación de curvas de nivel.
  • Números de parcelas ....

Fecha de última modificación: lunes, 3 de Junio de 2002


Orden AUTORECALCULAR_MDT

Una vez activada esta orden, sirve para autoregenerar automáticamente el archivo MDT cargado si realizamos algún tipo de cambio como pueda ser, añadir o modificar una línea, o borrar un punto.

Cuando llamamos esta orden, se activa, mostrando el mensaje arMDT en la barra de herramientas flags.

Órdenes relacionadas: MDTPC.

Fecha de última modificación: miércoles, 10 de Septiembre de 2003


Orden AUTOREGENERAR

Variable que se utiliza para activar o desactivar la regeneración automática del dibujo, y de la superimposición vectorial del mismo en la pantalla de visualización estereoscópica.

Si está activo, en la barra de herramientas Flags aparecerán las letras AR.

El cambio de un estado a otro se produce cada vez que se llama a esta orden. También se puede introducir el valor de AUTOREGENERAR en la ventana de órdenes:

AUTOREGENERAR=1 | Activa la regeneración automática del dibujo.
AUTOREGENERAR=0 | Desactiva la regeneración automática del dibujo.
AUTOREGENERAR | Cambia el estado del contador.

Órdenes relacionadas: REGENERA.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden AYUDA

Esta orden sirve para visualizar la ayuda de la orden que se esté utilizando. La ayuda, es decir, el archivo Digi3D.chm, debe estar en el directorio C:\Archivos de programa\Digi3D\Ayuda. Si se ha realizado la instalación con la instalación propia de la ayuda, ésta debe funcionar correctamente.

Existe también una ventana acoplable de Ayuda dinámica. Esta ventana de ayuda muestra la ayuda relacionada con la orden que se esté ejecutando, sin necesidad de ejecutar la orden AYUDA.

Fecha de última modificación: martes, 5 de Noviembre de 2002


órdenes de DigiNG. B

    BAJA_Z
    BAK
    BC
    BININFO
    BINTOP
    BINTRAM
    BLOQUE
    BLOQUE_2P
    BORRA_AUTODUPLICADOS
    BORRA_BARRA_SALIDA
    BORRA_COD
    BORRA_COD_V
    BORRA_E
    BORRA_LIN1
    BORRA_ULTIMO
    BORRA_V
    BORRA_VERTICE
    BORRADOS
    BORRAR_GUID
    BUSCAR
    BUSCAR+
    BUSCAR-

Fecha de última modificación: viernes, 26 de Septiembre de 2003


Orden BAJA_Z

Sirve para bajar la Z en una cuantía igual a la equidistancia de curvas que se tenga establecida. Esta equidistancia se define en el cuadro de diálogo Nuevo Proyecto de DigiNG, o bien mediante la orden EQUIDISTANCIA.

Órdenes relacionadas: SUBE_Z, EQUIDISTANCIA.

Fecha de última modificación: lunes, 10 de Junio de 2002


Orden BAK

Realiza una copia de seguridad del fichero de dibujo activo. Esta copia tendrá el mismo nombre que el fichero original, variando únicamente su extensión que ahora pasa a ser BIK. EL nuevo fichero se almacena en el directorio de trabajo activo.

DigiNG puede llamar automáticamente a esta orden cada cierto tiempo. Esta función se activa con la orden SALVAR, con la que se especifica el intervalo de tiempo entre copias de seguridad.

Órdenes relacionadas: SALVAR.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BASE_DATOS

Esta orden sirve para establecer una conexión con una base de datos. Al ejecutar la orden se muestra en pantalla el siguiente cuadro de diálogo:

donde se puede seleccionar una base de datos de tipo Access (.mdb). Esta base de datos tiene que contener una tabla, de nombre CATDBS, y definida como se explica en el tema de la ayuda Bases de Datos en DigiNG.

Sólo es posible tener cargada una base de datos. En el caso de tener una cargada y abrir otra, la primera se descarga y se queda cargada la segunda.

Mediante el programa de instalación del programa se almacena una base de datos, ejemplo.mdb, en el directorio C:\Archivos de programa\Digi3D\Tablas, y que está en el formato adecuado para trabajar con DigiNG.

Órdenes relacionadas: ALTA, ALTA_DUP, BORRA_ATR, CLONAR_ATRIBUTOS, DEJAR_BASE_DATOS, PONER_ATR, QUITAR_ATRIBUTOS.

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orden BC

Con esta orden, Busca Código, lo que hace el programa es ayudar al usuario a buscar un código dentro de la tabla DIGI.TAB. Al ejecutarla aparece la siguiente ventana:

donde se puede escribir tanto el código como un texto que se encuentre dentro de la Descripción del código, e interactivamente aparecen los diferentes códigos correspondientes a esa cadena. Y se puede seleccionar con el puntero del ratón, y luego pulsar sobre el botón Seleccionar para que dicho código sea el activo.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BININFO

Es una orden que sirve para visualizar por pantalla información relativa a las entidades de los ficheros de dibujo cargados.

Al llamar a la orden se lista en la ventana acoplable Salida la información sobre los archivos actualmente cargados:

Como se puede observar se proporciona con esta orden la siguiente información para cada archivo cargado:

  • Número de líneas.
  • Número de puntos.
  • Número de textos.
  • Coordenadas máximas y mínimas.
  • Códigos conocidos.
  • Códigos desconocidos: se trata de los códigos que no se encuentren en el archivo DIGI.TAB.

    • Órdenes relacionadas: BINTOP.

Fecha de última modificación: jueves, 27 de Septiembre de 2002


Orden BINTOP

Esta orden sirve para crear un archivo de topologías. Identifica como erróneos arcos de un solo punto, es decir elementos puntuales con códigos lineales.

Existe la posibilidad de llamar esta orden especificando sus parámetros en la linea de órdenes. En este caso serían los siguiente:

BINTOP = [tabla][generar archivo de errores][nombre fichero errores][tamaño error][cargar como fichero de referencia][mostrar error en barra output][cargar topología en memoria][visible][rellenar polígonos sin centroide][r][g][b]

Así pues, en caso de querer generar un archivo de errores le daríamos a dicho parámetro el valor 1 y tendríamos que especificar el tamaño para el símbolo de error y decirle al programa que lo cargue como fichero de referencia.

En caso de no querer generar un archivo de errores, le daríamos a éste parámetro el valor 0 y mostraríamos los errores en la barra output y así sucesivamente.

Ejemplos:

bintop="c:\tabla1.tab" 0 1 0
'hace topología con la tabla c:\tabla1, no genera fichero de errores, muestra una descripción del error en la barra Output y no carga la topología en memoria
bintop="c:\tabla1.tab" 0 1 1
'hace topología con la tabla c:\tabla1, no genera fichero de errores, muestra una descripción del error en la barra Output y carga la topología en memoria

bintop="c:\tabla1.tab" 0 1 1 0
'hace topología con la tabla c:\tabla1, no genera fichero de errores, muestra una descripción del error en la barra Output y carga la topología en memoria (invisible)
bintop="c:\tabla1.tab" 0 1 1 1 1 255 127 32
'hace topología con la tabla c:\tabla1, no genera fichero de errores, muestra una descripción del error en la barra Output y carga la topología en memoria visible, rellenando los polígonos sin centroide con el color 255 127 32

bintop="c:\tabla1.tab" 1 "c:\err.bin" 2.0 1 0 1 1 1 255 127 32
'hace topología con la tabla c:\tabla1, generando un fichero de errores llamado c:\err.bin, con errores con un tamaño de 2 metros, y cargando el fichero de errores como referencia, sin mostrar una descripción del error en la barra Output, cargando la topología en memoria ,visible y rellenando los polígonos sin centroide con el color 255 127 32.

Órdenes relacionadas: BININFO.

Fecha de última modificación: jueves, 18 de Septiembre de 2003


Orden BINTRAM

Esta orden sirve para: detectar intersecciones entre entidades, detectar arcos colgantes, buscar entidades duplicadas, tramificar entidades, juntar entidades para eliminar nodos superfluos y buscar errores en Z entre otras aplicaciones.

Existe la posibilidad de llamar esta orden especificando sus parámetros en la linea de órdenes. En este caso serían los siguientes:

BINTRAM = [tabla][generar archivo de errores][nombre archivo de errores][tamaño error][cargar como fichero de referencia][mostrar error en barra output][acción tramificar][corregir errores generando líneas o eliminando extremos superfluos][marcar como error, líneas que prodrían estar connectadas al estirarlas][acción duplicadas][acción juntar]

Así pues, en caso de querer generar un archivo de errores le daríamos a dicho parámetro el valor 1 y tendríamos que especificar el tamaño para el símbolo de error y decirle al programa que lo cargue como fichero de referencia.

En caso de no querer generar un archivo de errores, le daríamos a éste parámetro el valor 0 y mostraríamos los errores en la barra output y así sucesivamente.

BINTRAM da la posibilidad de corregir errores generando líneas o eliminando extremos superfluos, en éste caso tenemos que especificar una tolerancia mínima. Dicha tolerancia mínima también hay que especificarla en caso de que hayamos escogido la opción de marcar como error líneas que podrían estar conectadas al estirarlas.

Los posibles valores para los demás parámetros son los siguientes:

[accion_tramificar] : 0 = No buscar cruces entre líneas
                            1 = Insertar vértice en el cruce de líneas
                            2 = Partir
                            3 = Marcar como error
                            4 = Marcar como error si las diferencias de Z son superiores a la tolerancia máxima
                            5 = Marcar como errores los vértices extremos

[acción_duplicadas] : 0 = No buscar entidades duplicadas
                             1 = Marcar como error entidades duplicadas
                             2 = Borrar entidades duplicadas

[acción_juntar]     : 0 = No juntar líneas
                           1 = Juntar líneas por código
                           2 = Juntar líneas por tabla

Ejemplo:

BINTRAM="c:\tabla1.tab" 1 "c:\err.bin" 1 2.0 1 1 3 0 1 2 0

'hace topología con tabla c:\tabla1, genera fichero de errores,

el fichero de errores tendrá como nombre err.bin,

trunca el fichero de errores anterior,

el tamaño de símbolo de error será de 2 metros,

carga el fichero de errores como referencia,

muestra error en barra out put,

marca como error las tramificaciones,

no corrige errores generando líneas o eliminando extremos superfluos,

marca como error líneas que podrían estar conectadas al estirarlas,

borra entidades duplicadas,

no junta líneas por código.

Órdenes relacionadas: BINTRAM, BINTOP, BININFO.

Fecha de última modificación: viernes, 26 de Septiembre de 2003


Orden BLOQUE

Se utiliza para almacenar en un nuevo fichero una entidad o conjunto de entidades, que podrán ser insertadas posteriormente en cualquier dibujo.

La secuencia de acciones a realizar es:

  • Dibujar, en el fichero de trabajo, los elementos que constituirán el bloque.
  • Dibujar una entidad cerrada alrededor de los elementos de interés. Esta entidad tiene la misma función que una ventana.
  • Llamar a la orden BLOQUE, y se muestra la siguiente ventana:

  • Especificar el nombre del nuevo fichero en este cuadro de diálogo mostrado, y en la parte inferior del mismo existe una lista desplegable:

    • donde se selecciona el modo de corte. Después se pulsa sobre el botón Guardar de la ventana.

  • Seleccionar el punto que será el origen de coordenadas, como se puede leer en la parte inferior izquierda de la pantalla:

  • Seleccionar la entidad que va actuar de límite, dibujada anteriormente a modo de ventana, como se puede leer en la parte inferior izquierda de la pantalla:

Con esta sucesión de pasos ya estaría formado un bloque para su posterior inserción con las órdenes INS, INS_AA, INSR.

El punto indicado como origen se utilizará como punto de inserción cuando queramos incluir el bloque en un fichero de dibujo. La orden asigna a este punto las coordenadas (X=0, Y=0, Z=0), de forma que todas las entidades sufren una traslación y quedan referidas a este origen en el nuevo fichero.

Órdenes relacionadas: BLOQUE_2P, INS, INS_AA, INSR.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BLOQUE_2P

Se utiliza para almacenar en un nuevo fichero una entidad o conjunto de entidades, que podrán ser insertadas posteriormente en cualquier dibujo. Es similar a la orden BLOQUE con la excepción de que la orden BLOQUE_2P toma dos puntos para girar el bloque a grabar.

La secuencia de acciones a realizar es:

  • Dibujar, en el fichero de trabajo, los elementos que constituirán el bloque.
  • Dibujar una entidad cerrada alrededor de los elementos de interés. Esta entidad tiene la misma función que una ventana.
  • Llamar a la orden BLOQUE, y se muestra la siguiente ventana:

  • Especificar el nombre del nuevo fichero en este cuadro de diálogo mostrado, y en la parte inferior del mismo existe una lista desplegable:

    • donde se selecciona el modo de corte. Después se pulsa sobre el botón Guardar de la ventana.

  • Seleccionar el punto que será el origen de coordenadas, como se puede leer en la parte inferior izquierda de la pantalla:

  • Digitalizar un segundo punto, que marcará con el punto origen la rotación a efectuar al bloque:

  • Seleccionar la entidad que va actuar de límite, dibujada anteriormente a modo de ventana, como se puede leer en la parte inferior izquierda de la pantalla:

Con esta sucesión de pasos ya estaría formado un bloque para su posterior inserción con las órdenes INS, INS_AA, INSR.

El punto indicado como origen se utilizará como punto de inserción cuando queramos incluir el bloque en un fichero de dibujo. La orden asigna a este punto las coordenadas (X=0, Y=0, Z=0), de forma que todas las entidades sufren una traslación y quedan referidas a este origen en el nuevo fichero.

Órdenes relacionadas: BLOQUE, INS, INS_AA, INSR.

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BORRA_ATR

Esta orden sirve para borrar todos los atributos asociados a una entidad y que se refieren a registros en bases de datos externas. Al ejecutar la orden el programa solicita al usuario que seleccione la entidad para que la que desea borrar los atributos, como se puede observar en la parte inferior izquierda de la pantalla:

También existe la posibilidad de llamar la orden especificando los parámetros de la forma siguiente: BORRA_ATR=[código][tipo]

donde el tipo de código puede ser uno de los siguientes:
  c en caso de ser puntos y lineas,
  l en caso de ser sólo líneas,
  p en caso de ser sólo puntos,
  t en caso de ser sólo textos,
  * en caso de ser líneas, puntos y textos.

Esta orden se autorrepite en el caso de que se encuentre activo el conmutador REPITE.

Órdenes relacionadas: ALTA, ALTA_DUP, BASE_DATOS, CLONAR_ATRIBUTOS, PONER_ATR, QUITAR_ATRIBUTOS.

Fecha de última modificación: lunes, 28 de Octubre de 2002


Orden BORRA_BARRA_SALIDA

Esta orden permite borrar el contenido de la barra de salida.

Páginas relacionadas: Salida.

Fecha de última modificación: viernes, 3 de Septiembre de 2003


Orden BORRA_COD

Sirve para borrar todas aquellas entidades que tengan un código igual al tecleado por el usuario. Esta orden también permite borrar códigos secundarios. Ejecutada la orden aparece la siguiente ventana:

En la que se puede introducir el código a borrar, y se puede seleccionar si se quieren borrar líneas, puntos y textos. También existe la posibilidad de borrar fotos insertadas con la orden INS_FOTO

Borrar entidades por código se puede hacer ejecutando la siguiente línea:

borra_cod=<código> <tipo de entidad>

donde código es el código de las entidades a borrar, y tipo de entidad puede ser:

C | Borra puntos y líneas
T | Borra sólo textos
L | Borra sólo líneas
P | Borra sólo puntos
B | Borra sólo fotos

Un ejemplo puede ser:

BORRA_COD=010127 L

que borra las líneas que tengan el código 010127.

La visualización de las entidades borradas será posible si el interruptor de BORRADOS está activado. Bajo este estado, y llamando a la orden RECUPERA, los elementos volverán a ser accesibles al usuario para recuperarlos, perdiendo la marca de borrados.

La eliminación real de las entidades borradas se produce al ejecutar la orden COMPRIMIR. A partir de ese momento, los registros correspondientes a estas entidades desaparecen del fichero.

Órdenes relacionadas: BORRA_COD_V , BORRA_E , BORRA_LIN1 , BORRA_ULTIMO , BORRA_V , BORRADOS , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BORRA_COD_V

Sirve para borrar todas aquellas entidades que tengan un código igual al tecleado por el usuario y que además estén asociadas a una ventana, es decir, bien el interior de la ventana, bien en solape con ella, o bien que se corten con la ventana misma. Por lo que la primera operación será realizar una entidad cerrada a modo de ventana.

Ejecutada la orden pide en primer lugar solicita seleccionar la línea que hace de borde:

y una seleccionada la línea que actúa de borde emerge la siguiente ventana:

En la que se puede introducir el código a borrar, y se puede seleccionar si se quieren borrar líneas, puntos y textos. Y en la lista superior se puede ver las diferentes opciones en cuanto a la ventana:

La visualización de las entidades borradas será posible si el interruptor de BORRADOS está activado. Bajo este estado, y llamando a la orden RECUPERA , los elementos volverán a ser accesibles al usuario para recuperarlos, perdiendo la marca de borrados.

La eliminación real de las entidades borradas se produce al ejecutar la orden COMPRIMIR . A partir de ese momento, los registros correspondientes a estas entidades desaparecen del fichero.

Órdenes relacionadas: BORRA_COD , BORRA_E , BORRA_LIN1 , BORRA_ULTIMO , BORRA_V , BORRADOS , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BORRA_COD_V

Digi3D

Orden BORRA_E

Borra del dibujo las entidades gráficas y textos que se indiquen. Basta con seleccionar mediante el cursor, los elementos que se desean borrar del fichero.

Ejecutada la orden, el programa espera a que el usuario seleccione una entidad, como se puede ver en la parte inferior izquierda de la pantalla:

Esta orden impide la visualización de estos elementos, insertando una marca de borrado en los registros del fichero. Mientras no se ejecute la acción de comprimir el fichero de dibujo estaremos en disposición de:

  • Activar de nuevo su visualización en pantalla. Para ello se recurre a la orden BORRADOS (esta orden no elimina la marca de borrado en los registros).
  • Recuperar estos elementos mediante la eliminación de la marca de borrado, lo que se hace con la orden RECUPERA.

Si la variable REPITE está activa, esta orden se repetirá hasta que el usuario pulse la tecla Esc.

Órdenes relacionadas: BORRA_COD_V , BORRA_LIN1 , BORRA_ULTIMO , BORRA_V , BORRADOS , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BORRA_LIN1

Sirve para borrar del archivo de trabajo:

  • Todos los elementos que figuren como entidades de tipo lineal en el fichero DIGI.TAB, y que hayan sido registradas con un sólo punto, al igual que una entidad puntual.
  • Cualquier elemento compuesto de varios puntos cuyas coordenadas sean coincidentes. Este tipo de elementos se generan fácilmente en los procesos de restitución, cuando el operador sitiado en un punto, pisa y levanta varias veces el pedal sin cambiar de posición.

Puede establecerse un límite para el borrado, es decir, si se deseasen borrar segmentos de línea (residuos de la edición) de longitud menor que un cierto valor, se llamaría a la orden con dicho valor:

BORRA_LIN1=<magnitud>

  BORRA_LIN1=0.01

Órdenes relacionadas: BORRA_COD_V , BORRA_E, BORRA_LIN1 , BORRA_ULTIMO , BORRA_V , BORRADOS , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BORRA_ULTIMO

Borra la última entidad registrada en el fichero de dibujo. Cada vez que se ejecute la orden desaparecerá la entidad que se encuentre físicamente al final del fichero. Esta orden no pide confirmación para ejecutarse.

Órdenes relacionadas: BORRA_COD_V, BORRA_COD_V , BORRA_E, BORRA_LIN1 , BORRA_V , BORRADOS , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden BORRA_V

Borra del dibujo las entidades gráficas que se encuentran dentro de los límites de una entidad, definida previamente por el usuario. La secuencia de acciones a realizar es:

  1. Dibujar la entidad cuya geometría va a definir los límites de la zona a borrar. Este paso no es necesario, si ya existe una entidad que responda a los criterios anteriores.
  2. Llamar a la orden, con lo que aparece la siguiente ventana:

En esta ventana hay que especificar la modalidad de borrado que se desea, eligiendo una de las tres opciones que la orden ofrece:
  • Interior (0): se borran sólo los elementos que se encuentren totalmente incluidos dentro de los límites de la entidad. En el caso de que además esté marcada la casilla Borrar los elementos externos no se borran las entidades interiores a la ventana, sino las exteriores a la misma, excepto aquellas que tengan puntos dentro de la ventana.
  • Corte (1): se borran todos aquellos elementos que se hallen total o parcialmente en el interior de la entidad, cortándolos si rebasan los límites de ésta. Es decir, no se borran los trozos de los elementos que estén fuera de la entidad. Si además está activada la casilla Borrar los elementos externos se borran los elementos externos, de forma total o parcial.
  • Solape (2): el borde de la entidad actúa como límite de separación, borrándose todo lo que se encuentre total o parcialmente en su interior. Con esta opción se borrarán los elementos que tengan algún punto en el interior de la entidad. Si además está señalada la casilla Borrar los elementos externos se borrarán aquellas entidades exteriores a la ventana que no tengan ningún punto dentro de la misma.
  3. Seleccionar la entidad cerrada que funciona como una ventana.

También existe la posibilidad de ejecutar la orden desde la línea de commandos especificando el código del elemento que actúa como ventana y el tipo de recorte para recortar la ventana. En este caso, si por ejemplo quisieramos que el recorte sea de tipo Solape, escribiríamos:

BORRA_V=<CóDIGO> <2>

No se borrarán los códigos que estén desactivados, lo cual es muy útil, por ejemplo, para borrar las curvas de nivel de dentro de las casas respetando las medianerías. Para ello antes de borrar se desactivaría el código de las medianerías.

órdenes relacionadas: BORRA_COD_V, BORRA_COD_V , BORRA_E, BORRA_LIN1 , BORRA_ULTIMO, BORRADOS , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: viernes, 27 de Septiembre de 2002


Orden BORRA_VERTICE

Se utiliza para eliminar un vértice en una entidad lineal. Al llamar la orden, podremos ver en la parte inferior de la pantalla nos pide seleccionar el vértice a quitar:

Órdenes relacionadas: EDITAR, EDITAR_XYZ, EDITAR_Z, REPITE.

Fecha de última modificación: 29 de enero de 2004


Orden BORRADOS

Se utiliza para activar o desactivar la visualización de aquellas entidades que han sido borradas con posterioridad a la última compresión del fichero. Esta orden no elimina el código de borrado asignado a las entidades. Para ello, se ha de recurrir a la orden RECUPERA.

Cuando esta opción de visualización está activa se indica en la barra de herramientas Flags, con una B.

Órdenes relacionadas: BORRA_COD_V, BORRA_COD_V , BORRA_E, BORRA_LIN1 , BORRA_ULTIMO, BORRA_V , COMPRIMIR , RECUPERA , RECUPERA_COD .

Fecha de última modificación: lunes, 3 de Junio de 2002


Orden BORRAR_GUID

Sirve para eliminar el GUID de una entidad. Al ejecutar la orden aparecerá el siguiente mensaje que nos pide seleccionar la entidad de la cual se desea borrar el GUID.

En el caso de que la entidad seleccionada no tenga asociado un GUID, el programa nos avisa.

Órdenes relacionadas: ON_GUID, OFF_GUID, EXTRAER_GUID, ASIGNAR_GUID, RESTAURAR_FICHERO.

Fecha de última modificación: martes, 29 de Julio de 2003


Orden BUSCAR

Esta orden sirve para especificar criterios de búsqueda para entidades.

Al llamar a la orden, el programa muestra el siguiente cuadro de dialogo:

Este cuadro nos da la oportunidad de refinar la búsqueda especificando cualquiera de los siguientes parámetros:

Código de la entidad a buscar, aquí podremos definir el código o pulsando el botón de la derecha nos aparecería la ventana de la orden BC (busca código):

El resto de los parámetros que podemos encontrar en la ventana BUSCAR, son los siguientes:

Líneas, en caso de hacer una búsqueda de entidades lineales podremos especificar su perímetro y si queremos que sean líneas cerradas.
Puntos
Textos
Imágenes raster
Objetos O.L.E.

Órdenes relacionadas: BUSCAR+, BUSCAR-

Fecha de última modificación: jueves, 25 de Septiembre de 2003


Orden BUSCAR+

Con esta orden se puede pasar de una entidad localizada con el criterio de búsqueda especificado con la orden BUSCAR a la siguiente entidad.

Órdenes relacionadas: BUSCAR-, BUSCAR.

Fecha de última modificación: jueves, 25 de Septiembre de 2003


Orden BUSCAR-

Con esta orden se puede pasar de una entidad localizada con el criterio de búsqueda especificado con la orden BUSCAR a la entidad anterior.

Órdenes relacionadas: BUSCAR+, BUSCAR.

Fecha de última modificación: jueves, 25 de Septiembre de 2003


Órdenes de DigiNG. C

    C
    CAL_ORTO
    CAMB_AT
    CAMB_COD
    CAMB_JT
    CAMB_MAXPUNTOS
    CAMB_MODOB
    CAMB_SEN
    CAMB_SEN_BAJA
    CAMB_SEN_SUBE
    CAMB_TEXTO
    CAMB_Z
    CAMBIA_BRILLO_CONTRASTE
    CAMBIA_BRILLO_CONTRASTE_V
    CAMBIA_COLOR
    CAMBIA_COLOR_V
    CAMBIA_DIGI_TAB
    CAMBIA_FICHEROS
    CAMBIA_TECLAS_MNU
    CARGA_DISPOSICION
    CARGA_DLL
    CARGA_F
    CARGA_MDT
    CARGA_P
    CARGA_PUNTOS_MEDIDOS
    CARGA_RASTER
    CARGA_TOP
    CEBRA
    CEBRA_4P
    CIERRA
    CIERRA_ENT
    CIRCR
    CIR2P
    CIR3P
    CLONAR
    COD
    COD_COTAS
    COD_CURVAS
    COLOR_FONDO
    COLOR_PIXEL
    COLOR_TENTATIVO
    COMPRIMIR
    COPIA2P
    COPIAR
    CORTA_2P
    CORTAR_E
    CORTAR_F
    CORTAR_RASTER
    COTA
    COTAS_CURVAS
    CREAR_DIGI_TAB
    CRUCE
    CUADROS
    CUADROS_4P
    CUENTAGOTAS
    CURSOR
    CURVAR

Fecha de última modificación: 27 de Agosto, 2004


Orden C

Es un conmutador. Si está activado, al finalizar las entidades lineales, éstas se cierran automáticamente, uniéndose el último punto con el primero.

El estado de este conmutador se indica en la Barra de Herramientas Flags, en la que aparecerá C si está activado.

C=1 | Activa el conmutador.
C=0 | Desactiva el conmutador.
C | Cambia el estado del contador.

Órdenes relacionadas: CIERRA , CIERRA_ENT, FIN_ENT.

Fecha de última modificación: 7 de Mayo de 2004


Orden CAL_ORTO

Esta orden sirve para calcular Ortofotografías Digitales mediante DigiNG.

Este proceso requiere la existencia de una imagen raster orientada y un modelo digital del terreno de la zona a rectificar. Por tanto, antes de llamar a la orden, deben haberse realizado los siguientes pasos:

  • Cargar la imagen raster con la orden CARGA_RASTER. La imagen debe tener un fichero .ORI con los parámetros de las Orientaciones Interna y Externa.
  • Se debe tener disponible en memoria un modelo digital del terreno, en formato del programa MDTOP, de la zona que se va a procesar. Para ello bien se utiliza la orden CARGA_MDT, en el caso de que se tenga el MDT, o bien se utiliza las órdenes MDTPC y TRIANGULAR.
  • Debe definirse una entidad cerrada que delimite el área de la imagen que se va a rectificar. Para evitar problemas en la selección posterior de esta entidad se debería registrar con una Z activa próxima a la del terreno. Para ello se debe ejecutar la orden MDT_MUEVE_Z.

Realizadas estos pasos previos, se llama a la orden CAL_ORTO. El sistema solicita entonces, que se seleccione la entidad que delimitará la Ortofotografía Digital:

Una vez seleccionada emerge el siguiente cuadro de diálogo:

donde se definen las características de la Ortofotografía que se va a generar:

  • Tamaño del píxel: donde se define el tamaño del píxel de la Ortofotografía.
  • Tipo de interpolación: se puede elegir entre los siguientes tipos:
    • Vecino más próximo: es la más rápida pues sólo determina cuál es el pixel más proximo. Tiene el inconveniente de que los elementos lineales de la imagen aparecen como líneas quebradas, llamado efecto escalera
    • Bilineal: tarda más tiempo que el método anterior, pero no se nota tanto el efecto escalera. Tiene en cuenta los 4 píxeles más cercanos.
    • Bicúbica:es la interpolación que más tarda pero la que mejores resultados ofrece. Toma para la interpolación los píxeles ás próximos.
  • Archivo a generar: nombre y directorio donde se almacenará la imagen resultante.
  • GeoTIFF, TiffWorld (TFW), ORT, GEO: las casillas marcadas determinarán los ficheros resultantes, además de la imagen y su archivo de Orientaciones asociado de extensión .ORI.

En esta misma ventana se informa del tamaño de la Ortofotografía Digital resultante, tanto en píxeles como en MB. Para generar la Ortofotografía se pulsa sobre el botón Comenzar.

En el caso de que no haya ningún MDT cargado, se muestra el siguiente mensaje:

En el caso de que se ejecute la orden CAL_ORTO y no haya ninguna imagen raster cargada se muestra el siguiente mensaje:

Existe la posibilidad de llamar a la orden indicando todos los datos necesarios desde la línea de órdenes, es decir,

       C:\CAL_ORTO=<tipo interpolación> <nombre orto con extensión> <código entidad límite>

En este caso, la entidad límite debe ser la única entidad en el código dado y debe ser un elemento cerrado. Se deben tener cargados también la imagen original y el MDT, y se debe haber definido la variable DA.

En el caso de que no se especifique como tipo de interpolación uno de los permitidos se muestra el siguiente mensaje:

En el caso de que no se encuentre en el fichero la entidad con el código definido se muestra el siguiente mensaje:

Órdenes relacionadas: CARGA_MDT, CARGA_RASTER, DA, MDTPC, MDT_MUEVE_Z, TRIANGULAR.

Fecha de última modificación: martes, 24 de Septiembre de 2002


Orden CAMB_AA

Esta orden sirve para modificar el ángulo activo de un texto ya escrito. Como es habitual, puede llamarse a la orden de dos maneras:

  1. Teclear CAMB_AA y pulsar [ENTER]. El programa pide al usuario que seleccione un texto y cambia el ángulo activo de ese texto por el valor que tenga asignado la variable AA en el momento de ejecutar la orden.

  2. Teclear CAMB_AA=<código> y pulsar [ENTER]. En este caso, el programa cambia automáticamente el ángulo activo de todos los textos cuyo código se corresponda con el indicado en la llamada a la orden. El valor del nuevo ángulo activo se toma del que tuviera asignado la variable AA en el momento de ejecutar la orden.

CAMB_AA es una alternativa a la orden R_TEXTO.

Órdenes relacionadas: AA , R_TEXTO .

Fecha de última modificación: 24 de Febrero de 2004


Orden CAMB_AT

Se utiliza para modificar la altura de uno o varios textos del dibujo. Antes de ejecutar la orden se debe asignar la nueva altura de texto con la orden AT.

La llamada a la orden tiene dos modalidades:

  1. Teclear CAMB_AT y pulsar Enter. El programa pide al usuario que seleccione un texto, como se puede ver en la parte inferior izquierda de la pantalla:

    2. y cambia la altura del mismo por el valor que tenga asignado la variable AT en el momento de ejecutar la orden.

  1. Teclear CAMB_AT=<código> y pulsar Enter. En este caso, el programa cambia automáticamente la altura de todos los textos cuyo código se corresponda con el indicado en la llamada a la orden. El valor de la nueva altura se toma de la que tuviera asignada la variable AT en el momento de ejecutar la orden. Un ejemplo de esta forma de ejecutar la orden puede ser:
    2.         AT=2
        CAMB_AT=010325
    que cambia la altura de texto de la actual a 2, a los textos cuyo código sea 010325.

Órdenes relacionadas: AT.

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CAMB_COD

Sirve para cambiar el código asignado a un elemento gráfico. El usuario tiene que seleccionar la entidad cuyo código será sustituido por el que se encuentre activo en el momento de llamar a la orden. Esta orden admite los comodines '*' y '?'. Antes de ejecutar la orden hay que establecer como código activo el nuevo código con la orden COD.

Se teclea la orden y el programa pide que se seleccione el elemento a cambiar el código, como se puede ver en la parte inferior izquierda de la pantalla:

Supóngase que se tienen los siguientes códigos:

Edificación=160301
Valla=160303
Alambrada=160304

Si se quisieran convertir los códigos de edificio en límite de manzana (140101), valla en límite de manzana (140103) o alambrada en límite de manzana (140104), se establecería como código activo el 1401* con COD=1401*. Al seleccionar el edificio ocurriría lo siguiente:

160301 código de edificio
1401* código activo
CAMB_COD
140101 nuevo código para la entidad 'edificio en límite de manzana'.

y seleccionar

Y en la valla:

160303 código de valla
1401* código activo
CAMB_COD
140103 nuevo código para la entidad 'valla en límite de manzana'.

Esta orden se autorrepite si está activo el conmutador REPITE.

Órdenes relacionadas: COD, REPITE.

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CAMB_JT2

Se utiliza para modificar la justificación de uno o varios textos existentes en el dibujo pero sin modificar su posición. Antes de ejecutar esta orden hay que establecer la justificación de texto a la deseada, con la orden JT.

La llamada a la orden tiene dos modalidades:

  1. Teclear CAMB_JT2 y pulsar Enter. El programa pide al usuario que seleccione un texto y cambia la justificación del mismo por el valor que tenga asignado la variable JT en el momento de ejecutar la orden.

  2. Teclear CAMB_JT2=<código> y pulsar Enter. En este caso, el programa cambia automáticamente la justificación de todos los textos cuyo código se corresponda con el indicado en la llamada a la orden. El valor de la nueva justificación se toma del que tuviera asignado la variable JT en el momento de ejecutar la orden. Un ejemplo de esta forma de ejecutar la orden puede ser:
    3.         JT=8
        CAMB_JT2=020402
    en la que en primer lugar se establece la justificación del texto a 8 con la orden JT , y después se cambia la justificación de los textos del archivo que tengan por código 020402.

Órdenes relacionadas: JT, CAMB_JT.

Fecha de última modificación: martes, 7 de Octubre de 2003


Orden CAMB_JT

Se utiliza para modificar la justificación de uno o varios textos existentes en el dibujo. Antes de ejecutar esta orden hay que cambiar la justificación de texto a la deseada, con la orden JT.

La llamada a la orden tiene dos modalidades:

  1. Teclear CAMB_JT y pulsar Enter. El programa pide al usuario que seleccione un texto y cambia la justificación del mismo por el valor que tenga asignado la variable JT en el momento de ejecutar la orden.

  2. Teclear CAMB_JT=<código> y pulsar Enter. En este caso, el programa cambia automáticamente la justificación de todos los textos cuyo código se corresponda con el indicado en la llamada a la orden. El valor de la nueva justificación se toma del que tuviera asignado la variable JT en el momento de ejecutar la orden. Un ejemplo de esta forma de ejecutar la orden puede ser:
    3.         JT=8
        CAMB_JT=020402
    en la que en primer lugar se establece la justificación del texto a 8 con la orden JT , y después se cambia la justificación de los textos del archivo que tengan por código 020402.

Órdenes relacionadas: JT.

Fecha de última modificación: lunes, 4 de Julio de 2003


Orden CAMB_MAXPUNTOS

Esta orden permite cambiar el número máximo de puntos para entidades lineal a seleccionar por el valor actual de MAXPUNTOS. Este número máximo se define mediante la orden MAXPUNTOS, y debe ser predefinido antes de la ejecución de la orden CAMB_MAXPUNTOS. Una vez ejecutado solicita que se seleccione la entidad a la que se desea cambiar el número de puntos, como se puede ver en la parte inferior izquierda de la pantalla:

y se selecciona la entidad a la que s desea cambiar su número de puntos por MAXPUNTOS actual.

Esta orden se autorrepetirá en caso de que está activado el conmutador REPITE.

Órdenes relacionadas: MAXPUNTOS, REPITE.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CAMB_MODOB

Sirve para establecer el modo de búsqueda o enganche gráfico a elementos del dibujo. El ámbito de búsqueda de una entidad está determinado por el tamaño del cursor y el factor de zoom de pantalla.

La ejecución de esta orden solamente permite pasar de un modo de búsqueda al siguiente, si lo que desea es especificar un modo de búsqueda debe emplear la función MODOB.

Órdenes relacionadas: MODOB.

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CAMB_SEN

Sirve para modificar el sentido en que está digitalizado un elemento gráfico. En la llamada a la orden existen dos posibilidades y el comportamiento es diferente según el tipo de llamada:

  1. Teclear CAMB_SEN seguido de Enter. El sistema pide al usuario que seleccione la entidad, y el programa automáticamente cambia el orden en que estaban grabados sus vértices al inverso del actual.

  2. Teclear CAMB_SEN=<código> seguido de Enter. En este caso todas las entidades del fichero dibujadas con el código indicado, y con independencia del sentido en que se hayan registrado sus puntos, se ordenan en el sentido de las agujas del reloj.

Órdenes relacionadas: AREA.

Fecha de última modificación: 24 de Junio de 2004


Orden CAMB_SEN_BAJA

Sirve para modificar el sentido en que se han registrado los puntos después de haber digitalizado un elemento gráfico, como por ejemplo pueda pueda ser un río. En la llamada a la orden existen dos posibilidades y el comportamiento es diferente según el tipo de llamada:

  1. Teclear CAMB_SEN_BAJA seguido de Enter. El sistema pide al usuario que seleccione la entidad, y el programa automáticamente cambia el orden en que estaban grabados sus vértices al inverso del actual.

  2. Teclear CAMB_SEN_BAJA=<código> seguido de Enter. En este caso todas las entidades del fichero dibujadas con el código indicado, y con independencia del sentido en que se hayan registrado sus puntos, se ordenan en el sentido de las agujas del reloj.

Órdenes relacionadas: AREA, CAMB_SEN, CAMB_SEN_SUBE.

Fecha de última modificación: lunes, 28 de Julio 2003


Orden CAMB_SEN_SUBE

Sirve para modificar el sentido en que se han registrado los puntos después de haber digitalizado un elemento gráfico, como pueda ser por ejemplo un río. En la llamada a la orden existen dos posibilidades y el comportamiento es diferente según el tipo de llamada:

  1. Teclear CAMB_SEN seguido de Enter. El sistema pide al usuario que seleccione la entidad, y el programa automáticamente cambia el orden en que estaban grabados sus vértices al inverso del actual.

  2. Teclear CAMB_SEN_SUBE=<código> seguido de Enter. En este caso todas las entidades del fichero dibujadas con el código indicado, y con independencia del sentido en que se hayan registrado sus puntos, se ordenan en el sentido de las agujas del reloj.

Órdenes relacionadas: AREA, CAMB_SEN, CAMB_SEN_BAJA.

Fecha de última modificación: lunes, 28 de Julio de 2003


Orden CAMB_TEXTO

Se utiliza para sustituir todos los textos iguales a uno dado por otro que ha de ser especificado por el usuario.

La orden puede ejecutarse de dos formas:

  • Ejecutando CAMB_TEXTO, con lo que aparece la siguiente ventana:

    • donde se puede escribir el texto a buscar, el texto a reemplazar, si se desea que la búsqueda se haga teniendo en cuenta mayúsculas y minúsculas, o teniendo en cuenta sólo palabras completas.
  • Ejecutando la línea CAMB_TEXTO=<texto anterior> <texto nuevo>, con lo que se efectúa el cambio de todos los textos que coincidan con <texto anterior> por <texto nuevo>. Un ejemplo de esta forma de ejecutar la orden puede ser:
    •   CAMB_TEXTO=parcela terreno
    por lo que hace este ejemplo es buscar en el archivo los textos parcela y los reemplaza por terreno.

    Fecha de última modificación: martes, 4 de Junio de 2002


Orden CAMB_Z

Se utiliza para sustituir la altitud asignada a un elemento gráfico, por un nuevo valor. Ejecutada la orden aparece la siguiente ventana:

donde se introduce la nueva cota. Se pulsa sobre el botón Aceptar, y a continuación el programa pide que se seleccione la entidad a la cual se le va a cambiar la cota.

Una vez ejecutada la orden, todos los puntos que forman la entidad se ponen a la cota (Z) especificada.

Esta orden se autorrepite, independientemente de si está activado o no el conmutador REPITE.

Órdenes relacionadas: REPITE.

Fecha de última modificación: lunes, 3 de Junio de 2002


Orden CAMBIA_BRILLO_CONTRASTE

Esta orden sirve para cambiar el brillo y/o el contraste de las imágenes cargadas en DigiNG mediante la orden CARGA_RASTER. Al ejecutar la orden aparece la siguiente ventana:

donde se puede seleccionar una imagen, varias imágenes, o todas la imágenes pulsando sobre el botón Todos. Después de pulsar sobre el botón Aceptar aparece la siguiente ventana:

donde se puede cambiar tanto el brillo como el contraste de la imagen seleccionada, bien moviendo hacia la derecha o hacia la izquierda los correspondientes indicadores, o bien tecleando valores en los campos de texto. En el campo de texto situado en la parte superior derecha de la ventana se puede teclear cuánto se desea cambiar el brillo de la imagen, en el intervalo (-100, 100). En el campo de texto situado debajo se puede teclear cuánto se desea cambiar el contraste de la imagen (de -100 a 100).

Si se marca la casilla Previsualizar (situada en la esquina inferior izquierda de la pantalla), se puede visualizar de forma interactiva el cambio en el brillo y/o en el contraste de la imagen (o de las imágenes en el caso de que haya varias imágenes abiertas).

Cuando la imagen tenga el brillo y contrastes deseados, se pulsa sobre el botón Aceptar.

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: lunes, 29 de Julio de 2002


Orden CAMBIA_BRILLO_CONTRASTE_V

Esta orden sirve para cambiar el brillo y/o el contraste de parte de las imágenes cargadas en DigiNG mediante la orden CARGA_RASTER. Para ello se debe digitalizar una entidad cerrada a modo de ventana, previamente a la ejecución de esta orden.

Al ejecutar la orden se pide al usuario que seleccione la entidad que sirve de ventana:

y una vez seleccionada la entidad que hace de límite, aparece la siguiente ventana:

donde se puede cambiar tanto el brillo como el contraste de la zona de la imagen seleccionada, bien moviendo hacia la derecha o hacia la izquierda los correspondientes indicadores, o bien tecleando valores en los campos de texto. En el campo de texto situado en la parte superior derecha de la ventana se puede teclear cuánto se desea cambiar el brillo de la imagen, en el intervalo (-100, 100). En el campo de texto situado debajo se puede teclear cuánto se desea cambiar el contraste de la imagen (de -100 a 100).

Si se marca la casilla Previsualizar (situada en la esquina inferior izquierda de la pantalla), se puede visualizar de forma interactiva el cambio en el brillo y/o en el contraste de zona de la imagen (o de las imágenes en el caso de que haya varias imágenes abiertas).

Cuando la zona de la imagen tenga el brillo y contraste deseados deseados, se pulsa sobre el botón Aceptar.

En el caso de se seleccione una línea que no solape con ninguna imagen raster se muestra el siguiente mensaje:

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 23 de Agosto de 2002


Orden CAMBIA_COLOR

Esta orden se utiliza para cambiar un determinado color por otro en las imágenes raster cargadas en DigiNG. Se recomienda seleccionar el color a cambiar previamente mediante la orden CUENTAGOTAS antes de efectuar la llamada a la orden.

Al ejecutar la orden aparece la siguiente ventana:

donde se pueden seleccionar las imágenes a las que se desea cambiar un determinado color. Una vez seleccionadas, se muestra un primer cuadro de diálogo para definir el color a cambiar. El color seleccionado por defecto en este cuadro de diálogo corresponde con el color seleccionado con la orden CUENTAGOTASo definido con la orden COLOR_PIXEL. Si este es color que desea cambiar solamente debe pulsar sobre el botón Aceptar.

Una vez seleccionado el color a cambiar, se muestra otra vez el mismo cuadro de diálogo para seleccionar el color por el que se cambia.

El cuadro de diálogo puede variar, dependiendo de si las imágenes seleccionadas son de color verdadero o son de niveles de gris. En el primer caso, el cuadro mostrado será:

y en el caso de imágenes en niveles de gris el siguiente:

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: BILINEAL, CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CAMBIA_COLOR_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 23 de Agosto de 2002


Orden CAMBIA_COLOR_V

Esta orden sirve para cambiar un color determinado por otro en una zona de imágenes raster cargadas en DigiNG. Previamente a la llamada a la orden se debe dibujar un entidad cerrada a modo de límite. También se recomienda seleccionar el color a cambiar previamente mediante la orden CUENTAGOTAS.

Al ejecutar la orden se pide al usuario que seleccione la entidad cerrada:

Una vez seleccionada, se muestra un primer cuadro de diálogo para definir el color a cambiar. El color seleccionado por defecto en este cuadro de diálogo corresponde con el color seleccionado con la orden CUENTAGOTASo definido con la orden COLOR_PIXEL. Si este es color que desea cambiar solamente debe pulsar sobre el botón Aceptar.

Una vez seleccionado el color a cambiar, se muestra otra vez el mismo cuadro de diálogo para seleccionar el color por el que se cambia.

El cuadro de diálogo puede variar, dependiendo de si las imágenes seleccionadas son de color verdadero o son de niveles de gris. En el primer caso, el cuadro mostrado será:

y en el caso de imágenes en niveles de gris el siguiente:

En el caso de que la línea seleccionada no solape con ninguna imagen se muestra el siguiente mensaje:

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: BILINEAL, CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CAMBIA_COLOR, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 23 de Agosto de 2002


Orden CAMBIA_DIGI_TAB

Al ejecutar esta orden se cambia el fichero de definición de códigos actual por el siguiente fichero. Estos ficheros se definen en Configuración de Tablas.

Si desea conocer el formato de archivo .TAB lea el tema de la ayuda Formato del archivo .TAB.

Para observar el cambio de definición de códigos se debe refrescar la visualización del fichero de dibujo actual, ejecutando la orden REGENERA.

Órdenes relacionadas: REGENERA.

Fecha de última modificación: lunes, 7 de Octubre de 2002


Orden CAMBIA_FICHEROS

Con esta orden tenemos la posibilidad de cambiar el fichero de dibujo activo por el fichero de dibujo que tengamos de referencia, intercambiándose. Si tenemos más de un fichero enganchado se intercambiará con el primer fichero que se cargó de referencia, ocupando el actual fichero de dibujo la posición del que estaba de referencia.

Órdenes relacionadas: CARGA_F, DEJAR, FICHERO_DIBUJO.

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CAMBIA_TECLAS_MNU

Esta orden permite cambiar de fichero de teclas, cada vez que se ejecute esta orden establece como activo el siguiente archivo de teclas definido en la configuración de Tablas de Digi3D.

La orden TECLA permite asignar órdenes a teclas

El teclado activo se muestra en la barra de herramientas TeclasMnu.

Órdenes relacionadas: TECLA.

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CARGA_DISPOSICION

Permite cargar la disposición de vistas que se ha creado y guardado con anterioridad.

Por ejemplo, si hemos trabajado en un proyecto en el cual hemos abierto una o varias vistas nuevas con la orden NUEVA_VENTANA y hemos guardado esta determinada disposición de vistas con la orden GUARDA_DISPOSICION. Ahora seremos capaces de recuperar esta disposición en cualquier otro momento, ya que DigiNG ha creado un archivo de extensión .XML con la información necesaria.

Al ejecutar la orden tendremos que especificar el nombre de la disposición que queremos recuperar, por ello tendremos que introducir la orden en la linea de órdenes de la siguiente forma: CARGA_DISPOSICION= disposicion1

Órdenes relacionadas: NUEVA_VENTANA, GUARDA_DISPOSICION.

Fecha de última modificación: viernes, 10 de Octubre de 2003


Orden CARGA_DLL

Esta orden se utiliza cuando se necesita trabajar con librerías .dll Estos son ficheros en los cuales están programadas órdenes personalizadas en lenguaje de programación C. Para ejecutar esta orden existen dos posibilidades:

  1. Escribir CARGA_DLL y pulsar la tecla Enter. Entonces aparece la ventana

    donde el sistema pide al usuario que seleccione la librería DLL que quiere cargar. Una vez cardada la DLL, se podrá ejecutar desde dentro de Digi3D, la orden que deseemos mediante la orden DLL.

  2. Escribir directamente en la linea de órdenes: CARGA_DLL= directorio y nombre de la DLL que deseas cargar y pulsar Enter. En el ejemplo anterior tendríamos que haber escrito lo siguiente: CARGA_DLL=C:\Correo\MiPluggin1.html. Una vez cargado el archivo podremos hacer uso de las órdenes personalizadas ejecutando la orden DLL.

    En el momento que deseemos descargar el archivo de órdenes DLL tendremos que ejecutar la orden DESCARGA_DLL.

    Órdenes relacionadas: DLL, DESCARGA_DLL.

    Fecha de última modificación: 31 de Mayo de 2004


Orden CARGA_F

Sirve para visualizar por pantalla, junto al fichero actual de dibujo, uno o varios ficheros gráficos de referencia. La orden presenta un cuadro de diálogo:

para el usuario seleccione el fichero de DigiNG que se desea cargar. En la lista desplegable Tipos de archivos, situada en la parte inferior de la ventana, se puede seleccionar entre los siguientes tipos de archivo:

Los ficheros de referencia se usan en modo lectura, pudiéndose ejecutar sobre ellos cualquier operación de este tipo (listado de elementos, enganches gráficos,...). No es posible dibujar nuevas entidades o hacer modificaciones sobre las entidades que pertenecen a estos ficheros, para ello debe ejecutarse la orden CAMBIA_FICHEROS para pasar el archivo de referencia a fichero actual de dibujo.

Órdenes relacionadas: CAMBIA_FICHEROS, DEJAR.

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CARGA_MDT

Con esta orden se puede cargar un Modelo Digital del Terreno (MDT) generado bien con MDTop o bien con la orden TRIANGULAR. Al ejecutar esta orden se muestra en pantalla el siguiente cuadro de diálogo:

donde se puede seleccionar el archivo de MDT que se desee cargar.

Órdenes relacionadas: DEJAR_MDT, TRIANGULAR.

Fecha de última modificación: lunes, 3 de Junio de 2002


Orden CARGA_P

Sirve para leer el contenido de un fichero ASCII de coordenadas, incorporando al archivo de trabajo un punto por cada conjunto de coordenadas (X Y Z) leídas. Cada línea del fichero de texto deberá tener tres o cuatro valores separados por comas o espacios en blanco.

Número de punto | Es un número entero que sirve para identificar de forma unívoca cada uno de los puntos del fichero. Es el número de punto.
Coordenada X | Es un número real que representa la coordenada X.
Coordenada Y | Es un número real que representa la coordenada Y.
Coordenada Z | Es opcional, y si se utiliza, es un número real que representa el valor de la coordenada Z.

La llamada a la orden se puede realizar de dos formas:

  1. Escribir CARGA_P y pulsar la tecla Enter. En este caso el programa presenta un cuadro de diálogo

    2. para seleccionar el directorio y el fichero que se desee. Por defecto se esperan ficheros con extensión XYZ, pero seleccionando en la lista Archivos de tipo, la opción Todos los archivos, se pueden seleccionar ficheros con cualquier extensión. Una vez ejecutada la orden, el sistema añade al fichero de trabajo un punto y dos textos por cada una de las líneas leídas, por ello existen los campos Código del punto, Código del texto de número de punto, Código del rótulo de Z del punto, que se corresponden con el punto que se va a dibujar y las dos líneas que se van a escribir en el archivo de dibujo.

  2. Escribir CARGA_P=<nombre fichero con extensión> y pulsar Enter.

Una vez ejecutada la orden, el sistema añade al fichero de trabajo un punto y dos textos por cada una de las líneas leídas. Los puntos se representarán con el código activo en ese momento, que deberá ser un código de entidad puntual. Si no hay ningún código activo o el código pertenece a una entidad lineal, sólo se rotulan los textos antes citados. Con respecto a estos, uno de ellos se utilizará para indicar el número del punto, y se representa con el código "PUNTOS" visualizándose arriba y a la derecha del punto dibujado; el otro, se usa para expresar el valor de la cota en el código "COTAS", y se visualizará abajo y a la derecha del punto.

El ángulo, la altura y la inclinación de estos textos serán las que indiquen los valores que tengan, en el momento de llamar a la orden, las variables del sistema AA, AT, IT, respectivamente.

Si el usuario quiere cambiar los códigos utilizados para representar el número y la cota de cada punto, no tiene más que poner activo el código deseado y utilizar la orden RENOMCOD.

Si lo que se pretende es borrar alguno de estos tipos de texto, entonces se ha de utilizar la orden BORRA_COD en la forma BORRA_COD=<código> <tipo de entidad>, por ejemplo, para borrar los textos (tipo de entidad = T) incluidos como código PUNTOS se puede ejecutar la siguiente línea:

BORRA_COD=PUNTOS T

La orden CARGA_P establece como dispositivo de entrada de datos un determinado fichero. Suele utilizarse para cargar de forma automática una nube de puntos (puntos de relleno, puntos de apoyo, etc...).

Órdenes relacionadas: BORRA_COD, FICHERO_P, RENOMCOD .

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CARGA_PUNTOS_MEDIDOS

Fecha de última modificación: martes, 4 de Junio de 2002


Orden CARGA_RASTER

Con esta orden se carga una imagen en DigiNG (no en Digi3D). Para cargar una imagen debe existir en el mismo fichero donde esté la imagen alguno de los siguientes archivos asociado a la imagen:

  • Archivo ORI con las Orientaciones Interna y Externa de la imagen.
  • Fichero con la extensión ORT.
  • Archivo con la extensión TFW.

En el caso que la imagen esté en formato GeoTIFF no hace falta ninguno de estos archivos, pues se toma la información de la cabecera del archivo GeoTIFF, donde está la información geográfica.

En concreto, DigiNG busca información para georreferenciar la imagen en el siguiente orden:

  • Si la imagen a cargar está en formato GeoTIFF, carga la información geográfica almacenada en este tipo de archivo.
  • Si no es GeoTIFF, busca el archivo con extensión ORT.
  • Si no encuentra el archivo ORT, busca el archivo TFW.
  • Si no encuentra el archivo TFW, busca el archivo ORI.

Si el archivo asociado es .ORI, sólo será posible cargar en DigiNG imágenes que tengan asociados archivos .ORI con parámetros de Orientación Externa.

En el caso de que la imagen a cargar no tenga ficheros asociados a ella que posibiliten su georreferenciación, o bien no se trate de una imagen GeoTIFF, se muestra el siguiente mensaje en pantalla:

y no se carga la imagen.

Al ejecutar la orden aparece la siguiente ventana:

que se trata de un cuadro de diálogo común de Windows, donde se puede elegir una o varias imágenes a cargar. En la parte inferior de este cuadro se encuentra una casilla, Utilizar un color transparente, que si se activa permite definir un color de transparencia. Este número indica el nivel de gris en el caso de imágenes en blanco y negro. En el caso de imágenes en color el valor indicado se entenderá igual para los tres colores: Rojo, Verde y Azul.

Si se han creado dos vistas del fichero de dibujo (en el menú principal de DigiNG, seleccionando Nueva Ventana dentro de Ventana) se puede cargar una imagen por vista.

Se pueden cargar varias imágenes en un mismo fichero de dibujo. En el caso de que las imágenes se solapen entre ellas, se mostrarán por orden de carga. Así, la imagen cargada en primer lugar se verá tapada en zonas comunes por una imagen cargada en segundo lugar. Esta prioridad de visualización se puede alterar con la orden TRAER_AL_FRENTE.

En ocasiones, debido al solape y a la prioridad de una segunda imagen cargada sobre la primera en zonas comunes, interesa alterar dicha prioridad. Para ello puede utilizarse la orden COLOR_PIXEL para definir como color de píxel el blanco, y después ejecutar la orden CURSOR para definir un tamaño de píxel que interese, y por último, llamar a la orden PINTA_PIXEL para pintar de color blanco (en el caso de que se indique como transparente el color 255) sobre la segunda imagen. Así, y debido al efecto de transparencia, es posible hacer prevalecer en zonas comunes la primera imagen cargada sobre la segunda.

Para ello, hay que tener en cuenta que en el cuadro de diálogo de la orden CARGA_RASTER se define el color que se considera transparente.

Se establece por defecto el color blanco como transparente, por lo que en zonas de solape entre imágenes, no se visualiza este color, lo que ayuda a la formación de mosaicos.

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTERS_POR_VENTANA, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: lunes, 14 de Octubre de 2002


Orden CARGA_TOP

Sirve para cargar uno o más ficheros de topologías.

La llamada a la orden se puede realizar de la siguiente forma:

 Si escribimos  LOAD_TOP= [archivo] [0] el archivo se carga como invisible.
 Si escribimos  LOAD_TOP= [archivo] [1] el archivo se carga con apariencia visible y con los colores 0, 0, 255.
 Si escribimos  LOAD_TOP= [archivo] [0/1] [r g b] el archivo se carga con apariencia invisible(0) o visible(1) y
 con el color definido por la terna Rojo, Verde y Azul

Órdenes relacionadas: BINTOP, DEJAR_TOP, VER_TOPOLOGIAS.

Fecha de última modificación: viernes, 17 de Octubre de 2003


Orden CEBRA

Esta orden facilita el dibujo de pasos de cebra, introduciendo sólo el número de las franjas blancas y 3 puntos que definan la forma y posición de los pasos de cebra.

Al ejecutar la orden el programa pide el número de franjas blancas (debe ser 1 o superior) mediante el siguiente cuadro de diálogo:

e introducido dicho número, se pulsa sobre el botón Aceptar, y el programa solicita que se digitalice el primer punto, como se puede ver en la parte inferior izquierda de la pantalla:

digitalizado el primer punto, el programa solicita el segundo punto:

y por último, un tercer punto, con el que se puede observar cómo se dibujará el paso de cebra:

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CEBRA_4P

Esta orden facilita el dibujo de pasos de cebra, introduciendo sólo el número de las franjas blancas y 4 puntos que definan la forma y posición de los pasos de cebra.

Al ejecutar la orden el programa pide el número de franjas blancas (debe ser 1 o superior) mediante el siguiente cuadro de diálogo:

e introducido dicho número, se pulsa sobre el botón Aceptar, y el programa solicita que se digitalice el primer punto, como se puede ver en la parte inferior izquierda de la pantalla:

digitalizado el primer punto, el programa solicita el segundo punto, y después un tercer punto:

y por último, un cuarto punto, con el que se puede observar cómo se dibujará el paso de cebra:

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CIERRA

Se utiliza para cerrar una entidad ya existente en el fichero de dibujo. La orden pide que el usuario seleccione esta entidad, como se puede ver en la parte inferior izquierda de la pantalla:

El programa hace una copia de las coordenadas originales del elemento, y añade a continuación de ellas (en el fichero de trabajo) las coordenadas del primer punto.

El resultado producido es un nuevo segmento que une este primer punto con el último de la entidad dibujada.

En el caso de que el conmutador REPITE esté activado, esta orden se autorrepite hasta que el usuario pulse la tecla Esc.

Órdenes relacionadas: C, CIERRA_ENT, FIN_ENT, REPITE.

Fecha de última modificación: miércoles, 11 de Diciembre de 2002


Orden CIERRA_ENT

Se utiliza para cerrar una entidad que se esté dibujando. La función genera un nuevo segmento de enlace entre el primer y el último punto de esta entidad. Al igual que en la orden CIERRA, en el fichero de dibujo se añaden las coordenadas del primer punto.

Órdenes relacionadas: C, CIERRA, FIN_ENT.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CIR2P

Dibuja un circunferencia mediante el centro y un punto de la misma. Ejecutada la orden, el usuario ha de indicar un primer punto en el centro, como se puede ver que pide en la parte inferior de la pantalla:

y un segundo en la circunferencia:

Esta orden se autorrepite si el conmutador REPITE está activo.

Órdenes relacionadas: CIR3P, REPITE.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CIR3P

Dibuja un círculo a partir de tres puntos dados por el usuario. El círculo se construye de tal forma, que el triángulo definido por esos tres puntos queda inscrito en su interior. Ejecutada la orden, el programa solicita el primer punto de la circunferencia, como se puede ver en la parte inferior izquierda de la pantalla:

después solicita el segundo punto:

y el último:

Esta orden se autorrepite si el conmutador REPITE está activo.

Órdenes relacionadas: CIR2P, REPITE.

Fecha de última modificación: lunes, 3 de Junio de 2002


Orden CIRCR

Esta orden sirve para dibujar círculos especificando el centro y su radio. Al ejecutar la orden, el programa mostrará el siguiente mensaje:

una vez digitalizado el centro del círculo, el programa solicitará introducir el correspondiente radio:

Después de aceptar el radio, se mostrará el círculo en pantalla. El círculo se dibujará con el código activo en ese momento.

Órdenes relacionadas: CIR3P, CIR2P.

Fecha de última modificación: viernes, 3 de Octubre 2003


Orden CLONAR

Sirve para establecer como código activo el de la entidad que seleccione el usuario. Ejecutada la orden, el programa pide que se seleccione una entidad, como se puede ver en la parte inferior izquierda de la pantalla:

se selecciona una entidad y se carga como código activo el de dicha entidad. Si el elemento es un texto, además del código se establecerán el ángulo activo, la altura y la inclinación del texto.

Esta orden también clona los atributos en caso de que la entidad tenga asociado algún atributo.

Fecha de última modificación: mi&eeacute;rcoles, 5 de Junio de 2002


Orden CLONAR_ATRIBUTOS

Se utiliza para copiar en memoria los atributos asociados a una entidad, para después asignar dichos atributos bien a otra entidad que se digitalice, o bien a varias entidades mediante la orden PONER_ATR.

Órdenes relacionadas: ALTA, ALTA_DUP, BASE_DATOS, BORRA_ATR, PONER_ATR, QUITAR_ATRIBUTOS.

Fecha de última modificación: lunes, 28 de Octubre de 2002


Orden COD

Sirve para establecer el código con que se van a dibujar las entidades. Esta orden requiere como entrada, el valor correspondiente al código que se va a utilizar. Un código puede tener un máximo de 6 caracteres.

No se puede dibujar ningún elemento si no hay un código activo. Si se cambia de código mientras se está dibujando una entidad, el programa termina en ese momento la entidad que se estaba dibujando con el código anterior y empieza automáticamente una nueva cuyo primer punto es el último de la entidad terminada

La llamada a la orden admite dos posibilidades:

  1. Teclear COD y pulsar la tecla Enter. El programa pedirá que se introduzca un código mediante el siguiente cuadro de diálogo:

  2. Teclear COD=<código> y pulsar la tecla Enter. Un ejemplo de esta forma de ejecutar la orden puede ser:
    3. COD=010127
    con lo que el código activa pasa a ser el 010127.

Órdenes relacionadas: COD_COTAS, COD_CURVAS

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden COD_COTAS

Permite activar como código de cotas el que se especifique en esta orden. De esta manera, cuando se ponga un punto con este código, se registrará el punto y un texto con su cota. Cada vez que se inicia el programa el código de cotas por defecto el 020400. Si se quiere poner cotas con otro código será preciso activarlo con esta orden, o bien definirlo en el archivo de órdenes de inicio.

Esta orden se puede llamar de tres formas:

  • Teclear COD_COTAS y pulsar la tecla Enter. Entonces se muestra la siguiente ventana:

    • donde se escribe un código, para que cuando este codigo esté activo se registre una cota, y dibuje un punto y un texto con la cota. Si dicho código está asociado a una entidad lineal, pasa a ser puntual mientras sea el código activo para COD_COTAS. Cuando se desvincule dicho código a COD_COTAS, el código volverá al estado original. El código del punto y del texto de la cota son el mismo, a excepción de que se defina un código diferente para el texto de la cota en este cuadro de diálogo.

  • Teclear COD_COTAS=<código texto cota>. Con esta forma de ejecutar la orden, por ejemplo,
    •     COD_COTAS=000124
    COTA

    cuando se ejecute la orden COTA, el código del texto de la cota será 000124.

  • Teclear COD_COTAS=<código activo cotas><código texto cota>. Con esta forma de ejecutar la orden, por ejemplo,
    •     COD_COTAS=000125 000124

    lo que se consigue es que cuando el código activo sea 000125, se registren cotas, y se introduzcan en el fichero de dibujo un punto y un texto, siendo el primer valor el código del punto (000125), y el segundo valor el código del texto de la cota (000124).

La orden para registrar cotas con el código actual es COTA.

Órdenes relacionadas: COD, COD_CURVAS, COTA.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden COD_CURVAS

Esta orden sirve para definir el código de las curvas directora y finas, al mismo tiempo que un código, que cuando se activa, permite al operador registrar curvas de nivel sin preocuparse de si la línea que está registrando es una curva de nivel directora o fina.

Existen dos formas para llamar a la orden:

  • Teclear COD_CURVAS y pulsar la tecla Enter. Entonces aparece la siguiente ventana:

    • donde se define el código para activar el registro de curvas de nivel sin necesidad de cambiar de código para curva de nivel maestra o fina. Permite definir los códigos tanto de las curvas maestras como de las finas.

  • Teclear COD_CURVAS=<código activar> <código directora> <código finas> y pulsar la tecla Enter. Por ejemplo, si se quiere que al activar el código 010127 se digitalicen curvas de nivel, y que además el código correspondientes a las curvas directoras y finas sea 020400 y 020200 respectivamente, se tecleará la siguiente línea:
  • COD_CURVAS=010127 020400 020200

Esta orden supone que entre cada dos curvas de nivel directoras se dibujan 4 finas, como es norma general en cartografía.

Esta orden puede escribirse en el archivo de órdenes de inicio (que se define en el cuadro de diálogo Nuevo Proyecto Digi), para que cuando se inicia DigiNG ya estén configurados estos códigos.

Órdenes relacionadas: COD, COD_COTAS, EQUIDISTANCIA.

Fecha de última modificación: viernes, 14 de Junio de 2002


Orden COLOR_FONDO

Sirve para visualizar como fondo de pantalla el color especificado por el usuario. La llamada a la orden se realiza escribiendo:

COLOR_FONDO=<número>

La relación entre un determinado número y el color que le corresponde se determina en el archivo DIGI.PAL. En este fichero de texto se especifican las componentes RGB del color que se quiere asignar a un determinado número. Si no existe ningún fichero DIGI.PAL se utilizan unos valores por defecto. Por ejemplo, si queremos utilizar de fondo el color número 3 se ejecuta la siguiente línea:

COLOR_FONDO=3

Si escribimos:

COLOR_FONDO=?

el programa nos informa del número de color de fondo actual de la pantalla.

Órdenes relacionadas: COLOR_TENTATIVO.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden COLOR_PIXEL

Esta orden sirve para establecer el color de píxel, para luego utilizarlo para pintar píxeles con la orden PINTA_PIXEL. Esta orden puede servir para definir zonas transparentes en las imágenes, y de esta forma se puede alterar la prioridad de imágenes en aquellas zonas donde las imágenes se solapen.

Esta orden sólo funciona si todas las imágenes son del mismo tipo, por lo que en caso tener cargadas simultáneamente imágenes en niveles de gris y en color verdadero se muestra el siguiente mensaje:

Al ejecutar la orden aparece el siguiente cuadro, en el caso de que las imágenes cargadas sean de color verdadero:

y en caso de que las imágenes cargadas sean de niveles de gris aparece el siguiente:

En dicho cuadro de diálogo se puede definir el color del píxel. Una vea definido el color del píxel, se pulsa sobre el botón Aceptar. Ahora corresponde utilizar la orden PINTA_PIXEL para pintar píxeles con el color definido.

En el cuadro de diálogo correspondiente a las imágenes de color verdadero, el color que DigiNG considera transparente es el (255,255,255) de la terna (Rojo, Verde, Azul).

En el cuadro de diálogo correspondiente a las imágenes de niveles de gris, el color que DigiNG considera transparente es el 255, situado en la esquina superior izquierda en el cuadro.

En caso de que se ejecute la orden y no haya imágenes cargadas en DigiNG, se avisa de ello a través del siguiente mensaje:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: jueves, 22 de Agosto de 2002


Orden COLOR_TENTATIVO

Cuando se selecciona con tentativo una entidad, si se tiene activo el conmutador VER (verifica), ésta se sobreiluminará. Con la orden COLOR_TENTATIVO se puede cambiar el color de sobreiluminación de la entidad seleccionada.

La relación entre un determinado número y el color que le corresponde se determina en el archivo DIGI.PAL. En este fichero de texto se especifican las componentes RGB del color que se quiere asignar a un determinado número. Si no existe ningún fichero DIGI.PAL se utilizan unos valores por defecto. Por ejemplo, si queremos utilizar para el tentativo el color número 3 se ejecuta la siguiente línea:

COLOR_TENTATIVO=3

Si escribimos:

COLOR_TENTATIVO=?

el programa nos informa del número de color de tentativo actual.

Órdenes relacionadas: COLOR_FONDO, VER.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden COMPRIMIR

Sirve para eliminar de un fichero de dibujo todos los elementos que tengan la marca de borrado y actualiza las topologías cargadas en memoria.

Al ejecutar esta orden se libera una parte de la memoria del ordenador, ya que se elimina el espacio ocupado por los registros del fichero marcados como borrados. El tamaño del fichero de dibujo se reducirá ya que sólo se almacenarán las entidades que no tienen marca de borrado.

Después de esta orden ninguno de los elementos borrados podrá ser recuperado.

Esta orden admite los siguientes parámetros:
COMPRIMIR=[eliminar_vértices_duplicados_XYZ][eliminar_vértices_duplicados_XY]
En el caso de que queramos eliminar los vértices duplicados en XY (independientemente de la coordenada Z),
ejecutaríamos COMPRIMIR=1 1.

Órdenes relacionadas: BORRADOS, RECUPERA.

Fecha de última modificación: viernes, 17 de Octubre de 2003


Orden COPIA2P

Realiza una copia de una entidad de dibujo, aplicando traslación, factor de escala y giro. Para ello se precisan digitalizar 4 puntos, dos correspondientes a la entidad original, y otros dos a la entidad a generar. La secuencia de acciones en esta orden es:

  1. Seleccionar la entidad, como indica en la parte inferior izquierda de la pantalla:

  2. Indicar el primer punto origen:

  3. Indicar el segundo punto origen

  4. Indicar el primer punto destino:

  5. Indicar el segundo punto destino:

Como se puede ver en la siguiente imagen

La nueva entidad se crea con el código activo. En el caso de que el conmutador REPITE esté activo el programa sigue pidiendo puntos destino para crear nuevas entidades copia de la original.

Ésta orden permite copiar entidades pertenecientes a archivos de referencia.

Órdenes relacionadas: COPIAR, DUP, REPITE.

Fecha de última modificación: martes, 24 de Febrero de 2004


Orden COPIAR

Realiza una copia de una entidad de dibujo. Cuando se ejecuta la orden, la secuencia de acciones en esta orden es:

  • Seleccionar la entidad, como indica en la parte inferior izquierda de la pantalla:

  • Indicar un punto origen

  • Indicar un punto destino

El programa genera una entidad igual a la original, pero aplicando en el proceso de copia la traslación definida por el vector: (punto origen, punto destino). El nuevo elemento se dibuja con el código activo.

Ésta orden permite copiar entidades pertenecientes a archivos de referencia.

Órdenes relacionadas: COPIA2P, DUP.

Fecha de última modificación: 24 de Febrero de 2004


Orden CORTA_2P

Sirve para cortar una entidad por dos puntos de la misma. Ejecutada la orden, el programa pide que se digitalice el primer punto, como se puede observar en la parte inferior izquierda de la pantalla:

y después solicita el segundo punto:

Esta orden se autorrepite si está activo el conmutador REPITE.

Órdenes relacionadas: REPITE

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CORTAR_E

Sirve para cortar o descomponer un elemento en otros dos. Al llamar a esta orden el usuario ha de seleccionar la entidad a cortar, como se puede ver en la parte inferior izquierda de la pantalla:

La entidad se partirá en dos trozos por el punto de selección. Si éste coincide con un vértice de la entidad original, pasará a formar parte de los dos elementos resultantes. Si la elección se realizó por un segmento, se creará un nuevo vértice coincidente con el punto dado sobre éste.

En el proceso de corte, el programa genera dos entidades que están definidas entre el punto de selección y el primer punto correspondiente a la entidad original.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CORTAR_F

Se utiliza para generar un nuevo fichero con los elementos que se encuentren dentro de los límites de una entidad de dibujo elegida por el usuario. Si no existe una entidad cuya geometría sea adecuada para establecer los límites de selección de elementos, el usuario tendrá que definir un nuevo elemento con la forma deseada antes de ejecutar esta orden. Este elemento, cuya función equivale a la de una ventana, puede eliminarse una vez que el proceso de cortar ha sido realizado.

Al ejecutar la orden se abre un cuadro de diálogo para indicar un fichero de salida:

Si se selecciona uno existente, el programa le añadirá los elementos contenidos dentro de la entidad que va a funcionar como ventana. Si se quiere crear un archivo de dibujo nuevo con estos elementos hay que escribir un nombre para el archivo en la casilla Nombre de archivo del cuadro de diálogo. En la parte inferior de este cuadro de diálogo se puede ver una lista desplegable:

que permite especificar la modalidad de copia que se desee. El usuario puede elegir una de las opciones siguientes:

  • Interior: se copian sólo los elementos que se encuentren totalmente incluidos dentro de los límites de la entidad.
  • Corte: se copian todos aquellos elementos que se hallen total o parcialmente en el interior de la entidad, cortándolos si rebasan los límites de ésta. Es decir, sólo la parte interior de la entidad se copia en el fichero de salida.
  • Solape: el borde de la entidad actúa como límite de separación, copiando todo lo que se encuentre total o parcialmente en su interior.

En el caso de se marque la casilla Cortar por fuera, el nuevo fichero se genera con las entidades que se encuentren fuera de la entidad cerrada que actuará como ventana, conservando la modalidad de copia seleccionada.

En el proceso de copia de elementos al fichero, sea nuevo o ya creado, hay que destacar lo siguiente:

  • Se copian únicamente las entidades de dibujo que estén activas, es decir aquellas cuyo código se encuentre activo.
  • Se copian las entidades de todos los ficheros activos, es decir del fichero de trabajo y de los ficheros de referencia cargados.

y por último el programa solicita que se seleccione una entidad cerrada a modo de límite, como se puede ver en la parte inferior izquierda de la pantalla:

en caso de que el usuario seleccione una entidad no cerrada como límite, el programa genera un fichero vacío.

Órdenes relacionadas: BLOQUE, BLOQUE_2P, INS, INS_AA, INSR.

Fecha de última modificación: viernes, 27 de Septiembre de 2002


Orden CORTAR_RASTER

Con esta orden se cortan las imágenes en formato TIFF cargadas en DigiNG (no en Digi3D), y se genera una imagen a partir de este corte. Esta orden está pensada para realizar mosaicos.

Para utilizar esta orden se debe dibujar previamente una entidad cerrada que sirve de límite.

Al ejecutar la orden, en primer lugar pide que se seleccione la entidad cerrada

y una vez definida se muestra el siguiente cuadro de diálogo:

donde se puede teclear el nombre de la imagen, y se puede seleccionar el directorio donde se almacena la imagen. La imagen que se almacena será del tipo BMP o TIFF, de este modo se consigue que la orden trabaje sin consumir grandes recursos de memoria. En el caso de que la imagen sea de tipo TIFF, la imagen generada estará en formato GeoTIFF.

En el caso de que se ejecute la orden sin que haya ninguna imagen cargada, el programa avisa de ello mediante el siguiente mensaje:

En el caso de el límite seleccionado no contenga a ninguna imagen, el programa avisa de ello mediante el siguiente mensaje:

Nota: En caso de que la imagen raster haya sido georreferenciada mediante la orden AFIN_RASTER no podrá ser cortada con la orden CORTAR_RASTER.

órdenes relacionadas: AGREGA, CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPóN, TAMPóN_T, TRASLADA_RASTER.

Fecha de última modificación: 28 de Junio de 2004


Orden COTA

Esta orden sirve para registrar puntos de cota, dibujando un punto y un texto con la cota donde digitalice el usuario. Cuando se arranca la aplicación por defecto se establece un código para el texto de la cota, 020400. El punto se dibuja con el código activo. Se puede cambiar tanto el código de la cota como el código del texto de la cota, mediante la orden COD_COTAS.

Órdenes relacionadas: COD_COTAS.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden COTAS_CURVAS

Esta orden sirve para modificar globalmente la cota de una curva de nivel. Al ejecutar la orden, el programa muestra la ventana en la cuál se busca y selecciona el código de las curvas a cambiar. A continuación, Digi3D te pedirá digitalizar dos puntos.

Órdenes relacionadas: COD_COTAS.

Fecha de última modificación: 9 de Febrero de 2004


Orden CREAR_DIGI_TAB

Cuando se abre un archivo .bin en Digi3D con una entidad con código que no está definido en el archivo DIGI.TAB cargado, dicha entidad se verá de color gris.

Con la orden CREAR_DIGI_TAB el usuario podrá abrir archivos o archivos de referencia .bin que tengan códigos desconocidos y crear un nuevo archivo DIGI_TAB con una lista de todos los códigos que se localizan en el archivo .bin, incluidos archivos de referencia. A cada código se le asignará un color del rango (0,255].

Esta orden resulta muy útil cuando se está trabajando con archivos generados por la fase 1 del programa OrtoBAtch.

Last update: 24th of August, 2003


Orden CRUCE

Se utiliza para dibujar el cruce de una entidad con otras dos, de forma que el tramo de la primera comprendido entre los puntos de intersección con las dos últimas, se elimina del dibujo.

La secuencia de acciones a realizar con esta orden es:

  • Identificar la primera entidad (borde), que como se puede ver en la parte inferior de la pantalla lo indica el programa:

  • Identificar la segunda entidad, que se prolongará hasta su punto de corte con la primera entidad:

  • Identificar la tercera entidad, que también se prolongará hasta su punto de corte con la primera entidad:

Una vez realizado este proceso, el programa elimina del dibujo el tramo antes indicado. Esta orden suele utilizarse para dibujar cruces de caminos, carreteras, etc...

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden CUADROS

El funcionamiento de esta orden es similar al de la orden ESCALERA, con la posibilidad de trazar escalones (segmentos) tanto paralelos como perpendiculares a la base. El efecto visual sería equiparable al de una matriz de cuadrados o rectángulos.

El resultado gráfico final, puede ser cualquiera de los siguientes:

  • Dibujo de cuadros:

  • Dibujo de escalones sólo en la dirección paralela a la base:

  • Dibujo de escalones sólo en la dirección perpendicular a la base:

La secuencia de pasos a realizar es:

  • Ejecutar la orden CUADROS, y aparece la siguiente ventana:

    • donde se puede señalar el número de líneas a dibujar, tanto paralelas a la base como perpendiculares a la misma.

  • Indicar secuencialmente tres puntos para construir el rectángulo base, como se puede ver en la parte inferior izquierda de la pantalla:

    • como se puede ver en la siguiente animación:

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: CUADROS_4P, ESCALERA, REPITE, 3P.

Fecha de última modificación: jueves, 6 de Junio de 2002


Orden CUADROS_4P

Sirve para hacer escaleras o matrices de polígonos de cuatro lados. Se piden los puntos primero y segundo que definen la base. Y luego los tercero y cuarto que forman el cuadrilátero.

El resultado gráfico final, puede ser cualquiera de los siguientes:

  • Dibujo de cuadros.
  • Dibujo de escalones sólo en la dirección paralela a la base.
  • Dibujo de escalones sólo en la dirección perpendicular a la base.

La secuencia de pasos a realizar es:

  • Ejecutar la orden CUADROS_4P, y aparece la siguiente ventana:

    • donde se puede señalar el número de líneas a dibujar, tanto paralelas a la base como perpendiculares a la misma.

  • Indicar secuencialmente tres puntos para construir el rectángulo base, como se puede ver en la parte inferior izquierda de la pantalla como se puede ver en la siguiente animación:

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: CUADROS, ESCALERA, REPITE, 3P.

Fecha de última modificación: jueves, 6 de Junio de 2002


Orden CUENTAGOTAS

Esta orden sirve para obtener el color de un píxel de una imagen, para luego utilizar dicho color para pintar con la orden PINTA_PIXEL.

Al llamar a la orden, el programa solicita que se seleccione el píxel deseado, como se puede observar en la parte inferior izquierda de la pantalla:

Una vez seleccionado el píxel, corresponde ejecutar la orden PINTA_PIXEL para pintar con el color del píxel.

En caso de se ejecute esta orden y no hay ninguna imagen cargada, se muestra el siguiente mensaje:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 16 de Agosto de 2002


Orden CURSOR

Establece el tamaño y la forma del cursor. Con el tamaño del cursor se establece el ámbito de búsqueda cuando se selecciona una entidad en el fichero de dibujo.

Admite diversos tamaños diferentes que se van cambiando al llamar sucesivamente a esta orden.

También se puede establecer directamente dando el valor:

  CURSOR=0
  CURSOR=1
  CURSOR=2
  CURSOR=3
  CURSOR=15 (tamaño máximo)

Si se teclea la orden CURSOR cambia de valor sucesivamente entre 0 y 3. El valor cero corresponde al cursor en forma de cruz.

Fecha de última modificación: jueves, 6 de Junio de 2002


Orden CURVAR

Con esta orden se puede realizar el curvado de una triangulación. Ejecuta la orden aparece la siguiente ventana:

donde se especifican los siguientes parámetros:

  • Equidistancia Finas: equidistancia en metros correspondiente a las curvas finas.
  • Equidistancia Maestras: equidistancia en metros correspondiente a las curvas
  • Escala de dibujo: se trata del denominador de la escala. Se utiliza para aplicar un factor de suavizado a las isohipsas.
  • Factor de suavizado: aquí se especifica si se quiere suavizar o no el curvado. Se puede escoger un factor de suavizado cuyo rango va desde el valor 1 hasta el 10.
  • Código Finas: código con el que se generarán las curvas de nivel.
  • Código Maestras: código con el que se generarán las curvas de nivel maestras.
  • Realizar curvado DEM: sólo funciona si posee licencia de VirtualLand. Si se realiza el curvado mediante este método el curvado resultante es mucho más suave.
  • Paso de la rejilla: este parámetro sólo estará activo en caso de realizar curvado DEM, y corresponde al paso de malla del MDT.

También es posible ejecutar esta orden desde la línea de órdenes, mediante la siguiente secuencia:

CURVAR=<Curvado DEM> <Equidistancia Finas> <Equidistancia Maestras> <Escala> <Código Finas> <Código Maestras> <Paso rejilla>

donde Curvado DEM puede tomar dos valores: 0 y 1. En el caso de que valga 0 indica que no se desea realizar el curvado DEM, y no se debe especificar el último parámetro, que es el correspondiente a Paso rejilla. En el caso de que valga 1 indica que se desea realizar el curvado DEM, y se debe especificar el último parámetro, que es el correspondiente a Paso rejilla.

Un ejemplo de curvado desde la línea órdenes puede ser el siguiente:

       CURVAR=0 020200 020400 1000 1 5

Órdenes relacionadas: CARGA_MDT | DEJAR_MDT | TRIANGULAR

Fecha de última modificación: jueves, 6 de Junio de 2002


Órdenes de DigiNG. D

    DA
    DEGRADADO
    DEJAR
    DEJAR_BASE_DATOS
    DEJAR_MDT
    DEJAR_RASTER
    DEJAR_TOP
    DEM
    DESCARGA_DLL
    DIBUJAR
    DIGI.TAB
    DIGI3D
    DISPOSITIVO_ENTRADA
    DLL
    DUP

Fecha de última modificación: viernes, 25 de Septiembre de 2003


Orden DA

Sirve para especificar las distancias activas a emplear en distintas órdenes. El valor por defecto de las dos distancias activas es 1.

La llamada a la orden se puede realizar de tres formas:

  • Teclear DA y pulsar Enter, con lo que aparece la siguiente ventana para la distancia activa 1,

donde se puede bien teclear la distancia, y luego pulsar sobre el botón Aceptar, o bien pulsar sobre el botón Medir y medir gráficamente en pantalla, o bien empezar a medir directamente la distancia. Una vez medida, aparece una ventana similar a la anterior:

donde se puede introducir la distancia activa 2, como en el caso anterior, tecleando o gráficamente con el cursor en pantalla.
  • Ejecutar la siguiente línea: DA=<distancia 1> <distancia 2>, un ejemplo puede ser:
    • DA=10 20

    donde se está introduciendo 10 como distancia activa 1, y 20 como distancia activa 2.
  • Ejecutar la siguiente línea: DA=<distancia 1>, con lo que se asume que la distancia activa 2 es igual que la primera. Un ejemplo de esta forma de ejecutar la orden puede ser:
    • DA=10

    donde se está introduciendo 10 como distancia activa 1 y como distancia activa 2.

Para conocer las distancias activas en cada momento, basta con escribir DA=?, con lo que se muestran los valores de ambas distancias en la siguiente ventana:

La distancia activa también puede tomar valores negativos, y así, en órdenes como PARALELA, se tiene en cuenta el signo para ejecutar la orden.

Órdenes relacionadas: PARALELA.

Fecha de última modificación: jueves, 6 de Junio de 2002


Orden DEGRADADO

Con esta orden se pueden aclarar u oscurecer imágenes cargadas en DigiNG, de forma degradada y visual. Para ello el programa solicita tres puntos que definen un rectángulo (la base y el ancho), para aplicar posteriormente la función de degradado a la parte de las imágenes enmarcadas dentro de dicho rectángulo. Esta función de degradado se aplica desde la base hacia el lado paralelo a la misma, de tal forma que la función es mínima en la base y máxima en el lado paralelo.

Al ejecutar la orden DEGRADADO se pide un primer punto:

y después un segundo punto. Se puede ver como se digitaliza una línea en el dibujo:

Estos dos primeros puntos definen la base del rectángulo. Cuando se pide el tercer punto, se puede observar como se forma el rectángulo de forma interactiva:

Una vez definido este rectángulo, se muestra el siguiente mensaje en la parte inferior izquierda de pantalla:

y se muestra la siguiente ventana:

donde se puede definir si se desea Aclarar u Oscurecer, marcando la casilla correspondiente en la parte superior izquierda de la ventana. Se varía el Porcentaje total de oscurecimiento/aclarado bien tecleando un valor entre 0 y 255 dentro del campo de texto, o bien desplazando con el ratón el indicador.

Si se marca la casilla Invertir degradado, la función de degradado pasa a ser máxima en la base, y mínima en el lado paralelo.

En la parte inferior izquierda de esta ventana está la casilla Previsualizar. Si está marcada se pueden ver los cambios en las imágenes según se establezcan. Si no está marcada, los cambios en las imágenes se efectúan una vez pulsado sobre el botón Aceptar.

En el caso de que se ejecute la orden y no haya ninguna imagen cargada en DigiNG, se muestra el siguiente mensaje:

En el caso de que el rectángulo definido no contenga a ninguna imagen, pero si hay imágenes cargadas en DigiNG, se muestra el siguiente aviso:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: martes, 13 de Agosto de 2002


Orden DEJAR

Sirve para desactivar los ficheros de referencia que se encuentren unidos al fichero de trabajo. La llamada a la orden se puede realizar de varias formas:

  1. Escribir DEJAR=<nombre fichero> y pulsar Enter. El sistema dejará ese fichero de referencia. En este caso fichero de referencia se debe introducir con toda la ruta de directorios. Un ejemplo de esta llamada a la orden puede ser:
    DEJAR=C:\Instalacion\Bronchales\a.bin
    donde se deja el fichero a.bin que está en la carpeta Bronchales que cuelga a su vez del directorio Instalación, y éste del raíz.

  2. Escribir DEJAR y pulsar Enter. El programa muestra la siguiente ventana:

    donde se puede seleccionar un fichero y pulsar sobre el botón Aceptar. También se pueden seleccionar todos los archivos para descargarlos pulsando sobre el botón Todos.

  3. Escribir DEJAR=* y pulsar Enter. El sistema dejará todos los ficheros de referencia enganchados actualmente.

Órdenes relacionadas: CARGA_F.

Fecha de última modificación: viernes, 7 de Junio de 2002


Orden DEJAR_BASES_DATOS

Esta orden sirve para desestablecer la conexión a la base de datos enlazada con la orden BASE_DATOS.

Órdenes relacionadas: BASE_DATOS.

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orden DEJAR_MDT

Esta orden se utiliza para descargar el Modelo Digital del Terreno (MDT) que esté cargado en memoria. Con DigiNG sólo se puede tener cargado un MDT, por lo que si se quiere realizar una nueva triangulación (con la orden TRIANGULAR) y hay un MDT cargado (con la orden CARGA_MDT), aparece el siguiente globo en la parte inferior derecha de la pantalla:

que informa de que ya hay un MDT cargado, y de que es necesario ejecutar previamente la orden DEJAR_MDT. También se puede dar el caso de que se desee cargar un MDT (con la orden CARGA_MDT) y ya hay un MDT cargado.

En el caso de que se ejecute la orden sin que haya ningún MDT cargado, aparece el siguiente globo en la parte inferior derecha de la pantalla:

que informa de que no hay ningún MDT cargado.

Órdenes relacionadas: CARGA_MDT | TRIANGULAR

Fecha de última modificación: Lunes, 3 de Junio de 2002


Orden DEJAR_RASTER

Esta orden sirve para descargar imágenes que se hayan cargado con la orden CARGA_RASTER. Al ejecutar la orden se muestra la siguiente ventana:

donde se puede seleccionar la imagen a descargar de DigiNG de las varias que se tengan abiertas, y después se pulsa sobre el botón Aceptar. También es posible descargar todas la imágenes a la vez.

En el caso de que sólo haya una imagen cargada no se muestra esta ventana, y se descarga directamente la imagen.

En el caso de que no haya ninguna imagen cargada, se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al descargarlas de DigiNG se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: miércoles, 14 de Agosto de 2002


Orden DEJAR_TOP

Esta orden sirve para descargar un archivo de topología.

Órdenes relacionadas: COD_COTAS.

Fecha de última modificación: viernes, 22 de Agosto de 2003


Orden DEM

Esta orden sirve para generar una malla de puntos de regular a partir de una triangulación. Al ejecutar la orden se pide al usuario que seleccione la línea límite:

y una vez seleccionado dicho límite, muestra la siguiente ventana:

donde se define el ancho y alto de la malla de puntos a generar. Definidas ambas magnitudes, se pulsa sobre el botón Comenzar. Los puntos se generan con el código activo en el momento de llamar a la orden.

En el caso de que se ejecute esta orden sin tener cargada ninguna triangulación se muestra el siguiente mensaje:

que informa de la imposibilidad de generar un DEM.

Fecha de última modificación: miércoles, 11 de Diciembre de 2002


Orden DESCARGA_DLL

Esta orden se utiliza para descargar las librerías DLL que se cargaron previamente con la orden CARGA_DLL.

Al ejecutar esta orden deberemos de especificar directamente en la línea de órdenes el path entero de la librería.

Por ejemplo: si hemos cargado el archivo MiPluggin1.dll que se encuentra en el directorio C:\Correo, deberemos de escribir lo siguiente en la línea de órdenes:

Órdenes relacionadas: CARGA_DLL, DLL.

Fecha de última modificación: 1 de Junio de 2004


Orden DIBUJAR

Esta orden sirve para activar o desactivar cualquier acción de dibujo sobre la pantalla de DigiNG. Se trata de una orden que sólo acepta valores booleanos, es decir Verdadero o Falso. Existen varias opciones para llamarla,

DIBUJAR=1 | Activa la orden.
DIBUJAR=0 | Desactiva la orden.
DIBUJAR | Cambia el estado de la orden.
Esta orden tiene asignado por defecto el valor Verdadero, esto se puede apreciar por el icono en forma de lápiz [image] que aparece resaltado.

En caso de asignarle el valor falso, DigiNg no registrará ni líneas, ni puntos, ni cotas cuando digitalizamos con el ratón sobre la pantalla de DigiNG. En este caso el icono mostrará el siguiente aspecto

Fecha de última modificación: jueves, 25 de Septiembre de 2003


Orden DIGI.TAB

Con esta orden se accede a la siguiente ventana:

donde se tiene acceso a los códigos existentes en el fichero DIGI.TAB, y también se tiene acceso a la creación de nuevos ficheros.

Si quieres saber algo más acerca de esta ventana pulsa aquí.

Fecha de última modificación: viernes, 17 de Octubre de 2003


Orden DIGI3D

Esta orden sirva para que el cursor de DigiNG se asocie a los movimientos de Digi3D, aunque lo hace automáticamente al pulsar cualquier botón o pedal que se corresponda con Dato, Tentativo y Fin_Entidad.

Fecha de última modificación: viernes, 7 de Junio de 2002


Orden DISPOSITIVO_ENTRADA

Esta orden se utiliza para establecer el restituidor QASCO como dispositivo de entrada. Para ello se debe ejecutar la línea:

DISPOSITIVO_ENTRADA=QASCO

Con lo que aparece la siguiente ventana:

Se deben seguir los pasos según se indican en esta ventana, y una vez efectuados ya estará establecida la conexión entre DigiNG y QASCO.

Fecha de última modificación: viernes, 7 de Junio de 2002


Orden DLL

Se utiliza para especificar la orden personalizada definida en el fichero DLL cargado con anterioridad mediante la orden CARGA_DLL. Por ejemplo: pogamos por caso que hemos cargado una DLL que tiene una función llamada holamundoque nos informa sobre la cantidad de ficheros de referencia que tenemos cargados en un momento determinado.

Así que al llamar esta orden especificaremos directamente en la barra de comandos el nombre de la función personalizada que deseemos ejecutar. En este caso sería: DLL=holamundo. Es entonces que nos aparecería esta ventana:

Órdenes relacionadas: CARGA_DLL, DESCARGA_DLL

Fecha de última modificación: 1 de Junio de 2004


Orden DUP

Sirve para hacer una copia de una entidad sobre sí misma. La orden sólo requiere que el usuario seleccione la entidad. El nuevo elemento creado se superpone espacialmente al existente, con sus mismas características geométricas y de posición. La entidad copiada se visualiza y registra en el fichero con el código activo en el momento de llamar a la orden.

Al llamar a la orden, el programa pide que se seleccione el elemento a duplicar, como se puede ver en la parte inferior izquierda de la pantalla:

Se selecciona el elemento y DigiNG crea un duplicado de la entidad seleccionada.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: COPIAR, REPITE.

Fecha de última modificación: viernes, 7 de Junio de 2002


Ordenes de DigiNG. E

Digi3D

Órdenes de DigiNG. E

    EDITAR
    EDITAR_ATR
    EDITAR_FOTO
    EDITAR_TEXTO
    EDITAR_XYZ
    EDITAR_Z
    EQUIDISTANCIA
    EQUILIBRIO_COLOR
    EQUILIBRIO_COLOR_V
    ENTRENAMIENTO
    ENVIA_DATOS_DRIVER
    ERR
    ERR-
    ERR+
    ERROR
    ERROR+
    ERROR-
    ESC_ACT
    ESCALA
    ESCALERA
    ESCALERA_DA
    ESCAPE
    EXPLOTAR_PUNTOS
    EXPLOTAR_SIMBOLOGIA
    EXPLOTAR_TEXTOS
    EXPORTAR
    EXT
    EXT_M
    EXT_P
    EXT2X
    EXTRAER_GEOREFERENCIACIÓN
    EXTRAER_GUID

Fecha de última modificación: lunes, 10 de Marzo de 2003


Orden EDITAR

Se utiliza para modificar la posición planimétrica (X, Y) de los vértices de un elemento. Al llamar a la orden se pide seleccionar la entidad a editar, como se puede ver en la parte inferior izquierda de la pantalla:

Al seleccionar una entidad, aparecen en la pantalla dos cursores: el de dibujo (ya existente), y otro en forma de cruz en aspa, que se sitúa en uno de los vértices del elemento:

El usuario tiene la posibilidad de mover planimétricamente el vértice donde se sitúa el cursor con forma de cruz en aspa (cursor de edición), con sólo indicar la nueva posición colocando el cursor normal en dicha posición. Además, puede seguir las opciones que el programa ofrece para recorrer uno a uno los vértices de la entidad:

Se indica en la parte izquierda el número de vértice dentro del elemento, y las coordenadas del vértice donde esté situado el cursor de edición.

  • Pulsando la tecla + se pasa al vértice siguiente en el sentido de avance.
  • Pulsando la tecla - se retrocede al vértice anterior.
  • Pulsando la tecla * se modifica la posición del vértice de modo que los segmentos que se unen en él formen un ángulo recto.
  • Pulsando la tecla Insert se añade un nuevo vértice en la posición del cursor normal.
  • Pulsando la tecla Supr se elimina el vértice en el que estuviese el cursor de edición.
  • Pulsando la tecla Espacio (barra espaciadora) se aceptan las modificaciones.
  • Pulsando la tecla Esc se anula la orden.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: EDITAR_XYZ, EDITAR_Z, REPITE.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EDITAR_FOTO

Esta orden sirve para editar los atributos de las fotos insertadas con las orden INS_FOTO.

Al llamar a la orden, el programa pide seleccinonar la foto:

A continuación aparece un cuadro en el cual por defecto aparece la imagen a editar y en donde se puede especificar qué color queremos que se visualice como transparente. Al marcar la casilla de Usar color transparente se habilita el cuadro en el cual introducimos el valor que corresponde al color. En caso de ser fotos en blanco y negro, sabemos que el valor 255 equivale al blanco y el 0 al negro.

Órdenes relacionadas: INS_FOTO

Fecha de última modificación: viernes, 25 de Julio de 2003


Orden EDITAR_TEXTO

Sirve para editar un texto del fichero de dibujo. Ejecutada la orden, el programa pide que se seleccione el texto a editar, como se puede ver en la parte inferior izquierda de la pantalla:

Una vez seleccionado el texto a editar, éste aparece en una ventana de edición

donde puede modificarse el texto editado. Después se pulsa sobre el botón Aceptar para que se efectúe el cambio.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: REPITE.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EDITAR_XYZ

Se utiliza para modificar la posición tridimensional (X, Y, Z) de los vértices de un elemento. La orden trabaja igual que la orden EDITAR, variando ahora que cuando se modifique un vértice de la entidad, dicho vértice tomará la cota que se tenga en ese momento activa. El valor activo se establece con la orden Z, o bien por entrada del dato a través del restituidor.

Al llamar a la orden se pide seleccionar la entidad a editar, como se puede ver en la parte inferior izquierda de la pantalla:

Al seleccionar una entidad, aparecen en la pantalla dos cursores: el de dibujo (ya existente), y otro en forma de cruz en aspa, que se sitúa en uno de los vértices del elemento:

El usuario tiene la posibilidad de mover planimétricamente el vértice donde se sitúa el cursor con forma de cruz en aspa (cursor de edición), con sólo indicar la nueva posición colocando el cursor normal en dicha posición. Además, puede seguir las opciones que el programa ofrece para recorrer uno a uno los vértices de la entidad:

Se indica en la parte izquierda el número de vértice dentro del elemento, y las coordenadas del vértice donde esté situado el cursor de edición.

  • Pulsando la tecla + se pasa al vértice siguiente en el sentido de avance.
  • Pulsando la tecla - se retrocede al vértice anterior.
  • Pulsando la tecla * se modifica la posición del vértice de modo que los segmentos que se unen en él formen un ángulo recto.
  • Pulsando la tecla Insert se añade un nuevo vértice en la posición del cursor normal.
  • Pulsando la tecla Supr se elimina el vértice en el que estuviese el cursor de edición.
  • Pulsando la tecla Espacio (barra espaciadora) se aceptan las modificaciones.
  • Pulsando la tecla Esc se anula la orden.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: EDITAR, EDITAR_Z, REPITE, Z.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EDITAR_Z

Se utiliza para modificar la coordenada Z de la entidad indicada por el usuario. lista+El valor activo se establece con la orden Z, o bien por entrada del dato a través del restituidor.

Al llamar a la orden se pide seleccionar la entidad a editar, como se puede ver en la parte inferior izquierda de la pantalla:

Al seleccionar una entidad, aparecen en la pantalla dos cursores: el de dibujo (ya existente), y otro en forma de cruz en aspa, que se sitúa en uno de los vértices del elemento:

El usuario tiene la posibilidad de mover planimétricamente el vértice donde se sitúa el cursor con forma de cruz en aspa (cursor de edición), con sólo indicar la nueva posición colocando el cursor normal en dicha posición. Además, puede seguir las opciones que el programa ofrece para recorrer uno a uno los vértices de la entidad:

Se indica en la parte izquierda el número de vértice dentro del elemento, y las coordenadas del vértice donde esté situado el cursor de edición.

  • Pulsando la tecla + se pasa al vértice siguiente en el sentido de avance.
  • Pulsando la tecla - se retrocede al vértice anterior.
  • Pulsando la tecla * se modifica la posición del vértice de modo que los segmentos que se unen en él formen un ángulo recto.
  • Pulsando la tecla Insert se añade un nuevo vértice en la posición del cursor normal.
  • Pulsando la tecla Supr se elimina el vértice en el que estuviese el cursor de edición.
  • Pulsando la tecla Espacio (barra espaciadora) se aceptan las modificaciones.
  • Pulsando la tecla Esc se anula la orden.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: EDITAR, EDITAR_XYZ, REPITE, Z.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EQUIDISTANCIA

Sirve para establecer el valor de la equidistancia de curvas de nivel, que utilizarán las órdenes INTER (interpolación de curvas), FIJAZ (para fijar la cota a un múltiplo de este valor), BAJA_Z, .... También se puede emplear para moverse a intervalos fijos en X Y con la orden FIJAXY.

Existen varias formas de ejecución para esta orden:

  • Tecleando EQUIDISTANCIA, y pulsando la tecla Enter, con lo que aparece la siguiente ventana:

    • donde se puede introducir el valor de la equidistancia de las curvas de nivel, y después pulsar sobre el botón Aceptar. Además, se puede pulsar sobre el botón Medir, e introducir la equidistancia de forma gráfica digitalizando dos puntos, de tal forma que la distancia entre ellos marcará el valor de la equidistancia. También es posible introducir el valor de la equidistancia digitalizando directamente sobre la pantalla dos puntos, sin haber pulsado previamente el botón Medir.

  • Tecleando EQUIDISTANCIA=<valor>, y pulsando la tecla Enter, donde valor es el valor de la equidistancia de las curvas de nivel que se desea establecer.

  • Tecleando EQUIDISTANCIA=?, y pulsando la tecla Enter, y se muestra el valor actual de la equidistancia mediante un globo en la parte inferior derecha de la pantalla:

Órdenes relacionadas: BAJA_Z, FIJAXY, FIJAZ, INTER.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EQUILIBRIO_COLOR

Esta orden sirve para cambiar las componentes de color de las imágenes cargadas en DigiNG mediante la orden CARGA_RASTER. Esta orden sólo funciona con imágenes de color verdadero (24 bits).

Al ejecutar la orden aparece la siguiente ventana:

donde se puede seleccionar una imagen, varias imágenes, o todas la imágenes pulsando sobre el botón Todos. Después de pulsar sobre el botón Aceptar aparece la siguiente ventana:

donde se pueden ver tres campos de texto en la parte superior de la ventana, y tres indicadores de color. El rango de los valores es de -100 a 100. Los valores negativos se corresponden con movimientos de los indicadores hacia la izquierda, y los valores positivos hacia la derecha.

Si se marca la casilla Previsualizar (situada en la esquina inferior izquierda de la pantalla), se puede visualizar de forma interactiva el cambio en el color de la imagen (o de las imágenes en el caso de que haya varias imágenes abiertas).

Cuando la imagen tenga el color deseado, se pulsa sobre el botón Aceptar.

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se intenta ejecutar esta orden con imágenes que no sean de color verdadero aparece el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: lunes, 29 de Julio de 2002


Orden EQUILIBRIO_COLOR_V

Esta orden sirve para cambiar las componentes de color de parte de las imágenes cargadas en DigiNG mediante la orden CARGA_RASTER. Esta orden sólo funciona con imágenes de color verdadero (24 bits). Previamente a la llamada a esta orden es necesario digitalizar una entidad cerrada a modo de ventana.

Al ejecutar la orden se pide al usuario que seleccione dicha entidad cerrada:

y una vez seleccionada la entidad cerrada que actúa de límite, aparece la siguiente ventana:

donde se pueden ver tres campos de texto en la parte superior de la ventana, y tres indicadores de color. El rango de los valores es de -100 a 100. Los valores negativos se corresponden con movimientos de los indicadores hacia la izquierda, y los valores positivos hacia la derecha.

Si se marca la casilla Previsualizar (situada en la esquina inferior izquierda de la pantalla), se puede visualizar de forma interactiva el cambio en el color de la zona de la imagen (o de las imágenes en el caso de que haya varias imágenes abiertas).

Cuando la zona de la imagen tenga el color deseado, se pulsa sobre el botón Aceptar.

En el caso de que la línea seleccionada no solape con ninguna imagen cargada se muestra el siguiente mensaje:

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se intenta ejecutar esta orden con imágenes que no sean de color verdadero aparece el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 23 de Agosto de 2002


Orden ENTRENAMIENTO

Esta orden sirve para tomar muestras de objetos de las imágenes, para posteriormente utilizarlas con la orden MDTPC. Estas muestras se utilizan para indicarle al correlador sobre qué objetos no debe correlar, para así tomar medidas sobre el terreno y no sobre puntos elevados del mismo, como pueden ser árboles.

Antes de ejecutar esta orden se deben digitalizar entidades cerradas que marquen el perímetro de los objetos de los que se desea tomar muestras. Se pueden usar códigos diferentes para tomar muestras de distintos tipos.

Dentro de cada archivo de memoria se pueden almacenar varios códigos.

Al ejecutar la orden ENTRENAMIENTO aparece la siguiente ventana:

donde se pueden ver los siguientes elementos:

  • Archivo de memoria: aquí se almacenarán por cada código la media y desviación típica de los píxeles que definen las muestras encerradas por los códigos. Estos archivos tienen .TRAINING como extensión.
  • Códigos: aquí se puede ver el identificador de los códigos y la descripción de los mismos.
  • Recalcular: en caso de que se haya añadido una nueva entidad con un código, recalcula y modifica los valores para mejorar la definición de la muestra en el archivo.
  • Nuevo: sirve para crear un nuevo código para el muestreo. Si se pulsa emerge la siguiente ventana, donde se puede definir el código de la entidad que limita la muestra.

  • Borrar: sirve para borrar un código. Para ello se debe seleccionar en listado y luego pulsar este botón.
  • Guardar: se utiliza para guardar el código o códigos dentro del archivo de memoria.
  • Aceptar: si se pulsa se pasa a seleccionar las entidades cerradas previamente digitalizadas con el código seleccionado. Estas muestras se efectúan en la pantalla de visualización estereoscópica.

En el caso de que no se hayan cargado las imágenes en la pantalla de visualización estereoscópica, la orden no se puede ejecutar y muestra el siguiente mensaje:

Órdenes relacionadas: MDTPC.

Fecha de última modificación: miercoles, 9 de Julio de 2003


Orden ENVIA_DATOS_DRIVER

Esta orden sirve para enviar datos a los drivers programados para la orden DISPOSITIVO_ENTRADA.

Órdenes relacionadas: DISPOSITIVO_ENTRADA

Fecha de última modificación: lunes, 10 de Marzo de 2003


Orden ERROR

Esta orden se utiliza con los programas BINTRAM y BINTOP. Estos programas sirven para la detección de errores. El fichero de errores creado en este caso, es un fichero que se mostrará en la barra de salida.

La llamada a la orden presenta las siguientes modalidades:

  • Teclear ERROR y pulsar la tecla Enter. Aparece entonces la siguiente ventana:

    • donde se introduce un número, que se corresponde con el error que se quiere corregir. Se pulsa sobre el botón Aceptar y se muestra en pantalla y de forma centrada el error correspondiente a dicho número.

  • Teclear ERROR=<número> y pulsar la tecla Enter. El sistema presenta en pantalla el error cuyo número ha especificado el usuario.

  • Teclear ERROR=? y pulsar la tecla Enter. El sistema presenta mediante un globo en la parte inferior derecha de la pantalla el número del último error visitado:

Órdenes relacionadas: ERROR+, ERROR-.

Fecha de última modificación: viernes, 3 de septiembre de 2003


Orden ERR+

Esta orden se utiliza con los programas BINTRAM y BINTOP. Estos programas sirven para la detección de errores. El fichero de errores creado puede mostrarse en la barra de salida y con ésta orden podremos visitar los errores con un cierto orden.

Cuando se ejecuta la orden, el programa presenta por pantalla, con un zoom centrado, un error. Éste se corresponde con el error siguiente (al error mostrado actualmente) en el fichero.

Órdenes relacionadas: ERR, ERR-.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden ERROR-

Esta orden se utiliza con los programas BINTRAM y BINTOP. Estos programas sirven para la detección de errores. El fichero de errores creado puede mostrarse en la barra de salida y con ésta orden podremos visitar los errores con un cierto orden.

Cuando se ejecuta la orden, el programa presenta por pantalla, con un zoom centrado, un error. Éste se corresponde con el error anterior (al error mostrado actualmente) en el fichero.

Órdenes relacionadas: ERROR+, ERROR.

Fecha de última modificación: martes, 7 de octubre de 2003


Orden ERR

Esta orden se utiliza con los programas BINTRAM y BINTOP. Estos programas sirven para generar un fichero con símbolos, cuya localización se corresponde con todas aquellas posiciones donde se ha detectado un error. El fichero creado es un fichero gráfico (BIN) que puede ser cargado como referencia sobre el archivo de trabajo para visualizar los errores encontrados por cualquiera de los programas anteriormente citados.

La llamada a la orden presenta las siguientes modalidades:

  • Teclear ERR y pulsar la tecla Enter. Aparece entonces la siguiente ventana:

    • donde se introduce un número, que se corresponde con el error que se quiere visualizar. Se pulsa sobre el botón Aceptar y se muestra en pantalla y de forma centrada el error correspondiente a dicho número.

  • Teclear ERR=<número> y pulsar la tecla Enter. El sistema presenta en pantalla el error cuyo número ha especificado el usuario.

  • Teclear ERR=? y pulsar la tecla Enter. El sistema presenta mediante un globo en la parte inferior derecha de la pantalla el número del último error visitado:

Órdenes relacionadas: ERR+, ERR-.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden ERR-

Esta orden se utiliza con los programas BINTRAM y BINTOP. Estos programas sirven para generar un fichero con símbolos, cuya localización se corresponde con todas aquellas posiciones donde se ha detectado un error. El fichero creado es un fichero gráfico (BIN) que puede ser cargado como referencia sobre el archivo de trabajo para visualizar los errores encontrados por cualquiera de los programas anteriormente citados.

Cuando se ejecuta la orden, el programa presenta por pantalla, con un zoom centrado, un error. Éste se corresponde con el error anterior (al error mostrado actualmente) en el fichero.

Órdenes relacionadas: ERR+, ERR.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden ERR+

Esta orden se utiliza con los programas BINTRAM y BINTOP. Estos programas sirven para generar un fichero con símbolos, cuya localización se corresponde con todas aquellas posiciones donde se ha detectado un error. El fichero creado es un fichero gráfico (BIN) que puede ser cargado como referencia sobre el archivo de trabajo para visualizar los errores encontrados por cualquiera de los programas anteriormente citados.

Cuando se ejecuta la orden, el programa presenta por pantalla, con un zoom centrado, un error. Éste se corresponde con el error siguiente (al error mostrado actualmente) en el fichero.

Órdenes relacionadas: ERR, ERR-.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden ESC_ACT

Sirve para establecer como factor de escala el valor tecleado por el usuario al llamar a esta orden. Este factor se utilizará en inserciones de bloques (mediante las órdenes BLOQUE, BLOQUE_2P, INS, INS_AA, INSR.). Por defecto, tiene el valor 1. Esto significa que el bloque se insertará con las mismas dimensiones con las que fue guardado. Si la escala activa fuera 2, el bloque se insertaría con un tamaño doble del original.

Existen varias formas de ejecutar esta orden:

  • Tecleando ESC_ACT, y pulsando la tecla Enter, y se muestra la siguiente ventana:

    • donde bien se puede introducir el valor del factor de escala a aplicar en las inserciones de bloques, y pulsar luego sobre el botón Aceptar, o bien se puede medir un valor digitalizando dos puntos en pantalla pulsando sobre el botón Medir, o bien digitalizando directamente dos puntos sin necesidad de pulsar previamente sobre el botón Medir.

  • Tecleando ESC_ACT=<valor>, y pulsando la tecla Enter. En este caso se introduce valor como factor de escala en las inserciones de bloques.
  • Tecleando ESC_ACT=?, y pulsando la tecla Enter, y el programa muestra el valor actual del factor de escala en las inserciones de bloques mediante un globo en la parte inferior derecha de la pantalla:

Órdenes relacionadas: BLOQUE, BLOQUE_2P, INS, INS_AA, INSR.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden ESCALA

Al ejecutar esta orden se informa de la escala de visualización actual del fichero de dibujo. Se muestra el denominador de la escala en un globo en la parte inferior izquierda de la ventana principal de DigiNG.

Fecha de última modificación: martes, 12 de Noviembre de 2002


Orden ESCALERA

Sirve para construir una escalera en el espacio. Ejecutada la orden se muestra la siguiente ventana:

donde se introduce el número de escalones de la escalera, que serán paralelos a la base. Se pulsa sobre el botón Aceptar, y el programa solicita que se digitalicen tres puntos. Estos tres puntos forman un rectángulo, definiendo los dos primeros la base. El rectángulo generado no forma un elemento continuo, y el programa reconoce como independientes cada una de las líneas componentes.

Los escalones se construyen por interpolación entre los lados ya dibujados, y paralelos a la base inicial definida por los dos primeros puntos del rectángulo.

Órdenes relacionadas: CUADROS, CUADROS_4P, 3P.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden ESCALERA_DA

Sirve para construir una escalera en el espacio especificando el ancho de los peldaños. Antes de ejecutar esta orden hará falta especificar el ancho de los peldaños mediante el parámetro de DA. Una vez introducida esta distancia

donde se introduce el ancho de los escalones de la escalera. se pulsa sobre el botón Aceptar, y el programa solicita que se digitalicen cuatro puntos. Estos cuatro puntos forman un rectángulo, definiendo los dos primeros el lateral de la escalera. El rectángulo generado no forma un elemento continuo, y el programa reconoce como independientes cada una de las líneas componentes.

Los escalones se construyen por interpolación entre los lados ya dibujados.

Órdenes relacionadas: DA, ESCALERA, CUADROS, CUADROS_4P, 3P.

Fecha de última modificación: 24 de junio de 2004


Orden ESCAPE

Se utiliza para terminar o dar por finalizada una orden. La orden ESCAPE también se ejecuta al pulsar la tecla Esc, o cualquier otra tecla que tenga asignada esta orden en el correspondiente menú de teclado.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EXPLOTAR_PUNTOS

Esta orden sirve para convertir símbolos en elementos lineales (pasar de tipo 'T' a tipo 'C'). Resulta útil para el diseño o la modificación de símbolos.

Al ejecutar a esta orden hay que especificar en la línea de órdenes el código de los elementos a explotar:

  • EXPLOTAR_PUNTOS=<código> y pulsar [ENTER]. El sistema "explotará" automáticamente todos los textos que tengan ese código.

Órdenes relacionadas: EXPLOTAR_TEXTOS EXPLOTAR_SIMBOLOGIA.

Fecha de última modificación: 11 de Mayo de 2004


Orden EXPLOTAR_SIMBOLOGIA

Esta orden sirve para convertir líneas con patrón en elementos lineales (pasar de tipo 'T' a tipo 'C'). Resulta útil para el diseño o la modificación de símbolos.

Al ejecutar esta orden hay que especificar en la línea de órdenes el código de los elementos a explotar:

  • EXPLOTAR_SIMBOLOGIA=<código> y pulsar [ENTER]. El sistema "explotará" automáticamente todas las líneas que tengan ese código.

Órdenes relacionadas: EXPLOTAR_PUNTOS, EXPLOTAR_TEXTOS.

Fecha de última modificación: 12 de Mayo de 2004


Orden EXPLOTAR_TEXTOS

Esta orden sirve para convertir textos en elementos lineales (pasar de tipo 'T' a tipo 'C'). Resulta útil para el diseño o la modificación de símbolos, pues permite introducir textos en los mismos sin más que convertirlos en líneas.

Al ejecutar esta orden hay que especificar en la línea de órdenes el código de los elementos a explotar:

  • EXPLOTAR_TEXTOS=<código> y pulsar [ENTER]. El sistema "explotará" automáticamente todos los textos que tengan ese código.

Órdenes relacionadas: EXPLOTAR_PUNTOS, EXPLOTAR_SIMBOLOGIA

Fecha de última modificación: 11 de Mayo de 2004


Orden EXPORTAR

Sirve para exportar el archivo actual BIN a los formatos ASCII de Digi, ASCII de Kork, DGN, .XYZ, DXF y ASCII de Photomod. Ejecutada la orden aparece la siguiente ventana:

donde se puede teclear el nombre del fichero a generar, y seleccionar el tipo en la lista desplegable situada en la parte inferior de la ventana:

Se pulsa sobre el botón Guardar, y el programa genera el fichero deseado.

En caso de querer exportar el fichero BIN a formato DXF de AutoCAD, al salvar aparecerá el siguiente cuadro de dialogo:

Aquí se especificará el formato de salida, el factor de escala para BLOQUES Y TEXTOS, el color de los elementos y las tablas de traducción y de códigos origen. La tabla de traducción correspondiente es la llamada BINDXF.TAB.

También se podrá especificar el tratamiento de errores al exportar. Podemos especificar cómo insertar los elementos cuyo código no esté en la tabla o bien generar un archivo de errores con el listado de códigos que no aparece en la tabla.

Órdenes relacionadas: IMPORTAR.

Fecha de última modificación: 10 de Diciembre de 2003


Orden EXT

Sirve para prolongar una entidad hasta el punto de intersección con otra entidad dada. La secuencia de pasos a realizar es:

  • Seleccionar la primera entidad, como puede verse en la parte inferior izquierda de la pantalla:

    que será utilizada como borde o límite hasta el que puede extenderse el siguiente elemento.
  • Seleccionar la segunda entidad por el extremo que se quiere prolongar, como solicita el programa:

Una vez extendida la primera entidad, pide al usuario que se seleccione otra entidad a estirar hasta la primera entidad. Cuando se desee dejar de extender hasta la primera entidad se debe pulsar la tecla Esc, y el programa pedirá otra línea para que sirva como límite. Se puede seleccionar otra entidad, o bien se puede pulsar de nuevo la tecla Esc para dejar de ejecutar esta orden.

Esta orden suele utilizarse en Cartografía para extender algunas entidades (por ejemplo, curvas de nivel) hasta el borde de la hoja del mapa o para arreglar errores en líneas que no se han enganchado en otras (por ejemplo, límites de parcela). El sistema calcula y dibuja el segmento correspondiente a la prolongación del último elemento hasta su punto de intersección con la primera entidad.

Órdenes relacionadas: EXT2X, EXT_M, EXT_P, TRIM.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EXT_M

Esta orden es similar a la orden EXT y sirve para prolongar un grupo de entidad hasta que intersecten con otra entidad dada. La secuencia de pasos a realizar es:

  • Seleccionar la primera entidad, como puede verse en la parte inferior izquierda de la pantalla:

    que será utilizada como borde o límite hasta el que pueden extenderse el grupo de entidades.

  • Seleccionar el grupo de entidades mediante la digitalización de dos puntos, definiendo éstos un segmento que corta a las entidades a extender. Para ello el programa solicita los dos puntos:

Una vez extendida la primera entidad, pide al usuario que se seleccione otra entidad a estirar hasta la primera entidad. Cuando se desee dejar de extender hasta la primera entidad se debe pulsar la tecla Esc, y el programa pedirá otra línea para que sirva como límite. Se puede seleccionar otra entidad, o bien se puede pulsar de nuevo la tecla Esc para dejar de ejecutar esta orden.

Órdenes relacionadas: EXT, EXT2X, EXT_P, TRIM.

Fecha de última modificación: lunes, 10 de junio de 2002


Orden EXT_P

Extiende una entidad hasta su intersección con otra quedando ambas partidas en el punto de intersección, es decir, genera un nodo en este punto. Al llamar a la orden el programa pide que se seleccione la entidad que va actuar de borde, como se puede ver en la parte inferior izquierda de la pantalla:

Una vez seleccionada dicha entidad, pide que se seleccione la entidad que se va a extender:

Una vez seleccionadas las dos entidades, la segunda se prolonga hasta su intersección con la primera, cortándose ésta en el punto de intersección y generando en ella un nodo.

La orden EXT_P no insertará un vértice nuevo si las coordenadas de intersección con la línea a partir coincidan (dentro del rango de una unidad de precisión) con otro vértice existente en la línea a cortar.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: EXT, EXT2X, EXT_M, REPITE, TRIM.

Fecha de última modificación: martes, 11 de junio de 2002


Orden EXT2X

Sirve para prolongar dos entidades hasta su intersección. La orden precisa que el usuario seleccione estas entidades.

La intersección de los dos elementos se realiza a partir de los vértices extremos de cada uno, que se hallen más próximos a los puntos de selección. El programa genera dos segmentos de prolongación, con origen en estos vértices y hasta el punto de intersección.

Si el punto de intersección de las dos entidades está situado sobre una de ellas, esta será recortada hasta la intersección.

Si las entidades tienen el mismo código generará una sola entidad unida. Si las entidades tuvieran atributos en una base de datos, estos, además, deberán ser iguales para unir las entidades.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: EXT, EXT_M, EXT_P, REPITE, TRIM.

Fecha de última modificación: martes, 11 de junio de 2002


Orden EXTRAER_GEOREFERENCIACIÓN

Esta orden sirve para obtener los archivos de georreferenciación de una imagen raster cargada con la orden CARGA_RASTER. Con esta orden se pueden cargar los archivos de imagen que tengan asociada alguno de los siguientes archivos de georreferenciación: .ori, .ort, .geo, .tfw, o bien sea un archivo GeoTiff. Sin embargo, no se puede extraer información de georreferenciación del archivo .ori, por lo que creará los diferentes archivos con valores nulos o con aquellos que se le indiquen.

Al ejecutar la orden se muestra la siguiente ventana:

donde se puede seleccionar la imagen para la que se desea obtener todos los archivos de georreferenciación. En dicha ventana también se muestran las coordenadas de las esquinas de la imagen y el tamaño de píxel de la misma. Además, es posible introducir otros valores para estos campos.

Si desea conocer los diferentes archivos de georreferenciación, lea el tema de la ayuda Formatos de archivos utilizados por DigiNG.

En el caso de que se ejecute la orden sin que haya ninguna imagen raster cargada, se muestra el siguiente goblo de texto en la parte inferior izquierda de la pantalla:

Órdenes relacionadas: CARGA_RASTER.

Fecha de última modificación: lunes, 10 de Marzo de 2003


Orden EXTRAER_GUID

Sirve para copiar al portapapeles de Windows el GUID asignado a una entidad. Al hacer la llamada a la orden aparecerá el mensaje:

En caso de que no exista un GUID asociado a esa entidad, se podrá leer el mensaje:

Órdenes relacionadas: ON_GUID, OFF_GUID, BORRAR_GUID, ASIGNAR_GUID, RESTAURAR_FICHERO.

Fecha de última modificación: martes, 29 de Julio de 2003


Órdenes de DigiNG. F

    FICHERO_DIBUJO
    FICHERO_P
    FIJAXY
    FIJAZ
    FIN
    FIN_ENT

Fecha de última modificación: martes, 11 de Junio de 2002


Orden FICHERO_DIBUJO

Sirve para decirle al sistema el fichero de dibujo con el cual se va a trabajar, de entre los archivos de referencia cargados con la orden CARGA_F. Al ejecutar la orden aparece la siguiente ventana:

donde se listan todos los archivos de referencia cargados. Se selecciona el archivo que se desee establecer como activo, y se pulsa sobre el botón Aceptar. Se puede ver que se efectúa el cambio porque en la barra de título se cambia el nombre del archivo (entre corchetes, al lado del icono, en la parte izquierda):

Órdenes relacionadas: CAMBIA_FICHEROS, CARGA_F, DEJAR.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden FICHERO_P

Sirve para establecer o cambiar el fichero de puntos que utiliza DigiNG sin necesidad de abandonar la sesión de trabajo y salir a la pantalla de inicio del programa.

La llamada a la orden admite dos variantes:

  1. Teclear FICHERO_P y pulsar Enter. El programa pide al usuario que introduzca un nombre de fichero mediante el siguiente cuadro de diálogo:

  1. Teclear FICHERO_P = <nombre fichero con extensión> y pulsar Enter.

Una vez establecido el nuevo fichero de puntos, todas las órdenes DigiNG que lo necesiten escribirán y leerán datos de él.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden FIJAXY

Sirve para activar o desactivar la opción de forzar a que la variación de las coordenadas planimétricas se realice en intervalos múltiplos de la equidistancia. Este dato se especifica en la pantalla de inicio de DigiNG o bien con la orden EQUIDISTANCIA.

Se puede ejecutar de dos formas:

  • Teclear FIJAXY, y pulsar la tecla Enter, con lo que se cambia el estado de activo a inactivo, y viceversa.

  • Teclear FIJAXY=<valor>, y pulsar la tecla Enter. Si valor es 1, se activa. Si valor es 0, se desactiva.

Ejemplo: Si hemos establecido una equidistancia de 100 metros, y estamos en un punto de coordenadas X=1200.43, Y=3460.78, al activar FIJAXY se produciría:

  • El redondeo de las coordenadas a los valores: X=1200.00, Y=3500.00.
  • La variación de estos valores en intervalos de 100 metros, al realizar cualquier desplazamiento con el cursor en el fichero de trabajo.

Órdenes relacionadas: EQUIDISTANCIA, FIJAZ.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden FIJAZ

Sirve para activar o desactivar la opción de fijar el valor de la coordenada Z al múltiplo más próximo de la equidistancia de curvas de nivel. La equidistancia se especifica en la pantalla de inicio de DigiNG o bien con la orden EQUIDISTANCIA.

Cuando se encuentra activado, aparece en la barra de herramientas Flags el mensaje Z_f. El valor de Z queda bloqueado, de forma que no puede ser modificado al variar la altura con el pedal del restituidor.

Se puede ejecutar de dos formas:

  • Teclear FIJAZ, y pulsar la tecla Enter, con lo que se cambia el estado de activo a inactivo, y viceversa.

  • Teclear FIJAZ=<valor>, y pulsar la tecla Enter. Si valor es 1, se activa. Si valor es 0, se desactiva.

Esta orden se suele utilizar en el dibujo de curvas de nivel, forzando a que la coordenada Z se registre con un valor constante igual a un múltiplo de la equidistancia.

El modo de operar con el restituidor, consta de los siguientes pasos:

  • Mover el pedal de alturas del aparato hasta que el contador de Z de la pantalla, muestre una cota con el valor más próximo al de la curva de nivel que se quiere registrar.
  • Ejecutar la orden FIJAZ, para redondear la altitud del contador al múltiplo más próximo de la equidistancia, y dejar como fijo este valor.
  • Dibujar la curva de nivel. Esta se irá registrando con el valor de cota fijado.
  • Ejecutar la orden FIJAZ, para liberar el contador de Z.

Para registrar la siguiente curva de nivel, repetir el proceso desde el primer paso.

Órdenes relacionadas: EQUIDISTANCIA, FIJAXY, Z .

Fecha de última modificación: lunes, 15 de Julio de 2002


Orden FIN

Sirve para dar por finalizada la sesión de trabajo sobre el fichero actual. Con esta orden, se cierra el fichero de dibujo activo pero no sale de la ejecución de Digi3D.

Órdenes relacionadas: SALIR.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden FIN_ENT

Sirve para dar por finalizada la definición geométrica de una entidad. Tras esta orden podemos seguir trazando nuevas entidades con la orden y código de dibujo activos.

Órdenes relacionadas: C, CIERRA, CIERRA_ENT.

Fecha de última modificación: martes, 11 de Junio de 2002


Órdenes de DigiNG. G

    G
    GEN
    GIRAR
    GROSOR
    GROSORS
    GUARDA_DISPOSICION

Fecha de última modificación: lunes, 13 de Octubre de 2003


Orden G

Sirve para activar o desactivar la función de generalización. Para cambiar el valor de esta variable, basta con llamarla desde el menú de pantalla o bien escribir:

G=1 | Activa la función de generalización.
G=0 | Desactiva la función de generalización.
G | Cambia el estado de la función.

Cuando está activada aparece la letra G en la barra de herramientas Flags. Al terminar una entidad, sus puntos son generalizados antes de grabarse en el fichero.

Si se ejecuta la siguiente línea:

G=?

se muestra el siguiente globo en la parte inferior derecha de la pantalla:

que informa del estado de esta función. En el caso de que sea Si indica que la función de generalización está activada. En el caso de que sea No indica que dicha función no está activada.

Órdenes relacionadas: GEN, TOL, TOL_ANG.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden GEN

Se utiliza para filtrar o eliminar puntos de una entidad seleccionada por el usuario. El modo de actuar depende del factor de generalización que se encuentre activo en el momento de ejecutar esta orden. Este factor está condicionado por las variables de tolerancia, cuyos valores se asignan mediante las órdenes TOL y TOL_ANG. La llamada a la orden GEN admite dos posibilidades:

  1. Teclear GEN y pulsar Enter. El sistema nos pide que se seleccione la entidad a generalizar, como se puede ver en la parte inferior izquierda de la pantalla:

    una vez seleccionada, generaliza la entidad.

  2. GEN=<código> y pulsar Enter. El sistema generalizará todas las entidades con ese código existentes en el fichero de dibujo.

Como resultado de la orden GEN, la entidad elegida se graba en el fichero, pero sólo con aquellos puntos que han sido seleccionados en el proceso de generalización.

La selección se realiza calculando las distancias de cada punto a los segmentos que definen los puntos anterior y posterior, de forma que si ésta es que mayor que el valor de TOL, el punto se registra en el fichero. En caso contrario se elimina. También se considera el valor de la tolerancia angular dado por la orden TOL_ANG.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: G, REPITE, TOL, TOL_ANG.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden GIRAR

Sirve para visualizar el fichero de dibujo con el ángulo de giro indicado por el usuario. El valor angular de rotación se dará en graduación centesimal, y medido desde el Norte en el sentido de las agujas del reloj.

Esta orden admite varias formas de ejecución:

  • Teclear Girar, y pulsar la tecla Enter. Se muestra entonces la siguiente ventana:

    • donde se puede introducir el ángulo de giro y después pulsar sobre el botón Aceptar, o se puede pulsar sobre Medir y determinar el ángulo mediante la digitalización de dos puntos. También es posible medir el ángulo directamente sin pulsar previamente sobre el botón Medir.

  • Teclear Girar=<valor>, y pulsar la tecla Enter. Entonces valor es el ángulo de giro.
  • Teclear Girar=<valor>, y pulsar la tecla Enter. Aparece un globo en la parte inferior derecha:

    • que muestra el valor actual del ángulo de giro.

La orden se utiliza en restitución, cuando las pasadas no han sido realizadas en la dirección Este-Oeste. En este caso, y para visualizar por pantalla la imagen con la misma orientación que tiene en el fotograma, se llama a la orden GIRAR, introduciendo como ángulo de giro el mismo valor obtenido en la orientación externa de una de las imágenes.

La orden no introduce ninguna modificación en el fichero de trabajo. Sólo afecta a la visualización en pantalla.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden GROSOR

Sirve para asignar un grosor a las entidades que se visualizan en la pantalla d DigiNG. Esta orden se puede ejecutar de las varias formas:

  • Teclear Grosor, y pulsar la tecla Enter. Se muestra la siguiente ventana:

    • donde se puede teclear el valor del grosor y pulsar sobre el botón Aceptar, o bien se puede pulsar sobre el botón Medir y definir el grosor mediante la digitalización de dos puntos. También es posible digitalizar estos dos puntos sin necesidad de pulsar previamente sobre el botón Medir.

  • Teclear Grosor=<valor>, y pulsar la tecla Enter. El grosor se especifica mediante valor.
  • Teclear Grosor=?, y pulsar la tecla Enter. Se muestra el valor actual de la variable mediante un globo en la parte inferior derecha de la pantalla:

Fecha de última modificación: martes, 11 de Junio de 2002


Orden GROSORS

Sirve para asignar un grosor a las entidades que se visualizan en la pantalla estereoscópica. Esta orden se puede ejecutar de las varias formas:

  • Teclear Grosors, y pulsar la tecla Enter. Se muestra la siguiente ventana:

    • donde se puede teclear el valor del grosor y pulsar sobre el botón Aceptar, o bien se puede pulsar sobre el botón Medir y definir el grosor mediante la digitalización de dos puntos. También es posible digitalizar estos dos puntos sin necesidad de pulsar previamente sobre el botón Medir.

  • Teclear Grosors=<valor>, y pulsar la tecla Enter. El grosor se especifica mediante valor.
  • Teclear Grosors=?, y pulsar la tecla Enter. Se muestra el valor actual de la variable mediante un globo en la parte inferior derecha de la pantalla:

Fecha de última modificación: lunes, 7 de Julio de 2003


Orden GUARDA_DISPOSICION

Esta orden permite guardar la disposición de múltiples vistas con la que se está trabajando en el momento de llamar a la orden. A la hora de ejecutarla tendremos que introducirla en la línea de órdenes especificando el nombre con el que queremos guardar la disposición.

Por ejemplo: GUARDA_DISPOSICION = disposicion1

Órdenes relacionadas: NUEVA_VENTANA, CARGA_DISPOSICION.

Fecha de última modificación: viernes, 10 de Octubre de 2003


Órdenes de DigiNG. H

    HISTOGRAMA
    HORIZON

Fecha de última modificación: miércoles, 23 de Abril de 2003


Orden HISTOGRAMA

Esta orden se utiliza para mostrar el histograma de las imágenes cargadas en DigiNG. El histograma es un diagrama de frecuencias, que muestra gráficamente el número de píxeles pertenecientes a cada valor radiométrico de la imagen.

Al ejecutar la orden aparece la siguiente ventana en pantalla:

donde se puede elegir la imagen de la cual mostrar el histograma. También existe la posibilidad de visualizar de forma independiente el histograma de las componentes Rojo, Verde y Azul, en el caso de imágenes de color verdadero. En el caso de imágenes en niveles de gris, se muestra Valor.

Órdenes relacionadas: CARGA_RASTER.

Fecha de última modificación: miércoles, 23 de Abril de 2003


Orden HORIZON

Esta orden sirve para hacer líneas de señalización horizontal, mediante la inserción de símbolos (compuestos por segmentos horizontales y verticales) y de espacios en blanco. Si se ejecuta esta orden aparece la siguiente ventana:

donde se han de rellenar los siguientes campos:

  • Código de las líneas de señalización horizontal: código de las entidades lineales que se van a transformar a líneas de señalización horizontal. Se pueden utilizar los caracteres comodín *, ?.

  • Largo: se trata del largo del símbolo a insertar en metros.

  • Ancho: se trata del ancho del símbolo a insertar en metros.

  • Espacio en blanco entre líneas: se trata del espacio entre símbolos, también en metros.

Fecha de última modificación: 1 de Septiembre, 2004


órdenes de DigiNG. I

    IMPORTAR
    IMPRIMIR
    IMPRIMIR_V
    INC
    INS
    INS_AA
    INS_FOTO
    INS_OLE
    INSERTA_VERTICE
    INSR
    INTER
    INTER_EJE
    IR_A
    IR_PRINCIPIO
    IR_TENTATIVO
    IT

Fecha de última modificación: lunes, 18 de Julio de 2003


Orden IMPORTAR

Esta orden sirve para importar archivos de los siguiente tipos:

  • ASCII de Digi.
  • DGN (MicroStation).
  • ASCII de Kork.
  • DXF (AutoCAD).
  • ArcView.
  • Photomod.

Para ejecutar esta orden se teclea Importar y se pulsa la tecla Enter. Entonces se muestra la siguiente ventana:

donde en la lista desplegable situada en la parte inferior se puede elegir el tipo de archivo a importar.

Puedes encontrar más información referente a exportación e importacion de ficheros DGN y DXF en los siguientes temas de ayuda: Importación interactiva de ficheros DGN y Importación interactiva de ficheros DXF.

Fecha de última modificación: 10 de Diciembre de 2003


Orden IMPRIMIR

Esta orden sirve para imprimir el fichero de dibujo actual. Si desea imprimir sólo una parte del fichero de dibujo ejecute la orden IMPRIMIR_V.

Al ejecutar esta orden aparece la siguiente ventana:

donde se definen las características de la impresión. En la parte izquierda de esta ventana se encuentran las definiciones de impresión comunes en Windows, como son el nombre de la impresora, las propiedades de ésta, el intervalo de impresión y el número de copias. Si desea elegir otra impresora debe seleccionarla desde la lista desplegable. Las características de impresión asociadas a la impresión desde DigiNG son las siguientes:

  • Escala de impresión: en esta lista desplegable se define la escala de impresión.

    • También es posible establecer otra escala que no se encuentre en esta lista, tecleándola en el campo de texto.

  • Margen izquierdo: donde se define la distancia en cm desde el borde izquierdo del papel hasta el dibujo.
  • Margen inferior: donde se define la distancia en cm desde el borde inferior del papel hasta el dibujo.
  • Centrar: si se pulsa este botón, se centra el dibujo en el papel, cambiándose los valores de los márgenes.
  • Tabla de códigos a usar: se establece el fichero de definición de códigos con el que se quiere imprimir el dibujo actual. Estos archivos se definen en la Configuración de Tablas.
  • Archivo de grosor de plumas: donde se define el archivo de grosor de plumas que se empleará en la impresión. Si desea conocer el formato de este tipo de archivo lea el tema de la ayuda Formato del archivo .plu.
  • Fondo: con este botón se define si se desea imprimir el color de fondo o no.

En la parte derecha se encuentra una presentación preliminar de los márgenes, donde el rectángulo rojo marca el límite del dibujo, y el rectángulo relleno de color blanco simboliza el papel donde se efectuará la impresión.

Órdenes relacionadas: IMPRIMIR_V.

Fecha de última modificación: lunes, 7 de Octubre de 2002


Orden IMPRIMIR_V

Esta orden sirve para una parte del fichero de dibujo actual, mediante una entidad cerrada que actuará de límite. Si desea imprimir todo el fichero de dibujo ejecute la orden IMPRIMIR.

Al ejecutar esta orden el programa solicita que se seleccione la entidad cerrada, y una vez seleccionada aparece la siguiente ventana:

donde se definen las características de la impresión. En la parte izquierda de esta ventana se encuentran las definiciones de impresión comunes en Windows, como son el nombre de la impresora, las propiedades de ésta, el intervalo de impresión y el número de copias. Si desea elegir otra impresora debe seleccionarla desde la lista desplegable. Las características de impresión asociadas a la impresión desde DigiNG son las siguientes:

  • Escala de impresión: en esta lista desplegable se define la escala de impresión.

    • También es posible establecer otra escala que no se encuentre en esta lista, tecleándola en el campo de texto.

  • Margen izquierdo: donde se define la distancia en cm desde el borde izquierdo del papel hasta el dibujo.
  • Margen inferior: donde se define la distancia en cm desde el borde inferior del papel hasta el dibujo.
  • Centrar: si se pulsa este botón, se centra el dibujo en el papel, cambiándose los valores de los márgenes.
  • Tabla de códigos a usar: se establece el fichero de definición de códigos con el que se quiere imprimir el dibujo actual. Estos archivos se definen en la Configuración de Tablas.
  • Archivo de grosor de plumas: donde se define el archivo de grosor de plumas que se empleará en la impresión. Si desea conocer el formato de este tipo de archivo lea el tema de la ayuda Formato del archivo .plu.
  • Fondo: con este botón se define si se desea imprimir el color de fondo o no.

En la parte derecha se encuentra una presentación preliminar de los márgenes, donde el rectángulo rojo marca el límite del dibujo, y el rectángulo relleno de color blanco simboliza el papel donde se efectuará la impresión.

Órdenes relacionadas: IMPRIMIR.

Fecha de última modificación: lunes, 7 de Octubre de 2002


Orden INC

Se utiliza para establecer como incremento de registro activo el valor que indique el usuario al llamar a esta orden. Este incremento representa la distancia de registro de puntos cuando la entrada de datos se realiza en modo continuo.

Existen tres formas de ejecutar esta orden:

  • Teclear INC, y pulsar la tecla Enter. Aparece el siguiente cuadro de diálogo:

donde se puede teclear un valor y pulsar sobre el botón Aceptar, o bien se puede pulsar sobre el botón Medir y definir el incremento de registro mediante la distancia de dos puntos que se digitalizan. También es posible definir el incremento de registro mediante la digitalización directa los dos puntos, sin necesidad de pulsar previamente sobre el botón Medir.

  • Teclear INC=<valor>, y pulsar la tecla Enter. Donde valor es el nuevo valor correspondiente al incremento de registro.

  • Teclear INC=?, y pulsar la tecla Enter. Muestra el valor actual del incremento de registro mediante un globo en la parte inferior derecha de la pantalla:

De todos los puntos de entrada, sólo se registrarán aquellos cuya distancia al anterior sea igual o mayor al valor de la variable INC.

Si la distancia de un punto a la recta definida por los dos puntos anteriores es mayor que un tercio de INC, el punto es registrado aunque no se haya alcanzado el valor de INC.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden INS

Se utiliza para insertar un fichero de dibujo en el fichero de trabajo. Los ficheros de dibujo (BIN) se refieren a cualquier archivo DigiNG, o a los creados por el usuario con las órdenes BLOQUE y BLOQUE_2P.

La llamada a la orden se puede realizar de dos formas:

  1. Teclear INS y pulsar Enter. El sistema pide el nombre del fichero a insertar, mediante el siguiente cuadro de diálogo:

    2. y a continuación el punto de inserción en el dibujo, mediante sus coordenadas, que se pueden introducir mediante un punto en el dibujo o mediante la orden XY.

  2. Teclear INS=<nombre fichero con extensión> y pulsar Enter. El fichero a insertar debe estar en el directorio de trabajo. Al ejecutar la orden de esta forma solicita el punto de destino, como se puede ver en la parte inferior izquierda de la pantalla:

    3. que se puede introducir de forma interactiva en el dibujo o mediante la orden XY a través de sus coordenadas.

Si el fichero a insertar ha sido creado con la orden BLOQUE, el programa define el vector de traslación con origen (0, 0, 0) y destino las coordenadas del punto indicado por el usuario. De esta forma las coordenadas de todos los puntos del bloque toman los valores correspondientes a su nueva posición dentro del fichero.

Si el fichero a insertar es cualquier archivo de dibujo de DigiNG, el usuario ha de especificar como punto de inserción el punto de coordenadas (0, 0, 0) de su archivo de trabajo. En este caso, los dos ficheros han de estar en el mismo sistema de coordenadas para que el proceso de inserción sea posible.

El fichero, sea del tipo que sea, se insertará con un factor de escala igual al valor de la escala activa (ESC_ACT).

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: BLOQUE, BLOQUE_2P, ESC_ACT, INS_AA, INSR, REPITE, XY.

Fecha de última modificación: miércoles, 12 de Junio de 2002


Orden INS_AA

Se utiliza para insertar un fichero de dibujo en el archivo de trabajo. Funciona igual que la orden INS con la excepción de que el bloque, en este caso, se insertará rotando según la dirección del ángulo activo (AA).

Esta orden tiene dos formas de ejecución:

  1. Teclear INS y pulsar Enter. El sistema pide el nombre del fichero a insertar, mediante el siguiente cuadro de diálogo:

    2. y a continuación el punto de inserción en el dibujo, mediante sus coordenadas, que se pueden introducir mediante un punto en el dibujo o mediante la orden XY.

  2. Teclear INS=<nombre fichero con extensión> y pulsar Enter. El fichero a insertar debe estar en el directorio de trabajo. Al ejecutar la orden de esta forma solicita el punto de destino, como se puede ver en la parte inferior izquierda de la pantalla:

    3. que se puede introducir de forma interactiva en el dibujo o mediante la orden XY a través de sus coordenadas.

Si el fichero a insertar ha sido creado con la orden BLOQUE, el programa define el vector de traslación con origen (0, 0, 0) y destino las coordenadas del punto indicado por el usuario. De esta forma las coordenadas de todos los puntos del bloque toman los valores correspondientes a su nueva posición dentro del fichero.

Si el fichero a insertar es cualquier archivo de dibujo de DigiNG, el usuario ha de especificar como punto de inserción el punto de coordenadas (0, 0, 0) de su archivo de trabajo. En este caso, los dos ficheros han de estar en el mismo sistema de coordenadas para que el proceso de inserción sea posible.

El fichero, sea del tipo que sea, se insertará con un factor de escala igual al valor de la escala activa (ESC_ACT).

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: AA, BLOQUE, BLOQUE_2P, ESC_ACT, INS, INSR, REPITE, XY.

Fecha de última modificación: miércoles, 12 de Junio de 2002


Orden INS_FOTO

Esta orden permite insertar un archivo raster en el archivo de dibujo, como puede ser un logotipo o un escudo. La orden admite los formatos BMP, GIF y JPG.

Al ejecutar la orden INS_FOTO aparecerá un cuadro de dialogo para seleccionar el archivo a insertar.

Después de haber hecho la selección y aceptarla, el programa nos pedirá el primer punto de inserción, que corresponde a la esquina superior izquierda:

y a continuación un segundo punto. Podemos así controlar el tamaño de la imagen así como su posición.

En caso de querer cambiar la posición de la imagen insertada, podemos moverla con la orden MOVER, y en caso de que queramos eliminarla, lo podremos hacer mediante la orden BORRA_E.

También existe la opción de hacer la llamada a la orden definiendo parámetros, por ejemplo: INS_FOTO=parametro

Parámetros posibles:
Nombre completo del Archivo | El archivo se importa con sus colores en opaco, es decir tal y como se ve el original
Nombre_color | De este modo se puede definir el color que se quiere importar como transparente

Órdenes relacionadas: MOVER, EDITAR_FOTO, BORRA_E.

Fecha de última modificación: jueves, 24 de Julio de 2003


Orden INSERTA_VERTICE

Se utiliza para insertar un vértice en una entidad lineal. Al llamar la orden, podremos ver en la parte inferior de la pantalla nos pide seleccionar la entidad lineal en la cual queremos insertar el vértice:

Al seleccionar la entidad y aceptar la selección,el cursor queda enganchado y el programa pedirá posar el nuevo vértice:

y podremos moverlo a la posición deseada para el nuevo vértice.

El usuario tiene la posibilidad de mover el vértice a la posición en que desée.

Órdenes relacionadas: EDITAR, EDITAR_XYZ, EDITAR_Z, REPITE.

Fecha de última modificación: 29 de Enero de 2004


Orden INSR

Al igual que las órdenes INS e INS_AA, permite insertar un bloque, almacenado en un fichero de dibujo, en una determinada posición del fichero de trabajo actual. En este caso, se puede establecer la rotación del bloque indicando, después del punto de inserción, un segundo punto de orientación. De este modo quedará insertado en la dirección marcada por la recta que definen los dos puntos dados, el punto de inserción y el punto de orientación.

Existen dos formas de ejecutar esta orden:

a llamada a la orden se puede realizar de dos formas:

  1. Teclear INS y pulsar Enter. El sistema pide el nombre del fichero a insertar, mediante el siguiente cuadro de diálogo:

    2. y a continuación el punto de inserción en el dibujo, mediante sus coordenadas, que se pueden introducir mediante un punto en el dibujo o mediante la orden XY. Y después solicita un segundo punto, para poder efectuar la orientación del bloque.

  2. Teclear INS=<nombre fichero con extensión> y pulsar Enter. El fichero a insertar debe estar en el directorio de trabajo. Al ejecutar la orden de esta forma solicita el punto de destino, como se puede ver en la parte inferior izquierda de la pantalla:

    3. que se puede introducir de forma interactiva en el dibujo o mediante la orden XY a través de sus coordenadas. Y después pide el segundo punto:

    que sirve para indicar el giro a emplear en la inserción del bloque.

El fichero, sea del tipo que sea, se insertará con un factor de escala igual al valor de la escala activa (ESC_ACT).

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: AA, BLOQUE, BLOQUE_2P, ESC_ACT, INS, INS_AA, REPITE, XY.

Fecha de última modificación: martes, 11 de Junio de 2002


Orden INTER

Se utiliza para interpolar curvas de nivel. La llamada a esta orden admite dos posibilidades:

  1. Teclear INTER y pulsar Enter. El sistema pide que se seleccionen las dos entidades (curvas de nivel) entre las que va a interpolar, como se puede ver en la parte inferior izquierda de la pantalla:

    2. El programa interpola entre estas dos entidades nuevos elementos con altitudes múltiplos de la equidistancia, y de valores comprendidos entre las cotas de la primera y segunda entidad. Las entidades que se generan con esta orden se registran con el código activo.

  2. INTER=<código> y pulsar Enter. Al llamar a esta orden con un código de entidad, que se trata del código de curvas de nivel que se desean utilizar como maestras al interpolar. Se pueden usar los comodines habituales del DOS, es decir, *, ?.
    El programa pide cuatro puntos. Los dos primeros definen el primer segmento y los dos últimos el segundo segmento.
    Todas las curvas cuyo código sea el que se dio en la orden y que sean cortadas por los dos segmentos serán utilizadas para interpolar nuevas curvas, que se dibujarán en el código activo. Ejemplo:
    COD=020123 Código de curvas de nivel finas.
    INTER=020124 Utilizar las directoras para interpolar.
    INTER=0201* Todas las entidades cuyos códigos empiecen por 0201
    En este caso, las curvas interpoladas solo se dibujarán dentro del entorno definido por los cuatro puntos. Si la orden     REPITE está activada, se seguirán pidiendo puntos para volver a efectuar el proceso de interpolación. Se termina con Esc.

Órdenes relacionadas: COD_CURVAS, REPITE.

Fecha de última modificación: jueves, 13 de Junio de 2002


Orden INTER_EJE

Se utiliza para interpolar una entidad entre otras dos seleccionadas por el usuario. Al llamar a la orden, el programa pide que se seleccione la primera entidad, como se puede ver en la parte inferior izquierda de la pantalla:

y luego solicita la segunda entidad.

El programa interpola una entidad entre estas dos, realizando la interpolación en coordenadas (X Y Z). La nueva entidad se registrará con el código activo.

Fecha de última modificación: viernes, 14 de Junio de 2002


Orden IR_A

Se utiliza en restitución para llevar el índice del restituidor digital Digi3D al punto donde esté el cursor en ese momento o al punto que se le especifique. Al ejecutar la orden aparece el siguiente mensaje en la parte inferior izquierda de la pantalla:

que indica que se debe indicar el punto hacia el que se debe mover el restituidor. Este punto se puede indicar mediante la digitalización con el puntero del ratón en pantalla, o mediante la orden XY.

Órdenes relacionadas: IR_PRINCIPIO, IR_TENTATIVO, XY.

Fecha de última modificación: lunes, 1 de Junio de 2002


Orden IR_PRINCIPIO

Es un interruptor. En restitución, si está activado este interruptor, cuando se termina de registrar una entidad, el aparato vuelve automáticamente a la posición del primer punto de la entidad. Es útil al curvar. Se desactiva al cambiar de código.

Admite como parámetro 1 y 0, para activar y desactivar respectivamente. Si se ejecuta sin parámetro, conmuta de un estado al otro.

Cuando está activo se muestra <- en la barra de herramientas Flags.

Órdenes relacionadas: IR_A, IR_TENTATIVO.

Fecha de última modificación: lunes, 17 de Junio de 2002


Orden IR_TENTATIVO

Es un interruptor y es utilizado para la restitución. Si está activado, cuando se hace tentativo en alguna entidad, mueve el aparato a las coordenadas del punto en que se ha hecho tentativo. NO se desactiva al cambiar de código.

Admite como parámetro 1 y 0, para activar y desactivar respectivamente. Si se ejecuta sin parámetro, conmuta de un estado al otro.

Cuando está activo se muestra -> en la barra de herramientas Flags.

Órdenes relacionadas: IR_A, IR_PRINCIPIO.

Fecha de última modificación: lunes, 17 de Junio de 2002


Órdenes de DigiNG. J

    JSCRIPT
    JSCRIPT_ENCRIPTADO
    JT
    JUNTAR

Fecha de última modificación: lunes, 4 de Noviembre de 2002


Orden JSCRIPT

Bajo el nombre de DigiNGScript se incluyen una serie de métodos y propiedades que proporciona DigiNG para facilitar la integración de DigiNG con los diferentes motores de scripting instalados en el ordenador en el cual se ejecuta DigiNG.

Por defecto en Windows 2000 y en Windows XP vienen instalados dos motores de scripting:

  • VBScript: para programar en un lenguaje parecido a VBasic.
  • VBScript.Encode: igual que VBScript pero encriptado con el programa de Microsoft Windows Script Encoder.
  • JScript: para programar en un lenguaje parecido a C, C++ ó Java.
  • JScript.Encode: Igual que JScript pero encriptado con el programa de Microsoft Windows Script Encoder.

Para obtener información en línea en español acerca de scripting, así como tutoriales de VBScript y JScript, visite el web http://msdn.microsoft.es/scripting.

DigiNG publica un objeto denominado digi y dicho objeto posee una serie de Métodos y Propiedades con las cuales se puede controlar a DigiNG desde un script.

El procedimiento normal consiste en crear un archivo de texto con el código del script y luego ejecutarlo con la orden VBScript ó con la orden JScript de DigiNG.

Si desea conocer más lea el tema de la ayuda DigiNGScript.

Órdenes relacionadas: VBSCRIPT, VBSCRIPT_ENCRIPTADO, JSCRIPT_ENCRIPTADO,

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orden JSCRIPT_ENCRIPTADO

Bajo el nombre de DigiNGScript se incluyen una serie de métodos y propiedades que proporciona DigiNG para facilitar la integración de DigiNG con los diferentes motores de scripting instalados en el ordenador en el cual se ejecuta DigiNG.

Por defecto en Windows 2000 y en Windows XP vienen instalados dos motores de scripting:

  • VBScript: para programar en un lenguaje parecido a VBasic.
  • VBScript.Encode: igual que VBScript pero encriptado con el programa de Microsoft Windows Script Encoder.
  • JScript: para programar en un lenguaje parecido a C, C++ ó Java.
  • JScript.Encode: Igual que JScript pero encriptado con el programa de Microsoft Windows Script Encoder.

Para obtener información en línea en español acerca de scripting, así como tutoriales de VBScript y JScript, visite el web http://msdn.microsoft.es/scripting.

DigiNG publica un objeto denominado digi y dicho objeto posee una serie de Métodos y Propiedades con las cuales se puede controlar a DigiNG desde un script.

El procedimiento normal consiste en crear un archivo de texto con el código del script y luego ejecutarlo con la orden VBScript ó con la orden JScript de DigiNG.

Si desea conocer más lea el tema de la ayuda DigiNGScript.

Órdenes relacionadas: VBSCRIPT, VBSCRIPT_ENCRIPTADO, JSCRIPT,

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orden JT

Sirve para cambiar la justificación del texto al insertarlo en el dibujo. Es decir, con esta orden se puede definir el punto de enganche del texto para poder insertarlo con más precisión.

La llamada a la orden admite tres posibilidades:

  1. Escribir JT y pulsar Enter. El sistema muestra la siguiente ventana:

    2. donde se puede elegir directamente el valor de la justificación de textos, y luego pulsar sobre el botón Aceptar.

  1. Escribir JT=<valor> y pulsar Enter. De esta manera introducimos como valor la justificación de textos deseada.

  2. Escribir JT=? y pulsar Enter. El programa muestra el valor actual de la justificación de textos, mediante un globo en la parte inferior derecha de la pantalla:

En este caso, la posición de la justificación sería 1.

Los valores de justificación posibles son los siguientes:

2 | 3 | 4
1 | 8 | 5
0 | 7 | 6

 0 Sitúa el punto de inserción al SO del texto.
 1 Situa al punto de inserción al O del texto.
 2 Situa al punto de inserción al NO del texto.
 3 Situa al punto de inserción al N del texto.
 4 Situa al punto de inserción al NE del texto.
 5 Situa al punto de inserción al E del texto.
 6 Situa al punto de inserción al SE del texto.
 7 Situa al punto de inserción al S del texto.
 8 Situa al punto de inserción al Centro del texto.

Por ejemplo, si antes de introducir el texto se especifica la justificación de texto en 6, esto implicaría que el punto de inserción del texto se encuentra en la esquina inferior derecha del texto.

Deberemos tener en cuenta que para fuentes TrueType, las justificaciones 1, 5 y 8 se comportan como 0, 6 y 7 respectivamente.

Órdenes relacionadas: CAMB_JT.

Fecha de última modificación: lunes, 4 de Julio de 2003


Orden JUNTAR

Esta orden sirve para trasladar todos los puntos en un entorno, que será determinado por el tamaño del cursor, a un mismo punto. Para ejecutar a la orden se debe teclear JUNTAR y presionar Enter. Entonces el programa pide que se digitalice el punto donde se desea juntar los elementos:

Al digitalizar este punto, se mueven todos los puntos seleccionados (mediante el entorno definido por el tamaño del cursor) hacia dicho punto.

El tamaño del cursor se puede modificar con la orden CURSOR.

Órdenes relacionadas: CURSOR, UNIR.

Fecha de última modificación: lunes, 17 de Junio de 2002


Órdenes de DigiNG. L

    LANZA_ARROBA
    LIMITE_0
    LIMITE_1
    LINEA
    LIMPIA_BASE_DATOS
    LISTA LISTA_ATRIBUTOS

Fecha de última modificación: 21 de Septiembre, 2004


Orden LANZA_ARROBA

Esta orden sirve para ejecutar macroinstrucciones, también llamadas arrobas. Al ejecutar la orden se muestra la siguiente ventana:

donde se puede bien teclear la arroba a ejecutar (sin el sufijo @) , o bien se puede seleccionar de la lista, y después se pulsa sobre la tecla Aceptar. En la lista sólo se muestran las arrobas que existen en el directorio de tablas, que se define en el cuadro de diálogo Nuevo Proyecto (Página Digi).

Fecha de última modificación: miércoles, 18 de Diciembre de 2002


Orden LIMITE_0

Sirve para desactivar una zona de trabajo, establecida como límite por la orden LIMITE_1. Al ejecutar esta orden, el sistema libera la memoria ocupada por los puntos correspondientes al contorno geométrico de la zona de trabajo desactivada.

Órdenes relacionadas: LIMITE_1.

Fecha de última modificación: lunes, 17 de Junio de 2002


Orden LIMITE_1

Se utiliza para establecer una zona de trabajo, cuyos límites se corresponderán con el contorno geométrico de una entidad de dibujo. Esta entidad debe existir antes de llamar a la orden, y puede tener cualquier forma (incluyendo concavidades y convexidades). Se recomienda que esté definida por el menor número posible de puntos, por lo que debe utilizarse la modalidad "punto a punto" cuando se dibuje.

Al llamar a la orden, el programa pide que se seleccione la entidad que va a servir de límite, como se puede observar en la parte inferior izquierda de la pantalla:

Una vez que el límite ha sido establecido, el sistema avisa con una señal acústica si el cursor sale fuera de los bordes de la zona de trabajo, pero no impide que éste siga dibujando fuera de los limites establecidos.

Para desactivar esta orden se debe ejecutar la orden LIMITE_0.

Órdenes relacionadas: LIMITE_0.

Fecha de última modificación: lunes, 17 de Junio de 2002


Orden LINEA

Dibuja una línea en el archivo actual, aunque no es necesario ejecutar esta orden para dibujar una línea, pues basta con seleccionar un código definido para una entidad lineal, y pulsar sobre Dato para dibujar una línea.

Una vez ejecutada la orden, pide en primer lugar que se digitalice el primer punto:

y digitalizado aquel, solicita el siguiente punto:

y sigue solicitando puntos hasta que el usuario pulse la tecla Esc o pulse el pedal/botón de finalizar entidad (o ejecutar FIN_ENTIDAD) para dejar de ejecutar esta orden. Mientras se digitalicen puntos, muestra en la parte inferior izquierda de la pantalla la distancia y el ángulo para el segmento actual:

Cuando se está dibujando una línea, se puede enganchar con otra entidad ya digitalizada mediante el pedal/botón de Tentativo. La modalidad de enganche se elige con la orden MODOB. Para poder utilizar el tentativo con plenas funcionalidades debe estar activado el conmutador VER.

Si se mantiene pulsado el pedal/botón Dato se digitalizan las entidades en modo continuo, de modo que la densidad de puntos está definida por las siguiente variables:

  • INC: distancia entre puntos consecutivos. Se establece bien en el cuadro de diálogo Nuevo Proyecto Digi, o bien con la orden
    • INC.
  • TOL: tolerancia lineal que se aplica si está activa la función de generalización (Conmutador G).
  • TOL_ANG: tolerancia angular que se aplica si está activa la función de generalización (Conmutador G).

Es posible utilizar otras órdenes de digitalización como puede ser ARCO, de forma integrada con el dibujado de líneas. Si se está digitalizando una línea, y se desea insertar un arco, se ejecuta la orden ARCO, se dibuja éste, y se continúa dibujando la línea. Todo ello dentro de la misma entidad lineal, y sin necesidad de hacer tentativos.

Si desea saber algo más lea el tema de la ayuda Dibujar una línea con DigiNG.

Órdenes relacionadas: ARCO, FIN_ENT, G, INC, MODOB, TOL, TOL_ANG VER.

Fecha de última modificación: jueves, 7 de noviembre de 2002


Orden LISTA

Sirve para obtener información acerca de las entidades. Al ejecutar la orden, DigiNG solicita que se seleccione una entidad, como se puede observar en la parte inferior izquierda de la pantalla:

y una vez seleccionada muestra la información de la entidad en la ventana acoplable Salida:

La información que se puede mostrar en esta ventana es la siguiente:

  • Archivo: nombre y directorio del archivo de dibujo.

  • Código: código de la entidad seleccionada. Muestra entre corchetes la descripción de dicho código.

  • Coordenadas máximas y mínimas: informa de las coordenadas máximas y mínimas en las que está definida la entidad.

  • Tabla=interna: muestra los atributos de la tabla interna asociados a la entidad. Estos atributos son Número y Código.

  • Entidad: muestra el tipo de entidad (Texto, Línea, y Punto).

  • Puntos: se trata del número de puntos que forman la entidad seleccionada.

  • Atributos: muestra los valores de la entidad en la tabla interna de DigiNG.

  • Listado de coordenadas: muestra las coordenadas X, Y, Z de los puntos que forman la entidad seleccionada. Si se hace doble click con el ratón encima de un punto en la lista, DigiNG centra la visualización del dibujo en dicho punto.

  • Perímetro en el plano: Indica la longitud total de todos los segmentos en el plano que componen la entidad, sea ésta cerrada o no.

  • Perímetro tridimensional: Indica la longitud total de todos los segmentos en el espacio que componen la entidad, sea ésta cerrada o no.

  • Altura: sólo en el caso de entidad de tipo Texto. Indica la altura de texto.

  • Giro: sólo en el caso de entidad de tipo Texto. Indica el ángulo activo.

  • Justificación: sólo en el caso de entidad de tipo Texto. Indica la justificación del texto.

  • Inclinación: sólo en el caso de entidad de tipo Texto. Indica la inclinación del texto.

  • Texto: sólo en el caso de entidad de tipo Texto. Se trata de la cadena de texto escrita.

Al ejecutar la Orden Lista también tendremos la opción de almacenar en un archivo el listado de coordenadas. Para ello escribiríamos por ejemplo:

lista=C:\BRONCHALES\listado1

Indicando así el nombre y directorio del archivo que queremos generar. A continuación seleccionaríamos la entidad correspondiente.

Si el conmutador REPITE está activado, esta orden se autorrepite hasta que el usuario pulse la tecla Esc.

Órdenes relacionadas: REPITE.

Fecha de última modificación: lunes, 28 de Octubre de 2002


Orden LISTA

Digi3D

Orden LISTA_ATRIBUTOS

Sirve para obtener información acerca de los atributos de una entidad seleccionada. Al ejecutar la orden, DigiNG solicita que se seleccione una entidad, como se puede observar en la parte inferior izquierda de la pantalla:

y una vez seleccionada muestra la información de la entidad en la ventana acoplable Salida:

Si el conmutador REPITE está activado, esta orden se autorrepite hasta que el usuario pulse la tecla Esc.

Órdenes relacionadas: LISTA, REPITE.

Fecha de última modificación: lunes, 28 de Octubre de 2002


Órdenes de DigiNG. M

    MARCAR_ATR
    MAXPUNTOS
    MDT
     MDTPC
     MDT_MUEVE_Z
     MENU
     MEZCLAR
     MIDE
     MOD
     MOD_Z
     MODIFICA_VERTICE
     MODOB
     MOVER
     MOVER_Z
     MOVER_Z_V MULTIARCO

Fecha de última modificación: miércoles, 23 de Abril de 2004


Orden MAXPUNTOS

Sirve para establecer el número máximo de puntos que tendrá un tipo de entidad, de tal manera que cuando se alcance dicho número, la entidad se termina automáticamente o se cierra si está activado el interruptor C.

Esta orden se puede ejecutar de dos formas:

  • Tecleando la orden MAXPUNTOS y pulsando la tecla Enter, con lo que aparece el siguiente cuadro de diálogo:

    • donde el programa pide el número de puntos máximo para una entidad.

  • Tecleando la orden MAXPUNTOS=<número> y pulsando la tecla Enter.

Esta orden resulta útil, por ejemplo, para dibujar medianerías de edificios, que son casi siempre de dos puntos. Para ello se escribiría la siguiente línea:

MAXPUNTOS=2

Una vez ejecutada esta orden se puede ver el número de puntos máximo en la barra de herramientas Flags.

Se desactiva esta orden cuando se cambia de código o cuando se introduce como número de puntos máximo igual a cero (0). Se puede cambiar el número de puntos máximo mediante la orden CAMB_MAXPUNTOS.

Órdenes relacionadas: CAMB_MAXPUNTOS

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden MDT

Esta orden sirve para establecer una rejilla por la cual se va a mover el restituidor pudiendo registrar los puntos a los que llega el cursor. Al ejecutar la orden, el programa muestra la siguiente ventana:

donde pide la entidad que actúa como borde de la rejilla y en donde se puede seleccionar la opción de autoregistrar puntos cada cierto tiempo marcado por la orden TIEMPO_ESPERA.

También aquí se puede marcar la casilla Seleccionar límites de exclusión para que el programa tenga en cuenta que, dentro del límite que se selecciona para del modelo digital del terreno, puede haber una o varias entidades cerradas sobre las cuales no queremos que correle el programa. En caso de marcar esta casilla, el programa pedirá seleccionarlos al hacer el Modelo Digital del Terreno.

Fecha de última modificación: lunes, 7 de Julio de 2003


Orden MDTPC

Esta orden se utiliza para generar Modelos Digitales del Terreno por Correlación. Esta orden requiere antes de su ejecución:

  • La restitución de líneas de ruptura del terreno, para que el correlador tenga conocimiento de la cota aproximada de la zona.
  • La delimitación del límite del MDT que se quiera generar, mediante una entidad de tipo lineal cerrada.
  • La definición de las muestras que se quieran eliminar de la correlación, mediante la orden ENTRENAMIENTO.

Lo primero que pide la orden MDTPC cuando comienza a ejecutarse es que se seleccione la línea que hace de límite:

Seleccionado dichaa la línea con los pedales o con el ratón,aparece el cuadro de diálogo de la orden MDTPC:

  • En el campo titulado Geometría de la línea de límite se puede seleccionar el tipo de límite, dependiendo de si ningún vértice está posado en Z o sólo los vértices están posados en Z.
  • En los campos min y max se especifica el rango de Z dentro del cual se encuentran las líneas de ruptura. Todas las líneas que se encuentren dentro de la línea de límite pero que no se encuentren dentro de este rango de coordenadas mínimas y máximas no se tendrán en cuenta como líneas de ruptura.
  • En el campo Distancia entre puntos (en unidades terreno) se puede especificar cada cuántos metros se desea que el programa registre una cota. El programa registrará cotas separadas entre sí por esta distancia aproximadamente y nunca registrará una cota si en su posición se encuentra con algún segmento de alguna línea de ruptura.
  • Permitir que la Z se desplaze xxxxxx veces la distancia entre puntos. Cambiando este parámetro se puede indicar al programa, por ejemplo, que el terreno tiene mucho desnivel y que se puede dar el caso de que si se incrementa 10 metros en XY, la Z puede verse incrementada en 30 metros si se establece este campo a 3. Se puede establecer Semiancho de la imagen de referencia expresado en píxeles o en tanto por ciento con respecto al ancho de la imagen original, permite indicar el ancho en píxeles que tendrá el rectángulo que se correla con un factor piramidal 1:1. Aumentando este parámetro se consigue que el correlador tarde más en realizar su trabajo pero aumentamos la probabilidad de éxito de éste.
  • Tamaño del pixel en micras. Aquí se introduciría el tamaño del pixel del escaneo.
  • Anchos en píxeles de las imágenes de referencia para los diferentes niveles piramidales. Como valores por defecto aparecerán para el nivel piramidal 8, 4 y 1, los valores 16, 16 y 20 respectivamente. Estos valores se podrán variar en caso de que la imagen presente mucha resolución o que el terreno fotografiado presente mucha uniformidad, por ejemplo parcelas con cultivos iguales. Siendo ese el caso, se podría aumentar al valor de 20 a 21 píxeles.
  • Buscar puntos con factor de correlación >=. En este campo se define el factor de correlación mínimo con el que se desea que se efectúen las mediciones. En el siguiente campo se define el número de veces que se desea que se intente la medición de un punto. En el siguiente campo se define el número de píxeles con el se incremente la espiral (en la que se realiza la búsqueda) para cada nuevo intento. Si está marcada la casilla Borrar los puntos que no cumplan esta condición no se almacenarán los puntos que tengan factor de correlación menor del indicado y hayan superado el número de intentos. Si dicha casilla no está marcada, dichos puntos sí se almacenarán.
  • No correlar sobre las muestras de entrenamiento: si se marca esta casilla y se define una categoría (ver orden ENTRENAMIENTO), en el proceso de medición de puntos se tendrá en cuenta dicha muestra. Si el programa detecta que un punto correlado es una muestra, repite la medición según una espiral hasta que considere que el punto no está sobre la muestra. Esta espiral queda definida por el número de veces que se intentará posar en un punto, y por el número de píxeles en los que incrementa la espiral en cada intento. Estos parámetros se definen en esta misma ventana, en el apartado Buscar puntos con correlación. La muestra queda definida por el entrenamiento previo y el tamaño de la muestra que se define en esta ventana.
  • Generar un archivo log sirve para generar un archivo .html que luego se puede visualizar con un navegador web, y que muestra un resumen de la correlación. El nombre de este archivo será el nombre del archivo .BIN sobre el cual se va a generar el MDTPC, añadiéndole al final "_log.html".
  • Visualizar el proceso de correlación. Esta opción sirve para poder ver en tiempo real el proceso de correlación de las imágenes en la pantalla estereoscópica.
 Si quieres ver un ejemplo de este tipo archivo pulsa aquí.

Una vez rellenados todos los campos, se pulsa sobre el botón Calcular. cuando termine de calcular, ya estaría generado el Modelo Digital por Correlación.

Ejecución de la orden MDTPC desde la línea de órdenes.

Para ejecutar esta orden desde la línea de órdenes tendremos que ejecutarla escribiendo MDTPC seguido de los parámetros que se dan a continuación:

[código del límite] [geometría 0,1,2] [z mínima] [z máxima] [distancia máx de despl. en Z] [semiancho 8x 16] [semiancho 4x 16] [semiancho 1x 20] [factor de correl] [oportunidades] [pixeles de incremento en espiral] [1/0 si borrar los puntos que no cumplan la condición] [0/1* si utilizar muestras de entrenamiento] En el caso de poner 1 en el último parámetro tenemos que poner 3 parámetros más: [archivo de muestras de entrenamiento] [tamaño de la muestra en X pixeles (5)] [tamaño de la muestra en Y]

¿Con qué códigos se generan las cotas?

Dependiendo del factor de correlación de cada una de las cotas, el programa les ha asignado un código que podemos ver en la siguiente tabla:

Fact. de correlación | Código asignado a la cota
[0.6-1.0] | 6
[0.4-0.6) | 4
[0.25-0.4) | 2
[0.0-0.25) | 0

¿Por qué no se ven los puntos correlados?

Posíblemente por que no están creados estos códigos en la tabla Digi.tab. Ejecuta la orden DIGI.TAB dentro de DigiNG y crea estos códigos, puntuales y con diferentes colores (se recomienda rojo para el código 0, azul para el código 2, verde para el código 4 y amarillo para el código 6. Así, los puntos con colores oscuros están peor correlados que los puntos con colores claros).

También se puede editar manualmente el archivo Digi.tab, añadiendo estas entradas:

0 1 12 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.0-0.25)"
2 1 09 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.25-0.4)"
4 1 10 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.4-0.6)"
6 1 14 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 "Factor de correlación [0.6-1.0]"

¿Cómo se puede mover un punto mal posado?

Ejecutando la orden MOVER_Z que además de mover un punto en Z, cambia su código por el código activo. Por lo tanto, se recomienda poner como código activo un código que visualmente (por su color) se conozca que está posado correctamente y luego desactivar el flag Ver de DigiNG (para que cuando la orden pida que se seleccione una entidad a mover en Z, no pida después que se confirme por segunda vez). Luego se localiza el punto mal correlado, se efectúa el posado en XYZ correctamente y se pulsa el botón o pedal de Data. La orden con esa única pulsación moverá el punto a su Z correcta y además cambiará el código de éste por el que se tenga activo.

Ejemplo:

cod=6
ver=0
mover_z

¿Cómo se puede mover en Z de una vez una masa de puntos todos ellos elevados o hundidos la misma distancia?

Por ejemplo, si la orden MDTPC tiene que correlar sobre una masa de árboles, éste pondrá las cotas sobre las copas de éstos. Por lo tanto, hay que bajar todas estas cotas una determinada magnitud.
Para ello se pueden seguir los siguientes pasos:
  • Registrar una línea cerrada rodeando todas las cotas que se deseen bajar (o subir) en Z.
  • Ejecutar la orden MOVER_Z_V de DigiNG.
  • Seleccionar la línea que hace de límite.
  • El programa pide que se registre un punto. Se efectúa el posado en la copa de un árbol y se pulsa el botón/pedal de Data.
  • El programa pide que se registre un segundo punto. Se efectúa el posado en el terreno y se pulsa el botón/pedal de Data.

El programa bajará/subirá automáticamente todos los puntos que se encuentren dentro de la línea de límite.

¿Existen más órdenes que puedan ser útiles?

  • Si se desea borrar todas las cotas con un determinado código, y que además estén dentro de una línea de límite ejecuta la orden BORRA_COD_V.
  • Después de realizar cualquier modificación o corrección en el archivo del MDT hay que volver a calcular el MDT, para ello existe la función AUTORECALCULAR_MDT.
  • Si la última vez que se ejecutó la orden MDTPC, éste se equivocó mucho, se puede ejecutar la orden UNDO para deshacer los últimos cambios, y registrar más líneas de ruptura dentro de ese límite para luego volver a ejecutar la orden MDTPC.

Órdenes relacionadas: AUTORECALCULAR_MDT, BORRA_COD_V, DIGI.TAB, ENTRENAMIENTO, MOVER_Z, UNDO.

Fecha de última modificación: jueves, 12 de Septiembre de 2002


Orden MDT_MUEVE_Z

Esta orden se utiliza para activar o desactivar la actualización de la coordenada Z cuando el cursor pase por encima de los Modelos Digitales del Terreno cargados mediante la orden CARGA_MDT.

Para cambiar el estado de la orden, basta con llamarla, o bien escribir:

MDT_MUEVE_Z=1 | Activa la orden.
MDT_MUEVE_Z=0 | Desactiva la orden.
MDT_MUEVE_Z | Cambia el estado de la orden.

Si esta variable está activada, en la barra de herramientas Flags aparecerá el texto MDTz.

Órdenes relacionadas: CARGA_MDT.

Fecha de última modificación: martes, 24 de Septiembre de 2002


Orden MENU

Sirve para acceder al menú de pantalla. Para llamar a esta orden existen dos maneras posibles:

  1. Teclear MENU y pulsar Enter. El sistema mostrará en pantalla el menú accediendo al último submenú consultado.
  2. Teclear MENU=<número submenú> y pulsar Enter. El sistema mostrará en pantalla el menú accediendo al submenú indicado.

Fecha de última modificación: lunes, 17 de Junio de 2002


Orden MEZCLAR

Esta orden se utiliza para mezclar píxeles de zonas comunes a ortofotografías, definiendo el usuario la forma de realizar dicha mezcla.

Al ejecutar la orden aparece la siguiente ventana:

donde se puede elegir tanto el método de mezcla como las imágenes a mezclar.

Los métodos de mezcla que se ofrecen son los siguientes:

  • Media : se calcula y asigna la media de los píxeles de las ortos que coincidan.
  • Mezclar asignando pesos como el inverso de la distancia al centro de la ortofoto : se calcula la media ponderada de forma inversamente proporcional a la distancia al centro de cada ortofoto.
  • Mezclar asignando pesos como el inverso del cuadrado de la distancia al centro de la ortofoto : se calcula la media ponderada de forma inversamente proporcional al cuadrado de la distancia al centro de cada ortofoto.
  • Gana el píxel más cercano al centro de su ortofoto : se asigna directamente el píxel más cercano al centro de su ortofoto. Esta opción considera la geometría, mientras que el resto de opciones de mezcla consideran la radiometría de las imágenes intervinientes en la mezcla.
  • Gana el píxel más claro: asignación directa del píxel más claro.
  • Gana el píxel más oscuro: asignación directa del píxel más oscuro.

Las ortofotografías se deben cargar con la orden CARGA_RASTER, y se deben haber cargado al menos dos. En caso contrario se muestra el siguiente mensaje en la parte inferior derecha de la pantalla:

Órdenes relacionadas: CARGA_RASTER.

Fecha de última modificación: miércoles, 7 de Abril de 2003


Orden MIDE

Sirve para calcular y presentar por pantalla los valores correspondientes a las distancias planas y al azimut existente entre dos puntos.

Al llamar a la orden, el sistema pide al usuario que seleccione los dos puntos entre los que va a calcular los valores antes citados. En primer lugar solicita el primer punto, como se puede observar en la parte inferior izquierda de la pantalla:

Una vez digitalizado el primer punto, se puede ver en la parte inferior izquierda de la pantalla de forma interactiva:

La distancia entre los dos puntos, tanto reducida como geométrica, y los incrementos de coordenadas. Si se digitaliza el segundo punto aparece un globo en la parte inferior derecha de la pantalla:

que informa tanto de las distancia reducida y geométrica entre los dos puntos, como de los correspondientes incrementos de coordenadas.

Los puntos se pueden seleccionar gráficamente con el ratón, o analíticamente por coordenadas con la orden XY.

Órdenes relacionadas: XY.

Fecha de última modificación: jueves, 26 de Septiembre de 2002


Orden MOD

Sirve para modificar el trazado geométrico de una entidad. El usuario ha de dibujar una entidad que represente el nuevo trazado del elemento que quiere modificar, y sin dar por terminada ésta, llamará a la orden MOD. El nuevo tramo dibujado debería engancharse en los puntos apropiados de la entidad a modificar.

Al llamar a la orden, el programa precisa que se especifique la entidad a modificar, como se puede observar en la parte inferior izquierda de la pantalla:

El programa busca en esta entidad los puntos más próximos al primero y último de la entidad modificadora, y sustituye el tramo comprendido entre dichos puntos por los puntos de la entidad modificadora.

En el proceso de sustitución, la cota de los puntos de la entidad modificadora se ajusta a la de la entidad modificada. Si no desea modificar las cotas utilice la orden MOD_Z.

Con independencia del código utilizado al dibujar la entidad modificadora, éste se cambia por el de la entidad modificada.

Esta orden permite "arreglar" curvas de nivel que se corten. El usuario sólo tiene que dibujar el tramo de la curva que quiere modificar. Este proceso es más rápido que el utilizar la orden EDITAR, ya que ésta requiere modificar los vértices de interés de uno en uno.

En el caso de que se ejecute esta orden sin que se esté dibujando una línea, emerge el siguiente globo:

que informa al usuario de la razón por la que no se ejecuta esta orden.

Órdenes relacionadas: EDITAR, MOD_Z.

Fecha de última modificación: martes, 18 de Junio de 2002


Orden MOD_Z

Sirve para modificar el trazado geométrico de una entidad. El usuario ha de dibujar una entidad que represente el nuevo trazado del elemento que quiere modificar, y sin dar por terminada ésta, llamará a la orden MOD_Z. El nuevo tramo dibujado debería engancharse en los puntos apropiados de la entidad a modificar.

Esta orden es idéntica a la orden MOD, con la diferencia que dicha orden modifica las cotas de la entidad, y la orden MOD_Z no las modifica.

Al llamar a la orden, el programa precisa que se especifique la entidad a modificar, como se puede observar en la parte inferior izquierda de la pantalla:

El programa busca en esta entidad los puntos más próximos al primero y último de la entidad modificadora, y sustituye el tramo comprendido entre dichos puntos por los puntos de la entidad modificadora.

Si desea ajustar las cotas de la entidad modificadora a las cotas de la entidad modifica utilice la orden MOD_Z .

Con independencia del código utilizado al dibujar la entidad modificadora, éste se cambia por el de la entidad modificada.

Esta orden permite "arreglar" curvas de nivel que se corten. El usuario sólo tiene que dibujar el tramo de la curva que quiere modificar. Este proceso es más rápido que el utilizar la orden EDITAR, ya que ésta requiere modificar los vértices de interés de uno en uno.

En el caso de que se ejecute esta orden sin que se esté dibujando una línea, emerge el siguiente globo:

que informa al usuario de la razón por la que no se ejecuta esta orden.

Órdenes relacionadas: EDITAR, MOD.

Fecha de última modificación: martes, 18 de Junio de 2002


Orden MODIFICA_VERTICE

Se utiliza para modificar la posición de un vértice en una entidad lineal. Al llamar la orden, podremos ver en la parte inferior de la pantalla nos pide seleccionar el vértice que deseamos mover:

Al seleccionar la entidad y aceptar la selección, el cursor queda enganchado y el programa pedirá posar el vértice en la nueva posición:

El usuario tiene la posibilidad de mover el vértice a la posición deseada.

Órdenes relacionadas: EDITAR, INSERTAR_VERTICE, EDITAR_XYZ, EDITAR_Z, REPITE.

Fecha de última modificación: 29 de enero de 2004


Orden MODOB

Sirve para establecer el modo de búsqueda o enganche gráfico a elementos del dibujo. El ámbito de búsqueda de una entidad está determinado por el tamaño del cursor y el factor de zoom de pantalla.

Esta orden se puede ejecutar de dos maneras diferentes:

  • Tecleando MODOB, y pulsando la tecla Enter. Entonces aparece la siguiente ventana:

    • donde se puede seleccionar el modo de búsqueda, y luego se pulsa sobre el botón Aceptar.

  • Se puede teclear MODOB=<tipo modo búsqueda>, con lo que se asigna directamente el tipo de búsqueda. Un ejemplo de esta forma de ejecutar la orden puede ser:
    • MODOB=5

    por lo que este ejemplo establece como modo de búsqueda la Proyección en XZY.

El modo de búsqueda activo se puede visualizar en la barra de herramientas Tentativo.

Las modalidades de enganche son las siguientes:

  • 0. Vértice o proyección en XY: la función trata de encontrar los vértices de la entidad, si no encuentra ninguno en su ámbito de búsqueda, calcula la proyección del punto (correspondiente a la posición del cursor) sobre el segmento de la entidad que se encuentre en este ámbito. El enganche se realiza en coordenadas X, Y sobre la proyección calculada. El elemento que se engancha toma estas coordenadas planimétricas pero mantiene su cota.

  • 1. Proyección en XY: la función ignora los vértices de la entidad, y sólo calcula las proyecciones sobre sus segmentos componentes. Se toma como punto proyectado, aquel que se encuentre dentro del ámbito de búsqueda. El enganche se realiza en coordenadas X, Y sobre este punto (igual en que el caso anterior).

  • 2. Vértices extremos de la entidad en XYZ: la función sólo considera los vértices primero y último de las entidades. Por tanto, el enganche se realizará únicamente con uno de los extremos de la entidad, y en coordenadas X, Y, Z.

  • 3. Vértice o proyección en XYZ: igual que el modo 0 pero se engancha también en Z.

  • 4. Vértice en XYZ: se busca el vértice de la entidad más próximo y se engancha con él en X, Y, Z.

  • 5. Proyección en XYZ: igual que el modo 1 pero se engancha en X, Y, Z.

  • 6. Vértices extremos si coincide la Z: se engancha en X, Y, Z al vértice extremo más próximo de una entidad siempre y cuando la Z actual sea igual a la del vértice. Esto es útil para restitución ya que obliga a que se tenga la misma Z al engancharse a una curva de nivel ya existente. De esta forma, nos obligará a llevar activo el interruptor Z_fija al querernos enganchar, o nos permitirá descubrir si la curva existente fue hecha con el interrruptor Z_fija activo. En los aparatos analíticos cuando fijamos una Z con Z_fija el sistema nos buscará, dentro del ámbito de búsqueda del cursor, la curva de nivel que tenga esa Z, y engancharemos en uno de los extremos de esa curva.

  • 7. Dos puntos: 1º XY, 2º Z: cuando se selecciona un modo de búsqueda 7, se toman las coordenadas X,Y del último punto registrado, como coordenadas planimétricas para el siguiente punto de datos. La coordenada Z será el valor de Z cuando se de el punto. No hay que indicar ninguna entidad. Suele utilizarse para realizar volúmenes.

  • 8. XYZ en el punto medio del segmento: se engancha en X, Y, Z en el punto medio del segmento donde se halla seleccionado con el cursor.

  • 9. Vértice en XY: igual que el modo 2 pero tomando sólo las coordenadas X, Y del vértice más próximo. El valor de Z se toma del valor de la Z actual.

  • 10. Vértices extremos de la entidad en XY: igual que el modo 2 pero tomando sólo las coordenadas X, Y del vértice más próximo. El valor de Z se toma del valor de la Z actual.

  • 11. Intersección: la función busca el punto intersección de dos entidades.
    •
  • 12. Busca la Z: la función busca la Z que lleva el operador en la línea en la que se está realizando el tentativo. Es muy útil para hacer pasar una curva de nivel por ríos, caminos, etc...

Fecha de última modificación: lunes, 22 de Julio de 2002


Orden MOVER

Sirve para cambiar la posición planimétrica de un elemento. El usuario ha de realizar los siguientes pasos:

  • Seleccionar la entidad a desplazar, como se puede ver en la parte inferior izquierda de la pantalla:

  • Indicar un punto destino en el dibujo:

La entidad se moverá desde el punto donde se seleccionó la entidad hasta el punto destino.

Fecha de última modificación: martes, 18 de Junio de 2002


Orden MOVER_Z

Permite cambiar la cota de una entidad a la cota actual. Antes de ejecutar la orden se debe estar posado en la cota deseada. Ejecutada la orden, el programa pide que se seleccione la entidad a cambiar la cota:

una vez seleccionada, mueve la cota de la entidad a la cota actual.

Esta orden también cambia el código por el código activo, por lo que una buena secuencia es:

COD=020101
VER=0
MOVER_Z

con lo que se cambia al código 020101, después desactiva la variable VERIFICA con la orden VER, para que no haga tentativo y no haya que pulsar dos veces sobre Data. Y por último se ejecuta la orden MOVER_Z.

Si hay cargada una Triangulación de un Modelo Digital del Terreno (MDT), se puede modificar con esta orden la cota de los puntos de la triangulación.

Órdenes relacionadas: MOVER_Z_V, VER.

Fecha de última modificación: jueves, 6 de Junio de 2002


Orden MOVER_Z_V

Permite cambiar la cota de entidades situadas dentro de una entidad cerrada. Antes de ejecutar la orden se debe dibujar dicha entidad cerrada que servirá de límite. Ejecutada la orden, el programa pide que se seleccione la entidad a cambiar la cota:

una vez seleccionada, aparece la siguiente ventana:

donde se puede seleccionar el tipo de entidad para el que se desea modificar su cota. Por ejemplo, puede interesar cambiar la cota de las líneas y de los puntos, y no modificar la cota de los textos. Seleccionados los tipos de entidades deseados, se pulsa sobre el botón Mover, y el programa solicita que se efectúe un posado en la cota donde están los puntos a cambiar:

y después pide que se realice un posado en la nueva cota:

Hecho este último posado, se modifican las cotas de las entidades (según el tipo seleccionado) que están dentro de la entidad cerrada.

Órdenes relacionadas: MOVER_Z.

Fecha de última modificación: jueves, 6 de Junio de 2002


Orden MULTIARCO

Esta orden sirve para dibujar arcos de forma consecutiva y unidos entre sí, de tal forma que el último punto de un arco y el primero del siguiente arco sea el mismo. La orden ARCO solamente dibuja un arco, y con la orden MULTIARCO se pueden dibujar varios enlazados.

En primer lugar pide que se digitalice el primer punto, como se puede observar en la parte inferior izquierda de la pantalla:

Luego solicita el punto central del arco:

y el último punto:

A continuación solicita el punto central y el último punto para el segundo arco. Y así consecutivamente hasta que se pulse la tecla Esc.

Órdenes relacionadas: ARCO.

Fecha de última modificación: martes, 12 de Noviembre de 2002


Órdenes de DigiNG. N

    N
    NDEC
    NUEVA_VENTANA
    NUEVO_PROYECTO

Fecha de última modificación: lunes, 13 de Octubre de 2003


Orden N

Se utiliza para activar como dispositivo de entrada el fichero ASCII especificado en la pantalla de inicio de DigiNG o mediante la orden FICHERO_P. Cada línea del fichero contiene los datos de un punto, separados entre sí por comas o espacios en blanco:

  1. Primer dato: (número del punto) contiene un número entero que sirve para identificar de forma unívoca cada uno de los puntos del fichero.
  2. Segundo dato: contiene un número real que representa la coordenada X.
  3. Tercer dato: contiene un número real que representa la coordenada Y.
  4. Cuarto dato: es opcional, y se utiliza para almacenar el valor de la coordenada Z.

Para llamar a la orden sólo hay que escribir su nombre, N, y pulsar la tecla Enter. Entonces aparece la siguiente ventana:

donde el programa solicita el número del punto que se desea introducir:

El sistema utilizará este valor para posicionarse automáticamente en las coordenadas del punto.

En el caso de que se pida un punto que no exista en el fichero, lo advierte mediante el siguiente mensaje:

La orden se ejecuta en modo repetición si está activo el estado del conmutador REPITE, en este caso el programa pide continuamente un número o intervalo de puntos. Mientras la orden está activa, el sistema no admite ningún dato procedente del restituidor o del ratón, ya que la entrada de datos está dirigida exclusivamente al fichero.

Para finalizar el proceso y restaurar los dispositivos de entrada propios del sistema, el usuario ha de pulsar la tecla Esc, o pulsar sobre el botón Cancelar.

Al salir de esta orden, el sistema se queda en modo grabación o registro. Si se quiere finalizar la entidad que se estuviera dibujando con los puntos llamados por esta orden, habría que llamar a la orden FIN_ENTIDAD o pulsar la tecla a la cual se tenga asignada (normalmente la barra espaciadora).

Órdenes relacionadas: CARGA_P, FICHERO_P.

Fecha de última modificación: viernes, 25 de Septiembre de 2003


Orden NDEC

Sirve para fijar el número de decimales que van a aparecer en los textos numéricos utilizados para indicar valores de coordenadas X Y Z, distancias, superficies, etc. La llamada a la orden admite las modalidades siguientes:

  1. Escribir NDEC y pulsar Enter. El sistema pide al usuario el número de decimales deseado.
  1. Escribir NDEC=<número> y pulsar Enter. En este caso el número de decimales viene determinado por número.

  2. Escribir NDEC=? y pulsar Enter. El sistema muestra al usuario el número de decimales activo, mediante u globo en la parte inferior derecha de la pantalla:

Fecha de última modificación: martes, 18 de Junio de 2002


Orden NUEVO_PROYECTO

Sirve para abrir otro fichero de dibujo, pero no cierra el fichero actual. Al ejecutar la orden aparece el cuadro de diálogo Nuevo Proyecto, donde se define el archivo a abrir o a crear.

Fecha de última modificación: martes, 18 de Junio de 2002


Órdenes de DigiNG. O

    OFF
    OFFS
    OFF_GUID
    ON
    ONS
    ON_GUID
    ORDENA_POR_CODIGO
    ORDENA_POR_CODIGO_N
    ORDENA_POR_DIGI_TAB
    ORIGEN_GLOBAL
    ORTO
    ORTO_AA

Fecha de última modificación: sábado, 10 de Mayo de 2003


Orden OFF

Sirve para desactivar el código (o códigos) que no se desea visualizar en el dibujo (en DigiNG). En el caso de que se quiera desactivar la visualización en la pantalla de visión estereoscópica, se puede emplear bien la orden OFFD o bien la orden OFFS. Para indicar el código se puede utilizar el carácter comodín *, que sirve para sustituir cualquier cadena de caracteres. Por ejemplo:

OFF=020123

desactiva los elementos dibujados con dicho código, mientras que:

OFF=02*

desactiva los elementos dibujados con cualquier código que empiece por 02. Por ejemplo: 020123, 020124, 020125, 020126, 020127, etc...

Otra forma de desactivar un código es hacerlo en el editor de códigos.

Es posible dibujar con un código que esté desactivado. Pero cada vez que se regenere el dibujo, las entidades realizadas con este código no se visualizarán.

Sólo se pueden desactivar los códigos que se encuentren en el fichero de definición de códigos (con extensión .tab).

El estado de activación o desactivación de los códigos permite controlar el efecto de algunas ordenes de edición, que se aplican únicamente sobre las entidades con códigos activados.

Órdenes relacionadas: OFFD, OFFS, ON, OND, ONS.

Fecha de última modificación: jueves, 24 de Octubre de 2002


Orden OFFD

Sirve para desactivar el código (o códigos) que no se desea visualizar en el dibujo, tanto en DigiNG como en la pantalla de visualización esterescópica. Para indicar el código se puede utilizar el carácter comodín *, que sirve para sustituir cualquier cadena de caracteres. Por ejemplo:

OFFD=020123

desactiva los elementos dibujados con dicho código, mientras que:

OFFD=02*

desactiva los elementos dibujados con cualquier código que empiece por 02. Por ejemplo: 020123, 020124, 020125, 020126, 020127, etc...

Es posible dibujar con un código que esté desactivado. Pero cada vez que se regenere el dibujo, las entidades realizadas con este código no se visualizarán.

Sólo se pueden desactivar los códigos que se encuentren en el fichero de definición de códigos (con extensión .tab).

El estado de activación o desactivación de los códigos permite controlar el efecto de algunas ordenes de edición, que se aplican únicamente sobre las entidades con códigos activados.

Órdenes relacionadas: OFF, OFFS, ON, OND, ONS.

Fecha de última modificación: jueves, 24 de Octubre de 2002


Orden OFFS

Sirve para desactivar el código (o códigos) que no se desea visualizar en la pantalla de visión estereoscópica. En el caso de que se quiera desactivar la visualización en el dibujo (en DigiNG), se puede emplear bien la orden OFF o bien la orden OFFD. Para indicar el código se puede utilizar el carácter comodín *, que sirve para sustituir cualquier cadena de caracteres. Por ejemplo:

OFFS=020123

desactiva los elementos dibujados con dicho código, mientras que:

OFFS=02*

desactiva los elementos dibujados con cualquier código que empiece por 02. Por ejemplo: 020123, 020124, 020125, 020126, 020127, etc...

Es posible dibujar con un código que esté desactivado. Pero cada vez que se regenere el dibujo, las entidades realizadas con este código no se visualizarán.

Sólo se pueden desactivar los códigos que se encuentren en el fichero de definición de códigos, con extensión .tab.

El estado de activación o desactivación de los códigos permite controlar el efecto de algunas ordenes de edición, que se aplican únicamentesobre las entidades con códigos activados.

Órdenes relacionadas: OFF, OFFD, ON, OND, ONS.

Fecha de última modificación: jueves, 24 de Octubre de 2002


Orden OFF_GUID

Sirve para desactivar la visualización de la entidad que tenga asignado un determinado GUID. Al hacer la llamada a la orden tenemos que especificar el GUID de la entidad de la que queremos desactivar la visualización. El GUID de una entidad se puede averiguar con la orden EXTRAER_GUID, ya que ésta copia al portapapeles el GUID de la entidad seleccionada.

Un ejemplo para ejecutar la orden sería la siguiente, escribimos: OFF_GUID=aquí pegaríamos el GUID del portapapeles

Órdenes relacionadas: ON_GUID, EXTRAER_GUID, BORRAR_GUID, ASIGNAR_GUID, RESTAURAR_FICHERO.

Fecha de última modificación: martes, 29 de Julio de 2003


Orden ON

Sirve para activar el código (o códigos) que se desea visualizar en el dibujo (en DigiNG). En el caso de que se quiera activar la visualización en la pantalla de visión estereoscópica, se puede emplear bien la orden OND o bien la orden ONS. Para indicar el código se puede utilizar el carácter comodín *, que sustituye cualquier cadena de caracteres. Por ejemplo:

ON=020123

activa los elementos dibujados con dicho código, mientras que:

ON=02*

activa los elementos dibujados con cualquier código que empiece por 02. Por ejemplo: 020123, 020124, 020125, 020126, 020127, etc...

El hecho de que un código esté o no activado influye en el resultado de ciertas ordenes de edición, ya que algunas de ellas sólo consideran las entidades cuyo código este activado.

Órdenes relacionadas: OFF, OFFD, OFFS, OND, ONS.

Fecha de última modificación: jueves, 24 de Octubre de 2002


Orden OND

Sirve para activar el código (o códigos) que se desea visualizar en el dibujo, tanto en la pantalla de visualizacion estereoscópica como en DigiNG. Para indicar el código se puede utilizar el carácter comodín *, que sustituye cualquier cadena de caracteres. Por ejemplo:

OND=020123

activa los elementos dibujados con dicho código, mientras que:

OND=02*

activa los elementos dibujados con cualquier código que empiece por 02. Por ejemplo: 020123, 020124, 020125, 020126, 020127, etc...

El hecho de que un código esté o no activado influye en el resultado de ciertas ordenes de edición, ya que algunas de ellas sólo consideran las entidades cuyo código este activado.

Órdenes relacionadas: OFF, OFFD, OFFS, ON, ONS.

Fecha de última modificación: jueves, 24 de Octubre de 2002


Orden ONS

Sirve para activar el código (o códigos) que se desea visualizar en la pantalla de visión estereoscópica. En el caso de que se quiera activar la visualización en el dibujo (en DigiNG), se puede emplear bien la orden ON o bien la orden OND. Para indicar el código se puede utilizar el carácter comodín *, que sirve para sustituir cualquier cadena de caracteres. Por ejemplo:

ONS=020123

activa los elementos dibujados con dicho código, mientras que:

ONS=02*

activa los elementos dibujados con cualquier código que empiece por 02. Por ejemplo: 020123, 020124, 020125, 020126, 020127, etc...

El hecho de que un código esté o no activado influye en el resultado de ciertas ordenes de edición, ya que algunas de ellas sólo consideran las entidades cuyo código este activado.

Órdenes relacionadas: OFF, OFFD, OFFS, ON, OND.

Fecha de última modificación: jueves, 24 de Octubre de 2002


Orden ON_GUID

Sirve para activar la visualización de la entidad que tenga asignado un determinado GUID, al hacer la llamada a la orden tenemos que especificar el GUID que queremos visualizar. El GUID de una entidad se puede averiguar con la orden EXTRAER_GUID, ya que ésta copia al portapapeles el GUID de la entidad seleccionada.

Un ejemplo para ejecutar la orden sería la siguiente, escribimos: ON_GUID=aquí pegaríamos el GUID del portapapeles

En el caso de que la entidad seleccionada no tenga asociado un GUID, el programa nos avisa.

Órdenes relacionadas: OFF_GUID, EXTRAER_GUID, BORRAR_GUID, ASIGNAR_GUID, RESTAURAR_FICHERO.

Fecha de última modificación: martes, 29 de Julio de 2003


Orden ORDENA_POR_CODIGO

Sirve para ordenar por código las entidades de un fichero, agrupando en el fichero las entidades por el código al que pertenezcan.

Órdenes relacionadas: ORDENA_POR_CODIGO_N.

Fecha de última modificación: martes, 18 de Junio de 2002


Orden ORDENA_POR_CODIGO_N

Sirve para ordenar por código numérico las entidades de un fichero, agrupando en el fichero las entidades por el código numérico al que pertenezcan.

Órdenes relacionadas: ORDENA_POR_CODIGO.

Fecha de última modificación: martes, 18 de Junio de 2002


Orden ORIGEN_GLOBAL

Con esta orden se puede establecer el origen de coordenadas del archivo de dibujo actual en DigiNG. Por defecto el valor de esta variable es (0, 0, 0).

La llamada a esta orden se puede hacer de dos formas:

  • ORIGEN_GLOBAL=, con lo que la precisión se establece a X, Y, Z.
  • ORIGEN_GLOBAL=?, con lo que se muestra el valor actual de esta variable mediante un globo:

Si desea aprender algo más acerca de esta variable, lea el tema de la ayuda Precisión en DigiNG.

Ordenes relacionadas: PRECISION.

Fecha de última modificación: jueves, 1 de Mayo de 2003


Orden ORTO

Se utiliza para activar o desactivar la modalidad de Orto. Si cuando se dibuja está activado, cada segmento que se trace, se fuerza a que sea perpendicular al anterior.

La llamada a la orden se puede realizar de las siguientes formas:

ORTO=1 | Activa la regeneración automática del dibujo.
ORTO=0 | Desactiva la regeneración automática del dibujo.
ORTO | Cambia el estado del contador.

En la barra de herramientas Flags aparece Ort cuando esta función está activada.

Órdenes relacionadas: ORTO_AA.

Fecha de última modificación: miércoles, 17 de Julio de 2002


Orden ORTO_AA

Se utiliza al igual que la orden ORTO para trazar entidades en la que sus tramos son perpendiculares entre sí, pero atendiendo esta vez a la dirección marcada por el ángulo activo. Por lo tanto, habrá que determinar el valor del ángulo activo, mediante la orden AA, antes de llamar a la orden ORTO_AA.

La llamada a la orden se puede realizar de las siguientes formas:

ORTO_AA=1 | Activa la regeneración automática del dibujo.
ORTO_AA=0 | Desactiva la regeneración automática del dibujo.
ORTO_AA | Cambia el estado del contador.

En la barra de herramientas Flags aparece el texto Ort_aa cuando esta función está activada.

Órdenes relacionadas: AA, ORTO.

Fecha de última modificación: miércoles, 17 de Julio de 2002


Orden OSCURECER_ARCHIVOS_REFERENCIA

Se utiliza para oscurecer los archivos de referencia cargados. De esta forma, lo que se esté dibujando en el fichero actual se visualiza mejor respecto del dibujo existente en los ficheros de referencia.

La llamada a la orden se puede realizar de las siguientes formas:

OSCURECER_ARCHIVOS_REFERENCIA=1 | Oscurece la visualización de los ficheros de referencia.
OSCURECER_ARCHIVOS_REFERENCIA=0 | Muestra los ficheros de referencia con el brillo normal
OSCURECER_ARCHIVOS_REFERENCIA | Activa/desactiva el oscurecimiento de los ficheros de referencia.

Una vez ejecutada es necesario ejecutar la orden REGENERA para que se pueda ver el resultado. Esta orden está pensada para realizar las actualizaciones de una forma más cómoda.

El aspecto que presenta el archivo de referencia es el mostrado en la siguiente imagen:

donde se puede ver el archivo de referencia cargado con menos brillo que las entidades que se digitalicen en el archivo actual (la línea blanca).

Órdenes relacionadas: REGENERA.

Fecha de última modificación: martes, 16 de Julio de 2002


Órdenes de DigiNG. P

    P
    PARALELA
    PARAMETROS_IMPORTACION
    PATRON
    PATRONS
    PERP
    PERP_A
    PINTA_PIXEL
    PITA
    PIXEL
    PONE_ALTURA
    PONE_DISTANCIA
    PONER_ATR
    PONER_ATR_R
    PONER_XY
    POSITIVO_NEGATIVO_RASTER
    PRECISION
    PROG
    PUNTEAR
    PUNTO

Fecha de última modificación: sábado, 10 de Mayo de 2003


Orden P

Este interruptor sirve para dibujar una paralela a una entidad lineal automáticamente cuando se termina de registrar la entidad. Si está activado aparece en la barra de herramientas Flags la indicación //.

La llamada a la orden se puede realizar de las siguientes formas:

P=1 | Activa la generación automática de paralelas.
P=0 | Desactiva la generación automática de paralelas.
P | Cambia el estado del contador.

Conviene, en primer lugar, fijar la distancia activa (con la orden DA), con su signo (si es positiva, la paralela saldrá a la derecha en el sentido del avance del dibujo de la entidad, y si es negativa, se dibujará a la izquierda). No obstante, si no se ha establecido el valor de DA antes de llamar a la orden P, se pedirá la distancia activa en este momento, pues no se pueden dibujar paralelas con esta orden cuando el valor de DA es cero.

El proceso es el siguiente:

  • se determina una distancia activa con su signo,
  • se establece el código de la entidad lineal que se va a dibujar,
  • se activa el interruptor P,
  • se inicia el dibujo.
Al terminar de registrar la entidad se dibujará automáticamente una paralela con el mismo código que la entidad dibujada.

Este interruptor se desactiva al cambiar de código activo.

Puede coexistir con otros interruptores, por ejemplo, si está activo el interruptor C, de cerrado automático, al terminar la entidad esta se cerrará, pero además se dibujará la paralela.

Órdenes relacionadas: DA, PARALELA.

Fecha de última modificación: lunes, 1 de Julio de 2002


Orden PARALELA

Dibuja líneas paralelas a una o varias entidades utilizando el código que esté activo en el momento de ejecutar esta orden.

La llamada a la orden se puede realizar de dos formas:

  1. Escribir PARALELA y pulsar Enter. En este caso, el usuario ha de realizar los siguientes pasos:
    • Seleccionar la entidad gráfica, como solicita el programa:

    • Definir la distancia de separación entre la entidad y su paralela. Para determinar esta longitud se puede optar, al igual que en otras órdenes por el método gráfico (indicando dos puntos) o por el numérico (dando el valor de la distancia).

    • Indicar con un punto a qué lado ha de trazarse la paralela (a la derecha o a la izquierda de la entidad),

    La nueva línea se dibujará con el código que se encuentre activo en el momento de ejecutar esta orden. En modo REPITE la orden después de ejecutada vuelve a pedir que se seleccione una entidad y que se dé un punto a un lado, con lo que dibujará de nuevo una paralela a ese lado utilizando la distancia activa que se tenía establecida, y así sucesivamente.

  2. Escribir PARALELA=<código> y pulsar Enter. El programa dibujará paralelas a todas las entidades de código igual al indicado, y a una distancia igual al primer valor de la distancia activa DA. Si el usuario no ha asignado ningún valor a DA, el sistema utiliza por defecto el valor 1.

    3. Las paralelas se dibujarán a la derecha o a la izquierda de la entidad en función del signo correspondiente a la distancia activa DA, a la derecha si es un número positivo, y a la izquierda si es un número negativo. Derecha e izquierda se determinan con respecto al sentido de digitalización u orden de los puntos que componen la entidad.

Esta orden se suele utilizar para el trazado automático de paralelas. El proceso se realiza ejecutando una macro instrucción que contenga todas las especificaciones necesarias a la orden.

Si se quisiera trazar dos paralelas a todas las entidades de código EJE: una paralela a la izquierda con código LIZDA, y otra a la derecha con código LDCHA, y ambas separadas del eje una distancia de 2,5 metros, la macro instrucción contendría estas órdenes:

DA=2.5
COD=LDCHA
PARALELA=EJE
DA=-2.5
COD=LIZDA
PARALELA=EJE

Si el nombre asignado a la macroinstrucción fuera por ejemplo @PAR, bastaría con escribir este nombre en la línea de órdenes para que se ejecutara el proceso.

Órdenes relacionadas: DA.

Fecha de última modificación: martes, 18 de Junio de 2002


Orden PARAMETROS_IMPORTACION

Sirve para especificar los parámetros que se enviarán al importador/exportador correspondiente. De esta forma, no aparecerá el cuadro de diálogo de configuración de importación al importar/exportar un determinado tipo de archivo.

Si se intenta abrir un archivo .dgn (con la orden CARGA_F ), aparece el cuadro de diálogo de configuración donde se especifica la tabla de traducción, factor de transformación, y ciertos valores. Si al usuario no le interesa que aparezca este cuadro de diálogo, se puede especificar estos parámetros a priori desde la línea de órdenes mediante la orden PARAMETROS_IMPORTACION.

La sintaxis de esta orden es la siguiente:

parametros_importacion=[importación/exportación] [extensión] [parámetros
específicos para el importador (entre comillas)]

donde:

  • importación/exportación: cuando se trate de importar, este parámetro debe valer 1. Si se desea exportar debe ser 0.
  • extensión: la correspondiente al archivo a importar/exportar (dgn, ...).
  • parámetros específicos para el importador: deben ir entre comillas.

En el caso de archivos dgn los parámetros específicos para el importador son los siguientes:

[tabla] [factor de escala] [tipo de células] [tipo de códigos] [pattern]
  • tabla: ruta completa de la tabla de traducción.
  • factor de escala: Escala de la transformación. Aquí el concepto escala no es el tradicional, sino que tiene que ver con las unidades que se usen en MicroStation y las que se desee obtener en DigiNG, es decir, si las unidades en MicroStation (UORS) son cm. y se desea que en Digi21 sean también cms., la escala será 1. Si los UORS son mm. y se quieren obtener cm. en DigiNG, la escala será 0.1, y por último, si los UORS son dm. y quieren obtenerse cm. en DigiNG, el valor de la escala será 10.
      1 | DGN en cm. | Digi en cm.
      0.1 | DGN en mm. | Digi en cm.
      10 | DGN en dm. | Digi en cm.
  • tipo de células : puede tomar los valores 1, 2 ó 0 dependiendo de la traducción de las células:
    • 0: Traduce las células como puntos. Convertirá la célula en un elemento puntual, esto es, sólo se toma un punto de esa célula que es el de inserción de la misma, el cuál se recoge en Digi21 igualmente como un punto. En este caso, el programa lo único que hace es mirar la cabecera de la célula que siempre está puesta en el nivel cero y en la cual está el punto de inserción.
      El elemento que clasifica en qué código se pone ese punto es el propio nombre de la célula, es decir, si se tiene una célula que se llama "árbol", ese nombre tiene que estar en la tabla de traducción.
    • 1. Descompone las células en elementos de dibujo. Las células se descompondrán en todos los elementos de que consta, que pueden ser textos, líneas, polilíneas, etc. y pasar todo esto a entidades de dibujo dentro de DigiNG, asignándose cada uno a un número de entidad (según la tabla DGNBIN.TAB) que se corresponderá con un nivel, color, peso, estilo y simbología de MicroStation, o alternativamente, será función del grupo gráfico, según se elija en la siguiente opción.
    • 2: traduce células como símbolos. Convertirá la célula en MicroStation en el símbolo DigiNG que se haya especificado en la tabla DGNBIN.TAB según su nivel, estilo, color, peso o según su grupo gráfico.
  • tipo de códigos: indica si se va a utilizar o no el grupo gráfico. Un elemento en MicroStation se puede clasificar por nivel, estilo, color, peso o por grupo gráfico, y en esta clave tendremos que darle al programa la clasificación que vamos a utilizar. Por ejemplo, se puede decir que los elementos que están en el grupo gráfico 5030 se pasan al código DigiNG. En ese caso, la decodificación de los elementos no se hará mediante el nivel, color, peso y estilo sino por dicho grupo gráfico. La clave_gg puede tomar los siguientes valores:
    • 0: utiliza nivel, color, peso y estilo como traducción.
    • 1: utiliza grupo gráfico para la traducción.
  • pattern: con esta clave tendremos la posibilidad de traducir los pattern lineales de MicroStation. Si se traducen se harán como elementos descompuestos. Puede tomar los siguientes valores:
    • 0: no traduce los pattern.
    • 1: traduce los pattern de MicroStation como elementos descompuestos.

Un ejemplo de llamada a esta orden puede ser el siguiente:

parametros_importacion=1 dgn "c:\tablas\prueba.tab 1.0 1 1 0"

También es posible desactivar los parámetros asociados con alguna extensión, llamando a esta orden con la siguiente sintaxis:

parametros_importacion=[importación/exportación] [extension]

Fecha de última modificación: 23 de Abril de 2004


Orden PATRON

Es un conmutador que activa y desactiva la visualización en pantalla de los patrones de línea en el fichero de dibujo.

Cuanto está activado, DigiNG utiliza la información del fichero DIGI.TAB para visualizar las líneas con la simbología de ploteo.

Admite tres formas posibles de utilización:

PATRON=1 | Activa los patrones.
PATRON=0 | Desactiva los patrones.
PATRON | Conmuta.

Órdenes relacionadas: PATRONS.

Fecha de última modificación: jueves, 18 de Julio de 2002


Orden PATRONS

Es un conmutador que activa y desactiva la visualización en pantalla de los patrones de línea en la pantalla de visualización estereoscópica.

Cuanto está activado, DigiNG utiliza la información del fichero DIGI.TAB para visualizar las líneas con la simbología de ploteo.

Admite tres formas posibles de utilización:

PATRONS=1 | Activa los patrones.
PATRONS=0 | Desactiva los patrones.
PATRONS | Conmuta.

Órdenes relacionadas: PATRON.

Fecha de última modificación: jueves, 18 de Julio de 2002


Orden PERP

Sirve para el trazado de líneas perpendiculares a una entidad de dibujo. La secuencia de acciones a realizar en esta orden es la siguiente:

  • Selección de la entidad. El trazado de perpendiculares se realizará solamente con respecto al segmento utilizado en la elección del elemento. El modo de búsqueda que debería utilizarse para la selección de la entidad será uno que se enganche en la proyección sobre el segmento y no en vértices.

  • Indicación del punto a partir del cual y hasta su intersección con la entidad anterior, se dibujará una línea perpendicular a esta última:

Esta orden comienza a registrar una nueva entidad cuyo primer vértice se encuentra sobre la entidad seleccionada y su segundo vértice en el punto señalado a continuación.

Esta orden se autorrepite si está activado el conmutador REPITE .

Órdenes relacionadas: PERP_A, REPITE .

Fecha de última modificación: martes, 18 de Junio de 2002


Orden PERP_A

Dibuja segmentos perpendiculares a una entidad dada. El sistema solicita:

  • Entidad a la cual van a ser perpendiculares los segmentos, como se puede ver en la parte inferior izquierda de la pantalla:

  • Y pide un punto desde el cuál nos trazará la perpendicular a la entidad seleccionada:

El programa pide puntos para dibujar los segmentos hasta que el usuario pulsa la tecla Esc, independientemente del estado del conmutador REPITE.

Si la orden se ejecuta sin pasarle ningún parámetro, la línea que se genera tendrá la cota del punto desde el que se traza la perpendicular. Si a la orden se le pasa como parámetro la unidad, es decir, se ejecuta del siguiente modo:

PERP_A=1

el programa asigna a la línea perpendicular las siguientes cotas:

  • En el extremo correspondiente al punto desde el que se traza la perpendicular, se asigna la cota de dicho punto.
  • En el otro extremo se asigna la cota correspondiente a la entidad hacia la que se traza la perpendicular.
Órdenes relacionadas: PERP , REPITE .

Fecha de última modificación: miércoles, 11 de Diciembre de 2002


Orden PINTA_PIXEL

Esta orden sirve para pintar un píxel o varios de un color. Este color bien se define mediante la orden COLOR_PIXEL, o bien se selecciona con la orden CUENTAGOTAS. El número de píxeles a pintar está determinado por el valor de CURSOR.

Al ejecutar la orden se pide al usuario que pinte en una imagen, como se puede observar en la parte inferior izquierda de la pantalla:

y al pintar sobre la imagen se pintan los píxeles del color seleccionado.

En DigiNG está definido el color blanco como transparente, para así facilitar la visualización de imágenes superpuestas. Para ello, hay que tener en cuenta que en el cuadro de diálogo correspondiente a las imágenes de color verdadero, el color que DigiNG considera transparente es el (255,255,255) de la terna (Rojo, Verde, Azul). Si las imágenes cargadas son de niveles de gris el color que DigiNG considera transparente es el 255, situado en la esquina superior izquierda en el cuadro correspondiente. Dichos cuadros de diálogo aparecen al ejecutar la orden COLOR_PIXEL.

Esta orden se autorrepite, independientemente del estado del conmutador REPITE. Para finalizar la ejecución de esta orden se debe pulsar la tecla Esc.

En el caso de que se ejecute la orden sin que haya imágenes cargadas se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CURSOR, CUENTAGOTAS, CURSOR, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: jueves, 22 de Agosto de 2002


Orden PITA

Sirve para activar o desactivar las señales acústicas. Admite tres formas posibles de utilización:

PITA=1 | Activa el pitido.
PITA=0 | Desactiva el pitido.
PITA | Conmuta.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden PIXEL

Informa, con un cuadro de mensajes, del tamaño, en unidades del terreno, que le corresponde a un píxel de la imagen raster en la posición indicada por el cursor. La imagen raster debe haber sido georeferenciada con orientación interna y externa previamente, para poder realizar el cálculo.

Esta orden permite calcular un tamaño apropiado para el pixel, en unidades terreno, para realizar un proceso de ortorectificación.

Fecha de última modificación: viernes, 22 de Agosto de 2003


Orden PONE_ALTURA

Sirve para colocar un texto con el valor de cota activo, es decir, el valor actual de Z.

El texto se situará con justificación inferior izquierda sobre el punto de dato que se indique con el cursor. El texto tendrá como ángulo de orientación, altura y ángulo de inclinación los valores que se encuentren activos en las variables AA, AT e JT, respectivamente. El número de decimales que aparecerán en el texto será el determinado por la orden NDEC.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: AA, AT, JT, NDEC, PONE_DISTANCIA, REPITE.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden PONE_DISTANCIA

Sirve para colocar un texto con el valor de la distancia entre dos puntos. Al llamar a la orden el programa solicita el primer punto:

y digitalizado éste, pide el segundo:

El texto se situará con justificación inferior izquierda sobre el punto de dato que se indique con el cursor. El texto tendrá como ángulo de orientación, altura y ángulo de inclinación los valores que se encuentren activos en las variables AA, AT e IT, respectivamente. El número de decimales que aparecerán en el texto será el determinado por la orden NDEC.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: AA, AT, IT, NDEC, PONE_ALTURA, REPITE.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden PONER_ATR

Esta orden se utiliza para asignar a entidades los atributos que están actualmente en memoria. Al llamar a la orden el programa pide al usuario que seleccione las entidades a las que desea asignar los atributos, como se puede observa en la parte inferior izquierda de la pantalla:

En el caso de llamar a esta orden sin tener atributos en memoria se muestra el siguiente mensaje:

que informa al usuario de que no existen actualmente atributos en memoria para poder asignarlos a entidades.

Esta orden se autorrepite en el caso de que se encuentre activo el conmutador REPITE.

órdenes relacionadas: ALTA, ALTA_DUP, BASE_DATOS, BORRA_ATR, CLONAR_ATRIBUTOS, QUITAR_ATRIBUTOS.

Fecha de última modificación: lunes, 28 de Octubre de 2002


Orden PONER_XY

Sirve para colocar dos textos numéricos con los valores de las coordenadas X Y de los puntos seleccionados por el usuario. Esta orden se utiliza para rotular las coordenadas de las cruces de la cuadrícula utilizada en un fichero de dibujo.

Al llamar a la orden, el sistema pide al usuario que indique el punto cuyas coordenadas van a ser rotuladas.

Los textos de las coordenadas se colocan con un ángulo de 90º uno respecto del otro, y se insertan en la misma posición del punto elegido, o desplazados de este un valor igual al de la primera distancia activa. Los parámetros con los que se registrarán estos textos se corresponden con los valores de:

  • código (COD),
  • ángulo activo (AA),
  • altura de texto (AT),
  • inclinación de texto (JT),
  • distancia activa (DA),
  • número de decimales (NDEC),

que se hallen activos en el momento de llamar a la orden.

Fecha de última modificación: 24 de Mayo de 2004


Orden POSITIVO_NEGATIVO_RASTER

Esta orden sirve para alternar la visualización del positivo y del negativo de la imagen cargada.

En el caso de que se ejecute la orden POSITIVO_NEGATIVO_RASTER sin que haya ninguna imagen cargada, se indica al usuario esta cuestión:

En el caso de que se ejecute esta orden y haya varias imágenes cargadas, aparece la siguiente ventana:

donde se pide al usuario que seleccione la imagen (o las imágenes) que desea alternar su visualización.

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: lunes, 22 de Julio de 2002


Orden PRECISION

Con esta orden se puede elegir la precisión interna con la que trabaja DigiNG. Se indican el número de decimales, y por defecto el valor de esta variable es 2.

La llamada a esta orden se puede hacer de dos formas:

  • PRECISION=, con lo que la precisión se establece a valor.
  • PRECISION=?, con lo que se muestra el valor actual de esta variable mediante un globo:

Si desea aprender algo más acerca de esta variable, lea el tema de la ayuda Precisión en DigiNG.

Ordenes relacionadas: ORIGEN_GLOBAL.

Fecha de última modificación: jueves, 1 de Mayo de 2003


Orden PROG

Sirve para ejecutar otros programas (que no pertenecen al programa DigiNG) desde el entorno de trabajo. La llamada a la orden se realiza tecleando PROG=<nombre de programa>, y pulsando la tecla Enter. Entoces DigiNG ejecutará directamente el programa, y se retorna al entorno de trabajo de DigiNG cuando se finalice la ejecución de dicho programa.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden PROYECTA_ENTRE_CURVAS

Esta orden sirve para proyectar en Z puntos contenidos entre dos entidades lineales. Al ejecutar la orden el programa solicita al usuario que seleccione la primera línea:

y después solicita la segunda:

Entonces el programa comienza a calcular la triangulación correspondiente a los puntos que forman ambas líneas, y una vez generada, proyecta sobre ella las entidades puntuales que se encuentren entre el par de líneas seleccionado.

Además, el punto cambia su código por el activo en el momento de llamar a la orden.

Fecha de última modificación: miércoles, 11 de Diciembre de 2002


Orden PUNTEAR

Se utiliza para rellenar el interior de una entidad superficial de contorno cerrado con una trama de puntos. La disposición de los puntos depende de los valores que tengan asignados los parámetros AA (ángulo activo) y DA (distancia activa). Si no se ha realizado ninguna asignación previa, el sistema toma por defecto los valores cero y uno para AA y DA respectivamente.

La situación de los puntos coincidiría con las intersecciones de las rayas que se hubiesen obtenido al llamar a la orden TRAMAR, de forma que podemos distinguir dos conjuntos de puntos. El primer conjunto sigue la dirección del ángulo activo, y los puntos se hayan separadas una distancia igual al primer valor de la distancia activa. El segundo conjunto sigue una dirección perpendicular al primero, y sus puntos están separadas una distancia igual al segundo valor de la distancia activa.

La llamada a la orden se puede realizar de dos formas:

  1. Escribir PUNTEAR y pulsar la tecla [ENTER]. En este caso el sistema pide que se seleccione la entidad a puntear. La orden se ejecuta en modo repetición, de forma que el usuario puede puntear todas las entidades que desee, finalizando el proceso al pulsar la tecla [ESC].

  2. Escribir PUNTEAR=<código> y pulsar [ENTER]. En este caso el sistema punteará todas las entidades superficiales (cerradas) cuyo código coincida con el especificado en la llamada a la orden.

Los puntos de la trama se representan con el código que estuviera activo al llamar a la orden. El código activo debe ser un código de entidad puntual.

Órdenes relacionadas: SIMB, RAYAR, TRAMAR.

Fecha de última modificación: 11 de Mayo de 2004


Orden PUNTO

Sirve para dibujar un punto en el archivo actual, aunque no es necesario ejecutar esta orden para dibujar un punto, pues basta con seleccionar un código definido para una entidad puntual, y pulsar sobre Data para dibujar un punto.

Esta orden sirve para dibujar un punto con una entidad definida como lineal.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Órdenes de DigiNG. Q

    QUITAR_ATRIBUTOS

Fecha de última modificación: viernes, 25 de Octubre de 2002


Orden QUITAR_ATRIBUTOS

Esta orden elimina los atributos actualmente en memoria.

Órdenes relacionadas: ALTA, ALTA_DUP, BASE_DATOS, BORRA_ATR, CLONAR_ATRIBUTOS. PONER_ATR,

Fecha de última modificación: lunes, 28 de Octubre de 2002


Órdenes de DigiNG. R

    RANGO_Z
    RATON
    RATON_DIGI3D
    RAYAR
    RECUPERA
    RECUPERA_COD
    REGENERA
    RELLENA_COLOR
    RELLENAR
    RENOMCOD
    REPITE
    RESTAURAR_FICHERO
    RETRIANGULAR
    ROTULA_CURVAS
    ROTULA_T
    ROTULA_Z
    R_TEXTO

Fecha de última modificación: martes, 22 de Octubre de 2002


Orden RANGO_Z

Esta orden sirve para visualizar sólo aquellas entidades que están dentro de un determinado rango de cota. Ejecutando esta orden aparece la siguiente ventana, donde el sistema pide la Z mínima y la Z máxima:

La primera vez que se ejecute esta orden aparecerán por defecto las cotas que se pueden ver en la imagen, que corresponden a las cotas mínima y máxima que se pueden establecer en DigiNG.

El botón Defecto sirve para establecer como Z mínima y máxima de visualización dichos valores límite, con lo que se visualizarán todas las entidades existentes en el fichero.

Después de ejecutar a esta orden hay que refrescar la visualización del fichero de dibujo mediante la orden REGENERA, y así actualizar la información de la pantalla.

Órdenes relacionadas: REGENERA.

Fecha de última modificación: martes, 1 de Octubre de 2002


Orden RATON

Sirve para establecer el ratón como unidad de entrada de datos al programa. Si se está manejando Digi3D con manivelas y pedales, e interesa manejar DigiNG mediante el ratón del ordenador, se ejecuta esta orden para asociar al ratón como entrada de datos.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden RATON_DIGI3D

Esta orden permite mover la pantalla estereoscópica con el ratón, es decir, establece como dispositivo de entrada el ratón.
Si el ratón tiene rueda al mover esta moveremos el restituidor en Z.

Esta orden no admite parámetros. Si el ratón no está moviendo el restituidor y la ejecutamos, pasa a moverlo y si lo está moviendo y la ejecutamos deja de moverlo, esto es funciona como un conmutador.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden RAYAR

Se utiliza para rayar el interior de una entidad superficial de contorno cerrado. El tramado de rayas depende de los valores que tengan asignados los parámetros AA (ángulo activo) y DA (distancia activa). Si no se ha realizado ninguna asignación previa, el sistema toma por defecto los valores cero y uno para AA y DA respectivamente.

La dirección de las rayas está condicionada por el ángulo activo, y se hayan separadas una distancia igual al primer valor de la distancia activa.

La llamada a la orden se puede realizar de dos formas:

  1. Escribir RAYAR y pulsar la tecla [ENTER]. En este caso el sistema pide que se seleccione la entidad a rayar. La orden se ejecuta en modo repetición, de forma que el usuario puede tramar todas las entidades que desee, finalizando el proceso al pulsar la tecla [ESC].

  2. Escribir RAYAR=<código> y pulsar [ENTER]. En este caso el sistema rayará todas las entidades superficiales (cerradas) cuyo código coincida con el especificado en la llamada a la orden.

El tramado de rayas se realiza con el código que estuviera activo al llamar a la orden.

Órdenes relacionadas: SIMB, PUNTEAR, TRAMAR.

Fecha de última modificación: 11 de Mayo de 2004


Orden RECUPERA

Una vez activada la orden BORRADOS, permite recuperar los elementos marcados con la señal de borrado en el fichero de dibujo.

Al ejecutar la orden, el programa solicita que se seleccione el elemento que se quiere recuperar, como se puede ver en la parte inferior izquierda de la pantalla:

Una vez seleccionada la entidad, se le quita la marca de borrado a la entidad.

Si está activada la modalidad REPITE se podrán seleccionar entidades hasta que se pulse la tecla Esc.

Órdenes relacionadas: BORRADOS, COMPRIMIR, RECUPERA_COD, REPITE.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden RECUPERA_COD

Sirve para recuperar todas aquellas entidades borradas que tengan un código igual al tecleado por el usuario.

La llamada a la orden se realiza escribindo RECUPERA_COD=<código> <tipo de entidad> y pulsando la tecla Enter. Donde tipo de entidad puede ser

c | Entidades gráficas (puntos y líneas).
l | Sólo entidades lineales.
p | Sólo entidades puntuales.
t | Sólo textos.
b | Para bitmaps (fotos).
o | Para objetos OLE.
* | Para todos los tipos.

El siguiente ejemplo:

RECUPERA_COD=010224 lt

recupera las líneas l y los textos t, que tengan el código 010224.

La eliminación real de las entidades borradas se produce al ejecutar la orden COMPRIMIR. A partir de ese momento, los registros correspondientes a estas entidades desaparecen del fichero, por lo tanto, no se podrá recuperar ningún código borrado si se ha comprimido el fichero.

Órdenes relacionadas: BORRADOS, COMPRIMIR, RECUPERA, REPITE.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden REGENERA

Sirve para regenerar la pantalla, actualizando la visualización del fichero de dibujo. Cuando se realiza una regeneración, al igual que cuando se redibuja la pantalla mediante una de las órdenes de zoom, se puede parar el proceso pulsando la tecla Esc.

La llamada a la orden se puede efectuar de dos maneras diferentes, se puede escribir la orden el la línea de órdenes o bien pulsar el icono correspondiente en la barra de Herramientas Dibuja, situada en la parte superior de la pantalla de DigiNG.

Órdenes relacionadas: AUTOREGENERAR.

Fecha de última modificación: 10 de Diciembre de 2003


Orden RELLENA_COLOR

Esta orden sirve para rellenar una zona de una imagen raster cargada con un determinado color. Para ello es necesario antes de ejecutar la orden:

  • Dibujar una entidad cerrada, que sirva de límite para efectuar el relleno.
  • Definir el color deseado, bien mediante la orden COLOR_PIXEL o bien mediante la orden CUENTAGOTAS.

Esta orden sólo funciona si las imágenes cargadas son del mismo tipo, esto es, o bien todas son de color verdadero, o bien todas son de niveles de gris. En caso contrario, al ejecutar la orden se muestra el siguiente mensaje:

Al ejecutar la orden se pide al usuario que seleccione la entidad cerrada, como se puede observar en la parte inferior izquierda de la pantalla:

y una vez seleccionado dicha línea, se rellena su interior con el color definido.

En el caso de que se ejecute esta orden sin que se haya cargado previamente una imagen, se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 23 de Agosto de 2002


Orden RELLENAR

Esta orden activa o desactiva el rellenado de entidades lineales cerradas. El color de rellenado se define en el archivo de definición de códigos, con extensión .TAB. En cada línea de este tipo de archivos se define un código, y en el segundo campo se define el tipo de entidad. Si éste es negativo (menor de 0), indica que se trata de una entidad lineal cerrada con rellenado. El valor absoluto del campo define un número de color dentro del archivo DIGI.PAL, color con el que se rellenará la entidad lineal cerrada digitalizada con este código en caso de que esté esta propiedad activada.

Por defecto está activado, y se muestra una R en la Barra de Herramientas Flags. El cambio de un estado a otro se produce cada vez que se llama a esta orden. También se puede introducir el valor de RELLENAR en la ventana de órdenes:

RELLENAR=1 | Activa el rellenado.
RELLENAR=0 | Desactiva el rellenado.
RELLENAR | Cambia el estado del contador.

Fecha de última modificación: martes, 22 de Octubre de 2002


Orden RENOMCOD

Se utiliza para cambiar el código correspondiente a una serie de entidades por otro código, ya sea el activo o el código que se especifique en la llamada a la orden.

Para ejecutar esta orden existen dos posibilidades:

  1. Escribir RENOMCOD y pulsar la tecla Enter. Entonces aparece la siguiente ventana:

    2. donde el sistema pide al usuario que especifique el código de las entidades que quiere cambiar, (en Buscar), y el código por el que quiere cambiar (en Reemplazar por). También es posible seleccionar si se desea cambiar el código a líneas, puntos, textos o fotos insertadas con INS_FOTO. Si se pulsa sobre Buscar siguiente, el programa va entidad por entidad (que tenga el código a buscar y sea del tipo definido), y las marca con el color definido para Tentativo. El usuario puede pulsar sobre el botón Reemplazar, o nuevamente sobre Buscar siguiente. Si el usuario desea hacer todos los cambios de código en un solo paso debe pulsar sobre el botón Reemplazar todos.

  2. Escribir RENOMCOD=<código antiguo> <código nuevo> <tipo de entidad> y pulsar Enter. Donde tipo de entidad puede ser:

    C | Entidades gráficas (puntos y líneas).
    L | Sólo entidades lineales.
    P | Sólo entidades puntuales.
    T | Sólo textos.
    B | Sólo fotos.

En el siguiente ejemplo:

RENOMCOD=010223 010240 T

cambia el código 010223 por 010240 a todos los textos del fichero.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden REPITE

Sirve para activar o desactivar la modalidad de repetición. Si se encuentra activa al usar una orden, ésta se ejecutará en modo recursivo, es decir, se repetirá hasta que el usuario pulse la tecla Esc.

Para cambiar el estado de la orden, basta con llamarla, o bien escribir:

REPITE=1 | Activa la orden.
REPITE=0 | Desactiva la orden.
REPITE | Cambia el estado de la orden.

Si la modalidad de repetición está activada, en la barra de herramientas Flags aparecerá el texto Rep.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden RETRIANGULAR

Esta orden sirve para retriangular el primer archivo MDT cargado después de haber ejecutado algún tipo de cambio o corrección desde la última vez que se retrianguló o generó.

Órdenes relacionadas: TRIANGULAR.

Fecha de última modificación: miércoles, 10 de Septiembre de 2003


Orden RESTAURAR_FICHERO

Sirve para mezclar dos ficheros, pero comprobando en la mezcla los GUIDs de las entidades nuevas y borradas. De tal forma que si, por ejemplo, se extrajo una parte de un fichero A en un fichero B, y se movió en el fichero B una entidad de sitio y dicha entidad tenía asociado un GUID, al hacer la mezcla, se moverá en el archivo A dicha entidad a la nueva posición.

Al ejecutar la orden aparecerá la siguiente ventana, el la cuál elegiremos el fichero a importar.

En esta ventana se puede especificar si deseamos borrar las entidades originales que fueron borradas en el fichero que estamos importando o si deseamos insertar las nuevas entidades encontradas en el fichero.

órdenes relacionadas: OFF_GUID, ON_GUID, EXTRAER_GUID, BORRAR_GUID, ASIGNAR_GUID.

Fecha de última modificación: martes, 29 de Julio de 2003


Orden ROTULA_CURVAS

Esta orden sirve para rotular una o varias curvas de una vez con su cota correspondiente.

Al ejecutar la orden aparecerá la siguiente ventana:

en donde introduciremos el código de las curvas. Una vez seleccionado y aceptado, el programa nos pedirá seleccionar un punto a cada lado de la curva o curvas para a continuación colocar la cota Z.

Esta orden no rotulará entidades que están desactivadas con la orden OFF.

Esta orden se repite automaticamente con el conmutador REPITE .

Órdenes relacionadas: Z, REPITE.

Última modificación: 24 de Febrero, 2004


Orden ROTULA_T

Esta orden sirve para rotular con la descripción literal del código, cualquier entidad puntual. Se ejecuta después de haber editado la entidad o entidades puntuales, es entonces cuando se llama la orden ROTULA_T y aparece la siguiente ventana:

en donde introduciremos el código del punto o puntos. Una vez seleccionado y aceptado, se colocará el nemotécnico al lado derecho de todos los puntos que tengan el código definido.

En caso de querer modificar la descripción literal que está asignada a cualquier código sólo tienes que ir al Editor de códigos o editar directamente el archivo digi.tab.

Esta orden se autorrepite si está activado el conmutador REPITE.

órdenes relacionadas: REPITE.

Fecha de última modificación: lunes, 15 de Julio de 2003


Orden ROTULA_Z

Esta orden sirve para rotular un punto o varios puntos con su Z correspondiente.

Al ejecutar la orden aparecerá la siguiente ventana:

en donde introduciremos el código del punto o puntos. Una vez seleccionado y aceptado, se colocará el valor de la cota Z a la distancia activa DA de todos los puntos que tengan el código definido.

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: Z, DA, REPITE.

Fecha de última modificación: lunes, 14 de Julio de 2003


Orden R_TEXTO

Sirve para rotar un texto ya existente en el archivo de dibujo. Al llamar a la orden, en primer lugar se pide que se seleccione el texto a rotar:

y posteriormente pide que se se digitalice un punto para definir el giro:

De forma interactiva se gira el texto con el movimiento del cursor, por lo que se puede visualizar el texto girado antes de realizar el giro.

Si el conmutador está activado, esta orden se autorrepetirá.

Órdenes relacionadas: REPITE.

Fecha de última modificación: jueves, 18 de Julio de 2002


Órdenes de DigiNG. S

    S
    SACA_P
    SALIR
    SALVAR
    SELECCIONA_ULTIMO
    SELECCIONA_VENTANA
    SIMB
    SOLAPE
    SUAVIZA
    SUAVIZAR_MDT
    SUBE_Z

Fecha de última modificación: 9 de Agosto de 2004


Orden S

Sirve para activar o desactivar la función de suavizado de entidades. El estado de este interruptor se cambia cada vez que se llama a la orden desde el menú de pantalla, o bien se escribe una de las siguientes secuencias:

S=1 | Activa la función de suavizado.
S=0 | Desactiva la función de suavizado.
S | Cambia el estado de la función.

Si la función está activada, aparece la letra S en la barra de herramientas Flags. En este caso, si se ha dibujado una entidad con forma de poligonal, el programa ajusta una curva de interpolación que pasa por todos los puntos de la entidad.

Si durante el proceso de dibujo se desactiva la función, el programa suaviza solamente los puntos ya registrados de la entidad y no actúa sobre los que se registren a partir de ese momento.

Órdenes relacionadas: SUAVIZA .

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden SACA_P

Esta orden sirve para colocar un punto a una distancia activa de un texto que ya está en el dibujo. SACA_P es de gran utilidad cuando se han perdido puntos y necesitamos volver a colocarlos al lado de un texto.

Al ejecutar la orden aparecerá la siguiente ventana:

en donde introduciremos el código del texto. Una vez seleccionado y aceptado, se extraerán puntos a la distancia activa que esté definida en este momento. Esta distancia se contará a partir de la esquina inferior izquierda del texto.

Esta orden se autorrepite si está activado el conmutador REPITE.

órdenes relacionadas: DA, REPITE.

Fecha de última modificación: lunes, 14 de Julio de 2003


Orden SALIR

Termina la sesión de trabajo en DigiNG y en Digi3D devolviendo el control al sistema operativo sin pasar por la pantalla de inicio.

Órdenes relacionadas: FIN.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden SALVAR

Se utiliza para especificar el intervalo de tiempo con que el sistema, de forma automática, hará copias de seguridad de los ficheros de trabajo. El tiempo se expresa en minutos con un valor numérico. Las copias de seguridad tienen el mismo nombre que los ficheros de trabajo, pero su extensión no es BIN sino BIK.

La llamada a la orden admite las siguientes modalidades:

  1. Escribir SALVAR y pulsar Enter. El sistema pide al usuario que se introduzca el intervalo temporal deseado mediante la siguiente ventana:

  2. Escribir SALVAR = <número minutos> y pulsar Enter. Por ejemplo:
    3. SALVAR=15
    establece que cada 15 minutos el sistema hará una copia de seguridad del fichero de trabajo.

Si el parámetro SALVAR tiene asignado el valor nulo (SALVAR=0), el sistema no hará copias de seguridad de modo automático. En este caso, el usuario ha de recurrir a la orden BAK.

Órdenes relacionadas: BAK.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden SELECCIONA_ULTIMO

Selecciona la última entidad registrada en el fichero de dibujo cuando se ha ejecutado una orden en la cual se pide seleccionar una entidad. Por ejemplo: en caso de haber digitalizado la línea límite para generar un modelo digital del terreno por correlación, y después de dar la orden MDTPC podremos ejecuatr la orden SELECCIONA_ULTIMO para hacer una selección automática de la entidad limitadora.

Esta orden permite una mayor velocidad a la hora de restituir o editar.

Esta orden admite como parámetros los siguientes valores:

  • Sin parametros: selecciona todo tipo de elementos, líneas, puntos, textos, bitmaps u objetos OLE.
  • "l": selecciona la última línea registarada.
  • "p": selecciona el último punto.
  • "c": selecciona lineas y puntos.
  • "t": selecciona el último texto.
  • "b": selecciona bitmaps.
  • "o": selecciona objetos OLE.

En caso de estar activado el flag de BORRADOS la orden SELECCIONA_ULTIMO seleccionará la última entidad digitalizada aúnque este marcada como borrada.

La orden resulta muy útil en combinación con la orden ZOOM_ENTIDAD, en caso de que se haya digitalizado un punto en el infinito, ejecutaríamos primero la orden ZOOM_ENTIDAD y a continuación la orden SELECCIONA_ULTIMO así nos situaremos lo más rápido posible en la entidad y poderemos proceder a borrarla.

Órdenes relacionadas: ZOOM_ENTIDAD, MDTPC, BORRA_V, BORRA_COD_V, PUNTEAR, RAYAR, TRAMAR.

Fecha de última modificación: 25 de Mayo de 2004


Orden SELECCIONA_VENTANA

Esta orden sirve para seleccionar por ventana varios elementos al ejecutar las órdenes CAMB_COD y MOVER.

El modo de funcionamiento es el siguiente, primero ejecutaríamos la orden CAMB_COD o MOVER y a continuación tendremos la posibilidad de seleccionar el elemento individualmente o bien dar la orden SELECCIONA_VENTANA y seleccionar varios elementos a la vez para cambiarles el código o moverlos.

Órdenes relacionadas: CAMB_COD, MOVER .

Fecha de última modificación: 25 de Mayo de 2004


Orden SIMB

Se utiliza para rellenar el interior de una entidad superficial de contorno cerrado usando una trama de símbolos. La disposición de éstos depende de los valores que tengan asignados los parámetros AA (ángulo activo) y DA (distancia activa).

Si no se ha realizado ninguna asignación previa, el sistema toma por defecto los valores cero (0) y uno (1), para AA y DA respectivamente.

La posición de los símbolos coincidiría con las intersecciones de las rayas que se hubiesen obtenido al llamar a la orden TRAMAR, de forma que podemos distinguir dos conjuntos de símbolos.

El primer conjunto sigue la dirección del ángulo activo, y los símbolos se hayan separadas una distancia igual al primer valor de la distancia activa.

El segundo conjunto sigue una dirección perpendicular al primero, y sus símbolos están separadas una distancia igual al segundo valor de la distancia activa.

La llamada a la orden se puede realizar de dos formas:

  1. Escribir SIMB y pulsar la tecla [ENTER]. En este caso el sistema pide al usuario que introduzca el valor del texto o el número del símbolo que va a utilizar en el tramado. El número de un símbolo se indica anteponiendo el carácter @ a dicho número. Ejemplo: Texto: @127. Este valor se corresponde con un cierto símbolo. A continuación el sistema pide que se seleccione la entidad a tramar. La orden se ejecuta en modo repetición, de forma que el usuario puede tramar todas las entidades que desee, finalizando el proceso al pulsar [ESC].

  2. Escribir: SIMB=<código> <texto> y pulsar [ENTER]. Ejemplo: SIMB=010223 @127 En este caso el sistema tomará todas las entidades superficiales (cerradas) cuyo código coincida con el especificado en la llamada a la orden. La trama se realizará utilizando el texto o símbolo indicado a continuación del código.

Órdenes relacionadas: AA, DA, PUNTEAR, RAYAR, TRAMAR.

Fecha de última modificación: 11 de Mayo de 2004


Orden SOLAPE

Sirve para establecer el valor del porcentaje de solape de ventana para las órdenes ZOOMSUP, ZOOMINF, ZOOMDER y ZOOMIZQ.

La llamada a la orden permite varias posibilidades:

  1. SOLAPE y pulsar Enter. El programa pedirá el valor de solape (en %) mediante la siguiente ventana_:

  2. SOLAPE=<valor de solape> y pulsar Enter. Por ejemplo:
    3. SOLAPE=25

    tomará como solape el 25%.

  3. SOLAPE=? y pulsar Enter. El programa nos mostrará el valor de solape actual mediante un globo que emerge en la parte inferior derecha de la pantalla:

El valor por defecto es de 10%.

Órdenes relacionadas: ZOOMDER, ZOOMINF, ZOOMIZQ, ZOOMSUP.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden SUAVIZA

Suaviza la forma geométrica de un elemento lineal existente en el dibujo. La orden necesita que se especifique el elemento, cuya selección se realizará de forma gráfica. Así, al llamar a la orden el programa solicita que el usuario seleccione la entidad, como se puede observar en la parte inferior izquierda de la pantalla:

Como resultado se obtiene una línea sin quiebros y de contorno más suave. La función ha generado una serie de curvas de interpolación, que pasan por los vértices originales de la entidad gráfica:

Además, se produce un aumento del número de puntos grabados en el fichero, ya que la función rellena la entidad con nuevos puntos.

Estos se generan a una distancia del anterior igual al valor de la variable INC. Por tanto a menor valor del incremento de registro mayor efecto de suavizado se consigue.

Órdenes relacionada: INC, S .

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden SUAVIZAR_MDT

Esta orden sirve para suavizar Modelos Digitales del Terreno. En caso de ejecutarla desde la línea de commandos se han de especificar como parámetros la pendiente mínima y la pendiente máxima en graduación sexagesimal para el suavizado.

Por ejemplo:

  SUAVIZAR_MDT=1 30

Órdenes relacionadas: MDTPC, TRISNGULAR, CURVAR.

Fecha de última modificación: 9 de Agosto, 2004


Orden SUBE_Z

Sirve para subir la Z en una cuantía igual a la equidistancia de curvas que se tenga establecida. La equidistancia se define en el cuadro de diálogo de Nuevo Proyecto de DigiNG o mediante la ejecución de la orden EQUIDISTANCIA.

Órdenes relacionadas: BAJA_Z, EQUIDISTANCIA.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Órdenes de DigiNG. T

    TAMPÓN
    TAMPÓN_T
    TECLA
    TENTATIVO_CORTA
    TENTATIVO_FIN
    TENTATIVO_INSERTA
    TENTATIVO_TEXTOS
    TEXTO
    TEXTO_R
    TIEMPO_ESPERA
    TOL
    TOL_ANG
    TRAER_AL_FRENTE
    TRAMAR
    TRANSFORMA_RASTER
    TRASLADA_RASTER
    TRIANGULAR
    TRIM

Fecha de última modificación: sábado, 10 de Mayo de 2003


Orden TAMPÓN

Esta orden sirve para clonar píxeles de imágenes cargadas en DigiNG mediante la orden CARGA_RASTER.

La orden TAMPÓN_T es similar a ésta, con la diferencia de que aplica transparencias en los píxeles extremos.

De forma previa a la llamada a la orden, es conveniente establecer un tamaño de cursor adecuado, con la orden CURSOR.

Ejecutada la orden, el programa solicita que se defina el punto origen del área a clonar, haciendo click con el botón izquierdo del ratón a la vez que se pulsa la tecla Alt:

Una vez definido el origen, se pueden clonar los píxeles haciendo click y arrastrando, como se indica en la parte inferior izquierda de la pantalla:

Para finalizar la ejecución de la orden se debe pulsar la tecla Esc.

En el caso de cuando se debe seleccionar el área a clonar, no se haga pulsando al mismo tiempo la tecla Alt, el programa advierte esta circunstancia y muestra el siguiente mensaje:

En el caso de se ejecute la orden y no haya ninguna imagen cargada, se muestra el siguiente aviso:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: jueves, 8 de Agosto de 2002


Orden TAMPÓN_T

Esta orden sirve para clonar píxeles de imágenes cargadas en DigiNG mediante la orden CARGA_RASTER. A diferencia de la orden TAMPÓN, esta orden clona los píxeles aplicando transparencias en los extremos.

De forma previa a la llamada a la orden, es conveniente establecer un tamaño de cursor adecuado, con la orden CURSOR.

Ejecutada la orden, el programa solicita que se defina el punto origen del área a clonar, haciendo click con el botón izquierdo del ratón a la vez que se pulsa la tecla Alt:

Una vez definido el origen, se pueden clonar los píxeles haciendo click y arrastrando, como se indica en la parte inferior izquierda de la pantalla:

Para finalizar la ejecución de la orden se debe pulsar la tecla Esc.

En el caso de cuando se debe seleccionar el área a clonar, no se haga pulsando al mismo tiempo la tecla Alt, el programa advierte esta circunstancia y muestra el siguiente mensaje:

En el caso de se ejecute la orden y no haya ninguna imagen cargada, se muestra el siguiente aviso:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TRASLADA_RASTER.

Fecha de última modificación: jueves, 8 de Agosto de 2002


Orden TECLA

Sirve para asignar órdenes de DigiNG a pulsaciones de teclas. Esta orden permite la creación o modificación del fichero de asignación de teclas TECLAS.MNU, sin tener que editarlo como fichero de texto.

Cuando se llama a la orden TECLA desde el entorno de dibujo, el programa pide que se pulse la tecla a la que se le va a asignar una orden de DigiNG.

Después de pulsada una tecla, se presenta en pantalla una ventana para la asignación de una orden a dicha tecla:

donde se teclea la orden deseada.

No se puede asignar más de una orden a una tecla, pero es posible agrupar varias en un fichero de macro instrucciones (un arroba) y asignar este fichero a una tecla.

No se pueden realizar asignaciones a las teclas Enter, Esc, Bloq Mayús, Impr Pant, etc. Sin embargo, es posible utilizar una combinación de varias teclas para realizar la asignación, por ejemplo Ctrl+a, Mayús+F3.

Después de aceptar una asignación de una orden a una tecla, pulsando la tecla Enter, el programa vuelve a solicitar que se pulse una nueva tecla o combinación de varias, para realizar otra asignación. El proceso continúa hasta que se pulsa la tecla Esc, con lo que finaliza la ejecución de la orden.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden TENTATIVO_CORTA

Esta orden sirve para hacer un tentativo que corta la entidad en la que se ha hecho el tentativo.

TENTATIVO_CORTA=1 | Activa esta modalidad de tentativo.
TENTATIVO_CORTA=0 | Desactiva esta modalidad de tentativo.
TENTATIVO_CORTA | Conmuta el estado de esta función.

Cuando está activo, se observa el texto tc en la barra de herramientas Flags.

Órdenes relacionadas: TENTATIVO_FIN, TENTATIVO_TEXTOS.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden TENTATIVO_FIN

Esta orden activa o desactiva una función que finaliza automáticamente el registro de un elemento lineal cuando se acepta un tentativo sobre otra entidad. Se suele utilizar para dibujar medianerías.

Para llamar a la orden existen las siguientes posibilidades:

TENTATIVO_FIN=1 | Activa esta modalidad de tentativo.
TENTATIVO_FIN=0 | Desactiva esta modalidad de tentativo.
TENTATIVO_FIN | Conmuta el estado de esta función.

Cuando está activo, se observa el texto tYf en la barra de herramientas Flags.

Órdenes relacionadas: TENTATIVO_CORTA, TENTATIVO_TEXTOS.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden TENTATIVO_INSERTA

Esta orden sirve para insertar un punto en las entidades lineales sobre las que hacemos tentativo, al registrar líneas.

Podremos activar o desactivar la función de TENTATIVO_INSERTA. Para cambiar el estado de la orden basta con llamarla desde el menú de pantalla. Podremos confirmar que está activada si en la ventana de Flags aparece ti.

Fecha de última modificación: viernes, 25 de Julio de 2003


Orden TENTATIVO_TEXTOS

Es un interruptor que permite hacer tentativo en un texto. Para llamar a la orden existen las siguientes posibilidades:

TENTATIVO_TEXTOS=1 | Activa esta modalidad de tentativo.
TENTATIVO_TEXTOS=0 | Desactiva esta modalidad de tentativo.
TENTATIVO_TEXTOS | Conmuta el estado de esta función.

Cuando está activo, se observa el texto Tt en la barra de herramientas Flags.

Órdenes relacionadas: TENTATIVO_CORTA, TENTATIVO_FIN.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Orden TEXTO

Sirve para escribir un texto en el dibujo. Se colocará con los parámetros activos, es decir, los correspondientes a:

  • Ángulo activo (AA).
  • Altura de texto (AT).
  • Justificación de texto(JT).

La llamada a la orden se puede realizar de dos formas:

  1. Escribir TEXTO y pulsar Enter. El programa pide al usuario que introduzca el texto que desea insertar mediante la siguiente ventana:

  2. Escribir TEXTO=<cadena de caracteres> y pulsar Enter.

Posteriormente, se desplaza el texto dinámicamente con el cursor por la pantalla hasta colocarlo en la posición deseada y se indica un punto para fijarlo.

Si se ha utilizado la primera modalidad para llamar a la orden, y además está activado el conmutador REPITE, el sistema muestra de nuevo la ventana para que escriba un texto. Pulsando Esc o no tecleando ningún texto se termina la ejecución de la orden.

Si se ha utilizado la segunda modalidad para llamar a la orden, y si además está activado el conmutador REPITE, el sistema repite el texto introducido y el usuario sólo necesita dar puntos de inserción para colocar dicho texto en diferentes posiciones. Pulsando Esc o no tecleando ningún texto se termina la ejecución de la orden.

En caso de haber definido previamente un factor de autonumeración (ver orden AUTONUM) , el programa supone que se van a introducir textos numéricos. En este caso, se añadirán ceros a la izquierda de cada número. Después de la introducción del primer valor y determinar el punto de inserción, (y además está activado el conmutador REPITE), aparece automáticamente un nuevo texto que se corresponde con el valor anterior más el factor de autonumeración. Si se acepta este nuevo texto y se señala su punto de inserción se repite el proceso, hasta que se pulsa la tecla Esc.

La orden TEXTO tendrá en cuenta también la variable que define el número de decimales NDEC.

Órdenes relacionadas: AA, AT, AUTONUM, JT, REPITE, TEXTO_R, EXPLOTAR_TEXTOS 1TEXTO.

Fecha de última modificación: 3 de Mayo de 2004


Orden TEXTO_R

Sirve para escribir un texto en el dibujo, pero a diferencia de la orden TEXTO, el texto puede colocarse en la dirección indicada por el usuario.

Con respecto a los parámetros de altura e inclinación del texto, el sistema utilizará los valores que se hallen activos en el momento de llamar a la orden.

La secuencia de acciones a realizar con esta orden sería:

  • Llamar a la orden de cualquiera de las siguientes dos formas:
    1. Escribir TEXTO_R y pulsar Enter. El programa pide al usuario que introduzca el texto que se ha de insertar en la siguiente ventana:

    2. Escribir TEXTO_R = <cadena de caracteres> y pulsar Enter.

  • Mover el texto en la pantalla mediante desplazamientos del cursor, hasta colocarlo en la posición deseada y señalar un punto para fijarlo.
  • Indicar un segundo punto en la pantalla para determinar el ángulo de rotación con que ha de insertarse el texto. Por defecto aparece el texto orientado al Norte.

Si se ha utilizado la primera modalidad para llamar a la orden, y además está activado el conmutador REPITE, el sistema muestra de nuevo la ventana para que escriba un texto. Pulsando Esc o no tecleando ningún texto se termina la ejecución de la orden.

Si se ha utilizado la segunda modalidad para llamar a la orden, y además está activado el conmutador REPITE, el sistema repite el texto introducido y el usuario sólo necesita dar puntos de inserción para colocar dicho texto en diferentes posiciones. Pulsando Esc o no tecleando ningún texto se termina la ejecución de la orden.

Si se ha definido un factor de autonumeración previamente, el programa supone que se van a introducir textos numéricos. Después de la introducción del primer valor y determinar el punto de inserción, (y además está activado el conmutador REPITE), aparece automáticamente un nuevo texto que se corresponde con el valor anterior más el factor de autonumeración. Si se acepta este nuevo texto y se señala su punto de inserción se repite el proceso, hasta que se pulsa la tecla Esc.

Órdenes relacionadas: AA, AT, AUTONUM, IT, REPITE, TEXTO, 1TEXTO.

Fecha de última modificación: viernes, 7 de Julio de 2002


Orden TIEMPO_ESPERA

Sirve para definir el tiempo en milisegundos que se desea que pase antes de autoregistrar cada punto cuando se esté ejecutando la orden MDT.

Por ejemplo, se puede escribir: TIEMPO_ESPERA=<300> A continuación se llamaría la orden MDT y activaría TIEMPO_ESPERA, marcando la casilla de autoregisto de puntos.

Fecha de última modificación: martes, 8 de Julio de 2003


Orden TOL

Sirve para establecer el factor de tolerancia en el proceso de generalización. El usuario tiene que introducir el valor de este factor en metros.

Este parámetro actúa de la forma siguiente: al generalizar los puntos que componen una entidad, la función comprueba si la distancia de un punto al segmento definido por el anterior y siguiente, es menor o igual al valor de tolerancia activo. Si es así, este punto se elimina del fichero. En caso contrario se graban sus coordenadas. También se considera el valor de la tolerancia angular dado por la orden TOL_ANG.

Existen varias formas de ejecutar la orden:

  • Teclear TOL y pulsar la tecla Enter. Entonces el programa muestra la siguiente ventana:

    • donde se puede introducir el factor de tolerancia en la generalización, bien tecleando dicho valor y pulsando el botón Aceptar, o bien pulsando sobre el botón Medir y digitalizando dos puntos en pantalla. En este caso el factor de tolerancia quedará determinado por la distancia entre los dos puntos digitalizados. También es posible digitalizar estos dos puntos directamente, sin necesitar de pulsar previamente sobre el botón Medir.

  • Teclear TOL=<valor> y pulsar la tecla Enter. En este caso el factor de tolerancia en el proceso de generalización queda determinado por valor.

  • Teclear TOL=? y pulsar la tecla Enter. Entonces el programa muestra el valor del factor de tolerancia en el proceso de generalización mediante un globo en la parte inferior derecha de la pantalla:

El proceso de generalizar se ejecuta con todos y cada uno de los puntos de una entidad.

Órdenes relacionadas: G, GEN, TOL_ANG.

Fecha de última modificación: viernes, 21 de Junio de 2002


Orden TOL_ANG

Sirve para establecer el factor de tolerancia angular en el proceso de generalización. El usuario ha de especificar el valor de este factor en unidades centesimales.

Este parámetro se utiliza en la generalización para comprobar en un punto, si el valor de la tangente del ángulo formado por las rectas anterior y siguiente, supera el valor de la tolerancia angular. En este caso, el punto no se elimina aunque no supere la tolerancia lineal (TOL), para mantener la forma del elemento.

Existen varias formas de ejecutar la orden:

  • Teclear TOL_ANG y pulsar la tecla Enter. Entonces el programa muestra la siguiente ventana:

donde se puede introducir el factor de tolerancia angular en la generalización, bien tecleando dicho valor y pulsando el botón Aceptar, o bien pulsando sobre el botón Medir y digitalizando dos puntos en pantalla. En este caso el factor de tolerancia quedará determinado por la distancia entre los dos puntos digitalizados. También es posible digitalizar estos dos puntos directamente, sin necesitar de pulsar previamente sobre el botón Medir.

  • Teclear TOL_ANG=<valor> y pulsar la tecla Enter. En este caso el factor de tolerancia angular en el proceso de generalización queda determinado por valor.

  • Teclear TOL_ANG=? y pulsar la tecla Enter. Entonces el programa muestra el valor del factor de tolerancia en el proceso de generalización angular mediante un globo en la parte inferior derecha de la pantalla:

El proceso de generalizar se ejecuta con todos y cada uno de los puntos de una entidad.

Órdenes relacionadas: G, GEN, TOL.

Fecha de última modificación: viernes, 21 de Junio de 2002


Orden TRAER_AL_FRENTE

Esta orden sirve para asignar prioridad de visualización a una imagen sobre el resto de imágenes cargadas en DigiNG. Al ejecutar la orden se visualiza el siguiente cuadro de diálogo:

donde se puede seleccionar la imagen que se desea visualizar por encima del resto. Al seleccionar la imagen, se puede ver en DigiNG como dicha imagen queda marcada por unas líneas horizontales blancas, para que el usuario sepa en todo momento a qué imagen se le dará mayor prioridad.

Seleccionada la imagen deseada, se pulsa sobre el botón Aceptar para terminar de ejecutar la orden.

En el caso de que se ejecute la orden sin que haya ningún raster cargado se muestra el siguiente mensaje:

Órdenes relacionadas: CARGA_RASTER, DEJAR_RASTER.

Fecha de última modificación: lunes, 9 de Septiembre de 2002


Orden TRAMAR

Se utiliza para tramar el interior de una entidad superficial de contorno cerrado. El tramado se compone de un doble rayado cuya disposición depende de los valores que tengan asignados los parámetros AA (ángulo activo) y DA (distancia activa). Si no se ha realizado ninguna asignación previa, el sistema toma por defecto los valores cero y uno para AA y DA respectivamente.

El primer rayado tiene la dirección del ángulo activo, y las rayas se hayan separadas una distancia igual al primer valor de la distancia activa. El segundo tramado tiene una dirección perpendicular al primero, y sus rayas están separadas una distancia igual al segundo valor de la distancia activa.

La llamada a la orden se puede realizar de dos formas:

  1. Escribir TRAMAR y pulsar la tecla [ENTER]. En este caso el sistema pide que se seleccione la entidad a tramar. La orden se ejecuta en modo repetición, de forma que el usuario puede tramar todas las entidades que desee, finalizando el proceso al pulsar [ESC].

  2. Escribir TRAMAR=<código> y pulsar [ENTER]. Ejemplo: TRAMAR=010223. En este caso el sistema tramará todas las entidades superficiales cerradas cuyo código coincida con el especificado en la llamada a la orden.

El conjunto de rayas que componen el tramado se representan con el código que estuviera activo al llamar a la orden.

Órdenes relacionadas: AA, DA, RAYAR, PUNTEAR, TRAMAR.

Fecha de última modificación: 11 de Mayo de 2004


Orden TRANSFORMA_RASTER

Esta orden sirve para realizar giros a las imágenes cargadas en DigiNG. El sistema pide al usuario que digitalice 4 puntos que establecerán la relación entre la imagen original y la transformada. El programa se fija únicamente en el primer y último punto, y gira el raster para que el origen de coordenadas (0,0) coincida con el primer punto digitalizado sobre el raster. Esto se usa para plotear ortofotos que no están orientadas al Norte (que siguen trazas) para aprovechar el tamaño del papel. El programa genera un archivo .ori (con orientación afín) asociado al nuevo raster generado, en vez de un archivo .ort, ya que la cartografía se tiene que imprimir girada también. Se utilizan 4 puntos porque el programa HOJAS genera archivos .utm y dichos archivos .utm se componen de 4 puntos.

El orden de digitalización de los puntos (al igual que en los archivos .utm) es el siguiente: SO, NO, NE, SE.

Al ejecutar la orden el programa pide al usuario que digitalice los 4 puntos:

y una vez digitalizados, muestra la siguiente ventana:

donde se puede seleccionar:

  • La imagen a la cual se quierea aplicar la transformación, de entre las varias imágenes que es posible tener cargadas.
  • Tipo de interpolación: se puede elegir entre Vecino más próximo, Bilineal y Bicúbica.
  • Guardar como: nombre y tipo de la imagen transformada a generar:

    .

Se pulsa sobre Aceptar y el programa realiza la transformación solicitada:

con lo que se genera la imagen y el archivo .ori asociado.

También es posible ejecutar esta orden a través de la línea de órdenes. Para ello existen dos posibilidades:

TRANSFORMA_RASTER=[numero_de_raster] [interpolación] [transparente] [fichero_salida] [x0] [y0] [x1] [y1] [x2] [y2] [x3] [y3]

TRANSFORMA_RASTER=[numero_de_raster] [interpolación] [transparente] [fichero_salida] [archivo.utm]

donde:

  • numero_de_raster: número de la imagen a transformar, considerando que se comienza por 0 y se autoincrementa el número con cada carga.
  • interpolación: puede tomar los siguientes valores:
    • 0: vecino más próximo.
    • 1: interpolación bilineal.
    • 2: interpolación bicúbica.
  • transparente: color a considerar como transparente, en el rango [0-255].
  • fichero_salida: nombre y extensión del fichero de salida.
  • [x0 ... y3]: coordenadas de los cuatro puntos a considerar para la transformación.
  • archivo.utm: ruta completa de un arhivo .utm, del que se puede extraer las coordenadas de los cuatro puntos necesarios.

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTERS, CARGA_RASTERS_POR_VENTANA, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: sábado, 10 de Mayo de 2003


Orden TRASLADA_RASTER

Esta orden sirve para mover la imagen en el fichero de dibujo. Sólo funciona en el caso de que la imagen tenga un fichero ORT asociado a ella.

Al ejecutar la orden el programa solicita el punto hacia el que se desea mover la imagen:

y después el punto de la imagen desde donde se moverla:

En el caso de que se ejecute la orden TRASLADA_RASTER sin que haya ninguna imagen cargada, se indica al usuario esta cuestión:

En el caso de que se ejecuta esta orden y haya varias imágenes cargadas, después de digitalizar los puntos destino y origen, aparece la siguiente ventana:

donde se pide al usuario que seleccione la imagen (o las imágenes) que desea trasladar.

También es posible introducir las coordenadas de los puntos origen y destino de la traslación mediante las orden XY.

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T. XY.

Fecha de última modificación: lunes, 22 de Julio de 2002


Orden TRIANGULAR

Esta orden permite calcular la triangulación de un Modelo Digital del Terreno (MDT) a partir de una nube de puntos obtenida por correlación mediante la orden MDTPC, y a partir de la cartografía de la zona en formato BIN. Antes ejecutar esta orden es necesario dibujar una entidad cerrada a modo de límite, como se puede ver en la siguiente imagen:

Una vez que se ha dibujado una entidad cerrada a modo de límite, se puede ejecutar la orden TRIANGULAR, se selecciona dicha entidad

y aparece la siguiente ventana:

donde en el campo Nombre del archivo a generar se teclea el nombre del archivo donde se va a guardar la triangulación, en el formato empleado por MDTop. Por defecto siempre sale un nombre de archivo compuesto por:

Triangulación (n) de <archivo bin>.mdt

donde n es un número que comienza en cero y sirve para guardar varias triangulaciones de un mismo archivo. Si ya existen las triangulaciones 0 y 1, asignará un 2 a n. Y se identifica con el archivo bin abierto mediante archivo bin, y le asigna por defecto la extensión mdt. Si se hace la primera triangulación dentro del archivo ejemplo.bin, el nombre por defecto es:

Triangulación (0) de ejemplo.mdt

Y se almacena en el mismo directorio donde esté el archivo ejemplo.bin. También es posible cambiar este nombre por que el que se desee, o incluirlo en otro directorio pulsando sobre el botón situado a la derecha con puntos, abriéndose en este caso un cuadro de diálogo.

Se pulsa sobre el botón Aceptar, el programa comienza a triangular, e informa en la parte inferior de la pantalla de lo está haciendo e indica en una barra de progreso el avance en el cálculo:

Cuando termina los cálculos presenta la triangulación en pantalla con el código que esté activo:

Órdenes relacionadas: DEJAR_MDT | CURVAR | MDTPC

Fecha de última modificación: 10 de Agosto, 2004


Orden TRIM

Sirve para cortar una entidad hasta su punto de intersección con el borde de otra.

La secuencia de pasos a realizar por el usuario es:

  • Seleccionar la entidad que va a servir de límite, y con la que se han de calcular los puntos de intersección, como solicita el programa en la parte inferior izquierda de la pantalla:

  • Indicar la entidad a cortar, por el lado o la parte que habrá de ser eliminado a partir del punto de corte con el elemento anterior:

Cuando ha cortado la primera entidad, sigue pidiendo entidades a cortar. Cuando no se deseen cortar más, el usuario debe pulsar la tecla Esc. Entonces vuelve a pedir (independientemente del estado del conmutador REPITE) una entidad que sirva de límite. Para dejar de ejecutar esta orden se debe volver a pulsar la tecla Esc.

Órdenes relacionadas: EXT, EXT_M, EXT_P, EXT2X, REPITE.

Fecha de última modificación: viernes, 21 de Junio de 2002


Órdenes de DigiNG. U

    U
    UM
    UNDO
    UNIR

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden U

Sirve para borrar los últimos puntos de la entidad que se está registrando en el momento de llamar a la orden. Sólo tiene efecto mientras la entidad no se finalice. También sirve para eliminar el último atributo de la lista de atributos activos.

Órdenes relacionadas: UM.

Fecha de última modificación: viernes, 17 de Septiembre de 2003


Orden UM

Sirve para borrar los últimos puntos de la entidad que se está registrando en el momento de llamar a la orden. Sólo tiene efecto mientras la entidad no se finalice. Es similar a la orden U, con la diferencia de que la orden UM sirve borrar varios puntos de una sola vez.

Al ejecutar la orden (mientras se esté digitalizando una línea), el programa solicita que se defina el segmento hasta el que se desea borrar los puntos digitalizados:

una vez seleccionado, se borran los vértices de la entidad desde el último vértice hasta el vértice anterior del segmento seleccionado, y el programa sigue ejecutando la orden con la que se estaba digitalizando.

Órdenes relacionadas: U.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden UNDO

Esta orden sirve para deshacer las acciones efectuadas en el programa. Cuando se ejecutan órdenes, éstas colocan en una pila, una orden encima de la orden precedente. Cuando se ejecuta la orden UNDO se deshacen las órdenes según están colocadas en la pila, por lo tanto, la primera orden que se deshace es la última que se haya ejecutado, y después la penúltima, y así sucesivamente.

Cada ejecución de la orden UNDO sólo deshace una orden.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden UNIR

Sirve para unir dos entidades lineales que ha de seleccionar el usuario, generando un único elemento de dibujo. La unión se realiza por el extremo más próximo al punto de selección de cada una de las entidades.

Existen dos formas de ejecutar la orden:

  • Teclear UNIR y pulsar la tecla Enter. Entonces el programa solicita que se seleccione la primera línea:

    • y después la segunda línea. Finalmente, el programa une las líneas.

  • Teclear UNIR=<código> y pulsar la tecla Enter. Entonces el programa pide cuatro puntos que definirán el entorno dentro del cual se van a juntar las líneas, como se puede observar en la parte inferior izquierda de la pantalla:

    Una vez definido este contorno se producirá la unión automática de las líneas. Una interesante aplicación de esta orden sería la de unir curvas de nivel interpoladas. Por ejemplo, con la orden INTER=0201* se han interpolado una serie de curvas. Para juntarlas, llamar a la orden con el código correspondiente (pueden usarse comodines), por ejemplo, UNIR=0201*, como se puede ver en la siguiente figura:

Las entidades deben tener el mismo código y los mismos atributos, en caso contrario el programa muestra el siguiente mensaje:

También es posible unir líneas con los mismos atributos pero en distinto orden.

Órdenes relacionadas: JUNTAR.

Fecha de última modificación: lunes, 24 de Junio de 2002


Órdenes de DigiNG. V

    VBSCRIPT
    VBSCRIPT_ENCRIPTADO
    VER
    VER_MDT

Fecha de última modificación: lunes, 4 de Noviembre de 2002


Orden VBSCRIPT

Bajo el nombre de DigiNGScript se incluyen una serie de métodos y propiedades que proporciona DigiNG para facilitar la integración de DigiNG con los diferentes motores de scripting instalados en el ordenador en el cual se ejecuta DigiNG.

Por defecto en Windows 2000 y en Windows XP vienen instalados dos motores de scripting:

  • VBScript: para programar en un lenguaje parecido a VBasic.
  • VBScript.Encode: igual que VBScript pero encriptado con el programa de Microsoft Windows Script Encoder.
  • JScript: para programar en un lenguaje parecido a C, C++ ó Java.
  • JScript.Encode: Igual que JScript pero encriptado con el programa de Microsoft Windows Script Encoder.

Para obtener información en línea en español acerca de scripting, así como tutoriales de VBScript y JScript, visite el web http://msdn.microsoft.es/scripting.

DigiNG publica un objeto denominado digi y dicho objeto posee una serie de Métodos y Propiedades con las cuales se puede controlar a DigiNG desde un script.

El procedimiento normal consiste en crear un archivo de texto con el código del script y luego ejecutarlo con la orden VBScript ó con la orden JScript de DigiNG.

Si desea conocer más lea el tema de la ayuda DigiNGScript.

Órdenes relacionadas: VBSCRIPT_ENCRIPTADO, JSCRIPT, JSCRIPT_ENCRIPTADO,

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orden VBSCRIPT_ENCRIPTADO

Bajo el nombre de DigiNGScript se incluyen una serie de métodos y propiedades que proporciona DigiNG para facilitar la integración de DigiNG con los diferentes motores de scripting instalados en el ordenador en el cual se ejecuta DigiNG.

Por defecto en Windows 2000 y en Windows XP vienen instalados dos motores de scripting:

  • VBScript: para programar en un lenguaje parecido a VBasic.
  • VBScript.Encode: igual que VBScript pero encriptado con el programa de Microsoft Windows Script Encoder.
  • JScript: para programar en un lenguaje parecido a C, C++ ó Java.
  • JScript.Encode: Igual que JScript pero encriptado con el programa de Microsoft Windows Script Encoder.

Para obtener información en línea en español acerca de scripting, así como tutoriales de VBScript y JScript, visite el web http://msdn.microsoft.es/scripting.

DigiNG publica un objeto denominado digi y dicho objeto posee una serie de Métodos y Propiedades con las cuales se puede controlar a DigiNG desde un script.

El procedimiento normal consiste en crear un archivo de texto con el código del script y luego ejecutarlo con la orden VBScript ó con la orden JScript de DigiNG.

Si desea conocer más lea el tema de la ayuda DigiNGScript.

Órdenes relacionadas: VBSCRIPT, JSCRIPT, JSCRIPT_ENCRIPTADO,

Fecha de última modificación: miércoles, 6 de Noviembre de 2002


Orden VER

Se utiliza para activar o desactivar la función de verificación. Para cambiar el estado de la orden basta con llamarla desde el menú de pantalla o bien escribir:

VER=1 | Activa la función de verificación.
VER=0 | Desactiva la función de verificación.
VER | Cambia el estado de la función.

Si está activada, aparece en la línea de mensajes la letra V en la barra de herramientas Flags. En este estado, al efectuar un enganche a una entidad con el botón de tentativo, ésta se presenta en pantalla con el color asignado con la orden COLOR_TENTATIVO, y el usuario puede verificar si la captura se realiza o no con dicha entidad. En caso afirmativo, puede aceptar la operación pulsando la tecla + o el botón del cursor correspondiente.

Si la función está desactivada, al intentar un enganche a una entidad con el botón de tentativo, el proceso se llevará a cabo sin pedir confirmación.

Órdenes relacionadas: COLOR_TENTATIVO.

Fecha de última modificación: lunes, 17 de Junio de 2002


Orden VER_ATRIBUTOS

Si una línea tiene asociados atributos de una Base de Datos (ver tabla=DBDIGI), y está activa esta variable, al ejecutar la orden y regenerar, aparecen entre paréntesis y separados por comas, los atributos asignados a dicha línea en el centro de cada uno de los tramos de la línea.

Fecha de última modificación: martes, 8 de Julio de 2003


Orden VER_MDT

La orden VER_MDT sirve para activar y desactivar la visualización de la triangulación del Modelo Digital del Terreno actual. Se ejecuta con la siguiente sintaxis:

VER_MDT=<valor>

donde valor puede tomar los siguientes valores:

       0 para desactivar la visualización
       1 para activarla y poder observar los triangulos
       2 para visualizar exclusivamente los puntos del MDT
       3 para visualizar las curvas de nivel generadas por el MDT
       4 para visualizar ambos, los triángulos y las curvas de nivel al mismo tiempo
       5 para visualizar tanto los puntos como las curvas de nivel.

Si se ejecuta la orden simplemente tecleando VER_MDT, se conmutará el valor activo en ese momento, es decir si se activa la visualización en caso de estar desactivada, y se desactiva si está activada. Por defecto está desactivada esta visualización.

La visualización o no de la triangulación del MDT no descarga el MDT, simplemente se activa/desactiva su visualización. Por ello, si con la orden MOVER_Z se modifica un punto que sea tanto del fichero del dibujo como de la triangulación, se modificarán ambos, aunque no se está visualizando la triangulación del MDT.

Órdenes relacionadas: DEJAR_MDT, MOVER_Z.

Fecha de última modificación: martes, 24 de Febrero de 2004


Orden VER_TOPOLOGIAS

Permite activar o desactivar la visualización de una topología así como cambiar su orden.

Órdenes relacionadas: CARGA_TOP, DEJAR_TOP

Fecha de última modificación: viernes, 22 de Agosto de 2003


Órdenes de DigiNG. X

    XY

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden XY

Sirve para introducir las coordenadas de uno o varios puntos. Los valores tecleados deben estar separados por espacios en blanco o comas. Esta orden admite varios formatos y distintas formas de ejecución:

  • Teclear XY y pulsar la tecla Enter. Entonces el programa muestra la siguiente ventana:

    • donde, como se puede leer existen distintos formatos para introducir las coordenadas de un punto. Se escriben las coordenadas del punto en alguno de los formatos que se describen y se pulsa sobre el botón Aceptar. Se pueden teclear varios puntos, con distintos formatos. Cada punto debe estar en una línea, y para cambiar de línea se debe pulsar la tecla Enter. Por ejemplo, si se está digitalizando una línea, se puede ejecutar la orden XY y en esta ventana teclear las siguientes líneas:

    1500 1600
@100 250
325<<90
    donde se pide a DigiNG que continúe la línea digitalizando un nuevo vértice en el punto de coordenadas (1500,1600), después un punto que está en coordenadas relativas a (100, 250) del vértice anteriormente digitalizado, y el último punto digitalizado está a una distancia de 325 y en ángulo de 90 grados sexagesimales.

  • También existe la posibilidad de llamar a la orden XY pasando como parámetros más de una coordenada XYZ, por ejemplo introduciendo:
    XY=100.0 100.0 100.0 200.0 200.0 100.0

    Con esto conseguiríamos hacer una línea desde la coordenada (100, 100, 100) a (200, 200, 100).

    Esta orden se puede utilizar dentro de cualquier otro comando que esté activo, para indicar la posición de un punto determinado.

    Fecha de última modificación: miercoles, 10 de Septiembre de 2003


Órdenes de DigiNG. Z

    Z
    ZOOMA
    ZOOMDER
    ZOOME
    ZOOME_R
    ZOOMIN
    ZOOMINF
    ZOOMIZQ
    ZOOMOUT
    ZOOMP
    ZOOMSUP
    ZOOMV
    ZOOM+
    ZOOM-
    ZOOM2P

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden Z

Sirve para asignar un valor a la coordenada Z. Esta orden se usa cuando la entrada de datos se está realizando desde cualquiera de las siguientes unidades: ratón o digitalizador. Cuando la entrada de coordenadas se realiza desde el restituidor, el valor de Z es tomado de forma automática.

Una vez tecleada esta orden, todos los elementos gráficos que se dibujen se grabarán en el fichero de dibujo con la altitud especificada anteriormente.

Cuando se ha fijado un valor para la coordenada Z se muestra el texto Z_f en la barra de herramientas Flags. Para desactivar la Z fija se utiliza la orden FIJAZ.

La llamada a la orden admite dos posibilidades:

  1. Teclear Z y pulsar Enter. El sistema pregunta por el valor de Z mediante el siguiente cuadro de diálogo:

    2. donde se introduce la Z deseada y se pulsa sobre el botón Aceptar.

  2. Teclear Z=<valor> y pulsar Enter. El sistema tomará valor como el valor de Z.

Órdenes relacionadas: FIJAZ.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMA

Sirve para centrar la visualización de los elementos de la pantalla, en torno al punto donde está el cursor/restituidor. Las entidades se visualizan con el mismo factor de zoom, es decir con el mismo tamaño que tenían antes de llamar a esta orden.

Órdenes relacionadas: ZOOMDER, ZOOME, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMDER

Permite una visualización selectiva del dibujo hacia la derecha. El porcentaje de solape se elige con la orden SOLAPE.

Las ordenes ZOOMDER, ZOOMIZQ, ZOOMINF, ZOOMSUP son útiles para una revisión total del dibujo, empezando, por ejemplo en la esquina superior izquierda y visualizándolo ventana a ventana en toda su extensión.

El factor del zoom es el mismo que el de la ventana anterior.

Órdenes relacionadas: SOLAPE, ZOOMA, ZOOME, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOME

Realiza un zoom extendido. Ajusta el factor de zoom para que el dibujo completo se visualice en la pantalla.

La llamada a la orden se puede efectuar de dos maneras diferentes, se puede escribir la orden el la línea de órdenes o bien pulsar el botón situado en la parte superior de la pantalla de DigiNG.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMIN

Se utiliza para aumentar el factor de zoom. El efecto visual es de aproximación, viéndose las entidades de dibujo al doble de su tamaño inicial. El zoom se efectúa centrado en el punto donde se encuentra el cursor.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOME, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMINF

Permite una visualización selectiva del dibujo hacia abajo. El porcentaje de solape se elige con la orden SOLAPE.

Las ordenes ZOOMDER, ZOOMIZQ, ZOOMINF, ZOOMSUP son útiles para una revisión total del dibujo, empezando, por ejemplo en la esquina superior izquierda y visualizándolo ventana a ventana en toda su extensión.

El factor del zoom es el mismo que el de la ventana anterior.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOME, ZOOMIN, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMIZQ

Permite una visualización selectiva del dibujo hacia la izquierda. El porcentaje de solape se elige con la orden SOLAPE.

Las ordenes ZOOMDER, ZOOMIZQ, ZOOMINF, ZOOMSUP son útiles para una revisión total del dibujo, empezando, por ejemplo en la esquina superior izquierda y visualizándolo ventana a ventana en toda su extensión.

El factor del zoom es el mismo que el de la ventana anterior.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOME, ZOOMIN, ZOOMINF, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMOUT

Se utiliza para disminuir el factor de zoom. El efecto visual es de alejamiento, viéndose las entidades de dibujo a la mitad de su tamaño original. El zoom se efectúa centrado en el punto donde se encuentra el cursor.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOME, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMP

Esta orden sirve para hacer un centrado del dibujo en el punto que escoja el operador. Después de llamar la orden, el programa pide que se digitalice el punto en el cual se quiere hacer zoom.

También es posible que esta orden se ejecute definiendo como parámetros en la línea de órdenes, las coordenadas del punto en el cuál se desea hacer el zoom.

Órdenes relacionadas: ZOOM-, ZOOME, ZOOMA, ZOOMDER, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: lunes, 18 de Julio de 2003


Orden ZOOME_R

Realiza un zoom extendido por recinto, calculando topologías en tiempo real. Ajusta el factor de zoom para que el dibujo completo se visualice en la pantalla.

Además existe la posibilidad de deseleccionar recintos sin finalizar la orden, presionando el botón derecho del ratón.

Órdenes relacionadas: ZOOMA, ZOOME, ZOOMDER, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMP, ZOOMSUP, ZOOM+, ZOOM-, ZOOMV.

Fecha de última modificación: viernes, 17 de Junio de 2003


Orden ZOOMSUP

Permite una visualización selectiva del dibujo hacia arriba. El porcentaje de solape se elige con la orden SOLAPE.

Las ordenes ZOOMDER, ZOOMIZQ, ZOOMINF, ZOOMSUP son útiles para una revisión total del dibujo, empezando, por ejemplo en la esquina superior izquierda y visualizándolo ventana a ventana en toda su extensión.

El factor del zoom es el mismo que el de la ventana anterior.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOME, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMV.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOMV

Se utiliza para visualizar por pantalla el contenido de una zona de dibujo que el usuario ha de indicar, delimitando el contorno con una ventana. Esta ventana se define señalando dos puntos en pantalla.

La llamada a la orden se puede efectuar de dos maneras diferentes, se puede escribir la orden el la línea de órdenes o bien pulsar el botón situado en la parte superior de la pantalla de DigiNG.

Órdenes relacionadas: ZOOMA, ZOOMDER, ZOOME, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP.

Fecha de última modificación: lunes, 24 de Junio de 2002


Orden ZOOM+

Esta orden sirve para aumentar el factor de zoom. El efecto visual es de aproximación, viéndose las entidades de dibujo al doble de su tamaño inicial. El zoom se efectúa centrado el dibujo con respecto a la pantalla.

La llamada a la orden se puede efectuar de dos maneras diferentes, se puede escribir la orden el la línea de órdenes o bien pulsar el botón situado en la parte superior de la pantalla de DigiNG.

órdenes relacionadas: ZOOM-, ZOOMP, ZOOME, ZOOMA, ZOOMDER, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

.

Fecha de última modificación: jueves, 25 de Septiembre de 2003


Orden ZOOM-

Se utiliza para disminuir el factor de zoom. El efecto visual es de alejamiento, viéndose las entidades de dibujo a la mitad de su tamaño original. El zoom se efectúa centrado el dibujo con respecto a la pantalla.

La llamada a la orden se puede efectuar de dos maneras diferentes, se puede escribir la orden el la línea de órdenes o bien pulsar el botón situado en la parte superior de la pantalla de DigiNG.

Órdenes relacionadas: ZOOMP, ZOOMA, ZOOMDER, ZOOM+, ZOOME, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: miércoles, 5 de Junio de 2002


Orden ZOOM2P

Esta orden sirve para desplazarse con el ratón en la pantalla de DigiNG con el ratón. La llamada a la orden se puede hacer de dos formas diferentes, introduciéndola en la línea de órdenes o bien pulsando el icono que muestra la lupa y la flecha situado en la parte superior de la pantalla principal.

Cuando está activada, el programa pide digitalizar un punto [image] y a continuación otro

. Estos dos puntos configuran el vector de movimiento que desplazará el dibujo.

Fecha de última modificación: viernes, 3 de Septiembre de 2003


Órdenes de DigiNG. 1

    1TEXTO

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden 1TEXTO

Esta orden sirve para insertar un sólo texto en el dibujo, independientemente del estado del conmutador REPITE . El texto se colocará con los parámetros activos, es decir, los correspondientes a:

  • Ángulo activo (AA).
  • Altura de texto (AT).
  • Ángulo de justificación (JT).

La llamada a esta orden se puede realizar de dos formas:

  • Teclear 1TEXTO y pulsar la tecla Enter. Entonces se muestra la siguiente ventana:

donde se escribe el texto que se desee insertar y se pulsa sobre el botón Aceptar. Ahora el programa pide el punto de inserción, y digitalizado éste, se inserta el texto en el dibujo.

  • Teclear 1TEXTO=<cadena caracteres> y pulsar la tecla Enter. Entonces se pide al usuario que digitalice el punto de inserción del texto, que se corresponderá con cadena de caracteres.

Órdenes relacionadas: AA, AT, EDITAR_TEXTO, CAMB_AA, CAMB_AT, CAMB_JT, CAMB_JT2, JT, REPITE, AUTONUM, TEXTO, R_TEXTO. TEXTO_R.

Fecha de última modificación: martes, 25 de Junio de 2002


Órdenes de DigiNG. 2

    2P
    2P_AA

Fecha de última modificación: viernes, 26 de Septiembre de 2003


Orden 2P

Sirve para dibujar un cuadrado. La orden requiere la entrada de los puntos extremos que definen la diagonal.

Estos pueden introducirse bien de forma gráfica, señalándolos con el cursor/ratón, o bien por entrada de sus coordenadas desde el teclado, con la orden XY o bien desde archivo con la orden N.

El resultado final es una entidad cerrada de 5 puntos con forma de cuadrado (para que sea una entidad cerrada el primer punto y el último deben ser el mismo, por lo que se trata de un entidad de 5 puntos, 4 + 1).

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: REPITE, 2P_AA, 3P, XY.

Fecha de última modificación: martes, 25 de Junio de 2002


Orden 2P_AA

Esta orden sirve para dibujar un rectángulo en el cual uno de sus lados formará un ángulo determinado con la horizontal.

Para ejecutar esta orden hace falta establecer el ángulo activo con la orden AA, por ejemplo AA=45. Habiendo hecho esto, si se ejecuta a continuación la orden 2P_AA digitalizaríamos un rectángulo dando dos puntos. Dicho rectángulo tendrá uno de sus lados formando 45 grados con la horizontal, dependiendo de a qué lado digitalizamos el segundo punto.

Órdenes relacionadas: AA, 2P, 3P.

Fecha de última modificación: viernes, 26 de Septiembre de 2003


Órdenes de DigiNG. 3

    3P

Fecha de última modificación: viernes, 31 de Mayo de 2002


Orden 3P

Sirve para dibujar una forma geométrica rectangular. La orden requiere la entrada de 3 puntos, de forma que los dos primeros se corresponden con las esquinas de un lado, y el tercero con cualquier punto perteneciente al lado opuesto (no es necesario que se corresponda con una esquina).

Los puntos pueden definirse de forma gráfica o numérica (con la orden XY). El resultado final es un rectángulo definido por 5 puntos (para que sea una entidad cerrada el primer punto y el último deben ser el mismo, por lo que se trata de un entidad de 5 puntos, 4 + 1).

Esta orden se autorrepite si está activado el conmutador REPITE.

Órdenes relacionadas: CUADROS, CUADROS_4P, ESCALERA, REPITE, XY, 2P.

Fecha de última modificación: martes, 25 de Junio de 2002


Formatos de archivo utilizados por DigiNG

En este tema de la ayuda se encuentran las descripciones y ejemplos de los archivos utilizados por DigiNG.

Archivos de Configuración de DigiNG:

  • Formato del archivo de códigos (.TAB).
    • Ejemplo de archivo de códigos (.TAB).
  • Formato del archivo DIGI.PAL.
    • Ejemplo del archivo DIGI.PAL.
  • Formato del archivo TEXT.TXT.
    • Ejemplo del archivo TEXT.TXT.
  • Formato del archivo de plumas (.PLU).
    • Ejemplo de archivo de plumas (.PLU).

Archivos de Georreferenciación de imágenes:

  • Formato de archivo .ORT.
    • Ejemplo de archivo .ORT.
  • Formato de archivo .TFW.
    • Ejemplo de archivo .TFW.
  • Formato de archivo .GEO.
    • Ejemplo de archivo .GEO.

Otros archivos:

  • Formato de archivo .UTM.
    • Ejemplo de archivo .UTM.

Fecha de última modificación: sábado, 10 de Mayo de 2003


Formato del archivo de códigos (.TAB)

Es un archivo ASCII que contiene la simbología de visualización de las entidades de dibujo. El usuario puede elegir en cada trabajo la simbología que considere adecuada, con sólo modificar el contenido de este archivo o mediante el Editor de Códigos. También contiene los parámetros de ploteo asociados a cada código (número de pluma, color grosor de línea y número de fuente).

Este fichero de configuración es imprescindible para el funcionamiento de DigiNG. Si no existe ningún fichero con este nombre en el directorio de tablas, en el directorio de trabajo, o en C:\DIGI, DigiNG se ejecuta pero no habrá códigos disponibles.

En el fichero deben existir tantas líneas de información como códigos distintos vayan a utilizarse en la impresión o ploteo de los archivos.

La estructura del archivo es la siguiente:

  • Por cada código de dibujo que se vaya a utilizar, debe escribirse una línea de texto.
  • Cada línea ha de llevar obligatoriamente los siguientes campos:
Código | Es un campo alfanumérico que contiene el código de dibujo. El código es una cadena de caracteres que puede tener un máximo de 6 caracteres.
Tipo Es un campo numérico que hace referencia al tipo de entidad que se puede dibujar con el código anterior. Admite hasta 256 valores y que corresponden con:
    0: entidad puntual | El programa termina de forma automática la entidad cada vez que se da un punto. Todas las entidades que se registren con este código, sólo tendrán un punto. Con este tipo de entidades no se puede registrar en modo arrastre.
1: entidad lineal | Las entidades se pueden registrar en modo punto a punto o de arrastre. El programa une mediante segmentos los puntos registrados. El usuario ha de indicar el final de entidad con la orden FIN_ENT, para dibujar un nuevo elemento. Si se registra un sólo punto y da por finalizada la entidad, el programa no registra dicha entidad.
Número negativo: entidad lineal | En caso de que dicha entidad sea cerrada, la entidad se visualizará y se imprimirá rellena con el color correspondiente al número que se indique. La asociación entre un número de color y un determinado color RGB se realiza en el archivo DIGI.PAL. En el caso de que existan varias entidades cerradas y rellenas unas dentro de otras, la visualización y la impresión de los rellenos se realiza en el orden en que han sido registradas las entidades. Si la entidad no es cerrada no se rellenará.
Color | Es un campo numérico que especifica el color asociado al código de dibujo. Puede tomar cualquier valor entre 0 y 255. La correspondencia entre un determinado valor numérico y un color se realiza en el archivo DIGI.PAL.
Pluma | Indica el número de la pluma que se va a emplear en el dibujo de la entidad. Si el número es negativo, no se dibuja (códigos virtuales), pero si la entidad lleva relleno si se rellenará. Este número de pluma también se utiliza para definir el grosor de impresión, lo cual se hace relacionando este número pluma con su correspondiente en el archivo de plumas (.plu).
Grosor Es un campo numérico usado para especificar el grueso de línea asociado a cada código. Se utiliza tanto para archivos de ploteo en lenguaje BGL como HPGL, y permite generar diferentes grosores de línea utilizando una misma pluma. Esto se consigue mediante el trazado de varias líneas paralelas. El grosor también se muestra por pantalla.
Otra forma de obtener varios grosores es la que se basa en el uso de varias plumas diferentes. Es decir, cada grosor va asociado a una pluma específica del carrusel. Esta forma es más efectiva para obtener grosores que la anterior.
Fuente | Es un campo numérico usado para especificar el número de fuente o tipo de letra asociado a cada código, de forma que todos los textos registrados con dicho código se dibujarán con el tipo de letra correspondiente a la fuente especificada. Este campo puede tomar cualquier valor comprendido en el rango [0-255]. Si se indica un valor negativo en este campo se está especificando que se quiere utilizar un tipo de letra TRUE TYPE, en función de los tipos de letra que existan dentro de la lista desplegable. Si por ejemplo, indicamos -3, se tomará como letra la fuente TRUE TYPE que se encuentre en tercer lugar en la lista de las fuentes TRUE TYPE (En la lista desplegable de fuentes TRUE TYPE dentro del Editor de Códigos).
Símbolo Indica el número de símbolo que se va a utilizar a lo largo de una línea, o sobre una entidad puntual. Ejemplos: superposición del símbolo "aspa" sobre una línea para definir la entidad "alambrada", superposición del símbolo fuente en un punto, etc...
El número utilizado se corresponde con el del código asignado al símbolo en el archivo TEXT.TXT (campo 1 del primer registro asociado a cada uno de los símbolos).
En el caso de líneas sin patrón, este campo toma el valor "0".
Distancia Distancia de la posición del símbolo (sólo en el caso lineal). Indica el incremento en distancia utilizado para espaciar los símbolos sobre la línea. Se ha de tener en cuenta que el primer símbolo se coloca con respecto al origen de la línea a una distancia igual a la mitad del incremento especificado.
En la visualización en pantalla la distancia depende de la escala de dibujo, y en la representación obtenida con el plotter de la escala fijada en el programa PLT. El valor se da en décimas de mm. y es el que se obtendrá a la escala resultante de ploteo.
SimbX Indica el tamaño, expresado en décimas de milímetro, con el que ha de dibujarse el símbolo en el sentido del eje X (tamaño sobre papel).
Para definir un símbolo se utiliza un cuadrado de 100 x 100 cm, donde las coordenadas de las esquinas inferior izquierda y superior derecha son: (-50, -50) y (50, 50) respectivamente. El símbolo creado dentro de este espacio, ha de ser escalado de forma que en el dibujo tenga el tamaño especificado en este campo. El programa calculará un factor de escala en X, en función de este valor y de la escala de ploteo.
SimbY Indica el tamaño, expresado en décimas de milímetro, con el que ha de dibujarse el símbolo en el sentido del eje Y.
En este caso, el programa calcula el factor de escala en Y que debe aplicarse al símbolo, en función de la escala de ploteo. Si se trata de un texto en este código, los campos 9 y 10 indican la relación ancho/alto, es decir, los tamaños en X e Y que tomará la letra dentro del font seleccionado. Si se dejan a cero los campos 9 y 10, la relación será 1:1.

Los siguientes campos son campos opcionales y permiten definir al usuario el tipo de línea con que se va dibujar la entidad. Este proceso se realiza especificando la secuencia de trazos que constituyen la línea. Cada trazo se corresponderá con un tramo de cierta longitud, expresada en décimas de mm, que puede ser un segmento dibujado con la pluma correspondiente o un espacio en blanco. Los siguientes campos son:
Tipo de Línea Indica el tipo de línea. Puede tomar los valores:
    0 | Línea continua. El programa termina de forma automática la entidad cada vez que se da un punto. Todas las entidades que se registren con este código, sólo tendrán un punto. Con este tipo de entidades no se puede registrar en modo arrastre.
n | Cualquier número entero positivo, línea discontinua, cuyo primer trazo será un segmento de longitud igual a la especificada por este valor.

Si el campo tuviera el valor 6, indicaría una línea discontinua con un primer tramo de 0,6 mm.
En este caso, los campos que vienen a continuación, expresan alternativamente una secuencia de espacios en blanco y trazos.

Longitud Trazo en Blanco | Indica la longitud del siguiente tramo en blanco (pluma levantada).
Longitud Trazo | Indica la longitud del siguiente trazo (pluma bajada).
etc... La definición del trazado termina cuando uno de estos campos toma el valor cero. A partir de este momento, se repetirá la secuencia especificada a lo largo del trazado de la línea. Ejemplo: campo10 campo11 campo12 campo13 campo14 campo15
10, 5, 6, 2, 15, 0
Ultimo campo | En el último campo se puede poner la nomenclatura correspondiente al código, por ejemplo "CURVAS DE NIVEL FINAS".

En este archivo se usan los delimitadores de campos: coma, comillas, o espacio en blanco.

También es posible definir en este archivo tanto el color de fondo como el color de código desconocidos. Para ello es necesario escribir la primera línea de este archivo con los siguientes campos:

//@ | Para que el programa identifique que en esta línea se identifica el color de fondo y códigos desconocidos debe tener como primer campo //@
Color de fondo | Indica el número de color que se emplea para el fondo de la pantalla. Este número se corresponde con el color definido en el archivo DIGI.PAL.
Color de código nuevo | Indica el número de color que se emplea para representar aquellas entidades que no tengan un código asociado en el archivo DIGI.TAB. Este número se corresponde con el color definido en el archivo DIGI.PAL.

Si quiere ver un ejemplo de archivo DIGI.TAB lea el siguiente tema de la ayuda. Si quiere aprender a crear los códigos lea el tema de la ayuda Simbología en DigiNG.

Fecha de última modificación: martes, 17 de Septiembre de 2002


Ejemplo de archivo DIGI.TAB

    // DIGI.TAB
    "código" 0 código del Digi
    // tipo 1 tipo de entidad. 0: puntual, 1: lineal
    // color 2 color de pantalla
    // pluma 3 numero de pluma (negativo no se dibuja)
    // grosor 4 grosor de ploteo
    // font 5 numero de font para textos
    // símbolo 6 numeral del símbolo
    // distancia 7 distancia posición del símbolo (solo en caso lineal)
    // simbx 8 tamaño del símbolo en x
    // simby 9 tamaño del símbolo en y
    // valores[15] 10 array de valores del tipo de línea en décimas de mm.
    // nemotécnico _ al final del ultimo array
    //
    // poner al final de los valores un cero
    // 1 2 3 4 5 6 7 8 9 10 ............ 0
    //
    // TEMA 1. DIVISIONES ADMINISTRATIVAS  *****************************************
    // TRAMOS   ---------------------------------------------------------------------------
    010401 1 007 8 0 1 015 030 20 20 20 10 00 00 "LIMITE DE NACIÓN"
    010301 1 004 8 0 1 015 060 20 20 20 10 00 00 "LIMITE DE AUTONOMÍA"
    010201 1 012 1 0 1 015 060 20 20 20 10 00 00 "LIMITE DE PROVINCIA"
    010101 1 009 1 0 1 015 090 20 20 20 10 00 00 "LIMITE DE MUNICIPIO"
    017401 3 010 1 0 1 000 000 00 00 20 10 00 00 "PERÍMETRO PARQUE NACIONAL"
    017501 3 002 1 0 1 000 000 00 00 20 10 00 00 "PERÍMETRO PARQUE NATURAL"
    // ENTIDADES SUPERFICIALES  --------------------------------------------------------
    015401 0 007 1 0 1 000 000 00 00 00 00 00 00 "CENTROIDE DE NACIÓN"
    015301 0 004 1 0 1 000 000 00 00 00 00 00 00 "CENTROIDE DE AUTONOMÍA"
    015201 0 012 1 0 1 000 000 00 00 00 00 00 00 "CENTROIDE DE PROVINCIA"
    016101 0 002 1 0 1 000 000 00 00 00 00 00 00 "CENTROIDE DE COMARCA"
    // ENTIDADES PUNTUALES  -------------------------------------------------------------
    018501 0 006 1 0 1 014 000 20 20 00 00 00 00 "MUGA"
    018507 0 009 1 0 1 013 000 20 20 00 00 00 00 "MOJÓN INTERMUNICIPAL"
    018506 0 014 1 0 1 013 000 20 20 00 00 00 00 "MOJÓN DE TRES TÉRMINOS"
    // TEMA 2. RELIEVE  ***************************************************************
    // TRAMOS  ---------------------------------------------------------------------------
    020200 1 006 7 0 1 000 000 00 00 00 00 00 00 "CURVA DE NIVEL (FINA)"
    020400 1 005 5 0 1 000 000 00 00 00 00 00 00 "CURVA DE NIVEL (MAESTRA)"
    020600 1 006 7 0 1 000 000 00 00 60 07 00 00 "CURVA DE DEPRESIÓN (FINA)"
    020800 1 005 5 0 1 000 000 00 00 60 07 00 00 "CURVA DE DEPRESIÓN (MAESTRA)"
    021000 1 042 7 0 1 000 000 00 00 60 07 00 00 "# CURVA OCULTA (FINA)"
    021200 1 043 5 0 1 000 000 00 00 60 07 00 00 "# CURVA OCULTA (MAESTRA)"
    021151 1 008 7 0 1 016 030 30 30 00 00 00 00 "LÍNEA DE TALUD"
    021152 1 003 7 0 1 016 030 30 30 00 00 00 00 "LÍNEA DE DESMONTE"
    021153 1 003 7 0 1 016 030 30 30 00 00 00 00 "LÍNEA DE TERRAPLÉN"
    021220 1 039 4 0 1 016 050 10 10 00 00 00 00 "# MURO DE CONTENCIÓN"
    // ENTIDADES PUNTUALES  -------------------------------------------------------------
    028110 0 007 1 0 1 014 000 20 20 00 00 00 00 "SEÑAL DE NIVELACIÓN"
    028112 0 015 1 0 1 012 000 10 10 00 00 00 00 "PUNTO ACOTADO"
    // TEMA 3. HIDROGRAFÍA.  *********************************************************
    // TRAMOS  --------------------------------------------------------------------------
    // MODO VIRTUAL  --------------------------------------------------------------------
    030190 1 001 2 1 0 000 000 00 00 00 00 00 00 "CURSO REPRESENTADO POR UNA LÍNEA"
    030192 1 001 2 0 0 000 000 00 00 00 00 00 00 "MARGEN DE RÍO/ARROYO"
    030291 1 001 2 1 0 000 000 00 00 00 00 00 00 "CURSO FLUVIAL INTERMIT. UNA LÍNEA"
    030292 1 001 2 1 0 000 000 00 00 00 00 00 00 "MARGEN CURSO FLUVIAL INTERMIT."
    030194 1 001 2 1 0 000 000 00 00 00 00 00 00 "EJE DE CURSO FLUVIAL"
    030394 1 009 2 0 0 019 150 15 15 00 00 00 00 "EJE DE ACEQUIA/CANAL"
    030392 1 009 2 0 0 000 000 00 00 00 00 00 00 "MARGEN DE ACEQUIA/CANAL"
    // MODO NORMAL  ----------------------------------------------------------------------
    030100 1 032 2 1 1 000 000 00 00 00 00 00 00 "CURSO REPRESENTADO POR UNA LÍNEA"
    030102 1 032 2 0 1 000 000 00 00 00 00 00 00 "MARGEN DE RÍO/ARROYO"
    030201 1 032 2 1 1 000 000 00 00 00 00 00 00 "CURSO FLUVIAL INTERMIT. UNA LÍNEA"
    030202 1 032 2 1 1 000 000 00 00 00 00 00 00 "MARGEN CURSO FLUVIAL INTERMIT."
    030104 1 032 2 1 1 000 000 00 00 00 00 00 00 "EJE DE CURSO FLUVIAL"
    030304 1 033 2 0 1 019 150 15 15 00 00 00 00 "EJE DE ACEQUIA/CANAL"
    030305 1 033 2 0 1 019 150 15 15 00 00 00 00 "EJE DE ACEQUIA/CANAL (PARC. URB.)"
    030302 1 033 2 0 1 000 000 00 00 00 00 00 00 "MARGEN DE ACEQUIA/CANAL"
    032301 1 033 2 1 1 000 000 00 00 00 00 00 00 "LÍNEA DE COSTA"

Fecha de última modificación: martes, 17 de Septiembre de 2002


Formato del archivo DIGI.PAL

Es un archivo ASCII que contiene la relación entre un número de color y sus componentes RGB.

El número de color se utiliza en el tercer campo del archivo DIGI.TAB para asignar el color de visualización de las entidades de cada código y el color que se utiliza en la impresión desde el entorno de Digi21. También se utiliza este número de color para especificar, en el segundo campo de la tabla DIGI.TAB, un color de relleno para las entidades cerradas. Se puede asignar como color de relleno cualquiera que tenga un número de color entre 2 y 255. El número de color se usa para determinar, mediante las órdenes COLOR_FONDO y COLOR_TENTATIVO, el color de fondo de la pantalla y el de las entidades seleccionadas.

Este fichero de texto está compuesto de una serie de líneas y en cada una de ellas tiene que haber tres valores, entre 0 y 255, separados por comas, comillas o espacios en blanco. Estos valores son las componentes RGB del color correspondiente a la pluma con número igual al número de línea menos 1. Es decir, en la primera línea de este fichero se indican los tres valores RGB del color asociado al número 0. En la segunda se indicarían los valores RGB del color correspondiente al 1, etc.

No es necesario definir los 256 colores permitidos, sólo hay que definir los utilizados, pero en su línea correspondiente.

Se puede obtener fácilmente los valores RGB de un determinado color a través del programa Paint de Windows. Eligiendo Modificar colores dentro de Colores en el menú principal de dicha aplicación:

se presenta un cuadro de diálogo. Si se pulsa sobre el botón Definir colores personalizados:

se despliega un cuadro de colores:

Pulsando con el ratón sobre este cuadro se selecciona un color. Las componentes RGB del color elegido se indican en las casillas Rojo, Verde y Azul.

Si no existe ningún fichero DIGI.PAL en el directorio de Tablas, en el directorio de trabajo o en el directorio C:\DIGI, se utilizarán unos valores por defecto para cada número de color.

Si quiere ver un ejemplo del archivo DIGI.PAL lea el siguiente tema de la ayuda.

Fecha de última modificación: martes, 17 de Septiembre de 2002


Ejemplo de archivo DIGI.PAL

  0 0 0
  0 0 168
  0 168 0
  0 168 168
  168 0 0
  168 0 168
  168 84 0
  200 200 200
  84 84 84
  84 84 252
  84 252 84
  84 252 252
  252 84 84
  252 84 252
  252 252 84
  128 128 128
  255 255 255
  20 20 20
  32 32 32
  44 44 44
  56 56 56
  68 68 68
  80 80 80
  96 96 96
  112 112 112

Fecha de última modificación: martes, 17 de Septiembre de 2002


Formato del archivo TEXT.TXT

Es un archivo ASCII que se utiliza para definir símbolos y caracteres o tipos de letra. Este archivo no es leído directamente por el programa DigiNG. Para que pueda ser utilizado, es necesario transformarlo previamente a formato binario mediante el programa COMTEXT desde una ventana de DOS.

Como resultado de la operación, se obtiene un nuevo archivo en binario llamado TEXT.FNT, que es utilizado por el sistema, es decir, el archivo que DigiNG leerá será el TEXT.FNT. Debe existir un archivo TEXT.FNT en el directorio de trabajo, en el de tablas o en C:\DIGI para que el programa pueda funcionar correctamente.

Existe otro programa complementario, llamado TEXTCOM, que realiza la operación inversa, permitiendo pasar de un fichero TEXT.FNT a un fichero TEXT.TXT. Ambos programas se pueden obtener, junto con otros programas accesorios y ejemplos de ficheros y tablas, en la dirección de Internet www.digi21.net, en la sección Descargas / Accesorios.

Para diseñar el archivo ASCII TEXT.TXT, hay que tener en cuenta lo siguiente:

  • Cada símbolo o tipo de letra que se defina, estará compuesto por un número variable de líneas, tantas como hagan falta para determinar geométricamente su forma.
  • En la secuencia de líneas que definen cada elemento, se distinguen dos tipos:
    • Líneas con la especificación del elemento, es decir, el símbolo o letra que se va a definir. Sólo puede haber uno en cada secuencia, y es el primero de la misma.
    • Líneas con las coordenadas X, Y de los puntos que definen la geometría del elemento.

Para definir un tipo de letra cualquiera o un símbolo, utilizaríamos la siguiente estructura:

Línea 1
    Campo 1 | Especifica el código correspondiente al símbolo o letra (en un cierto font) que se va a definir. Este código es un valor numérico comprendido en el rango [1 - 65535]. Los números de fonts o tipos de letra diferentes que se pueden crear en Digi, se hayan comprendidos en el rango [0 - 255]. Para calcular el número o código correspondiente a un carácter en un cierto font, hay que usar la fórmula siguiente: código = (nº_font * 256) + nº_ASCII_carácter Todos los caracteres tienen asociado un número en la tabla ASCII. Como ejemplo de esta tabla, véase la siguiente relación: carácter-nº_ASCII: carácter nº_ASCII A 65 Z 90 a 97
Campo 2 | Es un campo opcional y se suele utilizar para indicar el nombre del carácter o del símbolo. Es un campo informativo.
Líneas siguientes
    Campo 1 | Puede tomar uno de estos dos valores, 3 ó 4. El número 3 indica el inicio de una línea a partir de las coordenadas escritas en los dos campos siguientes. El número 4 indica la continuación del trazado de una línea. El resultado sería un segmento (vector) definido por las coordenadas del punto anterior y las que aparecen en los campos 2 y 3 de este registro.
Campo 2 | Coordenada X del punto.
Campo 3 | Coordenada Y del punto.

Para definir geométricamente un símbolo o un carácter hay que tener en cuenta el sistema de referencia que se utiliza en cada caso:

  • Caracteres: Se trabaja en un espacio cuadrangular de 100 x 100 unidades (cm.). El origen del sistema coincide con la esquina inferior izquierda de este cuadrado, de forma que las coordenadas pueden variar en un rango de [0, 0] a [+100, +100]. Las dimensiones del carácter definido se reajustan a las del dibujo, usando como factor de conversión el valor (expresado en metros) asignado a la variable AT. El carácter se insertará en el archivo a partir del punto origen.
  • Símbolos: Se trabaja en un espacio cuadrangular de 100 x 100 unidades (cm.). El origen del sistema coincide con el centro de este cuadrado, de forma que las coordenadas pueden variar en un rango de [-50, -50] a [+50, +50]. Los símbolos creados se insertarán en el archivo de dibujo a partir de este origen o punto central.

Si quieres ver un ejemplo de archivo TEXT.TXT lee el siguiente tema de la ayuda.

Fecha de última modificación: martes, 17 de Septiembre de 2002


Ejemplo de archivo TEXT.TXT

  <Definición del símbolo vértice geodésico>
  10 @10 Vértice (El símbolo se hace corresponder, a elección del usuario, con el código 10. Se reconoce que es un símbolo por utilizar el signo @)
  3,0,50 (El primer punto del trazado tiene las coordenadas (0,50)).
  4,50,-50 (Se forma un segmento entre el punto anterior y el punto (50,-50)).
  4,-50,-50 (Se forma un segmento entre el punto anterior y el punto (-50,-50)).
  4,0,50 (Se forma un segmento entre el punto anterior y el punto (0,50)).
  3,0,20 (Empieza un nuevo segmento en el punto (0,20)).
  4,20,-20 (etc...)
  4,-20,-20

  <Definición de la letra "A" en el font cero>
  65 A (0*256+65)
  3 0 0
  4 0 100
  4 50 100
  4 50 0
  3 0 50
  4 50 50

  <Definición de la letra "A" en el font uno>
  321 A (1*256+65)
  3,5,5
  4,40,94
  4,48,94
  4,81,5
  3,71,25
  4,16,25

  <Definición de la letra "A" en el font dos>
  577 A (2*256+65)
  3,43,99
  4,10,0
  4,0,0
  4,29,0
  3,57,0
  4,86,0
  4,76,0
  4,43,99
  3,43,85
  4,71,0
  3,62,28
  4,19,28

Fecha de última modificación: martes, 17 de Septiembre de 2002


Formato del archivo de plumas (.PLU)

Es un archivo ASCII que contiene la relación entre un número de pluma y su grosor en cm.

La primera fila de este tipo de archivos debe contener la siguiente palabre entre corchetes: [GROSOR]. Las restantes filas del archivo definen los grosores correspondientes a cada número de pluma. Cada fila especifica una pluma, siguiendo esta sintaxis:

nº pluma=grosor en cm.

Los números identificativos de pluma deben ser consecutivos y comenzar con el número 0. Este número de pluma está relacionado con el campo Pluma dentro del archivo de definición de códigos (.tab).

Si quiere ver un ejemplo de este tipo de archivpos lea el siguiente tema de la ayuda.

Fecha de última modificación: miércoles, 9 de Octubre de 2002


Ejemplo de archivo de plumas (.PLU)

[GROSOR]
0=0.1
1=0.15
2=0.2

Fecha de última modificación: miércoles, 9 de Octubre de 2002


Formato de archivo .ORT

Este tipo de archivos se utiliza para georreferenciar imágenes enDigiNG. Debe tener el mismo nombre y estar dentro del mismo directorio que la imagen que georreferencia, y además debe tener la extensión ORT. Tiene la siguiente estructura:

[ORT] | La primera línea siempre debe ser '[ORT]'.
Pixel | La segunda línea especifica el tamaño de píxel en unidades terreno.
X | La tercera línea especifica la coordenada X en unidades terreno de la esquina superior izquierda del píxel situado en la esquina superior izquierda de la imagen.
Y | La cuarta línea especifica la coordenada Y en unidades terreno de la esquina superior izquierda del píxel situado en la esquina superior izquierda de la imagen.

Este tipo de archivos se genera bien al realizar una Ortofotografía Digital con Digi21, o bien al ejecutar la orden CORTAR_RASTER.

Si desea ver un ejemplo de este tipo de archivos lea el siguiente tema de la ayuda.

Fecha de última modificación: martes, 17 de Septiembre de 2002


Ejemplo de archivo .ORT

Este es un ejemplo de archivo .ORT:

[ORT]
Pixel=100.000000
X=421245.630000
Y=4485562.220000

Fecha de última modificación: martes, 17 de Septiembre de 2002


Formato de archivo .TFW

Este tipo de archivos se utiliza para georreferenciar imágenes en DigiNG. Debe tener el mismo nombre y estar dentro del mismo directorio que la imagen que georreferencia, y debe tener la extensión TFW. Tiene la siguiente estructura:

Ancho Píxel | La primera línea especifica el ancho del píxel en unidades terreno
0.000 | La segunda línea debe ser cero.
0.000 | La tercera línea debe ser cero.
Alto píxel | La cuarta línea especifica el alto del píxel en unidades terreno. Debe ser negativa.
X | La quinta línea especifica la coordenada X en unidades terreno del centro del píxel situado en la esquina superior izquierda de la imagen.
Y | La sexta línea especifica la coordenada Y en unidades terreno del centro del píxel situado en la esquina superior izquierda de la imagen.

Este tipo de archivos se genera al ejecutar la orden CORTAR_RASTER.

Si desea ver un ejemplo de este tipo de archivos lea el siguiente tema de la ayuda.

Fecha de última modificación: martes, 17 de Septiembre de 2002


Ejemplo de archivo .TFW

Este es un ejemplo de archivo .TFW:

100.000
0.000
0.000
-100.000
421295.630
4485512.220

Fecha de última modificación: martes, 17 de Septiembre de 2002


Formato de archivo .GEO

Este tipo de archivos se utiliza para georreferenciar imágenes en DigiNG. Debe tener el mismo nombre y estar dentro del mismo directorio que la imagen que georreferencia, y debe tener la extensión GEO. Tiene la siguiente estructura:

Xmin, Ymin | La primera línea especifica las coordenadas X e Y mínimas de la imagen.
Xmax, Ymax | La segunda línea especifica las coordenadas X e Y máximas de la imagen.

Este tipo de archivos se genera al ejecutar la orden CORTAR_RASTER.

Si desea ver un ejemplo de este tipo de archivos lea el siguiente tema de la ayuda.

Fecha de última modificación: martes, 17 de Septiembre de 2002


Ejemplo de archivo .GEO

Este es un ejemplo de archivo .GEO:

421245.630,4281662.220
621045.630,4485562.220

Fecha de última modificación: martes, 17 de Septiembre de 2002


Formato de archivo .UTM

Este tipo de archivos se utilizan junto con la orden TRANSFORMA_RASTER. Tiene la siguiente estructura:

X Y | La primera línea especifica la coordenadas X, Y de la esquina SO.
X Y | La segunda línea especifica la coordenadas X, Y de la esquina NO.
X Y | La tercera línea especifica la coordenadas X, Y de la esquina NE.
X Y | La cuarta línea especifica la coordenadas X, Y de la esquina SE.

Si desea ver un ejemplo de este tipo de archivos lea el siguiente tema de la ayuda.

Fecha de última modificación: sábado, 3 de Mayo de 2003


Ejemplo de archivo .UTM

Este es un ejemplo de archivo .UTM:

338962.67 4316645.83
338612.88 4317040.08
339295.85 4317446.47
339468.70 4316977.30

Fecha de última modificación: sábado, 3 de Mayo de 2003


IMPORTADORES

Con Digi3D podras importar los siguientes tipos de archivos:

  • ASCII de Digi.
  • DGN (MicroStation).
  • ASCII de Kork.
  • DXF (AutoCAD).
  • ArcView.

Puedes importar de varias formas diferentes desde DigiNG:

  • Por el método interactivo, ejecutando la orden IMPORTAR.
  • Importar desde la línea de órdenes.

Fecha de última modificación: 18 de Diciembre de 2003


Importación de Ficheros DGN

DigiNg te ofrece la posibilidad de importar (o convertir) un fichero de MicroStation™ con extensión .DGN.

Requisitos
  • Programa DigiNG (incluido en el restituidor digital Digi3D).
  • Tabla de conversión de formatos (DGNBIN.TAB).

A continuación se explicarán los métodos de importación Interactivo y por Linea de órdenes. Por último se muestra y describe la tabla de conversión de DGN a BIN, para poder transformar la simbología de MicroStation™ a código de Digi. Finalmente se realiza un ejemplo, en el que partimos de un archivo DGN y una tabla de conversión (DGNBIN.TAB), y generamos el archivo en formato BIN.

SIGUIENTE >

Mirar también

Exportación de Ficheros .BIN a .DGN

Fecha de última modificación: martes, 18 de Diciembre de 2003
© 2001 Dreaming With Objects. Todos los derechos reservados.


Importación de Ficheros DGN

Para convertir un fichero de formato DGN a BIN es necesario conocer cómo tenemos los elementos en MicroStation™ y cómo los queremos en DigiNG. Y con ello se define la tabla DGNBIN.TAB, y se debe almacenar en el mismo directorio donde esté el archivo DGN. El archivo DGN de este ejemplo tiene el nombre de Ejemplo.dgn.

Entramos en DigiNG, y en la ventana de inicio.

Creamos un nuevo archivo BIN vacío, en este caso Ejemplo.bin. Una vez dentro de DigiNGejecutamos la orden IMPORTAR, donde seleccionamos en la lista desplegable inferior Archivo DGN, y luego seleccionamos el archivo que vamos a transformar a formato BIN. Al pulsar el botón Abrir nos aparece la siguiente ventana:

donde podemos seleccionar la tabla de traducción, el factor de escala, si queremos transformar las células, ... Seleccionamos lo que nos interese y luego pulsamos sobre el botón Aceptar.Y ya está convertido el archivo Ejemplo.dgn en el archivo Ejemplo.BIN:

Si quieres seguir este ejemplo, bájate los archivos dgnbin.zip de nuestra página de descargas.

SIGUIENTE >

Mirar también

Exportación de Ficheros .BIN a .DGN | IMPORTAR

Fecha de última modificación: 18 de Diciembre de 2003
© 2003 Dreaming With Objects. Todos los derechos reservados.


Tabla para la importación de Ficheros DGN

DigiNg te ofrece la posibilidad de importar (o convertir) un fichero de MicroStation™ con extensión .DGN.

Tabla DGNBIN.TAB

MicroStation™ no diferencia los códigos como DigiNG. En DigiNG tenemos una cadena de seis caracteres que identifica cada código. En MicroStation tenemos dos opciones:

  • Diferenciar los elementos por la composición de cuatro valores: Nivel, Estilo, Color y Peso.
  • Diferenciar los elementos por su Grupo Gráfico.

DigiNG MicroStation™
Código
Nivel Estilo Color Peso
ó
Grupo Gráfico

Tendremos que solicitar al cliente su tabla de códigos, y generar una tabla de traducción que relacione un código de Digi con los valores de la tabla de códigos del cliente.

La tabla de traducción es un archivo ASCII (que podemos generar con el programa Bloc de Notas) que tiene el nombre DGNBIN.TAB y su formato es el siguiente:

    Código DigiNG | Código correspondiente a DigiNG.
Nivel | Es el nivel en el que se encuentre el elemento en MicroStation.
Estilo de línea | Es el estilo de línea del elemento en MicroStation.
Color | Es el color del elemento en MicroStation.
Peso | Es el peso (grosor) del elemento en MicroStation.
Fuente | Fuente de MicroStation.
Grupo gráfico (gg) | Si se usa el grupo gráfico los datos correspondientes a MicroStation™ (nivel, estilo, color y peso) estarán a cero. En el caso de que se utilicen los datos correspondientes a MicroStation (nivel, estilo, color, peso), el grupo gráfico será cero.
Nombre célula | La siguiente columna es el nombre de la célula si existe. En el caso de que no se trate de una célula se pone un espacio en blanco " ", que sirve para materializar esa posición.
Alto | Se trata de un factor de escala que se aplica a las células.
Símbolo Digi | Correspondencia con el símbolo de DigiNG.

La tabla puede tener una cabecera comentario, comenzando estas líneas de comentario con los caracteres '//'

Un ejemplo de línea de este archivo puede ser:

//COD   LV   ST   CO   WT   FONT   GG   CELL  ALTO  SIMB.DIGI
00100    1    2    3    4    0     0    " "

Si hay en el fichero elementos que sean pattern component, de ellos no se traduce el patrón sino la línea generadora.

Para poder recuperar los symbol font en DigiNG se deberán poner en la tabla en correspondencia con los mismos los símbolos Digi (@<n>) que habrán de representarlos. Por ejemplo, en la siguiente línea, a la célula con el nombre 'W' le corresponde el símbolo @166 de DigiNG, por lo tanto, siempre que aparezca "W" en el fichero DGN, será sustituido en el fichero BIN por el @166:

//COD   LV   ST   CO   WT   FONT   GG   CELL  ALTO  SIMB.DIGI
001118  20    0    0    1    0    1118    W     1     @166

Fichero de Error

Si en el fichero .DGN existe una entidad que no haya sido considerada en la tabla de traducción, DigiNG generará un fichero de error, con extensión .err.

En este fichero de error se informa sobre los atributos del código que no ha sido capaz de reconocer. El formato de dicho fichero de error es el siguiente:

Nivel(LV)  Estilo(ST)  Color(CO)  Peso(WT)  Fuente(FONT)  GrupoGráfico(GG)  Célula(CELL)

Mirar también

Conversión de Ficheros .BIN a .DGN | IMPORTAR

Fecha de última modificación: martes, 18 de Diciembre de 2003
© 2001 Dreaming With Objects. Todos los derechos reservados.


Importación de Ficheros DXF

DigiNG te ofrece la posibilidad de importar (o convertir) un fichero de AutoCAD™ con extensión .DXF.

Requisitos
  • Programa DigiNG (incluido en el restituidor digital Digi3D).
  • Tabla de conversión de formatos (DXFBIN.TAB). (Opcional)

A continuación se explicarán los métodos de importación Interactivo y por Linea de órdenes. Por último se muestra y describe la tabla de conversión de DXF a BIN, para poder transformar la simbología de AutoCAD™ a código de Digi. Finalmente se realiza un ejemplo, en el que partimos de un archivo DXF y una tabla de conversión (DXFBIN.TAB), y generamos el archivo en formato BIN.

SIGUIENTE >

Mirar también

Exportación de Ficheros .BIN a .DGN

Fecha de última modificación: 20 de Enero de 2004
© 2001 Dreaming With Objects. Todos los derechos reservados.


Importación de Ficheros DXF

DigiNG te ofrece la posibilidad de convertir un fichero de AutoCAD con extensión .DXF al correspondinte fichero .BIN.

Requisitos
  • Programa DigiNG (incluido en el restituidor digital Digi3D).
  • Programa DXFBIN.exe, que se puede encontrar en la Págian de Digi21, bajo Descargas/ DXFBIN.
  • Opcional: Tabla de conversión de formatos (DXFBIN.TAB).
Una vez instalado el DXFBIN.msi. Es posible ejecutar el programa DXFBIN.exe.

Al ejecutarlo aparece la siguiente ventana:

Aquí podrá definir los ficheros a transformar, la precisión de archivo BIN y la tabla de traducción, en el caso de que la necesite.

Una vez rellenados los campos, pulse el botón de comenzar.

El archivo creado será guardado automáticamente en el directorio en el cual está el archivo DXF que se ha transformado.

Mirar también

Conversión de Ficheros .BIN a .DGN | IMPORTAR

Fecha de última modificación: 20 de Enero de 2004
© 2001 Dreaming With Objects. Todos los derechos reservados.


EXPORTADORES

Con Digi3D podrás exportar los siguientes tipos de archivos:

  • Archivos .bin de la versión 2003 y anteriores.
  • ASCII de Digi.
  • DGN (MicroStation).
  • ASCII de Kork.
  • DXF (AutoCAD).
  • ASCII photomod

Puedes exportar de varias formas diferentes desde DigiNG:

  • Por el método interactivo, ejecutando la orden EXPORTAR

Fecha de última modificación: 27 de Enero de 2004


Conversión de ficheros BIN a DGN

Digi3D

Traducción de Bin a DGN

Este tutorial le guiará paso a paso en la traducción de archivos creados por Digi (Digi21 y DigiNG) a formato .DGN.

Requisitos
  • MicroStation™ instalado.
  • Módulo BINDGN.MA
  • Una tabla de traducción BINDGN.TAB.
  • Un archivo de semilla.
  • Un archivo de células (archivo con extensión .cel).
  • Archivos de Digi (con extensión .bin) a traducir.

Si necesitas el módulo BINDGN.MA, una tabla de traducción de ejemplo BINDGN.TAB, un archivo de semilla de ejemplo y un archivo de células de ejemplo puedes descargar el archivo BinDGN de nuestra página de descargas.

Fecha de última modificación: 13 de Enero de 2004
© 2001 Dreaming With Objects. Todos los derechos reservados.


Conversión de ficheros BIN a DGN

Digi3D

Traducción de Bin a DGN

Este tutorial le guiará paso a paso en la traducción de archivos creados por Digi (Digi21 y DigiNG) a formato .DGN.

Requisitos
  • MicroStation™ instalado.
  • Módulo BINDGN.MA
  • Una tabla de traducción BINDGN.TAB.
  • Un archivo de semilla.
  • Un archivo de células (archivo con extensión .cel).
  • Archivos de Digi (con extensión .bin) a traducir.

Si necesitas el módulo BINDGN.MA, una tabla de traducción de ejemplo BINDGN.TAB, un archivo de semilla de ejemplo y un archivo de células de ejemplo puedes descargar el archivo BinDGN de nuestra página de descargas.

Paso1: Instalación del módulo BINDGN.MA

Este paso se realizará únicamente la primera vez que hagamos la conversión. Una vez realizada esta instalación, no hará falta repetir este proceso

El módulo BINDGN.MA es propiamente dicho el programa de traducción. No tiene extensión .EXE por que no es un programa que se pueda ejecutar directamente desde Windows, si no que es un tipo de programa especial que se ejecuta únicamente desde dentro de MicroStation™.

Pero para que se pueda ejecutar un módulo, éste tiene que estar copiado dentro de un directorio especial que es: c:\win32apps\ustation\mdl.

Paso 1.1: Descomprimimos el archivo bindgn.zip

Descomprimimos el archivo bindgn.zip, que como se explicó en el paso anterior contiene el traductor y una serie de tablas de ejemplo en un directorio nuevo, por ejemplo c:\ejemplo

Paso 1.2: Copiamos el módulo BINDGN.MA en el directorio c:\win32apps\ustation\mdl:

Ya hemos completado el proceso de instalación del módulo BINDGN.MA.

Paso 1.3: Copiamos el módulo BINDGN.BA en el directorio c:\win32apps\ustation\macros:

Ya hemos completado el proceso de instalación del módulo BINDGN.BA.

Paso 2: Creación de la tabla de traducción

MicroStation™ no diferencia los códigos como Digi. En Digi tenemos una cadena de seis caracteres que identifica cada código. En MicroStation™ diferenciamos los elementos por la composición de cuatro valores: Nivel, Estilo, Color y Peso y opcionalmente Grupo Gráfico.

Digi MicroStation™
Código
Nivel Estilo Color Peso Grupo Gráfico*
* Opcional.

Tendremos que solicitar al cliente su tabla de códigos, y generar una tabla de traducción que relacione un código de Digi con los valores de la tabla de códigos del cliente.

La tabla de traducción es un archivo ASCII (que podemos generar con el programa Bloc de Notas) que tiene el nombre BINDGN.TAB y su formato es el siguiente:

Código Nivel Estilo Color Peso Tipo de Letra Grupo Gráfico Célula Tipo de entidad Altura Texto Y Altura Texto X Justificación Color de relleno Nemotécnico
Código de Digi a traducir Valor de Nivel para este código según la tabla de códigos del cliente. El valor nivel es un número en el rango [1-63]. Campo numérico que indica el estilo de línea con que se dibujará una entidad lineal. Si se indica en este campo un valor numérico negativo ó que no este comprendido entre 0 y 7, se utilizará el estilo de línea personalizado que se indique en el campo nombre de célula o estilo de línea. Si este estilo de línea no está asociado al espacio de trabajo actual de MicroStation se utilizará el estilo 0 y se indicará el error en el fichero de errores. Campo numérico que indica el color con que se visualizará la entidad Campo numérico que indica el peso o ancho de la línea Campo numérico que indica el tipo de letra o font a utilizar en la transformación de los textos Campo numérico que indica el grupo gráfico al que se quiere asociar la entidad. Si no se desea utilizar un grupo gráfico, este campo toma el valor cero

Campo alfanumérico que indica el nombre de la célula o estilo de línea personalizado que se va a utilizar en la representación de la entidad. Si es una célula ha de estar definida en la librería de células usada en la llamada al programa. Si no se utiliza ninguna célula directamente, ni patrones lineales, ni estilo de línea personalizado, y tampoco se va a usar este campo para indicar el texto a insertar en un elemento puntual, ha de indicarse un valor nulo en este campo. Este valor nulo se representa por dos comillas dobles <"">.

Campo numérico que indica el tipo de entidad a usar en MicroStation. Puede tomar los siguientes valores:

  1. Entidad del tipo linea, polilínea o line string para elementos lineales y estilos de línea personalizados Si la entidad de Digi tiene más de 101 vértices se transformará en tantos elementos de tipo line string como sea necesario.

  2. Entidad del tipo forma o shape. Si la línea en Digi es cerrada se transforma en una forma poligonal, en caso contrario en una polilínea. Si la entidad de Digi tiene más de 101 vértices no se puede crear una forma poligonal y en este caso se transformará en tantos elementos de tipo line string como sea necesario.

  3. Entidad del tipo patrón lineal o pattern line, poniendo a lo largo de la línea la célula especificada en el campo nombre de célula o estilo de línea. Si existe un error al asignar la célula se transformará el elemento con estilo de línea 0 y se indicará en el fichero de errores. Si la entidad de Digi tiene más de 101 vértices se divide en tantos elementos como sea necesario.

  4. Entidad del tipo célula o cell para elementos puntuales. Un elemento puntual en Digi no es necesario que siempre se transforme en una célula. Se puede usar una transformación a una línea de longitud nula (puntos inicial y final coincidentes). Si existe un error al asignar la célula se transformará el elemento en una línea de longitud nula y se indicará en el fichero de errores.

  5. Entidad del tipo texto para elementos puntuales. Es posible transformar un código puntual de Digi en una secuencia de caracteres determinada. El texto que se insertará en las coordenadas del punto se indica en el campo 8, es decir, con el nombre de la célula. La altura de los caracteres del texto se corresponde con el valor especificado en el campo 10, es decir, con el factor de escala de altura. La anchura de los caracteres se corresponde con el factor de escala de anchura del campo 11. El font o tipo de letra utilizado para el texto, será el indicado en el campo 6. La justificación del texto se indica en el campo 12.
    Por ejemplo, si se quisiera insertar el texto "Tc" con el font 65 sin modificar el tamaño de los caracteres originales y con justificación inferior izquierda, en una serie de puntos procedentes del archivo Digi, en el fichero BINDGN.TAB habría que especificar los siguientes valores en los registros correspondientes a los códigos de esos elementos puntuales:
    campo 6: 65
    campo 8: "Tc"
    campo 9: 4
    campo 10: 1
    campo 11: 1
    campo 12: 2
    Ver apartado Traducción de elementos Digi de tipo texto a elementos DGN del tipo célula.

Campo numérico que indica la altura de texto, especificada en las mismas unidades que el fichero de dibujo.

Campo numérico que indica la anchura de texto, especificada en las mismas unidades que el fichero de dibujo. Si se quiere mantener la proporción del original deberá indicarse el mismo valor que en el campo anterior.

  • Campo numérico utilizado para indicar la justificación de los textos. Puede tomar los siguientes valores:

    1. Justificación superior-izquierda
    2. Justificación centro-izquierda
    3. Justificación inferior-izquierda
    4. Justificación margen izquierdo-superior
    5. Justificación margen izquierdo-centro
    6. Justificación margen izquierdo-inferior
    7. Justificación superior-centro
    8. Justificación centro-centro
    9. Justificación inferior-centro
    10. Justificación margen derecho-superior
    11. Justificación margen derecho-centro
    12. Justificación margen derecho-inferior
    13. Justificación superior-derecha
    14. Justificación centro-derecha
    15. Justificación inferior-derecha
    127. Sin Justificación

Campo numérico para indicar el color de relleno. Si el valor de este campo es cero no se rellenarán las entidades. Si es un valor distinto de cero y la entidad es lineal y cerrada se aplicará este color de relleno.
MicroStation presenta en pantalla los elementos en el orden en que han sido escritos en el fichero, por ello un elemento relleno puede impedir la visualización de elementos escritos anteriormente. Si se quiere controlar la visualización de los rellenos debe prepararse el archivo Digi previamente al traspaso, de modo que las entidades que deben visualizarse rellenas estén en primer lugar en el fichero Digi, los rellenos que deben visualizarse encima, en segundo lugar y así sucesivamente. La preparación del fichero se realiza fácilmente extrayendo del dibujo las entidades que van a ser rellenadas con el programa BINSELEC y realizando una unión de los ficheros resultantes con BINUNION según el orden que se desee de visualización.

Campo alfanumérico utilizado como nemotécnico. Es un campo opcional.

Si una línea comienza por el carácter / se toma como una línea de comentarios.

Ejemplo de una tabla de traducción:

//COD   LV   ST  CO  WT  FONT  GG  CELL        Tipo   Ty    Tx   Just Col_relleno
0       24    0   0   0   1     0   ""           4    10    10    0    0   "texto general"
1       63    0   0   0   1     0   ""           4    10    10    0    0   "Linea de límite"
5        6    0   0   2   23    0   ""           4    10    10    2    0   "texto curva maestra"
TBARRA  10    0   0   2   23    0   ""           4    10    10    2    0   "TEXTO BARRANCO"
HOJAS    24   0   0   0   1     0   ""           4    10    10    0    0   "texto general"
000102   4    0   0   1   31    0   ""           4    8.75  8.75  0    0   "vertice orden inferior"
010123   62   0   0   4   1     0   "LIMITP"     2    0.5   0.5   0    0   "lim. provincia"
010223   62   0   0   3   23    0   ""           2    17.5  17.5  0    0   "texto lim. municipal"
010323   20   0   0   2   23    0   ""           0    15    15    0    0   "lim. comarcal"
010324   28   0   0   2   31    0   ""           0    10    8.75  0    0   "lim. comunidad"
020123   3    0   6   0   1     0   ""           0    1     1     0    0   "curva de nivel fina"
020124   2    0   5   2   1     0   ""           0    1     1     2    0   "curva directora"
020401   8    0   0   0   31    0   "COTP"       3    7.5   7.5   2    0   "cota altimetrica"
020402   8    0   0   0   31    0   ""           4    10    10    2    0   "Texto de cota altimetrica"
030127   10   3   1   1   1     0   ""           0    1     1     0    0   "vaguada"
040124   22   0   2   0   1     0   ""           0    1     1     0    0   "linde de parcela"
040256   21   0   2   0   1     0   "BOSQUE"     2    0.45  0.45  0    0   "MASA DE ARBOLES"
040523   44   0   3   0   1     0   "MUROC"      2    0.25  0.25  0    0   "muro"
050145   47   0   0   0   1     0   "CERCA"      2    0.25  0.25  0    0   "estructura metalica"
050146   40   0   3   2   1     0   ""           0    1     1     0    0   "edificio privado"
050151   57   2   3   2   1     0   ""           0    1     1     0    0   "edificio ruinas"
050331   40   0   3   0   1     0   ""           0    1     1     0    0   "voladizo"
060142   35   1   0   2   1     0   ""           0    1     1     0    0   "senda"
060145   34   0   0   0   1     0   ""           0    1     1     0    0   "camino"
090102   22   0   0   0   31    0   ""           4    7.5   7.5   2    0   "t.c. terreno de cultivo"

Analizando esta tabla comprobamos que las entidades registradas con el código 060145 (camino) se transformarán en entidades en MicroStation™ en el nivel 34, con el estilo de línea 0 (no se pintará con un estilo de línea personalizado al ser un valor entre 0 y 7), con color 0, con peso 0. Los textos registrados en este código (si es que hay algún texto registrado con el código de camino), se representarán con la fuente 0 de MicroStation™. No se almacena información de Grupo Gráfico para este código, ni tampoco célula (se ha puesto una célula nula ""). Se traducirá como una línea, polilínea o line string (tipo=0) y los textos se pintarán con el mismo alto que ancho que equivaldrá con la altura del texto en el archivo digi. El color de relleno será 0.

El código 090102 "t.c. terreno de cultivo" es prácticamente igual que el anterior pero con la particularidad de que los textos tendrán una altura y anchura de texto de 7.5 unidades (unidades del archivo de Digi).

Paso 3: Traducción del archivo

Vamos a traducir el archivo ejemplo.bin que hemos descomprimido en el primer paso de este tutorial con la tabla bindgn de ejemplo y con el archivo de células de ejemplo.

El archivo de Digi a traducir se llama ejemplo.bin.

El siguiente paso es copiar el archivo de semilla (que nos habrá dado el cliente) con el nombre del archivo dgn a generar.

En nuestro ejemplo disponemos de dos archivos de semilla (semilla2d.dgn y semilla3d.dgn) que nos servirán para traducir archivos en 2D ó en 3D.

Vamos a copiar el archivo semilla2d.dgn con el nombre ejemplo.dgn.

El siguiente paso es hacer doble click en el archivo ejemplo.dgn para que se ejecute el programa de MicroStation© mostrándonos una ventana en negro, ya que el archivo ejemplo.dgn no tiene ninguna entidad (se ha copiado de un archivo de semilla que es un archivo sin entidades pero que tiene información no gráfica, como tipos de línea personalizados...).

El siguiente paso es ejecutar la orden "mdl load bindgn". Este comando lo escribimos en la ventana blanca que aparece en la parte superior del programa como en la siguiente instantánea. Una vez escrito el comando, pulsamos enter.

Aparece el cuadro de diálogo del módulo BINDGN.MA.

Rellenamos los campos como en el siguiente ejemplo:

Pulsamos sobre el botón Aceptar.

El programa se pone a traducir. Cuando termina, aparece una ventana llamada "Text Window" en la que nos aparece el número de entidades traducidas. pulsamos sobre el botón Salir.

Ya sólo nos queda comprobar si se ha traducido bien. Para ello ejecutamos el comando "fit". Cuando ejecutamos este comando el programa nos indica que pulsemos la ventana sobre la que queremos ejecutar ese comando. Hacemos click con el ratón en la ventana del archivo ejemplo.dgn y vemos algo como lo siguiente:

Nos salimos del programa MicroStation© y damos por finalizado este tutorial.

Paso 4: Traducción en grupo

Si queremos traducir más de un archivo a la vez, podemos utilizar la macro BINDGN que instalamos en el directorio de macros de MicroStation™ en el Paso 1.

Tenemos que tener en el directorio de trabajo el archivo BINDGN.TAB, el archivo de células, un archivo de semilla y todos los archivos .bin que queremos traducir. En el caso de que queramos traducir con estilos personalizados de línea, además del archivo de semilla tendremos que tener en el mismo directorio el archivo .RSC con la definición de los estilos de línea personalizados.

Paso 4.1: Hacemos doble click sobre el archivo de semilla y entramos en MicroStation™

Paso 4.2: Ejecutamos la orden MACRO BINDGN

Paso 4.3: Rellenamos los datos del cuadro de diálogo

Paso 4.4: Pulsamos el botón Aceptar y se traducen todos los archivos .BIN del directorio de trabajo.

Nos salimos del programa MicroStation© y damos por finalizado este tutorial.

Fecha de última modificación: 13 de Noviembre de 2003
© 2001 Dreaming With Objects. Todos los derechos reservados.


Exportación de Ficheros DGN

DigiNg te ofrece la posibilidad de importar (o convertir) un fichero de MicroStation™ con extensión .DGN.

Requisitos
  • Programa DigiNG (incluido en el restituidor digital Digi3D).
  • Tabla de conversión de formatos (BINDGN.TAB).

A continuación se explicará la tabla de conversión de BIN a DGN, para poder transformar los códigos de Digi a la simbología de MicroStation™ .

Tabla BINDGN.TAB

MicroStation™ no diferencia los códigos como DigiNG. En DigiNG tenemos una cadena de seis caracteres que identifica cada código. En MicroStation tenemos dos opciones:

  • Diferenciar los elementos por la composición de cuatro valores: Nivel, Estilo, Color y Peso.
  • Diferenciar los elementos por su Grupo Gráfico.

DigiNG MicroStation™
Código
Nivel Estilo Color Peso
ó
Grupo Gráfico

Tendremos que solicitar al cliente su tabla de códigos, y generar una tabla de traducción que relacione un código de Digi con los valores de la tabla de códigos del cliente.

La tabla de traducción es un archivo ASCII (que podemos generar con el programa Bloc de Notas) que tiene el nombre BINDGN.TAB y su formato es el siguiente:

    Código DigiNG | Código correspondiente a DigiNG.
Nivel | Es el nivel en el que se encuentre el elemento en MicroStation.
Estilo de línea | Es el estilo de línea del elemento en MicroStation.
Color | Es el color del elemento en MicroStation.
Peso | Es el peso (grosor) del elemento en MicroStation.
Fuente | Fuente de MicroStation.
Grupo gráfico (gg) | Si se usa el grupo gráfico los datos correspondientes a MicroStation™ (nivel, estilo, color y peso) estarán a cero. En el caso de que se utilicen los datos correspondientes a MicroStation (nivel, estilo, color, peso), el grupo gráfico será cero.
Nombre célula | La siguiente columna es el nombre de la célula si existe. En el caso de que no se trate de una célula se pone un espacio en blanco " ", que sirve para materializar esa posición.
Alto | Se trata de un factor de escala que se aplica a las células.
Ancho | Se trata de un factor de escala que se aplica a las células.
Justificación | Correspondencia con la justificación del texto en DigiNG.
Color Relleno | Corresponde al color de relleno de la entidad.

La tabla puede tener una cabecera comentario, comenzando estas líneas de comentario con los caracteres '//'

Un ejemplo de línea de este archivo puede ser:

//TABLA EJEMPLO BINDGN//
//cód   niv est  col peso  font gg  célula      tipo alto ancho just colorrelleno

Fichero de Error

Si en el fichero .DGN existe una entidad que no haya sido considerada en la tabla de traducción, DigiNG generará un fichero de error, con extensión .err.

En este fichero de error se informa sobre los atributos del código que no ha sido capaz de reconocer. El formato de dicho fichero de error es el siguiente:

Nivel(LV)  Estilo(ST)  Color(CO)  Peso(WT)  Fuente(FONT)  GrupoGráfico(GG)  Célula(CELL)

Mirar también

Conversión de Ficheros .BIN a .DGN | IMPORTAR

Fecha de última modificación: martes, 12 de Noviembre de 2003
© 2001 Dreaming With Objects. Todos los derechos reservados.


Conversión de ficheros BIN a DXF

Digi3D

Traducción de Bin a DXF

Este tutorial le guiará paso a paso en la traducción de archivos creados por Digi (Digi21 y DigiNG) a formato .DXF.

Digi3D es capaz de exportar diversos tipos de archivo:
  • Antiguos archivos .bin de la versión 2003.
  • Archivos ASCII de Digi.
  • Archivos XYZ (.xyz).
  • Archivos de AutoCAD.
  • ASCII de Kork.
  • y archivos DGN de MicroStation.

Pulse aquí para aprender cómo hacer la exportación a AutoCAD.

Fecha de última modificación: 20 de Enero 2004
© 2001 Dreaming With Objects. Todos los derechos reservados.


Conversión de ficheros BIN a DXF

Digi3D

Traducción de Bin a DXF

Este tutorial le guiará paso a paso en la traducción de archivos creados por Digi (Digi21 y DigiNG) a formato .DXF.

En primer lugar ejecutamos la orden EXPORTAR. Al hacerlo aparecerá la siguiente ventana:

En la parte inferior elegimos el tipo de archivo que queremos generar, en este caso Archivos AutoCAD DXF.

Una vez hecho esto e introducido el nombre del archivo a generar, pulsamos Guardar y aparecerá esta otra ventana:

En esta ventana hay que definir los siguientes parámetros:

  • Formato de salida: Pudiendo ser éste en dos o tres dimensiones.
  • Archivo Semilla: La introducción de este archivo es opcional pero se hace imprescindible en caso de trabajar con AutoCad 2000 o posteriores.
  • Factor de escala para textos y bloques, en caso de querer escalar los objetos.
  • La tabla de traducción, dicha tabla se llama BINDXF.tab y se puede modifcar para el trabajo requerido.
  • La tabla de códigos origen, es la tabla con la que se ha trabajado dentro de Digi.
  • Tratamiento de errores: Aquí existen varias opciones, existiendo la opción de generar un archivo de errores, especificando el nombre deseado y el directorio en donde guardarlo.

Antes de abrir el fichero exportado de DigiNG, será conveniente crear una plantilla de AutoCAD en la cual se definan cada uno de los símbolos puntuales de Digi que aparecen en el archivo digi.tab. En dicho archivo los símbolos estarán definidos por un número, en la séptima columna.

Si se diera el caso de que en la plantilla de AutoCAD no está definido alguno de los símbolos usados por Digi (pongamos por caso el símbolo 12), al abrir el archivo en AutoCAD con el comando _dxfin, saldría el siguiente mensaje de error: "Bloque B12 no definido, entrada de archivo DXF no válida o imcompleta -- dibujo descartado." Esto quiere decir que hay que definir dicho bloque en la plantilla.

Para definir un bloque en la plantilla de AutoCAD, se ejecutará el comando: _block.

Fecha de última modificación: 22 de Marzo de 2004
© 2001 Dreaming With Objects. Todos los derechos reservados.


Tabla para la exportación de Ficheros DXF

DigiNG ha cambiado su exportador a DXF a partir de la versión 2003.63.0000, ahora sus tablas de traducción son archivos en formato XML. Para poder ver una tabla de ejemplo, simplemente hay que abrir el archivo de nombre BINDXF.TAB.XML.

Nota: Si en el archivo BINDXF.TAB.XML no se especifíca la traducción para un determinado tipo de entidad, esta no se traduciría. Por ejemplo: Si tenemos un grupo en el fichero .xml para el código de entrada "020400" y solamente se especifica la traducción de las líneas con ese código, pero no aparece ninguna línea que especifique cómo traducir puntos o textos que tengan ese código, estas entidades no se traducirán.

En caso de trabajar con versiones anteriores de Digi3D, el formato de la tabla de traducción BINDXF.TAB es el siguiente:

DigiNG AutoCAD™
Código Digi
Capa Tipo Número de color Estilo de texto Tamaño de texto Nemotécnico opcional

El fichero BINDXF.TAB se compone de tantas líneas como códigos de dibujo se vayan a transformar. Cada línea consta de varios valores separados por espacios o comas:

1.- Campo que contiene el nombre del código usado en Digi para representar una cierta entidad gráfica.
2.- Campo con el nombre  de la capa o LAYER AutoCad.
3.- Campo que contiene la orden que ha de ser utilizada en AutoCad para representar adecuadamente la entidad gráfica.
    Las ordenes más frecuentes son:
    - INSERT=. Sirve para insertar un elemento definido como un bloque.
    - PLINE. Sirve para representar una polilínea en un plano bidimensional.
    - 3DPOLY. Sirve para representar una polilínea en el espacio (tridimensional).
    - LINE. Sirve para representar un segmento .
    - POINT. Sirve para representar una entidad puntual.

4.- Campo en el que figurará el número del color (de AutoCad) con que se dibuja la entidad.
5.- Campo con el estilo de texto a que se transformará el texto Digi cuando se traduzca.
6.- Campo con el tamaño de texto que tendrá el texto Digi cuando se traduzca.
7.- Campo que contiene un nemotécnico utilizado como identificador de la entidad gráfica. Este campo es opcional.

Tendremos que solicitar al cliente su tabla de códigos, y generar una tabla de traducción que relacione un código de Digi con los valores de la tabla de códigos del cliente.

La tabla de traducción es un archivo ASCII (que podemos generar con el programa Bloc de Notas) que tiene el nombre BINDXF.TAB.

La tabla puede tener una cabecera comentario, comenzando estas líneas de comentario con los caracteres '//'

Un ejemplo de línea de este archivo puede ser:

010123  "010123"   "3DPOLY"       7 STANDARD  1 "LIMITE PROVINCIAL"

Fichero de Error

Si en el fichero .DXF existe una entidad que no haya sido considerada en la tabla de traducción, DigiNG generará un fichero de error, con extensión .err.

En este fichero de error se informa sobre los atributos del código que no ha sido capaz de reconocer. El formato de dicho fichero de error es el siguiente:

Capa  tipo  color  estilo_texto  tamaño_texto  Descripción

Mirar también

Exportación de ficheros DXF | IMPORTAR

Fecha de última modificación: martes, 28 de Enero de 2004
© 2001 Dreaming With Objects. Todos los derechos reservados.


Programación

En este tema de la ayuda se explican aspectos relacionados con la programación. Se ofrece a los usuarios de Digi3D información referente a la programación en:

  • DigiNGScrip.
  • Visual C++.
  • Visual Basic.

Fecha de última modificación: viernes, 17 de Enero de 2003


DigiNGScript

Bajo el nombre de DigiNGScript se incluyen una serie de métodos y propiedades que proporciona DigiNG para facilitar la integración de DigiNG con los diferentes motores de scripting instalados en el ordenador en el cual se ejecuta DigiNG.

Por defecto en Windows 2000 y en Windows XP vienen instalados cuatro motores de scripting:

VBScript
Para programar en un lenguaje parecido a VBasic.
VBScript.Encode
Igual que VBScript pero encriptado con el programa de Microsoft Windows Script Encoder.
JScript
Para programar en un lenguaje parecido a C, C++ ó Java.
JScript.Encode
Igual que JScript pero encriptado con el programa de Microsoft Windows Script Encoder.

Para obtener información en línea en español acerca de scripting, así como tutoriales de VBScript y JScript, visite el web http://msdn.microsoft.es/scripting.

DigiNG publica un objeto denominado digi y dicho objeto posee una serie de Métodos y Propiedades con las cuales se puede controlar a DigiNG desde un script.

El procedimiento normal consiste en crear un archivo de texto con el código del script y luego ejecutarlo con la orden VBScript, con la orden JScript, con la orden VBScript_Encriptado ó con la orden JScript_Encriptado de DigiNG.

Ejemplo

Creamos el archivo MiPrimerScript (en el directorio de otrabajo o en el de tablas, ya que cuando lo ejecutemos se busca por el disco duro como si fuera una arroba) con el siguiente código:

Digi.EjecutaOrden "zoome"

...Y luego dentro de DigiNG ejecutamos la orden VBScript=MiPrimerScript, con lo que conseguimos hacer un zoom extendido.

Ejemplo Encriptado

Si queremos encriptar el ejemplo anterior, instalamos Windows Script Encoder, generamos el script anterior, nos vamos al símbolo del sistema y encriptamos el archivo:

scren /l VBScript /e vbs MiPrimerScript MiPrimerScriptEncriptado
Nota: Si no hemos puesto en la variable de entorno PATH la ruta c:\Archivos de programa\Windows Script Encoder tenemos que anteponer esta ruta a la llamada al programa screen.

Ahora el contenido del archivo MiPrimerScriptEncriptado es el siguiente:

#@~^HgAAAA==9borc2N+m!Ym6D9+UPryGGs+J,@#@&KQkAAA==^#~@

...Y luego dentro de DigiNG ejecutamos la orden VBScript_Encriptado=MiPrimerScriptEncriptado, con lo que conseguimos hacer un zoom extendido.

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Métodos de DigiNGScript

Métodos relacionados con la visualización de entidades
Descripción | Elemento del lenguaje
Dibuja una entidad. | Método DibujaEntidad
Oculta una entidad. | Método OcultaEntidad
Regenera la vista ortogonal. | Método RegeneraVistaOrtogonal
Activa un código en la pantalla ortogonal o en la pantalla estereoscópica | Método ActivaCodigo
Desactiva un código en la pantalla ortogonal o en la pantalla estereoscópica | Método DesactivaCodigo
Nos indica si está activado un código en la pantalla ortogonal o en la pantalla estereoscópica | Método EsActivoCodigo
Métodos relacionados con archivos de referencia
Descripción | Elemento del lenguaje
Añade una entidad al archivo digi. | Método AnadeEntidad
Hace una copia de seguridad del archivo actual. | Método Bak
Borra una entidad de un archivo digi. | Método BorraEntidad
Cambia el archivo de referencia. | Método CambiaArchivoReferencia
Carga un archivo y devuelve sus entidades en un array. | Método CargaArchivo
Comprime el archivo. | Método ComprimeArchivo
Deja un archivo de referencia. | Método DejarArchivoReferencia
Carga un nuevo archivo de referencia. | Método NuevoArchivoReferencia
Carga un nuevo archivo DGN de referencia. | Método NuevoArchivoReferencia2
Devuelve un objeto Entidad del primer elemento de un archivo digi. | Método PrimeraEntidad
Devuelve un objeto Entidad del primer elemento de un archivo digi cuyas coordenadas máximas y mínimas solapen con un Objeto MaxMin pasado por parámetro. | Método PrimeraEntidadSolapaCon
Recupera una entidad de un archivo digi. | Método RecuperaEntidad
Devuelve un objeto Entidad del siguiente de un archivo digi. | Método SiguienteEntidad
Devuelve un objeto Entidad del siguiente de un archivo digi cuyas coordenadas máximas u mínimas solapen con un Objeto MaxMin pasado por parámetro. | Método SiguienteEntidadSolapaCon
Métodos relacionados con la comunicación con el usuario
Descripción | Elemento del lenguaje
Añade una barra de herramientas al marco del programa. | Método AnadeBarraHerramientas
Añade una línea de texto en la página "DigiNG" de la barra acoplable "Salida". | Método AnadeLineaOutput
Borra una barra de herramientas creada por el usuario. | Método BorraBarraHerramientas
Borra el contenido de la página "DigiNG" de la barra acoplable "Salida". | Método BorraPaginaOutput
Muestra un cuadro de diálogo para abrir un archivo. | Método DialogoPideArchivo
Muestra un cuadro de diálogo para solicitar un código al usuario. | Método DialogoPideCodigo
Muestra un cuadro de diálogo para abrir un archivo raster. | Método DialogoPideArchivoRaster
Muestra un cuadro de diálogo para abrir un archivo de referencia. | Método DialogoPideArchivoReferencia
Imprime un mensaje en la barra de mensajes de DigiNG. | Método ImprimeMensaje
Modifica un botón de una barra de herramientas. | Método ModificaBotonBarraHerramientas
Muestra un globo durante un cierto tiempo en la barra de mensajes de DigiNG. | Método MuestraGlobo
Muestra/Oculta una barra de herramientas creada por el usuario. | Método MuestraBarraHerramientas
Muestra/Oculta la barra acoplable "Salida". | Método MuestraOutput
Hace sonar el altavoz o la tarjeta de sonido con el tipo de música que el usuario ha configurado en el cuadro de diálogo de configuración. | Método Musica
Devuelve una tecla pulsada por el usuario. | Método PideTecla
Muestra un tanto por ciento en la barra de progreso de DigiNG. | Método Porciento
Métodos relacionados con la ejecución de órdenes por parte de DigiNG
Descripción | Elemento del lenguaje
Almacena una instantánea | Método AlmacenaInstantanea
Cambia el teclado activo | Método CambiaTeclasMnu
Devuelve las coordenadas de la última selección con el método PideEntidad. | Método CoordenadasUltimoPideEntidad
Ejecuta una orden. | Método EjecutaOrden
Indica si la última selección con el método PideEntidad se confirmó con las coordenadas de un vértice o con la proyección a un segmento. | Método FueVerticeUltimoPideEntidad
Devuelve un ángulo introducido por el usuario mediante un cuadro de diálogo o midiendo dos puntos. | Método PideAngulo
Devuelve una distancia introducida por el usuario mediante un cuadro de diálogo o midiendo dos puntos. | Método PideDistancia
Devuelve una entidad seleccionada por el usuario. | Método PideEntidad
Devuelve un punto registrado por el usuario mediante la orden XY, mediante el ratón, pedal o tentativo. | Método PidePunto
Deshace la última operación. | Método Undo
Devuelve el número de vértice/segmento de la ultima selección con el método PideEntidad. | Método VerticeUltimoPideEntidad
Métodos relacionados con archivos raster
Descripción | Elemento del lenguaje
Deja un archivo raster. | Método DejarArchivoRaster
Carga un nuevo archivo raster. | Método NuevoArchivoRaster
Métodos relacionados con Modelos Digitales del Terreno
Descripción | Elemento del lenguaje
Deja un archivo de modelos digitales del terreno. | Método DejarArchivoMDT
Carga un nuevo archivo de modelos digitales del terreno. | Método NuevoArchivoMDT
Proyecta unas coordenadas sobre los archivos de MDT cargados. | Método Proyecta
Métodos relacionados con la creación/gestión de Objetos
Hace una copia no constante exacta de un objeto Entidad constante. | Método ClonaEntidad
Métodos relacionados con la impresión de ficheros
Imprime todos los archivos de referencia. | Método Imprimir
Imprime todos los archivos de referencia (únicamente una ventana). | Método ImprimirVentana
Métodos relacionados con Bases de Datos
Devuelve el objeto ADODB.Connection de la base de datos actual. | Método BaseDatos
Carga una base de datos. | Método CargaBaseDatos
Descarga la base de datos actual. | Método DescargaBaseDatos
Métodos relacionados con el control del restituidor
Bloquea el restituidor para que no se puedan mover las imagenes. | Método BloqueaDigi3D
Mueve el restituidor a unas coordenadas. | Método IrA

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.ActivaCodigo

Hace visible un código en la pantalla ortogonal o en la pantalla estereoscópica.

digi.ActivaCodigo (pantallaOrtogonal, código )

Argumentos

pantallaOrtogonal
Valor booleano que indica si el código a activar es en la pantalla ortogonal True o en la pantalla estereoscópica False.
código
Código a activar.

Ejemplo

digi.ActivaCodigo True, "020400"  'Activa el código 020400 en la pantalla ortogonal
digi.DesactivaCodigo False, "123456" 'Desactiva el código 123456 de la pantalla estereoscópica

If digi.EsActivoCodigo(False, "020400") Then
    MsgBox "El código 020400 está activo en la pantalla estereoscópica"
End If

Mirar también

Método DesactivaCodigo | Método EsActivoCodigo

Fecha de última modificación: viernes, 11 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.AlmacenaInstantanea

Almacena una instantánea (obtenida de la foto izquierda del monitor estereoscópico) cuyo centro coincide con las coordenadas terreno pasadas por parámetro.
La instantánea se almacenará en el directorio que tenga el usuario configurado como directorio de instantáneas.

digi.AnadeEntidad (nombre, ptCoordenadasTerreno, bForzarEscritura)

Argumentos

nombre
Nombre con el que se almacenará la instantánea.
ptCoordenadasTerreno
Objeto Point con las coordenadas terreno de las cuales se desea sacar la instantánea.
bForzarEscritura
Ti es True, sobreescribe la instantánea en el caso de que exista, si es False, no la sobreescribe si existe pero la crea si no existe.

Devuelve

True
Si la instantanea se almacenó con éxito.
False
No se pudo almacenar la instantánea por varios motivos: que el usuario no tenga activo Digi3D, o que alguna de las orientaciones (internas, relativa o absoluta) no esté realizada.

Ejemplo

Const vbDigi3DError = 2

Dim ptTerreno
digi.ImprimeMensaje "Digitaliza un punto para almacenar una instantánea..."
Set ptTerreno = digi.PidePunto
digi.ImprimeMensaje ""

Dim nombre
nombre = InputBox("Nombre del punto")

If Not digi.AlmacenaInstantanea(nombre, ptTerreno) Then
    digi.Musica vbDigi3DError
    digi.MuestraGlobo "Error almacenando una instantánea", "No se pudo almacenar la instantánea" & vbCrLf & "Posiblemente por que no está abierto Digi3D", 3, 5000
Else
    MsgBox("Se almacenó la instantánea correctamente")
End If

' Liberamos la memoria
Set ptTerreno = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método Musica | Método MuestraGlobo | Objeto Point

Fecha de última modificación: domingo, 28 de abril de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.AnadeBarraHerramientas

Añade una barra de herramientas al marco del programa.

digi.AnadeBarraHerramientas (titulo, tooltips, ordenes, bitmaps, coordenadas, acople, hermano )

Argumentos

titulo
Título de la barra de herramientas que aparecerá en su "caption" cuando esta se desacople, así como en el menú contextual utilizado para activar/desactivar la visualización de barras de herramientas ó en el cuadro de diálogo de berras de herramientas. Este valor además será el que se tome como referencia cuando el tipo de acople sea "acoplar a la izquierda/derecha/arriba/abajo" de otra barra de herramientas ya creada.
tooltips
Array de cadenas de caracteres con los valores de los tooltips asociados a los botones.
ordenes
Array de cadenas de caracteres con los nombres de las órdenes a ejecutar al pulsar los botones.
bitmaps
Array de cadenas de caracteres con las rutas completas a los archivos bitmap (.bmp) asociados a los botones.
coordenadas
Objeto Point con las coordenadas en las cuales insertar la barra de herramientas.
Este perámetro podrá ser sustituido por Nothing si el parámetro Acople es diferente de 0 ó 1.
acople
Valor que indica cómo aparecerá la barra de herramientas al crearse: acoplada ó flotando.

El valor podrá ser uno de entre los siguientes:

Valor | Significado
0 | Flotando con orientación horizontal
1 | Flotando con orientación vertical
2 | Acoplado arriba
3 | Acoplado abajo
4 | Acoplado a la izquierda
5 | Acoplado a la derecha
6 | Acoplado encima de otra barra de herramientas que se especifica en el campo hermano
7 | Acoplado debajo de otra barra de herramientas que se especifica en el campo hermano
8 | Acoplado a la izquierda de otra barra de herramientas que se especifica en el campo hermano
9 | Acoplado a la derecha de otra barra de herramientas que se especifica en el campo hermano

Ejemplo 1: Crea una barra de herramientas acoplada a la derecha

Option Explicit

Const vbFlotanteHorizontal=0
Const vbFlotanteVertical=1
Const vbAcopladoArriba=2
Const vbAcopladoAbajo=3
Const vbAcopladoIzquierda=4
Const vbAcopladoDerecha=5
Const vbAcopladoEncimaDe=6
Const vbAcopladoDebajoDe=7
Const vbAcopladoIzquierdaDe=8
Const vbAcopladoDerechaDe=9

Dim tooltips(2)
Dim ordenes(2)
Dim bitmaps(2)

tooltips(0)="Zoom extendido"
ordenes(0) = "zoome"
bitmaps(0) = "c:\digi\img1.bmp"

tooltips(1)="Zoom ventana"
ordenes(1)="zoomv"
bitmaps(1)="c:\digi\img2.bmp"

digi.AnadeBarraHerramientas "MiBarra",tooltips,ordenes,bitmaps,Nothing,vbAcopladoDerecha,""

Ejemplo 2: Crear una barra de herramientas flotando en las coordenadas (200,300)

Option Explicit

Const vbFlotanteHorizontal=0
Const vbFlotanteVertical=1
Const vbAcopladoArriba=2
Const vbAcopladoAbajo=3
Const vbAcopladoIzquierda=4
Const vbAcopladoDerecha=5
Const vbAcopladoEncimaDe=6
Const vbAcopladoDebajoDe=7
Const vbAcopladoIzquierdaDe=8
Const vbAcopladoDerechaDe=9

Dim tooltips(2)
Dim ordenes(2)
Dim bitmaps(2)

tooltips(0)="Zoom extendido"
ordenes(0) = "zoome"
bitmaps(0) = "c:\digi\img1.bmp"

tooltips(1)="Zoom ventana"
ordenes(1)="zoomv"
bitmaps(1)="c:\digi\img2.bmp"

Dim pt
Set pt = CreateObject("Digi3D.Point")
pt.x = 200
pt.y = 300
digi.AnadeBarraHerramientas "MiBarra",tooltips,ordenes,bitmaps,pt,vbFlotanteHorizontal,""
Set pt = Nothing

Ejemplo 3: Crea tres barras de herramientas, la primera se llamará prueba1 y estará acoplada horitonzalmente, la segunda se llamará prueba2 y aparecerá acoplada a la izquierda de la barra prueba1 y la tercera se llamará prueba3 y aparecerá acoplada debajo de prueba1

Option Explicit

Const vbFlotanteHorizontal=0
Const vbFlotanteVertical=1
Const vbAcopladoArriba=2
Const vbAcopladoAbajo=3
Const vbAcopladoIzquierda=4
Const vbAcopladoDerecha=5
Const vbAcopladoEncimaDe=6
Const vbAcopladoDebajoDe=7
Const vbAcopladoIzquierdaDe=8
Const vbAcopladoDerechaDe=9

Dim tooltips(2)
Dim ordenes(2)
Dim bitmaps(2)

tooltips(0)="Zoom extendido"
ordenes(0) = "zoome"
bitmaps(0) = "c:\digi\img1.bmp"

tooltips(1)="Zoom ventana"
ordenes(1)="zoomv"
bitmaps(1)="c:\digi\img2.bmp"

digi.AnadeBarraHerramientas "prueba1",tooltips,ordenes,bitmaps,Nothing,vbAcopladoArriba,""
digi.AnadeBarraHerramientas "prueba2",tooltips,ordenes,bitmaps,Nothing,vbAcopladoDerechaDe,"prueba1"
digi.AnadeBarraHerramientas "prueba3",tooltips,ordenes,bitmaps,Nothing,vbAcopladoDebajoDe,"prueba1"

Mirar también

Método ModificaBotonBarraHerramientas | Método MuestraBarraHerramientas | Método BorraBarraHerramientas

Fecha de última modificación: jueves, 24 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.AnadeEntidad

Añade al archivo de DigiNG activo un Objeto Entidad.

Todas las coordenadas del objeto deben estar multiplicadas por el valor de la Propiedad Precision.

digi.AnadeEntidad (entidad)

Argumentos

entidad
Objeto a añadir.

Ejemplo

Dim entidad
Dim ptTerreno

Set entidad = CreateObject("Digi3D.Entidad")

digi.ImprimeMensaje "Digitaliza el centro del cuadrado de 200 unidades..."
Set ptTerreno = digi.PidePunto
digi.ImprimeMensaje ""

Dim semiancho
semiancho = 100 * digi.Precision

entidad.Codigo = "020123"
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y + semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x + semiancho, ptTerreno.y + semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x + semiancho, ptTerreno.y - semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y - semiancho, ptTerreno.z
entidad.Cerrar

digi.DibujaEntidad entidad
digi.AnadeEntidad entidad

Set ptTerreno = Nothing
Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método DibujaEntidad | Método AnadeEntidad | Propiedad Precision | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.AnadeEntidades

Añade al archivo de DigiNG activo un array de Objetos Entidad .

digi.AnadeEntidades (array )

Argumentos

array
Array de Objetos entidad a añadir.

Ejemplo

Option Explicit

Const vbFin = 1
Dim nombreArchivo
Dim entidades

nombreArchivo = digi.DialogoPideArchivoReferencia
numeroEntidades = digi.CargaArchivo(nombreArchivo, entidades)

digi.AnadeEntidades entidades
digi.Musica vbFin

Mirar también

Método DialogoPideArchivoReferencia | Método CargaArchivo | Método Musica

Fecha de última modificación: miércoles, 18 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.AnadeLineaOutput

Añade una línea de texto a la página titulada "DigiNG" de la barra acoplable "Salida".

digi.AnadeLineaOutput ( cadena )

Argumentos

cadena
Cadena de caracteres con la línea que se va a añadir.

Ejemplo

digi.MuestraOutput True
digi.BorraPaginaOutput
digi AnadeLineaOutput "Hola mundo".

Mirar también

Método MuestraOutput | Método BorraPaginaOutput

Fecha de última modificación: viernes, 30 de agosto de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.BaseDatos

Devuelve un objeto ADODB.Connection (ver documentación en el sitio web de MSDN Library (en inglés)) de la base de datos cargada con la orden BASE_DATOS. En el caso de que el usuario no haya cargado ninguna base de datos, el objeto que se devuelve es Nothing.

digi.BaseDatos

Ejemplo

If digi.BaseDatos Is Nothing Then
    MsgBox "No hay ninguna base de datos cargada"
Else
    Set rsCalles = CreateObject("ADODB.Recordset")
    rsCalles.Open "SELECT NOMBRE FROM CALLES", digi.BaseDatos
End If

Mirar también

Método CargaBaseDatos | Método DescargaBaseDatos

Fecha de última modificación: martes, 29 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.Bak

Hace una copia de seguridad (con extensión .bik) del archivo actual.

digi.Bak

Ejemplo

digi.Bak

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.BloqueaDigi3D

Bloquea el restituidor digital en el caso de tener una sesión de Digi3D abierta. Cuando se está ejecutando un script, si se mueven las manivelas Digi3D envía eventos al script y esto puede hacer que se bloquée el programa. Lo solucionamos bloqueando Digi3D al comienzo de un script de larga duración de cálculo.

digi.BloqueaDigi3D (bloquear )

Argumentos

bloquear
Valor booleano que indica si bloquear (True) o desbloquear (False) Digi3D.

Ejemplo

digi.BloqueaDigi3D True

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: miércoles, 13 de agosto de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.BorraBarraHerramientas

Borra una barra de herramientas creada por el usuario.

digi.BorraBarraHerramientas (nombre )

Argumentos

nombre
Nombre de la barra de herramientas a borrar.

Ejemplo

digi.BorraBarraHerramientas "prueba1"    ' borra la barra "prueba1"

Mirar también

Método AnadeBarraHerramientas | Método ModificaBotonBarraHerramientas | Método MuestraBarraHerramientas

Fecha de última modificación: jueves, 24 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.BorraEntidad

Hace que DigiNG ponga el atributo de borrado a un Objeto Entidad que debe pertenecer a un archivo de DigiNG.

digi.BorraEntidad (entidad)

Argumentos

entidad
Objeto a borrar.

Ejemplo

Const vbLineas = 1
Const vbPuntos = 2
Const vbTextos = 4

Dim entidad

digi.ImprimeMensaje "Selecciona una entidad..."
Set entidad = digi.PideEntidad( False, vbLineas + vbPuntos + vbTextos )
digi.ImprimeMensaje ""

digi.OcultaEntidad entidad
digi.BorraEntidad entidad

' Liberamos memoria
Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método OcultaEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.BorraPaginaOutput

Borra el contenido de la página titulada "DigiNG" de la barra acoplable "Salida".

digi.BorraPaginaOutput

Ejemplo

digi.MuestraOutput True
digi.BorraPaginaOutput
digi AnadeLineaOutput "Hola mundo".

Mirar también

Método MuestraOutput | Método AnadeLineaOutput

Fecha de última modificación: viernes, 30 de agosto de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.CambiaArchivoReferencia

Cambia el archivo de referencia activo.

digi.CambiaArchivoReferencia

Ejemplo

digi.CambiaArchivoReferencia

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.CambiaTeclasMnu

Cambia el teclado activo.

digi.CambiaTeclasMnu

Ejemplo

digi.CambiaTeclasMnu

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.CargaArchivo

Carga un archivo devolviendo todas las entidades en un array. Este array es un array de Objetos Entidad.

El archivo no se carga como archivo de referencia en el documento activo de DigiNG como ocurre con el Método NuevoArchivoReferencia. Si se desea que las entidades se almacenen en el archivo actual de DigiNG, tendremos que recorrer el array devuelto y llamar al Método AnadeEntidad por cada uno de los elementos del array.

Como este método no carga dentro del documento activo de DigiNG las entidades, éstas son de lectura/escritura. Si almacenamos una de estas entidades con el Método AnadeEntidad ésta entidad se convierte en una entidad de sólo lectura.

digi.CargaArchivo (archivo, destino)

Devuelve
Numero de entidades almacenadas en el vector.
archivo
Nombre del archivo a cargar.
destino
Array en el cual se almacenarán las entidades del archivo.

Ejemplo

' Este ejemplo carga un archivo (que selecciona el usuario) y muestra por cada una de las entidades
' del archivo un cuadro de mensaje con el código de cada entidad.
Option Explicit

Dim nombreArchivo
Dim numeroEntidades
Dim entidades
Dim i

nombreArchivo = digi.DialogoPideArchivoReferencia
numeroEntidades = digi.CargaArchivo(nombreArchivo, entidades)

For i = 0 To numeroEntidades - 1
    MsgBox entidades(i).Codigo
Next

Mirar también

Método DialogoPideArchivoReferencia

Fecha de última modificación: miércoles, 22 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.CargaBaseDatos

Carga una nueva Base de Datos. La nueva base de datos debe ser compatible con DigiNG.

digi.CargaBaseDatos (archivo)

Devuelve
True si se pudo completar la operación.
archivo
Nombre del archivo a cargar.

Ejemplo

digi.CargaBaseDatos "c:\prueba.mdb"

Mirar también

Método BaseDatos | Método DescargaBaseDatos

Fecha de última modificación: martes, 29 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.ClonaEntidad

Esté método hace una copia de un Objeto constante Entidad, devolviendo un nuevo objeto que ya no es constante (es decir, que no está incluido dentro de ningún archivo de Digi), y que es una copia perfecta del primero.

digi.ClonaEntidad (original)

Argumentos

original
Objeto Entidad original a copiar.

Ejemplo

' Este ejemplo cambia el código de todas las entidades del archivo digi que pasa a ser "020200"
Dim entidadParada
Dim entidad

Set entidadParada = Nothing
Set entidad = digi.PrimeraEntidad(True)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        ' La siguiente línea, si la descomentamos genera un error, ya que entidad es un objeto Constante
        ' entidad.Codigo = "020400"

        ' Para cambiar el código de la entidad lo hacemos en tres pasos:

        ' 1º Clonamos la entidad original
        Dim copia
        Set copia = digi.ClonaEntidad(entidad)

        ' 2º Hacemos los cambios pertinentes sobre el nuevo objeto no constante
        copia.Codigo = "020200"

        ' 3º Borramos de pantalla y del archivo Digi la entidad original y pintamos y añadimos la copia
        digi.OcultaEntidad entidad
        digi.BorraEntidad entidad
        digi.DibujaEntidad copia
        digi.AnadeEntidad copia ' A partir de este instante la entidad copia pasa a ser constante

        If entidadParada Is Nothing Then
            Set entidadParada = copia
        End If
    End If

    Set entidad = digi.SiguienteEntidad

    If Not entidadParada Is Nothing Then
        If entidadParada.EsMismaEntidad(entidad) Then
            Set entidad = Nothing
        End If
    End If
Wend

Mirar también

Método PrimeraEntidad | Método OcultaEntidad | Método BorraEntidad | Método DibujaEntidad | Método AnadeEntidad | Método SiguienteEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.ComboOpciones

Muestra un cuadro de diálogo con un Combo Box para que el usuario seleccione una opción de entre una lista de opciones. El método devuelve una cadena de caracteres con el valor de la lista seleccionado por el usuario.

digi.ComboOpciones (título, descripción, lista_de_opciones )

Argumentos

título
Título que aparecerá en la barra de título del cuadro de diálogo.
descripción
Descripción para invitarle al usuario que seleccione una opción de la lista.
lista_de_opciones
Cadena de caracteres con el conjunto de opciones que mostrará el combo box. Las opciones se separan con el carácter |
.

Ejemplo

Option Explicit

Dim color
color = digi.ComboOpciones("Mis colores", "Selecciona un color de entre los siguiente", "blanco|negro|rojo|verde|azul|ciano|magenta|amarillo")

MsgBox "Seleccionaste el color " & color

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: miércoles, 18 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.ComprimeArchivo

Comprime el archivo actual, eliminando todos los elementos marcados como elementos borrados y vaciando el buffer de undo.

digi.ComprimeArchivo

Ejemplo

digi.ComprimeArchivo

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.CoordenadasUltimoPideEntidad

Devuelve un Objeto Point con las coordenadas en las que se tentativó con la última llamada al Método PideEntidad.

digi.CoordenadasUltimoPideEntidad

Ejemplo

Const vbLineas = 1
Dim entidad

digi.ImprimeMensaje "Seleccione una línea..."
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

Dim ptCoordenadas
Set ptCoordenadas = digi.CoordenadasUltimoPideEntidad

digi.MuestraGlobo "Ejemplo de tentativo", "Las coordenadas de la última selección fueron : " & vbCrLf & ptCoordenadas.x/digi.Precision & "," & ptCoordenadas.y/digi.Precision & "," & ptCoordenadas.z/digi.Precision, 1, 3000

Set entidad = Nothing
Set ptCoordenadas = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método MuestraGlobo | Propiedad Precision | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DejarArchivoMDT

Descarga un archivo de Modelos Digitales del Terreno previamente cargado con el Método NuevoArchivoMDT.

digi.DejarArchivoMDT (archivo)

Argumentos

archivo
Nombre del archivo MDT a dejar.

Ejemplo

digi.DejarArchivoMDT "c:\trabajo\prueba.mdt"

Mirar también

Método NuevoArchivoMDT

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DejarArchivoRaster

Deja un archivo raster.

digi.DejarArchivoRaster (archivo)

Argumentos

archivo
Nombre del archivo raster a dejar.

Ejemplo

Dim archivo
archivo = digi.DialogoPideArchivoRaster
digi.NuevoArchivoRaster archivo
digi.RegeneraVistaOrtogonal

MsgBox "Cuando acepte este cuadro de diálogo se dejará el raster"

digi.DejarArchivoRaster archivo
digi.RegeneraVistaOrtogonal

Mirar también

Método DialogoPideArchivoRaster | Método NuevoArchivoRaster | Método RegeneraVistaOrtogonal

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DejarArchivoReferencia

Deja un archivo de referencia.

digi.DejarArchivoReferencia (archivo)

Argumentos

archivo
Nombre del archivo de referencia a dejar.

Ejemplo

digi.DejarArchivoReferencia "c:\trabajos\ejemplo.bin"

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DesactivaCodigo

Hace invisible un código en la pantalla ortogonal o en la pantalla estereoscópica.

digi.ActivaCodigo (pantallaOrtogonal, código )

Argumentos

pantallaOrtogonal
Valor booleano que indica si el código a desactivar es en la pantalla ortogonal True o en la pantalla estereoscópica False.
código
Código a desactivar.

Ejemplo

digi.ActivaCodigo True, "020400"  'Activa el código 020400 en la pantalla ortogonal
digi.DesactivaCodigo False, "123456" 'Desactiva el código 123456 de la pantalla estereoscópica

If digi.EsActivoCodigo(False, "020400") Then
    MsgBox "El código 020400 está activo en la pantalla estereoscópica"
End If

Mirar también

Método ActivaCodigo | Método EsActivoCodigo

Fecha de última modificación: viernes, 11 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.DescargaBaseDatos

Descarga la base de datos activa de DigiNG.

digi.DescargaBaseDatos

Ejemplo

digi.DescargaBaseDatos

Mirar también

Método BaseDatos | Método CargaBaseDatos

Fecha de última modificación: martes, 29 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DialogoPideArchivo

Muestra el cuadro de diálogo de Windows "Abrir" o "Guardar" para solicitar al usuario el nombre de un archivo, y devuelve una cadena con el nombre de archivo seleccionado por el usuario.

digi.DialogoPideArchivo (guardar)

Argumentos

guardar
Valor booleano que indica si se debe mostrar un diálogo titulado "Abrir". Si el valor es False se mostrará un diálogo titulado "Guardar".

Ejemplo

Dim archivo
archivo = digi.DialogoPideArchivo(True) ' Muestra un cuadro de diálogo con el título "Abrir".

Mirar también Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DialogoPideArchivoRaster

Muestra el cuadro de diálogo de Windows "Abrir" para solicitar al usuario el nombre de un archivo raster (de todos los formatos raster soportados) y devuelve una cadena con el nombre de archivo seleccionado por el usuario.

digi.DialogoPideArchivoRaster

Ejemplo

Dim archivo
archivo = digi.DialogoPideArchivoRaster
digi.NuevoArchivoRaster archivo
digi.RegeneraVistaOrtogonal

Mirar también

Método NuevoArchivoRaster | Método RegeneraVistaOrtogonal

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DialogoPideArchivoReferencia

Muestra el cuadro de diálogo de Windows "Abrir" para solicitar al usuario el nombre de un archivo de referencia y devuelve una cadena con el nombre de archivo seleccionado por el usuario.

El cuadro de diálogo mostrará todos los tipos de archivos que es capaz de interpretar DigiNG (.bin, .asc, .dxf, .lst,...)

digi.DialogoPideArchivoReferencia

Ejemplo

Dim archivo
archivo = digi.DialogoPideArchivoReferencia
digi.NuevoArchivoReferencia archivo
digi.RegeneraVistaOrtogonal

Mirar también

Método NuevoArchivoReferencia | Método RegeneraVistaOrtogonal

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DibujaEntidad

Dibuja un Objeto Entidad en la vista estereoscópica y ortogonal.

digi.DibujaEntidad (entidad)

Argumentos

entidad
Objeto a dibujar.

Ejemplo

Dim entidad
Dim ptTerreno

Set entidad = CreateObject("Digi3D.Entidad")

digi.ImprimeMensaje "Digitaliza el centro del cuadrado de 200 unidades..."
Set ptTerreno = digi.PidePunto
digi.ImprimeMensaje ""

Dim semiancho
semiancho = 100 * digi.Precision

entidad.Codigo = "020123"
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y + semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x + semiancho, ptTerreno.y + semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x + semiancho, ptTerreno.y - semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y - semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y + semiancho, ptTerreno.z

digi.DibujaEntidad entidad
digi.AnadeEntidad entidad

Set ptTerreno = Nothing
Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método DibujaEntidad | Método AnadeEntidad | Propiedad Precision | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.DialogoPideCodigo

Muestra un cuadro de diálogo para solicitar al usuario un código de entre los códigos del archivo digi.tab.

digi.DialogoPideCodigo (título )

Argumentos

título
Título que aparece en la barra de títulos del cuadro de diálogo.

Ejemplo

Dim codigo
codigo = digi.DialogoPideCodigo("Introduzca un código")

Mirar también Métodos de DigiNGScript

Fecha de última modificación: martes, 22 de julio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.EjecutaOrden

Hace que DigiNG ejecute la orden que se pasa por parámetros.

digi.EjecutaOrden (orden)

Argumentos

orden
Nombre de la orden a ejecutar.

Ejemplo

digi.EjecutaOrden "zoome" ' ejecuta la orden "zoome"

Mirar también Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.EsActivoCodigo

Nos indica si está activo un código para la pantalla ortogonal o para la pantalla estereoscópica.

digi.EsActivoCodigo (pantallaOrtogonal, código )

Argumentos

pantallaOrtogonal
Valor booleano que indica si el código a desactivar es en la pantalla ortogonal True o en la pantalla estereoscópica False.
código
Código sobre el cual hacemos la consulta.

Ejemplo

digi.ActivaCodigo True, "020400"  'Activa el código 020400 en la pantalla ortogonal
digi.DesactivaCodigo False, "123456" 'Desactiva el código 123456 de la pantalla estereoscópica

If digi.EsActivoCodigo(False, "020400") Then
    MsgBox "El código 020400 está activo en la pantalla estereoscópica"
End If

Mirar también

Método ActivaCodigo | Método DesactivaCodigo

Fecha de última modificación: viernes, 11 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.FueVerticeUltimoPideEntidad

Nos indica si en la última selección con el Método PideEntidad, dicho método seleccionó la entidad tentativándose en un vértice de la entidad o en un segmento de ésta.

digi.FueVerticeUltimoPideEntidad

Devuelve

True
La última selección se realizó tentativando en un vértice de la entidad.
False
La última selección se realizó tentativando en un segmento de la entidad.

Ejemplo

Const vbLineas = 1
Dim entidad

digi.ImprimeMensaje "Seleccione una línea..."
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

If digi.FueVerticeUltimoPideEntidad Then
    MsgBox "La selección de la entidad se realizó en el vértice: " & digi.VerticeUltimoPideEntidad
Else
    MsgBox "La selección de la entidad se realizó en el segmento: " & digi.VerticeUltimoPideEntidad
End If

Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método VerticeUltimoPideEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.GuardaArchivo

Crea un archivo .bin nuevo (y trunca el archivo en caso de que ya existiese a la hora de ejecutar el método) y almacena en el un array de entidades.

digi.GuardaArchivo (nombreArchivo, entidades )

Argumentos

nombreArchivo
Nombre del archivo a generar.
entidades
Array de Objetos entidad a almacenar en el archivo.

Ejemplo

Option Explicit

Dim ArrayEntidades()
Dim i

Redim ArrayEntidades(2)

Set ArrayEntidades(0) = CreaCuadrado(100,100,200,200)
Set ArrayEntidades(0) = CreaCuadrado(125,125,175,175)

digi.GuardaArchivo "c:\prueba.bin" ArrayEntidades

' Liberamos la memoria
For i = 0 To 1
    Set ArrayEntidades(i) = Nothing
Next

Function CreaCuadrado(x1, y1, x2, y2)
    Dim entidad

    Set entidad = CreateObject("Digi3D.Entidad")
    entidad.Codigo = digi.Codigo
    entidad.AnadePuntoXYZ x1, y1, 0
    entidad.AnadePuntoXYZ x2, y1, 0
    entidad.AnadePuntoXYZ x2, y2, 0
    entidad.AnadePuntoXYZ x1, y2, 0
    entidad.Cerrar

    Set CreaCuadrado = entidad
End Function

Mirar también

Método DialogoPideArchivoReferencia | Método CargaArchivo | Método Musica

Fecha de última modificación: miércoles, 18 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.ImprimeMensaje

Imprime un mensaje en la barra de mensajes de DigiNG. Si le pasamos al método como parámetro "", se borra el contenido de la barra de mensajes.

digi.ImprimeMensaje (mensaje)

Argumentos

mensaje
Mensaje a imprimir.

Ejemplo

digi.ImprimeMensaje "Digitalize un punto..."

Mirar también Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.Imprimir

Imprime todos los archivos cargados en la vista activa.

digi.Imprimir

Ejemplo

digi.Imprimir"

Mirar también

Método ImprimirVentana

Fecha de última modificación: martes, 8 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.ImprimirVentana

Imprime todos los archivos cargados en la vista activa. Imprime únicamente el área pasada por parámetros.

digi.ImprimirVentana (ventanaTerreno)

Argumentos

ventanaTerreno
Objeto MaxMin que define el rango de coordenadas a imprimir.

Ejemplo:
El siguiente ejemplo imprime la ventana comprendida entre (100,100)->(200,200)

Dim MaxMin
Set MaxMin = CreateObject("Digi3D.MaxMin")

MaxMin.xmin = 100 * Digi.Precision
MaxMin.ymin = 100 * Digi.Precision
MaxMin.xmax = 200 * Digi.Precision
MaxMin.ymax = 200 * Digi.Precision

digi.ImprimirVentana MaxMin

' Liberamos memoria
Set MaxMin = Nothing

Mirar también Método Imprimir

Fecha de última modificación: martes, 8 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.InputBox

Muestra un cuadro de diálogo para que el usuario introduzca datos, en la pantalla de DigiNG. Este método emula la función InputBox de VBScript, por que si se ejecuta ésta con un modelo estereoscópico cargado, el programa se minimiza, por que el cuadro de diálogo InputBox de VBScript se ejecuta en otro contexto de ejecución. Para solucionar el problema, es conveniente usar el método suministrado por DigiNG.

digi.InputBox (descripción, título, valorPorDefecto, cantidadMaximaCaracteres )

Argumentos

descripción
Texto descriptivo a mostrar en el InputBox
título
Título que aparecerá en la barra de título del cuadro de diálogo.
valorPorDefecto
Valor por defecto con el que aparecerá rellena la ventana de rellenar datos en el cadro de diálogo.
cantidadMaximaCaracteres
Número máximo de caracteres que podrá introducir el usuario en la ventana de introducir texto.

Ejemplo

Option Explicit
Const vbMaxCaracteres = 8
Dim resultado

resultado = digi.InputBox("Escriba el número de referencia catastral", "Catastro", "01222436", vbMaxCaracteres )

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: miércoles, 18 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.IrA

Mueve el restituidor (en el caso de que el usuario tuviera abierta una sesión estereoscópica Digi3D) a las coordenadas especificadas por parámetros. Las coordenadas

digi.IrA (x, y, z )

Argumentos

x,y,z
Coordenadas a las que queremos que se desplaze el restituidor.

Ejemplo

' Desplazamos el restituidor a las coordenadas (100.0, 100.0, 0.0)
digi.IrA 100 * digi.PRECISION, 100 * digi.PRECISION, 0.0

Mirar también Métodos de DigiNGScript

Fecha de última modificación: martes, 22 de julio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.ModificaBotonBarraHerramientas

Modifica el tooltip y la orden asociada a un determinado botón de una barra de herramientas.

digi.ModificaBotonBarraHerramientas (nombre, botón, tooltip, orden )

Argumentos

nombre
Nombre de la barra de herramientas sobre la que queremos cambiar los valores de uno de sus botones.
botón
Número (comenzando por 0) que indica el botón a modificar.
tooltip
Nuevo tooltip asociado al botón modificado.
orden
Nueva orden asociada botón modificado.

Ejemplo

digi.ModificaBotonBarraHerramientas "prueba1", 0, "Pulse este botón para comprimir el archivo", "comprimir"

Mirar también

Método AnadeBarraHerramientas | Método MuestraBarraHerramientas | Método BorraBarraHerramientas

Fecha de última modificación: jueves, 24 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.MsgBox

Muestra un cuadro de mensajes en la pantalla de DigiNG. Este método emula la función MsgBox de VBScript, por que si se ejecuta ésta con un modelo estereoscópico cargado, el programa se minimiza por que el cuadro de diálogo MsgBox de VBScript se ejecuta en otro contexto de ejecución. Para solucionar el problema, es conveniente usar el método suministrado por DigiNG.

digi.MsgBox (descripción, título, botones+iconos )

Argumentos

descripción
Texto a mostrar en el MsgBox
título
Título que aparecerá en la barra de título del cuadro de diálogo.
botones+iconos
Valor para indicar qué botones mostrar y qué icono mostrar en el cuadro de mensaje de entre los siguientes:
Botones
OK | 0
Cancelar | 1
Abortar, reintentar, ignorar | 2
Si, no, cancelar | 3
Si, no | 4
Reintentar, cancelar | 5

Iconos
Cruz | 16
Interrogación | 32
Admiración | 48
Asterisco | 64

Ejemplo

Option Explicit
' Definiciones de los botones a mostrar
' No definimos las siguientes variables por que ya están definidas por defecto por el motor de VBScript, pero las mostramos aquí para conocer
' los valores standard a utilizar.

'Const vbOK=0
'Const vbOKCANCEL=1
'Const vbABORTRETRYIGNORE=2
'Const vbYESNOCANCEL=3
'Const vbYESNO=4
'Const vbRETRYCANCEL=5

Const vbICONHAND=16
Const vbICONQUESTION=32
Const vbICONEXCLAMATION=48
Const vbICONASTERISK=64

retMsgBox = digi.MsgBox("Este es mi primer MsgBox desde DigiNG", "Hola mundo!",  vbYESNO + vbICONEXCLAMATION)

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: miércoles, 18 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.MuestraBarraHerramientas

Muestra/Oculta una barra de herramientas creada por el usuario

digi.MuestraBarraHerramientas (mostrar, nombre )

Argumentos

mostrar
Valor booleano que indica que queremos mostrar (vbTrue) u ocultar (vbFalse) la barra de herramientas.
nombre
Nombre de la barra de herramientas a mostrar/ocultar.

Ejemplo

digi.MuestraBarraHerramientas vbTrue, "prueba1"    ' muestra la barra "prueba1"
digi.MuestraBarraHerramientas vbFalse, "prueba1"   ' oculta la barra "prueba1"

Mirar también

Método AnadeBarraHerramientas | Método ModificaBotonBarraHerramientas | Método BorraBarraHerramientas

Fecha de última modificación: jueves, 24 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Método digi.MuestraGlobo

Muestra un globo durante una cierta cantidad de tiempo en la barra de mensajes.

digi.MuestraGlobo (titulo, descripción, icono, tiempo)

Argumentos

titulo
Título a mostrar en el globo.
descripción
Texto a mostrar en el cuerpo del mensaje del globo. Este texto puede estar dividido en varias líneas mediante el código ASCII de salto de línea y de retorno de carro vbCrLf.
icono
Tipo de icono a mostrar a la izquierda del título del globo.
Puede tener uno de los siguiente valores:
0
No se muestra ningún icono
1
Se muestra un icono de información
2
Se muestra un icono de alerta
3
Se muestra un icono de error
tiempo
Número de milisegundos en los que el globo será visible.

Ejemplo

Const vbDigiNGNinguno = 0
Const vbDigiNGInformacion = 1
Const vbDigiNGAlerta = 2
Const vbDigiNGError = 3

digi.MuestraGlobo "Hola", "Este es mi primer globo" & vbCrLf & "esta es la segunda línea de mi globo" & vbCrLf & "y esta la tercera.", vbInformacion, 5000

Mirar también Métodos de DigiNGScript

Fecha de última modificación: domingo, 27 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.MuestraOutput

Hace que aparezca/desaparezca la barra acoplable titulada "Salida".

digi.MuestraOutput (mostrar)

Argumentos

mostrar
Indica si que quiere hacer que aparezca (True) o que desaparezca (False) la barra "Salida".

Ejemplo

digi.MuestraOutput True
digi.BorraPaginaOutput
digi.AnadeLineaOutput "Hola mundo".

Mirar también

Método BorraPaginaOutput | Método AnadeLineaOutput

Fecha de última modificación: viernes, 30 de agosto de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.Musica

Hace sonar el altavoz del ordenador o la tarjeta de sonido de éste con la configuración especificada por el usuario en el cuadro de diálogo de configuración.

digi.Musica (tipo)

Argumentos

tipo
Tipo de música a sonar, que puede tener uno de los siguientes valores:
0
Música correspondiente a la entrada de un dato. (Ej: pulsación de un pedal en modo punto a punto).
1
Música correspondiente a la finalización de una orden.
2
Música correspondiente a un error.

Ejemplo

Const vbBeep = 0
Const vbFin = 1
Const vbDigi3DError = 2  ' No ponemos aquí vbError por que es una palabra reservada de VBScript

digi.Musica vbDigi3DError

Mirar también Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.NuevoArchivoMDT

Carga un archivo de Modelos Digitales del Terreno y devuelve el número de MDTs cargados en memoria después de ejecutar el método.

digi.NuevoArchivoMDT (archivo)

Argumentos

archivo
Nombre del archivo MDT a cargar.

Ejemplo

Dim mdt
mdt = digi.NuevoArchivoMDT "c:\trabajo\prueba.mdt"

Mirar también

Método DejarArchivoMDT

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.NuevoArchivoRaster

Carga un nuevo archivo raster.
El formato del archivo debe ser un formato soportado por DigiNG (bmp, tif, jpg). Si además el archivo tiene asociado un archivo de orientación .ort u .ori, la imagen se cargará con su orientación, afectando ello a la visualización de los vectores.

digi.NuevoArchivoRaster (archivo)

Argumentos

archivo
Nombre del archivo raster a cargar.

Ejemplo

Dim archivo
archivo = digi.DialogoPideArchivoRaster
digi.NuevoArchivoRaster archivo
digi.RegeneraVistaOrtogonal

MsgBox "Cuando acepte este cuadro de diálogo se dejará el raster"

digi.DejarArchivoRaster archivo
digi.RegeneraVistaOrtogonal

Mirar también

Método DialogoPideArchivoRaster | Método DejarArchivoRaster | Método RegeneraVistaOrtogonal

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.NuevoArchivoReferencia

Carga un nuevo archivo de referencia.

Si el archivo ya estaba cargado, no se carga de nuevo.

digi.NuevoArchivoReferencia (archivo)

Argumentos

archivo
Nombre del archivo de referencia a cargar.

Ejemplo

digi.NuevoArchivoReferencia "c:\trabajos\ejemplo.bin"

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.OcultaEntidad

Oculta un Objeto Entidad en la vista estereoscópica y ortogonal.

digi.OcultaEntidad (entidad)

Argumentos

entidad
Objeto a ocultar.

Ejemplo

Const vbLineas = 1
Const vbPuntos = 2
Const vbTextos = 4

Dim entidad

digi.ImprimeMensaje "Seleccione entidad a ocultar... (cuando regenere la pantalla con la orden REGENERA, volverá a aparecer)"
Set entidad = digi.PideEntidad( True, vbLineas + vbPuntos + vbTextos )
digi.ImprimeMensaje ""

digi.OcultaEntidad entidad

Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PideAngulo

Devuelve un ángulo en sexagesimal, medido con respecto al eje de las X, bien introducido por el usuario rellenando el cuadro de diálogo o bien digitalizando dos puntos.

Cuando se ejecuta este método aparece un cuadro de diálogo solicitando al usuario que introduzca un ángulo ó que digitalice dos puntos. En la llamada al método se puede especificar el título del cuadro de diálogo, así como un texto que aparecerá dentro del mismo para indicar al usuario que introduzca un valor. Si el usuario digitaliza un dato, el cuadro de diálogo desaparece y se muestra en la barra de mensajes un texto que también se pasa por parámetro al método, y que invita al usuario a digitalizar un segundo punto.

digi.PideAngulo (titulo, mensaje, mensajeBarraEstado)

Argumentos

titulo
El título del cuadro de diálogo.
mensaje
El mensaje que aparece dentro del cuadro de diálogo.
mensajeBarraEstado
Mensaje que aparece en la barra de estado cuando el usuario ha registrado un primer punto.

Ejemplo

Dim angulo
angulo = digi.PideAngulo("Ángulo", "Introduzca numéricamente la distancia ó digitalice un punto", "Digitalice el segundo punto")
MsgBox "El ángulo medido fué de: " & vbCrLf & angulo & " grados sexagesimales con respecto al eje de las X."

Este método devuelve un valor en Sexagesimal, para pasarlo a radianes debemos realizar la operación grados*Pi/180.

Mirar también

Método ImprimeMensaje | Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PideDistancia

Devuelve una distancia introducida por el usuario rellenando el cuadro de diálogo ó digitalizando dos puntos.

Cuando se ejecuta este método aparece un cuadro de diálogo solicitando al usuario que introduzca una distancia ó que digitalice dos puntos. En la llamada al método se puede especificar el título del cuadro de diálogo, así como un texto que aparecerá dentro del mismo para indicar al usuario que introduzca un valor. Si el usuario digitaliza un dato, el cuadro de diálogo desaparece y se muestra en la barra de mensajes un texto que también se pasa por parámetro al método y que le invita al usuario a digitalizar un segundo punto.

El valor de la distancia devuelto están multiplicadas por el valor de la Propiedad Precision.

digi.PideDistancia (titulo, mensaje, mensajeBarraEstado)

Argumentos

titulo
El título del cuadro de diálogo.
mensaje
El mensaje que aparece dentro del cuadro de diálogo.
mensajeBarraEstado
Mensaje que aparece en la barra de estado cuando el usuario ha registrado un primer punto.

Ejemplo

Dim distancia
distancia = digi.PideDistancia("Paralela", "Introduzca numéricamente la distancia ó digitalice un punto", "Digitalice el segundo punto...")
MsgBox "La distancia introducida ha sido: " & distancia/digi.Precision

Mirar también

Método ImprimeMensaje | Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PideEntidad

Devuelve un Objeto Entidad de sólo lectura correspondiente a una entidad seleccionada por el usuario.

Todas las coordenadas del objeto devuelto están multiplicadas por el valor de la Propiedad Precision.

digi.PideEntidad (BuscarEnTodosLosArchivos, TipoDeElementos)

Argumentos

BuscarEnTodosLosArchivos
Valor booleano que indica si queremos que DigiNG busque en todos los archivos de referencia True ó únicamente en el archivo de referencia actual False.
TipoDeElementos
Valor que indica que tipo de elementos queremos que seleccione DigiNG.

Éste valor puede ser uno ó una suma de los siguientes:

1
Línea
2
Punto
4
Texto

Cuando el usuario selecciona una entidad, ésta se selecciona internamente con la orden de tentativo de DigiNG, por lo que dependiendo del tipo de modo de búsqueda que tengamos seleccionado en ese momento, la selección se realizará tentativando en un vértice, o en un segmento.

Existen métodos que se pueden ejecutar después de ejecutar el método PideEntidad que nos indicarán si la selección se realizó en un vértice o en un segmento Método FueVerticeUltimoPideEntidad, además de un método que nos indica el número de vértice/segmento de dicha entidad con el cual se tentativó Método VerticeUltimoPideEntidad, o incluso obtener las coordenadas de dicha selección Método CoordenadasUltimoPideEntidad.

¿Qué significa que el objeto devuelto es de sólo lectura? Significa que no podemos llamar a ningún método del Objeto Entidad que modifique cualquier propiedad de éste. No podemos cambiar su código, no podemos añadirle un punto, ni cambiar su tipo...
Para realizar cualquiera de estas tareas tendremos que realizar los siguientes pasos:

  • Indicarle a DigiNG que nos Clone la entidad, devolviéndonos un objeto nuevo que ya no será de sólo lectura y al que podremos modificar a nuestro antojo. Método ClonaEntidad.
  • Ocultar la entidad original Método OcultaEntidad.
  • Borrar del archivo DigiNG la entidad original Método BorraEntidad.
  • Almacenar en el archivo DigiNG la nueva entidad clonada Método AnadeEntidad.

Ejemplo

Const vbLineas = 1
Const vbPuntos = 2
Const vbTextos = 4

Dim entidad

digi.ImprimeMensaje "Seleccione elemento a ocultar... (cuando regenere la pantalla con la orden REGENERA, volverá a aparecer)"
Set entidad = digi.PideEntidad( True, vbLineas + vbPuntos + vbTextos )
digi.ImprimeMensaje ""

digi.OcultaEntidad entidad

Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método OcultaEntidad | Método FueVerticeUltimoPideEntidad | Método VerticeUltimoPideEntidad | Método CoordenadasUltimoPideEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PidePunto

Devuelve un Objeto Point con las coordenadas terreno de un punto medido por el usuario mediante alguno de los métodos de introducir un punto (orden XY, botones del ratón, pedales, tentativo...).

Las coordenadas del objeto devuelto están multiplicadas por el valor de la Propiedad Precision.

digi.PidePunto

Ejemplo

Dim ptTerreno

digi.ImprimeMensaje "Digitalice un punto..."
Set ptTerreno = digi.PidePunto
digi.ImprimeMensaje ""

' ...

' Liberamos memoria
Set ptTerreno = Nothing

Mirar también

Método ImprimeMensaje | Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PideTecla

Devuelve un velor long con el valor ASCII de una tecla pulsada por el usuario.

digi.PideTecla

Como el método no devuelve un carácter ASCII sino que devuelve un valor de tipo long no podemos hacer comparaciones del tipo:

Dim tecla
digi.ImprimeMensaje "Pulsa una tecla..."
tecla = digi.PideTecla
digi.ImprimeMensaje ""

If tecla = "A" Then
    ' código
End If

Ya que si el usuario pulsa la tecla "A", en realidad el valor que se almacena en la variable tecla es 65, y no "A".

Para poder hacer comparaciones de este tipo podemos usar la función interna de VBScript Chr como en el siguiente ejemplo:

Dim tecla
digi.ImprimeMensaje "Pulsa una tecla..."
tecla = Chr(digi.PideTecla)
digi.ImprimeMensaje ""

If tecla = "A" Then
    ' código
End If

Además éste método no diferencia mayúsculas de minúsculas y siempre devuelve mayúsculas.

Para teclas especiales podemos definir una de las siguientes constantes:
vbSpace | &h20
vbPrior | &h21
vbNext | &h22
vbEnd | &h23
vbHome | &h24
vbLeft | &h25
vbUp | &h26
vbRight | &h27
vbDown | &h28
vbSelect | &h29
vbPrint | &h2A
vbExecure | &h2B
vbSnapshot | &h2C
vbInsert | &h2D
vbDelete | &h2E
vbHelp | &h2F
vbNUMPAD0 | &h60
vbNUMPAD1 | &h61
vbNUMPAD2 | &h62
vbNUMPAD3 | &h63
vbNUMPAD4 | &h64
vbNUMPAD5 | &h65
vbNUMPAD6 | &h66
vbNUMPAD7 | &h67
vbNUMPAD8 | &h68
vbNUMPAD9 | &h69
vbMULTIPLY | &h6A
vbADD | &h6B
vbSEPARATOR | &h6C
vbSUBTRACT | &h6D
vbDIVIDE | &h6F
vbF1 | &h70
vbF2 | &h71
vbF3 | &h72
vbF4 | &h73
vbF5 | &h74
vbF6 | &h75
vbF7 | &h76
vbF8 | &h77
vbF9 | &h78
vbF10 | &h79
vbF11 | &h7A
vbF12 | &h7B
vbF13 | &h7C
vbF14 | &h7D
vbF15 | &h7E
vbF16 | &h7F
vbF17 | &h80
vbF18 | &h81
vbF19 | &h82
vbF20 | &h83
vbF21 | &h84
vbF22 | &h85
vbF23 | &h86
vbF24 | &h87

Ejemplo

Const vbF1 = &h70

Dim tecla

digi.ImprimeMensaje "Pulsa una tecla"
tecla = digi.PideTecla
digi.ImprimeMensaje ""

If tecla = vbF1 Then
    MsgBox "Has pulsado la tecla de ayuda"
Else
    MsgBox "No has pulsado la tecla de ayuda"
End If

Mirar también

Método ImprimeMensaje

Fecha de última modificación: sábado, 8 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.Porciento

Muestra un tanto por ciento en la barra de progreso de DigiNG (situada en la barra de mensajes de DigiNG).
La barra de progreso aparecerá detrás del texto asignado previamente con el Método ImprimeMensaje.

digi.Porciento (valor)

Argumentos

valor
El valor del tanto por ciento. Es un valor de 0 a 100 ambos inclusive.
También se puede usar el valor -1 para hacer desaparecer la barra de progreso.

Ejemplo

Option Explicit
Dim i

digi.ImprimeMensaje "Calculando..."
For i = 0 To 100
    digi.Porciento i
Next

digi.ImprimeMensaje ""
digi.Porciento -1  ' Hacemos desaparecer la barra de progreso

Mirar también

Método ImprimeMensaje

Fecha de última modificación: sábado, 1 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PrimeraEntidad

Devuelve un Objeto Entidad constante correspondiente a la primera entidad registrada en un archivo DigiNG. La llamada a este método hace que la siguiente llamada al Método SiguienteEntidad devuelva un objeto a la segunda entidad del archivo.

¿Qué significa que el objeto devuelto es de sólo lectura? Significa que no podemos llamar a ningún método del Objeto Entidad que modifique cualquier propiedad de éste. No podemos cambiar su código, no podemos añadirle un punto, ni cambiar su tipo...
Para realizar cualquiera de estas tareas tendremos que realizar los siguientes pasos:

  • Indicarle a DigiNG que nos Clone la entidad, devolviéndonos un objeto nuevo que ya no será de sólo lectura y al que podremos modificar a nuestro antojo. Método ClonaEntidad.
  • Ocultar la entidad original Método OcultaEntidad.
  • Borrar del archivo DigiNG la entidad original Método BorraEntidad.
  • Almacenar en el archivo DigiNG la nueva entidad clonada Método AnadeEntidad.

digi.PrimeraEntidad (bSoloDelArchivoActivo)

Argumentos

bSoloDelArchivoActivo
Valor booleano (True ó False) que indica si queremos enumerar elementos sólo del archivo activo ó de todos los archivos de referencia.

Ejemplo

Const vbLinea = 1
Const vbPunto = 2
Const vbTexto = 4

Dim entidad
Dim lineas
Dim puntos
Dim textos

Set entidad = digi.PrimeraEntidad(True)

While Not entidad Is Nothing
    Select Case entidad.Tipo
        Case vbLinea
            lineas = lineas + 1
        Case vbPunto
            puntos = puntos + 1
        Case vbTexto
            textos = textos + 1
    End Select
    Set entidad = digi.SiguienteEntidad
Wend

MsgBox( "El archivo actual tiene: " & vbCrLf & lineas & " líneas" & vbCrLf & puntos & " puntos" & vbCrLf & textos & " textos")

Mirar también

Método SiguienteEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.PrimeraEntidadSolapaCon

Devuelve un Objeto Entidad constante correspondiente a la primera entidad registrada en un archivo DigiNG y cuyo rango de coordenadas máximas y mínimas solapen con un Objeto MaxMin pasado por parámetros.

¿Qué significa que el objeto devuelto es de sólo lectura? Significa que no podemos llamar a ningún método del Objeto Entidad que modifique cualquier propiedad de éste. No podemos cambiar su código, no podemos añadirle un punto, ni cambiar su tipo...
Para realizar cualquiera de estas tareas tendremos que realizar los siguientes pasos:

  • Indicarle a DigiNG que nos Clone la entidad, devolviéndonos un objeto nuevo que ya no será de sólo lectura y al que podremos modificar a nuestro antojo. Método ClonaEntidad.
  • Ocultar la entidad original Método OcultaEntidad.
  • Borrar del archivo DigiNG la entidad original Método BorraEntidad.
  • Almacenar en el archivo DigiNG la nueva entidad clonada Método AnadeEntidad.

digi.PrimeraEntidadSolapaCon (MaxMin, bSoloDelArchivoActivo)

Argumentos

MaxMin
Objeto MaxMin con el rango de coordenadas con el que se comparará para seleccionar una entidad.
bSoloDelArchivoActivo
Valor booleano (True ó False) que indica si queremos enumerar elementos sólo del archivo activo ó de todos los archivos de referencia.

Ejemplo

Dim punto
digi.ImprimeMensaje "Digitalize un punto. Se oscurecerán todas las entidades que solapen con dicho punto en una ventana de 100x100"
Set punto = digi.PidePunto
digi.ImprimeMensaje ""

Dim maxmin
Set maxmin = CreateObject("Digi3D.MaxMin")

maxmin.xmin = punto.x - 50 * digi.Precision
maxmin.ymin = punto.y - 50 * digi.Precision
maxmin.xmax = punto.x + 50 * digi.Precision
maxmin.ymax = punto.y + 50 * digi.Precision

Dim entidad

Set entidad = digi.PrimeraEntidadSolapaCon(maxmin, True)

While Not entidad Is Nothing
    digi.OcultaEntidad entidad
    Set entidad = digi.SiguienteEntidadSolapaCon(maxmin)
Wend

Set punto = Nothing
Set maxmin = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método OcultaEntidad | Método SiguienteEntidadSolapaCon | Objeto Point | Objeto MaxMin | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.Proyecta

Proyecta un punto de coordenadas (XY) representado con un Objeto Point para obtener su Z si el punto está incluido en alguno de los archivos de Modelos Digitales del Terreno cargados con el Método NuevoArchivoMDT. El método modifica la coordenada Z del objeto Point y devuelve un valor True si el punto se pudo proyectar.

digi.Proyecta (punto)

Argumentos

punto
Objeto Point con las coordenadas de entrada/salida.

Ejemplo

digi.NuevoArchivoMDT "c:\trabajo\prueba.mdt"

Dim pt
Set pt = CreateObject("Digi3D.Point")

pt.x = 100 * digi.Precision
pt.y = 200 * digi.Precision

If digi.Proyecta( pt ) Then
    MsgBox "El punto está dentro de un triángulo y tiene z=" & pt.z
Else
    MsgBox "El punto no está dentro de ningún triángulo.
End If

Set pt = Nothing

digi.DejarArchivoMDT "c:\trabajo\prueba.mdt"

Mirar también

Método NuevoArchivoMDT | Método DejarArchivoMDT | Propiedad PRECISION | Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.RecuperaEntidad

Hace que DigiNG elimine el atributo de borrado a un Objeto Entidad que debe pertenecer a un archivo de DigiNG.

digi.RecuperaEntidad (entidad)

Argumentos

entidad
Objeto a recuperar.

Ejemplo

Const vbLineas = 1
Const vbPuntos = 2
Const vbTextos = 4

Dim oldBorrados
oldBorrados = digi.Borrados
digi.Borrados = True
digi.RegeneraVistaOrtogonal

Dim entidad
digi.ImprimeMensaje "Selecciona una entidad..."
Set entidad = digi.PideEntidad( False, vbLineas + vbPuntos + vbTextos )
digi.ImprimeMensaje ""

digi.RecuperaEntidad entidad

digi.Borrados = oldBorrados
digi.RegeneraVistaOrtogonal

' Liberamos memoria
Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método RegeneraVistaOrtogonal | Propiedad Borrados | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.RegeneraVistaOrtogonal

Hace que DigiNG regenere la vista ortogonal.

digi.RegeneraVistaOrtogonal

Ejemplo

digi.RegeneraVistaOrtogonal

Mirar también Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.SiguienteEntidad

Devuelve el siguiente Objeto Entidad constante del archivo DigiNG. Para comenzar desde el principio, usamos el Método PrimeraEntidad.

¿Qué significa que el objeto devuelto es de sólo lectura? Significa que no podemos llamar a ningún método del Objeto Entidad que modifique cualquier propiedad de éste. No podemos cambiar su código, no podemos añadirle un punto, ni cambiar su tipo...
Para realizar cualquiera de estas tareas tendremos que realizar los siguientes pasos:

  • Indicarle a DigiNG que nos Clone la entidad, devolviéndonos un objeto nuevo que ya no será de sólo lectura y al que podremos modificar a nuestro antojo. Método ClonaEntidad.
  • Ocultar la entidad original Método OcultaEntidad.
  • Borrar del archivo DigiNG la entidad original Método BorraEntidad.
  • Almacenar en el archivo DigiNG la nueva entidad clonada Método AnadeEntidad.

digi.SiguienteEntidad

Ejemplo

Const vbLinea = 1
Const vbPunto = 2
Const vbTexto = 4

Dim entidad
Dim lineas
Dim puntos
Dim textos

Set entidad = digi.PrimeraEntidad(True)

While Not entidad Is Nothing
    Select Case entidad.Tipo
        Case vbLinea
            lineas = lineas + 1
        Case vbPunto
            puntos = puntos + 1
        Case vbTexto
            textos = textos + 1
    End Select
    Set entidad = digi.SiguienteEntidad
Wend

MsgBox( "El archivo actual tiene: " & vbCrLf & lineas & " líneas" & vbCrLf & puntos & " puntos" & vbCrLf & textos & " textos")

Mirar también

Método PrimeraEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.SiguienteEntidadSolapaCon

Devuelve el siguiente Objeto Entidad constante del archivo DigiNG cuyo rango de coordenadas máximas y mínimas solapen con un Objeto MaxMin pasado por parámetros.

¿Qué significa que el objeto devuelto es de sólo lectura? Significa que no podemos llamar a ningún método del Objeto Entidad que modifique cualquier propiedad de éste. No podemos cambiar su código, no podemos añadirle un punto, ni cambiar su tipo...
Para realizar cualquiera de estas tareas tendremos que realizar los siguientes pasos:

  • Indicarle a DigiNG que nos Clone la entidad, devolviéndonos un objeto nuevo que ya no será de sólo lectura y al que podremos modificar a nuestro antojo. Método ClonaEntidad.
  • Ocultar la entidad original Método OcultaEntidad.
  • Borrar del archivo DigiNG la entidad original Método BorraEntidad.
  • Almacenar en el archivo DigiNG la nueva entidad clonada Método AnadeEntidad.

digi.SiguienteEntidadSolapaCon (MaxMin)

Argumentos

MaxMin
Objeto MaxMin con el rango de coordenadas con el que se comparará para seleccionar una entidad.

Ejemplo

Dim punto
digi.ImprimeMensaje "Digitalice un punto. Se oscurecerán todas las entidades que solapen con dicho punto en una ventana de 100x100"
Set punto = digi.PidePunto
digi.ImprimeMensaje ""

Dim maxmin
Set maxmin = CreateObject("Digi3D.MaxMin")

maxmin.xmin = punto.x - 50 * digi.Precision
maxmin.ymin = punto.y - 50 * digi.Precision
maxmin.xmax = punto.x + 50 * digi.Precision
maxmin.ymax = punto.y + 50 * digi.Precision

Dim entidad
Set entidad = digi.PrimeraEntidadSolapaCon(maxmin, True)

While Not entidad Is Nothing
    digi.OcultaEntidad entidad
    Set entidad = digi.SiguienteEntidadSolapaCon(maxmin)
Wend

Set punto = Nothing
Set maxmin = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método OcultaEntidad | Método PrimeraEntidadSolapaCon | Objeto Point | Objeto MaxMin | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.Undo

Deshace la última operación. El método devuelve un valor booleano (True o False) que nos indica si se ha podido realizar la operación o no.

digi.Undo

Ejemplo

' Este ejemplo deshace absolutamente todo lo que queda en el buffer de Undo de DigiNG
Dim continuar
continuar = True
While continuar = True
    continuar = digi.Undo
Wend

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método digi.VerticeUltimoPideEntidad

Devuelve el número de vértice/segmento con el cuál se tentativó con la última llamada al Método PideEntidad.

digi.VerticeUltimoPideEntidad

Ejemplo

Const vbLineas = 1
Dim entidad

digi.ImprimeMensaje "Seleccione una línea..."
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

If digi.FueVerticeUltimoPideEntidad Then
    MsgBox "La selección de la entidad se realizó en el vértice: " & digi.VerticeUltimoPideEntidad
Else
    MsgBox "La selección de la entidad se realizó en el segmento: " & digi.VerticeUltimoPideEntidad
End If

Set entidad = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método FueVerticeUltimoPideEntidad | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedades de DigiNGScript

Relacionadas con variables de entorno/parámetros
Descripción | Elemento del lenguaje
Devuelve los argumentos pasados al script. | Propiedad ARGUMENTOS
Relacionadas con variables del programa
Descripción | Elemento del lenguaje
Devuelve o asigna el valor de la variable distancia activa. | Propiedad DA
Devuelve o asigna el valor de la variable distancia activa secundaria. | Propiedad DA2
Devuelve o asigna el valor de la variable incremento de registro. | Propiedad INC
Devuelve o asigna el valor de la variable ángulo activo. | Propiedad AA
Devuelve o asigna el valor de la variable altura de texto. | Propiedad AT
Devuelve o asigna el valor de la variable justificación de texto. | Propiedad JT
Devuelve o asigna el valor de la variable tolerancia. | Propiedad TOL
Devuelve o asigna el valor de la variable tolerancia angular. | Propiedad TOLANG
Devuelve o asigna el valor de la variable equidistancia. | Propiedad EQUIDISTANCIA
Devuelve o asigna el valor de la variable escala activa. | Propiedad ESCACT
Devuelve o asigna el valor de la variable girar. | Propiedad GIRAR
Devuelve o asigna el valor de la variable número de decimales. | Propiedad NDEC
Devuelve o asigna el grosor con el que se visualizan las entidades en la pantalla estereoscópica. | Propiedad GROSOR
Activa o desactiva la propiedad cerrado. | Propiedad C
Activa o desactiva la propiedad orto. | Propiedad ORTO
Activa o desactiva la propiedad orto con ángulo activo. | Propiedad ORTOAA
Permitir/denegar la visualización de elementos borrados. | Propiedad BORRADOS
Activa o desactiva la verificación para las selecciones de elementos con el tentativo. | Propiedad VER
Fija/desfija la Z desactivando el pedal de Z cuando se fija. | Propiedad FIJAZ
Permitir/denegar la selección de textos con el tentativo. | Propiedad TENTATIVOTEXTOS
Ir al principio automático cuando se finaliza una entidad. | Propiedad IRPRINCIPIO
Generalizar una entidad cuando se finaliza. | Propiedad G
Suavizar una entidad cuando se finaliza. | Propiedad S
Repetir una orden cuando ésta se finaliza. | Propiedad REPITE
Finalizar una entidad cuando se acepta un tentativo. | Propiedad TENTATIVOFIN
Mover el restituidor automáticamente a las distintas opciones del tentativo. | Propiedad IRTENTATIVO
Activar o desactivar los pitidos del programa. | Propiedad PITA
Visualizar las líneas con simbología en la ventana ortogonal. | Propiedad PATRON
Visualizar las líneas con simbología en la ventana estereoscópica. | Propiedad PATRONS
Establecer como dispositivo de entrada el ratón. | Propiedad RATON
Fijar las coordenadas a la equidistancia. | Propiedad FIJAXY
Devuelve o asigna el código de trabajo. | Propiedad CODIGO
Devuelve o asigna la precisión por la cual están multiplicadas todas las coordenadas. | Propiedad PRECISION
Devuelve el directorio de tablas. | Propiedad DIRECTORIOTABLAS
Visualiza/Oculta los Modelos Digitales del Terreno cargados. | Propiedad VERMDT
Permite que DigiNG proyecte la coordenada Z a partir de los archivos de Modelos Digitales del Terreno cargados. | Propiedad MDTMUEVEZ
Asigna/Devuelve la coordenada Z mínima de la orden RANGO_Z. | Propiedad MINRANGOZ
Asigna/Devuelve la coordenada Z máxima de la orden RANGO_Z. | Propiedad MAXRANGOZ
Especifica el origen global de coordenadas | Propiedad OrigenGlobal
Asigna/Devuelve la escala de visualización para los patrones | Propiedad Escala
Devuelve el nombre la ruta complete del archivo de dibujo | Propiedad NombreArchivoDibujo
Devuelve un array con los nombres de los archivos de referencia cargados. | Propiedad NombresArchivosReferencia
Devuelve las coordenadas del cursor | Propiedad CoordenadasCursor
Relacionadas con la vista ortogonal
Descripción | Elemento del lenguaje
Rango de coordenadas que se visualizan en la vista ortogonal activa. | Propiedad VISTAMAXMIN
Relacionadas con los archivos cargados
Descripción | Elemento del lenguaje
Rango de coordenadas de todos los archivos cargados. | Propiedad ARCHIVOSMAXMIN

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.AA

Almacena/Devuelve el valor del ángulo activo de DigiNG.

digi.AA

Ejemplo

digi.AA = 45.0   ' Establece el ángulo activo a 45 grados

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.ARCHIVOSMAXMIN

Almacena/Devuelve el rango de coordenadas de los archivos de referencia cargados.
Este rango de coordenadas se indica mediante un objeto de tipo Objeto MaxMin .

Ésta es una propiedad de sólo lectura .

digi.ARCHIVOSMAXMIN

Ejemplo

Dim mm
Set mm = digi.ArchivosMaxMin
digi.VISTAMAXMIN = mm          ' Le decimos a la vista que el rango de coordenadas que tiene que mostrar es (100,100)-(200,200)
digi.RegeneraVistaOrtogonal
Set mm = Nothing               ' Liberamos la memoria ocupada por el objeto mm

Mirar también Propiedades de DigiNGScript | Objeto MaxMin | Método RegeneraVistaOrtogonal

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.ARGUMENTOS

Almacena los argumentos pasados como parámetros al script.

digi.Argumentos

Ejemplo

Option Explicit
Dim argumentos
Dim I

Set argumentos = digi.Argumentos
For I = 0 to argumentos.Count - 1
    MsgBox argumentos(I)
Next

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: miércoles, 26 de febrero de 2003
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.AT

Almacena/Devuelve el valor de la altura de texto de DigiNG.

digi.AT

Ejemplo

digi.AT = 4.5   ' Establece la altura de texto a 4.5 metros

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.BORRADOS

Activa/Desactiva la visualización de elementos borrados.

digi.BORRADOS

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.Borrados = True   ' Activa la visualización de elementos borrados

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.C

Almacena/Devuelve el flag de Digi que hace que los elementos lineales se cierren al ejecutar la orden FIN_ENT.

digi.C

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.c = True   ' Activa el flag C

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.CODIGO

Almacena/Devuelve el valor del código activo de DigiNG.

digi.CODIGO

Ejemplo

digi.CODIGO = "020123"

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.CoordenadasCursor

Devuelve un Objeto Point con las últimas coordenadas donde se ha situado el cursor de DigiNG.

Propiedad de solo lectura.

digi.CoordenadasCursor

Ejemplo

' Ejemplo que simula la orden de DigiNG ZOOMA
Dim ptCentroVista
Dim nuevoMaxMin

Set ptCentroVista = digi.CoordenadasCursor

' Creamos un objeto de tipo MaxMin con el nuevo rango de coordenadas de visualización
Set nuevoMaxMin = CreateObject("Digi3D.MaxMin")
nuevoMaxMin.xmin = ptCentroVista.x - digi.VistaMaxMin.Width/2
nuevoMaxMin.ymin = ptCentroVista.y - digi.VistaMaxMin.Height/2
nuevoMaxMin.xmax = ptCentroVista.x + digi.VistaMaxMin.Width/2
nuevoMaxMin.ymax = ptCentroVista.y + digi.VistaMaxMin.Height/2

' Modificamos el rango de coordenadas de visualización de la vista ortogonal y regeneramos la vista
digi.VistaMaxMin = nuevoMaxMin
digi.RegeneraVistaOrtogonal

' Liberamos la memoria
Set nuevoMaxMin = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método RegeneraVistaOrtogonal | Propiedad VistaMaxMin

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.CORRECCIONZ

Almacena/Devuelve el factor de corrección de Z entre operadores..

digi.CORRECCIONZ

Ejemplo

digi.CORRECCIONZ = 0.20   ' Establece como corrección de Z 20 centímetros

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: jueves, 19 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.DA

Almacena/Devuelve el valor de la distancia activa de DigiNG.

digi.DA

Ejemplo

digi.DA = 1.75   ' Establece la distancia activa a 1.75 metros

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.DA2

Almacena/Devuelve el valor de la distancia activa secundaria de DigiNG.

digi.DA2

Ejemplo

digi.DA2 = 2.0   ' Establece la distancia activa secundaria a 2.0 metros

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: viernes, 7 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.DIRECTORIOTABLAS

Devuelve el directorio que el usuario rellenó en el campo Directorio de Tablas de la carátula de entrada de DigiNG.
Esta es una propiedad de sólo lectura.

digi.DIRECTORIOTABLAS

Ejemplo

MsgBox "El directorio de tablas es: " & digi.DirectorioTablas

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.EQUIDISTANCIA

Almacena/Devuelve el valor de la equidistancia de DigiNG.

digi.EQUIDISTANCIA

Ejemplo

digi.EQUIDISTANCIA = 2.0   ' Establece la equidistancia actual a 2 metros

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.ESCACT

Almacena/Devuelve el valor de la escala activa de DigiNG.

digi.ESCACT

Ejemplo

digi.ESCACT = 1.0   ' Establece la escala activa a 1.0

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.Escala

Devuelve/Asigna la escala de visualización con que se representarán los patrones. Es el valor que el usuario especifica en la carátula de entrada de DigiNG.

digi.Escala

Ejemplo

digi.Escala = 1000 * digi.PRECISION   ' Establece como escala de representación de patrones 1:1000

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: jueves, 24 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.FIJAXY

Activa/Desactiva el flag que hace que los movimientos se realicen a incrementos múltiples de la distancia activa.

digi.FIJAXY

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.FijaXY = True   ' Activa el ratón como dispositivo de entrada.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.FIJAZ

Fija/Desfija la coordenada Z.

digi.FIJAZ

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.FijaZ = True  ' Fija la Z

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.G

Activa/Desactiva la opción que hace que las líneas se generalicen cuando se registran.

digi.G

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.g = True   ' Activa la generalización.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.GIRAR

Almacena/Devuelve el valor del giro con el que se visualizan los elementos en una ventana ortogonal de DigiNG.

digi.GIRAR

Ejemplo

digi.GIRAR  = 45.0   ' Establece el giro de visualización a 45 grados.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.GROSOR

Almacena/Devuelve el grosor con el que se visualizan los elementos en la pantalla estereoscópica.

digi.GROSOR

Ejemplo

digi.GROSOR = 2.0   ' Establece el grosor a 2

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.INC

Almacena/Devuelve el valor del incremento de registro de DigiNG.

digi.INC

Ejemplo

digi.INC = 1.0   ' Establece el incremento de registro a 1.0 metros

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.IRPRINCIPIO

Activa/Desactiva la opción que hace que el restituidor se mueva al comienzo de la línea cuando esta se registra.

digi.IRPRINCIPIO

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.IRPRINCIPIO = True   ' Activa el flag <-

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.IRTENTATIVO

Activa/Desactiva la opción que hace que la orden TENTATIVO mueva el restituidor.

digi.IRTENTATIVO

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.IrTentativo = True   ' Activa la variable IrTentativo.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.JT

Almacena/Devuelve el valor de la justificación de DigiNG.

Los valores de justificación son los siguientes:

2 | 3 | 4
1 | 8 | 5
0 | 7 | 6

digi.JT

Ejemplo

Const JUSTIFICACION_SO=0
Const JUSTIFICACION_O=1
Const JUSTIFICACION_NO=2
Const JUSTIFICACION_N=3
Const JUSTIFICACION_NE=4
Const JUSTIFICACION_E=5
Const JUSTIFICACION_SE=6
Const JUSTIFICACION_S=7
Const JUSTIFICACION_C=8

digi.JT = JUSTIFICACION_C   ' Establece como justificación activa el centro del texto

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: viernes, 25 de julio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.MAXRANGOZ

Almacena/Devuelve el valor de Z máxima de la orden RANGO_Z.

digi.MAXRANGOZ

Ejemplo

digi.MINRANGOZ = 100 * digi.Precision
digi.MAXRANGOZ = 9999 * digi.Precision

Mirar también

Propiedades de DigiNGScript

Fecha de última modificación: martes, 8 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.MDTMueveZ

Almacena/Devuelve y activa/desactiva la posibilidad de que el cursor de DigiNG obtenga la Z proyectando la coordenada XY sobre un Modelo Digital del Terreno cargado..

digi.MDTMueveZ

Ejemplo

digi.MDTMueveZ = True

Mirar también

Propiedad VERMDT | Método DejarArchivoMDT | Método NuevoArchivoMDT | Método Proyecta

Fecha de última modificación: martes, 8 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.MINRANGOZ

Almacena/Devuelve el valor de Z mínima de la orden RANGO_Z.

digi.MINRANGOZ

Ejemplo

digi.MINRANGOZ = 100 * digi.Precision
digi.MAXRANGOZ = 9999 * digi.Precision

Mirar también

Propiedades de DigiNGScript

Fecha de última modificación: martes, 8 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.NDEC

Almacena/Devuelve el número de decimales con el que se se registran las cotas.

digi.NDEC

Ejemplo

digi.NDEC = 2.0   ' Establece el número de decimales a 2

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.NombreArchivoDibujo

Devuelve la ruta completa del archivo de dibujo actual (el archivo sobre el que se registran entidades).

Propiedad de solo lectura.

digi.NombreArchivoDibujo

Ejemplo

MsgBox digi.NombreArchivoDibujo

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.NombresArchivosReferencia

Devuelve el número de archivos de referencia cargados y rellena el array pasado por parámetros con los nombres de los archivos de referencia cargados.
Devuelve
Numero de archivos de referencia almacenados en el array.

Parámetros

destino
Array en el cual se almacenarán los nombres de los archivos de referencia cargados.

Propiedad de solo lectura.

digi.NombresArchivosReferencia

Ejemplo

Option Explicit
Dim nombresArchivosReferencia
Dim cuantosArchivosReferencia
Dim i

cuantosArchivosReferencia = digi.NombresArchivosReferencia(nombresArchivosReferencia)

If cuantosArchivosReferencia > 0 Then
    For i = 0 To cuantosArchivosReferencia - 1
        MsgBox nombresArchivosReferencia(i)
    Next
End If

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.OrigenGlobal

Especifica el origen global.

digi.OrigenGlobal x, y, z

Ejemplo

digi.OrigenGlobal = 0, 4000000 * digi.PRECISION, 0   ' Establece como origen global (0,4.000.000,0)

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: jueves, 24 de abril de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.ORTO

Activa/Desactiva la función ortogonal.

digi.Orto

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.Orto = True   ' Activa el ortogonal

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.ORTOAA

Activa/Desactiva la función ortogonal con ángulo activo.

digi.ORTOAA

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.OrtoAA = True   ' Activa el ortogonal con ángulo activo

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.PATRON

Activa/Desactiva la visualización de los elementos con el patrón en una ventana ortogonal.

digi.PATRON

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.Patron = True   ' Activa la visualización de elementos con el patrón.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.PATRONS

Activa/Desactiva la visualización de los elementos con el patrón en la pantalla estereoscópica.

digi.PATRONS

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.PatronS = True   ' Activa la visualización de elementos con el patrón en la pantalla estereoscópica.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.PITA

Activa/Desactiva la opción que hace que el programa se comunique con el usuarios mediante el altavoz o la tarjeta de sonido.

digi.PITA

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.Pita = True   ' Activa la variable Pita.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.PRECISION

Devuelve la precisión por la cual están multiplicadas todas las coordenadas de todos los Objetos Entidad que intervienen en la ejecución de un script.

Puede tener uno de los siguientes valores dependiendo de la selección por parte del usuario en la carátula de entrada de DigiNG:

Metros
1.0
Decímetros
10.0
Centímetros
100.0
Milímetros
1000.0
Micras
1000000.0

digi.PRECISION

Ejemplo

Dim punto
digi.ImprimeMensaje "Digitalice un punto..."
Set punto = digi.PidePunto
digi.ImprimeMensaje ""

Dim a
a = punto.x/digi.Precision

MsgBox("El punto tiene de coordenadas (" & punto.x/digi.Precision() & "," & punto.y/digi.Precision & "," & punto.z/digi.Precision & ")" )

' Liberamos la memoria
Set punto = Nothing

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.RATON

Activa/Desactiva el ratón como dispositivo de captura de las ventana ortogonal.

digi.RATON

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.Raton = True   ' Activa el ratón como dispositivo de entrada.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.REPITE

Activa/Desactiva la opción que hace que una orden se repita cuando se finaliza. (Sólo las órdenes que admiten esta posibilidad se repiten al finalizar).

digi.REPITE

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.Repite = True   ' Activa la repetición de órdenes

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.S

Activa/Desactiva la opción que hace que las líneas se suavicen cuando se registran.

digi.S

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.s = True   ' Activa el suavizado

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.TENTATIVOFIN

Activa/Desactiva la opción que hace que se finalice el registro de una entidad lineal cuando se confirma un tentativo.

digi.TENTATIVOFIN

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.TentativoFin = True   ' Activa la finalización automática de órdenes al confirmar un tentativo.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.TENTATIVOTEXTOS

Almacena/Devuelve el flag de Digi que hace que los elementos lineales se cierren al ejecutar la orden FIN_ENT.

digi.TENTATIVOTEXTOS

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.TentativoTextos = True   ' Activa la posibilidad de tentativar textos.

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.TOL

Almacena/Devuelve el valor de la tolerancia a generalizar de DigiNG.

digi.TOL

Ejemplo

digi.TOL = 4.5   ' Establece la tolerancia a 4.5

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.TOLANG

Almacena/Devuelve el valor de la tolerancia angular de DigiNG.

digi.TOLANG

Ejemplo

digi.TOLANG = 4.5   ' Establece la tolerancia angular a 4.5

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.VER

Activa/Desactiva la verificación de las selecciones con el tentativo.

digi.VER

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.ver = False  ' Desactiva el verifica

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.VERMDT

Activa/Desactiva la visualización de los Modelos Digitales del Terreno cargados.

digi.VERMDT

Esta propiedad admite únicamente valores booleanos.

Ejemplo

digi.VerMDT = True   ' Activa la visualización de MDTs

Mirar también Propiedades de DigiNGScript

Fecha de última modificación: viernes, 7 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad digi.VISTAMAXMIN

Almacena/Devuelve el rango de coordenadas que muestra la vista ortogonal.
Este rango de coordenadas se indica mediante un objeto de tipo Objeto MaxMin .

La modificación de esta propiedad no realiza una regeneración de la vista ortogonal.

digi.VISTAMAXMIN

Ejemplo 1

Dim mm
Set mm = CreateObject("Digi3D.MaxMin")
mm.xmin = 100
mm.ymin = 100
mm.xmax = 200
mm.ymax = 200

Digi.VISTAMAXMIN = mm          ' Le decimos a la vista que el rango de coordenadas que tiene que mostrar es (100,100)-(200,200)
Digi.RegeneraVistaOrtogonal

Set mm = Nothing               ' Liberamos la memoria ocupada por el objeto mm

Ejemplo 2

Dim mm
Set mm = Digi.VISTAMAXMIN
mm.Deflate 100,100,0
Digi.VISTAMAXMIN = mm
Digi.RegeneraVistaOrtogonal
Set mm = Nothing

Mirar también Propiedades de DigiNGScript | Objeto MaxMin | Método RegeneraVistaOrtogonal

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Objeto Atr

Un Objeto Atr representa un registro de atributos. Una entidad de DigiNG puede tener hasta 255 registros de atributos.

¿Con qué tipos de tablas podemos enlazar con una entidad de DigiNG?

  • Con la tabla interna de DigiNG DBDIGI que no precisa de una base de datos externa.
  • Cualquier tabla que creemos en una base de datos compatible con DigiNG (como Access) siempre que cumpla con una serie de condiciones

¿Cuál es la estructura de un registro que se refiera a la tabla interna de DigiNG?

Nombre del campo | Tabla | Registro | Resto
Tamaño en bytes | 2 | 2 | 8
Tipo* | N | N | A
Rango de valores | [1]** | [-32,768 a 32,767] | xxxxxxxx***
* N=Numérico (-32,768 a 32,767) A=Alfanumérico (8 caracteres)
** Forzosamente tiene que tener el valor 1 para indicar que la tabla es DBDIGI.
*** Cualquier cadena de caracteres de 8 bytes de longitud.

¿Cuál es la estructura de una tabla externa?

Una tabla externa puede tener cualquier estructura, pero con la restricción de que su primer campo se llame REGISTRO y que sea de tipo numérico ó autonumérico.

Además, el nombre de la tabla debe aparecer en una tabla especial que tiene que existir dentro de la base de datos.
Esta tabla se tiene que llamar DIGIDBS y tiene que tener dos campos:

Nombre del campo | ID | NOMBRE
Tipo | Numérico* | Texto
* Este valor deberá ser forzosamente > 1

¿Un ejemplo gráfico de una base de datos compatible con DigiNG?

Tenemos una base de datos creada con Access (por ejemplo Catastro.mdb) con las siguientes tablas:

DIGIDBS
ID | NOMBRE
2 | Manzanas
3 | Pacerlas

Manzanas
REGISTRO | calle | tv por cable | etc
1 | Francisco Luján | si | 27
2 | Carretera de Canillas | no | 44
3 | etc | etc | etc

Parcelas
REGISTRO | Manzana | Policía | etc | etc
1 | 1 | 1 | x | y
2 | 1 | 3 | j | k
3 | 2 | 7 | a | b
4 | etc | etc | etc | etc

¿Cuál es la estructura de un registro que se refiera a una tabla externa?

Nombre del campo | Tabla | Registro
Tamaño en bytes | 2 | 2
Tipo* | N | N
Rango de valores | [2 a 32,376] | [-32,768 a 32,767]

¿Cuál es el significado del siguiente atributo en una entidad de DigiNG con la base de datos "Catastro.mdb"?

Tabla | Registro
3 | 3

Nos estamos refiriendo a la tabla externa "Parcelas" y al campo de dicha tabla con valores:
REGISTRO | Manzana | Policía | etc | etc
3 | 2 | 7 | a | b

¿Cuál es el significado del siguiente atributo en una entidad de DigiNG con la base de datos "Catastro.mdb"?

Tabla | Registro | Resto
1 | 247 | 020400

Nos estamos refiriendo a un registro de la base de datos interna de DigiNG (Tabla=1) con el valor 247 para el campo Registro y con el valor "020400" para el campo Resto.

Para crear un objeto de tipo Atr lo hacemos con el método CreateObject("Digi3D.Atr").

Propiedades
Descripción | Elemento del lenguaje
Almacena/Devuelve el valor del campo Tabla. | Propiedad Tabla
Almacena/Devuelve el valor del campo Registro. | Propiedad Registro
Almacena/Devuelve el valor del campo Resto. | Propiedad Resto

Fecha de última modificación: jueves, 23 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Atr.Tabla

DigiNG edición Scripting

Propiedad Tabla

Establece o Devuelve el valor del campo Tabla de un Objeto Atr.

objeto.Tabla

Ejemplo

' Este ejemplo crea un objeto de tipo Atr, lo rellena con información y luego
' muestra sus valores en un cuadro de texto.
Option Explicit
Dim atr
Set atr = CreateObject("Digi3D.Atr")

atr.Tabla = 1
atr.Registro = 2
atr.Resto = "020400"

MsgBox atr.Tabla & "," & atr.Registro & "," & atr.Resto

Set atr = Nothing 'Liberamos la memoria

Mirar también

Objeto Atr

Fecha de última modificación: jueves, 23 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Atr.Registro

DigiNG edición Scripting

Propiedad Registro

Establece o Devuelve el valor del campo Registro de un Objeto Atr.

objeto.Registro

Ejemplo

' Este ejemplo crea un objeto de tipo Atr, lo rellena con información y luego
' muestra sus valores en un cuadro de texto.
Option Explicit
Dim atr
Set atr = CreateObject("Digi3D.Atr")

atr.Tabla = 1
atr.Registro = 2
atr.Resto = "020400"

MsgBox atr.Tabla & "," & atr.Registro & "," & atr.Resto

Set atr = Nothing 'Liberamos la memoria

Mirar también

Objeto Atr

Fecha de última modificación: jueves, 23 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Atr.Resto

DigiNG edición Scripting

Propiedad Resto

Establece o Devuelve el valor del campo Resto de un Objeto Atr.

objeto.Resto

Ejemplo

' Este ejemplo crea un objeto de tipo Atr, lo rellena con información y luego
' muestra sus valores en un cuadro de texto.
Option Explicit
Dim atr
Set atr = CreateObject("Digi3D.Atr")

atr.Tabla = 1
atr.Registro = 2
atr.Resto = "020400"

MsgBox atr.Tabla & "," & atr.Registro & "," & atr.Resto

Set atr = Nothing 'Liberamos la memoria

Mirar también

Objeto Atr

Fecha de última modificación: jueves, 23 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Objeto Entidad

El objeto Entidad es el objeto más complejo de la librería Digi3D.
Representa a cualquier tipo de entidad que se puede almacenar en un archivo Digi.

Un objeto Entidad puede representar líneas, puntos, textos, Mapas de bits y Objetos OLE .

Por defecto, cuando creamos un objeto de tipo entidad, el tipo asociado a dicho objeto es el tipo Punto.

  • Si añadimos un primer punto con coordenadas a dicho objeto, se mantendrá su tipo como Punto.
  • Si añadimos un segundo punto con coordenadas a dicho objeto, se cambiará automáticamente su tipo a Línea.
  • Si asignamos un texto al objeto, se cambiará automáticamente a tipo texto y si tenía más de una coordenada, se eliminarán todas menos la primera.
    • Si tenemos un objeto de tipo texto y añadimos un punto con coordenadas, se sobreescribirá el valor de las coordenadas antiguas por el de las nuevas, pero el objeto mantendrá únicamente una coordenada.
  • Si asignamos la ruta a un archivo de mapa de bits (jpeg, tiff, bmp...) el tipo cambia a Mapa de bits.
  • Si asignamos la ruta a un objeto OLE el tipo cambia a Objeto OLE.

Para crear un objeto de tipo Entidad lo hacemos con el método CreateObject ("Digi3D.Entidad").

Propiedades
Descripción | Elemento del lenguaje
Asigna/Devuelve la altura de un texto asociado con un objeto Entidad. | Propiedad Altura
Devuelve una copia de un determinado atributo de un objeto Entidad. | Propiedad Atributo
Devuelve el número de atributos de un objeto Entidad. | Propiedad Atributos
Devuelve/Establece el atributo de borrado de un objeto Entidad. | Propiedad Borrado
Almacena/Devuelve el código asignado a un objeto Entidad. | Propiedad Codigo
Asigna/Devuelve el giro de un texto asociado con un objeto Entidad. | Propiedad Giro
Asigna/Devuelve la justificación de un texto asociado con un objeto Entidad. | Propiedad Justificacion
Devuelve un objeto MaxMin con las coordenadas máximas y mínimas de la entidad. | Propiedad MaxMin
Devuelve la coordenadas de un determinado punto. | Propiedad Punto
Devuelve el número de puntos que tiene la entidad. | Propiedad Puntos
Asigna/Devuelve el texto asociado a un objeto Entidad. | Propiedad Texto
Asigna/Devuelve el tipo de elemento que representa el objeto. | Propiedad Tipo
Asigna/Devuelve el si una entidad es visible. | Propiedad Visible
Métodos
Descripción | Elemento del lenguaje
Añade un atributo mediante un Objeto Atr | Método AnadeAtributo
Añade una coordenada mediante un Objeto Point | Método AnadePunto
Añade una coordenada mediante tres parámetros X,Y y Z | Método AnadePuntoXYZ
Borra un atributo | Método BorraAtributo
Borra un punto | Método BorraPunto
Cierra un elemento de tipo Línea añadiendo un vértice al final de la línea con las coordenadas del primer vértice. | Método Cerrar
Desplaza todas las coordenadas de un objeto Entidad. | Método Desplaza
Multiplica todas las coordenadas de un objeto Entidad por una escala. | Método Escala
Nos dice si dos objetos Entidad representan la misma entidad. | Método EsMismaEntidad
Multiplica todas las coordenadas de un objeto Entidad por una matriz de giros. | Método Gira
Inserta un atributo | Método InsertaAtributo
Inserta un punto | Método InsertaPunto
Inserta un punto | Método InsertaPuntoXYZ
Modifica un atributo | Método ModificaAtributo
Modifica un punto | Método ModificaPunto
Modifica un punto | Método ModificaPuntoXYZ
Nos indica si un punto está en el interior de un polígono cerrado. | Método PuntoEnPoligono
Devuelve la superficie en el plano del polígono cerrado. | Método Superficie2D

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Altura

DigiNG edición Scripting

Propiedad Altura

Establece o Devuelve la altura asociada a un Objeto Entidad de tipo texto.

Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo lectura, la llamada fallará.
Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo escritura, la llamada fallará.

objeto.Altura

Ejemplo

' Este ejemplo amula la orden CAMB_AT de DigiNG
Const vbTexto = 4
Dim texto
Dim nueva

Digi.ImprimeMensaje "Selecciona un texto para cambiar su altura"
Set texto = Digi.PideEntidad(True, vbTexto)
Digi.ImprimeMensaje ""

Set nueva = Digi.ClonaEntidad(texto)

nueva.Altura = digi.AT * digi.Precision

Digi.OcultaEntidad texto
Digi.BorraEntidad texto
Digi.DibujaEntidad nueva
Digi.AnadeEntidad nueva

' Liberamos la memoria
Set nueva = Nothing
Set texto = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método OcultaEntidad | Método BorraEntidad | Método DibujaEntidad | Método AnadeEntidad | Propiedad AT | Propiedad PRECISION | Objeto Entidad

Fecha de última modificación: lunes, 28 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Atributo

DigiNG edición Scripting

Propiedad Atributo

Devuelve una copia de un determinado atributo perteneciente al Objeto Entidad sobre el cual se ejecuta el método.

objeto.Atributo (posición)

Ejemplo

' Este ejemplo solicita una entidad al usuario y muestra en cuadros de
' mensaje todos los atributos asociados a la entidad
Option Explicit

Const vbLineas = 1
Const vbPuntos = 2
Const vbTextos = 4

Dim entidad
Dim i

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( False, vbLineas + vbPuntos + vbTextos )
digi.ImprimeMensaje ""

If entidad.Atributos = 0 Then
    MsgBox "La entidad seleccionada no tiene atributos."
Else
    MsgBox "La entidad seleccionada tiene " & entidad.Atributos & " atributos"

    For i = 0 To entidad.Atributos - 1
        MsgBox "Atributo: " & i & vbCrLf & _
               "Tabla: " & entidad.Atributo(i).Tabla & vbCrLf & _
               "Registro: " & entidad.Atributo(i).Registro & vbCrLf & _
               "Resto: " & entidad.Atributo(i).Resto
    Next
End If

Set entidad = Nothing ' Liberamos la memoria

Mirar también

Método ImprimeMensaje | Método PideEntidad | Objeto Entidad

Fecha de última modificación: lunes, 27 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Atributos

DigiNG edición Scripting

Propiedad Atributos

Devuelve el número de atributos pertenecientes al Objeto Entidad sobre el cual se ejecuta el método.

objeto.Atributos

Ejemplo

' Este ejemplo solicita una entidad al usuario y muestra en un cuadro
' de diálogo el número de atributos asociados con la entidad seleccionada
' mensaje todos los atributos asociados a la entidad
Option Explicit

Const vbLineas = 1
Const vbPuntos = 2
Const vbTextos = 4

Dim entidad
Dim i

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( False, vbLineas + vbPuntos + vbTextos )
digi.ImprimeMensaje ""

If entidad.Atributos = 0 Then
    MsgBox "La entidad seleccionada no tiene atributos."
Else
    MsgBox "La entidad seleccionada tiene " & entidad.Atributos & & " atributos"
End If

Set entidad = Nothing ' Liberamos la memoria

Mirar también

Método ImprimeMensaje | Método PideEntidad | Objeto Entidad

Fecha de última modificación: lunes, 27 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Borrado

DigiNG edición Scripting

Propiedad Borrado

Devuelve/Establece el atributo de borrado de un objeto Entidad.

Si intentamos modificar el atributo de borrado en un Objeto Entidad Constante, la llamada a la propiedad falla. Para borrar un Objeto Entidad Constante tenemos que usar el método Método BorraEntidad de DigiNG.

objeto.Borrado

Ejemplo

' Este ejemplo nos muestra en un globo el número de entidades borradas que tenemos
' en nuestro archivo actual
Const vbLinea = 1
Const vbPunto = 2
Const vbTexto = 4

Dim entidad
Dim lineas
Dim puntos
Dim textos

Set entidad = digi.PrimeraEntidad(True)

While Not entidad Is Nothing
    If entidad.Borrado Then
        Select Case entidad.Tipo
            Case vbLinea
                lineas = lineas + 1
            Case vbPunto
                puntos = puntos + 1
            Case vbTexto
                textos = textos + 1
        End Select
    End If
    Set entidad = digi.SiguienteEntidad
Wend

digi.MuestraGlobo "Número de entidades borradas", "Líneas: " & lineas & vbCrLf & "Puntos: " & puntos & vbCrLf & "Textos: " & textos, 1, 5000

Mirar también

Método PrimeraEntidad | Método SiguienteEntidad | Método MuestraGlobo | Objeto Entidad

Fecha de última modificación: lunes, 28 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Codigo

DigiNG edición Scripting

Propiedad Codigo

Establece o devuelve el código asignado a un Objeto Entidad.

objeto.Codigo

Ejemplo

El siguiente código de ejemplo crea un Objeto Entidad y le asigna el código 020400.

Dim linea
Set linea = CreateObject("Digi3D.Entidad")
linea.Codigo = "020400"

Mirar también

Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Giro

DigiNG edición Scripting

Propiedad Giro

Establece o Devuelve el giro asociado a un Objeto Entidad de tipo texto.

El valor del giro se mide en grados sexagesimales.

Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo lectura, la llamada fallará.
Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo escritura, la llamada fallará.

objeto.Giro

Ejemplo

' Este ejemplo emula la orden CAMB_AA de DigiNG
Const vbTexto = 4
Dim texto
Dim nueva

Digi.ImprimeMensaje "Selecciona un texto para cambiar su ángulo activo"
Set texto = Digi.PideEntidad(True, vbTexto)
Digi.ImprimeMensaje ""

Set nueva = Digi.ClonaEntidad(texto)

nueva.Giro = digi.AA * digi.Precision

Digi.OcultaEntidad texto
Digi.BorraEntidad texto
Digi.DibujaEntidad nueva
Digi.AnadeEntidad nueva

' Liberamos la memoria
Set nueva = Nothing
Set texto = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método OcultaEntidad | Método BorraEntidad | Método DibujaEntidad | Método AnadeEntidad | Propiedad AA | Propiedad PRECISION | Objeto Entidad

Fecha de última modificación: lunes, 28 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Justificacion

DigiNG edición Scripting

Propiedad Justificacion

Establece o Devuelve la justificación asociada a un Objeto Entidad de tipo texto.

Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo lectura o escritura, la llamada fallará.

objeto.Justificacion

Ejemplo

' Este ejemplo emula la orden CAMB_JT de DigiNG
Const vbTexto = 4
Dim texto
Dim nueva

Digi.ImprimeMensaje "Selecciona un texto para cambiar su justificación"
Set texto = Digi.PideEntidad(True, vbTexto)
Digi.ImprimeMensaje ""

Set nueva = Digi.ClonaEntidad(texto)

nueva.Justificacion = digi.JT

Digi.OcultaEntidad texto
Digi.BorraEntidad texto
Digi.DibujaEntidad nueva
Digi.AnadeEntidad nueva

' Liberamos la memoria
Set nueva = Nothing
Set texto = Nothing

Mirar también

Método ImprimeMensaje | Método PideEntidad | Método OcultaEntidad | Método BorraEntidad | Método DibujaEntidad | Método AnadeEntidad | Propiedad JT | Objeto Entidad

Fecha de última modificación: viernes, 25 de julio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.MaxMin

DigiNG edición Scripting

Propiedad MaxMin

Devuelve un Objeto MaxMin con las coordenadas máximas y mínimas de entre todas las coordenadas del Objeto Entidad sobre el cual se está ejecutando la propiedad.

objeto.MaxMin

Ejemplo

Const vbLineas = 1

Dim entidad
Dim maxmin

digi.ImprimeMensaje "Selecciona una línea"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

Set maxmin = entidad.MaxMin

MsgBox "Las máximas y mínimas son: (" & maxmin.xmin & "," & maxmin.ymin & "," & maxmin.zmin & "->" & maxmin.xmax & "," & maxmin.ymax & "," & maxmin.zmax & ")"

Set maxmin = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Punto

DigiNG edición Scripting

Propiedad Punto

Devuelve una copia del objeto Objeto Point con las coordenadas del punto solicitado.

objeto.Punto (punto)

Argumentos

punto
Número de punto que estamos solicitando. Si el objeto es de tipo Punto o de tipo Texto este argumento debe ser obligatoriamente 0; si no, se generará un error en tiempo de ejecución.

Ejemplo

Dim linea
Set linea = CreateObject("Digi3D.Entidad")

linea.AnadePuntoXYZ 100,200,300

Dim ptTerreno
Set ptTerreno = linea.Punto(0)

if ptTerreno.x = 100 And ptTerreno.y = 200 And ptTerreno.z = 300 Then
    MsgBox "Parece que esto funciona"
End if

Set ptTerreno = Nothing
Set linea = Nothing

Mirar también

Objeto Entidad | Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Puntos

DigiNG edición Scripting

Propiedad Puntos

Devuelve el número de puntos que tiene almacenado un Objeto Entidad.

Si el objeto es de tipo Punto o de tipo Texto esta propiedad devuelve siempre 1.

objeto.Puntos

Ejemplo

' Suponemos que existe un objeto de tipo Entidad llamado linea
Dim puntos
Set puntos = linea.Puntos

Mirar también

Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Texto

DigiNG edición Scripting

Propiedad Texto

Establece o Devuelve el texto asociado a un Objeto Entidad.

Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo lectura, la llamada fallará.

Si el Objeto Entidad no representa una entidad de tipo Texto, cuando accedemos a la propiedad en modo escritura, convierte inmediatamente el objeto a uno de tipo Texto.

objeto.Texto

Ejemplo

Dim ent
Set ent = CreateObject("Digi3D.Entidad")

Dim texto
' texto = ent.Texto   'Si quitamos el comentario de esta línea, falla, ya que por defecto al crear un objeto entidad, este es de tipo Punto

ent.Texto = "Hola mundo"  ' Esto hace que el objeto "ent" se convierta a uno de tipo texto
ent.AnadePuntoXYZ 100 * digi.Precision, 100 * digi.Precision, 0

digi.DibujaEntidad ent
digi.AnadeEntidad ent  ' A partir de este momento, el objeto ent es de solo lectura

'ent.Texto = "Adios"   ' Si descomentamos esta línea, falla, por que el objeto es de solo lectura

' Liberamos la memoria
Set ent = Nothing

Mirar también

Método DibujaEntidad | Método AnadeEntidad | Propiedad PRECISION | Objeto Entidad

Fecha de última modificación: lunes, 28 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Tipo

DigiNG edición Scripting

Propiedad Tipo

Establece o Devuelve el tipo de elemento que representa un Objeto Entidad.

objeto.Tipo

La propiedad puede contener tres valores que son:

1
El objeto representa una línea.
2
El objeto representa un punto.
4
El objeto representa un texto.

Es conveniente no usar nunca números como constantes y definir variables constantes que representen dichos valores.

Ejemplo

El siguiente ejemplo crea un objeto (que por defecto es de tipo puntual) y cambia su tipo a uno de tipo texto

Const vbLinea = 1
Const vbPunto = 2
Const vbTexto = 4

Dim texto
Set texto = CreateObject("Digi3D.Entidad")

texto.Tipo = vbTexto

Mirar también

Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Entidad.Visible

DigiNG edición Scripting

Propiedad Visible

Establece o Devuelve si es visible un Objeto Entidad.

objeto.Visible

Ejemplo

' Este ejemplo hace invisible un texto
Const vbTexto = 4
Dim texto

Digi.ImprimeMensaje "Selecciona un texto para ocultar"
Set texto = Digi.PideEntidad(True, vbTexto)
Digi.ImprimeMensaje ""

texto.Visible = False

Mirar también

Método ImprimeMensaje | Método PideEntidad

Fecha de última modificación: martes, 29 de octubre de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.AnadeAtributo

DigiNG edición Scripting

Método AnadeAtributo

Añade un atributo (al final de la lista de atributos) a un Objeto Entidad.

Este método funciona únicamente en Objetos Entidad de lectura/escritura.

objeto.AnadeAtributo (atributo)

Argumentos

atributo
Objeto Atr que representa el atributo a añadir.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' le añade un atributo en la tabla interna (DBDIGI)
' con los datos introducidos por el usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim atributo

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

Set atributo = CreateObject("Digi3D.Atr")
atributo.Tabla = vbDBDIGI
atributo.Registro = InputBox("Registro")
atributo.Resto = InputBox("Resto")

Set copia = digi.ClonaEntidad(entidad)
copia.AnadeAtributo(atributo)

digi.AnadeEntidad(copia)
digi.BorraEntidad(entidad)

' Liberamos la memoria
Set copia = Nothing
Set atributo = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: martes, 28 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.AnadePunto

DigiNG edición Scripting

Método AnadePunto

Añade un punto de coordenadas a un Objeto Entidad.

objeto.AnadePunto (punto)

Argumentos

punto
Objeto Point con las coordenadas a añadir.

Por defecto, cuando creamos un objeto de tipo entidad, el tipo asociado a dicho objeto es el tipo Punto.

  • Si añadimos un primer punto con coordenadas a dicho objeto, se mantendrá su tipo como Punto.
  • Si añadimos un segundo punto con coordenadas a dicho objeto, se cambiará automáticamente su tipo a Línea.
  • Si asignamos un texto al objeto, se cambiará automáticamente a tipo texto y si tenía más de una coordenada, se eliminarán todas menos la primera.
  • Si tenemos un objeto de tipo texto y añadimos un punto con coordenadas, se sobreescribirá el valor de las coordenadas antiguas por el de las nuevas, pero el objeto mantendrá únicamente una coordenada.

Ejemplo

El siguiente ejemplo crea un objeto y le añade dos puntos, uno que el usuario introduce mediante el cursor, pedales... y otro creado por el script.

Dim linea
Set linea = CreateObject("Digi3D.Entidad")

Dim ptTerrenoUsuario
Dim ptTerrenoScript

digi.ImprimeMensaje "Digitalice un punto..."
Set ptTerrenoUsuario = digi.PidePunto
digi.ImprimeMensaje ""

Set ptTerrenoScript = CreateObject("Digi3D.Point")
ptTerrenoScript.x = ptTerrenoUsuario.x + 10
ptTerrenoScript.y = ptTerrenoUsuario.y + 10
ptTerrenoScript.z = ptTerrenoUsuario.z

linea.AnadePunto ptTerreno
linea.AnadePunto ptTerrenoScript

'...

' Liberamos la memoria
Set ptTerrenoUsuario = Nothing
Set ptTerrenoScript = Nothing
Set linea = Nothing

Mirar también

Objeto Entidad | Objeto Point | Método ImprimeMensaje | Método PidePunto

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.AnadePuntoXYZ

DigiNG edición Scripting

Método AnadePuntoXYZ

Añade un punto de coordenadas a un Objeto Entidad.

objeto.AnadePuntoXYZ (x, y, z)

Argumentos

x
Coordenada X del punto que se añade.
y
Coordenada Y del punto que se añade.
z
Coordenada Z del punto que se añade.

Por defecto, cuando creamos un objeto de tipo entidad, el tipo asociado a dicho objeto es el tipo Punto.

  • Si añadimos un primer punto con coordenadas a dicho objeto, se mantendrá su tipo como Punto.
  • Si añadimos un segundo punto con coordenadas a dicho objeto, se cambiará automáticamente su tipo a Línea.
  • Si asignamos un texto al objeto, se cambiará automáticamente a tipo texto y si tenía más de una coordenada, se eliminarán todas menos la primera.
  • Si tenemos un objeto de tipo texto y añadimos un punto con coordenadas, se sobreescribirá el valor de las coordenadas antiguas por el de las nuevas, pero el objeto mantendrá únicamente una coordenada.

Ejemplo

El siguiente ejemplo crea un objeto y le añade dos puntos, uno que el usuario introduce mediante el cursor, pedales... y otro creado por el script.

Dim linea
Set linea = CreateObject("Digi3D.Entidad")

Dim ptTerreno

digi.ImprimeMensaje "Digitalize un punto..."
Set ptTerreno = digi.PidePunto
digi.ImprimeMensaje ""

linea.AnadePuntoXYZ ptTerreno.x, ptTerreno.y, ptTerreno.z
linea.AnadePuntoXYZ 10.02, 24.47, 136.29

'...

' Liberamos la memoria
Set ptTerreno = Nothing
Set linea = Nothing

Mirar también

Objeto Entidad | Objeto Point | Método ImprimeMensaje | Método PidePunto

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.BorraAtributo

DigiNG edición Scripting

Método BorraAtributo

Borra un atributo en una determinada posición de la lista de atributos.

Este método funciona únicamente en Objetos Entidad de lectura/escritura.

objeto.BorraAtributo (posición)

Argumentos

posición
posición que indica qué atributo borrar.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' borra todos sus atributos.
Option Explicit

Const vbLineas = 1

Dim entidad
Dim copia

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

If entidad.Atributos = 0 Then
    MsgBox "La entidad no tiene atributos"
Else
    Set copia = digi.ClonaEntidad(entidad)

    While copia.Atributos > 0
        copia.BorraAtributo(0)
    Wend

    digi.AnadeEntidad(copia)
    digi.BorraEntidad(entidad)

    ' Liberamos la memoria
    Set copia = Nothing
End If
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: martes, 28 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.BorraPunto

DigiNG edición Scripting

Método BorraPunto

Borra un punto de una determinada posición de la lista de coordenadas en un Objeto Entidad de tipo línea y de modo lectura/escritura.

objeto.BorraPunto (posición)

Argumentos

posición
posición que indica qué punto borrar.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' le inserta un punto al comienzo de la lista de puntos. Este punto que se inserta se ha solicitado
' previamente al usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim punto

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

punto = InputBox("Punto a borrar")

Set copia = digi.ClonaEntidad(entidad)
copia.BorraPunto punto

digi.OcultaEntidad(entidad)
digi.DibujaEntidad(copia)
digi.AnadeEntidad(copia)
digi.BorraEntidad(entidad)

' Liberamos la memoria
Set copia = Nothing
Set punto = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método ClonaEntidad | Método OcultaEntidad | Método DibujaEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: jueves, 6 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.Cerrar

DigiNG edición Scripting

Método Cerrar

Cierra un elemento de tipo Línea añadiendo un vértice al final de la línea con las coordenadas del primer vértice.

objeto.Cerrar

Este método sólo funciona si el elemento representado por el Objeto Entidad es de tipo lineal.

Ejemplo

El siguiente ejemplo crea un objeto y le añade dos puntos, uno que el usuario introduce mediante el cursor, pedales... y otro creado por el script.

Dim entidad
Dim ptTerreno

Set entidad = CreateObject("Digi3D.Entidad")

digi.ImprimeMensaje "Digitaliza el centro del cuadrado de 200 unidades..."
Set ptTerreno = digi.PidePunto
digi.ImprimeMensaje ""

Dim semiancho
semiancho = 100 * digi.Precision

entidad.Codigo = "020123"
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y + semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x + semiancho, ptTerreno.y + semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x + semiancho, ptTerreno.y - semiancho, ptTerreno.z
entidad.AnadePuntoXYZ ptTerreno.x - semiancho, ptTerreno.y - semiancho, ptTerreno.z
entidad.Cerrar

digi.DibujaEntidad entidad
digi.AnadeEntidad entidad

Set ptTerreno = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Objeto Point | Método ImprimeMensaje | Método PidePunto | Método DibujaEntidad | Método AnadeEntidad

Fecha de última modificación: lunes, 28 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.Desplaza

DigiNG edición Scripting

Método Desplaza

Genera una matriz de transformación de desplazamiento a partir de los datos pasados por parámetro y multiplica todas las coordenadas del Objeto Entidad sobre el que se está ejecutando el método por dicha matriz de transformación.

Este método sólo se puede ejecutar en Objetos Entidad de lectura/escritura.

objeto.Desplaza (desplazamientoX, desplazamientoY, desplazamientoZ )

Argumentos

desplazamientoX
Factor de desplazamiento en X en la matriz de transformación generada.
desplazamientoY
Factor de desplazamiento en Y en la matriz de transformación generada.
desplazamientoZ
Factor de desplazamiento en Z en la matriz de transformación generada.

Ejemplo

El siguiente ejemplo solicita al usuario que seleccione una línea y hace una copia de ésta duplicando su tamaño.

Option Explicit

Const vbLineas = 1

Dim entidad
Dim copia
Dim desplazamientoX
Dim desplazamientoY
Dim desplazamientoZ

digi.ImprimeMensaje "Selecciona una línea"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

desplazamientoX = (entidad.MaxMin.xmin + entidad.MaxMin.xmax)/2
desplazamientoY = (entidad.MaxMin.ymin + entidad.MaxMin.ymax)/2
desplazamientoZ = (entidad.MaxMin.zmin + entidad.MaxMin.zmax)/2

Set copia = digi.ClonaEntidad(entidad)

copia.Desplaza -desplazamientoX, -desplazamientoY, -desplazamientoZ
copia.Escala 2.0, 2.0, 1.0
copia.Desplaza desplazamientoX, desplazamientoY, desplazamientoZ

digi.OcultaEntidad entidad
digi.DibujaEntidad copia

digi.AnadeEntidad copia
digi.BorraEntidad entidad

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método ClonaEntidad | Método OcultaEntidad | Método DibujaEntidad | Método AnadeEntidad | Método BorraEntidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.Escala

DigiNG edición Scripting

Método Escala

Genera una matriz de transformación de escalado a partir de los datos pasados por parámetro y multiplica todas las coordenadas del Objeto Entidad sobre el que se está ejecutando el método por dicha matriz de transformación.

Este método sólo se puede ejecutar en Objetos Entidad de lectura/escritura.

objeto.Escala (factorX, factorY, factorZ )

Argumentos

factorX
Factor de escalado en X en la matriz de transformación generada.
factorY
Factor de escalado en Y en la matriz de transformación generada.
factorZ
Factor de escalado en Z en la matriz de transformación generada.

Ejemplo

El siguiente ejemplo solicita al usuario que seleccione una línea y hace una copia de ésta duplicando su tamaño.

Option Explicit

Const vbLineas = 1

Dim entidad
Dim copia
Dim desplazamientoX
Dim desplazamientoY
Dim desplazamientoZ

digi.ImprimeMensaje "Selecciona una línea"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

desplazamientoX = (entidad.MaxMin.xmin + entidad.MaxMin.xmax)/2
desplazamientoY = (entidad.MaxMin.ymin + entidad.MaxMin.ymax)/2
desplazamientoZ = (entidad.MaxMin.zmin + entidad.MaxMin.zmax)/2

Set copia = digi.ClonaEntidad(entidad)

copia.Desplaza -desplazamientoX, -desplazamientoY, -desplazamientoZ
copia.Escala 2.0, 2.0, 1.0
copia.Desplaza desplazamientoX, desplazamientoY, desplazamientoZ

digi.OcultaEntidad entidad
digi.DibujaEntidad copia

digi.AnadeEntidad copia
digi.BorraEntidad entidad

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método ClonaEntidad | Método OcultaEntidad | Método DibujaEntidad | Método AnadeEntidad | Método BorraEntidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.EsMismaEntidad

DigiNG edición Scripting

Método EsMismaEntidad

Nos dice si dos objetos Entidad representan la misma entidad.

¿Esto que significa?

Podemos tener dos referencias diferentes a la misma entidad:

Ejemplo:

Const vbLineas = 1
Dim linea1
Dim linea2

digi.ImprimeMensaje "Seleccione una línea"
Set linea1 = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

digi.ImprimeMensaje "Seleccione la misma línea"
Set linea2 = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

Si el usuario selecciona realmente dos veces la misma línea, tenemos dos referencias distintas (ya que si comprobamos si linea1 = linea2 nos devuelve False) a la misma línea.

Para comprobar con seguridad si las dos referencias se refieren a la misma entidad en DigiNG, utilizamos el método EsMismaEntidad.

Ejemplo:

Const vbLineas = 1
Dim linea1
Dim linea2

digi.ImprimeMensaje "Seleccione una línea"
Set linea1 = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

digi.ImprimeMensaje "Seleccione la misma línea"
Set linea2 = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

If linea1 = Linea2 Then    ' Esto está mal y nunca dará True
    MsgBox "Es muy poco probable que aparezca este cuadro de diálogo"
End If

If linea1.EsMismaEntidad( linea2 ) Then
    MsgBox "Este código ya si que es correcto."
End If

Mirar también

Método ImprimeMensaje | Método PideEntidad | Objeto Entidad

Fecha de última modificación: lunes, 28 de enero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.Gira

DigiNG edición Scripting

Método Gira

Genera una matriz de transformación de giros a partir del factor pasado por parámetro y multiplica todas las coordenadas del Objeto Entidad sobre el que se está ejecutando el método por dicha matriz de transformación.

Este método sólo se puede ejecutar en Objetos Entidad de lectura/escritura.

objeto.Gira (theta )

Argumentos

theta
Valor (en radianes) con el giro que se desea aplicar.

Ejemplo

El siguiente ejemplo solicita al usuario que seleccione una línea y hace una copia de ésta girándola 180 grados sexagesimales.

Option Explicit

Const vbLineas = 1
Const Pi = 3.14159265358979323846

Dim entidad
Dim copia
Dim desplazamientoX
Dim desplazamientoY
Dim desplazamientoZ

digi.ImprimeMensaje "Selecciona una línea"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

desplazamientoX = (entidad.MaxMin.xmin + entidad.MaxMin.xmax)/2
desplazamientoY = (entidad.MaxMin.ymin + entidad.MaxMin.ymax)/2
desplazamientoZ = (entidad.MaxMin.zmin + entidad.MaxMin.zmax)/2

Set copia = digi.ClonaEntidad(entidad)

copia.Desplaza -desplazamientoX, -desplazamientoY, -desplazamientoZ
copia.Gira Pi
copia.Desplaza desplazamientoX, desplazamientoY, desplazamientoZ

digi.OcultaEntidad entidad
digi.DibujaEntidad copia

digi.AnadeEntidad copia
digi.BorraEntidad entidad

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método ClonaEntidad | Método OcultaEntidad | Método DibujaEntidad | Método AnadeEntidad | Método BorraEntidad

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.InsertaAtributo

DigiNG edición Scripting

Método InsertaAtributo

Inserta un atributo en una determinada posición de la lista de atributos.

Este método funciona únicamente en Objetos Entidad de lectura/escritura.

objeto.InsertaAtributo (posición, atributo)

Argumentos

posición
posición (dentro de la lista de atributos) donde se insertará el atributo. Si la posición es mayor que el número de atributos que tiene el Objeto Entidad sobre el que se ejecuta el método, el comportamiento de este método se asemeja al del Método Entidad.AnadeAtributo.
atributo
Objeto Atr que representa el atributo a insertar.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' le inserta un atributo al comienzo de la lista de atributo. El atributo creado pertenecerá a la
' tabla interna (DBDIGI) con los datos introducidos por el usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim atributo

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

Set atributo = CreateObject("Digi3D.Atr")
atributo.Tabla = vbDBDIGI
atributo.Registro = InputBox("Registro")
atributo.Resto = InputBox("Resto")

Set copia = digi.ClonaEntidad(entidad)
copia.InsertaAtributo(0, atributo)

digi.AnadeEntidad(copia)
digi.BorraEntidad(entidad)

' Liberamos la memoria
Set copia = Nothing
Set atributo = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: martes, 28 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.InsertaPunto

DigiNG edición Scripting

Método InsertaPunto

Inserta un punto en una determinada posición de la lista de coordenadas en un Objeto Entidad de tipo línea y de modo lectura/escritura.

objeto.InsertaPunto (posición, punto)

Argumentos

posición
posición (dentro de la lista de coordenadas) donde se insertará el punto. Si la posición es mayor que el número de coordenadas que tiene el Objeto Entidad sobre el que se ejecuta el método, el comportamiento de este método se asemeja al del Método Entidad.AnadePunto.
punto
Objeto Point que representa el punto a insertar.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' le inserta un punto al comienzo de la lista de puntos. Este punto que se inserta se ha solicitado
' previamente al usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim punto

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )

digi.ImprimeMensaje "Digitaliza un punto"
Set punto = digi.PidePunto
digi.ImprimeMensaje ""

Set copia = digi.ClonaEntidad(entidad)
copia.InsertaPunto 0, punto

digi.OcultaEntidad(entidad)
digi.DibujaEntidad(copia)
digi.AnadeEntidad(copia)
digi.BorraEntidad(entidad)

' Liberamos la memoria
Set copia = Nothing
Set punto = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método PidePunto | Método OcultaEntidad | Método DibujaEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: lunes, 3 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.InsertaPuntoXYZ

DigiNG edición Scripting

Método InsertaPuntoXYZ

Inserta un punto en una determinada posición de la lista de coordenadas en un Objeto Entidad de tipo línea y de modo lectura/escritura.

objeto.InsertaPuntoXYZ (posición, x, y, z )

Argumentos

posición
posición (dentro de la lista de coordenadas) donde se insertará el punto. Si la posición es mayor que el número de coordenadas que tiene el Objeto Entidad sobre el que se ejecuta el método, el comportamiento de este método se asemeja al del Método Entidad.AnadePunto.
x
Coordenada X del punto a insertar.
y
Coordenada Y del punto a insertar.
z
Coordenada Z del punto a insertar.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' le inserta un punto al comienzo de la lista de puntos. Este punto que se inserta se ha solicitado
' previamente al usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim punto

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )

digi.ImprimeMensaje "Digitaliza un punto"
Set punto = digi.PidePunto
digi.ImprimeMensaje ""

Set copia = digi.ClonaEntidad(entidad)
copia.InsertaPuntoXYZ 0, punto.x, punto.y, punto.z

digi.OcultaEntidad(entidad)
digi.DibujaEntidad(copia)
digi.AnadeEntidad(copia)
digi.BorraEntidad(entidad)

' Liberamos la memoria
Set copia = Nothing
Set punto = Nothing
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método PidePunto | Método OcultaEntidad | Método DibujaEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: jueves, 6 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.ModificaAtributo

DigiNG edición Scripting

Método ModificaAtributo

Modifica un atributo en una determinada posición de la lista de atributos.

Este método funciona únicamente en Objetos Entidad de lectura/escritura.

objeto.ModificaAtributo (posición, atributo)

Argumentos

posición
posición que indica qué atributo se modificará. Si la posición es mayor que el número de atributos se genera un error.
atributo
Objeto Atr que representa el atributo.

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea y
' modifica su primer atributo por uno nuevo generado con datos solicitados al usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim atributo

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

If entidad.Atributos = 0 Then
    MsgBox "La entidad no tiene atributos"
Else
    Set atributo = CreateObject("Digi3D.Atr")
    atributo.Tabla = vbDBDIGI
    atributo.Registro = InputBox("Registro")
    atributo.Resto = InputBox("Resto")

    Set copia = digi.ClonaEntidad(entidad)
    copia.ModificaAtributo(0, atributo)

    digi.AnadeEntidad(copia)
    digi.BorraEntidad(entidad)

    ' Liberamos la memoria
    Set copia = Nothing
    Set atributo = Nothing
End If
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: martes, 28 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.ModificaPunto

DigiNG edición Scripting

Método ModificaPunto

Modifica un punto en una determinada posición de la lista de puntos.

Este método funciona únicamente en un Objeto Entidad de tipo línea y de lectura/escritura.

objeto.ModificaPunto (posición, punto)

Argumentos

posición
posición que indica qué punto se modificará. Si la posición es mayor que el número de puntos se genera un error.
punto
Objeto Point que representa el punto nuevo.

Ejemplo

' Este ej' Este ejemplo solicita al usuario que seleccione una línea y
' le inserta un punto al comienzo de la lista de puntos. Este punto que se inserta se ha solicitado
' previamente al usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim punto
Dim nPunto

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

nPunto = CInt(InputBox("Punto a modificar"))

If ((nPunto < 0) Or (nPunto >= entidad.Puntos)) Then
    MsgBox "Error, el punto no es válido"
Else
    digi.ImprimeMensaje "Digitaliza un punto"
    Set punto = digi.PidePunto
    digi.ImprimeMensaje ""

    Set copia = digi.ClonaEntidad(entidad)
    copia.ModificaPunto nPunto, punto

    digi.OcultaEntidad(entidad)
    digi.DibujaEntidad(copia)
    digi.AnadeEntidad(copia)
    digi.BorraEntidad(entidad)

    ' Liberamos la memoria
    Set copia = Nothing
    Set punto = Nothing
End If
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: jueves, 6 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.ModificaPuntoXYZ

DigiNG edición Scripting

Método ModificaPuntoXYZ

Modifica un punto en una determinada posición de la lista de puntos.

Este método funciona únicamente en un Objeto Entidad de tipo línea y de lectura/escritura.

objeto.ModificaPuntoXYZ (posición, x, y, z)

Argumentos

posición
posición que indica qué punto se modificará. Si la posición es mayor que el número de puntos se genera un error.
x
Coordenada X del punto modificado.
y
Coordenada Y del punto modificado.
z
Coordenada Z del punto modificado.

Ejemplo

' Este ej' Este ejemplo solicita al usuario que seleccione una línea y
' le inserta un punto al comienzo de la lista de puntos. Este punto que se inserta se ha solicitado
' previamente al usuario.
Option Explicit

Const vbLineas = 1
Const vbDBDIGI = 1

Dim entidad
Dim copia
Dim punto
Dim nPunto

digi.ImprimeMensaje "Seleccione elemento"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

nPunto = CInt(InputBox("Punto a modificar"))

If ((nPunto < 0) Or (nPunto >= entidad.Puntos)) Then
    MsgBox "Error, el punto no es válido"
Else
    digi.ImprimeMensaje "Digitaliza un punto"
    Set punto = digi.PidePunto
    digi.ImprimeMensaje ""

    Set copia = digi.ClonaEntidad(entidad)
    copia.ModificaPuntoXYZ nPunto, punto.x, punto.y, punto.z

    digi.OcultaEntidad(entidad)
    digi.DibujaEntidad(copia)
    digi.AnadeEntidad(copia)
    digi.BorraEntidad(entidad)

    ' Liberamos la memoria
    Set copia = Nothing
    Set punto = Nothing
End If
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Método BorraEntidad | Método AnadeEntidad

Fecha de última modificación: jueves, 6 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.PuntoEnPoligono

DigiNG edición Scripting

Método PuntoEnPoligono

Nos indica si el Objeto Point pasado por parámetros está en el interior del Objeto Entidad sobre el cual se ejecuta el método.

objeto.PuntoEnPoligono

Este método sólo funciona si el elemento representado por el Objeto Entidad es de tipo lineal.

Ejemplo

El siguiente ejemplo solicita al usuario que seleccione una línea cerrada y luego le solicita que digitalice un punto. Luego muestra mediante un cuadro de diálogo si el punto registrado está o no dentro de la línea seleccionada.

' Ejemplo del método PuntoEnPoligono de un objeto de tipo Linea
Option Explicit
Const vbLineas = 1

Dim linea
Dim ptTerreno

digi.ImprimeMensaje "Selecciona una línea cerrada"
Set linea = digi.PideEntidad( True, vbLineas )

digi.ImprimeMensaje "Digitaliza un punto..."
Set ptTerreno = digi.PidePunto

digi.ImprimeMensaje ""

If linea.PuntoEnPoligono(ptTerreno) Then
    MsgBox("El punto está en el interior de la línea")
Else
    MsgBox("El punto no está en el interior de la línea")
End If

' Liberamos la memoria
Set linea = Nothing
Set ptTerreno = Nothing

Mirar también

Objeto Entidad | Objeto Point | Método ImprimeMensaje | Método PideEntidad | Método PidePunto |

Fecha de última modificación: sábado, 4 de mayo de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Entidad.Superficie2D

DigiNG edición Scripting

Método Superficie2D

Calcula la superficie en el plano del Objeto Entidad (lineal).

objeto.Superficie2D

Ejemplo

' Este ejemplo solicita al usuario que seleccione una línea cerrada y muestra su superficie en el plano
Option Explicit

Const vbLineas = 1

Dim entidad

digi.ImprimeMensaje "Seleccione una línea cerrada"
Set entidad = digi.PideEntidad( True, vbLineas )
digi.ImprimeMensaje ""

MsgBox "La superficie en el plano de la línea seleccionada es " & entidad.Superficie2D / digi.Precision
' Liberamos la memoria
Set entidad = Nothing

Mirar también

Objeto Entidad | Método ImprimeMensaje | Método PideEntidad | Propiedad PRECISION

Fecha de última modificación: jueves, 25 de septiembre de 2003
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Objeto MaxMin

Almacena un rango de coordenadas máximas y mínimas.

Para crear un objeto de tipo MaxMin lo hacemos con el método CreateObject("Digi3D.MaxMin").

Propiedades
Descripción | Elemento del lenguaje
Almacena/Devuelve la coordenada X mínima. | Propiedad xmin
Almacena/Devuelve la coordenada Y mínima. | Propiedad ymin
Almacena/Devuelve la coordenada Z mínima. | Propiedad zmin
Almacena/Devuelve la coordenada X máxima. | Propiedad xmax
Almacena/Devuelve la coordenada Y máxima. | Propiedad ymax
Almacena/Devuelve la coordenada Z máxima. | Propiedad zmax
Métodos
Descripción | Elemento del lenguaje
Devuelve el ancho del rango de coordenadas. | Método Width
Devuelve el alto del rango de coordenadas. | Método Height
Infla el rango de coordenadas. | Método Inflate
Desinfla el rango de coordenadas. | Método Deflate

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad MaxMin.xmin

DigiNG edición Scripting

Propiedad xmin

Almacena/Devuelve la coordenada X mínima en un Objeto MaxMin.

objeto.xmin

El valor es siempre de tipo long.

Ejemplo

Function CreaMaximasAlrededorDelPunto( x, y, ancho, alto)
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")
    maxmin.xmin = x - ancho/2
    maxmin.ymin = y - ancho/2
    maxmin.zmin = 0
    maxmin.xmax = x + ancho/2
    maxmin.ymax = y + ancho/2
    maxmin.zmax = 0
    CreaMaximasAlrededorDelPunto = maxmin
End Function

Mirar también Objeto MaxMin | Propiedad ymin | Propiedad zmin | Propiedad xmax | Propiedad ymax | Propiedad zmax

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad MaxMin.ymin

DigiNG edición Scripting

Propiedad ymin

Almacena/Devuelve la coordenada Y mínima en un Objeto MaxMin.

objeto.ymin

El valor es siempre de tipo long.

Ejemplo

Function CreaMaximasAlrededorDelPunto( x, y, ancho, alto)
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")
    maxmin.xmin = x - ancho/2
    maxmin.ymin = y - ancho/2
    maxmin.zmin = 0
    maxmin.xmax = x + ancho/2
    maxmin.ymax = y + ancho/2
    maxmin.zmax = 0
    CreaMaximasAlrededorDelPunto = maxmin
End Function

Mirar también Objeto MaxMin | Propiedad xmin | Propiedad zmin | Propiedad xmax | Propiedad ymax | Propiedad zmax

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad MaxMin.zmin

DigiNG edición Scripting

Propiedad zmin

Almacena/Devuelve la coordenada Z mínima en un Objeto MaxMin.

objeto.zmin

El valor es siempre de tipo long.

Ejemplo

Function CreaMaximasAlrededorDelPunto( x, y, ancho, alto)
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")
    maxmin.xmin = x - ancho/2
    maxmin.ymin = y - ancho/2
    maxmin.zmin = 0
    maxmin.xmax = x + ancho/2
    maxmin.ymax = y + ancho/2
    maxmin.zmax = 0
    CreaMaximasAlrededorDelPunto = maxmin
End Function

Mirar también Objeto MaxMin | Propiedad xmin | Propiedad ymin | Propiedad xmax | Propiedad ymax | Propiedad zmax

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad MaxMin.xmax

DigiNG edición Scripting

Propiedad xmax

Almacena/Devuelve la coordenada X máxima en un Objeto MaxMin.

objeto.xmax

El valor es siempre de tipo long.

Ejemplo

Function CreaMaximasAlrededorDelPunto( x, y, ancho, alto)
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")
    maxmin.xmin = x - ancho/2
    maxmin.ymin = y - ancho/2
    maxmin.zmin = 0
    maxmin.xmax = x + ancho/2
    maxmin.ymax = y + ancho/2
    maxmin.zmax = 0
    CreaMaximasAlrededorDelPunto = maxmin
End Function

Mirar también Objeto MaxMin | Propiedad xmin | Propiedad ymin | Propiedad zmin | Propiedad ymax | Propiedad zmax

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad MaxMin.ymax

DigiNG edición Scripting

Propiedad ymax

Almacena/Devuelve la coordenada Y máxima en un Objeto MaxMin.

objeto.ymax

El valor es siempre de tipo long.

Ejemplo

Function CreaMaximasAlrededorDelPunto( x, y, ancho, alto)
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")
    maxmin.xmin = x - ancho/2
    maxmin.ymin = y - ancho/2
    maxmin.zmin = 0
    maxmin.xmax = x + ancho/2
    maxmin.ymax = y + ancho/2
    maxmin.zmax = 0
    CreaMaximasAlrededorDelPunto = maxmin
End Function

Mirar también Objeto MaxMin | Propiedad xmin | Propiedad ymin | Propiedad zmin | Propiedad xmax | Propiedad zmax

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad MaxMin.zmax

DigiNG edición Scripting

Propiedad zmax

Almacena/Devuelve la coordenada Z máxima en un Objeto MaxMin.

objeto.zmax

El valor es siempre de tipo long.

Ejemplo

Function CreaMaximasAlrededorDelPunto( x, y, ancho, alto)
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")
    maxmin.xmin = x - ancho/2
    maxmin.ymin = y - ancho/2
    maxmin.zmin = 0
    maxmin.xmax = x + ancho/2
    maxmin.ymax = y + ancho/2
    maxmin.zmax = 0
    CreaMaximasAlrededorDelPunto = maxmin
End Function

Mirar también Objeto MaxMin | Propiedad xmin | Propiedad ymin | Propiedad zmin | Propiedad xmax | Propiedad ymax

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método MaxMin.Width

DigiNG edición Scripting

Método Width

Devuelve el ancho del rango de coordenadas almacenado en un Objeto MaxMin.

objeto.Width

El valor es siempre de tipo long.

Ejemplo

Function Area( maxmin )
    Area = maxmin.Width * maxmin.Height
End Function

Mirar también Objeto MaxMin | Método Height

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método MaxMin.Height

DigiNG edición Scripting

Método Height

Devuelve el alto del rango de coordenadas almacenado en un Objeto MaxMin.

objeto.Height

El valor es siempre de tipo long.

Ejemplo

Function Area( maxmin )
    Area = maxmin.Width * maxmin.Height
End Function

Mirar también Objeto MaxMin | Método Width

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método MaxMin.Inflate

DigiNG edición Scripting

Método Inflate

Infla el rango de máximas y mínimas moviendo las caras desde el centro. Pera hacer esto, Inflate resta unidades a xmin, ymin, zmin y suma unidades a xmax, ymax, zmax.

Los parámetros de Inflate son parámetros con signo; valores positivos inchan el rango de máximas y mínimas y valores negativos lo desinchan.

objeto.Inflate incharX, incharY, incharZ

Ejemplo

El siguiente código ilustra el uso del método Inflate.

Function CreaMaxMin( x, y, ancho, alto )
    Dim maxmin
    Set maxmin = CreateObject("Digi3D.MaxMin")

    maxmin.xmin = x
    maxmin.xmax = x
    maxmin.ymin = y
    maxmin.ymax = y
    maxmin.Inflate ancho/2, alto/2, 0

    CreaMaxMin = maxmin
End Function

Mirar también Objeto MaxMin

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método MaxMin.Deflate

DigiNG edición Scripting

Método Deflate

Desinfla el rango de máximas y mínimas moviendo las caras hacia el centro. Pera hacer esto, Deflate suma unidades a xmin, ymin, zmin y resta unidades a xmax, ymax, zmax.

Los parámetros de Deflate son parámetros con signo; valores positivos deshinchan el rango de máximas y mínimas y valores negativos lo hinchan.

objeto.Deflate desincharX, desincharY, desincharZ

Ejemplo

El siguiente código deshincha un rango de máximas y mínimas en 100 unidades en horizontal.

maxmin.Deflate 50,0,0

Mirar también Objeto MaxMin

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Objeto Point

Almacena un un punto de coordenadas en tres dimensiones.

Para crear un objeto de tipo Point lo hacemos con el método CreateObject("Digi3D.Point").

Propiedades
Descripción | Elemento del lenguaje
Almacena/Devuelve la coordenada X. | Propiedad x
Almacena/Devuelve la coordenada Y. | Propiedad y
Almacena/Devuelve la coordenada Z. | Propiedad z
Métodos
Descripción | Elemento del lenguaje
Devuelve el ángulo en radianes con respecto a otro objeto Point. | Método Angulo
Devuelve la distancia con respecto a otro objeto Point. | Método Distancia
Devuelve la distancia en 2D con respecto a otro objeto Point. | Método Distancia2D

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Point.x

DigiNG edición Scripting

Propiedad x

Almacena/Devuelve la coordenada X de un Objeto Point.

objeto.x

El valor es siempre de tipo long.

Ejemplo

Function CreaPunto( x, y, z )
    Dim punto
    Set punto = CreateObject("Digi3D.Point")
    punto.x = x
    punto.y = y
    punto.z = z
    CreaPunto = punto
End Function

Mirar también Objeto Point | Propiedad y | Propiedad z

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Point.y

DigiNG edición Scripting

Propiedad y

Almacena/Devuelve la coordenada Y de un Objeto Point.

objeto.y

El valor es siempre de tipo long.

Ejemplo

Function CreaPunto( x, y, z )
    Dim punto
    Set punto = CreateObject("Digi3D.Point")
    punto.x = x
    punto.y = y
    punto.z = z
    CreaPunto = punto
End Function

Mirar también Objeto Point | Propiedad x | Propiedad z

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Propiedad Point.z

DigiNG edición Scripting

Propiedad z

Almacena/Devuelve la coordenada Z de un Objeto Point.

objeto.z

El valor es siempre de tipo long.

Ejemplo

Function CreaPunto( x, y, z )
    Dim punto
    Set punto = CreateObject("Digi3D.Point")
    punto.x = x
    punto.y = y
    punto.z = z
    CreaPunto = punto
End Function

Mirar también Objeto Point | Propiedad x | Propiedad y

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Point.Angulo

DigiNG edición Scripting

Método Angulo

Devuelve el ángulo en radianes que forma el objeto con otro Objeto Point.

objeto.Angulo (punto)

Argumentos

punto
Objeto Point con el que medir el ángulo.

Ejemplo

Dim pt1
Dim pt2
Dim angulo

Set pt1 = CreateObject("Digi3D.Point")
Set pt2 = CreateObject("Digi3D.Point")

pt1.x = 100
pt1.y = 100

pt2.x = 12
pt2.y = 26

angulo = pt1.Angulo(pt2)

Mirar también

Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Point.Distancia

DigiNG edición Scripting

Método Distancia

Devuelve la distancia desde el objeto hasta otro Objeto Point.

objeto.Distancia (punto)

Argumentos

punto
Objeto Point con el que medir la distancia.

Ejemplo

Dim pt1
Dim pt2
Dim distancia

Set pt1 = CreateObject("Digi3D.Point")
Set pt2 = CreateObject("Digi3D.Point")

pt1.x = 100
pt1.y = 100

pt2.x = 12
pt2.y = 26

distancia = pt1.Distancia(pt2)

Mirar también

Objeto Point

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Método Point.Distancia2D

DigiNG edición Scripting

Método Distancia2D

Devuelve la distancia (en el plano) desde el objeto hasta otro Objeto Point.

objeto.Distancia2D (punto)

Argumentos

punto
Objeto Point con el que medir la distancia.

Ejemplo

Dim pt1
Dim pt2
Dim distancia

Set pt1 = CreateObject("Digi3D.Point")
Set pt2 = CreateObject("Digi3D.Point")

pt1.x = 100
pt1.y = 100

pt2.x = 12
pt2.y = 26

distancia = pt1.Distancia2D(pt2)

Mirar también

Objeto Point

Fecha de última modificación: lunes, 17 de junio de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Ejemplos de DigiNGScript

Descripción | Ejemplo
Elimina el último punto de una línea sin confirmar, pero si mover el restituidor en el caso de que esté activa la variable IR_TENTATIVO. | Ejemplo U
Almacena en el archivo que el usuario diga, todas las propiedades con sus valores actuales. | Ejemplo GuardaDatos
Carga del archivo que el usuario diga, todas las propiedades con sus valores previamente almacenados con el script del ejemplo GuardaDatos. | Ejemplo CargaDatos
Hace un zoom extendido en la vista ortogonal. | Ejemplo Zoome
Emula la orden ZOOMP de DigiNG. | Ejemplo Zoomp
Crea un polígono con un número determinado de lados especificado por el usuario mediante un cuadro de diálogo. | Ejemplo Poligono
Emula el comportamiento del programa de Digi "Binunion". | Ejemplo Binunion

Algoritmos básicos

Descripción | Ejemplo
Algoritmo para la eliminación de extensiones o la extracción del directorio donde se ubica un archivo. | Algoritmo 1

Fecha de última modificación: jueves, 14 de febrero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


MARCAR_ATR

DigiNG edición Scripting

Programación de la orden MARCAR_ATR

Nivel: MEDIO

Vamos a programar una orden denominada MARCAR_ATR muy util para hacer catástros. La orden generará un archivo de errores que posteriormente cargaremos como archivo de referencia con la orden CARGA_F y por cuyos errores iteraremos con las órdenes ERR+ y ERR-, y dichas marcas de error nos indicarán qué entidades lineales tenemos en el archivo sobre el cual se ejecutó la orden con exactamente un determinado número de atributos vinculados con una determinada tabla de la base de datos cargada cuando se ejecutó la orden.

Ej: Si tenemos cargada una base de datos con varias tablas, una de las cuales tiene como nombre TAB, y ejecutamos nuestro script como sigue:

vbscript=marcar_atr.vbs TAB 5 salida.bin
El script generará un archivo denominado err.bin con marcas a todas las entidades lineales con exáctamente 5 atributos enlazados con la tabla TAB de la base de datos activa en el momento de la ejecución del script.

El script admitirá o no parámetros. Si no especificamos parámetros, solicitará mediante cuadros de diálogo los datos necesarios para su ejecución.

El formato de parámetros es el siguiente:

VBSCRIPT=MARCAR_ATR.vbs [tabla] [número de atributos] [archivo a generar]

Y algunos ejemplos de ejecución del script:

VBSCRIPT=MARCAR_ATR.vbs
VBSCRIPT=MARCAR_ATR.vbs TAB
VBSCRIPT=MARCAR_ATR.vbs TAB 1
VBSCRIPT=MARCAR_ATR.vbs TAB 1 salida.bin

Comenzamos haciendo un sencillo script que nos muestre un mensaje de error en el caso de que el usuario intente ejecutarlo sin ninguna base de datos cargada:

Option Explicit

If digi.BaseDatos Is Nothing Then
    MsgBox "No hay ninguna base de datos cargada en Digi", vbOkOnly, "Error"
Else
    ' Aquí se encontrará el grueso de nuestro programa
End If

A continuación vamos a introducir la lógica para comprobar los argumentos y solicitar al usuario los parámetros que no se puedan obtener de los argumentos:

Option Explicit

Dim argumentos
Dim rsCATDBS
Dim listaTablas
Dim tabla
Dim numeroAtributos
Dim nombreArchivo

If digi.BaseDatos Is Nothing Then
    MsgBox "No hay ninguna base de datos cargada en Digi", vbOkOnly, "Error"
Else
    Set rsCATDBS = CreateObject("ADODB.Recordset")
    rsCATDBS.Open "SELECT NOMBRE FROM CATDBS", digi.BaseDatos

    While NOT rsCATDBS.EOF
        listaTablas = listaTablas + "|"
        listaTablas = listaTablas + rsCATDBS(0)

        rsCATDBS.MoveNext
    Wend
    rsCATDBS.Close

    Set argumentos = digi.Argumentos
    Select Case argumentos.Count
        Case 0
        tabla = digi.ComboOpciones ("Seleccione tabla", "Seleccione una tabla de entre las mostradas en la siguiente lista", listaTablas)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 1
        tabla = argumentos(0)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 2
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 3
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = argumentos(2)
    End Select
End If

A continuación vamos a averiguar el valor interno que tiene la tabla seleccionada:

Option Explicit

Dim argumentos
Dim rsCATDBS
Dim listaTablas
Dim tabla
Dim numeroAtributos
Dim nombreArchivo
Dim idTAB

If digi.BaseDatos Is Nothing Then
    MsgBox "No hay ninguna base de datos cargada en Digi", vbOkOnly, "Error"
Else
    Set rsCATDBS = CreateObject("ADODB.Recordset")
    rsCATDBS.Open "SELECT NOMBRE FROM CATDBS", digi.BaseDatos

    While NOT rsCATDBS.EOF
        listaTablas = listaTablas + "|"
        listaTablas = listaTablas + rsCATDBS(0)

        rsCATDBS.MoveNext
    Wend
    rsCATDBS.Close

    Set argumentos = digi.Argumentos
    Select Case argumentos.Count
        Case 0
        tabla = digi.ComboOpciones ("Seleccione tabla", "Seleccione una tabla de entre las mostradas en la siguiente lista", listaTablas)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 1
        tabla = argumentos(0)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 2
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 3
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = argumentos(2)
    End Select

    rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = '" & tabla & "'", digi.BaseDatos
    idTAB = rsCATDBS(0)
    rsCATDBS.Close
    Set rsCATDBS = Nothing
End If

Vamos a continuar iterando por todas las entidades del fichero de dibujo y añadiremos las marcas de error para dada línea que cumpla las condiciones siguientes en un array dinámico:

    Condiciones:
  • Que no estén borradas
  • Que su tipo sea lineal
  • Que tengan exáctamente numeroAtributos atributos cuya tabla sea idTAB. Las entidades podrán tener más atributos vinculados con otras tablas, pero con la tablaidTAB tienen que tener exáctamente numeroAtributos atributos.
Option Explicit

Dim argumentos
Dim rsCATDBS
Dim listaTablas
Dim tabla
Dim numeroAtributos
Dim nombreArchivo
Dim idTAB
Dim entidad
Dim coincidentes
Dim ArrayEntidades()

If digi.BaseDatos Is Nothing Then
    MsgBox "No hay ninguna base de datos cargada en Digi", vbOkOnly, "Error"
Else
    Set rsCATDBS = CreateObject("ADODB.Recordset")
    rsCATDBS.Open "SELECT NOMBRE FROM CATDBS", digi.BaseDatos

    While NOT rsCATDBS.EOF
        listaTablas = listaTablas + "|"
        listaTablas = listaTablas + rsCATDBS(0)

        rsCATDBS.MoveNext
    Wend
    rsCATDBS.Close

    Set argumentos = digi.Argumentos
    Select Case argumentos.Count
        Case 0
        tabla = digi.ComboOpciones ("Seleccione tabla", "Seleccione una tabla de entre las mostradas en la siguiente lista", listaTablas)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 1
        tabla = argumentos(0)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 2
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 3
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = argumentos(2)
    End Select

    rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = '" & tabla & "'", digi.BaseDatos
    idTAB = rsCATDBS(0)
    rsCATDBS.Close
    Set rsCATDBS = Nothing

    Set entidad = digi.PrimeraEntidad(True)
    While Not entidad Is Nothing
        If Not (entidad.Borrado) And (entidad.Tipo = vbLinea) And (entidad.Atributos >= numeroAtributos) Then
            coincidentes = 0

            For j = 0 To entidad.Atributos - 1
                If entidad.Atributo(j).Tabla = idTAB Then
                    coincidentes = coincidentes + 1
                End If
            Next

            If coincidentes=numeroAtributos Then
                entidades = entidades + 1
                ReDim Preserve ArrayEntidades( entidades )
                Set ArrayEntidades(entidades - 1) = AlmacenaError( entidad )
            End If
        End If

        Set entidad = digi.SiguienteEntidad
    Wend

    For j = 0 To entidades - 1
        Set ArrayEntidades(j) = Nothing
    Next
End If

Function AlmacenaError( entidad )
    Dim x
    Dim y
    Dim linea
    Dim at

    at = digi.AT * digi.Precision
    x = (entidad.Punto(CInt(entidad.Puntos/2)).x + entidad.Punto(CInt(entidad.Puntos/2)-1).x)/2
    y = (entidad.Punto(CInt(entidad.Puntos/2)).y + entidad.Punto(CInt(entidad.Puntos/2)-1).y)/2

    Set linea = CreateObject("Digi3D.Entidad")
    linea.Codigo = digi.Codigo
    linea.AnadePuntoXYZ x, y, 0
    linea.AnadePuntoXYZ x -	at, y + at, 0
    linea.AnadePuntoXYZ x + at, y + at, 0
    linea.AnadePuntoXYZ x + at, y - at, 0
    linea.AnadePuntoXYZ x - at, y - at, 0
    linea.Cerrar

    digi.DibujaEntidad linea
    Set AlmacenaError = linea
End Function

Por último nos queda almacenar el archivo de errores en disco:

Option Explicit

Const vbLinea = 1
Dim argumentos
Dim rsCATDBS
Dim listaTablas
Dim tabla
Dim idTAB
Dim numeroAtributos
Dim nombreArchivo
Dim ArrayEntidades()
Dim entidades
Dim coincidentes
Dim j
Dim entidad

If digi.BaseDatos Is Nothing Then
    MsgBox "No hay ninguna base de datos cargada en Digi", vbOkOnly, "Error"
Else
    Set rsCATDBS = CreateObject("ADODB.Recordset")
    rsCATDBS.Open "SELECT NOMBRE FROM CATDBS", digi.BaseDatos

    While NOT rsCATDBS.EOF
        listaTablas = listaTablas + "|"
        listaTablas = listaTablas + rsCATDBS(0)

        rsCATDBS.MoveNext
    Wend
    rsCATDBS.Close

    Set argumentos = digi.Argumentos
    Select Case argumentos.Count
        Case 0
        tabla = digi.ComboOpciones ("Seleccione tabla", "Seleccione una tabla de entre las mostradas en la siguiente lista", listaTablas)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 1
        tabla = argumentos(0)
        numeroAtributos = CInt(InputBox("Introduzca el número de atributos", "Número de atributos"))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 2
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = digi.DialogoPideArchivo(False)
        Case 3
        tabla = argumentos(0)
        numeroAtributos = CInt(argumentos(1))
        nombreArchivo = argumentos(2)
    End Select

    rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = '" & tabla & "'", digi.BaseDatos
    idTAB = rsCATDBS(0)
    rsCATDBS.Close
    Set rsCATDBS = Nothing

    Set entidad = digi.PrimeraEntidad(True)
    While Not entidad Is Nothing
        If Not (entidad.Borrado) And (entidad.Tipo = vbLinea) And (entidad.Atributos >= numeroAtributos) Then
            coincidentes = 0

            For j = 0 To entidad.Atributos - 1
                If entidad.Atributo(j).Tabla = idTAB Then
                    coincidentes = coincidentes + 1
                End If
            Next

            If coincidentes=numeroAtributos Then
                entidades = entidades + 1
                ReDim Preserve ArrayEntidades( entidades )
                Set ArrayEntidades(entidades - 1) = AlmacenaError( entidad )
            End If
        End If

        Set entidad = digi.SiguienteEntidad
    Wend

    digi.GuardaArchivo nombreArchivo, ArrayEntidades

    For j = 0 To entidades - 1
        Set ArrayEntidades(j) = Nothing
    Next
End If

Function AlmacenaError( entidad )
    Dim x
    Dim y
    Dim linea
    Dim at

    at = digi.AT * digi.Precision
    x = (entidad.Punto(CInt(entidad.Puntos/2)).x + entidad.Punto(CInt(entidad.Puntos/2)-1).x)/2
    y = (entidad.Punto(CInt(entidad.Puntos/2)).y + entidad.Punto(CInt(entidad.Puntos/2)-1).y)/2

    Set linea = CreateObject("Digi3D.Entidad")
    linea.Codigo = digi.Codigo
    linea.AnadePuntoXYZ x, y, 0
    linea.AnadePuntoXYZ x -	at, y + at, 0
    linea.AnadePuntoXYZ x + at, y + at, 0
    linea.AnadePuntoXYZ x + at, y - at, 0
    linea.AnadePuntoXYZ x - at, y - at, 0
    linea.Cerrar

    digi.DibujaEntidad linea
    Set AlmacenaError = linea
End Function

Fecha de última modificación: jueves, 19 de junio de 2003
© 2001-2003 Dreaming With Objects. Todos los derechos reservados.


DigiNG edición Scripting

DigiNG como herramienta S.I.G.
Nivel: avanzado

Gracias a la incorporación de soporte de Bases de Datos a DigiNG y a las tecnologías de scripting y al módulo de programación DigiNGScript podemos convertir DigiNG en un motor completo de S.I.G. como se demuestra en este artículo:

Disponemos de un archivo Digi sig.bin con entidades asociadas a una base de datos Access sig.mdb.

Haga click aquí para descargar los archivos de ejemplo.

Nuestro ejemplo consistirá en la realización paso a paso de un script de VBScript que nos permitirá ocultar en DigiNG todas las entidades y mostrar sólo aquellas cuyo número de policía y nombre de calle coincidan con un valor que especifique el usuario en un cuadro de diálogo.

El archivo sig.bin contiene la siguiente información (los elementos de color azul son meramente informativos)

El archivo de base de datos contiene tres tablas: la tabla standard de Digi CATDBS, una tabla denominada TAB sobre la cual están asociadas las entidades del archivo sig.bin y una tabla denominada CALLES con los identificadores de las calles.

Contenido de la tabla CATDBS:
ID | NOMBRE
1 | DBDIGI
2 | TAB

Contenido de la tabla TAB:
REGISTRO | NPOLICIA | CALLE
1 | 1 | 0
2 | 2 | 0
3 | 3 | 0
4 | 4 | 0
5 | 5 | 0
6 | 6 | 0
7 | 7 | 0
8 | 8 | 0
9 | 1 | 1
10 | 2 | 1
11 | 3 | 1
12 | 4 | 1
13 | 5 | 1
14 | 6 | 1
15 | 7 | 1

Contenido de la tabla CALLES:
CALLE | NOMBRE
0 | Carretera de Canillas
1 | Francisco Lujan

Además, se ha impuesto una norma de integridad referencial entre el campo CALLE de la tabla CALLES y el campo CALLE de la tabla TAB, de modo que el campo CALLE de la tabla TAB se comporta como una clave externa ó clave foránea que referencia a la clave primaria CALLE de la tabla CALLES.

Paso 1: Determinación del número de tabla correspondiente al nombre de tabla "TAB"
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

' Liberamos memoria
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 2: Obtenemos un recordset con todos los registros que cumplan una condición determinada.

Por ahora, y para simplificar el código, vamos a fijar los parámetros de búsqueda. Vamos a buscar el número de policía 3 para la calle con índice 1 (Francisco Lujan)

Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM TAB WHERE (NPOLICIA='3' And CALLE=1)", digi.BaseDatos
idRegistro = rsBusqueda(0)

' Liberamos memoria
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 3: Creación de un script básico que enumere todos los elementos de un documento en DigiNG:
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro
Dim entidad

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM TAB WHERE (NPOLICIA='3' And CALLE=1)", digi.BaseDatos
idRegistro  = rsBusqueda(0)

Set entidad = digi.PrimeraEntidad(False)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        ' Aquí añadiremos todo el código del programa
    End If
    Set entidad = digi.SiguienteEntidad
Wend

' Liberamos memoria
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 4: Ocultamos las entidades sin atributos relacionados con la tabla TAB:
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro
Dim entidad
Dim sw
Dim i

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM TAB WHERE (NPOLICIA='3' And CALLE=1)", digi.BaseDatos
idRegistro = rsBusqueda(0)

Set entidad = digi.PrimeraEntidad(False)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        If entidad.Atributos = 0 Then
            ' Esto oculta los textos de calles y los números de policía que aparecen en la imágen en color azul ya que no tienen
            ' asociado ningún atributo
            entidad.Visible = False
        Else
            ' La entidad tiene atributos, por lo que vamos a buscar si alguno de ellos apunta a la tabla TAB
            sw = False

            For i = 0 to entidad.Atributos - 1
                If entidad.Atributo(i).Tabla = idTAB Then
                    sw = True
                    i = entidad.Atributos ' forzamos a finalizar el bucle en la siguiente iteración
                End If
            Next

            If Not sw Then
                entidad.Visible = False
            End If
        End If
    End If
    Set entidad = digi.SiguienteEntidad
Wend

digi.RegeneraVistaOrtogonal

' Liberamos memoria
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 5: Ocultamos las entidades que no apuntan al registro idRegistro:
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro
Dim entidad
Dim sw
Dim i

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM TAB WHERE (NPOLICIA='3' And CALLE=1)", digi.BaseDatos
idRegistro = rsBusqueda(0)

Set entidad = digi.PrimeraEntidad(False)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        If entidad.Atributos = 0 Then
            ' Esto oculta los textos de calles y los números de policía que aparecen en la imagen en color azul ya que no tienen
            ' asociado ningún atributo
            entidad.Visible = False
        Else
            ' La entidad tiene atributos, por lo que vamos a buscar si alguno de ellos apunta a la tabla TAB
            sw = False

            For i = 0 to entidad.Atributos - 1
                If entidad.Atributo(i).Tabla = idTAB And entidad.Atributo(i).Registro = idRegistro Then
                    sw = True
                    i = entidad.Atributos ' forzamos a finalizar el bucle en la siguiente iteración
                End If
            Next

            If Not sw Then
                entidad.Visible = False
            End If
        End If
    End If
    Set entidad = digi.SiguienteEntidad
Wend

digi.RegeneraVistaOrtogonal

' Liberamos memoria
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 6: Hacemos la misma consulta con un INNER JOIN para poder buscar por el nombre de calle:
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro
Dim entidad
Dim sw
Dim i

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM TAB WHERE (NPOLICIA='3' And CALLE=1)", digi.BaseDatos
rsBusqueda.Open "SELECT * FROM Tab INNER JOIN Calles ON Tab.Calle = Calles.Calle WHERE (NPOLICIA='3'And Nombre='Francisco Lujan')", digi.BaseDatos
idRegistro = rsBusqueda(0)

Set entidad = digi.PrimeraEntidad(False)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        If entidad.Atributos = 0 Then
            ' Esto oculta los textos de calles y los números de policía que aparecen en la imágen en color azul ya que no tienen
            ' asociado ningún atributo
            entidad.Visible = False
        Else
            ' La entidad tiene atributos, por lo que vamos a buscar si alguno de ellos apunta a la tabla TAB
            sw = False

            For i = 0 to entidad.Atributos - 1
                If entidad.Atributo(i).Tabla = idTAB And entidad.Atributo(i).Registro = idRegistro Then
                    sw = True
                    i = entidad.Atributos ' forzamos a finalizar el bucle en la siguiente iteración
                End If
            Next

            If Not sw Then
                entidad.Visible = False
            End If
        End If
    End If
    Set entidad = digi.SiguienteEntidad
Wend

digi.RegeneraVistaOrtogonal

' Liberamos memoria
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 7: Añadimos el interface de usuario para seleccionar el nombre de la calle de entre todas las posibles:
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro
Dim entidad
Dim sw
Dim i
Dim listaCalles
Dim calle
Dim rsCalles

Set rsCalles = CreateObject("ADODB.Recordset")
rsCalles.Open "SELECT NOMBRE FROM CALLES", digi.BaseDatos

While NOT rsCalles.EOF
    listaCalles = listaCalles + "|"
    listaCalles = listaCalles + rsCalles(0)

    rsCalles.MoveNext
Wend

calle = digi.ComboOpciones ("Seleccione calle", "Seleccione una calle de entre las mostradas en la siguiente lista", listaCalles)

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM Tab INNER JOIN Calles ON Tab.Calle = Calles.Calle WHERE (NPOLICIA='3'And Nombre='Francisco Lujan')", digi.BaseDatos
rsBusqueda.Open "SELECT * FROM Tab INNER JOIN Calles ON Tab.Calle = Calles.Calle WHERE (NPOLICIA='3'And Nombre='" & calle & "')", digi.BaseDatos
idRegistro = rsBusqueda(0)

Set entidad = digi.PrimeraEntidad(False)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        If entidad.Atributos = 0 Then
            ' Esto oculta los textos de calles y los números de policía que aparecen en la imágen en color azul ya que no tienen
            ' asociado ningún atributo
            entidad.Visible = False
        Else
            ' La entidad tiene atributos, por lo que vamos a buscar si alguno de ellos apunta a la tabla TAB
            sw = False

            For i = 0 to entidad.Atributos - 1
                If entidad.Atributo(i).Tabla = idTAB And entidad.Atributo(i).Registro = idRegistro Then
                    sw = True
                    i = entidad.Atributos ' forzamos a finalizar el bucle en la siguiente iteración
                End If
            Next

            If Not sw Then
                entidad.Visible = False
            End If
        End If
    End If
    Set entidad = digi.SiguienteEntidad
Wend

digi.RegeneraVistaOrtogonal

' Liberamos memoria
Set rsCalles = Nothing
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing
Paso 8: Añadimos el interface de usuario para seleccionar el número de policía de entre todas las posibles:
Option Explicit
Dim baseDatos
Dim rsCATDBS
Dim idTAB
Dim rsBusqueda
Dim idRegistro
Dim entidad
Dim sw
Dim i
Dim listaCalles
Dim calle
Dim rsCalles
Dim listaPolicias
Dim policia
Dim rsPolicia

Set rsCalles = CreateObject("ADODB.Recordset")
rsCalles.Open "SELECT NOMBRE FROM CALLES", digi.BaseDatos

While NOT rsCalles.EOF
    listaCalles = listaCalles + "|"
    listaCalles = listaCalles + rsCalles(0)

    rsCalles.MoveNext
Wend

calle = digi.ComboOpciones ("Seleccione calle", "Seleccione una calle de entre las mostradas en la siguiente lista", listaCalles)

Set rsPolicia = CreateObject("ADODB.Recordset")
rsPolicia.Open "SELECT NPOLICIA FROM Tab INNER JOIN Calles ON Tab.Calle = Calles.Calle WHERE (Nombre='" & calle & "')", digi.BaseDatos

While NOT rsPolicia.EOF
    listaPolicias = listaPolicias + "|"
    listaPolicias = listaPolicias + rsPolicia(0)

    rsPolicia.MoveNext
Wend

policia = digi.ComboOpciones ("Seleccione número de policía", "Seleccione un número de policía de entre los mostrados en la siguiente lista", listaPolicias)

Set rsCATDBS = CreateObject("ADODB.Recordset")
rsCATDBS.Open "SELECT ID FROM CATDBS WHERE NOMBRE = 'TAB'", digi.BaseDatos
idTAB = rsCATDBS(0)

Set rsBusqueda = CreateObject("ADODB.Recordset")
rsBusqueda.Open "SELECT * FROM Tab INNER JOIN Calles ON Tab.Calle = Calles.Calle WHERE (NPOLICIA='3'And Nombre='" & calle & "')", digi.BaseDatos
rsBusqueda.Open "SELECT * FROM Tab INNER JOIN Calles ON Tab.Calle = Calles.Calle WHERE (NPOLICIA='" & policia & "'And Nombre='" & calle & "')", digi.BaseDatos
idRegistro = rsBusqueda(0)

Set entidad = digi.PrimeraEntidad(False)

While Not entidad Is Nothing
    If Not entidad.Borrado Then
        If entidad.Atributos = 0 Then
            ' Esto oculta los textos de calles y los números de policía que aparecen en la imagen en color azul ya que no tienen
            ' asociado ningún atributo
            entidad.Visible = False
        Else
            ' La entidad tiene atributos, por lo que vamos a buscar si alguno de ellos apunta a la tabla TAB
            sw = False

            For i = 0 to entidad.Atributos - 1
                If entidad.Atributo(i).Tabla = idTAB And entidad.Atributo(i).Registro = idRegistro Then
                    sw = True
                    i = entidad.Atributos ' forzamos a finalizar el bucle en la siguiente iteración
                End If
            Next

            If Not sw Then
                entidad.Visible = False
            End If
        End If
    End If
    Set entidad = digi.SiguienteEntidad
Wend

digi.RegeneraVistaOrtogonal

' Liberamos memoria
Set rsPolicia = Nothing
Set rsCalles = Nothing
Set rsBusqueda = Nothing
Set baseDatos = Nothing
Set rsCATDBS = Nothing

Referencias:
Deseo aprender más acerca de DigiNGScript
Deseo aprender más acerca de ADO (ActiveX Data Objects) (en inglés)
Deseo aprender más acerca de SQL
Deseo aprender más acerca de VBScript ó JScript

Fecha de última modificación: martes, 29 de octubre de 2002
© 2002 Dreaming With Objects S.L. Todos los derechos reservados.
© 2002 Digi21.net. Todos los derechos reservados.


Ejemplo U

DigiNG edición Scripting

Código de ejemplo "U"

El código de ejemplo de esta sección suministra un ejemplo de la vida real que demuestra cómo ejecutar la orden "U" pero desactivando la característica inherente a esta orden que hace que se mueva el restituidor si está activa la propiedad IR_TENTATIVO.

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "U". Posiblemente, al salvar el archivo el editor de textos utilizado le añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "U".

Dim oldIrTentativo

oldIrTentativo = digi.IrTentativo   ' almacenamos el valor de la propiedad de DigiNG IrTentativo en una variable temporal
digi.IrTentativo = FALSE            ' desactivamos la propiedad IrTentativo de DigiNG.
digi.EjecutaOrden "U"               ' Ejecutamos la orden "U"
digi.IrTentativo = oldIrTentativo   ' Volvemos a dejar la propiedad IrTentativo como estaba.

Mirar también

Propiedad IrTentativo | Método EjecutaOrden

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Ejemplo GuardaDatos

DigiNG edición Scripting

Código de ejemplo "GuardaDatos"

El código de este ejemplo solicita al usuario mediante un cuadro de diálogo el nombre de un archivo en el cual se almacenarán los valores de todas las propiedades ( DA, IT, INC, ... ) con sus valores actuales.
Este archivo es el que usará el ejemplo CargaDatos

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "GuardaDatos". Posiblemente, al salvar el archivo el editor de textos utilizado le añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "GuardaDatos".

Call GuardaDatos

Sub GuardaDatos
    Dim archivo
    Dim fso
    Dim os

    archivo = digi.DialogoPideArchivo(False)                   ' Almacenamos en la variable "archivo" el nombre del archivo
                                                               ' que ha seleccionado el usuario.

    If archivo == "" Then Exit Sub                             ' Si el usuario pulsó escape nos salimos y no hacemos nada

    set fso = CreateObject("Scripting.FileSystemObject")       ' Creamos un objeto FileSystemObject que nos permitirá crear
                                                               ' un archivo.

    set os = fso.CreateTextFile(archivo, True)                 ' Creamos un archivo de texto con el nombre devuelto por la
                                                               ' función de DigiNG DialogoPideArchivo. El segundo parámetro,
                                                               ' si es True, indica que queremos sobreescribir el archivo en
                                                               ' el caso de que existiera.

    os.WriteLine( digi.da )                                    ' Almacenamos en el archivo el valor de la propiedad DA
    os.WriteLine( digi.inc )
    os.WriteLine( digi.aa )
    os.WriteLine( digi.at )
    os.WriteLine( digi.it )
    os.WriteLine( digi.tol )
    os.WriteLine( digi.tolang )
    os.WriteLine( digi.equidistancia )
    os.WriteLine( digi.escact )
    os.WriteLine( digi.girar )
    os.WriteLine( digi.ndec )
    os.WriteLine( digi.grosor )
    os.WriteLine( digi.c )
    os.WriteLine( digi.orto )
    os.WriteLine( digi.ortoaa )
    os.WriteLine( digi.borrados )
    os.WriteLine( digi.ver )
    os.WriteLine( digi.fijaz )
    os.WriteLine( digi.tentativotextos )
    os.WriteLine( digi.irprincipio )
    os.WriteLine( digi.g )
    os.WriteLine( digi.s )
    os.WriteLine( digi.repite )
    os.WriteLine( digi.tentativofin )
    os.WriteLine( digi.irtentativo )
    os.WriteLine( digi.pita )
    os.WriteLine( digi.patron )
    os.WriteLine( digi.patrons )
    os.WriteLine( digi.raton )
    os.WriteLine( digi.fijaxy )

    os.Close
End Sub

Mirar también

Método DialogoPideArchivo | Propiedades de DigiNGScript | Ejemplo CargaDatos

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Ejemplo CargaDatos

DigiNG edición Scripting

Código de ejemplo "CargaDatos"

El código de este ejemplo solicita al usuario mediante un cuadro de diálogo el nombre de un archivo del cual se cargarán los valores de las propiedades almacenadas con el ejemplo GuardaDatos.

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "CargaDatos". Posiblemente, al salvar el archivo el editor de textos utilizado le añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "CargaDatos".

Call CargaDatos

Sub CargaDatos
    Dim archivo
    Dim fso
    Dim os
    Const ModoLectura = 1

    archivo = digi.DialogoPideArchivo(True)

    If archivo = "" Then Exit Sub

    set fso = CreateObject("Scripting.FileSystemObject")
    set os = fso.OpenTextFile(archivo, ModoLectura)

    digi.da = os.ReadLine
    digi.inc = os.ReadLine
    digi.aa = os.ReadLine
    digi.at = os.ReadLine
    digi.it = os.ReadLine
    digi.tol = os.ReadLine
    digi.tolang = os.ReadLine
    digi.equidistancia = os.ReadLine
    digi.escact = os.ReadLine
    digi.girar = os.ReadLine
    digi.ndec = os.ReadLine
    digi.grosor = os.ReadLine
    digi.c = os.ReadLine
    digi.orto = os.ReadLine
    digi.ortoaa = os.ReadLine
    digi.borrados = os.ReadLine
    digi.ver = os.ReadLine
    digi.fijaz = os.ReadLine
    digi.tentativotextos = os.ReadLine
    digi.irprincipio = os.ReadLine
    digi.g = os.ReadLine
    digi.s = os.ReadLine
    digi.repite = os.ReadLine
    digi.tentativofin = os.ReadLine
    digi.irtentativo = os.ReadLine
    digi.pita = os.ReadLine
    digi.patron = os.ReadLine
    digi.patrons = os.ReadLine
    digi.raton = os.ReadLine
    digi.fijaxy = os.ReadLine

    os.Close
End Sub

Mirar también

Método DialogoPideArchivo | Propiedades de DigiNGScript | Ejemplo GuardaDatos

Fecha de última modificación: domingo, 9 de diciembre de 2001

© 2001 Dreaming With Objects. Todos los derechos reservados.


Ejemplo Zoome

DigiNG edición Scripting

Código de ejemplo "Zoome"

El código de ejemplo de esta sección emula la orden interna de DigiNG zoome que hace un zoom extendido en la vista ortogonal.

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "Zoome". Posiblemente, al salvar el archivo el editor de textos añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "Zoome".

digi.VistaMaxMin = digi.ArchivosMaxMin      ' Indicamos que las máximas y mínimas de la vista se correspondan con las máximas
                                            ' y mínimas de todos los archivos cargados.
digi.RegeneraVistaOrtogonal                 ' Regeneramos la vista ortogonal para visualizar los cambios

Mirar también

Propiedad ArchivosMaxMin | Propiedad VistaMaxMin

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Ejemplo Zoomp

DigiNG edición Scripting

Código de ejemplo "Zoomp"

El código de ejemplo de esta sección emula la orden interna de DigiNG zoomp que centra la visualización de la pantalla ortogonal en un punto que el usuario digitaliza con el ratón o con los codificadores.

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "Zoomp". Posiblemente, al salvar el archivo, el editor de textos añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "Zoomp".

Dim ptCentroVista
Dim nuevoMaxMin

' Solicitamos al usuario que digitalize un punto
digi.ImprimeMensaje "Digitalize el punto para centrar la pantalla alrededor de éste..."
Set ptCentroVista = digi.PidePunto
digi.ImprimeMensaje ""

' Creamos un objeto de tipo MaxMin con el nuevo rango de coordenadas de visualización
Set nuevoMaxMin = CreateObject("Digi3D.MaxMin")
nuevoMaxMin.xmin = ptCentroVista.x - digi.VistaMaxMin.Width/2
nuevoMaxMin.ymin = ptCentroVista.y - digi.VistaMaxMin.Height/2
nuevoMaxMin.xmax = ptCentroVista.x + digi.VistaMaxMin.Width/2
nuevoMaxMin.ymax = ptCentroVista.y + digi.VistaMaxMin.Height/2

' Modificamos el rango de coordenadas de visualización de la vista ortogonal y regeneramos la vista
digi.VistaMaxMin = nuevoMaxMin
digi.RegeneraVistaOrtogonal

' Liberamos la memoria
Set nuevoMaxMin = Nothing

Mirar también

Método ImprimeMensaje | Método PidePunto | Método RegeneraVistaOrtogonal | Propiedad VistaMaxMin

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Ejemplo Poligono

DigiNG edición Scripting

Código de ejemplo "Poligono"

El código de este ejemplo registra un polígono cerrado con un número determinado de lados especificados por el usuario mediante un InputBox de VBScript.

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "Poligono". Posiblemente, al salvar el archivo el editor de textos utilizado le añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "CargaDatos".

Const Pi = 3.14159265358979323846

Dim lados

lados = InputBox("Número de lados")

If lados < 3 Then
    MsgBox "El número de lados debe ser tres o superior", vbOKOnly, "Error"
Else
    Dim ptCentro
    Dim ptPrimerVertice

    digi.ImprimeMensaje "Digitalize el centro del polígono..."
    Set ptCentro = digi.PidePunto

    digi.ImprimeMensaje "Digitalize un vértice del polígono..."
    Set ptPrimerVertice = digi.PidePunto

    digi.ImprimeMensaje ""

    Dim distancia
    distancia = ptCentro.Distancia(ptPrimerVertice)

    Dim angulo
    angulo = ptCentro.Angulo(ptPrimerVertice)

    Dim puntoCalculado
    Set puntoCalculado = CreateObject("Digi3D.Point")
    puntoCalculado.z = ptPrimerVertice.z

    Dim linea
    Set linea = CreateObject("Digi3D.Entidad")
    linea.Codigo = digi.Codigo

    Dim i
    For i = 1 To lados
        puntoCalculado.x = ptCentro.x + distancia * Cos( angulo + (i-1)*2*Pi/lados )
        puntoCalculado.y = ptCentro.y + distancia * Sin( angulo + (i-1)*2*Pi/lados )
        linea.AnadePunto(puntoCalculado)
    Next

    linea.Cerrar

    digi.DibujaEntidad(linea)
    digi.AnadeEntidad(linea)

    ' Liberamos la memoria
    Set puntoCalculado = Nothing
    Set ptCentro = Nothing
    Set ptPrimerVertice = Nothing
End If

Mirar también

Método ImprimeMensaje | Método PidePunto | Método DibujaEntidad | Método AnadeEntidad | Propiedad Codigo | Objeto Point | Objeto Entidad

Fecha de última modificación: domingo, 9 de diciembre de 2001

© 2001 Dreaming With Objects. Todos los derechos reservados.


Ejemplo Binunion

DigiNG edición Scripting

Código de ejemplo "Binunion"

El código de este ejemplo solicita al usuario mediante un cuadro de diálogo el nombre de un archivo. Luego se copiarán todas las entidades de dicho archivo en el documento activo de DigiNG tal y como lo haría la utilidad de Digi "Binunion".

Para ejecutar este código en DigiNG, seguir los siguientes pasos:

Crear con un editor de textos (como el bloc de notas) un archivo llamado "Binunion". Posiblemente, al salvar el archivo el editor de textos utilizado le añada la extensión .txt, que tendremos que quitar más adelante con el explorador de archivos de Windows.

Copiar el siguiente bloque de código de ejemplo en el archivo "Binunion".

Option Explicit

Dim nombreArchivo
Dim numeroEntidades
Dim entidades
Dim i

nombreArchivo = digi.DialogoPideArchivoReferencia
numeroEntidades = digi.CargaArchivo(nombreArchivo, entidades)

For i = 0 To numeroEntidades - 1
    digi.AnadeEntidad entidades(i)
Next

Mirar también

Método DialogoPideArchivo | Método CargaArchivo | Método AnadeEntidad

Fecha de última modificación: miércoles, 22 de mayo de 2002
© 2001 Dreaming With Objects. Todos los derechos reservados.


Algoritmo para la eliminación de extensiones o la extracción del directorio donde se ubica un archivo

Copiar el siguiente bloque de código de ejemplo en el archivo "algoritmo1".

' Algoritmo básico para eliminar de una ruta completa de archivo (compuesta por Directorio + Nombre de Archivo + Extensión)
' la extensión del archivo o el nombre del archivo para quedarse únicamente con el nombre del directorio donde está el
' archivo.

Dim completo
completo = "c:\prueba\jander.abc"

' ruta contiene el directorio, el nombre del archivo y la extension
Dim sinExtensionMal
sinExtensionMal = Left( completo, Len(completo) - 4 )  ' Asumiendo que la extensión es 1 punto + 3 caracteres = 4

MsgBox "sinExtensionMal=" & sinExtensionMal

' ¿Por qué hemos llamado a la variable donde almacenar el nombre del archivo sin la extensión sinExtensionMal?
' Pues por que está mal hecho.
' ¿Que hubiera ocurrido si la variable "completo" hubiera tenido el valor "c:\prueba\jander.abcde"?
' Pues que el resultado hubiera sido "c:\prueba\jander.a", ya que quitamos forzosamente los 4 últimos caracteres.

' Vamos a hacerlo bien:
'   Ya que la extensión no tiene por que tener forzosamente 3 caracteres, lo que hacemos es
'   ir quitando progresivamente el último carácter a la cadena hasta quitar el carácter .
'
'   Ej: Tenemos la cadena="c:\prueba\a.abcde"
'
'   ¿'e' = '.'?. No, por lo que le quitamos el último carácter. Ahora cadena="c:\prueba\a.abcd"
'   ¿'d' = '.'?. No, por lo que le quitamos el último carácter. Ahora cadena="c:\prueba\a.abc"
'   ¿'c' = '.'?. No, por lo que le quitamos el último carácter. Ahora cadena="c:\prueba\a.ab"
'   ¿'b' = '.'?. No, por lo que le quitamos el último carácter. Ahora cadena="c:\prueba\a.a"
'   ¿'a' = '.'?. No, por lo que le quitamos el último carácter. Ahora cadena="c:\prueba\a."
'   ¿'.' = '.'?. Si, por lo que nos salimos del bucle, pero tenemos que quitar ese último carácter, que no nos interesa tener al final un punto,
'   y ya está
'
'
Dim sinExtensionBien
sinExtensionBien = completo
While Not Right( sinExtensionBien, 1 ) = "."
    sinExtensionBien = Left( sinExtensionBien, Len(sinExtensionBien)-1 ) ' Quitamos el último carácter
Wend

sinExtensionBien = Left( sinExtensionBien, Len(sinExtensionBien)-1 ) ' Quitamos el punto

MsgBox "sinExtensionBien=" & sinExtensionBien

' y ahora podemos generalizarlo en una función
MsgBox "El nombre del archivo sin extensión es: " & QuitaExtension( completo )

' y si hacemos una función parecida, conseguimos extraer el directorio (quitando el nombre del archivo y la extensión)
MsgBox "El directorio es :" & DameDirectorio( completo )

Function QuitaExtension( archivo )
    Dim sinExtensionBien
    sinExtensionBien = archivo
    While Not Right( sinExtensionBien, 1 ) = "."
        sinExtensionBien = Left( sinExtensionBien, Len(sinExtensionBien)-1 ) ' Quitamos el último carácter
    Wend
    sinExtensionBien = Left( sinExtensionBien, Len(sinExtensionBien)-1 ) ' Quitamos el último carácter

    QuitaExtension = sinExtensionBien
End Function

Function DameDirectorio( archivo )
    ' DameDirectorio funciona exactamente igual que QuitaExtension, pero en vez de buscar "." lo que busca es "\"
    Dim sinExtensionBien
    sinExtensionBien = archivo
    While Not Right( sinExtensionBien, 1 ) = "\"
        sinExtensionBien = Left( sinExtensionBien, Len(sinExtensionBien)-1 ) ' Quitamos el último carácter
    Wend
    sinExtensionBien = Left( sinExtensionBien, Len(sinExtensionBien)-1 ) ' Quitamos el último carácter

    DameDirectorio = sinExtensionBien
End Function

Fecha de última modificación: jueves, 14 de febrero de 2002
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Visual C++

En esta parte de la ayuda se explican temas relacionados con la programación en Visual C++:

  • Ejemplo de código de lectura de archivos .bin.

Fecha de última modificación: viernes, 17 de Enero de 2003


Entidad.CPP

#include <stdio.h>
#include <stdlib.h>
#include <fcntl.h>
#include <io.h>
#include <sys\stat.h>
#include <conio.h>
#define     RESTO   6

   typedef struct lpoint3d LPOINT3D;
   struct lpoint3d{
    long x,y,z ;
   };

   typedef struct tipo_dat TIPO_DAT;
   struct tipo_dat {
     char          tipo[2];
     char          cod[7];
     unsigned char atr;         /* numero de atributos */
     unsigned short  npuntos;
   };

   typedef struct tipo_dat ATR;
   struct atr {
     short tabla;       /* numero de la tabla de BD */
     long registro;     /* numero del registro de la BD enlazado */
     char resto[RESTO] ;    /* disponible */
   };

   typedef struct tipo_max TIPO_MAX;
   struct tipo_max {
     long  xmin, ymin, zmin;
     long  xmax, ymax, zmax;
     long  xlib, ylib, zlib;
     };

   typedef struct cab_digi CAB_DIGI ;
   struct cab_digi {
       TIPO_DAT dat;
       TIPO_MAX max;
   };

   typedef struct TpEntidad Entidad;
   struct TpEntidad {
    int	  ID;
    CAB_DIGI  cab;
    LPOINT3D  *coor;
    ATR       *atr;
    struct TpEntidad *Siguiente;
   };

   Entidad *ListaDeEntidades = NULL;

void CargaEntidad(Entidad dato,Entidad ** Lista)
{
    Entidad *Lista_aux;
    Lista_aux = (Entidad*)malloc(sizeof(Entidad));
    *Lista_aux = dato;
    Lista_aux->Siguiente = *Lista;
    *Lista = Lista_aux;
}

void CargaBIN(char *bin_arch)   {
   char asc_arch[80];
   FILE *fichero_ASCII;
   int fichero_BIN;

   if ((fichero_BIN = open(bin_arch,O_RDONLY|O_BINARY,S_IREAD))==-1) {
      printf("No se puede abrir el archivo... %s\n",bin_arch);
      exit(1);
   }
   else {
    int n=1;
    Entidad dato;
    lseek(fichero_BIN,0L,SEEK_SET);
    for(;;) {
    if (read(fichero_BIN,&(dato.cab),sizeof(CAB_DIGI)) <= 0) break;
    dato.ID=n++;
    dato.coor = (LPOINT3D*)malloc(sizeof(LPOINT3D)*dato.cab.dat.npuntos);
    dato.atr = (ATR*)malloc(sizeof(ATR)*dato.cab.dat.npuntos);
    if (((dato.coor==NULL)&(dato.cab.dat.npuntos>0))|
        ((dato.atr==NULL)&(dato.cab.dat.atr>0)))
    {
         puts("Insuficiente memoria disponible \n");
         exit(1);
    }
    read(fichero_BIN,dato.coor,dato.cab.dat.npuntos * sizeof(LPOINT3D));
    read(fichero_BIN,dato.atr,dato.cab.dat.atr * sizeof(ATR));
    CargaEntidad(dato,&ListaDeEntidades);
    }
  close (fichero_BIN);
  }
}

void GuardaBIN(char *bin_arch)   {
   char asc_arch[80];
   FILE *fichero_ASCII;
   int fichero_BIN;

   if ((fichero_BIN = open(bin_arch,O_WRONLY|O_BINARY,S_IWRITE))==-1) {
      printf("No se puede abrir el archivo... %s\n",bin_arch);
      exit(1);
   }
   else {
    Entidad *dato;
    dato = ListaDeEntidades;
    lseek(fichero_BIN,0L,SEEK_SET);
    for(;dato!=NULL;dato=dato->Siguiente) {
    write(fichero_BIN,&(dato->cab),sizeof(CAB_DIGI));
    write(fichero_BIN,dato->coor,(*dato).cab.dat.npuntos * sizeof(LPOINT3D));
    write(fichero_BIN,dato->atr,(*dato).cab.dat.atr * sizeof(ATR));
    }
  close (fichero_BIN);
  }
}

void main(){
CargaBIN("c:\\kk.bin");
GuardaBIN("c:\\ll.bin");
};

Fecha de última modificación: viernes, 17 de Enero de 2003


Visual Basic

Fecha de última modificación: viernes, 17 de Enero de 2003


Barra de Herramientas Base de Datos

Tiene el siguiente aspecto:

Esta barra de herramientas tiene varias funciones que de izquierda a derecha son:

  • Carga una nueva base de datos
  • Descarga la base de datos actual .
  • Añade un atributo a la memoria .
  • Añade una copia del último atributo a la memoria .
  • Elimina los atributos de la memoria.
  • Inserta atributos en una entidad.
  • Borra todos los atributos de una entidad.

Fecha de última modificación: viernes, 10 de Octubre de 2003


Bienvenido a Digi3D y DigiNG versión 2003.85.0000

Información General

Bienvenido a Digi3D y DigiNG

Digi21 ofrece actualmente diferentes módulos de software y hardware para responder a las necesidades de la restitución fotogramétrica digital. Entre estas aplicaciones se encuentra la Estación Fotogramétrica Digital Digi3D y el sistema de diseño e información cartográfico DigiNG.

La ayuda de Digi3D contiene los siguientes apartados:

  • Instalación del hardware: aquí aprenderás a instalar todo el hardware perteneciente a la estación fotogrametrica digital.
  • Instalación de Digi3D: aquí se explica toda la instalación del software de Digi3D.
  • Comenzando con Digi3D: aquí, además de las explicaciones teóricas hay a una serie de videos explicativos con los que podrás aprender los conceptos básicos para preparar tu equipo y trabajar con Digi3D y DigiNG.
  • Comenzando con DigiNG: en este apartado de la ayuda aprenderás a restituir y editar con DigiNG.
  • Referencia: este apartado de la ayuda está dividido en varias secciones y explica al completo todos los aspectos de Digi3D y DigiNG. Desde explicaciónes detalladas de los menus, Configuraciones, Ordenes exixtentes hasta formatos de archivo.
  • Programacion: en este tema de la ayuda se explican aspectos relacionados con la programación con DigiNGScript, VisualC++ y Visual Basic.

© 2003 equipo de Digi21.net Todos los derechos reservados.

Fecha de última modificación: 25 de Mayo de 2004


Control de Digi3D mediante comandos

El restituidor digital Digi3D es controlado por medio de órdenes, que pueden ser introducidas en el restituidor de las formas siguientes:

  • Introducción de órdenes mediante el Menú Digital
  • Introducción de ordenes mediante la ventana de comandos
  • Asignación de órdenes a teclas

Fecha de última modificación: lunes, 11 de Noviembre de 2002


Ejemplo de importación de Orientaciones Externas de SD2000

Para importar las Orientaciones Externas de SD2000 a Digi3D mediante un archivo, se elige Importar/Exportar en Archivo dentro del menú principal de la ventana de Digi3D,

aparece la siguiente ventana:

donde se selecciona Importar orientaciones externas de SD2000 y se pulsa sobre el botón Ejecutar que se encuentra en la parte inferior derecha de dicha ventana. Se muestra en pantalla la siguiente ventana:

En esta ventana se deben introducir los siguientes datos:

  • Imagen izquierda: en este ejemplo se trata de la imagen 2316.tif.
  • Imagen derecha: en este ejemplo se trata de la imagen 2319.tif.
  • Archivo de cámara: se trata del archivo rc30.cam.
  • Archivo a importar: se trata del archivo EXTERIOR.ORI, cuyo contenido es el siguiente:
    Exterior Orientation Parameters

Structure of parameter block:
----------------------------------------------------
Image ID    Camera ID
Flags:  Disregard / Rot. sequence / Strip No. / I.Ori. Type / Time
Coordinates of projection center X Y Z
Orientation angles  Omega Phi Kappa [gon]
----------------------------------------------------

Interpretation of flags:

Disregard = 0 => Image is used
Disregard = 1 => Image is disregarded

Rotation from object to image system:
Rotation sequence = 0 => X-axis, Y-axis, Z-axis
Rotation sequence = 1 => Y-axis, X-axis, Z-axis
Rotation sequence = 2 => X-axis 100[gon] fixed, Y-axis, X-axis, Z-axis

Strip No.         = 1..n

Inner Orientation Type = 0 => Affine
Inner Orientation Type = 1 => Conformal
Inner Orientation Type = 2 => Shift & Rotation

Time the image was taken, comes from GPS receiver

The file is free formatted.
Each parameter must be separated by at least one space character.

**** Start of Data ****
      2316       rc30
         0          0           1          0       0.000
         765845.00938         4570627.72722         3206.52702665
       -1.91979856704         1.07937891885       0.0500900740164
      2319       rc30
         0          0           1          0       0.000
        767456.801899         4570687.70695         3196.07193312
       0.365768155972        0.632372802387        0.581956796673
  • Z media del terreno: en este caso es 1500 metros.

Seleccionados todos los archivos en la ventana Importar orientaciones externas de SD2000, se pulsa sobre el botón Importar situado en la parte inferior de dicha ventana. Como resultado de esta importación se crean 4 archivos:

  • Archivo de Orientación Relativa: se crea el archivo 2316-2319.rel. Si quiere ver una descripción de este tipo de archivos lea el tema de la ayuda Formato del archivo de Orientación Relativa.
  • Archivo de Orientación Absoluta: se crea el archivo 2316-2319.abs. Si quiere ver una descripción de este tipo de archivos lea el tema de la ayuda Formato del archivo de Orientación Absoluta.
  • Archivos de Orientación Externa: se crean dos archivos, correspondientes a cada una de las imágenes: 2316.ori y 2319.ori. Si quiere ver una descripción de este tipo de archivos lea el tema de la ayuda Formato del archivo de Orientación Externa.

Fecha de última modificación: lunes, 14 de Octubre de 2002


Importación de Ficheros DGN

DigiNg te ofrece la posibilidad de importar (o convertir) un fichero de MicroStation™ con extensión .DGN.

Requisitos
  • Programa DigiNG (incluido en el restituidor digital Digi3D).
  • Tabla de conversión de formatos (DGNBIN.TAB).

A continuación se explicará la tabla de conversión de DGN a BIN, para poder transformar la simbología de MicroStation™ a código de Digi. Finalmente se realiza un ejemplo, en el que partimos de un archivo DGN y una tabla de conversión (DGNBIN.TAB), y generamos el archivo en formato BIN.

Tabla DGNBIN.TAB

MicroStation™ no diferencia los códigos como DigiNG. En DigiNG tenemos una cadena de seis caracteres que identifica cada código. En MicroStation tenemos dos opciones:

  • Diferenciar los elementos por la composición de cuatro valores: Nivel, Estilo, Color y Peso.
  • Diferenciar los elementos por su Grupo Gráfico.

DigiNG MicroStation™
Código
Nivel Estilo Color Peso
ó
Grupo Gráfico

Tendremos que solicitar al cliente su tabla de códigos, y generar una tabla de traducción que relacione un código de Digi con los valores de la tabla de códigos del cliente.

La tabla de traducción es un archivo ASCII (que podemos generar con el programa Bloc de Notas) que tiene el nombre DGNBIN.TAB y su formato es el siguiente:

    Código DigiNG | Código correspondiente a DigiNG.
Nivel | Es el nivel en el que se encuentre el elemento en MicroStation.
Estilo de línea | Es el estilo de línea del elemento en MicroStation.
Color | Es el color del elemento en MicroStation.
Peso | Es el peso (grosor) del elemento en MicroStation.
Fuente | Fuente de MicroStation.
Grupo gráfico (gg) | Si se usa el grupo gráfico los datos correspondientes a MicroStation™ (nivel, estilo, color y peso) estarán a cero. En el caso de que se utilicen los datos correspondientes a MicroStation (nivel, estilo, color, peso), el grupo gráfico será cero.
Nombre célula | La siguiente columna es el nombre de la célula si existe. En el caso de que no se trate de una célula se pone un espacio en blanco " ", que sirve para materializar esa posición.
Alto | Se trata de un factor de escala que se aplica a las células.
Símbolo Digi | Correspondencia con el símbolo de DigiNG.

La tabla puede tener una cabecera comentario, comenzando estas líneas de comentario con los caracteres '//'

Un ejemplo de línea de este archivo puede ser:

//COD   LV   ST   CO   WT   FONT   GG   CELL  ALTO  SIMB.DIGI
00100    1    2    3    4    0     0    " "

Si hay en el fichero elementos que sean pattern component, de ellos no se traduce el patrón sino la línea generadora.

Para poder recuperar los symbol font en DigiNG se deberán poner en la tabla en correspondencia con los mismos los símbolos Digi (@<n>) que habrán de representarlos. Por ejemplo, en la siguiente línea, a la célula con el nombre 'W' le corresponde el símbolo @166 de DigiNG, por lo tanto, siempre que aparezca "W" en el fichero DGN, será sustituido en el fichero BIN por el @166:

//COD   LV   ST   CO   WT   FONT   GG   CELL  ALTO  SIMB.DIGI
001118  20    0    0    1    0    1118    W     1     @166

Conversión de formato DGN a BIN con DigiNG

Por lo tanto, para convertir un fichero de formato DGN a BIN es necesario conocer cómo tenemos los elementos en MicroStation™ y cómo los queremos en DigiNG. Y con ello se define la tabla DGNBIN.TAB, y se debe almacenar en el mismo directorio donde esté el archivo DGN. El archivo DGN de este ejemplo tiene el nombre de Ejemplo.dgn.

Entramos en DigiNG, y en la ventana de inicio.

Creamos un nuevo archivo BIN vacío, en este caso Ejemplo.bin. Una vez dentro de DigiNGejecutamos la orden IMPORTAR, donde seleccionamos en la lista desplegable inferior Archivo DGN, y luego seleccionamos el archivo que vamos a transformar a formato BIN. Al pulsar el botón Abrir nos aparece la siguiente ventana:

donde podemos seleccionar la tabla de traducción, el factor de escala, si queremos transformar las células, ... Seleccionamos lo que nos interese y luego pulsamos sobre el botón Aceptar.Y ya está convertido el archivo Ejemplo.dgn en el archivo Ejemplo.BIN:

Si quieres seguir este ejemplo, bájate los archivos dgnbin.zip de nuestra página de descargas.

Fichero de Error

Si en el fichero .DGN existe una entidad que no haya sido considerada en la tabla de traducción, DigiNG generará un fichero de error, con extensión .err.

En este fichero de error se informa sobre los atributos del código que no ha sido capaz de reconocer. El formato de dicho fichero de error es el siguiente:

Nivel(LV)  Estilo(ST)  Color(CO)  Peso(WT)  Fuente(FONT)  GrupoGráfico(GG)  Célula(CELL)

Mirar también

Conversión de Ficheros .BIN a .DGN | IMPORTAR

Fecha de última modificación: martes, 12 de Noviembre de 2003
© 2001 Dreaming With Objects. Todos los derechos reservados.


Información General

Información General

Digi3D es la aplicación para el manejo de la Estación de Fotogrametría Digital que permite el registro de entidades geográficas a partir de imágenes aéreas, de satélite y procedentes de Fotogrametría terrestre. Como datos de entrada, Digi3D permite múltiples formatos de archivos gráficos, entre los que se encuentran TIFF, BMP, JPEG, Mister SID, etc.

DigiNG es la aplicación de registro y edición de información especificamente cártográfica, y por ello gran número de empresas apuestan por ella para sus trabajos cartográficos. Esta aplicación posee una perfecta conexión con la estación de fotogramétrica Digi3D y con otros aparatos analógicos y analíticos.

© 2003 equipo de Digi21.net Todos los derechos reservados.

Fecha de última modificación: 22 de Marzo de 2004


Instalación de los dispositivos de entrada y movimiento de imágenes

El sistema de movimiento de imágenes también puede tener diferentes configuraciones. El funcionamiento de dichos dispositivos requiere la instalación de una tarjeta de codificadores.

En los siguientes temas de la ayuda se explica cómo instalar cada componente del restituidor digital Digi3D:

  • Instalación de la tarjeta de codificadores.
  • Instalación del sistema de manivelas.
  • Instalación del pedal de Z.
  • Instalación del ratón 3D.

Fecha de última modificación: 22 de Marzo de 2004


Instalación del Hardware de Visualización Estereoscópico

El sistema de visualización estereoscópico puede tener diferentes configuraciones.

En los siguientes temas de la ayuda se explica cómo instalar cada uno de dichos componentes:

  • Instalación de los monitores de la estación fotogramétrica Digi3D.
  • Instalación del Sistema de visión estereoscópica por monitor ZScreen.
  • Instalación del Estereóscopo.
  • Instalación del Sistema de gafas activas.

Fecha de última modificación: 22 de Marzo de 2004


Instalación del Software

En este capítulo se describen los temas siguientes:

  1. Requisistos del Sistema.
  2. Instalar Digi3D.
  3. Instalación del Software.
  4. Instalación del driver de la llave de protección.
  5. Desinstalar Digi3D.
  6. Solucionar problemas de GenPORT. Si tu tarjeta de codificadores es externa, no hagas este paso e instala Digi3D como se explica en el siguiente punto.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: miércoles, 10 de abril 2002


Instalar de Digi3D

La instalación de Digi3D es un proceso automatizado.

Para instalar Digi3D:

  1. Antes de iniciar la instalación comprueba que no exisista ninguna otra versión de Digi3D instalada en tu equipo.
  2. Sigue uno de estos procedimientos para iniciar el proceso de instalación:
    • (Windows)Si tiene el CD, insértalo en la unidad de CD. Se reproduce una película Flash que te indica las opciones de instalación de programas.

      Nota: también puedes ejecutar el archivo Digi3D2003.exe para iniciar la instalación manualmente, si es necesario.

    • También es posible bajar Digi3D de la página web de Digi21.net entrando en el apartado de Descargas y seleccionandolo de la lista desplegable.

  3. A continuación sigue las instrucciones que el instalador te muestra en pantalla y elige la instalación completa por defecto si lo deseas.

    Una vez que se haya completado la instalación aparecerá en tu pantalla el Histórico de Versiones Readme.txt. Este archivo te informa de las últimas novedades y modificaciones que tiene la versión y dicho archivo se te guardará en el Directorio C:\Archivos de Programa\Digi21.net\Digi3D.

Nota: En caso de tener que instalar otra versión, hará falta desinstalar Digi3D por medio del Panel de Control de Windows y reiniciar el equipo antes de instalar denuevo el programa.

Te invitamos a ver un video explicativo sobre éste tema de ayuda. Para verlo haz click aquí.

Siguiente

Fecha de última modificación: jueves, 1 de Marzo de 2004


Método digi.NuevoArchivoReferencia2

Carga un nuevo archivo de referencia. Especifica los parámetros de importación.

Si el archivo ya estaba cargado, no se carga de nuevo.

digi.NuevoArchivoReferencia2 (archivo, parámetros de importación)

Argumentos

archivo
Nombre del archivo de referencia a cargar.

Parámetros de importación
Parámetros específicos del importador.

Ejemplo

digi.NuevoArchivoReferencia "c:\trabajos\ejemplo.dgn"  "

Mirar también

Métodos de DigiNGScript

Fecha de última modificación: domingo, 9 de diciembre de 2001
© 2001-2002 Dreaming With Objects. Todos los derechos reservados.


Orden AUTOCORRELAR

Digi3D

Orden: AUTOCORRELAR

Esta orden activa/desactiva la opción de correlar automáticamente cuando Digi, u otro programa externo de CAD, mueve el restituidor.

Esta opción es util cuando estamos haciendo modelos digitales del terreo interactivos, ya que podemos programar a Digi para que mueva el restituidor con un determinado incremento de registro. Si tenemos activada la orden AUTOCORRELAR el restituidor se posará en Z automáticamente, y tan solo tendremos que corregir la Z si éste se ha posado mal.


Orden BILINEAL

Esta orden sirve para pintar un píxel en una imagen cargada en DigiNG, cuyo color será resultado de una interpolación bilineal realizada entre los colores de los 4 píxeles más cercanos.

Al ejecutar la orden, el programa pide que se seleccione el píxel en el que se desea pintar, como se puede observar en la parte inferior izquierda de la pantalla:

y una vez pintado, pide de nuevo un píxel. Para salir de la orden se debe pulsar la tecla Esc.

Esta orden se autorrepite, independientemente del estado del conmutador REPITE.

En el caso de que se ejecute la orden sin que haya ninguna imagen se muestra el siguiente mensaje:

Si se efectúan cambios en las imágenes cargadas, al salir de DigiNG o al ejecutar la orden DEJAR_RASTER se pregunta al usuario si desea salvar los cambios mediante el siguiente cuadro:

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: viernes, 15 de Agosto de 2002


Orden BORRA_AUTODUPLICADOS

Esta orden sirve para borrar parte de entidades que vuelven sobre sí mismas, y por lo tanto están duplicadas. Esta orden no borra entidades duplicadas. La forma de ejecutar esta orden es:

BORRA_AUTODUPLICADOS=<código>

con lo que se que borran las partes duplicadas de las entidades con dicho código.

Órdenes relacionadas: BORRA_COD, BORRA_COD_V, BORRA_E, BORRA_LIN1, BORRA_ULTIMO, BORRA_V, BORRADOS.

Fecha de última modificación: miércoles, 11 de Septiembre de 2002


Orden CARGA_RASTERS_POR_VENTANA

Con esta orden se cargan en DigiNG (no en Digi3D ), todas las imágenes que tengan asociado alguna de los archivos de georreferenciación y además solapen con una entidad cerrada (a modo de ventana).

Al ejecutar la orden el programa solicita que se seleccione la entidad cerrada y posteriormente el directorio donde debe buscar imágenes georreferenciadas para proceder a su carga.

Órdenes relacionadas: CAMBIA_BRILLO_CONTRASTE, CAMBIA_BRILLO_CONTRASTE_V, CARGA_RASTER, COLOR_PIXEL, CORTAR_RASTER, CUENTAGOTAS, DEGRADADO, DEJAR_RASTER, EQUILIBRIO_COLOR, EQUILIBRIO_COLOR_V, PINTA_PIXEL, POSITIVO_NEGATIVO_RASTER, TAMPÓN, TAMPÓN_T, TRASLADA_RASTER.

Fecha de última modificación: lunes, 14 de Octubre de 2002


Orden EDITAR_ATR

La orden EDITAR_ATR permite la modificación o eliminación de los atributos pertenecientes a una entidad. Al ejecutar esta orden el programa solizitará que se seleccione la entidad con los atributos a editar. Una vez seleccionada este elemento, aparecerá el siguiente cuandro de dialogo en el cual se pueden realizar los cambios:

Una vez introducidos los nuevoas datos se acepta y al visualizar los atributos con la orden VER_ATRIBUTOS, veríamos el resultado de la edición.

Órdenes relacionadas: ALTA, BASE_DATOS, BORRA_ATR, CLONAR_ATRIBUTOS, PONER_ATR, VER_ATRIBUTOS, QUITAR_ATRIBUTOS.

Fecha de última modificación: 28 de Julio de 2004


Orden INS_OLE

Sirve para insertar objetos OLE dentro de un archivo Digi, como por ejemplo un documento de Microsoft Word.

Al ejecutar la orden, aparecerá una ventana de la cual se podrá seleccionar el archivo OLE que deseamos importar.

Una vez seleccionado el archivo, el programa pedirá el primer punto de inserción,

Y a continuación el segundo,

En caso de querer borrar el objecto insertado lo podríamos hacer con la orden BORRA_E

Fecha de última modificación: martes, 29 de Julio de 2003


Orden MARCAR_ATR

En caso de que existan entidades que tengan asignado más de un atributo podremos detectar estos errores con ayuda de la orden MARCAR_ATR. Dicha orden funciona de la siguiente manera, al ejecutarla aparece este cuadro de dialogo:

En dicho cuadro especificaremos la siguiente información:

  1. Tabla Se refiere al número de tabla al que pertenecen los atributos.
  2. Número de atributos Se refiere al número de atributos duplicados que se buscan.
  3. Archivo de salida Este es el archivo de referencia que se creará con los símbolos de error marcando las entidades que tengan el número especificado de atributos duplicados.
  4. Código de las entidades de error y Tamaño del error Se refiere al código usado para el símbolo de error y su tamñano en metros.
  5. Cargar el fichero de salida como fichero de referencia Aquí se da la opción de visualizar el archivo de errores en cuanto se refresque la pantalla, ya que este archivo se carga de referencia automáticamente.

Una vez rellenados los campos, podremos aceptar y ver el resultado.

Órdenes relacionadas: ALTA, BASE_DATOS, BORRA_ATR, CLONAR_ATRIBUTOS, EDITAR_ATR, PONER_ATR, QUITAR_ATRIBUTOS, VER_ATR.

Fecha de última modificación: viernes, 27 de Julio de 2004


Orden NUEVA_VENTANA

Permite crear una o varias ventanas con diferentes vistas que se mostrarán en el espacio de dibujo de DigiNG. Para ejecutar esta orden hace falta ir al menú principal de DigiNG/ Ventana/ Nueva Ventana.

Una vez pulsada esta opción, se crea automaticamente la nueva vista que aparecerá en un principio como maximizada. Para poder ver las ventanas actuales del proyecto tendremos que dar al boton de restaurar situado en la esquina superior derecha de la ventana principal.

Las ventanas creadas se pueden disponer en el espacio de dibujo de varias formas diferentes, las podemos colocar manualmente en la posición que deseemos o bien organizarlas según una cascada:

o bien como un mosaico, cubriendo todo el espacio de dibujo:

Todo esto se consigue con las opciones mostradas en el menú desplegable. Las diferentes ventanas pueden mostrar diferentes partes del dibujo todas ellas con el cursor en movimiento sincronizado y con la posibilidad de ejecutar diferentes Zooms en las diferentes vistas.

Órdenes relacionadas: GUARDA_DISPOSICION, CARGA_DISPOSICION.

Fecha de última modificación: viernes, 10 de Octubre de 2003


Orden ORDENA_POR_DIGI_TAB

Esta orden sirve para reordenar las entidades de un archivo según el orden en el archivo digi.tab.

En caso de querer invertir el orden de las entidades, habría que dar como parámetro un -1.

Órdenes relacionadas: DIGI.TAB.

Fecha de última modificación: jueves, 24 de Julio de 2003


Orden PONER_ATR_R

Esta orden sirve para poner atributos por recinto calculando topologías en tiempo real.

También existe la posibilidad de deseleccionar recintos sin finalizar la orden, pulsando el botón derecho del ratón.

Órdenes relacionadas: PONER_ATR.

Fecha de última modificación: miércoles, 18 de Agosto de 2003


Orden TRANSFORMA

Esta orden sirve para realizar transformaciones en el archivo de dibujo:

Al ejecutar la orden aparecerá el siguiente cuadro

en el cuál se podrá elegir entre las diferentes opciones:

Las transformaciones se definen mediante las coordenadas de una serie de puntos en dos sistemas de coordenadas: sistema original y sistema destino o transformado. Las transformaciones pueden incluir un giro, una translación, un factor de escala o tensor 3x3.

Para ejecutar cualquiera de dichas transformaciones hay que haber creado previamente un fichero de texto con los datos de entrada necesarios para la transformación, se indicarán las coordenadas origen y destino de al menos dos puntos.

En cada línea del fichero , y justificado arriba a la izquierda, se indicarán las coordenadas de la posición origen y las coordenadas de la posición destino de un punto conocido. Estos cuatro valores se separan mediante comas o espacios en blanco. Es decir, la estructura de este fichero es la siguiente:

X del punto 1 original, Y del punto 1 original, X del punto 1 destino, Y del punto 1 destino
X del punto 2 original, Y del punto 2 original, X del punto 2 destino, Y del punto 2 destino
.......

Si la transformación es en tres dimensiones, la estructura sería:

X p1 original, Y p1 original, Z p1 original, X p1 destino, Y p1 destino, Z p1 destino
X p2 original, Y p2 original, Z p2 original, X p2 destino, Y p2 destino, Z p2 destino, Z p2 destino
.......

Una vez creado el fichero se podrá ejectutar la orden TRANSFORMA.

Para cada caso de transformación los ficheros de texto tendrán unas características específicas:

  • Transformación de Helmert: Fichero ASCii con coordenadas Xi Yi XI YI de al menos dos puntos.
  • Transformación Afín: Fichero ASCII igual que el anterior pero el número mínimo de puntos es cuatro.
  • Transformación Tridimensional Conforme: Fichero ASCII con coordenadas Xi Yi Zi XI YI ZI de al menos tres puntos.
  • Traslación: Fichero ASCII con coordenadas Xi Yi Zi XI YI ZZI de un solo punto.
  • Cambio de Huso: Fichero ASCII con el huso actual y el huso nuevo.
  • Escala de dibujo: Fichero ASCII con el factorX factorY factorZ.
  • Tensor 3x3: Fichero ASCII con matriz de tres por tres:

    a00 a01 a02
    a10 a11 a12
    a20 a21 a22

Si el usuario quisiera hacer sólo una traslación de la coordenada Y con un desplazamiento negativo de -4000000, en el proceso de transformaciónn se especificaría en un fichero ASCII con los valores siguientes:

0 0 0 -4000000
que son primero las coordenadas X e Y originales y a continuación X e Y destino. Los valores indicados en el ejemplo cambiarían en funcion de la transformación que se necesite en cada caso: giro, cambio de escala...

Para ejecutar la orden hay que especificar el fichero de texto que contiene los datos de entrada:

Una vez completado el cuadro y pulsando sobre el botón Comenzar el DigiNG transforma todos los elementos del fichero original en el fichero de salida. El fichero original no se modifica.

Fecha de última modificación: 21 de Septiembre, 2004


Orden ZOOM_ENTIDAD

Con la orden ZOOM_ENTIDAD podremos ejecutar un zoom en la entidad que nosotros seleccionemos. Esto proporciona una mayor velocidad al restituir y al editar.

Órdenes relacionadas: ZOOME, ZOOMA, ZOOMDER, ZOOMIN, ZOOMINF, ZOOMIZQ, ZOOMOUT, ZOOMSUP, ZOOMV.

Fecha de última modificación: 25 de Mayo de 2004


Cómo crear un fichero de cámara

El archivo de cámara tiene una gran importancia dentro de Digi3D, pues en él se definen, además de datos relativos a la Orientación Interna, elementos correspondientes a otros importantes pasos fotogramétricos dentro de Digi3D. Tenemos entonces tres grupos de información dentro de este archivo:

  • Datos del certificado de calibración de la cámara.
  • Coordenadas para Orientación Relativa.
  • Coordenadas para Aerotriangulación.
  • Distrorsión radial de la cámara.

El archivo de cámara es un archivo de texto que se puede crear o modificar con un editor de textos. Si lo prefieres, puedes crearlo o modificarlo mediante Digi3D.

Si quieres conocer el formato del archivo de cámara pulsa aquí.

Si quieres pasar al tema de la ayuda Orientaciones en Digi3D pulsa aquí.

Fecha de última modificación: 20 de Abril de 2004


Distorsión radial de la cámara

En el fichero de cámara existe la posibilidad de introducir la distorsión radial que también se encuentra especificada en el Certificado de Calibración.

Antes de introducir este dato en el fichero se debe comprobar el tamaño del pixel de la foto, es decir la resolución y fijarse en los valores medios de la distorsión de la cámara.

Hoy en día las cámaras aéreas presentan mucha menos distorsión radial y los valores medios de los errores encontrados no suelen superar el tamaño del pixel en la imagen. Por esta razón se pueden obviar estos datos de distorsión radial en el fichero de cámara.

En caso de tener que añadir los valores de distorsión, se introducirían de la forma Radio Distorsión. Hay que tener especial cuidado con las unidades:

    Distorsion1=0  0.000
Distorsion2=10 0.001
Distorsion3=20 0.000
Distorsion4=30 0.000
Distorsion5=40 0.001
Distorsion6=50 0.002
Distorsion7=60 0.003
Distorsion8=70 0.003
Distorsion9=80 0.003
Distorsion10=90 0.002
Distorsion11=100 0.001
Distorsion12=110 -0.001
Distorsion13=120 -0.002
Distorsion14=130 -0.003
Distorsion15=140 -0.003
Distorsion16=150 0.001

Fecha de última modificación: 20 de Abril de 2004


Cómo crear un fichero de cámara mediante un editor de textos

Cuando se abre un fichero de cámara con un editor de texto, por ejemplo el bloc de notas se puede ver lo siguiente:

    [Camara]
PosicionPanel=0
Focal=305.363
PuntoPrincipal= 0.000 0.011
Fiducial1=113.012 0.019
Fiducial2=-112.997 0.020
Fiducial3=0.001 0.002
Fiducial4=0.002 -112.988
Fiducial5=112.999 113.014
Fiducial6=-112.994 -112.981
Fiducial7=-113.000 113.017
Fiducial8=113.000 -112.987
PRel1=0 0
PRel2=90 0
PRel3=90 90
PRel4=0 90
PRel5=0 -90
PRel6=90 -90
PRel7=45 0
PRel8=45 50
PRel9=45 -50
PAero1=1 0.0 0.0
PAero2=2 0.0 90.0
PAero3=3 0.0 -90.0
Distorsion1=0  0.000
Distorsion2=10 0.001
Distorsion3=20 0.000
Distorsion4=30 0.000
Distorsion5=40 0.001
Distorsion6=50 0.002
Distorsion7=60 0.003
Distorsion8=70 0.003
Distorsion9=80 0.003
Distorsion10=90 0.002
Distorsion11=100 0.001
Distorsion12=110 -0.001
Distorsion13=120 -0.002
Distorsion14=130 -0.003
Distorsion15=140 -0.003
Distorsion16=150 0.001

Como se puede apreciar, el archivo de cámara se compone de diferentes partes correspondientes al certificado de calibración, a los puntos de Orientación Relativa y Aerotriangulación y finalmente a la distrorsión radial de la cámara.

Para ver el video explicativo y aprender a crear un fichero de cámara con el editor de texto, pulsa aquí.

Fecha de última modificación: lunes, 22 de Abril de 2002


Desinstalación de Digi3D para actualizaciones

Para la actualización sólo es necesario desinstalar Digi3D, salvo que en la página web se indique expresamente que haya que desinstalar también Archivos Comunes.

Digi3D se desinstala mediante Agregar o quitar programas del Panel de Control de Windows.

Una vez desinstalado se puede proceder a la actualización.

En caso de que se desée hacer una desinstalación completa de Digi3D del equipo, hay que desinstalar el programa por el Panel de Control y a continuación hay que borrar las referencias a Digi3D desde el registro de Windows.

Para ello se arranca Regedit desde Ejecutar del menú Inicio. Se busca en HKEY_CURRENT_USER la carpeta correspondiente a Digi3D, se selecciona y se elimina. También se debe eliminar la carpeta Digi3D correspondiente a HKEY_LOCAL_MACHINE. Hay que tener especial cuidado en esta operación para borrar solamente estas carpetas.

Para ver el video explicativo pulsa aquí.

Ahora está completamente desinstalado el programa.

Se recomienda efectuar los pasos en el orden en que se explican.

Fecha de última modificación: 20 de Abril de 2004


Cuadro de diálogo Nuevo Proyecto

Este cuadro de diálogo es el cuadro de diálogo principal del restituidor digital Digi3D. En él indicamos al restituidor digital todos los datos necesarios para visualizar y trabajar con un par estereoscópico o con una imagen.

Este cuadro aparece cada vez que se ejecuta el restituidor digital (siempre y cuando no se haya activado el cuadro de chequeo con el título "No mostrar este cuadro de diálogo en el futuro") y cuando pulsamos sobre el menú Archivo/Nuevo o bien la combinación de teclas Ctrl + N.

El cuadro de diálogo se divide en cuatro partes principales:

  • Estereoscópico: donde podemos rellenar la información necesaria para crear un nuevo par estereoscópico.
  • Monoscópico: donde podemos rellenar la información necesaria para trabajar con una foto.
  • Digi: donde podemos abrir DigiNG.
  • Recientes: donde podemos recuperar con un simple click de ratón un modelo creado con anterioridad.

Siguiente

Fecha de última modificación: lunes, 6 de Mayo de 2002


Ejecutar Digi3D

Una vez instalado Digi3D, hay 3 formas de ejecutarlo:

  1. Desde el menú Inicio
  2. Haciendo doble click sobre el acceso directo en el Escritorio de Windows
  3. Haciendo un único click sobre el icono en la Barra de Windows:

Haz click aquí para ver el video

La primera vez que se ejecuta la aplicación aparece la siguiente ventana:

de Sugerencias del día. En esta ventana tenemos las siguientes opciones:

  • Activar/desactivar Mostrar sugerencias al empezar. Lo podemos dejar activo para leer las sugerencias al iniciar el programa, o lo podemos desactivar para que no nos aparezca al iniciar Digi3D.
  • Pulsar el botón Siguiente Sugerencia para seguir informándonos sobre Digi3D.
  • Cerrar la ventana y empezar a utilizar Digi3D. Para ello pulsamos bien sobre el botón Cerrar, o bien sobre la cruz en forma de aspa que se encuentra en la esquina superior derecha de la ventana.

Una vez que hayamos cerrado esta ventana, pasaremos a la ventana principal de Digi3D.

Siguiente

Fecha de última modificación: lunes, 6 de Mayo de 2002


Creación de un archivo de puntos

Al igual que el fichero de cámara, el archivo de puntos se puede crear o modificar con un editor de textos, como puede ser el bloc de notas.

Se trata de un archivo ASCII con varias líneas cada una de las cuales indica el número de punto y las Coordenadas Terreno de éste. Se puede añadir un comentario detrás de la Coordenada Z.

Se admiten como separadores de campo el espacio, tabulador, comillas y coma.

El identificador de un punto tiene que ser numérico.

También es importante pulsar la técla Enter o Return después de la última línea escrita para que el programa reconozca éste punto.

Ejemplos válidos de puntos en un archivo de puntos:

1255 432257.32 4655200.46  127.66
1256 432257.32 4655200.46  127.66    "Arqueta, cota suelo"
1257,432257.32,4655200.46 "127.66"  Arqueta, cota suelo

Para ver el video explicativo correspondiente a este tema de ayuda, pulsa aquí.

Fecha de última modificación: 20 de abril de 2004


Introducción de órdenes mediante el Menú Digital

La forma más intuitiva de ejecutar las órdenes en Digi3D es la de usar el menú Digital. Dicho menú está compuesto por cuatro apartados: Archivo, Digital, Herramientas y Ayuda.

Haz click aquí para ver el video explicativo correspondiente.

Fecha de última modificación: lunes, 19 de Abril, 2004


Asignación de órdenes a teclas

En el restituidor digital Digi3D se pueden asignar las órdenes a las teclas del ordenador:

  • Cada usuario puede asignar las ordenes que desée a las teclas mediante la orden TECLA
  • A continuación también podrás ver cuales son las teclas instaladas por defecto en la primera instalación de Digi3D

Fecha de última modificación: 14 de Abril, 2004


Introducción de órdenes mediante la Ventana de Comandos

Una vez que el operador se haya familiarizado con los nombres de las órdenes de Digi3D, una manera rápida de ejecutarlas es usando la Ventana de Comandos.

Esta ventana aparecerá en cuanto el usuario pulse la tecla Enter.

Usando la ventana de comandos, se pueden introducir manualmente el nombre de la orden y sus correspondientes parámentros. Una vez introducidos estos datos, se pulsa nuevamente la tecla Enter para ejecutar la orden.

Para ver el video explicativo correspondiente, pulsa aquí.

Fecha de última modificación: lunes, 19 de Abril, 2004


Movimiento de las imágenes

Para manejar las imágenes que vemos en el monitor de visualización estereoscópica tenemos las siguientes opciones:

Mover las imágenes: dependerá del equipo que tengas en el restituidor digital Digi3D.
  • Si tienes manivelas, moverás las imágenes con ellas.
  • Si quieres también puedes hacerlo con el ratón de tu ordenador. Si tu equipo está formado por un ratón, moverás las fotografías con él.

Fecha de última modificación: 20 de Abril de 2004


Ejecución de un zoom 1x1

Muestra las imágenes que se visualizan en la pantalla estereoscópica con un factor de 1x.

Órdenes relacionadas:

REST_ZOOMIN | REST_ZOOMOUT | REST_ZOOME

Siguiente

Fecha de última modificación: martes, 30 de julio de 2002


Ejecución de un zoom extendido

La ejecución de un zoom extendido se puede hacer de varias formas o bién por menú, dando la orden REST_ZOOME o dando a la técla que tenga configurada dicha orden.

La orden REST_ZOOME hace un Zoom extendido de las imágenes que se visualizan en la pantalla estereoscópica.

Si ejecutamos la orden una vez, calcula el zoom extendido para centrar el índice en la foto izquierda, y si ejecutamos la misma orden una segunda vez calcula el zoom extendido para centrar el índice en la foto derecha.

Haz click aquí para ver el video explicativo correspondiente

Órdenes relacionadas:

REST_ZOOMIN | REST_ZOOMOUT | REST_ZOOM1X1

Siguiente

Fecha de última modificación: martes, 30 de julio de 2002


Asignación de órdenes a teclas mediante la orden TECLA

La orden TECLA sirve para asignar órdenes de DigiNG a pulsaciones de teclas. Esta orden permite la creación o modificación del fichero de asignación de teclas TECLAS.MNU, sin tener que editarlo como fichero de texto.

No se puede asignar más de una orden a una tecla, pero es posible agrupar varias en un fichero de macro instrucciones (un arroba) y asignar este fichero a una tecla.

Para aceptar la asignación se pulsa la tecla Enter, el programa seguirá pidiendo asignaciones hasta que se finalice la orden TECLA pulsando Esc.

Nota: No se pueden realizar asignaciones a las teclas Enter, Esc, Bloq Mayús, Impr Pant, etc. Sin embargo, es posible utilizar una combinación de varias teclas para realizar la asignación, por ejemplo Ctrl+a, Mayús+F3.

Para ver el video explicativo correspondiente pulse aquí.

Fecha de última modificación: miércoles, 19 de Junio de 2002


Salir del modo gráfico

Cuando estamos viendo imágenes en el monitor de visualización estereoscópica, estamos en el llamado modo gráfico. Por varios motivos, se debe salir de este modo con el restituidor digital Digi3D:

  • Cuando vayamos a cambiar de aplicación
  • Cuando vayamos a ejecutar alguna herramienta (del menú de herramientas de Digi3D) que cargue en memoria archivos raster (como por ejemplo la herramienta de Orientaciones Internas Automáticas u Orientaciones Relativas Automáticas).

La orden para salir del modo gráfico es SALIR_DIGI3D, que en el teclado por defecto (TDigital.mnu) está asignada a las teclas Ctrl+Fin:

    Tecla | Orden | Descripción
Ctrl+Fin | SALIR_DIGI3D | Sale del modo gráfico y muestra la carátula principal del restituidor.

A través del cuadro de diálogo Nuevo Proyecto se entra en el modo gráfico, es decir, visualizando las imágenes otra vez. Cada entrada/salida del modo gráfico no significa carga/descarga en de las imágenes, lo que implicaría esperar a que se carguen las imágenes en memoria en cada entrada al modo gráfico. Solamente se cargan en memoria las imágenes la primera vez que se entre en el modo gráfico, y ya no se descargan hasta que se salga de Digi3D.

Haz click aquí para ver el video explicativo correspondiente

Fecha de última modificación: martes, 15 de Octubre de 2002


Control del restituidor

Al instalar el módulo TeclasMnu de Digi3D, se instalan una serie de asignaciones de órdenes al teclado de Digi3D.

La asignación de teclas por defecto es la siguiente:

    Tecla | Orden | Descripción
Ctrl+Fin | SALIR_DIGI3D | Sale del modo gráfico y muestra la carátula principal del restituidor.
AvPág | REST_ZOOMIN | Zoom de acercar.
RePág | REST_ZOOMOUT | Zoom de alejar.
F3 | REST_ZOOME | Zoom extensión.
F4 | REST_ZOOM1X1 | Zoom a escala 1:1.
+ (del teclado numérico) | VELOCIDAD_MAS_XY | Aumenta la velocidad de las manivelas en XY.
- (del teclado numérico) | VELOCIDAD_MENOS_XY | Disminuye la velocidad de las manivelas en XY.
* (del teclado numérico) | VELOCIDAD_MAS_Z | Aumenta la velocidad de las manivelas en Z.
/ (del teclado numérico) | VELOCIDAD_MENOS_Z | Disminuye la velocidad de las manivelas en Z.
F2 | TIPO_INDICE | Cambia el tipo de índice.
B | CORRELAR | Posa en Z fijando la imagen izquierda
Tab | CAMBIA_TECLAS_MNU | Cambia la asignación de teclas actual
Control+P | IR_A_PUNTO_APOYO | Mueve el restituidor a un punto de apoyo del archivo de puntos.
R | RATON_DIGI3D | Activa/Desactiva el movimiento del restituidor con un ratón.

El archivo de teclas que se instala por defecto recibe el nombre de TDigital.mnu.

Si quieres ver todas las órdenes del restituidor Digi3D lee el tema de la ayuda Listado de Órdenes de Digi3D.

Fecha de última modificación: 19 de Abril, 2004


Primeros Pasos con Digi3D

Esta guía constituye una introducción a Digi3D. El tutorial de la misma le guiará por el proceso de toma de contacto con el Interfaz de Digi3D:

  • Cómo ejecutar Digi3D versión 2003 una vez instalado.
  • Cómo abrir un Nuevo Proyecto Estereoscópico.
  • Cómo ejecutar un Zoom extendido.
  • Cómo ejecutar un Zoom 1X1.
  • Cómo mover las imágenes.
  • Cómo salir del modo Gráfico.

Fecha de última modificación: jueves, 1 de Abril de 2004


Requisitos para abrir y trabajar con un modelo estereoscópico

Para poder abrir un modelo estereoscópico y trabajar con el hace falta cumplir una serie de requisitos. Al entrar en el modelo el programa pedirá el archivo de cámara y el archivo de puntos de apoyo en caso de que exista.

Para aprender más sobre dichos archivos y sobre como cargar un modelo estereoscópico, selecciona el tema de ayuda de la siguiente lista.

  • Creación de un archivo de cámara.
  • Creación de un archivo de puntos.
  • Cargar un modelo estereoscópico.

Fecha de última modificación: jueves, 1 de Abril de 2004


Requisistos del Sistema

Digi3D

Requisitos del Sistema

A continuación se indican el hardware y software necesarios para ejecutar Digi3D y DigiNG.

Para instalar Digi3D se recomienda tener la siguiente configuración del equipo:

  • Ordenador Pentium IV, 2.4 Gz, 1.5 Gb de RAM, HD. 80 Gb 7200RPM
  • Tarjeta gráfica Matrox Millenium G550 dual
  • Monitor CRT de 21"
  • Monitor secundario TFT 15"
  • Sistema Operativo Windows 2000 o superior
  • Sistema de manivelas o ratón 3D
  • Sistema de Visualización Estereoscópica

Siguiente

Fecha de última modificación: 22 de marzo, 2004


Cómo crear símbolos

Fecha de última modificación: lunes, 29 de Abril de 2002